Subject: Notification: incoming/1350

From: [email-masked]
Date: Thu, 15 Jul 2004 08:39:48 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/1350

Message summary for PR#1350
	From: [email-masked]
	Subject: starting up some X apps crashes X under fvwm
	Date: Thu, 15 Jul 2004 08:37:23 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Thu Jul 15 08:37:24 2004
Date: Thu, 15 Jul 2004 08:37:23 -0500
From: [email-masked]
To: [email-masked]
Subject: starting up some X apps crashes X under fvwm

Full_Name: James Falkner
Version: 2.5.10
CVS_Date: 
OS: Solaris 10 build 63 (beta 6) - SPARC platform
X_Server: Xsun
Submission from: (NULL) (192.18.128.13)

When running under 2.5.10, if I start up gaim, xchat, or attempt to
display
a PNG icon using 2.5.10, all of X crashes.

I have no idea whether this is an fvwm bug or a bug in Sun's X server,
however this does not happen under twm, and it does not happen under
fvwm 2.4.18 (what I am currently using), so I suspect it might be fvwm.

This is on Solaris 10 build 63, which is due to be released in few weeks
on http://wwws.sun.com/software/solaris/solaris-express/index.html however
it also happens with the currently available "Software Express" version
of Solaris available from the same location  This is on the sparc
platform.
I have not tried it on the x86 platform.  I'm not entirely sure what I
need
to do to gather more detailed information, so if one could suggest
additional flags, or debugging methods for fvwm it would be much
appreciated.  It is easily reproducible 100% of the time.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 15 Jul 2004 18:35:52 +0200

> appreciated.  It is easily reproducible 100% of the time.

First strip down your .fvwm2rc as much as possible so that the
problem still happens and post that.  Second, look for a core
file and see if it was created by fvwm.  If so, fetch us a stack
trace (I can only describe what you have to do with gdb):

  $ gdb fvwm core
  (gdb) where

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]