Subject: Notification: incoming/1346

From: [email-masked]
Date: Sat, 10 Jul 2004 14:33:08 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/1346

Message summary for PR#1346
	From: [email-masked]
	Subject: Wait <windowname> with identical windownames failing
	Date: Sat, 10 Jul 2004 14:30:44 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Sat Jul 10 14:30:45 2004
Date: Sat, 10 Jul 2004 14:30:44 -0500
From: [email-masked]
To: [email-masked]
Subject: Wait <windowname> with identical windownames failing

Full_Name: Athanasius
Version: 2.5.10 (Debian 2.5.10-8)
CVS_Date: 
OS: Debian/testing
X_Server: 4.3.0.1 (Debian 4.3.0.dfsg.1-4 20040529113443
Submission from: (NULL) (81.6.228.236)

In my Initfunction I have some lines to switch to various Pages in
FvwmPager and start applications, using Wait to ensure windows have drawn
before moving to the next page so that windows end up on the correct
pages.

I used to (2.4.6) be able to use:

+       "I" GotoPage    0 1
+       "I" Exec exec color_xterm -fn 9x15 -geometry 141x24+0+120 -T
'games' -n 'games'
+       "I" Wait games
+       "I" Exec exec color_xterm -fn 9x15 -geometry 80x24+0-0 -T 'games'
-n 'games'
+       "I" Wait games

And things would work fine.  When I updated to Debian/testing and fvwm
2.5.10 this stopped working.  The second Wait would seem to not 'run' and
the Page would be changed (by following lines) before the window was drawn.
 Changing the above to:

+       "I" GotoPage    0 1
+       "I" Exec exec color_xterm -fn 9x15 -geometry 141x24+0+120 -T
'games' -n 'games'
+       "I" Wait games
+       "I" Exec exec color_xterm -fn 9x15 -geometry 80x24+0-0 -T 'games2'
-n 'games2'
+       "I" Wait games2

i.e. unique window names has made it work again.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 11 Jul 2004 18:04:07 +0200

> i.e. unique window names has made it work again.

Fixed in CVS.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]