Subject: Building FVWM in separate directories

From: Scott Smedley <[email-masked]>
Date: Fri, 2 Jul 2004 14:51:19 +1000

Is it possible to build FVWM in separate directories?
ie. a bit like how GCC is built.

I'd like to have a NFS-mounted directory with CVS source code
& then build it for several systems.

SCoTT. :)
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 2 Jul 2004 11:24:04 +0000

> & then build it for several systems.

Out of tree builds should work. If not, then it is a bug.

For example, this should work:

  cd /nfs/cvs/fvwm
  aclocal
  autoheader
  automake -a
  autoconf

  cd /build/mysystem
  /nfs/cvs/fvwm/configure [params]
  make
  make install

Just tried this on the fresh cvs checkout, works perfectly without
writing anything system dependent to the checkout directory.

Regards,
Mikhael.

---

From: Scott Smedley <[email-masked]>
Date: Tue, 6 Jul 2004 00:29:39 +1000

Hi Mikhael, :)

> writing anything system dependent to the checkout directory.

automake creates a bunch of system-dependent soft-links:

depcomp -> /usr/share/automake-1.7/depcomp*
install-sh -> /usr/share/automake-1.7/install-sh*
missing -> /usr/share/automake-1.7/missing*
mkinstalldirs -> /usr/share/automake-1.7/mkinstalldirs*

When I ./configure on another machine those links are broken.

SCoTT. :)

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 5 Jul 2004 15:34:12 +0000

> When I ./configure on another machine those links are broken.

If the file systems on these machines are not identical then run
"automake --add-missing --copy", not "automake -a".

Regards,
Mikhael.

---

From: Scott Smedley <[email-masked]>
Date: Tue, 6 Jul 2004 23:04:18 +1000

> "automake --add-missing --copy", not "automake -a".

This works perfectly - thanks Mikhael! :)

SCoTT. :)