Subject: Wrong behavior of WarpToWindow function: it reset viewport on multipage desk

From: [email-masked]
Date: Sat, 3 Jul 2004 08:46:49 +0700 (NOVST)

Configuration Information [Automatically generated, do not change]:
uname: Linux joemast 2.4.25-1-686 #1 Tue Feb 24 10:55:59 EST 2004 i686 GNU/Linux
compiler flags: i386-linux-gcc -g -O2 -Wall -Wno-implicit-int

FVWM Version:	2.5.10
FVWM_MODULEDIR:	/usr/lib/fvwm/2.5.10
FVWM_DATADIR:	/usr/share/fvwm
FVWM_USERDIR:	/home/rk/.fvwm

Description:
	WarpToWindow function after invoke resets viewport coordinates to 0x0 
	relative to page with operation window.

	Such behavior is not depend from FPFocusByFunctionWarpPointer option.

Repeat-By:
	1. Use a multipages desk (DesktopSize more than 1x1, for example 4x4)
	2. Scroll viewport (for example, by send Scroll 20 20 to fvwm)
	3. Send WarpToWindow 50 50 to fvwm - mouse pointer will jump to 50 50, but 
	   viewport will resets like GoToPage command.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 5 Jul 2004 14:27:27 +0200

> 	   viewport will resets like GoToPage command.

Not exactly.  This only happens if the center of the window is not
on the current page.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]