Subject: Notification: incoming/1342

From: [email-masked]
Date: Mon, 5 Jul 2004 03:25:26 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/1342

Message summary for PR#1342
	From: [email-masked]
	Subject: EdgeScroll 10 10 and eclipse
	Date: Sun, 4 Jul 2004 15:23:10 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Sun Jul 04 15:23:10 2004
Date: Sun, 4 Jul 2004 15:23:10 -0500
From: [email-masked]
To: [email-masked]
Subject: EdgeScroll 10 10 and eclipse

Full_Name: claudius
Version: 2.5.10
CVS_Date: -
OS: Linux 2.6.7-gentoo-r6
X_Server: 4.3.0-r5
Submission from: (NULL) (82.212.31.243)

from my globalfeel:
DeskTopSize 6x6

EdgeScroll 10 10

When I start eclipse and open any new window (Find, Help,...), as soon as
the new window appears fvwm scrolls to one Desktop.
E.g. if my screen shows the right part of desktop 2 and the left of desktop
3 then after the window opens my screen shows only desktop 2 (or only
desktop 3, depending on which "middle of desktop" is displayed).
This bug appears only on my laptop:
fvwm 2.5.10 compiled on Jun  8 2004 at 01:41:34
with support for: ReadLine, XPM, PNG, Shape, XShm, SM, XRender, XFT, NLS
not on my other computer:
FVWM version 2.4.8 compiled on Oct 14 2002 at 20:55:44
with support for: ReadLine, Stroke, XPM, GNOME WM hints, Shape, SM,
Multibyte, Xinerama

Eclipse (www.eclipse.org) is an IDE (mainly for developing Java programs).
Eclipse-Version: 3.0.0
Build id: 200406251208

It doesn't happen in other applications.
Please note that eclipse uses neighter Java-Swing nor SWT but AWT,
described on eclipse.org

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 5 Jul 2004 14:21:50 +0200

> the new window appears fvwm scrolls to one Desktop.

I think we call "Pages" what you call "Desktops".

> Please note that eclipse uses neighter Java-Swing nor SWT but AWT,

You probably have the "StartsOnPage ..." style somewhere in your
config.  WIth that, fvwm switches to the given page when a
matching window appears.  Remove that line or try

  Style <eclipse window class> SkipMapping

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]