Subject: Re: FVWM: HoverIcon for FvwmButtons (Was: animated FvwmButtons)

From: Scott Smedley <[email-masked]>
Date: Thu, 15 Jul 2004 01:27:07 +1000

> But the option "Pixmap none" don't work properly, ie it doesn't have
> a transparent background as expected.

Still TODO.

The way transparency is implemented with "Pixmap none" is a bit hacky (IMO),
especially when we're moving toward Colorsets. But I s'pose it should
be backwards-compatible ...

SCoTT. :)
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 15 Jul 2004 11:48:31 +0200

> be backwards-compatible ...

Be *very* carful here.  If the inactive pixmap changes, and the
new on has a different shape, the pointer may immediately leave
the FvwmButtons window.  The old pixmap would be drawn again, and
the pointer reenters the window ... (ad infinitum).

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]