Subject: CVS migo: * fvwm.1: always use commas between conditions

From: FVWM CVS <[email-masked]>
Date: Sun, 11 Jul 2004 21:11:39 -0500

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	migo	04/07/11 21:11:39

Modified files:
	fvwm           : fvwm.1.in 
	modules/FvwmProxy: FvwmProxy.1 
	.              : ChangeLog 

Log message:
* fvwm.1: always use commas between conditions
* FvwmProxy.1: minor reformatting to avoid long lines in examples

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Scott Smedley <[email-masked]>
Date: Mon, 12 Jul 2004 16:36:07 +1000

> * fvwm.1: always use commas between conditions

I checked this. It doesn't appear to be mandatory.

ie.

All ("xterm", Iconic) Echo w is $[w.name]
All ("xterm" Iconic) Echo w is $[w.name]

both of the above appear to give the same results.

Is that a bug?

SCoTT.

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 12 Jul 2004 11:19:59 +0000

> both of the above appear to give the same results.

The man page examples should use commas. Every comma is an AND operator.
A mere whitespace that sometimes delimit options and sometimes delimit
option parameters is confusing and harder for readability and parsing.

I suppose we can't make a comma mandatory now, because some users omit it
in their current configs, but I would encourage it in all documentation
and make it mandatory in the future.

Regards,
Mikhael.