Subject: Re: FVWM: How often is an edge command executed

From: Uwe Pross <[email-masked]>
Date: Sat, 5 Jun 2004 22:42:49 +0200

Hi there,

On 05 Jun 2004 at 14:07:03 +0100, Piotr Zielinski wrote:

> In my .fvwm2rc, I have a function bound to the edges of
> the screen with EdgeCommand (see below for the details). 
> The problem is that when the mouse pointer stays on the
> edge the function is being called again and again, which
> prevents fvwm from doing any useful work until the mouse
> pointer is moved away from the edge (for example the
> scheduled commands do not work).  Can anybody tell me
> when exactly the function bound to the edge is called,
> how can I control the frequency of it being called?  The
> only solution I can think of is removing the edge
> bindings for a second or so every time the edge function
> is called.

Actually the function is (or better should be)
executed/called when the pan frame gets an enter event. For
some reason this event is produced several times if a
complex function is bound to an edge. For example:

   EdgeCommand N Echo EdgeCommandNorth

works as expected while

   AddToFunc EchoFunc I Echo EdgeCommandNorthFunc
   EdgeCommand N EchoFunc

shows the behaviour you describe. This is actually a bug. I
hope we get this fixed soon.

Cheers, Uwe
-- 
  ,_,   For personal reply/mail put "fvwm"
 (O,O)  in the subject.
 (   )  Otherwise I won't receive your mail.
--"-"----------------------------------------
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Uwe Pross <[email-masked]>
Date: Sat, 5 Jun 2004 22:59:24 +0200

Hi there,

On 05 Jun 2004 at 22:42:49 +0200, Uwe Pross wrote:

> This is actually a bug. I hope we get this fixed soon.

I tried to have a look what's going on in edge command.

When trying to build the cvs tree I get the following errors: 

uwp@nelix:uwp/Quelltexte/fvwm/>utils/configure_dev.sh
+ aclocal
+ autoheader
autoheader: WARNING: Using auxiliary files such as acconfig.h', config.h.bot'
autoheader: WARNING: and config.h.top', to define templates for config.h.in'
autoheader: WARNING: is deprecated and discouraged.
autoheader: 
autoheader: WARNING: Using the third argument of AC_DEFINE' and
autoheader: WARNING: AC_DEFINE_UNQUOTED' allows to define a template without
autoheader: WARNING: acconfig.h':
autoheader: 
autoheader: WARNING:   AC_DEFINE([NEED_FUNC_MAIN], 1,
autoheader:             [Define if a function main' is needed.])
autoheader: 
autoheader: WARNING: More sophisticated templates can also be produced, see the
autoheader: WARNING: documentation.
+ automake --add-missing
Makefile.am:7: AM_GNU_GETTEXT in configure.in' but po' not in SUBDIRS
Makefile.am:7: AM_GNU_GETTEXT in configure.in' but intl' not in SUBDIRS
Makefile.am:782: po/fvwm.ar.po exists but fvwm.ar' not in ALL_LINGUAS'
Makefile.am:782: po/fvwm.de.po exists but fvwm.de' not in ALL_LINGUAS'
Makefile.am:782: po/fvwm.fr.po exists but fvwm.fr' not in ALL_LINGUAS'
Makefile.am:782: po/fvwm.sv_SE.po exists but fvwm.sv_SE' not in ALL_LINGUAS'
Makefile.am:782: po/fvwm.zh_CN.po exists but fvwm.zh_CN' not in ALL_LINGUAS'
Makefile.am:782: po/FvwmScript.ar.po exists but FvwmScript.ar' not in ALL_LINGUAS'
Makefile.am:782: po/FvwmScript.de.po exists but FvwmScript.de' not in ALL_LINGUAS'
Makefile.am:782: po/FvwmScript.fr.po exists but FvwmScript.fr' not in ALL_LINGUAS'
Makefile.am:782: po/FvwmScript.sv_SE.po exists but FvwmScript.sv_SE' not in ALL_LINGUAS'
Makefile.am:782: po/FvwmScript.zh_CN.po exists but FvwmScript.zh_CN' not in ALL_LINGUAS'
Makefile.am:782: po/FvwmTaskBar.ar.po exists but FvwmTaskBar.ar' not in ALL_LINGUAS'
Makefile.am:782: po/FvwmTaskBar.de.po exists but FvwmTaskBar.de' not in ALL_LINGUAS'
Makefile.am:782: po/FvwmTaskBar.fr.po exists but FvwmTaskBar.fr' not in ALL_LINGUAS'
Makefile.am:782: po/FvwmTaskBar.sv_SE.po exists but FvwmTaskBar.sv_SE' not in ALL_LINGUAS'
Makefile.am:782: po/FvwmTaskBar.zh_CN.po exists but FvwmTaskBar.zh_CN' not in ALL_LINGUAS'
Makefile.am:782: sv_SE in ALL_LINGUAS' but po/sv_SE.po does not exist
Makefile.am:782: fr in ALL_LINGUAS' but po/fr.po does not exist
Makefile.am:782: de in ALL_LINGUAS' but po/de.po does not exist
Makefile.am:782: zh_CN in ALL_LINGUAS' but po/zh_CN.po does not exist
Makefile.am:782: ar in ALL_LINGUAS' but po/ar.po does not exist
+ exit 3
uwp@nelix:uwp/Quelltexte/fvwm/>

Any hints where to look at? I use debian sarge which comes with 
"automake (GNU automake) 1.4-p6". It sayed before that it misses 
./ABOUT-NLS as well so I copied it from
/usr/share/gettext/ABOUT-NLS hoping that the other errors 
disappear as well. But they remained :-(.

Cheers, Uwe