Subject: Notification: incoming/1334

From: [email-masked]
Date: Mon, 28 Jun 2004 11:55:16 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/1334

Message summary for PR#1334
	From: [email-masked]
	Subject: keyboard focus is nowhere
	Date: Mon, 28 Jun 2004 11:52:53 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Mon Jun 28 11:52:54 2004
Date: Mon, 28 Jun 2004 11:52:53 -0500
From: [email-masked]
To: [email-masked]
Subject: keyboard focus is nowhere

Full_Name: Brent
Version: 2.4.16
CVS_Date: 
OS: 
X_Server: XFree86  4.3.0
Submission from: (NULL) (209.30.201.134)

Sometimes the active window does not get the keyboard focus.  Happens with
Mozilla 1.4 (20030915).  Clicking on the title bar, in the window, or in
text entry boxes in the window does not move keyboard focus to the window. 
There was only one window, the title bar was the active window color, a
cursor was present in one of the text entry boxes, but keystrokes did
nothing.  Alt-tab did nothing.  The only way I found to get keyboard focus
to the window was to right click on the background to bring up the list of
windows (which had only one window in it) and select that window.  Mouse
clicks (like, on links) work.

I have fvwm2 set up with no pager and no task bar, just the mini buttons
(ps shows fvwm2 and FvwmButtons in list).  I am using Slackware 9.1, which
came with those versions of Mozilla and X.

Haven't figured out how to reproduce this problem reliably.  Has happened
several times.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 29 Jun 2004 01:51:46 +0200

> Haven't figured out how to reproduce this problem reliably.  Has happened

I'm already aware of this problem which appeared with mozilla-1.4
and still occurs with mozilla-1.7.  All I found out yet is that it
happens more frequently if you have web sites with input fields.
Although I suspect it's a mozilla bug, I'd like to see what
happens in detail with a debugger attached to fvwm.  But I never
could make it happen on demand.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]