Subject: Notification: incoming/1294

From: [email-masked]
Date: Tue, 1 Jun 2004 16:20:55 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/1294

Message summary for PR#1294
	From: [email-masked]
	Subject: Mouse Move stopped working
	Date: Tue, 1 Jun 2004 16:18:35 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Tue Jun 01 16:18:38 2004
Date: Tue, 1 Jun 2004 16:18:35 -0500
From: [email-masked]
To: [email-masked]
Subject: Mouse Move stopped working

Full_Name: Yedidyah Bar-David
Version: 2.5.7
CVS_Date: 
OS: Debian sid
X_Server: XFree86 4.3
Submission from: (NULL) (132.66.16.34)

I have the following line in my .fvwm2rc:
Mouse 2         A       CS      Move
(Also other such things, for other combinations and actions, behave the
same).
It should move a window when pressing Ctrl-Shift-Button2 anywhere on it.
It works well with 2.4.18, 2.5.[56] (probably earlier too), and stopped
working in 2.5.7 (checked 2.5.{7,8,9,10}). Stopped working means:
In those working, I press Ctrl-Shift-Button2, move the mouse, the window
moves, then I release the mouse, and things go back to normal.
In those not working, I press Ctrl-Shift-Button2, move the mouse, nothing
happens. When I release Button2, moving the mouse moves the window, until
I press and release Button1 (or other things, e.g. Return, Space).
I guess the bug is in the file fvwm/binding.c, but the change between
2.5.6
and 2.5.7 is too big for me to understand without speding a lot of time.
I might be wrong, of course. From skimming the diff, it seems reasonable.
I will probably try to debug it myself eventually, but will appreciate it
if someone (maybe the one that did it, around a year ago) already knows
how
to fix this.
Thanks,
-- 
Didi

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Shawn Anderson <[email-masked]>
Date: Sat, 5 Jun 2004 12:22:12 -0600

On Tue, Jun 01, 2004 at 04:20:55PM -0500, [email-masked] wrote:
> I press Ctrl-Shift-Button2, move the mouse, nothing happens. When I 
> release Button2, moving the mouse moves the window

try:

Mouse 2 A   CS FuncFvwmRaiseLowerX move

for a explaination, see http://www.hpc.uh.edu/fvwm/archive/0303/msg00354.html

cya,
sa

---

From: Yedidyah Bar-David <[email-masked]>
Date: Sat, 5 Jun 2004 23:22:51 +0300

> for a explaination, see http://www.hpc.uh.edu/fvwm/archive/0303/msg00354.html

Thanks a lot! It does work.
I suggest to try and write a script for 2.4 users to help them move.
Those who only want to have the old config working will simply run it,
those that want to know what changed might find it easier to diff their
file and the output than looking through the changelog. I am not sure
how much work this is - maybe I am writing nonsense, but at least for
this thing I saw in the link you wrote that it was already written.
Anyway, thanks for a quick and helpful answer.
-- 
Didi