Subject: Is this a bug?

From: [email-masked]
Date: Mon, 14 Jun 2004 19:46:43 +0800

Hi all,

I define the following key binding:
Mouse (Totem) 1 W A MaximizeFullScreen2

AddToFunc   MaximizeFullScreen
 + I ThisWindow (Maximized) WindowStyle Title, Borders
 + I TestRc (NoMatch) WindowStyle NoTitle, !Borders
 + I TestRc (NoMatch) Raise
 + I TestRc (NoMatch) UpdateStyles
 + I Maximize ewmhiwa
AddToFunc MaximizeFullScreen2 D MaximizeFullScreen

Then, Double-Click Mouse1 will maximmize totem.
But all other key bindings (using mouse1) set by totem
are disabled. I can't even use mouse1 to pull down menu.

I suspect this a bug.

Regards,
Liu Shidai

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 14 Jun 2004 16:44:27 +0200

> are disabled. I can't even use mouse1 to pull down menu.

No, it's no bug.  You told fvwm to handle any button 1 click with
the MaximizeFullScreen2 function, and so it does.  A click that is
eaten by a function is never passed to the application, not even
if the function does nothing with the click.

What you are trying to achive isn't possible with fvwm.  Think
about it:  once fvwm knows whether you made a single or double
click it's already too late to pass the click to the application.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]