Subject: Notification: incoming/1335

From: [email-masked]
Date: Tue, 29 Jun 2004 12:53:27 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/1335

Message summary for PR#1335
	From: [email-masked]
	Subject: FakeClick generates EnterNotify event
	Date: Tue, 29 Jun 2004 12:51:06 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Tue Jun 29 12:51:06 2004
Date: Tue, 29 Jun 2004 12:51:06 -0500
From: [email-masked]
To: [email-masked]
Subject: FakeClick generates EnterNotify event

Full_Name: Piotr Zielinski
Version: 2.5.10
CVS_Date: 
OS: Red Hat Linux 9
X_Server: 4.3.0
Submission from: (NULL) (128.232.8.138)

I use FakeClick to intercept clicks in some windows, and pass the click to
the others, for example

AddToFunc HandleClick
+ I PointerWindow (FvwmPager) DoSomethingSpecial
+ I PointerWindow (!FvwmPager) FakeClick depth 0 press 1

This sometimes doesn't work.  For example, in xdvi should react to such a
click by displaying a window containing a magnified version of some part of
the document as long as the button it pressed.  It does not.  Using xev I
discovered that FakeClick produces an additional EnterNotify event just
after the button has been pressed.  Is this a bug?

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 30 Jun 2004 03:19:09 +0200

On Tue, Jun 29, 2004 at 12:53:27PM -0500, fvwm-bug wrote:
> the document as long as the button it pressed.  It does not.

Please carefully read the description of the FakeClick command in
the man page.  A binding like yours can not work reliably with all
applications.  Windows need to be clicked at various "depth"
values, and it's impossible to know without trying.  In case of
xdvi the problem is that is does not react to the button press but
to the button release.  You can try

  + I PointerWindow (!FvwmPager) FakeClick depth 0 press 1 release 1

or shorter

  + I PointerWindow (!FvwmPager) FakeClick d 0 p 1 r 1

>  Using xev I
> after the button has been pressed.
>
> Is this a bug?

No.  EnterNotify and LeaveNotify events are generated by the X
server automatically when a button is pressed or released.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Scott Smedley <[email-masked]>
Date: Wed, 30 Jun 2004 12:42:20 +1000

Hmmm, I thought specifying [email-masked] in the notification
list (of the fvwm-bug website) would ensure this note got sent to the
list - obviously not:

> use FakeClick to intercept clicks in
> some windows, and pass the click to
> the others ...

The correct way to do this now is with a window-specific binding. ie.

Mouse (rxvt) 1 A N Echo "mouse1-in-rxvt"
Mouse (xterm) 1 A N Echo "mouse1-in-xterm"

Note that this feature is currently in CVS & will be available in
2.5.11.

> xdvi should react to such a click

I can't reproduce your problem. It worked fine for me with:

sleep 2 && FvwmCommand 'FakeClick depth 0 press 1'

The sleep is so I have time to move the mouse cursor to the xdvi window.

SCoTT. :)

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 30 Jun 2004 09:58:24 +0000

> list (of the fvwm-bug website) would ensure this note got sent to the

This probably awaited the moderation.

Regards,
Mikhael.