Subject: Notification: incoming/1328

From: [email-masked]
Date: Thu, 24 Jun 2004 08:33:34 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/1328

Message summary for PR#1328
	From: [email-masked]
	Subject: Problem Installing  fvwm-themes-0.7.0-2
	Date: Thu, 24 Jun 2004 08:31:14 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Thu Jun 24 08:31:14 2004
Date: Thu, 24 Jun 2004 08:31:14 -0500
From: [email-masked]
To: [email-masked]
Subject: Problem Installing  fvwm-themes-0.7.0-2

Full_Name: Jon Turenne
Version: fvwm 2.5.10
CVS_Date: 
OS: Linux 2.4.21-4.EL
X_Server: 
Submission from: (NULL) (192.11.223.120)

When I try to install the themes PKG, I get a dependency error, saying that
I need to have >= 2.5.8.   Since I am running 2.5.10, I should be fine.  I
have also tried this with FVWM 2.5.8, and got the same results.

>>pats:~> fvwm -version
>>fvwm 2.5.10 compiled on Jun 24 2004 at 08:42:13
>>with support for: ReadLine, Stroke, XPM, PNG, Shape, XShm, SM, Xinerama,
>>XRender, XFT, NLS

>>fvwm comes with NO WARRANTY, to the extent permitted by law. You may
>>redistribute copies of fvwm under the terms of the GNU General Public
License.
>>For more information about these matters, see the file named COPYING.
>>pats:~> sudo rpm -i fvwm-themes-0.7.0-2.noarch.rpm
>>Password:
>>error: Failed dependencies:
>>        fvwm >= 2.5.8 is needed by fvwm-themes-0.7.0-2

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 24 Jun 2004 17:24:24 +0200

> FVWM Bug Tracking notification

Questions about using fvwm are best asked on the mailing lists
[email-masked] or [email-masked].

> have also tried this with FVWM 2.5.8, and got the same results.

Either your fvwm-2.5.10 is not properly installed (fvwm-config is
not in the PATH) or an older fvwm version is installed too and its
fvwm-config is before the new one in the PATH.  Check your PATH
setting carefully.  If that does not fix the problem, try
deinstalling all fvwm's on the system and reinstall only 2.5.10.

> >>        fvwm >= 2.5.8 is needed by fvwm-themes-0.7.0-2

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 25 Jun 2004 14:39:18 +0000

> >>fvwm 2.5.10 compiled on Jun 24 2004 at 08:42:13

Compiled by hand.

> >>        fvwm >= 2.5.8 is needed by fvwm-themes-0.7.0-2

This is a general rpm dependency problem that has nothing special to do
with fvwm and fvwm-themes.

Like the error says, you should install fvwm rpm before installing
fvwm-themes rpm. Both rpms are available in the same place. If you prefer
to install fvwm from sources, then install fvwm-themes from sources too.

Think about it. You installed fvwm into the /usr/local or some other
prefix, but this rpm uses the /usr prefix, it simply can't work together
with your manual installation and thus the dependancy error is good.

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 25 Jun 2004 15:10:29 +0000

I bounced the answer to Jon and closed the bug together with other 60
"bugs" (mostly SPAM).

Regards,
Mikhael.

---

From: Jonathan Turenne <[email-masked]>
Date: Mon, 28 Jun 2004 08:35:04 -0400 (EDT)

Yes!  Everything installs properly this way.  Thank you very much.

Jon