Subject: Notification: incoming/1291

From: [email-masked]
Date: Sun, 30 May 2004 07:15:58 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/1291

Message summary for PR#1291
	From: [email-masked]
	Subject: Pixmaps for borderstyles in 2.5
	Date: Sun, 30 May 2004 07:13:42 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Sun May 30 07:13:43 2004
Date: Sun, 30 May 2004 07:13:42 -0500
From: [email-masked]
To: [email-masked]
Subject: Pixmaps for borderstyles in 2.5

Full_Name: Evgeny Stambulchik
Version: 2.5.8
CVS_Date: 
OS: Linux 2.6.5-gentoo-r1 x86_64
X_Server: X.Org version: 6.7.0
Submission from: (NULL) (132.77.4.129)

In 2.5.*, when a pixmap is used for window borders, the right border is
rendered separately (with shifted origin) using the pixmap, whereas in
2.4.* the same pixmap was used, so for gradiented pixmaps it looks now
(2.5) ugly. Please see
http://plasma-gate.weizmann.ac.il/~fnevgeny/tmp/2.4.18.png and
http://plasma-gate.weizmann.ac.il/~fnevgeny/tmp/2.5.8.png.

Regards,

Evgeny

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 31 May 2004 23:31:52 +0000

> http://plasma-gate.weizmann.ac.il/~fnevgeny/tmp/2.5.8.png.

This is a feature. Now the window resizing and moving over other windows
do not flicker at all (smooth and fast decorations).

I don't think it is possible to have both the old look and not the
constant border redrawing on interactive Resize. Yes, it is sad, but
flickering is more annoying, I don't even want to recall how ugly it was.

So although I would definitelly like to have the way to define border
images nicely in the future, I think this may be done after 2.6.x.

Regards,
Mikhael.