Subject: Re: Freaze on startup (Was: Notification: incoming/1280)

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 14 May 2004 21:46:16 +0000

On 15 May 2004 04:16:34 +0400, Executier wrote:
> 
> In docs:
> 
> What is exactly freeze for you? Please explain.
> SORRY!!! Kill me. I know ho to simulate this bug. But for the first a
> few strings from file BUGS:
> --------------------------
> ...
> Some users have been getting odd startup problems, like total lockups.
> I cannot reproduce this, and have no idea why.  Let me know if you see
> this and find a way to consistently reproduce it.
> ...
> --------------------------

I want to remove the ancient files TODO and BUGS, they only cause
confusion. Don't read them.

> The problem is that i run "xinit" not from native linux console but from 
> midnight commander subshell. In search case fvwm hangs. I`m totally
> braindead if do so?

I don't know. If X works well when started from MC, then it should be ok.

But you didn't say whether you experience the same problem when you start
X from the plain shell.

> 1) Does pressing Ctrl-Alt-Esc help?
> Yes, X server dies.

Are you sure? I mean Ctrl-Alt-Esc, not Ctrl-Alt-Backspace.

> 2) Does adding line like "ModuleTimeout 5" to your config help?
> No, but X server is still alive. The cursor icon is still change
> on screen borders.
> 
> 3) How do you run fvwm, for example directly from .xinitrc, or maybe from
> some session manager like gnome-config?
> In ~/.xinitrc: "Exec /usr/X11R6/bin/fvwm". I run it by command "xinit"
> in the shell.

This is incorrect. It should be "exec", not "Exec". Do you have some
shell/unix command named "Exec" on your system?

> 4) Other relevant info.
> Please don`t kill me.

Why should I do this?

Please do the following.

Ensure /usr/X11R6/bin/fvwm is the right version (I don't think you have
2.5.10 installed in this location, but who knows.) Run something like:

  /path/to/fvwm -V

The last line in ~/.xinitrc should look like:

  exec fvwm

But first try "exec fvwm -f /dev/null" line to see whether the problem is
in your .fvwm2rc configuration.

> I cached one more thing:
> in 2.4.18 this string in the config works fine:
> ------------
> Mouse 0 R N - # Removes default menu
> ------------
> 
> But in the 2.5.10 this don`t do that i think it`s must do.

The man page says it should be now:

  Mouse 1 R A -

P.S. Can your mailer add "> " to quotes on reply, for easier reading?

Please write to the list, not to me privatelly. You are welcome to discuss
problems with 2.5.x on "fvwm-workers" list and to ask questions on "fvwm"
@fvwm.org list, see the web site for details.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Executier <[email-masked]>
Date: Sat, 15 May 2004 23:21:33 +0400

On Fri, 14 May 2004 21:46:16 +0000
Mikhael Goikhman <[email-masked]> wrote:

I`ll catch it!!! Look the output of command
exec strace -o /X /usr/X11R6/bin/fvwm2 in x.initrc:
--------------------------------

write(2, "_cdim: --- not moved 0x0814c9f8 \'FvwmTaskBar\'\n", 46) = ? ERESTARTSYS (To be restarted)
--- SIGTTOU (Stopped (tty output)) ---
--- SIGTTOU (Stopped (tty output)) ---
write(2, "_cdim: --- not moved 0x0814c9f8 \'FvwmTaskBar\'\n", 46) = ? ERESTARTSYS (To be restarted)
--- SIGTTOU (Stopped (tty output)) ---
--- SIGTTOU (Stopped (tty output)) ---
write(2, "_cdim: --- not moved 0x0814c9f8 \'FvwmTaskBar\'\n", 46) = ? ERESTARTSYS (To be restarted)
--- SIGTTOU (Stopped (tty output)) ---
--- SIGTTOU (Stopped (tty output)) ---
....

--------------------------------------
And it`s continies on infinite loop! I think fvwm can`t print message to stderr/stdout.

I must say you that before xfree4.4.0 i`ve got 4.2.0 and i instold 4.4.0 over 4.2.0.
I think where may be old Xlibs. I don`t know. But fvwm compiled after instlling 4.4.0.
If you say i totally reinstall my X with removing current.
My mc is 4.6.1-pre1 and i`ll try to upgrade.

>From plain shell xinit and fvwm works fine.

> Are you sure? I mean Ctrl-Alt-Esc, not Ctrl-Alt-Backspace.
Sorry, i`m wrong. Nothing happens then i press Ctrl-Alt-Backspace. 

> shell/unix command named "Exec" on your system?
Sorry, my full .xinitrc:
----------
exec /usr/X11R6/bin/fvwm
----------
Where "fvwm" is a link to the "fvwm2".

> Why should I do this?
For my bad bugreport.

> 2.5.10 installed in this location, but who knows.)
Oh, yes, i run configure with "--exec-prefix=/usrX11R6/fvwm"

> Run something like:
Output: "fvwm 2.5.10 compiled on May 15 2004 at 03:44:50"

> in your .fvwm2rc configuration.
Yes! It`s works with -f /dev/null! I think that problem in modules or modules interface.
See output from strace.

> The man page says it should be now:
Very big thanx! I`ll try to be carefully with reading manpages. 

> P.S. Can your mailer add "> " to quotes on reply, for easier reading?
Sorry, i`ll fix it.