Subject: Bug: FvwmConsole doesn't use X resources when class name is used.

From: ddtl <[email-masked]>
Date: Thu, 20 May 2004 16:01:48 +0200

Hello,

According to the man page of FvwmConsole, all resources set for xterm
are inherited. But it is not the case if xterm's resources are set
using class name, i.e. this works:

xterm*background: white

but this doesn't:

XTerm*background: white

though both are supposed to work, as xterm itself makes use both
of xterm* and XTerm*.

ddtl.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 20 May 2004 16:22:09 +0000

> though both are supposed to work, as xterm itself makes use both

The reality is quite opposite to what you say, unless you invoke
FvwmConsole using some non-standard way that you don't tell us.

FvwmConsole does not do anything with resources, it just starts xterm
-name FvwmConsole -title FvwmConsole, that creates a window with class
"XTerm" and resource "FvwmConsole". Try FvwmIdent on this window.

So it matches all "XTerm*", but not "xterm*". And you may just configure:
FvwmConsole*background: #003030
FvwmConsole*foreground: white

Regards,
Mikhael.

---

From: ddtl <[email-masked]>
Date: Thu, 20 May 2004 22:33:24 +0200

> FvwmConsole*foreground: white

Once again it seems that it is a problem with Debian's package:
(by "once again" I refer to the recent topic called
"FVWM: Usage of FvwmEvent." in [email-masked] mailing list).

Indeed, using freshly compiled fvwm (2.5.10) I get exactly the same
behaviour you have described, but using Debian's package not only
does the things work as I wrote previously, but setting resources
via FvwmConsole*background etc. doesn't work at all.

Go figure.

ddtl.

---

From: ddtl <[email-masked]>
Date: Thu, 20 May 2004 22:42:34 +0200

> ...but using Debian's package not only
> does the things work as I wrote previously...

Forgotten to say - fvwm's version (in Debian package)
is 2.5.10-6 (the "-6" is Debian specific).

ddtl.

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 20 May 2004 21:44:21 +0000

> is 2.5.10-6 (the "-6" is Debian specific).

I think Debian replaces "xterm" in FvwmConsole with "x-terminal-emulator"
that may be any random application and may not even support resources.

You may create debian packages from clean sources by "make deb-dist".

Regards,
Mikhael.

---

From: Manoj Srivastava <[email-masked]>
Date: Sat, 22 May 2004 21:22:08 -0500

On Thu, 20 May 2004 21:44:21 +0000, Mikhael Goikhman <[email-masked]> said: 

>> Forgotten to say - fvwm's version (in Debian package) is 2.5.10-6
>> (the "-6" is Debian specific).

> I think Debian replaces "xterm" in FvwmConsole with
> "x-terminal-emulator" that may be any random application and may not
> even support resources.

	That is correct. Currently, these packages can serve as an X
 terminal emulator:

----------------------------------------------------------------------
aterm - Afterstep XVT - a VT102 emulator for the X window system
aterm-ml - Afterstep XVT - a VT102 emulator for the X window system
eterm - Enlightened Terminal Emulator
gmrun - Featureful CLI-like GTK+ application launcher
gnome-terminal - The GNOME 2 terminal emulator application
hanterm-xf - X terminal emulator with Hangul support
konsole - KDE X terminal emulator
kterm - Multi-lingual terminal emulator for X.
mlterm - MultiLingual TERMinal
mlterm-tiny - MultiLingual TERMinal, tiny version
multi-gnome-terminal - Enhanced the GNOME Terminal
powershell - powerful terminal emulator for GNOME
pterm - PuTTY terminal emulator
rxvt - VT102 terminal emulator for the X Window System
rxvt-beta - VT102 terminal emulator for the X Window System
rxvt-ml - multi-lingual VT102 terminal emulator for the X Window System
rxvt-unicode - RXVT-like terminal emulator with Unicode support
tn5250 - 5250 telnet emulator for accessing an IBM iSeries (AS/400)
wterm - An rxvt based, color xterm replacement
wterm-ml - A multi-lingual rxvt based, color xterm replacement
xiterm+thai - x-terminal program with Thai languague support
xterm - X terminal emulator
xvt - X terminal-emulator similar to xterm, but smaller
----------------------------------------------------------------------

	manoj

-- 
I find you lack of faith in the forth dithturbing. Darse ("Darth")
Vader
Manoj Srivastava   <[email-masked]>  <http://www.datasync.com/%7Esrivasta/>
1024R/C7261095 print CB D9 F4 12 68 07 E4 05  CC 2D 27 12 1D F5 E8 6E
1024D/BF24424C print 4966 F272 D093 B493 410B  924B 21BA DABB BF24 424C
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]