Subject: query mini icon for window (using perllib?)

From: Scott Smedley <[email-masked]>
Date: Wed, 19 May 2004 01:14:50 +1000

Hi Mikhael,

Is there a way to find out the mini icon associated with a window
via the perllib interface?

SCoTT. :)
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Scott Smedley <[email-masked]>
Date: Wed, 19 May 2004 01:43:19 +1000

> via the perllib interface?

I suppose I could issue the following command from within FvwmTabs:

WindowId $winId SendToModule FvwmTabs fn setMiniIcon $winId $[w.miniiconfile]

but that seems a bit cumbersome ... is there a better way?

SCoTT. :)

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 18 May 2004 21:15:24 +0000

> but that seems a bit cumbersome ... is there a better way?

Is not this the last (name) field of M_MINI_ICON event?

Of course you clomber all names in your WindowList patch as far as I
understand it.

I had some idea about how to fix this.

Regards,
Mikhael.

---

From: Scott Smedley <[email-masked]>
Date: Wed, 19 May 2004 09:01:42 +1000

Hi Mikhael,

: Is not this the last (name) field of M_MINI_ICON event?

Ah, of course.

: Of course you clomber all names in your WindowList patch as far as I
: understand it.
: I had some idea about how to fix this.

Do tell.

Would you like me to fix it?

SCoTT. :)

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 19 May 2004 11:44:01 +0000

On 19 May 2004 09:01:42 +1000, Scott Smedley wrote:
> : Of course you clo[b]ber all names in your WindowList patch as far as I
> : understand it.

You may submit an updated patch if you have one. But this is optional, I
planned to improve it anyway before commiting. Maybe in a week.

Regards,
Mikhael.