Subject: Re: CR_DETECT_MOTION_METHOD_DEBUG

From: [email-masked]
Date: Wed, 21 Apr 2004 12:51:30 +0200

Sorry for the late reply.

On Wed, Mar 03, 2004 at 06:44:26PM +0100, Markus Rost wrote:
> The new version fvwm-2.5.9 has CR_DETECT_MOTION_METHOD_DEBUG #defined
> in events.c which leads to messages like
> 
> s 476/498 0/ 0, g 481/523 5/25: +++ travelling traditional 0x08122f20
> 'xv 3.10a <unregistered>'
> 
> Is this intended?

Yes.  The message will go away some time in the future.

> By the way, I have sent a bug report to [email-masked]
> 
> <URL:http://www.fvwm.org/cgi-bin/fvwm-bug/incoming?id=1146>
> 
> Is that really the right place, or is it better to use
> [email-masked] ?

Yes, but apparently the bug reports have not been forwarded to
the mailing list for ages, so nobody read them :-/

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Markus Rost <[email-masked]>
Date: Thu, 22 Apr 2004 00:29:17 +0200

Thanks for the reply.

> the mailing list for ages, so nobody read them :-/

OK, so here is that bug report.  It includes a patch to fix it.

Note that emacs buffers with names like *mail* in separate Emacs
frames can easily create window titles containing *'s, so I think
it's worth to fix it.

------- Start of forwarded message -------
Date: Mon, 1 Mar 2004 10:22:26 -0600
From: [email-masked]
To: [email-masked]
Subject: FvwmWindowMenu and stars

Full_Name: Markus Rost
Version: 2.5.8
CVS_Date: 
OS: GNU/linux
X_Server: 
Submission from: (NULL) (129.70.14.216)

After the Fvwm commands

Module FvwmWindowMenu
Exec exec xterm -name "*xterm*"
SendToModule FvwmWindowMenu Menu

window "*xterm*" is listed in the menu, but with empty title.
You get also an error:

Use of uninitialized value in concatenation (.) or string at 
/var/tmp/fvwm/install2/libexec/fvwm/2.5.9/FvwmWindowMenu line 331.
[FVWM][scanForPixmap]: <<WARNING>> Couldn't load image from
xterm

The reason is that "*" in menu labels needs to be quoted as "**".
I don't know the proper fix, but the following patch works fine for me.

*** /var/tmp/local/libexec/fvwm/2.5.8/FvwmWindowMenu.~1~	Thu Feb 12
15:52:27 2004
- --- /var/tmp/local/libexec/fvwm/2.5.8/FvwmWindowMenu	Fri Feb 27 17:01:51
2004
***************
*** 324,329 ****
- --- 324,333 ----
  	$format =~ s/%i/&Shorten($window{$id}->{icon},
$opt->{maxlen})/ge;
  	$format =~ s/%c/&Shorten($window{$id}->{class},
$opt->{maxlen})/ge;
  	$format =~ s/%r/&Shorten($window{$id}->{resource},
$opt->{maxlen})/ge;
+ 
+ 	# escape *'s
+ 	$format =~ s/\*/**/g;
+ 
  	$format =~ s/%x/$window{$id}->{x}/g;
  	$format =~ s/%y/$window{$id}->{y}/g;
  	$format =~ s/%d/$window{$id}->{desk}/g;