Subject: Re: FVWM: debian

From: Dan Espen <[email-masked]>
Date: Fri, 16 Apr 2004 13:36:45 -0400

"Glaser, Ben I" <[email-masked]> writes:
> I'm trying to install on Solaris 8.  I get the following when running a
> make.
> 
> "make: Fatal error in reader: Makefile, line 333: Badly formed macro
> assignment
> Current working directory /var/tmp/fvwm-2.5.10/debian
> *** Error code 1
> make: Fatal error: Command failed for target `install-recursive'
> 
> Any ideas?

The Makefile in the debian directory is broken.
You can avoid it by changing the Makefile in the top directory.
Remove debian from the list assigned to SUBDIR.

At least these 2 lines in debian/Makefile.am are gnumake only:

arch ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
fullinstdir ?= $(shell cd $(top_srcdir) && pwd)/$(instdir)

-- 
Dan Espen                           E-mail: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Fri, 16 Apr 2004 13:50:29 -0400

> fullinstdir ?= $(shell cd $(top_srcdir) && pwd)/$(instdir)

Since I don't have a debian system I'll let someone else
fix this.  It looks like '=' and backticks will work.

In the future, before we create a release, ask me and I'll
try a build on Solaris with Sun's make and cc.  I can do AIX
and HP too, but my guess is just Solaris will handle most of
these problems.

---

From: Manoj Srivastava <[email-masked]>
Date: Sun, 18 Apr 2004 16:49:30 -0500

On Fri, 16 Apr 2004 13:50:29 -0400, Dan Espen <[email-masked]> said: 

>> > I'm trying to install on Solaris 8.  I get the following when
>> > running a make.
>> >
>> > "make: Fatal error in reader: Makefile, line 333: Badly formed
>> > macro assignment Current working directory
>> > /var/tmp/fvwm-2.5.10/debian
>> > *** Error code 1
>> The Makefile in the debian directory is broken.  You can avoid it
>> by changing the Makefile in the top directory.  Remove debian from
>> the list assigned to SUBDIR.
>>
>>
>> arch ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH) fullinstdir ?=
>> $(shell cd $(top_srcdir) && pwd)/$(instdir)

> Since I don't have a debian system I'll let someone else fix this.
> It looks like '=' and backticks will work.

	If you do have a Debian system, apt-get source fvwm will give
 you a working ./debian directory, integrated into the Debian
 menusystem, and with maintainer script hooks to allow for smooth
 upgrades from older Debian releases.

	manoj
-- 
"It says he made us all to be just like him.  So if we're dumb, then
god is dumb, and maybe even a little ugly on the side." Frank Zappa
Manoj Srivastava   <[email-masked]>  <http://www.datasync.com/%7Esrivasta/>
1024R/C7261095 print CB D9 F4 12 68 07 E4 05  CC 2D 27 12 1D F5 E8 6E
1024D/BF24424C print 4966 F272 D093 B493 410B  924B 21BA DABB BF24 424C
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 18 Apr 2004 22:10:01 +0000

>  upgrades from older Debian releases.

The point is the cvs version before '17 Apr 2004' does perfectly work on
Debian like systems, but not on systems without GNU make.

Regards,
Mikhael.