Subject: cvs down

From: Dan Espen <[email-masked]>
Date: Sat, 27 Mar 2004 09:36:39 -0500

Good morning Jason:

cvs update
cvs [update aborted]: recv() from server cvs.fvwm.org: Connection timed out

-- 
Dan Espen                               E-mail: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Jason L Tibbitts III <[email-masked]>
Date: 27 Mar 2004 13:07:47 -0600

>>>>> "DE" == Dan Espen <[email-masked]> writes:

DE> cvs update cvs [update aborted]: recv() from server cvs.fvwm.org:
DE> Connection timed out

Not sure why; everything seems fine from work and from home.  I see
that connections have been coming in from various places without
interruption pretty much as far back as I have logs.

 - J<

---

From: Dan Espen <[email-masked]>
Date: Sat, 27 Mar 2004 15:07:03 -0500

> interruption pretty much as far back as I have logs.

I'm not getting in from home or work.

Is this the right IP addr:

dane-2.cc> ping cvs.fvwm.org
PING util1.math.uh.edu (129.7.128.22) from 128.96.196.27 : 56(84) bytes of data.

(Can't seem to ping it either.)

---

From: Jason L Tibbitts III <[email-masked]>
Date: 27 Mar 2004 14:46:37 -0600

>>>>> "DE" == Dan Espen <[email-masked]> writes:

DE> I'm not getting in from home or work.

Can you traceroute?  (Note the next-to-last hop is supposed to be
null; the router is not on the public Internet.)

DE> Is this the right IP addr:

Yes, 129.7.128.22 is correct.

DE> (Can't seem to ping it either.)

Stupid university network people filter ICMP for all of 129.7/16.
Ping won't work regardless.

 - J<

---

From: Dan Espen <[email-masked]>
Date: Sat, 27 Mar 2004 15:58:55 -0500

>From work with the internal stuff removed:

dane-2.cc> traceroute cvs.fvwm.org
 6  s2-0-10.hsa1.nwr1.bbnplanet.net (64.156.0.5)  4.968 ms  4.996 ms  4.875 ms
 7  so-5-2-0.bbr1.NewYork1.Level3.net (4.68.113.45)  5.578 ms  5.601 ms  5.168 ms
 8  ge-2-0.core2.NewYork1.Level3.net (64.159.17.6)  5.533 ms  12.701 ms  5.457 ms
 9  oc12.Level3.nycmny01.us.bb.verio.net (209.244.160.150)  6.182 ms  5.629 ms  5.475 ms
10  p16-1-1-0.r21.nycmny01.us.bb.verio.net (129.250.3.48)  5.776 ms  5.966 ms  5.978 ms
11  p16-1-0-1.r21.asbnva01.us.bb.verio.net (129.250.5.99)  13.023 ms  12.400 ms  11.874 ms
12  p64-0-0-0.r20.asbnva01.us.bb.verio.net (129.250.2.34)  17.087 ms  12.197 ms  12.023 ms
13  p16-0-0-0.r00.atlnga03.us.bb.verio.net (129.250.2.49)  48.716 ms  48.763 ms p16-0-1-1.r21.dllstx09.us.bb.verio.net (129.250.5.34)  44.056 ms
14  p16-2-0-0.r01.atlnga03.us.bb.verio.net (129.250.5.17)  48.589 ms p16-6-0-0.r02.hstntx01.us.bb.verio.net (129.250.5.101)  50.374 ms  50.270 ms
15  p16-1-0-2.r20.dllstx09.us.bb.verio.net (129.250.4.194)  48.327 ms ge-0-2-0.a03.hstntx01.us.ra.verio.net (129.250.29.89)  51.526 ms p16-1-0-2.r20.dllstx09.us.bb.verio.net (129.250.4.194)  48.162 ms
16  p16-5-0-0.r02.hstntx01.us.bb.verio.net (129.250.5.41)  54.796 ms a1-1-2-0-2.a03.hstntx01.us.ce.verio.net (128.241.11.50)  52.428 ms p16-5-0-0.r02.hstntx01.us.bb.verio.net (129.250.5.41)  54.033 ms
17  vespasian-vlan10.gw.uh.edu (129.7.254.254)  56.439 ms  53.569 ms ge-0-2-0.a03.hstntx01.us.ra.verio.net (129.250.29.89)  53.575 ms
18  * a1-1-2-0-2.a03.hstntx01.us.ce.verio.net (128.241.11.50)  58.992 ms *
19  vespasian-vlan10.gw.uh.edu (129.7.254.254)  61.755 ms util1.math.uh.edu (129.7.128.22)  51.958 ms vespasian-vlan10.gw.uh.edu (129.7.254.254)  54.865 ms

---

From: Jason L Tibbitts III <[email-masked]>
Date: 27 Mar 2004 15:15:05 -0600

>> From work with the internal stuff removed:

Your traceroute output looks weird to me, but it seems that you're
reaching the site OK.  Which means I'm confused; there aren't any
restrictions on the server with regards to which addresses can
connect, and the logs show continued connections from various places.

I suppose you could run nmap against 129.7.128.22 to see if you can
reach any ports there.

 - J<

---

From: Dan Espen <[email-masked]>
Date: Sat, 27 Mar 2004 16:30:29 -0500

>From home:

home> nmap 129.7.128.22

Starting nmap V. 2.54BETA22 ( www.insecure.org/nmap/ )
Interesting ports on util1.math.uh.edu (129.7.128.22):
(The 1512 ports scanned but not shown below are in state: closed)
Port       State       Service
21/tcp     open        ftp                     
22/tcp     open        ssh                     
25/tcp     open        smtp                    
53/tcp     open        domain                  
79/tcp     open        finger                  
80/tcp     open        http                    
111/tcp    open        sunrpc                  
135/tcp    filtered    loc-srv                 
136/tcp    filtered    profile                 
137/tcp    filtered    netbios-ns              
138/tcp    filtered    netbios-dgm             
139/tcp    filtered    netbios-ssn             
194/tcp    filtered    irc                     
445/tcp    filtered    microsoft-ds            
707/tcp    filtered    unknown                 
873/tcp    open        rsync                   
974/tcp    open        unknown                 
991/tcp    open        unknown                 
994/tcp    filtered    ircs                    
1013/tcp   open        unknown                 
1433/tcp   filtered    ms-sql-s                
1434/tcp   filtered    ms-sql-m                
1723/tcp   open        pptp                    
2003/tcp   open        cfingerd                
2048/tcp   filtered    dls-monitor             
2401/tcp   open        cvspserver              
3306/tcp   open        mysql                   
6699/tcp   filtered    napster                 
8888/tcp   filtered    sun-answerbook          
32771/tcp  open        sometimes-rpc5          

Nmap run completed -- 1 IP address (1 host up) scanned in 76 seconds

I see the cvspserver port 2401 is open.
I tried to telnet to that port, but so far it's hanging
just like it does when I try CVS.

---

From: Jason L Tibbitts III <[email-masked]>
Date: 27 Mar 2004 15:40:15 -0600

>>>>> "DE" == Dan Espen <[email-masked]> writes:

DE> I see the cvspserver port 2401 is open. I tried to telnet to that
DE> port, but so far it's hanging just like it does when I try CVS.

Still can't find anything wrong; just did another full checkout from
yet another location and it went fine.  There are no hung CVS
processes on the server and no error messages in any logs.  Other
users seem to be connecting fine.  Nothing has changed on the server
recently that would cause problems.

If anyone else is having problems, please speak up.

 - J<

---

From: Dan Espen <[email-masked]>
Date: Sat, 27 Mar 2004 16:49:28 -0500

> recently that would cause problems.

Just tried from my Solaris machine at work.
Works fine from there.

Just checked my home and work Linux machines, same problem.

> If anyone else is having problems, please speak up.

Think I'll go do some RW stuff.

---

From: Jason L Tibbitts III <[email-masked]>
Date: 27 Mar 2004 16:49:51 -0600

>>>>> "DE" == Dan Espen <[email-masked]> writes:

DE> Just checked my home and work Linux machines, same problem.

Do the Linux machines share a common CVS version?  The server is
running 1.11.1p1 plus security patches.  This hasn't changed since the
last CVS security hole.  My home machine is running 1.11.2, but I also
checked 1.11.5 and it works fine as well.  A long time ago we had a
problem with the version of CVS on the server causing client hangs but
that was resolved, and in any case the versions on the server haven't
changed so this has got to be either a networking or client issue.

Also check /proc/sys/net/ipv4/tcp_ecn; make sure it's off.

 - J<

---

From: Dan Espen <[email-masked]>
Date: Sat, 27 Mar 2004 18:50:17 -0500

> changed so this has got to be either a networking or client issue.

The linux machines are both 1.11.1p1.
The solaris machine is 1.10.

I just strace/trussed both of them and they both do this:

connect(3, {sin_family=AF_INET, sin_port=htons(2401), sin_addr=inet_addr("129.7.128.22")}}, 16) = 0
send(3, "BEGIN AUTH REQUEST\n", 19, 0)  = 19
send(3, "/home/cvs/fvwm", 14, 0)        = 14
send(3, "\n", 1, 0)                     = 1
send(3, "dane", 4, 0)                   = 4
send(3, "\n", 1, 0)                     = 1
send(3, "XXXXXXX", 7, 0)                = 7
send(3, "\n", 1, 0)                     = 1
send(3, "END AUTH REQUEST\n", 17, 0)    = 17
recv(3, 0xbffff57b, 1, 0)               = -1 ETIMEDOUT (Connection timed out)

6187:	connect(3, 0xFFBED368, 16, 1)			= 0
6187:	send(3, 0x001345D8, 19, 0)			= 19
6187:	   B E G I N   A U T H   R E Q U E S T\n
6187:	send(3, 0x0013D933, 14, 0)			= 14
6187:	   / h o m e / c v s / f v w m
6187:	send(3, "\n", 1, 0)				= 1
6187:	send(3, " d a n e", 4, 0)			= 4
6187:	send(3, "\n", 1, 0)				= 1
6187:	send(3, " X X X X X X X", 7, 0)			= 7
6187:	send(3, "\n", 1, 0)				= 1
6187:	send(3, 0x001345EC, 17, 0)			= 17
6187:	   E N D   A U T H   R E Q U E S T\n
6187:	recv(3, " I", 1, 0)				= 1
6187:	recv(3, "  ", 1, 0)				= 1
6187:	recv(3, " L", 1, 0)				= 1
6187:	recv(3, " O", 1, 0)				= 1
6187:	recv(3, " V", 1, 0)				= 1
6187:	recv(3, " E", 1, 0)				= 1
6187:	recv(3, "  ", 1, 0)				= 1
6187:	recv(3, " Y", 1, 0)				= 1
6187:	recv(3, " O", 1, 0)				= 1
6187:	recv(3, " U", 1, 0)				= 1
6187:	recv(3, "\n", 1, 0)				= 1

Interesting, who knew that's the way the CVS server responds. 
Obviously I replaced the encrypted password, but they were the
same.

> Also check /proc/sys/net/ipv4/tcp_ecn; make sure it's off.

I don't know what that is but here it is:

home> cat /proc/sys/net/ipv4/tcp_ecn 
0

I'll see about changing the cvs version I'm using later but
it doesn't look like that's the problem to me.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 29 Mar 2004 10:58:24 +0200

> changed so this has got to be either a networking or client issue.

I'm running cvs-1.11.1p1 like the server.  Of course that's not
surprising because you downgraded the server to the old version
because I had hangs.

> Also check /proc/sys/net/ipv4/tcp_ecn; make sure it's off.

It's off.

Ciao

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 29 Mar 2004 10:55:03 +0200

> If anyone else is having problems, please speak up.

I have the same problem as Dan.  CVS just hangs.

---
$ traceroute 129.7.128.22
traceroute to 129.7.128.22 (129.7.128.22), 30 hops max, 38 byte packets
 1  gw-ma-a.dev-system.ma.schlund.de (172.17.39.253)  0.510 ms  0.436 ms 0.425 ms
 2  gw-nat-a.dist.bs.ka.schlund.net (212.227.125.234)  0.400 ms  0.301 ms  0.362 ms
 3  v999.gw-dist-a.bs.ka.schlund.net (212.227.125.253)  0.521 ms  0.580 ms  0.462 ms
 4  ge-42.gw-backbone-b.bs.ka.schlund.net (212.227.121.232)  0.551 ms 0.509 ms  0.563 ms
 5  pos-80.gw-backbone-b.ffm.schlund.net (212.227.112.127)  3.024 ms 3.100 ms  3.069 ms
 6  212.162.44.157 (212.162.44.157)  3.349 ms  3.349 ms  3.306 ms
 7  ae-0-51.mp1.Frankfurt1.Level3.net (195.122.136.1)  3.994 ms  3.791 ms  3.910 ms
 8  so-2-0-0.mp2.Amsterdam1.Level3.net (212.187.128.94)  10.153 ms 10.157 ms  10.251 ms
 9  ge-6-2.core2.Amsterdam1.Level3.net (213.244.165.118)  10.413 ms 10.308 ms  10.288 ms
10  Verio-Level3.Level3.net (213.244.165.242)  23.462 ms  23.372 ms 23.273 ms
11  p16-2-0-0.r01.amstnl02.nl.bb.verio.net (129.250.2.135)  80.279 ms 23.594 ms  23.581 ms
12  p16-1-0-0.r80.asbnva01.us.bb.verio.net (129.250.5.87)  99.250 ms 99.144 ms  99.260 ms
13  p16-0-1-1.r20.asbnva01.us.bb.verio.net (129.250.2.38)  99.196 ms 98.944 ms  99.137 ms
14  p16-0-0-0.r00.atlnga03.us.bb.verio.net (129.250.2.49)  115.749 ms p16-0-1-1.r21.dllstx09.us.bb.verio.net (129.250.5.34)  128.464 ms 128.418 ms
15  p16-2-0-0.r01.atlnga03.us.bb.verio.net (129.250.5.17)  132.889 ms p16-6-0-0.r02.hstntx01.us.bb.verio.net (129.250.5.101)  134.676 ms p16-2-0-0.r01.atlnga03.us.bb.verio.net (129.250.5.17)  132.722 ms
16  p16-1-0-2.r20.dllstx09.us.bb.verio.net (129.250.4.194)  132.634 ms ge-0-2-0.a03.hstntx01.us.ra.verio.net (129.250.29.89)  134.661 ms p16-1-0-2.r20.dllstx09.us.bb.verio.net (129.250.4.194)  132.478 ms
17  a1-1-2-0-2.a03.hstntx01.us.ce.verio.net (128.241.11.50)  136.002 ms 135.776 ms p16-5-0-0.r02.hstntx01.us.bb.verio.net (129.250.5.41) 137.789 ms
18  vespasian-vlan10.gw.uh.edu (129.7.254.254)  136.418 ms ge-0-2-0.a03.hstntx01.us.ra.verio.net (129.250.29.89)  137.987 ms vespasian-vlan10.gw.uh.edu (129.7.254.254)  136.564 ms
19  a1-1-2-0-2.a03.hstntx01.us.ce.verio.net (128.241.11.50)  139.130 ms *  139.558 ms
20  vespasian-vlan10.gw.uh.edu (129.7.254.254)  139.623 ms util1.math.uh.edu (129.7.128.22)  136.176 ms vespasian-vlan10.gw.uh.edu (129.7.254.254)  139.781 ms
---

Ciao

Dominik ^_^  ^_^

---

From: [email-masked]
Date: Mon, 29 Mar 2004 22:46:29 +0200

> > Also check /proc/sys/net/ipv4/tcp_ecn; make sure it's off.

I have the same problem from my home machine (1.11.1p1 too).

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]