Subject: small Makefile.am bug(?) in FvwmGtk

From: Stephan Beyer <[email-masked]>
Date: Tue, 16 Mar 2004 18:35:50 +0100

Hi,

found a 'bug' (more or less) in the FvwmGtk's Makefile.am. It's not
really a bug, because - I don't know why - only on some builds a 'make
install' doesn't install a FvwmGtk manual page. This patch for latest
cvs (use 'patch -p1' in fvwm src dir) should make it work with every
compilation.
The problem is nothing horrible, but also it's not nice.

If it's a feature, and not a bug, please tell me why the FvwmGtk manual
page isn't installed on my system... ;)

greetings
sbeyer

PS: No replies on the Translucency patch mail? :\
diff -ruN fvwm/configure.in fvwm-bugfix/configure.in
--- fvwm/configure.in	2004-03-02 13:47:35.000000000 +0100
+++ fvwm-bugfix/configure.in	2004-03-16 18:17:01.000000000 +0100
@@ -988,7 +988,6 @@
 if test x"$enable_gtktest" = xyes; then
 	AM_PATH_GTK(1.1.0,[
 		FVWMGTK=FvwmGtk AC_SUBST(FVWMGTK)
-		MANFVWMGTK=FvwmGtk.1 AC_SUBST(MANFVWMGTK)
 	],)
 	if test x"$no_gtk" = x; then
 		with_gtk=yes
diff -ruN fvwm/modules/FvwmGtk/Makefile.am fvwm-bugfix/modules/FvwmGtk/Makefile.am
--- fvwm/modules/FvwmGtk/Makefile.am	2003-06-19 23:44:32.000000000 +0200
+++ fvwm-bugfix/modules/FvwmGtk/Makefile.am	2004-03-16 18:13:46.000000000 +0100
@@ -5,8 +5,8 @@
 module_PROGRAMS = @FVWMGTK@
 EXTRA_PROGRAMS = FvwmGtk
 
-man_MANS = @MANFVWMGTK@
-EXTRA_DIST = FvwmGtk.1
+man_MANS = FvwmGtk.1
+EXTRA_DIST = $(man_MANS)
 
 GTK_CFLAGS = @GTK_CFLAGS@
 GTK_LIBS = @GTK_LIBS@

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 17 Mar 2004 10:42:40 +0100

> page isn't installed on my system... ;)

It's only installed if FvwmGtk is installed too.

Ciao

Dominik ^_^  ^_^
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Stephan Beyer <[email-masked]>
Date: Wed, 17 Mar 2004 11:48:24 +0100

> It's only installed if FvwmGtk is installed too.

FvwmGtk is installed too, of course...

sbeyer

---

From: [email-masked]
Date: Tue, 30 Mar 2004 00:46:48 +0200

> FvwmGtk is installed too, of course...

Ah, forget my earlier mail.  I see the problem too.  It seems to
be an automake bug:  Although the man_MANS variable is not empty
in the Makefile, automake does not generate an install rule for
man pages.  I'll commit a fix as soon as I can access CVS again.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]