Subject: Re: FvwmButton/Panel changes 2.5.7 <->2.5.8

From: Dominik Vogt <[email-masked]>
Date: Wed, 4 Feb 2004 10:26:46 +0100

On Sat, Jan 17, 2004 at 01:51:11PM +0530, Kingsly John wrote:
> I'm using the following config(see end of mail) for a panel which slides out
> my licq main window... until 2.5.7 the window would slide out and slide back
> in (32 steps both directions).
> 
> >From 2.5.8 onwards it slides out... but when retracting it goes away
> instantly(0steps instead of the expected 32)
> 
> Same problem exists in 2.5.9(4/5th Jan snapshot.) too.
> 
> Kingsly
> 
> DestroyModuleConfig licq-holder
> 
> *licq-holder: Geometry 170x12-0+0
> *licq-holder: Colorset 1
> *licq-holder: Columns 1
> *licq-holder: Frame 0
> *licq-holder: (Panel(indicator, smooth, down, steps 32, \
>         position module center mtb , NoClose , UseOld) "Licq (Schattenjäger)"\
>        'Exec exec licq')
> 
> Module FvwmButtons licq-holder

I can't reproduce this, but I have a suspicion.  It may be related
to the new window movement method detection code.  To evaluate the
situation, I need more information.

 1. Try using this style:

      Style * MoveByProgramMethod IgnoreGravity

    If I am right, the problem should go away.

 2. When shading or unshading the window, fvwm prints a lot of
    debug messages on the console, e.g.

      s 831/112 -31936/-32655, g 835/134 -31932/-32633: --- not detected
      0x08138de0 'Licq (255773845)'
      s 831/112  0/ 0, g 835/134  4/22: +++ travelling traditional 0x08138de0
      'Licq (255773845)'

    I need all that output (separately for shade and unshade)

 3. Finally I need the whole config file.  There are a number of
    styles that can affect this.

Ciao

Dominik ^_^  ^_^

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Kingsly John <[email-masked]>
Date: Wed, 11 Feb 2004 22:43:46 +0530

[Sorry about the delay in replying had a busy week... -KJ]

>     If I am right, the problem should go away.

You were right... it works like before now.

>       s 831/112  0/ 0, g 835/134  4/22: +++ travelling traditional 0x08138de0

Without the above Style line added... I was getting the following line when
the licq window was being displayed/expanded.

s 1429/ 14 -31338/-32753, g 1430/ 15 -31337/-32752: +++ near border icccm 0x0814c468 'Licq (Schattenjäger)'

>     I need all that output (separately for shade and unshade)

No output while shading..

With the style added there are no messages at all.

>     styles that can affect this.

The config is very ugly.. way too many "Read"s and even some files that are
not used. You can find the whole config directory tarball here
http://kingsly.net/kj-fvwm.tar.gz

If it makes your job easier, Here is a list of all the Style statements
used...

http://kingsly.net/styles.txt

(The only styles definitions left out are the ones for some fvwmbuttons based
desktop launcher icons.. which have the following definition.
Style $0Launch HandleWidth 0, NoTitle, Sticky, StaysOnBottom, ClickToFocus, WindowListSkip )

Kingsly