Subject: fvwm-root failure

From: Chris Ross <[email-masked]>
Date: Fri, 20 Feb 2004 11:38:34 -0500

Hi.  I'm running a solaris 8 system, with the installed
openwin X server, and fvwm-root is failing with a shared
memory error on my machine.

   I looked into it, and it's a error returned from shmget()
somewhere in the X libraries.  The X error being displayed
is:

X Error of failed request:  BadAccess (attempt to access private 
resource denied)
   Major opcode of failed request:  131 (MIT-SHM)
   Minor opcode of failed request:  1 (X_ShmAttach)
   Serial number of failed request:  10
   Current serial number in output stream:  11

   Looking at the system calls, it appears that shmget()
is returning EINVAL when it's being called to create
a 5+ MB memory segment.  In reading documentation,
I see that the "system default" maximum size for shared
memory is 1MB.  I realize my fvwm-root is trying to ask for
a little over 5MB, but, doing some math, even a 1024x768
screen at 16-bit pixmap-depth will produce an X Pixmap that
is 1.5MB in size.

   Perhaps there should be another way to load this?  Is
this just a solaris bogosity?  Can we interact with the
MIT-SHM extension directly to check on things?

                             - Chris

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Feb 2004 10:05:54 +0100

On Fri, Feb 20, 2004 at 11:38:34AM -0500, Chris Ross wrote:
>   Perhaps there should be another way to load this?

Yes, definitely.  Relying exclusively on shared memory is a bad
thing, not only because some (all) implementations have limits on
the size of shared memory that can be allocated in one chunk, but
also because the total amount of shared memory is limited (usually
less than the total available memory on the system).

>  Is this just a solaris bogosity?  Can we interact with the

Ciao

Dominik ^_^  ^_^

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 25 Feb 2004 17:10:26 +0100

> MIT-SHM extension directly to check on things?

I will fix this bug this week-end. Normaly, if shm fail fvwm-root use
normal XImage, but it seems that there is miss-print somewhere (a cast
problem I think).

Regards, Olivier

---

From: Chris Ross <[email-masked]>
Date: Wed, 25 Feb 2004 14:16:15 -0500

Olivier Chapuis wrote:
>> [ limits on shm usage cause fvwm-root to fail ]
> 
> 

   Thank you very much!  Would much appriciate it.

                  - Chris

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 28 Feb 2004 13:30:54 +0100

>   Thank you very much!  Would much appriciate it.

I've just commited a fix. Can you try it?

Thanks, Olivier