Subject: 2.5.8 - FvwmEvents doesn't like RecaptureWindow

From: Carl Mummert <[email-masked]>
Date: Sat, 21 Feb 2004 14:29:39 -0500

I want fvwm to apply a new style when the title of my xterm changes.
So I put this in my .fvwm2rc:

  Module FvwmEvent
  *FvwmEvent: window_name RecaptureWindow

to no avail.  When the title of a window changes, the window begins to
flicker and is unusable.  Is this a bug?   How can I achieve the effect
I want?

fvwm 2.5.8 compiled on Feb  7 2004 at 00:28:41
with support for: XPM, PNG, Shape, XShm, SM, Xinerama, XRender, XFT, NLS

-- Carl

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Feb 2004 09:49:47 +0100

>   *FvwmEvent: window_name RecaptureWindow

There are two mistakes here.  First, the module should not be
started directly in the .fvwm2rc but in the StartFunction.
Second, you're starting FvwmEvent before it is configured (note
that order does not matter when using StartFunction, but it *does*
matter in the .fvwm2rc fil).  Try this:

  AddToFunc StartFunction
  + I Module FvwmEvent
  
> flicker and is unusable.  Is this a bug?   How can I achieve the effect

Ciao

Dominik ^_^  ^_^

---

From: Carl Mummert <[email-masked]>
Date: Mon, 23 Feb 2004 07:24:42 -0500

Dominik Vogt writes:
>There are two mistakes here. 
> ...
>  Try this:
>
>  AddToFunc StartFunction
>  + I Module FvwmEvent

Thanks for the tip.  I changed my .fvwm2rc to match your stuff above.
FvwmEvent still didn't work, though.   I needed to add 

  *FvwmEvent:  Delay 5

to prevent the recapture from falling into (what seems to be) an
infinite loop.  Does the Recapture function generate window_name
events?  

Carl

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Feb 2004 14:04:17 +0100

> infinite loop.  Does the Recapture function generate window_name

Yes.  When a window is (re)captured, the various ...name events
are sent.

Ciao

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 23 Feb 2004 13:51:23 +0000

> Yes.  When a window is (re)captured, the various ...name events

We need ReStyle (or StyleAgain or ReStyleWindow) command that reevaluates
the context window style (no name events should be sent). Absense of such
command is one of the main reasons why RecaptuteWindow can't be removed.

Probably having Style option AutoReStyleOnNameChange would solve the
Carl's problem better, this is a pretty reasonable feature.

Regards,
Mikhael.