Subject: Window operation-permitting styles and conditions

From: Marcus Lundblad <[email-masked]>
Date: Sat, 7 Feb 2004 13:18:01 +0100 (CET)

I was discussing with someone on #fvwm about the condition "Iconifiable".
Then it hit me I never implemented "Style WindowShadable" and the
correspodning style.
What's the opinion, I guess it should be there for consistency, but it's
not urgent for me, since I don't need it. Should this be postponed to
post-2.6?

//Marcus
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 16 Feb 2004 11:37:03 +0100

> not urgent for me, since I don't need it. Should this be postponed to

I'd like to add a way to disable any operation by the user or the
program anyway:

  - Forbid operations by user interaction.
  - Forbid operations using plain X (iconify, move, resize).
  - Override MWM hints.
  - Ignore EWMH hints and protocols.
  - Ignore GNOME hints and protocols.

Only a few operations can be controlled yet.

Such a permission system needs to be designed carefully and can
not be part of 2.6.0.

Ciao

Dominik ^_^  ^_^