Subject: Re: Focusing bug

From: Dominik Vogt <[email-masked]>
Date: Mon, 2 Feb 2004 09:54:13 +0100

On Sun, Feb 01, 2004 at 01:03:58AM +0100, Jochen Klenner wrote:
> Hi all,
> I found this issue in the latest 2.5.9 CVS. When I use ClickToFocus and
> use the mouse to change the focus, the windowlist is not in last focused
> order. Instead the list is rotated, as if the Focus command had been
> used. This does not happen when the MouseFocus or SloppyFocus style is
> in use. If I issue a
> Style * FPSortWindowlistByFocus
> everything works as expected.
> 
> The manpage seems to suggest (in the description of
> FPSortWindowlistByFocus) that the observed behavior is the default for
> ClickToFocus. As well as for SloppyFocus, contradicting actual behavior.
> The section about FlipFocus implies that selecting windows with the mouse
> is equivalent to the FlipFocus command. So, I don't know how much of the
> bug is in the documentation. In my opinion the default should be the old
> most-recently-focused order anyway.

Implementing the new focus styles was very confusing for me.  It
was hard to determine the default behaviour for all the old focus
styles and keep compatibility with them.  Can anybody tell me
exactly what fvwm-2.4.x did for

  MouseFocus
  SloppyFocus
  ClickToFocus

with an otherwise empty config file?

Ciao

Dominik ^_^  ^_^
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Jochen Klenner <[email-masked]>
Date: Mon, 2 Feb 2004 23:33:01 +0100 (MET)

> with an otherwise empty config file?

I happen to have a 2.4.6 lying around. I just verified that the default
for all three styles is to keep the windowlist in last-focused order,
i. e. FlipFocus like behavior.

Best regards

Jochen

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 5 Feb 2004 16:03:37 +0100

> i. e. FlipFocus like behavior.

Fixed.  I always though ClickToFocus ordered the window list by
creation time.  But if this ever was the case, it was changed
before 2.4.0.

Ciao

Dominik ^_^  ^_^