Subject: FullScreen/Layers issue between 2.5.7 and 2.5.8

From: Kingsly John <[email-masked]>
Date: Sun, 4 Jan 2004 09:56:04 +0530

I have the following style for gkrellm ...

Style "gkrellm" Sticky, WindowListSkip, StaysOnTop, CirculateSkip, BorderWidth 0, NoTitle, NoHandles, ClickToFocus

Under 2.5.7 both mplayer and tvtime went to fullscreen perfectly okay.(ie.
fullscreen and on top of all other windows)

Under 2.5.8 the gkrellm window ends up on top of tvtime even when it's on
fullscreen. But mplayer works perfectly as before.

I've not made any changes to the config.. and the only layer related note in
the changelog is about the !Layer condition.

What could be the issue and how do I get tvtime to go fullscreen ?

Kingsly
-- 
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 5 Jan 2004 10:15:03 -0500

I was having the same sort of problem until I finally noticed that gkrellm was setting its own layer.
If you bring up the config windows for gkrellm and select General->Properties uncheck 'Set on top' and 'Set below'

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Kingsly John <[email-masked]>
Date: Mon, 5 Jan 2004 21:09:51 +0530

> If you bring up the config windows for gkrellm and select General->Properties uncheck 'Set on top' and 'Set below'

I like gkrellm to be on the top of all regular windows... only the fullscreen
windows should be over gkrellm... everything worked this way in 2.5.7 but
something changed between 2.5.7 and 2.5.8 is.. mplayer goes over gkrellm ..
and tvtime doesn't!

Olivier's suggestion of adding ...

Style * EWMHUseStackingOrderHints 

fixes the issue... so for now my desktop is back to normal.

Kingsly