Subject: FvwmTaskBar Margin

From: Tavis Ormandy <[email-masked]>
Date: Sun, 11 Jan 2004 19:35:53 +0000

Hi there, using FvwmTaskBar in fvwm-2.5.8, I am unable to get a right
margin if I disable the Start button. 

I have a ButtonBar that stretches the entire Right side of my screen and
sits on top of the TaskBar, covering the "Clock" area (which I have
disabled), I would like to make sure that buttons on the TaskBar dont get
obscured by the ButtonBar by using a WindowButtonsRightMargin, but I cant
get it to work with my configuration, this patch gets it to work:

--- modules/FvwmTaskBar/Start.c 2003-09-03 14:52:36.000000000 +0100
+++ modules/FvwmTaskBar/Start.c 2004-01-11 19:29:00.000000000 +0000
@@ -458,7 +458,6 @@
          StartAndLaunchButtonsWidth = 0;
          StartButtonRightMargin = 0;
          WindowButtonsLeftMargin = 0;
-         WindowButtonsRightMargin = 0;
   }
 }

This is my TaskBar configuration:

Colorset 11 fg white, bg #c6c3c6, sh black, hi black, RootTransparent buffer
DestroyModuleConfig FvwmTaskBar: *
*FvwmTaskBar: Geometry +0-0
*FvwmTaskBar: Rows 1
*FvwmTaskBar: Font "xft:Bitstream Vera Sans Mono:style=Roman:size=10"
*FvwmTaskBar: StatusFont "xft:Bitstream Vera Sans Mono:style=Roman:size=10"
*FvwmTaskBar: SelFont "xft:Bitstream Vera Sans Mono:style=Roman:size=10"
*FvwmTaskBar: Colorset 11
*FvwmTaskBar: AutoStick
*FvwmTaskBar: UseSkipList
*FvwmTaskBar: PageOnly
*FvwmTaskBar: ShowTips
*FvwmTaskBar: NoDefaultStartButton
*FvwmTaskBar: NoBrightFocus
*FvwmTaskBar: 3DFvwm
*FvwmTaskBar: MailCheck 0
*FvwmTaskBar: IconColorset 11
*FvwmTaskBar: FocusColorset 11
*FvwmTaskBar: ClockFormat
*FvwmTaskBar: WindowButtonsRightMargin 124

-- 
-------------------------------------
[email-masked] | finger me for my gpg key.
-------------------------------------------------------
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 12 Jan 2004 10:56:13 +0100

> get it to work with my configuration, this patch gets it to work:

I've committed a patch that does not remove user define margins if
no start button is used.  Could you try the code from CVS please?

Ciao

Dominik ^_^  ^_^

---

From: Tavis Ormandy <[email-masked]>
Date: Mon, 12 Jan 2004 12:16:36 +0000

> no start button is used.  Could you try the code from CVS please?

Thanks, that works great :)