Subject: Memory fault when clicking right mouse button

From: Nuno Morgadinho <[email-masked]>
Date: Sun, 2 Nov 2003 12:57:42 GMT

Configuration Information [Automatically generated, do not change]:
uname: OpenBSD awaken.lockstep.org 3.4 AWAKEN#0 i386
compiler flags: gcc -g -O2 -Wall -Wno-implicit-int

FVWM Version:	2.5.8
FVWM_MODULEDIR:	/usr/local/libexec/fvwm/2.5.8
FVWM_DATADIR:	/usr/local/share/fvwm
FVWM_USERDIR:	/home/gotcha/.fvwm

Description:
	When user clicks right mouse button, Fvwm gives a memory fault and exits dumping core. 

Repeat-By:
	Starting XFree and Fvwm, starting aterm, emacs, xchat or others applications and then clicking right mouse button.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 2 Nov 2003 19:02:45 +0000

> 	Starting XFree and Fvwm, starting aterm, emacs, xchat or others applications and then clicking right mouse button.

Can you reproduce this with no fvwm config?

Please do "gdb /usr/local/bin/fvwm core", then "where" and post the
output. Optionally type some debug "print var" statements (if you know C).

Regards,
Mikhael.