Subject: CVS migo: * FvwmAnimate: support new dynamical commands "pause", "play", "push", "pop"

From: FVWM CVS <[email-masked]>
Date: Sun, 26 Oct 2003 14:29:25 -0600

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	migo	03/10/26 14:29:25

Modified files:
	.              : Makefile.am NEWS 
	modules        : ChangeLog 
	modules/FvwmAnimate: FvwmAnimate.1 FvwmAnimate.c 
	perllib/FVWM/Tracker: Colorsets.pm 
	perllib        : ChangeLog 
	rpm            : ChangeLog Makefile.am fvwm.spec.in 

Log message:
* FvwmAnimate: support new dynamical commands "pause", "play", "push", "pop"
_ and "reset" to manipulate the playing state.
* perllib: make it compatible with perl < 5.6.0
* rpm: minor changes

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 26 Oct 2003 20:44:04 +0000

> _ and "reset" to manipulate the playing state.

Apart that these are nice features to have, this was the only way for me
to supress the persistent deadlocks between fvwm and FvwmAnimate
(FvwmAnimate was killed after a long timeout).

So, if you have similar problems with:

  # commands making FvwmAnimate crazy, like:
  All (XTerm) Iconify
  # or some unfortunate configuration reload with a lot of things started

you may solve this now using:

  SendToModule FvwmAnimate push pause
  # commands making FvwmAnimate crazy
  SendToModule FvwmAnimate pop

Regards,
Mikhael.