Subject: Notification: incoming/1093

From: [email-masked]
Date: Thu, 09 Oct 2003 21:02:24 -0500

FVWM Bug Tracking notification

new message incoming/1093

Message summary for PR#1093
	From: [email-masked]
	Subject: Enhancement: Style to take $w Window ID
	Date: Thu, 9 Oct 2003 21:02:24 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Thu Oct 09 21:02:24 2003
Date: Thu, 9 Oct 2003 21:02:24 -0500
From: [email-masked]
To: [email-masked]
Subject: Enhancement: Style to take $w Window ID

Full_Name: Tim Baverstock
Version: 2.4.6 (Debian/Woody)
CVS_Date: 
OS: Linux vermillion 2.4.16-k6 #1 Wed Nov 28 10:34:08 EST 2001 i586 unknown
X_Server: XFree86 Version 4.1.0.1 / X Window System
Submission from: (NULL) (62.253.128.6)

I've written a 'stays on top' function (and its antifunction), that
operates on random windows, in much the same way that Sticky operates on
random windows (ie windows with only user-nomination in common).

My problem is that sticky windows are distinctive, but I can't make my
'stays on top' windows visually distinctive. (I'd like to give them a
yellow border.)

Enhancement 1: The following would seem to be a sensible syntax, except
that $w isn't a valid kind of parameter for Style.

AddToFunc GlueWindow
+ I Layer 0 6
+ I Style $w Color purple/yellow
+ I Raise

I imagine the above would be easier than the following suggestion:

Enhancement 2: If keying on $w isn't desireable, perhaps random windows
could be added to arbitrarily named sets (possibly a window could be a
member of multiple sets), so the magical behaviour of Sticky would be more
regular.

Regards,

Tim Baverstock.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 10 Oct 2003 22:46:50 +0300

> member of multiple sets), so the magical behaviour of Sticky would be more

This is already possible. In 2.5.8 from cvs use "WindowStyle Colorset 9",
it works better than your suggested "Style $[w.id] Color purple/yellow".

Regards,
Mikhael.