Subject: Notification: incoming/1081

From: [email-masked]
Date: Tue, 23 Sep 2003 03:38:03 -0500

FVWM Bug Tracking notification

new message incoming/1081

Message summary for PR#1081
	From: [email-masked]
	Subject: infinite flashing dialogs
	Date: Tue, 23 Sep 2003 03:38:02 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Tue Sep 23 03:38:03 2003
Date: Tue, 23 Sep 2003 03:38:02 -0500
From: [email-masked]
To: [email-masked]
Subject: infinite flashing dialogs

Full_Name: Khaled SOUEIDAN
Version: 2.4.15 and 2.4.16
CVS_Date: 
OS: sparc-sun-solaris2.6
X_Server: Xsun 11R6
Submission from: (NULL) (143.196.162.107)

Some input grabbing windows and modal windows (mostly dialog boxes)
can flash infinitely depending on existing windows.
Sometimes it happens, sometimes it doesn't.
The behaviour can permanently freeze the whole server needing
logging from a remote terminal to kill the freezing process.
A workaround consists of using FvwmPager to switch to another
viewport on the same desktop and when you switch back to the initial
viewport the flashing has stopped.
In my daily usage it only happens using Interleaf 6 or my home made
Motif applications.

FVWM configuration:
# Bugs Workaround
BugOpts FlickeringMoveWorkaround True
BugOpts ModalityIsEvil False
BugOpts FlickeringQtDialogsWorkaround False

# General Behaviour
Style *     SloppyFocus
Style *     MWMFunctions
Style *     MWMDecor
Style *     HintOverride
Style *     DecorateTransient
Style *     NoPPosition
Style *     RandomPlacement
Style *     SmartPlacement
Style *     ClickToFocusRaisesOff
Style *     GNOMEIgnoreHints

# Icons
Style "*"   IconBox 150x800-0+0, IconFill top right
Style "*"   StickyIcon

# Specific Window Styles
Style "*"               BorderWidth 7, HandleWidth 7
Style "Fvwm*"           ClickToFocus, Sticky, WindowListSkip
Style "Fvwm*"           StaysPut, CirculateSkip, CirculateSkipIcon
Style "Fvwm*"           NoTitle,  NoHandles

# General Window Setings
BorderStyle     Simple
TitleStyle      Centered -- Flat
AddTitleStyle       VGradient 8 2 Indianred1 80 Indianred3 20 Indianred3
AddTitleStyle       Inactive VGradient 8 2 Azure2 80 Azure4 20 Azure4

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 24 Sep 2003 10:06:00 +0200

> In my daily usage it only happens using Interleaf 6 or my home made

Can you give some instructions how to make that happen, please
(even if they are not reliable).

> AddTitleStyle       Inactive VGradient 8 2 Azure2 80 Azure4 20 Azure4

Ciao

Dominik ^_^  ^_^