Subject: Status of logo voting?

From: Dominik Vogt <[email-masked]>
Date: Mon, 29 Sep 2003 10:22:19 +0200

I think we need to start the voting process soon before the logo
artits get angry :-)

Ciao

Dominik ^_^  ^_^
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Uwe Pross <[email-masked]>
Date: Mon, 29 Sep 2003 12:59:05 +0200

Hi there,

On 29 Sep 2003 at 10:22:19 +0200, Dominik Vogt wrote:

> I think we need to start the voting process soon before
> the logo artits get angry :-)

I got hardly feedback for the actual voting page. You
reported one problem I could not reproduce. Using the actual
voting page voting should be possible. Could you please
check if you can vote with the actual page?

I don't think we should state any voting results during the
voting time.

Cheers, Uwe
-- 
  ,_,   For personal reply/mail put "fvwm"
 (O,O)  in the subject.
 (   )  Otherwise I won't receive our mail.
--"-"----------------------------------------
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 29 Sep 2003 17:09:18 +0200

> I don't think we should state any voting results during the

What's the URL again?

Ciao

Dominik ^_^  ^_^

---

From: Uwe Pross <[email-masked]>
Date: Mon, 29 Sep 2003 17:34:38 +0200

Hi there,

> > I don't think we should state any voting results during the

http://www.fvwm.org/logo-competition/logos/voting/

You should see a page which shows a link to 

http://www.tu-chemnitz.de/~uwp/fvwm-web/logo-competition/logos/voting

where voting can be done. I could make an automatic
redirection if it is wanted.

Cheers, Uwe
 (   )  Otherwise I won't receive your mail.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 29 Sep 2003 17:56:54 +0200

The page looks good.  I see one typo:

> for logos taking part on the
                        ^
                  in ___|

And I'd use the medium or dark gray tone as a default background.

I'm not sure whether we should vote in two stages or not.  With
108 logos, there may be too few votes per logo on average.
Perhaps we should weed out 80% to 90% of the logos in the first
stage, then elect the best of the remaining logos in a second
stage.

I have an idea how to reduce the chance of cheating:  We may
require that everybody votes for at least 20 logos.  Cheating will
become very tedious.  And since it is extremely unlikely to have
two voting sheets with exactly the same votes, it is easy to
discover cheaters with identical votes.

Ciao

Dominik ^_^  ^_^

---

From: Uwe Pross <[email-masked]>
Date: Mon, 29 Sep 2003 18:24:14 +0200

Hi there,

> > for logos taking part on the

Fixed.

> And I'd use the medium or dark gray tone as a default background.

Actually there is no default  background  at  all.  Whatever
your browser settings are will be used. If we use background
settings we have to set all foregrounds (text and links)  as
well.  I kept the page simple on purpose but if you think it
should be more fancy that would be no problem. 

> stage, then elect the best of the remaining logos in a second

For me at does not matter. There would not be major  changes
to  the current pagem, I guess. For the second stage I would
keep the page and display just the remaining logos. 

It might be too much efford for the voters to vote twice.

> discover cheaters with identical votes.

If you want to cheat you would like to vote for one logo not
for  20.  So  if you have 100 email addresses you would vote
each time for one logo and distribute your  remaining  votes
over  the  remaining  107 logos. This would ensure that your
favorite logo got 100 votes and the other logos got  1  vote
on average. 

I think we cannot avoid cheating at all.  After  the  voting
time  we may look through the votes and see if there are any
suspicions. We may check domains and  user  names.  But  the
question  is if we find any suspicions what can we do. Shall
we delete this votes? What if two people have similar  email
addresses? 

Cheers, Uwe

---

From: Uwe Pross <[email-masked]>
Date: Mon, 29 Sep 2003 21:45:53 +0200

Hi there,

On 29 Sep 2003 at 18:24:14 +0200, Uwe Pross wrote:

> > I have an idea how to reduce the chance of cheating: We
> > may require that everybody votes for at least 20 logos. 
> > Cheating will become very tedious. And since it is
> > extremely unlikely to have two voting sheets with
> > exactly the same votes, it is easy to discover cheaters
> > with identical votes.
> 
> on average.                                         ^^^
                                      _________________|
            about 20 votes on average               

Cheers, Uwe

---

From: [email-masked]
Date: Tue, 30 Sep 2003 00:51:43 +0200

> should be more fancy that would be no problem. 

It's just that some of the logos don't look good on the white
background I got.  Nothing really important.

> It might be too much efford for the voters to vote twice.
 
What do the others think?

> favorite logo got 100 votes and the other logos got  1  vote

Sure.  It just becomes more tedious to cheat.  We also might
restrict voting to the mail addresses subscribed to the mailing
lists, but I am reluctant to do so.

> I think we cannot avoid cheating at all.

You probably mean we can not avoid cheating completely.  Being
unable to prevent it at all would be a sad prospect :-)

> After  the  voting
> suspicions. We may check domains and  user  names.

(and a few other things we should not announce now)

> But  the question is if we find any suspicions what can we do. Shall

I'd add a comment to the voting rules that the voting committee
(whoever that is) may reject votes if there is strong evidence
that they are forged.  We can think about the details later.  The
important part is to collect as many data as possible right from
the start (i.e. the complete mails should be archived).

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 30 Sep 2003 03:25:28 +0300

> What do the others think?

Well, I voiced my opinion previously, and I can't find anything better
yet. :)

> Sure.  It just becomes more tedious to cheat.

It may be a good idea to require everybody to choose 20 logos or more.
But the opposite side is that with this system it is pretty guaranteed
some mediocre logo wins. This is because, (a plausible example) the
really best logo (that would win with a usual give-a-mark-to-every-logo-
and-sum-marks system) is something bright, it is never understood by
everyone. So probably 50% of users place the best logo in the positions
1-4, 20% place it in 5-20 and 30% place it in 21-100. It is more than
guaranteed that there are several mediocre logos that are placed in
positions 5-20 by 70% of voters, they win because voters are required to
choose something at all (at least 20 (!) of these).

The 2 stage system usually solves this mediocre-wins problem, but only
if you don't require a minimal number of choosen logos again, otherwise
we end up with the same results. However if we already go with 2 stages,
then I would go for the "best artists first, their logos second" system.

In the end, any voting system that is thought throughly (even a one
stage system) is ok by me.

> unable to prevent it at all would be a sad prospect :-)

Well, the problem arises on the internet only where you don't see a voter
and his ID card (supposing everyone has the unique ID card with a photo).

On the internet, the best system to avoid cheeting seems to be to vote a
committee (10-25 trusted people) and let it to vote actual things. :)

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Mon, 29 Sep 2003 20:53:11 -0400

> http://www.fvwm.org/logo-competition/logos/voting/

Feedback:

Since you are asking for an email address, the first page
should be very clear about the email address being securly stored and
NEVER being made visible to anyone else.

It should be clear how long the response will take.
Mine took a couple of minutes.  In the mean time, the blinking
drove me nuts.

The id I got was way longer than the input field I pasted it into.
It worked, but it didn't seem right.

Here is a fix for the wording after the vote:

 Your vote has been counted.
 Thank you for taking part in the fvwm logo competition voting.

I didn't want to pick 20 logos.  I only voted for 2.
(Not that there weren't 20 good ones.)

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 30 Sep 2003 10:10:56 +0200

> stage system) is ok by me.

I'm fine with 2 stages, but I don't like to vote for the best
artist first.  Well, obviously the "at least n votes" approach
won't take us very far in the second stage.

> committee (10-25 trusted people) and let it to vote actual things. :)

Which defies the ideas behind fvwm development :-(

Ciao

Dominik ^_^  ^_^

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 29 Sep 2003 14:53:33 +0200

> I don't think we should state any voting results during the

I tried it, it seems to work fine.

Regards, Olivier

---

From: Uwe Pross <[email-masked]>
Date: Tue, 30 Sep 2003 17:50:25 +0200

Hi there,

On 30 Sep 2003 at 00:51:43 +0200, [email-masked] wrote:

> You probably mean we can not avoid cheating completely.
> Being unable to prevent it at all would be a sad prospect
> :-)

;-) Right.

I think forcing voters to vote for at least 20 logos might
lead to wrong results. If I like only 3 logos I would like
vote for 3 logos only. So if I have to vote for 20 logos I
would spread randomly my other 17 votes over the remaining
logos, which means that I have to vote for logos I don't
like.

> > After the voting time we may look through the votes and
> > see if there are any suspicions. We may check domains
> > and user names.
> 
> > But the question is if we find any suspicions what can
> > we do. Shall we delete this votes? What if two people
> > have similar email addresses?
> 
> I'd add a comment to the voting rules that the voting
> committee (whoever that is) may reject votes if there is
> strong evidence that they are forged.

I'll do that.

> We can think about the details later.  The important part
> is to collect as many data as possible right from the
> start (i.e. the complete mails should be archived).

Actually there are not any mails. Currently the voter is
asked to state its email address only.

I store some further information about the voting access
(IP, Browser, Hostname, ..) which may be used to detect
cheating.

Cheers, Uwe

---

From: Uwe Pross <[email-masked]>
Date: Tue, 30 Sep 2003 18:13:29 +0200

Hi there,

> NEVER being made visible to anyone else.

I changed it to:

  Your mail address is only used to send you an
  authorization key to avoid voting multiple times. E-mail
  addresses are stored securly and are NEVER used to any
  other purpose than sending you your authorization key for
  fvwm logo competition voting.

> It should be clear how long the response will take.  Mine
> took a couple of minutes.  

This is quite difficult to say. Actually the mail is sent to
you immediately. So any delay should be caused by the smtp
agents. 

> In the mean time, the blinking drove me nuts.

;-) I know. This is only for the testing phase.

Fixed.

Fixed.

> (Not that there weren't 20 good ones.)

That's my point too.

Thanks for that feedback.

Cheers, Uwe

---

From: Alex Wallis <[email-masked]>
Date: Wed, 01 Oct 2003 02:01:33 +0930

> Thanks for that feedback.

I would prefer there was a link or button beside each logo individually
on the normal pages that display each logo full size. The smaller
thumbnails confuse me, and having to vote for too many logos at once,
seems too time consuming and a bit of a hassle. This would therefore
tend to discourage some people from providing the very input you want.

It should be possible to just vote for one or two logos you like, or
more, up to a certain specified limit (say 20 total).

Just my humble opinion of course.

Alex

---

From: Alex Wallis <[email-masked]>
Date: Wed, 01 Oct 2003 02:13:05 +0930

> Just my humble opinion of course.

As an afterthought, I think having a "Dont like!" button as well, may be
a helpful guide too. It may help to weed out the logos users definately
do not want.

All votes for and against should remain purely voluntary of coure.

Alex

P.S. The problem then is how to authenticate the user's email address,
which may be resolved by adding it as a parameter to enter the logo
competition pages, since all submissions are now closed.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 30 Sep 2003 19:16:20 +0200

> > tend to discourage some people from providing the very input you want.

And if everybody thinks like this, we have 200 votes in total
distributed amongst 108 logos.  With this many logos, we need a
lot of votes.  Otherwise the outcome of the election is more or
less random.

> a helpful guide too. It may help to weed out the logos users definately

That's exactly what this voting mode is meant to prevent.  You
should vote for logos you like, not vote against logos you want to
prevent.

Ciao

Dominik ^_^  ^_^

---

From: Dan Espen <[email-masked]>
Date: Tue, 30 Sep 2003 13:33:18 -0400

> you immediately. So any delay should be caused by the smtp

It took a few minutes, how about:

  An  automated email should reach you  in a  few minutes assuming no
unusual network delays.

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 1 Oct 2003 00:02:02 +0300

The logo voting process seems to work ok.

I received an email in 10 seconds.

On the opposite hand, I spent a lot of time comparing logos and thinking
which one would be the best for our WM.

Suggestions:

* Use #808080 bg or darker, do not rely on the user's browser default
(which is usually white).

* Use [email-masked] as the From address, not [email-masked].

* Add some words on being responsible when voting, so we don't end up
with a random winner logo. :)

Regards,
Mikhael.