Subject: Using Unicode's Private Use Are for additional presentation forms

From: Marcus Lundblad <[email-masked]>
Date: Sun, 7 Sep 2003 21:23:12 +0200 (CEST)

I was looking through some documentation on the web.
The program Mutt has assigned some part of the private use area for
contextual presentation forms and ligatures not present in
"normal" Unicode.
For example U+E600 to U+E6FF contains Arabic presentation forms not
defined in the Unicode standard (as compatibility characters).
This is mostly (as far as I can see) for charaters used in languages
normally written in other scripts (Khazak,Uzbek etc.) and unusual forms.
This range could easily be supported in FVWM by exending some lookup
tables.
I would also like to add support for Indic scripts (Mutt has defined some
ligature ranges for those scripts also), but this will require some more
research.

So, what do you think, is it a good or bad idea to add the U+E600 range?
This assumes the user has a font with the correct characters in this range
(such as Mutt's "clearlyu"). Maybe this is an acceptable assumption (after
all these Arabic characters is probably quite rare).

//Marcus

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 8 Sep 2003 09:34:41 +0200

Sorry, I have no opinion on this topic.  But I wanted to say that
your mail only berly passed my manual mail filter (the one in my
head).  The subject sounds like spam at the first glance ;-)

Ciao

Dominik ^_^  ^_^

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 10 Sep 2003 11:11:31 +0200

> all these Arabic characters is probably quite rare).

I do not know. I will prefer that fvwm respects the standard and it
seems strange to me to add support for one font (there is a lot of ttf
fonts which cover various part of the unicode).

Not also that we are in feature freeze. I will be very happy to see a
test/purify/text_rendering.fvwmrc. Say a big menu which may look like
(very informal): 

CopyMenuStyle * fooxyz
MenuStyle fooxyz Font "a_fooxyz_font"
...

AddToMenu TestTextRendering "Test Text Rendering" Title
+ "Test Arabic font:foo, enc:xyz " Popup ArabicTestfooxyz
...

AddToMenu ArabicTestfooxyz "ArabicTestfooxyz" Title
+ "some more or less random string"
+ "some more or less random string"
+ ...

CopyMenuStyle * fooxyz
ChangeMenuStyle fooxyz ArabicTestfooxyz
...

Of course some part of this big menu may works only with
the good locale (and this may appear on the label of the menus).

Finally, I've noted the following problem with "hot key":

My locale is "fr_FR" and I want to display a menu with UTF-8
labels: I used

CopyMenuStyle * xdg
MenuStyle xdg Font "StringEncoding=UTF-8:xft:piselsize=10"
MenuStyle xdg AutomaticHotkeys

AddToMenu test "Test" Title
+ "Ãconomiseur d'Ã©cran" Exec xscreensaver-demo --crapplet

ChangeMenuStyle xdg test

So the label in iso-8859-15 is "Économiseur d'écran".
The Hot-key underline is too big: it is under  "Écon".

Regards, Olivier

---

From: Marcus Lundblad <[email-masked]>
Date: Wed, 10 Sep 2003 22:37:17 +0200 (CEST)

> fonts which cover various part of the unicode).

Yes, that's correct. My intention was to see what Mutt's implentation is
based on (if there is more support behind (perhaps Pango..) ).

> the good locale (and this may appear on the label of the menus).
Yes, I will take a look at doing this.
> + "�conomiseur d'écran" Exec xscreensaver-demo --crapplet
> 
> ChangeMenuStyle xdg test
> 
> So the label in iso-8859-15 is "�conomiseur d'�cran".
> The Hot-key underline is too big: it is under  "�con".
> 
I tried hot-keys under UTF-8 (using chacters outside 7-bit ASCII).
It displays correctly, so probably something goes wrong at the conversion
between different locales.
But using the hot-keys doesn't work, even in UTF-8 (could you use the
hot-key you defined in ISO 8859-15?).

//Marcus