Subject: bug-report + question

From: Claudius Haecker <[email-masked]>
Date: Mon, 22 Sep 2003 21:17:48 +0200

Hi,
I got the following errors. I don't know what they mean.
But btw. can you tell me how to make windows (especially the button bar) 
always stay on top,
as the commands Layer and StaysOnTop have no effect.
regards
Claudius

 fvwm2 -version
FVWM version 2.4.8 compiled on Oct 14 2002 at 20:55:44
with support for: ReadLine, Stroke, XPM, GNOME WM hints, Shape, SM, 
Multibyte, Xinerama

[FVWM][GetWindowSizeHints]: <<WARNING>> Fortschritt des Kopiervorgangs 
window 0x
34000e1 has broken (max_height) size hints
Please send a bug report to the application owner,
        you may use [email-masked] as a reference.
hint override = 0
flags = 23a
min_width = 485, min_height = 237, max_width = 32767, max_height = 233
width_inc = 211, height_inc = 11
min_aspect = 1087298704/135282128, max_aspect = 145/-1073748728
base_width = 1083467545, base_height = 135282128
win_gravity = 1

[FVWM][GetWindowSizeHints]: <<WARNING>> Fortschritt des Kopiervorgangs 
window 0x
34000e1 has broken (max_height) size hints
Please send a bug report to the application owner,
        you may use [email-masked] as a reference.
hint override = 0
flags = 23a
min_width = 485, min_height = 237, max_width = 32767, max_height = 233
width_inc = 211, height_inc = 11
min_aspect = 1087298704/135282128, max_aspect = 145/-1073748728
base_width = 1083467545, base_height = 135282128
win_gravity = 1

[FVWM][GetWindowSizeHints]: <<WARNING>> KDE - Konqueror window 0x2a037e2 
has bro
ken (max_width) size hints
Please send a bug report to the application owner,
        you may use [email-masked] as a reference.
hint override = 0
flags = 23f
min_width = 579, min_height = 223, max_width = 578, max_height = 222
width_inc = -1073750936, height_inc = -1073751240
min_aspect = 1084354210/137746552, max_aspect = 223/579
base_width = 1088199824, base_height = 1088199824
win_gravity = 1

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 23 Sep 2003 04:03:02 +0300

> I got the following errors. I don't know what they mean.

You may report them to the authors of "Fortschritt des Kopiervorgangs"
and Konqueror applications like the message says. These applications
use invalid hints for their windows.

> But btw. can you tell me how to make windows (especially the button
> bar) always stay on top, as the commands Layer and StaysOnTop have no
> effect.

  Style FvwmButtons StaysOnTop, NeverFocus

Layer (both command and Style option) works too, see the man page for
the correct syntax.

The [email-masked] list is the best place to ask questions.

Regards,
Mikhael.