Subject: Notification: incoming/1080

From: [email-masked]
Date: Mon, 22 Sep 2003 14:54:34 -0500

FVWM Bug Tracking notification

new message incoming/1080

Message summary for PR#1080
	From: [email-masked]
	Subject: problem with fvwm 2.4.15 and NoIcon
	Date: Mon, 22 Sep 2003 14:54:33 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Mon Sep 22 14:54:33 2003
Date: Mon, 22 Sep 2003 14:54:33 -0500
From: [email-masked]
To: [email-masked]
Subject: problem with fvwm 2.4.15 and NoIcon

Full_Name: Ned Danieley
Version: 2.4.15
CVS_Date: 
OS: Solaris 9
X_Server: sun openwin
Submission from: (NULL) (152.3.148.1)

when I upgraded from 2.2 to 2.4.15, I discovered that xcalc doesn't show up
in the icon manager. a look with 'ps' shows that's it's running, and
playing with my .fvwm2rc led me to find out that having NoIcon in my style
is what's screwing things up. if I remove the NoIcon, xcalc shows up in the
icon manager, but with it in, it doesn't.

Style "xcalc"       StartIconic, NoIcon, MinOverlapPlacement

doesn't work, but

Style "xcalc"       StartIconic, MinOverlapPlacement

does. I'm using the xcalc that came with openwin.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 23 Sep 2003 03:54:16 +0300

> does. I'm using the xcalc that came with openwin.

You didn't say which "icon manager" you use. FvwmIconMan, FvwmIconBox,
FvwmWinList? Maybe FvwmTaskBar? I don't see in their man pages that there
is a way to configure them to show only non-iconic windows; but it is
possible to ignore some, for example using *FvwmIconMan: DontShow.

Anyway, I can't reproduce the problem with 2.4.16 without configuration,
your first Style line and any of the mentioned modules.

Do you see xcalc in WindowList (by default Alt-Tab invokes it).

Please create a minimal configuration file (consisting of some Style,
Exec, Module and module configuration lines) that shows this problem.

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 24 Sep 2003 00:01:53 +0300

This problem was fixed in 2.4.16, and Ned confirmed this.

Regards,
Mikhael.