Subject: Re: vim and 2.5.7 crash

From: Dan Espen <[email-masked]>
Date: Fri, 19 Sep 2003 21:28:16 -0400

Eduardo Alvarez <[email-masked]> writes:
> As requested by Dan Espen, I am sending to you a core dump of fvwm 2.5.7
> which crashes when the following happens:
> 
> I call 'aterm -name vim -e vim' either via a different aterm or by a
> keyboard shortcut, as so:
> 
> Key v  A  SCM Exec exec aterm -name vim -e vim
> 
> The interesting thing is, if I call it, then immediately quit, nothing
> happens.  However, if I  edit a buffer, whether I save it or not, fvwm
> crahses with a signal 11, dumping core.  It is noted that, if I open an
> aterm an THEN call vim, there's no problem.  Also, other applications
> called similarly (eg: aterm -name mutt -e mutt), cause no problem on exit.
> 
> Thank you very much for any help you might provide.

Sorry, I guess I wasn't clear enough.
We need a stack trace.  Core files are usually only useful on
the system they were generated on.

To get a stack trace:

cd to directory where core file is.
get full path name to fvwm executable by typing

which fvwm

then run gdb supplying these 2 values:

gdb full-path-fvwm name-of-core-file

after gdb is done starting, type "where".

That should print a stack trace (about 10 lines).

Mail that.

-- 
Dan Espen                           E-mail: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Eduardo Alvarez <[email-masked]>
Date: Fri, 19 Sep 2003 21:39:58 +0000

> That should print a stack trace (about 10 lines).

No, my mistake.  I should've read more carefully.  here goes the stack
trace.  Bug me if I didn't do it right :P

-- 
Eduardo Alvarez			http://www.great-atuin.net/~punga
						(offline, at the moment)
"Stercus, stercus stercus, moriturus sum"
    			-- Rincewind the Wizzard, "Interesting Times"

---

From: Dan Espen <[email-masked]>
Date: Fri, 19 Sep 2003 21:57:59 -0400

Eduardo Alvarez <[email-masked]> writes:
> > We need a stack trace.
> #0  0x80a660a in XMapRaised ()
> #1  0x8112c00 in ?? ()
> #2  0x80743ea in XMapRaised ()
> #3  0x80745e2 in XMapRaised ()
> #4  0x806fe83 in XMapRaised ()
> #5  0x80700e2 in XMapRaised ()
> #6  0x8070170 in XMapRaised ()
> #7  0x8084849 in XMapRaised ()
> #8  0x804d491 in XMapRaised ()

Well, that's not going to help.
The stack should lead back to the main.

I don't have aterm to try this myself.
If no one else picks this up, I'll see about installing aterm.
It didn't cause any problem for me
when I tried xterm instead of aterm.

---

From: Jason L Tibbitts III <[email-masked]>
Date: 19 Sep 2003 21:00:50 -0500

>>>>> "DE" == Dan Espen <[email-masked]> writes:

DE> Sorry, I guess I wasn't clear enough. We need a stack trace.  Core
DE> files are usually only useful on the system they were generated
DE> on.

FYI, a nice 15000-line message containing a core file was sent to the
list, but the filters bounced it to me for approval and I don't think
I'll be sending it on.

 - J<

---

From: Dan Espen <[email-masked]>
Date: Sat, 20 Sep 2003 14:15:30 -0400

Eduardo Alvarez <[email-masked]> writes:
> 
> --AqsLC8rIMeq19msA
> Content-Type: text/plain; charset=us-ascii
> Content-Disposition: inline
> 

I've installed aterm 0.4.2.

I started an aterm, then typed:

aterm -name vim -e vim xxx

That gave me a new window running vim.
I typed a few characters, then saved the file and exited with ZZ.

No problem.

I notice that aterm can be compiled with "Afterstep support".
When I configured aterm, it didn't use that option.

I'm not sure if that would be shown with --help.  Here's what I get:

[dane@home-1 tmp]$ aterm --help

Usage v0.4.2 :(XPM,transparency,no fading,NeXT scrollbar,.Xdefaults)
aterm [options] [-e command args]

As far as the stack dump showing meaningless information,
all I can suggest for that is to build fvwm yourself if you
haven't done that already.