Subject: Bugfix for StickyAcrossPages

From: Robert Wittek <[email-masked]>
Date: Wed, 6 Aug 2003 15:51:27 +0200

Hi,

I think I've found a bug concerning the handling of the
sticky-attributes.  After restarting fvwm, windows with the
attribute StickyAcrossPages are also StickyAcrossDesks it they are
on a desk > 0.

I have attached a patch of which I think that it fixes this bug.

Cheers,

Robert

? stickyAcrossPagesFix.patch
Index: ChangeLog
===================================================================
RCS file: /home/cvs/fvwm/fvwm/ChangeLog,v
retrieving revision 1.2401
diff -u -u -r1.2401 ChangeLog
--- ChangeLog	6 Aug 2003 09:11:36 -0000	1.2401
+++ ChangeLog	6 Aug 2003 13:45:56 -0000
@@ -1,3 +1,8 @@
+2003-08-06  Robert Wittek  <[email-masked]>
+
+	* fvwm/add_window.c (AddWindow): Fixed wrong initialization of
+	int stick_desk.
+
 2003-08-06  olicha  <[email-masked]>
 
 	* fvwm/ewmh.c (EWMH_WindowInit):
Index: fvwm/add_window.c
===================================================================
RCS file: /home/cvs/fvwm/fvwm/fvwm/add_window.c,v
retrieving revision 1.355
diff -u -u -r1.355 add_window.c
--- fvwm/add_window.c	23 Jul 2003 12:16:53 -0000	1.355
+++ fvwm/add_window.c	6 Aug 2003 13:46:01 -0000
@@ -2421,7 +2421,7 @@
 		int stick_desk;
 
 		stick_page = is_window_sticky_across_pages(fw);
-		stick_desk = is_window_sticky_across_pages(fw);
+		stick_desk = is_window_sticky_across_desks(fw);
 		if ((stick_page &&
 		     !IsRectangleOnThisPage(&fw->frame_g, Scr.CurrentDesk)) ||
 		    (stick_desk && fw->Desk != Scr.CurrentDesk))

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 7 Aug 2003 08:52:29 +0200

> I have attached a patch of which I think that it fixes this bug.

Thanks for the patch.  I have applied it to the development tree.

Bye

Dominik ^_^  ^_^
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]