Subject: Superimposing characters and non-UTF-8 locale

From: Marcus Lundblad <[email-masked]>
Date: Wed, 9 Jul 2003 12:03:41 +0200 (CEST)

Now it should work to use a Unicde font in a non-UTF-8 locale (I tried
using "C" and "sv_SE") and use composing characters (tried with the Arabic
strings Nadim supplied).

I tested this with normal and rotated text using locales "C", "sv_SE" and
"sv_SE.UTF-8".

Nadim, do some of the Arabic combining characters have there equivalent in
ISO-8859-6?
Could you supply me with some strings in ISO-8859-6, I would like to test
it.

Thank you in advance.

//Marcus 

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 9 Jul 2003 20:05:35 +0300

> Could you supply me with some strings in ISO-8859-6, I would like to test

You may run "iconv -f utf-8 -t iso8859-6" to convert from any encoding to
any. Another way to get some strings is: "env LANG=ar_JO.iso8859-6 date".

Regards,
Mikhael.

---

From: Nadim Shaikli <[email-masked]>
Date: Wed, 9 Jul 2003 11:35:27 -0700 (PDT)

--- Marcus Lundblad wrote:
> Now it should work to use a Unicde font in a non-UTF-8 locale
> (I tried using "C" and "sv_SE") and use composing characters
> (tried with the Arabic strings Nadim supplied).
> 
> I tested this with normal and rotated text using locales "C",
> "sv_SE" and "sv_SE.UTF-8".

Great, let me see if your changes are in the 0709 snapshot.  Yup
they are.

BTW: on some systems I get the following error,

 cd . \
   && CONFIG_FILES=Makefile CONFIG_HEADERS= /bin/sh ./config.status
 creating Makefile
 ld.so.1: make: fatal: librt.so.1: version `SUNW_1.2' not found (required by
file make)
 Killed

and on others I don't - thought it might be of interest to add that
check as well into configure possibly.

Problematic - uname -a : SunOS pez 5.7 Generic_106541-15 sun4u
OK          - uname -a : SunOS pod 5.8 Generic_108528-15 sun4u

Marcus, I'm confirming that your changes in fact work :-)  Well done !!!

> Nadim, do some of the Arabic combining characters have there
> equivalent in ISO-8859-6?  Could you supply me with some strings
> in ISO-8859-6, I would like to test it.

Its a long story, but don't bother with ISO-8859-6 (its not usable),
you won't see shaping.

In short, per

  http://czyborra.com/charsets/iso8859.html#ISO-8859-6

   ''This fixed font is not well-suited for text display.
     Each Arabic letter occurs in up to four (2^2) presentation
     forms: initial, medial, final or separate [and 8859-6 is
     missing all except "separate"].''

All of our work on Arabeyes.org have been strictly UTF-8.

Regards,

 - Nadim

__________________________________
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Danek Duvall <[email-masked]>
Date: Wed, 9 Jul 2003 15:54:28 -0700

On Wed, Jul 09, 2003 at 11:35:27AM -0700, Nadim Shaikli wrote:

>  ld.so.1: make: fatal: librt.so.1: version `SUNW_1.2' not found (required by file make)
>  Killed

Looks like you're using a make which was compiled on Solaris 8 and
requires symbols from the librt that was installed on that system.  If
you recompile your make on your S7 box, it should work fine on both S7
and S8 (and up).  Alternately, have one compiled for each OS, but that's
usually a waste of effort.  Or use /usr/ccs/bin/make.  :)

Danek