Subject: Notification: incoming/1064

From: [email-masked]
Date: Sun, 20 Jul 2003 18:36:13 -0500

FVWM Bug Tracking notification

new message incoming/1064

Message summary for PR#1064
	From: [email-masked]
	Subject: ChangeMenuStyle
	Date: Sun, 20 Jul 2003 18:36:12 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Sun Jul 20 18:36:12 2003
Date: Sun, 20 Jul 2003 18:36:12 -0500
From: [email-masked]
To: [email-masked]
Subject: ChangeMenuStyle

Full_Name: Khosrow Hassani
Version: 2.4.16
CVS_Date: 
OS: Debian woody
X_Server: Xfree86
Submission from: (NULL) (132.206.9.219)

ChangeMenuStyle only affects the menu if the assignment is issued after the
defenition of the meny. you have to first define a menu and them assigne a
style to it using ChangeMenuStyle. this is probably due to the way the
program works. in my mind, the program should first read the whole
configuration file (fvwm2rc, post.hook,...) and then does the assignments.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Jul 2003 09:43:29 +0200

> configuration file (fvwm2rc, post.hook,...) and then does the assignments.

Well, you can't change the settings of something that does not
exist.  Processing configuration commands out of order is not a
good idea because fvwm does not have a real "configuration file".
All the commands in there can be issued at any time in any order,
and the order does matter.

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 22 Jul 2003 12:10:01 +0300

> configuration file (fvwm2rc, post.hook,...) and then does the assignments.

If you put your ChangeMenuStyle command into StartFunction then the order
will not matter. StartFunction (and InitFunction) is designed to be
executed after the entire initial configuration is read and processed.

  AddToFunc StartFunction
  + I ChangeMenuStyle menu-that-will-be-defined-below ActiveColorset 6

Regards,
Mikhael.