Subject: Notification: incoming/1065

From: [email-masked]
Date: Mon, 21 Jul 2003 11:33:37 -0500

FVWM Bug Tracking notification

new message incoming/1065

Message summary for PR#1065
	From: [email-masked]
	Subject: Remove swallowed app / icon limitation from FvwmButtons
	Date: Mon, 21 Jul 2003 11:33:36 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Mon Jul 21 11:33:37 2003
Date: Mon, 21 Jul 2003 11:33:36 -0500
From: [email-masked]
To: [email-masked]
Subject: Remove swallowed app / icon limitation from FvwmButtons

Full_Name: Marc Jackisch
Version: 2.5.6
CVS_Date: 
OS: Linux 2.4.21-ck3
X_Server: XFree86 4.3.0
Submission from: (NULL) (217.82.22.86)

Somewhere in the 2.5 series, a limitation has been introduced, which
prevents a button in FvwmButtons to get an icon AND swallow an
application.

This is purely a check done while reading the config. (Namely in parse.c,
lines 928 and 1028 as of 2.5.7 sources.) Removing this check does not seem
to have any adverse effects. Thus, I guess that this limitation is just
artificial. However, sometimes this kind of configuration is necessary to
make a button "fit right in", if the application uses shaped windows.

Here's an example from my config, which only works after a little source
screwing:

*RightButtons(Icon new_button_base.xpm Swallow(UseOld) "xeyes123" \
              'Exec xeyes -bg SteelBlue2 -title xeyes123 &',\
              Action 'Exec "jpview" jpview &')

(Swallowed xeyes over icon background starting an image viewer on click.)

Note: though I have not installed it yet, the limitation is still present
in 2.5.7 from reading the source.

Please restore the previous functionality, where this was possible.

Best regards,
Marc.

PS: Obvious: remove the "_dontyouspamme" from the mail address before use
;-)

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Jul 2003 09:59:03 +0200

> make a button "fit right in", if the application uses shaped windows.

Please explain what the problem is.  I removed this possibility
because (a) it was never intended to work and (b) it did indeed
not work.  The code never handled sizing of the button and
placement of the icon correctly.

> Please restore the previous functionality, where this was possible.

Bye

Dominik ^_^  ^_^