Subject: title or name in FvwmWindowMenu?

From: Richard Lister <[email-masked]>
Date: Wed, 02 Jul 2003 19:13:55 -0400 (EDT)

Mikhael

In FvwmWindowMenu I noticed you changed the pattern type "title" to
"name". Why is this? I think it makes it consistent with
FvwmIdent output, but inconsistent with FvwmIconMan type=pattern
options.

People tend to think in terms of "xterm __titles__" and window
manager "__title__bars", etc, so I think using "name" is a little
confusing, e.g. xterms set their title with -T, and icon name with -n.

What is official X terminology on the issue?

Should we support both?

Cheers
Ric

Richard J Lister
Dept of Neuroscience
Georgetown University Medical Center
http://cns.georgetown.edu/~ric/
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 3 Jul 2003 01:32:47 +0000

> FvwmIdent output, but inconsistent with FvwmIconMan type=pattern

I thought it is more important to make it consistent with FvwmIdent,
since this is what people use to find names.

Besides, we have now (well, I added these after the change above):

  $[w.name] $[w.iconname] $[w.class] $[w.resource]

> What is official X terminology on the issue?

We use internally .name and .icon_name fields in the code.
This is also the standard terminology in X:

  XA_WM_NAME XA_WM_ICON_NAME

> Should we support both?

We may if you need this.

Do you want to help me to simplify FvwmWindowMenu by using ModuleConfig
and PageInfo trackers (and WindowList tracker in the future)?

Do you want to add more functionality (see WindowList command for hints)?
Additional features may also include window groups arranged in submenus.

Regards,
Mikhael.

---

From: Richard Lister <[email-masked]>
Date: Wed, 02 Jul 2003 21:53:10 -0400 (EDT)

Mikhael Goikhman <[email-masked]> wrote
on Thu, 3 Jul 2003 01:32:47 +0000:
>
> Subject: Re: title or name in FvwmWindowMenu?
>

All of that makes good sense.

> We may if you need this.

Don't _need_ it :-)  We could make 'title' a synonym for 'name',
but that could be even more confusing for users.

> and PageInfo trackers (and WindowList tracker in the future)?

Sure. I've not been paying attention to recent developments
due to pressure of work: when will trackers be ready to use?
I always approve of simplifying code :-)

> Additional features may also include window groups arranged in submenus.

Absolutely. Maybe in a few weeks when work relaxes a bit.

Cheers
Ric

Richard J Lister
Dept of Neuroscience

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 3 Jul 2003 02:35:26 +0000

> due to pressure of work: when will trackers be ready to use?

All trackers except for WindowList are usable now.

WindowList tracker is the largest one, it should optionally track
all window flags/names/stack list/icon files and probably more.

Regards,
Mikhael.

---

From: Richard Lister <[email-masked]>
Date: Thu, 03 Jul 2003 10:07:51 -0400 (EDT)

> all window flags/names/stack list/icon files and probably more.

Cool. I'll take a look in a couple of weeks when work slacks off
a bit.

Cheers
Ric

Richard J Lister
Dept of Neuroscience