Subject: CVS malu: Removed "F" prefix on some files

From: FVWM CVS <[email-masked]>
Date: Sun, 06 Jul 2003 05:01:55 -0500

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	malu	03/07/06 05:01:55

Modified files:
	libs           : Makefile.am Flocale.c FBidi.h FBidi.c 
	.              : ChangeLog 
Added files:
	libs           : CombineChars.h CombineChars.c BidiJoin.h 
	                 BidiJoin.c 
Removed files:
	libs           : FCombineChars.h FCombineChars.c FBidiJoin.h 
	                 FBidiJoin.c 

Log message:
Removed "F" prefix on some files

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked]
Date: Sun, 6 Jul 2003 14:15:54 +0200

> Removed "F" prefix on some files

Thanks.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked]
Date: Sun, 6 Jul 2003 15:29:27 +0200

On Sun, Jul 06, 2003 at 03:00:46PM +0200, Marcus Lundblad wrote:
> Bitte :-)
> I was the one guilty of decalaring a variable after a statement in a
> block.

> But I'm aware that this is not correct C. It was a mistake. I'm surprised
> that could compile. (I'm using gcc 3.3), is this a bug in gcc?

I love gcc :-P

> That should only work in C++, shouldn't it?

It's clearly not C and should not compile.

Bye

Dominik ^_^  ^_^

---

From: Marcus Lundblad <[email-masked]>
Date: Sun, 6 Jul 2003 15:00:46 +0200 (CEST)

Bitte :-)

//Marcus

---

From: [email-masked]
Date: Sun, 6 Jul 2003 16:32:06 +0200

And while we are at nitpicking:  we all use 

  foo.[ch], foo.{c,h} or Fvwm*.c

sometimes in the ChangeLog.  This makes it hard to grep for
changes.  We should not use these wildcard constructs at all in
the ChangeLog.

Bye

Dominik ^_^  ^_^

---

From: Marcus Lundblad <[email-masked]>
Date: Sun, 6 Jul 2003 16:38:27 +0200 (CEST)

> > that could compile. (I'm using gcc 3.3), is this a bug in gcc?

Yep, it's nice.
> It's clearly not C and should not compile.

In fact. it's legal in C99.
http://www.cis.ohio-state.edu/cgi-bin/info/info/gcc,Mixed%20Declarations

Maybe we should state that code must compile in "C89 mode". A guess this
is not anymore standard in gcc (I'm pretty sure it was in gcc 2.x).
I guess -pendantic is a good idea to use.

//Marcus

---

From: Dan Espen <[email-masked]>
Date: Sun, 06 Jul 2003 10:46:38 -0400

> I guess -pendantic is a good idea to use.

That's declarations anywhere.

I think Dominik was objecting to block declarations.

I'm not sure of the exact status of block declarations.
I've been trying to find the standard with little luck.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Marcus Lundblad <[email-masked]>
Date: Sun, 6 Jul 2003 16:52:59 +0200 (CEST)

> I think Dominik was objecting to block declarations.

By "block declarations", do you mean to declare variables in any block,
not just at the top of a function?
Declaring variables in in arbitrary block (before "real" statements), I
think has been allowed in C since at lest C89.

//Marcus

---

From: Dan Espen <[email-masked]>
Date: Sun, 06 Jul 2003 11:02:58 -0400

> think has been allowed in C since at lest C89.

Sorry, I missed something in Dominik's original comment:

 * Do not write something like this:

     {
       int x;
       y = 2;
       int z;
     }

   This is not C and usually does not compile.

A block declaration would be:

int func()
  {
...
     {
       int x;
       int z;
       y = 2;
     }

---

From: [email-masked]
Date: Sun, 6 Jul 2003 21:17:37 +0200

On Sun, Jul 06, 2003 at 11:02:58AM -0400, Dan Espen wrote:
> > > > Maybe we should state that code must compile in "C89 mode".

Yes.

> > > A guess this

Yup.  Block declarations are fine.

Bye

Dominik ^_^  ^_^