Subject: Notification: incoming/1063

From: [email-masked]
Date: Sun, 20 Jul 2003 18:29:45 -0500

FVWM Bug Tracking notification

new message incoming/1063

Message summary for PR#1063
	From: [email-masked]
	Subject: AddToDecor
	Date: Sun, 20 Jul 2003 18:29:45 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Sun Jul 20 18:29:45 2003
Date: Sun, 20 Jul 2003 18:29:45 -0500
From: [email-masked]
To: [email-masked]
Subject: AddToDecor

Full_Name: Khosrow Hassani
Version: 2.4.16
CVS_Date: 
OS: Debian Woody
X_Server: Xfree86
Submission from: (NULL) (132.206.9.219)

It seems that after you set a ButtonStyle in a Decor, it is impossible to
change it with the single command AddButtonStyle. the onle way to do so is
to use AddToDecor. I'm not sure if this is a bug or just the worng logic in
the program. if, let say, I am not happy with one of the settings in a
decor I've created, I should be able to change that particular setting with
a single command without altering the decor. in other words, the command
issued later should override the setting in the decor. 

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Jul 2003 09:40:49 +0200

> issued later should override the setting in the decor. 

You are right, it *should* be possible.  The design of both, the
"Decors" and the "ButtonStyle" features is flawed and not as
flexible as it should be.  Both will be replaced by a better
mechanism in the future.

Bye

Dominik ^_^  ^_^