Subject: Re: FVWM: Icons from applications

From: Uwe Pross <[email-masked]>
Date: Thu, 5 Jun 2003 16:43:35 +0200

Hi there,

On 05 Jun 2003 at 16:01:20 +0200, Olivier Chapuis wrote:

> If you use "Style * Icon, NoIconOverride" you will see these
> icons in fvwm (when the window is iconified).

So, I do not use Icons - I am just interested in that many
mini icons are set properly. 

> > For  example  one  could  use it as mini icon. This would be
> > nice :-) 
> >
> 
> This is not possible in general ... This is done only if the
> application provide an EWMH icon (or/and mini-icon). GNOME2 and KDE>=2
> (and others) provide such icons but not the applications you mention
> (but galeon "2" ??)

This where no KDE2 nor GNOME2 applications. It was
gnome-1.2.7. So there must be any other mechanismen which
extracts this icon. Maybe the X-Server takes the big icon
and scales it down.

> Your feature request should be send at the good place :o)

So I would like to do that hereby ;-) 

If the big icon is available from an application can fvwm
scale it down and use it as mini icon? This would be a fancy
feature for winlist, FvwmWindowList and FvwmTaskBar.

Also, it would be nice if there is a way to extract this
icon from the application so that it can be used in the
menus :-) Possible that a tool does already exists to do
that.

Cheers, Uwe
-- 
  ,_,  Uwe Pross
 (O,O) mailto:[email-masked]
 (   ) http://www.tu-chemnitz.de/~uwp
=-"-"-================================
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 5 Jun 2003 15:57:47 +0000

> So I would like to do that hereby ;-) 

I think Olivier says that the right place is to ask the application
authors to add EWMH mini icon hint support. :)

> menus :-) Possible that a tool does already exists to do

Just my opinion on the subject. Most of the old applications set the
icon image that is very bad for my taste, I would like to use only the
icons that I define (using wm-icons icon sets), so IconOverride for me.

Unfortunately, IconOverride is even not strong enough for me, I would
like "Style * IconOverride" or at least "Style ** IconOverride" to mean
no application icons are ever used, even if no "Style pattern Icon" is
matched for a window, for such windows the icon defined in "Style * Icon"
should be used, not the application icon. Is this a bug or a feature?

Regards,
Mikhael.

---

From: Uwe Pross <[email-masked]>
Date: Thu, 5 Jun 2003 19:53:42 +0200

Hi there,

On 05 Jun 2003 at 15:57:47 +0000, Mikhael Goikhman wrote:

> I think Olivier says that the right place is to ask the
> application authors to add EWMH mini icon hint support. :)

:-) Maybe I got that wrong - but I have thought about many
applications so I cannot contact all the authors.

> Just my opinion on the subject. Most of the old
> applications set the icon image that is very bad for my
> taste, I would like to use only the icons that I define
> (using wm-icons icon sets), so IconOverride for me.

At the moment I do the same since there is no  other  choice
for  applications  which do not support EWMH mini icons. But
seeing that X-Win can obtain the mini  icons,  even  of  old
applications, made me think this would be a nice feature for
my fvwm setup. 
If I have some time maybe I have a look how  this  might  be
done. If fvwm already extracts the big icon it should not be
that hard to implement it. 

But I agree fully that both the icon and the mini  icon  has
to be overrideable by the config. 

Regards, Uwe