Subject: Bugs with transparency when used with various modules

From: Jason Gabler <[email-masked]>
Date: Mon, 16 Jun 2003 09:30:37 -0700

transparency + FvwmWinList:

I'm trying to use as much transparency as possible (similar to the Crystal 
theme), this includes using transparency with the FvwmWinList module.  I find 
that it often uses the wrong window names/titles in the list.  Sometimes an fvwm 
restart can fix this (most often not).  Fully login out of X and then back in 
sometimes fixes it (more often than an fvwm restart).  Basically the behavior is 
FvwmWinList will use window names of windows that have WindowListSkip in their 
Style to replace window names that sjould be in the list.  For the record, I've 
never seen this happen when not using transparency.  I've only seen this when 
Fvwm starts.

transparency with title bars:

Transparent title bars can often get locked into a particular portion of the 
background.  No matter where you place the windows they maintain them same 
portion of the background.  This can happen when Fvwm starts or after some use 
of the WM.

Transperent title bars sometimes show the given background color and do not do 
transparency.    This can happen when Fvwm starts or after some use of the WM.

transparency with FvwmButtons:

The same sticking image problem can happen as with title bars.

transparency with FvwmPager:

Not sure if this is transparency related, but sometimes FvwmPager just doesn't 
start or it wont swallow into Buttons.  I've never seen this w/o transparency.

My .fvwm2rc is attached as "fvwm2rc.jyg"

thanx,

jason

--
Jason Gabler
Advanced Systems Group - NERSC
Lawrence Berkeley National Laboratory
510-486-4752
###################################################################
# Paths and Module Loading
#####################################################################
ImagePath  /home/jason/Icons/16x16:/home/jason/Icons/misc:/home/jason/Icons/Desktop
ModulePath /usr/libexec/fvwm/2.5.7
Module FvwmBacker
Module FvwmTheme
Module FvwmWinList
Module FvwmButtons

####################################################################
# FvwmTheme
####################################################################
*FvwmTheme: Colorset 1 RootTransparent
*FvwmTheme: Colorset 2 RootTransparent, Tint #000000 5
*FvwmTheme: Colorset 3 RootTransparent, Tint #000000 15
*FvwmTheme: Colorset 4 RootTransparent, Tint #000000 20
*FvwmTheme: Colorset 5 RootTransparent, Tint #000000 25
*FvwmTheme: Colorset 6 RootTransparent, Tint #000000 30
*FvwmTheme: Colorset 7 RootTransparent, Tint #000000 35
*FvwmTheme: Colorset 8 RootTransparent, Tint #000000 40
*FvwmTheme: Colorset 9 RootTransparent, Tint #000000 45
*FvwmTheme: Colorset 10 RootTransparent, Tint #000000 50
*FvwmTheme: Colorset 12 Pixmap initialD_FDnFC.xpm
*FvwmBacker: Command (Desk *, Page * *) Exec fvwm-root /home/jason/Icons/Desktop/initialD_FDnFC.xpm
*FvwmBacker: Command (Desk 0) Colorset 12
*FvwmBacker: RetainPixmap

#####################################################################
# Stylizing 
#####################################################################
Colorset 1	Transparent
DefaultFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
AddToDecor a
	+ TitleStyle Height 15
	+ TitleStyle Colorset 7 -- flat
	+ ButtonStyle 8 Pixmap dotIconifyButton.xpm
	+ ButtonStyle 8 Inactive Pixmap dotIconifyButtonInactive.xpm
	+ ButtonStyle 6 Pixmap vertExpandButton.xpm
	+ ButtonStyle 6 Inactive Pixmap vertExpandButtonInactive.xpm
	+ ButtonStyle 4 Pixmap boxExpandButton.xpm
	+ ButtonStyle 4 Inactive Pixmap boxExpandButtonInactive.xpm
	+ ButtonStyle 2 Pixmap arrowResizeButton.xpm
	+ ButtonStyle 2 Inactive Pixmap arrowResizeButtonInactive.xpm
	+ ButtonStyle 1 Pixmap barMenuButton.xpm
	+ ButtonStyle 1 Inactive Pixmap barMenuButtonInactive.xpm
	+ ButtonStyle All -- UseTitleStyle
	+ ButtonStyle All -- flat

Style "b" UseDecor a
Style "*" UseStyle b

Style * 			ForeColor #AAAAAA, HilightFore #FFFFFF,
Style * 			ActivePlacement, SmartPlacement, 
Style *				StickyIcon, NoIcon, HiddenHandles, HandleWidth 2
Style "Fvwm*"       StaysOnTop, NoIcon, NoTitle, NoHandles, Sticky, WindowListSkip, BorderWidth 0
Style "*XMMS*"      NoTitle, NoHandles, NoIcon
Style "*XMMS P*"    NoIcon, NoTitle, WindowListSkip
Style "*XMMS E*"    NoIcon, NoTitle, WindowListSkip
Style "*clock*"     NoIcon, NoTitle, WindowListSkip
Style "*Buddy List*" Title Gaim
Style "*Gaim*"		MinOverlapPercentPlacement

####################################################################
# Suff to do at startup and restart
####################################################################
AddToFunc InitFunction
+   "I" Exec xhost -
+   "I" Exec aterm -iconic -C -bg black -fg \#FFFFFE -fn "-schumacher-*-medium-r-*-*-10-*-*-*-*-*-*-*" -sl 5000 -tr -trsb -sr -shading 65 -name console &
+   "I" Exec aterm -bg black -fg \#FFBBBB -fn "-schumacher-*-medium-r-*-*-10-*-*-*-*-*-*-*" -sl 5000 -tint red -tr -trsb -sr -shading 100 -name root -e su -&

#AddToFunc RestartFunction

####################################################################
# Functions
####################################################################
AddToFunc Move-or-Raise "I" Raise
+   "M" Move
+   "D" WindowShade

AddToFunc VertMax   "C"   Maximize 0 100
+              "C"   Raise

AddToFunc HorzMax   "C"   Maximize 92 0
+              "C"   Raise

AddToFunc FullMax   "C"   Maximize 92 100
+         "C"   Raise

AddToFunc "Move-or-Lower"
+ I        Lower           "Motion"
+ I        Lower           "Click"
+ I        RaiseLower      "DoubleClick"

AddToFunc "Move-or-Iconify"
+ I        Move            "Motion"
+ I        Iconify         "DoubleClick"

AddToFunc "Resize-or-Raise"
+ I        Resize          "Motion"
+ I        Raise           "Motion"
+ I        Raise           "Click"
+ I        RaiseLower      "DoubleClick"

AddToFunc "MoveToCurrentPageAndRaise"
 	+ I MoveToPage 0
 	+ I Raise
	+ I Iconify off

####################################################################
# MENU - Backgrounds 
####################################################################
AddToMenu Backgrounds "Backgrounds" Title
+ KLatNight_bg%bg.xpm%			exec /usr/X11R6/bin/xv -max -root -quit /home/jason/Images/Backgrounds/KLatNight_bg.jpg

####################################################################
# MENU - Window Ops 
####################################################################
AddToMenu Window-Ops "Window Ops" Title
+   ""								Nop
+   "Refresh Screen"%mini.exp.xpm%	Refresh
+   ""								Nop
+   (Un)Stick%mini.stick1.xpm%		Stick
+   ""								Nop
+   Destroy%destroy.xpm%			Destroy
+   ""								Nop
+   Move%move.xpm%					Move
+   ""								Nop
+   Xterm%x.xpm%					Exec xterm -rv -fn fixed&
+   ""								Nop
+   "Edit Fvwm2rc"%vim.xpm%			Exec gvim  -rv -font fixed $HOME/.fvwm2rc
+   ""								Nop
+   "Restart Fvwm"%reload.xpm%		Restart
+   ""								Nop
+   "Exit"%exit.xpm%				Quit

####################################################################
# MENU - Button Bar, the pulldown on a window's title
####################################################################
AddToMenu Bar-Button
+   "Raise"           Raise
+   "Lower"           Lower
+   "Resize"          Resize
+   "(Un)Stick"       Stick
+   "Close"           Close
+   "Destroy"         Destroy

####################################################################
# Mouse
####################################################################
# mouse control
EdgeScroll     0 0
EdgeResistance 10000 10000
XORvalue       F
# mouse bindings
Mouse 1         R       A       Refresh
Mouse 1         R       C       Refresh
Mouse 2         R       A       Menu Backgrounds Nop
Mouse 3         R       A       Menu Window-Ops Nop
Mouse 0         1       A       Menu Bar-Button Close
Mouse 0         2       A       Resize
Mouse 0         4       A       FullMax
Mouse 0         6       A       VertMax
Mouse 0         8       A       Iconify
Mouse 1         W       M       Raise
Mouse 2         W       M       Move
Mouse 3         W       M       Resize
Mouse 1         T       N       Move-or-Raise
Mouse 1         FS      N       Resize
Mouse 2         TSF     N       Iconify
Mouse 3         SF      N       Resize
Mouse 3         T       N       Destroy
Mouse 1         I       N       Iconify
Mouse 2         I       N       Raise
Mouse 3         I       N       Destroy

####################################################################
# FvwmPager
####################################################################
DeskTopSize 2x2
*FvwmPager:	Rows 0
*FvwmPager:	Columns 0
*FvwmPager:	Font none
*FvwmPager:	SmallFont 5x8
*FvwmPager:	DeskHighlight 
*FvwmPager:	HilightColorset * 10
*FvwmPager:	WindowColorset 7 7
*FvwmPager:	Colorset * 7
*FvwmPager:	Fore #AAAAAA
*FvwmPager:	Hilight #FFFFFF

####################################################################
# FvwmWinList
####################################################################
*FvwmTheme: Colorset 13 fg #777777, RootTransparent, Tint #000000 35
*FvwmTheme: Colorset 14 fg #FFFFFF, RootTransparent, Tint #000000 35
*FvwmWinList: Geometry     75x443+949+301
*FvwmWinList: MaxWidth     75
*FvwmWinList: MinWidth     75
*FvwmWinList: Action       Click1       Iconify
*FvwmWinList: Action       Click2       MoveToCurrentPageAndRaise
*FvwmWinList: Action       Click3       Destroy
*FvwmWinList: Colorset 13
*FvwmWinList: IconColorset 13
*FvwmWinList: FocusColorset 14
*FvwmWinList: ButtonFrameWidth 0
*FvwmWinList: UseSkipList
*FvwmWinList: LeftJustify
*FvwmWinList: Font -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmWinList: UseIconNames
 
####################################################################
# FvwmButtons
####################################################################
#*FvwmButtons: Geometry   110x255+914+0
*FvwmButtons: Geometry   75x300+949+0
*FvwmButtons: Rows 7 
*FvwmButtons: Columns   1
*FvwmButtons: Colorset 7
*FvwmButtons: Font   5x7
*FvwmButtons: Frame   0
*FvwmButtons: Padding 0 0
*FvwmButtons: BoxSize smart
####################################
# Stuff to swallow
*FvwmButtons(1x2, Frame 0,  Padding 0, Container(Columns 1, Rows 16, Frame 0))
	*FvwmButtons(1x3, Center, Frame 0, Padding 0, Swallow "daliclock", \
		'Exec /usr/local/bin/xdaliclock  -title daliclock -name daliclock \
		-transparent -noseconds -fn "-adobe-helvetica-*-r-*-*-24-*-*-*-*-*-*-*"&'
	*FvwmButtons(1x9, Frame 1, Padding 0, Swallow "FvwmPager", "FvwmPager 0 0")
	*FvwmButtons(1x4, Frame 1, Padding 0, Swallow "xsysinfo" 'Exec \
		/usr/X11R6/bin/xsysinfo -bg \\#2C3A50 -fg \\#AAAAAA -nocpu -noswap -nonfs \
		-fn 5x8 -colors green,orangeblue,red &')
*FvwmButtons(End)
####################################
# Frame containing login and app buttons
*FvwmButtons(1x2, Frame 0,  Padding 0, Container(Columns 1, Rows 7, Frame 0))
####################################
#	Aterm/remote Login Buttons Frame
	*FvwmButtons(1x4, Frame 0,  Padding 0, Container(Columns 2, Rows 6, Frame 1))
		*FvwmButtons (Title LOCAL, Action 'Exec aterm -bg black -fg \#FFFFFE -fn \
			"-schumacher-*-medium-r-*-*-10-*-*-*-*-*-*-*" -sl 5000 -tr -trsb -sr \
			-shading 65 -name `hostname`&')
		*FvwmButtons (Title CONS, Action 'Exec aterm -C -bg black -fg \#FFFFFE -fn \
			"-schumacher-*-medium-r-*-*-10-*-*-*-*-*-*-*" -sl 5000 -tr -trsb -sr \
			-shading 65 -name console&')
        *FvwmButtons (Title ROOT, Back #52323A, Action 'Exec aterm -bg black -fg \
			\#FFBBBB -fn \ "-schumacher-*-medium-r-*-*-10-*-*-*-*-*-*-*" -sl 5000 \
			-tint red -tr -trsb -sr -shading 100 -name root -e su -&')
        *FvwmButtons (Title GABRIEL, Action 'Exec aterm -bg black -fg \#FFFFFE -fn \
			"-schumacher-*-medium-r-*-*-10-*-*-*-*-*-*-*" -sl 5000 -tr -trsb -sr \
			-shading 65 -T gabriel -n gabriel -e ssh -X [email-masked] &')
		*FvwmButtons (Title FLY, Action 'Exec aterm -bg black -fg \#FFFFFE -fn \
			"-schumacher-*-medium-r-*-*-10-*-*-*-*-*-*-*" -sl 5000 -tr -trsb -sr \
			-shading 65 -T flywheel -n flywheel -e ssh -X -p 27005  \
			[email-masked] &')
		*FvwmButtons (Title DCN, Action 'Exec aterm -bg black -fg \#FFFFFE -fn \
			"-schumacher-*-medium-r-*-*-10-*-*-*-*-*-*-*" -sl 5000 -tr -trsb -sr \
			-shading 65 -T dcn -n dcn -e ssh -X [email-masked] &')
		*FvwmButtons (Title BLONDE, Action 'Exec aterm -bg black -fg \#FFFFFE -fn \
			"-schumacher-*-medium-r-*-*-10-*-*-*-*-*-*-*" -sl 5000 -tr -trsb -sr \
			-shading 65 -T blonde -n blonde -e ssh -X [email-masked] &')
		*FvwmButtons (Title JOKE, Action 'Exec aterm -bg black -fg \#FFFFFE -fn \
			"-schumacher-*-medium-r-*-*-10-*-*-*-*-*-*-*" -sl 5000 -tr -trsb -sr \
			-shading 65 -T joke -n joke -e ssh -X [email-masked] &')
        *FvwmButtons (Title LETS, Action 'Exec aterm -tn vt102 -bg black -fg \#FFFFFE -fn \
			"-schumacher-*-medium-r-*-*-10-*-*-*-*-*-*-*" -sl 5000 -tr -trsb -sr \
			-shading 65 -T blogus -n blogus -e ssh -X [email-masked]&')
		*FvwmButtons (Title ALVIN01, Action 'Exec aterm -bg black -fg \#FFFFFE -fn \
			"-schumacher-*-medium-r-*-*-10-*-*-*-*-*-*-*" -sl 5000 -tr -trsb -sr \
			-shading 65 -T alvin01 -n alvin01 -e ssh -X [email-masked] &')
		*FvwmButtons (Title ALVIN02, Action 'Exec aterm -bg black -fg \#FFFFFE -fn \
			"-schumacher-*-medium-r-*-*-10-*-*-*-*-*-*-*" -sl 5000 -tr -trsb -sr \
			-shading 65 -T alvin02 -n alvin02 -e ssh -X [email-masked] &')
		*FvwmButtons (Title ALVMN01, Action 'Exec aterm -bg black -fg \#FFFFFE -fn \
			"-schumacher-*-medium-r-*-*-10-*-*-*-*-*-*-*" -sl 5000 -tr -trsb -sr \
			-shading 65 -T alvmn01 -n alvmn01 -e ssh -X [email-masked] &')
	*FvwmButtons(End)
####################################
#	Applications Buttons Frame
	*FvwmButtons(1x3, Frame 1,  Padding 0, Container(Columns 4, Rows 3, Frame 1))
		*FvwmButtons (Icon netscape.xpm, Action 'Exec mozilla&')
		*FvwmButtons (Icon xcalc.xpm, Action 'Exec xcalc -rv -rpn&')
		*FvwmButtons (Icon xv.xpm, Action 'Exec  xv -perfect&')
		*FvwmButtons (Icon vim.xpm, Action 'Exec gvim -rv -fn \
			-schumacher-*-medium-r-*-*-10-*-*-*-*-*-*-* &')
		*FvwmButtons (Icon gaim.xpm, Action 'Exec gaim &')
		*FvwmButtons (Icon soffice.xpm, Action 'Exec /compat/linux/usr/OpenOffice/soffice&')
		*FvwmButtons (Icon cal.xpm, Action 'Exec ctime&')
		*FvwmButtons (Icon acroread.xpm, Action 'Exec export LANG=C && \
			/usr/local/Acrobat5/bin/acroread&')
		*FvwmButtons (Icon xpaint.xpm, Action 'Exec gimp&')
		*FvwmButtons (Icon lock.xpm, Action 'Exec xlock -mode cage&')
		*FvwmButtons (Icon xmms.xpm, Action 'Exec xmms&')
	*FvwmButtons(End)
*FvwmButtons(End)

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 17 Jun 2003 07:42:22 +0200

On Mon, Jun 16, 2003 at 09:30:37AM -0700, Jason Gabler wrote:
> theme), this includes using transparency with the FvwmWinList module.  I 
> find that it often uses the wrong window names/titles in the list.  
> Sometimes an fvwm restart can fix this (most often not).  Fully login out 
> of X and then back in sometimes fixes it (more often than an fvwm restart). 
> Basically the behavior is FvwmWinList will use window names of windows that 
> have WindowListSkip in their Style to replace window names that sjould be 
> in the list.  For the record, I've never seen this happen when not using 
> transparency.  I've only seen this when Fvwm starts.
> 

I will take a look at this pb but you start your module as

> Module FvwmButtons

This is not a good idea (as the man pager says). This should be

AddToFunc StartFunction
+ I Module FvwmBacker
+ I Module FvwmTheme
+ I Module FvwmWinList
+ I Module FvwmButtons
 
> Transparent title bars can often get locked into a particular portion of 
> the background.  No matter where you place the windows they maintain them 
> same portion of the background.  This can happen when Fvwm starts or after 
> some use of the WM.
> 
> Transperent title bars sometimes show the given background color and do not 
> do transparency.    This can happen when Fvwm starts or after some use of 
> the WM.
> 

I think that these stick images problem come from your FvwmBaker

> *FvwmBacker: RetainPixmap

You should use the "--retain-pixmap" option of fvwm-root

> Not sure if this is transparency related, but sometimes FvwmPager just 
> doesn't start or it wont swallow into Buttons.  I've never seen this w/o 
> transparency.
> 

Do you have any error msg (X stderr) or a core dump file when this
happen?

> My .fvwm2rc is attached as "fvwm2rc.jyg"

Some others remarks on you config.

First you do not always define the bg color in the Colorsets. This
causes fvwm to compute the "average" color of your root pixmap. If
you do not want this for a colorset define the bg color (this speedup
colorset loading). 

> ModulePath /usr/libexec/fvwm/2.5.7

This line is not useful and cause pb when you upgrade

Please replace any line of the form:

*FvwmThemes: Colorset

by

Colorset

and be sure you do not start the FvwmTheme module.

Regards, Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]