Subject: Xnest and Xft

From: Marcus Lundblad <[email-masked]>
Date: Sun, 29 Jun 2003 19:27:41 +0200 (CEST)

Is it possible to use Xft with Xnest.
I use to Xnest to debug FVWM when developing. I was about to try my patch
with Xft fonts. But I get this message:

Xlib:  extension "RENDER" missing on display ":1.0".

And all title bars appears empty. I tried using the line:
Style	*	Font 	xft:Verdana:pixelsize=14

from the man page. It doesn't indicate that the font is missing, and if so
wouldn't it use a default font?

//Marcus

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tomas Ogren <[email-masked]>
Date: Sun, 29 Jun 2003 22:45:40 +0200

> Xlib:  extension "RENDER" missing on display ":1.0".

Hm. That shouldn't be a problem. Maybe the first versions of Xft, but
current versions and a while back can use RENDER to speed up
antialiasing but work without.. I use it at work on the Solaris boxes
which doesn't have a new enough X server to have RENDER..

What version of Xft are you using?

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student at Computing Science, University of Umeå
`- Sysadmin at {cs,ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Marcus Lundblad <[email-masked]>
Date: Sun, 29 Jun 2003 23:16:24 +0200 (CEST)

> What version of Xft are you using?

I just installed Xft 2.
xft-config says
2.0.0

but when I run configure (for FVWM), I get this:

checking for xft-config... /usr/local/bin//xft-config
checking for Xft - version >= 2.0.0... no
*** The Xft test program failed to run.  If your system uses
*** shared libraries and they are installed outside the normal
*** system library path, make sure the variable LD_LIBRARY_PATH
*** (or whatever is appropiate for your system) is correctly set.

and if I run "which xft-config" from the command line, I get:
/usr/local/bin/xft-config

So, shouldn't it work?

//Marcus