Subject: Notification: incoming/1048

From: [email-masked]
Date: Wed, 11 Jun 2003 11:12:44 -0500

FVWM Bug Tracking notification

new message incoming/1048

Message summary for PR#1048
	From: [email-masked]
	Subject: Multiple conditions in All command
	Date: Wed, 11 Jun 2003 11:12:43 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Wed Jun 11 11:12:44 2003
Date: Wed, 11 Jun 2003 11:12:43 -0500
From: [email-masked]
To: [email-masked]
Subject: Multiple conditions in All command

Full_Name: Julien Cervelle
Version: 2.5.7
CVS_Date: 
OS: linux 2.4.19 i686
X_Server: XFree86 Version 4.3.0
Submission from: (NULL) (193.50.159.2)

In order to raise only mozilla windows that are not mail, I use this
command, but only the first condition is taken in account : it raises all
windows whose name end with Mozilla. Moreover, the manpage does not precise
wether the conditions are ORed or ANDed. I expect that they ere ANDed, but
tell me if I'm wrong.

All ("*Mozilla","!*for julien.cervelle@* - Mozilla") WindowListFunc

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 11 Jun 2003 17:17:38 +0000

> All ("*Mozilla","!*for julien.cervelle@* - Mozilla") WindowListFunc

This is a documented feature, currently only one name may be used in
conditions. Here is the solution for you:

  All (*Mozilla) ThisWindow ("!*for julien.cervelle@* - Mozilla") WindowListFunc

Regards,
Mikhael.