Subject: Problem with my ,,crystal console''

From: Jaroslaw Swierad <[email-masked]>
Date: Wed, 4 Jun 2003 17:59:50 +0200

Hi there.
I have the lates snapshot from Your cvs (20030604) and there are problems with defined by me bindings.

# -- Crystal Console --

Key     grave   A       M       CC_ShowHide
Key     grave   A       MS      FvwmConsole

# -- Funcstions --

DestroyFunc CC_Init
AddToFunc CC_Init
+ I Style CrystalConsole !Title, !Handles, BorderWidth 1, SkipMapping, \
    WindowListSkip, VariableSize, NoIcon, StaysOnTop, !Iconifiable, \
        FixedPosition, StickyAcrossPages, Maximizable
	+ I Exec exec x-terminal-emulator -name CrystalConsole -geometry +0+0
	+ I Wait CrystalConsole
	+ I All (CrystalConsole) Maximize 100 50
	+ I All (CrystalConsole) RefreshWindow
	+ I All (CrystalConsole) MoveToDesk 666
	+ I All (CrystalConsole) WindowShade False
	+ I Style CrystalConsole FixedSize, !Maximizable
	+ I Prev (CurrentPage) Focus

	DestroyFunc CC_ShowHide
	AddToFunc CC_ShowHide
	+ I None (CrystalConsole) CC_Init
	+ I All (CrystalConsole, CurrentDesk)
	+ I Cond (NoMatch) CC_Show
	+ I Cond (Match) CC_Hide

	DestroyFunc CC_Show
	AddToFunc CC_Show
	+ I All (CrystalConsole) WindowShade true
	+ I All (CrystalConsole) MoveToDesk
	+ I All (CrystalConsole) Raise
	+ I All (CrystalConsole) WindowShade false
	+ I All (CrystalConsole) Focus

	DestroyFunc CC_Hide
	AddToFunc CC_Hide
	+ I All (CrystalConsole) WindowShade true
	+ I All (CrystalConsole) MoveToDesk 666
	+ I All (CrystalConsole) WindowShade false
	+ I All (CrystalConsole) RefreshWindow
	+ I Prev (CurrentPage) Focus

I have something like that.
It should start console (like this one in quake?). It should move from the top of my monitor....

But when I press Alt+~ (this is this shortcut) nothing happend and X crashes.

I use two monitors with xinerama, but the same problem is with only one monitor.

Any suggestions ?
	
-- 

UNIX::Messer()
{
  imię = Jarosław;   nazwisko = Świerad;
  gpg = 0x97AA41AA;  *http.gentoo.eu.org;
}

---

From: [email-masked]
Date: Thu, 19 Jun 2003 15:28:19 +0200

> But when I press Alt+~ (this is this shortcut) nothing happend and X crashes.

Does fvwm leave a core file?  If so, please fetch a stack trace
and post it at fvwm-workers:

  $ gdb fvwm core
  (gdb) where

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]