Subject: Fw: Re: fvwm-menu-desktop

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 30 Jun 2003 12:55:47 +0000

I forward this message. Initially Matt asked me privatelly about
supporting parsing of the vfolders XML Categories description.

Regards,
Mikhael.

Subject: Re: fvwm-menu-desktop
From: Matt Davey <[email-masked]>
To: Mikhael Goikhman <[email-masked]>
Date: Mon, 30 Jun 2003 10:27:18 +0100

> What is "vfolders XML Category description"?

On the current redhat distribution (and I've no idea which others, but
I guess anything keeping with the everchanging gnome2 landscape),
the .desktop files include an extra piece of meta-information.  For example,
my gnu-emacs.desktop contains the line:
	
	Categories=TextEditor;Development;X-Red-Hat-Base;Application;

Then, .menu files  a menu structure is defined, with each submenu defined
by a set of categories which can be ANDed and NOTted together, in the style
of Apache XML configuration.

> > My rh9 distribution has all the .desktop files in /usr/share/applications..
> .
> 
> So you should use:
> 
>   fvwm-menu-desktop --dir /usr/share/applications

/usr/share/applications has no subdirectories, so I end up with a flat menu
list that is about twice the height of my desktop, and doesn't split into 
multiple columns.

All the best,

Matt

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 30 Jun 2003 16:56:25 +0200

> supporting parsing of the vfolders XML Categories description.

Yes, fvwm-menu-desktop should be rewritten to support "vfolders"
and the "new" spec (http://www.freedesktop.org/standards/desktop-entry-spec/).
I've not the time to do this. Sorry.

Regards, Olivier

> X-Mailer: exmh version 2.6.3 04/04/2003 with nmh-1.0.4

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 30 Jun 2003 17:20:56 +0200

> and the "new" spec (http://www.freedesktop.org/standards/desktop-entry-spec/).

Sorry it is:

http://www.freedesktop.org/standards/desktop-entry-spec/desktop-entry-spec.html

Also

http://www.freedesktop.org/standards/menu/draft/menu-spec/menu-spec.html
http://www.freedesktop.org/standards/basedir/draft/basedir-spec/basedir-spec.html

should be taken in account

Regards, Olivier