Subject: Re: FVWM: FVWM 2.4.7, Move & resize problems

From: Dan Espen <[email-masked]>
Date: Wed, 04 Jun 2003 08:40:20 -0400

Mikhael Goikhman <[email-masked]> writes:
> On 04 Jun 2003 10:25:00 +0200, Gert Brinkmann wrote:
> > 
> > Marcus Lundblad wrote:
> > 
> > >>to move windows by dragging them with left Windows key and Mouse-1. 
> > >>Since 2.4.7, behavior of the Move command changed - I have to click into 
> > >>the window, then move the window and then click again at the new 
> > >>position. How can I enable the old behavior?
> > >
> > >
> > >If you define a function like this:
> > >
> > >AddToFunc MyMove M Move
> > >
> > >and
> > >
> > >Mouse 1                W       4       MyMove
> > >
> > >It works as expected.
> > 
> > Is this just a temporary behaviour of the developer's version or is this 
> > changed definitely?
> 
> It may be the final behaviour, it is not decided yet.

How about renaming move/resize to describe what they do,
something like "resize-on-release"?  And then make move/resize
built-in functions.

Otherwise 2.6 is going to need a conversion tool.

-- 
Dan Espen                           E-mail: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 5 Jun 2003 01:07:27 +0000

On 04 Jun 2003 08:40:20 -0400, Dan Espen wrote:
> > > Is this just a temporary behaviour of the developer's version or is
> > > this changed definitely?
> > 

I would like Dominik to decide here.

> Otherwise 2.6 is going to need a conversion tool.

Regardless of this problem, I think we should supply the conversion
script, even if most of the old things are supported. I am slowly
starting to write out things that better be converted.

Regards,
Mikhael.