Subject: Birthday decorations and announcement?

From: Dominik Vogt <[email-masked]>
Date: Tue, 27 May 2003 17:01:39 +0200

We still need to

 - Write at least a minimal birthday announcement and post it
   (volunteers?)
 - Update the web page with an announcement including
     - a BIG birthday statement
     - some information on the IRC chat.  I plan to hang out on
       IRC between about 16:00 and 22:00 GMT on Sunday on both,
       the German and the English channels.
     - Where to send congratulation messages (fvwm mailing list).
 - Some birthday decorations for the web page?

Bye

Dominik ^_^  ^_^
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Uwe Pross <[email-masked]>
Date: Tue, 27 May 2003 22:05:40 +0200

Hi there,

>  - Some birthday decorations for the web page?

I made a couple of banners for the web page. Maybe we can
use one of them:

http://www-user.tu-chemnitz.de/~uwp/fvwm-web/birthday/

We could include one of these banners on sunday
automatically by the php scripts.

Uwe
-- 
  ,_,  Uwe Pross
 (O,O) mailto:[email-masked]
 (   ) http://www.tu-chemnitz.de/~uwp
=-"-"-================================
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Bob Woodside <[email-masked]>
Date: Tue, 27 May 2003 18:23:26 -0400

On Tue, 27 May 2003 22:05:40 +0200

> http://www-user.tu-chemnitz.de/~uwp/fvwm-web/birthday/

	I would vote for either logo2 or logo4. I think these will stand out
best against the current background. I wonder if we should add an
exclamation mark at the end ("Happy Birthday FVWM!").

> automatically by the php scripts.

	Perhaps we should have it (and whatever extra birthday verbiage we
add..."FVWM turns 10 this month, blah, blah, blah") included for all of
the month of June...or do you think it should remain for a longer
period, like, say, till after the close of the logo contest?

Cheers,
Bob

---

From: Uwe Pross <[email-masked]>
Date: Wed, 28 May 2003 10:38:05 +0200

Hi there,

> exclamation mark at the end ("Happy Birthday FVWM!").

Yes, I can do that. But I need to do that at home since I
don't have the fonts at work :-|

> period, like, say, till after the close of the logo contest?

I enhanced the page a bit:

The birthday page got its own class which is derived from
the default class:

http://www-user.tu-chemnitz.de/~uwp/fvwm-web/birthday/index.php?body_bg_image=ballons1_bg.jpg
http://www-user.tu-chemnitz.de/~uwp/fvwm-web/birthday/index.php?body_bg_image=ballons2_bg.jpg
http://www-user.tu-chemnitz.de/~uwp/fvwm-web/birthday/index.php?body_bg_image=ballons3_bg.jpg
http://www-user.tu-chemnitz.de/~uwp/fvwm-web/birthday/index.php?body_bg_image=ballons4_bg.jpg

Suggestions, comments?

Anybody who can write some sentences for this site?

I need also a nice window decoration for the birthday page -
nice window screenshot.

Cheers, Uwe

---

From: Uwe Pross <[email-masked]>
Date: Wed, 28 May 2003 11:13:17 +0200

Hi there,

On 28 May 2003 at 10:38:05 +0200, Uwe Pross wrote:

> ...

Two more:

> http://www-user.tu-chemnitz.de/~uwp/fvwm-web/birthday/index.php?body_bg_image=ballons5_bg.gif
> http://www-user.tu-chemnitz.de/~uwp/fvwm-web/birthday/index.php?body_bg_image=ballons6_bg.jpg

---

From: Uwe Pross <[email-masked]>
Date: Wed, 28 May 2003 21:06:27 +0200

Hi there,

I have made a suggestion for the web page on:

http://www-user.tu-chemnitz.de/~uwp/fvwm-web/

This includes the birthday page as well.

If it is liked I would commit it tommorow morning. Maybe I
remove the link until the birthday page has been finished.

Uwe

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 28 May 2003 20:35:31 +0000

> don't have the fonts at work :-|

I also think that the right syntax is a comma after "Birthday". :)

> http://www-user.tu-chemnitz.de/~uwp/fvwm-web/birthday/index.php?body_bg_image=ballons1_bg.jpg

I like ballons5_bg.gif, but something not too strewn instead of the black
may be ok too.

> Anybody who can write some sentences for this site?

You may put the following paragraphs into the new birthday page in the
News section:

Read about the FVWM's history.
[incorporate/reformat the text at http://fvwm.sf.net/tmp/fvwm-history.txt]
[probably create a new history page in the Features section]

Join the irc channel #fvwm at irc.freenode.net on 2003-06-01 all the
day and particularly around 17:00 UTC.

Ideas for irc discussions:
  * what is your favorite "F" definition
  * who has bigger monitor, longer uptime, bigger purse
  * who has older fvwm version running
  * favorite pet
  * favorite logo from the submitted ones
  * favorite fvwm feature
  * ...

See the photos of the developers (all happen to be listed in AUTHORS).
[The photos are at http://fvwm.sf.net/tmp/developers.tar.bz2]

[Put some window manager related joke. Anyone?]

> I need also a nice window decoration for the birthday page -

You may take one of the Dorothy decors. For example
  http://www.twobarleycorns.net/fvwm/starry.jpg
or, if your engine does not support this, any other decor.

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 29 May 2003 02:08:03 +0200

> [probably create a new history page in the Features section]

About FVWM "recent" history I run a simple perl script around all our
change log (fvwm head and fvwm-web) I get the following:

Number of ChangeLog entries: 3227 
Number of file modification: 12819

Andi Karrer            entries: 1       files: 1
Andrew T. Veliath      entries: 4       files: 9
André Dahlqvist        entries: 1       files: 1
Ben Mansell            entries: 1       files: 22
Ben Mathews            entries: 3       files: 8
Ben Winslow            entries: 1       files: 1
Bob Woodside           entries: 67      files: 162
Brad Giaccio           entries: 23      files: 46
Chris Rankin           entries: 37      files: 67
Dan Espen              entries: 341     files: 540
Daniel Henninger       entries: 2       files: 7
Darren Stuart Embry    entries: 2       files: 4
Dave Trollope          entries: 2       files: 2
David Fries            entries: 1       files: 2
Derek B. Noonburg      entries: 1       files: 5
Dominik Vogt           entries: 1374    files: 7204
Douglas                entries: 1       files: 1
Eric Gillespie Jr.     entries: 2       files: 6
Fred Maciel            entries: 1       files: 6
Happy                  entries: 1       files: 2
Jason L Tibbitts III   entries: 1       files: 1
Jason Weber            entries: 10      files: 26
Jochen Klenner         entries: 1       files: 1
Johan Bengtsson        entries: 3       files: 11
Ke Huang               entries: 1       files: 12
Marcus Lundblad        entries: 7       files: 21
Mark Rainford          entries: 1       files: 6
Matthias Clasen        entries: 83      files: 405
Michael Han            entries: 11      files: 34
Mikhael Goikhman       entries: 518     files: 1382
Mikhail Kruk           entries: 1       files: 1
Neil Bird              entries: 1       files: 1
Olivier Chapuis        entries: 469     files: 2013
Paul D. Smith          entries: 60      files: 191
Steve Talley           entries: 1       files: 9
Steven Michael ROBBINS entries: 27      files: 161
Stian Sletner          entries: 1       files: 1
Suzanne Britton        entries: 1       files: 5
Suzanne Skinner        entries: 2       files: 5
Tim Cutts              entries: 1       files: 1
Tim Phipps             entries: 118     files: 281
Tomas Ogren            entries: 19      files: 66
Tony Finch             entries: 1       files: 1
Uwe Pross              entries: 23      files: 84

Is FVWM an active project? Since the 2001-11-01 (2.5.0 fork) we have
(fvwm head) something like:

Number of ChangeLog entries: 1032
Number of file modification: 7015

Ben Mathews       entries: 3    files: 8
Bob Woodside      entries: 6    files: 10
Dan Espen         entries: 79   files: 112
Daniel Henninger  entries: 2    files: 7
Dave Trollope     entries: 2    files: 2
David Fries       entries: 1    files: 2
Derek B. Noonburg entries: 1    files: 5
Dominik Vogt      entries: 372  files: 2013
Jason Weber       entries: 10   files: 26
Jochen Klenner    entries: 1    files: 1
Marcus Lundblad   entries: 7    files: 21
Mikhael Goikhman  entries: 246  files: 615
Mikhail Kruk      entries: 1    files: 1
Olivier Chapuis   entries: 287  files: 1601
Steve Talley      entries: 1    files: 9
Stian Sletner     entries: 1    files: 1
Suzanne Skinner   entries: 2    files: 5
Tim Phipps        entries: 5    files: 9
Tony Finch        entries: 1    files: 1
Uwe Pross         entries: 4    files: 12

Maybe some authors (entries/file) are missing here as sometimes a
fvwm-workers apply a patch from some one else and even if this is
mentioned in the change log my script cannot detect that.
Moreover, there is maybe a few bugs in my script :o§

An other statistic. During 2002 the fvwm mailing lists receive
something like 7501 messages (6270 real msg + 1231 cvs commit msg).

Regards, Olivier

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 29 May 2003 00:29:16 +0000

> Number of file modification: 12819

Does your script count the time spent preparing these commits? :)

> Moreover, there is maybe a few bugs in my script :o?

If the script works on ChangeLog I may see some problems, how about file
globing, */*.{in,1}? Another approach is to parse the "cvs log" output.

> something like 7501 messages (6270 real msg + 1231 cvs commit msg).

This may be another statistics/ page in the Features section (together
with scripts to build it). But it is not really essential.

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 29 May 2003 10:35:55 +0200

> > Number of file modification: 12819

Seems that the current cvs tree has been created on 1998-11-06.
 
> globing, */*.{in,1}? Another approach is to parse the "cvs log" output.
               ^^^^^^
This syntax is now forbiden :o)
About cvs log I found in freashmeat a perl script which produce
stat from cvs log output (cvstat).

>From Juli Mallett (author of cvstat):

"These statistics are provided purely for interested developers, and
are not intended to reflect quality -or- quality of work done by any
given developer in CVS, merely to show activity of operations in the
CVS repository performed by all developers. If you want to use them to
motivate yourself, that's fine, but keep in mind that a bit of useful
work is more meaningful than a lot of useless work."

Regards, Olivier

---

From: Uwe Pross <[email-masked]>
Date: Fri, 30 May 2003 09:26:19 +0200

Hi there,

> I also think that the right syntax is a comma after "Birthday". :)

I'll do that today or tommorow morning.

> I like ballons5_bg.gif, but something not too strewn instead of the black

I put a colorful design online now. Maybe to shiny ...

>   * favorite logo from the submitted ones

Not done yet.

> [The photos are at http://fvwm.sf.net/tmp/developers.tar.bz2]

Done. I put it on the birthday page - Maybe we want to pics
on a separate page ...

> or, if your engine does not support this, any other decor.

Looks nice but can not be used for the web site since the
title bar pictures is to wide.

Cheers, Uwe

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 30 May 2003 14:14:59 +0000

> title bar pictures is to wide.

Sorry, my mice pasted the wrong url. It is:

  http://www.twobarleycorns.net/fvwm/purpsilver.jpg

You may ignore the LeftOfText, UnderText and RightOfText parts of the
titlebar althought it is not such beautiful without them.

Please no solid red theme for the birthday. :)

Regards,
Mikhael.

---

From: Uwe Pross <[email-masked]>
Date: Fri, 30 May 2003 16:36:06 +0200

Hi there,

> Sorry, my mice pasted the wrong url. It is:

My mouse always does ;-)

> titlebar althought it is not such beautiful without them.

I used this picture but it is pretty poor quality. I also
think the colors do not match that good.

> Please no solid red theme for the birthday. :)

You may try to change the decoration using the script 

pictures/decorations/make_decoration.sh

It prints a short help message. For the birthday decoration
I used in the root of fvwm-web tree:

pictures/decorations/make_decoration.sh purpsilver.jpg 4 birthday/window_decor_birthday 23 -f

4   .. border width of the window
23  .. titlebar height
-f  .. override files in directory birthday/window_decor_birthday

Regards, Uwe

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 30 May 2003 15:13:52 +0000

> >   http://www.twobarleycorns.net/fvwm/purpsilver.jpg

Dorothy, please send us purpsilver.png ASAP. Or something as nice for the
birthday web decorations.

> think the colors do not match that good.

Yes, too much yellow for me. Maybe window colors #fffff8/#283848
and pager bg #f8f8cc?

Also I think that ballons5_bg.gif is too motley and ballons7_bg.gif is
too pale, something in the middle?

Regards,
Mikhael.