Subject: Re: [Falk Hueffner <[email-masked]>] Bug#188337: mwm hints parsing broken on 64 bit architectures

From: [email-masked]
Date: Sun, 25 May 2003 11:18:55 +0200

So, what are we going to do with this problem?

On Wed, Apr 09, 2003 at 06:57:26PM -0400, Dan Espen wrote:
> Alexander Kotelnikov <[email-masked]> writes:
> > I've received this bug report along with a patch.
> > 
> > 
> > --=-=-=
> > Subject: Bug#188337: mwm hints parsing broken on 64 bit architectures
> > Reply-To: Falk Hueffner <[email-masked]>, [email-masked]
> > Resent-To: [email-masked]
> > Resent-CC: Alexander Kotelnikov <[email-masked]>,
> >  [email-masked]
> > Date: Wed, 09 Apr 2003 14:40:31 +0200
> > 
> > Package: fvwm
> > Version: 2.4.15-2
> > Severity: normal
> > Tags: patch
> > 
> > Hi,
> > 
> > fvwm contains the same bug as qvwm (#97326), which makes for example
> > mozilla's window borders not show up. Here's a patch.
> > 
> > --- fvwm/decorations.c~	2003-02-08 14:09:43.000000000 +0100
> > +++ fvwm/decorations.c	2003-04-09 14:07:49.000000000 +0200
> > @@ -73,10 +73,10 @@
> >  /* Motif  window hints */
> >  typedef struct
> >  {
> > -  CARD32      flags;
> > -  CARD32      functions;
> > -  CARD32      decorations;
> > -  INT32       inputMode;
> > +  ulong      flags;
> > +  ulong      functions;
> > +  ulong      decorations;
> > +  long       inputMode;
> >  } PropMotifWmHints;
> >  
> >  typedef PropMotifWmHints        PropMwmHints;
> 
> OK, this is the way that structure is defined on my Solaris 8 system:
> 
> /usr/dt/share/include/Xm/MwmUtil.h:
> 
> typedef struct
> {
>     /* These correspond to XmRInt resources. (VendorSE.c) */
>     int          flags;
>     int          functions;
>     int          decorations;
>     int          input_mode;
>     int          status;
> } MotifWmHints;
> 
> Its the same on HPUX.11.  On AIX 5.1 the one in
> /usr/include/Motif2.1/Xm/MwmUtil.h
> is the same, but they have the old Motif 1.2 where it was:
> 
> /usr/include/Motif1.2/Xm/MwmUtil.h:
> 
> typedef struct
> {
> #ifndef OSF_v1_2_4
>     long        flags;
>     long        functions;
>     long        decorations;
> #else /* OSF_v1_2_4 */
>     /* These correspond to XmRInt resources. (VendorSE.c) */
>     int          flags;
>     int          functions;
>     int          decorations;
> #endif /* OSF_v1_2_4 */
>     int         input_mode;
> #ifndef OSF_v1_2_4
>     long        status;
> #else /* OSF_v1_2_4 */
>     int          status;
> #endif /* OSF_v1_2_4 */
> } MotifWmHints;
> 
> So it looks like "int" is the way to go.  What is the "ulong"
> solution based on?

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sun, 25 May 2003 08:36:16 -0400

> So, what are we going to do with this problem?

Since we never got any feedback on why we should use longs,
I've changed our stuff to use ints.

-- 
Dan Espen                           E-mail: [email-masked]