Subject: Problems displaying the birthday pages.

From: Alex Wallis <[email-masked]>
Date: Fri, 30 May 2003 23:51:47 +0930

I'm resending this as it doesn't seem to have reached the list.

It may just be me, but I suspect the background picture for the birthday
pages is doing some really evil and wicked things to my X server. I've
attached a screenshot to give an idea of what I'm seeing (or not seeing
as the case may be).  :(

I also had a similar reaction to Uwe's demo pages on his server so it
must be something to do with the code and my choice of browser (Netscape
4.79). Nope! I just tried it with Mozilla too and I get the same thing
happening. 

Maybe it's my X server? Or my xinerama?

I'm using RH9 and XFree86 4.3.0. It would seem to be the code for the
pages window borders at a guess. Dunno.

Anyone else see this?

Alex

P.S. Since I sent this email the first time, many changes have been made
on the web site. All of the birthday decorated pages mess up my X server
very badly indeed. No other web site ever does this to me at all.

---

From: Uwe Pross <[email-masked]>
Date: Sat, 31 May 2003 00:02:31 +0200

Hi there,

> 4.79). Nope! I just tried it with Mozilla too and I get the same thing

This shot looks strange. Even if the web page is totaly
broken you should not get a screenshot like this.

The actual web page version is tested with 4.79, Opera and
Gecko. I also run html checkers regularly.

Netscape 4.79 has some problems rendering complex tables but
it should still do the current version.

I guess, if you have got the problem with netscape and
mozilla there might be a broken library on your system. 
Maybe libjpeg or something like this.

How about the other themes on the web page? Can you view the
default theme? If so you can replace the "?theme=birthday"
in the url to "?theme=default" or "?theme=plain" which
should always work.

Regards, Uwe
-- 
  ,_,  Uwe Pross
 (O,O) mailto:[email-masked]
 (   ) http://www.tu-chemnitz.de/~uwp
=-"-"-================================
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Alex Wallis <[email-masked]>
Date: Sat, 31 May 2003 16:48:37 +0930

> On 30 May 2003 at 23:51:47 +0930, Alex Wallis wrote:
<snip>
> in the url to "?theme=default" or "?theme=plain" which

Yes. The other web page themes work fine. It seems to only be the
birthday pages.

A broken library is something I hadn't thought of. But this is the only
problems I've had with the new installation. I'll see if I can track
down some more information on what's wrong with my system somehow.

Thanks.

Alex

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 31 May 2003 13:58:37 +0000

> down some more information on what's wrong with my system somehow.

This is probably because of the transparent gif background.
There is no really a reason to have a transparent page background.

To be honest I like the background on the posted bad-bleah.jpg
more than the current one. Pink, orange, violet, brown and lightsalad
are really not my favorite colors. And the page is a bit dark for me.

Uwe, can you please put into cvs transparent ballons.png instead of
ballons.jpg, so I may try to work on it too. :)

I would really like to make the birthday theme more joyful, I prefer
the following color modification to the decorations:

  http://fvwm.sf.net/tmp/purple_smaller-2.png

Can you please adjust the color scheme (including visited links)?

Regards,
Mikhael.

---

From: Uwe Pross <[email-masked]>
Date: Sat, 31 May 2003 20:57:15 +0200

Hi there,

> This is probably because of the transparent gif background.

Possible.

> There is no really a reason to have a transparent page background.

I had some tries with the ballons on different
background colors. That's why it is transparent.

> more than the current one. 

I liked this one too, but I thought it was said to be too
colorful. 

> Pink, orange, violet, brown and lightsalad

I changed it a bit.
A couple of ballon pics should be one the cvs now. Please
remove some you don't want to use.

> Can you please adjust the color scheme (including visited links)?

I adapted the colors for this decorations. Feel free to
change the colors if it is still not liked. 
-> web-themes/classes/birthday_class.inc

Cheers, Uwe

---

From: Uwe Pross <[email-masked]>
Date: Sat, 31 May 2003 21:17:13 +0200

Mikhael,

if you found a color scheme. You may set the birthday theme
as default in file definitions.inc. The lines are already
there they just have to be commented out. I am off for
tonight and may have no time tommorow morning.

Cheers, Uwe