Subject: Re: web: some pages too wide

From: Uwe Pross <[email-masked]>
Date: Mon, 5 May 2003 14:59:53 +0200

Hi there,

On 30 Apr 2003 at 14:48:23 +0000, Mikhael Goikhman wrote:

> > A line break inside a command descriptions may confuse the
> > user. That's why <pre> was used. I would leave it as it is
> > or add a statement that the following command must be without a
> > linebreak.
> 
> I think css allows to define different margins/alighment for continuation
> lines than the corresponding properties for the leading lines.
> If you may find the css solution to reduce a confusion, it would be nice.

I noticed that you have changed <pre class="cvs"> to 
<p class="cmdline"> in file dev_cvs.php already. A better
way to achieve linebreaks is using <pre class="cvs"> and
allow line breaking explicitly. With 

pre.cvs {
	white-space:normal;
}

This makes all "command line text" in the same style in the
file and works with all browsers. If browsers don't obey to
style sheet lines are not wrapped put displayed in fixed
font. 

I would like to turn it back to <pre class="cvs">.

Regards, Uwe
-- 
  ,_,  Uwe Pross
 (O,O) mailto:[email-masked]
 (   ) http://www.tu-chemnitz.de/~uwp
=-"-"-================================
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 5 May 2003 21:59:10 +0000

> style sheet lines are not wrapped put displayed in fixed

So the old browsers show the same original problem this thread is started
from. Also this does not solve the confusion between the continuation
lines and the leading lines. What exactly this would solve?

> I would like to turn it back to <pre class="cvs">.

We don't really should use a monospace font (usually wide) for commands.
<p> or <div> with <br> would look nicer for a visitor, although it needs a
bit more work to write. For me, we should write all commands inside
<p class="cmdline">, but if you see a better solution, do it.

Regards,
Mikhael.

---

From: Uwe Pross <[email-masked]>
Date: Tue, 6 May 2003 09:21:14 +0200

Hi there,

On 05 May 2003 at 21:59:10 +0000, Mikhael Goikhman wrote:

> > This makes all "command line text" in the same style in
> > the file and works with all browsers. If browsers don't
> > obey to style sheet lines are not wrapped put displayed
> > in fixed font.
> 
> So the old browsers show the same original problem this
> thread is started from. Also this does not solve the
> confusion between the continuation lines and the leading
> lines. What exactly this would solve?

Currently there are two different styles for command line
text on the pages - the <pre> and <p> style. I would like if
we use the same style for all command line text and source
code examples. 

> We don't really should use a monospace font (usually wide)

The monospace font shows that either source code or  command
line  text is shown. But variable font is ok if we signalize
in an other way that this is "special text". 

> for commands.  <p> or <div> with <br> would look nicer for
> a visitor, although it needs a bit more work to write. For
> me, we should write all commands inside <p
> class="cmdline">, but if you see a better solution, do it.

Currently not. Actually the proper way  to  include  command
line  text would be <kbd>... and for source code <code>... I
have played around with this but came not  to  a  satisfying
solution. 

The problem I have with the current solution is that it uses
a  mix  of  different  tags.  Sometimes  <pre>  is  used and
sometimes <p>.  Looking  at  the  plain  layout  you  cannot
distinguish  between  normal  text and the command line text
formated with the <p> tag. That's why I suggested <pre> with
the linebreak option. If stylesheets are used by the browser
and the layout we can allow a line break  within  the  <pre>
tag  by  providing  a css class. If not the user has to life
with a wide page but recognizes command line text and source
code. 

Regards, Uwe