Subject: Notification: incoming/1037

From: [email-masked]
Date: Thu, 29 May 2003 10:57:49 -0500

FVWM Bug Tracking notification

new message incoming/1037

Message summary for PR#1037
	From: [email-masked]
	Subject: Mis-advertised EWMH fullscreen
	Date: Thu, 29 May 2003 10:57:48 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Thu May 29 10:57:48 2003
Date: Thu, 29 May 2003 10:57:48 -0500
From: [email-masked]
To: [email-masked]
Subject: Mis-advertised EWMH fullscreen

Full_Name: Ethan Blanton
Version: 2.5.6
CVS_Date: 
OS: 
X_Server: XFree86 4.2
Submission from: (NULL) (4.64.26.64)

Fvwm advertises support for the _NET_WM_STATE_FULLSCREEN EWMH, but does not
yet provide support.  This causes EWMH-aware full-screen apps (tvtime,
ogle, others) to fail to go full-screen, assuming the window manager should
handle it.  This bug is also present in CVS as of May 4, 2003.

A simple fix (until this hint is implemented, hopefully soon!) seems to be
to comment out the one line in ewmh.c where this hint is registered.

Ethan

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 29 May 2003 18:40:13 +0200

> Message-Id: <[email-masked]>

Done.

Regards, Olivier