Subject: A Silent core dump

From: Olivier Chapuis <[email-masked]>
Date: Wed, 7 May 2003 17:34:37 +0200

Hello,

A get a core dump with the following function:

AddToFunc CoreDump I Silent Move

Then executing

CoreDump

in a FvwmConsole gives a core dump with the follwing gdb output:

#0  __move_window (cond_rc=0xbfffef84, exc=0x81e93a8, action=0x81e939c "",
    do_animate=0, mode=0) at move_resize.c:1321
1321            w = FW_W_FRAME(fw);
(gdb) where
#0  __move_window (cond_rc=0xbfffef84, exc=0x81e93a8, action=0x81e939c "",
    do_animate=0, mode=0) at move_resize.c:1321
#1  0x0806682b in CMD_Move (cond_rc=0xbfffef84, exc=0x81e93a8,
    action=0x81e939c "") at move_resize.c:1461
#2  0x080998b5 in __execute_function (cond_rc=0xbfffef84, exc=0x81e9308,
    action=0x81e93a8 "M", exec_flags=128 '\200', args=0x81e939c)
    at functions.c:602
#3  0x08099d87 in __run_complex_function_items (cond_func_rc=0xbfffef84,
    cond=105 'i', func=0x1, exc=0x81e9308, args=0xbffff010) at functions.c:787
#4  0x08099fdf in execute_complex_function (cond_rc=0xbffff0ac, exc=0x81e5d98,
    action=0x81e9308 "M", desperate=0x5) at functions.c:957
#5  0x0809993a in __execute_function (cond_rc=0xbffff0ac, exc=0x81e9240,
    action=0x81e5d98 "M", exec_flags=0 '\0', args=0x81e92f8) at functions.c:621
#6  0x0809a53f in execute_function (cond_rc=0x0, exc=0x81e9240,
    action=0x81db168 "CoreDump", exec_flags=0 '\0') at functions.c:1193
#7  0x08086171 in ExecuteModuleCommand (w=0, module=1, text=0x81db168 "SF")
    at module_interface.c:693
#8  0x0808760e in ExecuteCommandQueue () at module_interface.c:1924
#9  0x08063cf7 in My_XNextEvent (dpy=0x80eb418, event=0xbffff360)
    at events.c:3500
#10 0x08063a52 in HandleEvents () at events.c:3297
#11 0x0808458c in main (argc=3, argv=0xbffff8a4) at fvwm.c:2433
#12 0x401fc082 in __libc_start_main () from /lib/i686/libc.so.6

CMD_Move is executed with no FvwmWindow as DeferExecution is
"stopped" by silent but with (exec_flags & FUNC_DONT_DEFER)
true. I see various possible fix.

However, Dominik, maybe you will prefer to fix this yourself?

Regards, Olivier
 
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked]
Date: Thu, 8 May 2003 00:47:29 +0200

>     do_animate=0, mode=0) at move_resize.c:1321

Fixed.

> true. I see various possible fix.

The right fix is to not execute the command at all.  I forgot to
catch that case in __execute_function() when I rewrote the
DeferExectuion() calls.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]