Subject: Re: FVWM: FvwmTabs v1.7

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 26 May 2003 23:26:42 +0000

On 23 May 2003 21:41:52 +1000, Scott Smedley wrote:
> 
> A new version of FvwmTabs is available.
> 
> You can get it at:
> 
> http://users.tpg.com.au/users/scottie7/fvwmtabs.html
> 
> The big change in this release is that it finally supports key-bindings.
> (eg. you can switch b/w tabs with your keyboard.) There are other
> small improvements too - see the web page.

Several suggestions to the code.

If you move the line "use Tk;" several lines down, then users without
Tk.pm installed will automatically get a nice error window telling them
about this (together with a usual error on the X output).

If you replace the line "use X11::Protocol;" with
"use FVWM::Module::Toolkit 'X11::Protocol';" then the users without
X11::Protocol installed will get the already mentioned error box too.

You may use debug facilities of FVWM::Module[::Tk].

Some trackers are usable now in perllib, should be documented soon.
You asked for ModuleConfig. Please test the cvs version. If you do this
today/tomorrow, I will have a chance to fix it (if needed) before 2.5.7,
otherwise you may just wait for 2.5.7 and hope it will do what you need.

  $configTracker = $module->track('ModuleConfig');
  $configHash = $configTracker->data;
  $font = $configHash->{Font} || 'fixed';

or:

  $configTracker = $module->track(
    'ModuleConfig', DefaultConfig => { Font => 'fixed' });
  $font = $configTracker->data('Font');

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: SCoTT SMeDLeY <[email-masked]>
Date: Tue, 27 May 2003 11:15:01 +1000

Hi Mikhael,

: Several suggestions to the code.

Excellent! I will address them in the next release. Thanks.

: Some trackers are usable now in perllib, should be documented soon.
: You asked for ModuleConfig. Please test the cvs version.

Awesome! I'll check it out as soon as I can. Thanks.

SCoTTie! :)
-- 
[email-masked]