Subject: in v2.5.6, cannot simply remove Mouse 2 binding via '-' function

From: parv <[email-masked]>
Date: Fri, 25 Apr 2003 22:33:48 -0400

I cannot seem to remove default 'Mouse 2' binding to "Builtin Menu"
by using '-' function, in fvwm 2.5.6 ...

  Mouse 2 R N -

...if i only have that (or no other binding) for middle mouse
button, i always get the "Builtin Menu" on pressing it.  I have/had
to bind the middle button to some other menu or function to disable
it.

I would hate to create a otherwise noop function just to disable the
"Builtin Menu".

  - parv

-- 

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Fri, 25 Apr 2003 22:38:55 -0400

> by using '-' function, in fvwm 2.5.6 ...

The built in binding is:

           Mouse 0 R N Menu MenuFvwmRoot

To remove it you need:

           Mouse 0 R N -

-- 
Dan Espen                           E-mail: [email-masked]

---

From: parv <[email-masked]>
Date: Sat, 26 Apr 2003 01:18:23 -0400

in message <[email-masked]>,
wrote Dan Espen thusly...
> > by using '-' function, in fvwm 2.5.6 ...
...
>            Mouse 0 R N -

Ah!  Thanks much.

A question: if 'A' context means any context, then why does the 'A'
context not override 'R'?  I would expect the following to work just
like above (but doesn't)...

  Mouse 0 A N -

  - parv

--

---

From: Marcus Lundblad <[email-masked]>
Date: Sat, 26 Apr 2003 11:15:17 +0200 (CEST)

>            Mouse 0 R N Menu MenuFvwmRoot

Maybe this should be changed to

Mouse 1 R N Menu MenuFvwmRoot
Mouse 2 R N Menu MenuFvwmRoot
Mouse 3 R N Menu MenuFvwmRoot

because 0 will match all buttons, also the scrollwheel on such mice.
Perhaps this is a bit annoying.
On the other hand, there may be mice where button 4 is actually a
"real" button.
Is it possible to detect somehow? Does the X server report such things?
If this would be so, it would be possible to redefine 
Mouse 0 to only match normal buttons.
And perhaps Mouse U,Mouse D for scroll.

//Marcus

---

From: [email-masked]
Date: Sat, 26 Apr 2003 10:23:12 +0200

> like above (but doesn't)...

There is no wildcard matching.  You must use exactly the same
arguments that were used initially to remove it.  Both approaches
have strenghth and weaknesses.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 26 Apr 2003 12:45:40 +0000

> Perhaps this is a bit annoying.

I think I already said my opinion in the past. IMHO, it should be simply:

The internal bindings should be as minimal as possible (although
functional).

> And perhaps Mouse U,Mouse D for scroll.

I don't see any X utility (or maybe function) that would distinguish
wheel buttons from non-wheel. (say, "xmodmap -pp", "xev")

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Sat, 26 Apr 2003 10:52:43 -0400

> The internal bindings should be as minimal as possible (although

If someone disagreed, it must have been me,
but I don't remember it.

I think I put in the mouse 0 binding.
I was trying to catch any mouse press for the user with no
config file.
I think that worked, we get a lot less emails about
starting up Fvwm and not being able to get anything to work.

I guess I don't understand the motivation of the few users
that complain that there are any built in bindings and want
to remove them.  Why don't they just override them?

Ie.:

Mouse 4 R N Nop

Anyway, if I was the one that objected,
I don't care that much. Either binding the buttons 1-3 or only
1 is OK with me.

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 26 Apr 2003 16:07:48 +0000

> to remove them.  Why don't they just override them?

I agree, it is pretty easy to do this if a user understands what happens.
However he may be surprized, say, to get a menu that he did not define
every time he moves to a new mouse supporting more buttons. I may easily
understant his willing to remove this unchancy built-in binding.

> Anyway, if I was the one that objected,

No, noone neither objected nor agreed then. :)

> I don't care that much. Either binding the buttons 1-3 or only

I will do the second option.

Regards,
Mikhael.