Subject: Re: Notification: incoming/1000

From: Olivier Chapuis <[email-masked]>
Date: Thu, 3 Apr 2003 22:20:22 +0200

On Thu, Mar 20, 2003 at 07:15:51AM -0600, [email-masked] wrote:
> FVWM Bug Tracking notification
> 
> new message incoming/1000
> 
> Message summary for PR#1000
> 	From: [email-masked]
> 	Subject: KDE Kicker system tray
> 	Date: Thu, 20 Mar 2003 07:15:50 -0600
> 	0 replies 	0 followups
> 
> Date: Thu, 20 Mar 2003 07:15:50 -0600
> 
> Full_Name: Robby Pählig
> Version: 2.5.6
> CVS_Date: 
> OS: Linux 2.4.19
> X_Server: XFree86 4.3
> Submission from: (NULL) (212.202.167.112)
> 
> 
> fvwm doesn't handle the KDE Kicker system tray properly. Often the icons
> are misplaced. The KAlarm system tray icon doesn't show up at all. If I
> kill fvwm and start the native KDE window manager, the Kicker tray works
> properly.
>

I will try to fix this before 2.6, but this is difficult as the KDE
system tray is not a standard and I presume that different KDE version
can react differently. There is a system tray standard now which does
not involve the window manager (I hope that future or maybe current
version of KDE will use it).

What version of KDE do you use?

Regards, Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 16 Apr 2003 09:28:36 +0200

> kill fvwm and start the native KDE window manager, the Kicker tray works

I've make some test and I cannot reproduce problems (KDE 3.0.3).
You say "Often the icons are misplaced", can you be more precise
("operation" which cause misplacement, type of misplacement ...).

What happen if you restart fvwm (Restart does not work with my
KDE, but "Restart fvwm" should work as well as killing fvwm and
start fvwm).

I am troubled by the KAlarm problem. If you have some times you
can edit fvwm/ewmh.c and uncomment the line

/* #define DEBUG_KST */

and re-install fvwm. Then, you will have "KST" debug msg on
stderr as:

ADD_TO_KST: 0x1200017
ADD_TO_KST: 0x1200017 0x2000009
KST_UNMAP: 0x1200017
KST_UNMAP: 0x2000009
...

These msg may help me.

Regards, Olivier