Subject: CVS migo: * FvwmEvent now executes all window related events within a window context,

From: FVWM CVS <[email-masked]>
Date: Tue, 15 Apr 2003 20:40:44 -0500

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	migo	03/04/15 20:40:44

Modified files:
	.              : ChangeLog NEWS 
	docs           : FAQ 
	fvwm           : fvwm.1.in 
	modules        : ChangeLog 
	modules/FvwmEvent: FvwmEvent.1 FvwmEvent.c 

Log message:
* FvwmEvent now executes all window related events within a window context,
_ so PassId is not needed anymore, and prefixes "WindowId $0" may be removed

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 16 Apr 2003 01:52:35 +0000

> _ so PassId is not needed anymore, and prefixes "WindowId $0" may be removed

This means that if you have FvwmEvent configuration like this:

  *FvwmEvent: PassId
  *FvwmEvent: raise_window  RestoreWindow
  *FvwmEvent: deiconify     RestoreWindow
  *FvwmEvent: dewindowshade RestoreWindow

  AddToFunc RestoreWindow
  + I WindowId $0 Raise
  + I WindowId $0 Iconify off
  + I WindowId $0 (XTerm) WindowShade off

you may freely replace it with:

  *FvwmEvent: raise_window  RestoreWindow
  *FvwmEvent: deiconify     RestoreWindow
  *FvwmEvent: dewindowshade RestoreWindow

  AddToFunc RestoreWindow
  + I Raise
  + I Iconify off
  + I ThisWindow (XTerm) WindowShade off

I will backport this to 2.4.x, so I may start to suggest a new syntax.

Regards,
Mikhael.