Subject: menu changes - please test

From: [email-masked]
Date: Sat, 26 Apr 2003 21:39:19 +0200

I've made a few patches that affect the handling of context
windows and the specific context bit s in menus.  Can someone
please help testing:

  - Menus invoked from various contexts
  - Running the dynamic... menu actions from/outside a context
  - Dynamic menu functions that destroy the context window
  - Same for tear off menus
  - Same for indirect root menus (PopupAsRootMenu menu style).

Watch out for core dumps and actions being applied to the wrong
windows or window contexts.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sat, 26 Apr 2003 17:03:18 -0400

> windows or window contexts.

Heres one:

(gdb) where
#0  0x402941a7 in malloc () from /lib/libc.so.6
#1  0x40293f98 in malloc () from /lib/libc.so.6
#2  0x080c4f4a in safemalloc (length=124) at ../../fvwm2_5_7/libs/safemalloc.c:43
#3  0x080abf36 in exc_clone_context (excin=0x811f2a0, ecc=0xbffff3a0, mask=20)
    at ../../fvwm2_5_7/fvwm/execcontext.c:140
#4  0x0806135b in HandleKeyPress (ea=0xbffff3f4) at ../../fvwm2_5_7/fvwm/events.c:2026
#5  0x080628ce in dispatch_event (e=0xbffff440) at ../../fvwm2_5_7/fvwm/events.c:3257
#6  0x0806295a in HandleEvents () at ../../fvwm2_5_7/fvwm/events.c:3295
#7  0x08083216 in main (argc=1, argv=0xbffff9b4) at ../../fvwm2_5_7/fvwm/fvwm.c:2427
#8  0x402305b0 in __libc_start_main () from /lib/libc.so.6
(gdb) 

I'm not quite sure what kicked it off, I was just starting to verify
that the menus were working.

I wasn't using the mouse.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: [email-masked]
Date: Sun, 27 Apr 2003 00:12:33 +0200

> that the menus were working.

Fixed?  If not, can you run it under Purify to catch the problem
earlier, please?

Bye

Dominik ^_^  ^_^

---

From: Dan Espen <[email-masked]>
Date: Sat, 26 Apr 2003 19:40:02 -0400

> Fixed?  If not, can you run it under Purify to catch the problem

Fixed.

The problem was caused by a menu built from another menu with
piperead.