Subject: CVS migo: * WindowListFunc is executed now within a window context,

From: FVWM CVS <[email-masked]>
Date: Mon, 14 Apr 2003 20:24:07 -0500

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	migo	03/04/14 20:24:07

Modified files:
	.              : ChangeLog NEWS todo-2.6 
	docs           : ChangeLog FAQ 
	fvwm           : ConfigFvwmDefaults fvwm.1.in windowlist.c 
	modules        : ChangeLog 
	modules/FvwmGtk: FvwmGtk.1 windowlist.c 
	modules/FvwmProxy: FvwmProxy.1 FvwmProxy.c 
	modules/FvwmWindowMenu: FvwmWindowMenu.in 
	sample.fvwmrc  : system.fvwm2rc-sample-95 

Log message:
* WindowListFunc is executed now within a window context,
_ so "WindowId $0" is not needed anymore in its definition.
_ Internal WindowList, FvwmGtk, FvwmProxy and FvwmWindowMenu all support
_ both old and new syntaxes for now.
_ todo-2.6: close E.14

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 15 Apr 2003 01:57:27 +0000

> _ so "WindowId $0" is not needed anymore in its definition.

This means that if you have redefined WindowListFunc like:

  DestroyFunc WindowListFunc
  AddToFunc   WindowListFunc
  + I WindowId $0 Raise
  + I WindowId $0 WindowShade off
  + I WindowId $0 WarpToWindow 50 10p

please replace it with:

  DestroyFunc WindowListFunc
  AddToFunc   WindowListFunc
  + I Raise
  + I WindowShade off
  + I WarpToWindow 50 10p

I think we may support only the second version in the future.

I will backport this to 2.4.x, so I may start to suggest a new syntax.

Regards,
Mikhael.