Subject: Switching to the new web design

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 20 Apr 2003 16:00:23 +0000

All pages seem to be converted. The new design is pretty usable now
although it does not have yet all planned extra features.

Please test it at http://fvwm.org/index.php

I think we may make it the default today.

The old pages may still be here, but they should be removed in some
near future after error404 supports the old-to-new url mapping.

BTW, thanks to Uwe who did all the design scripting.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 21 Apr 2003 04:00:49 +0000

It seems that including DirectoryIndex line in .htaccess gives Internal
Error 500 on fvwm.org (only). This line also somehow makes all php (even
if explicitly specified) to throw error 500 too. It is hard to know what
happens without seeing error_log.

Jason, can you please make DirectoryIndex override-able?

Regards,
Mikhael.

---

From: [email-masked]
Date: Mon, 21 Apr 2003 11:47:44 +0200

> BTW, thanks to Uwe who did all the design scripting.

Ahem, before that happens, a couple of important things have to
happen:

 1) Any windows-like decorations have to vanish.  Especially the
    big X in title button 1.
 2) The number of icons on the page has to reduce dramatically.
 3) Is *must* be possible to get to the logo competition rules
    without loading a page that shows all the submitted logos.

And I think it would look better if the pager bar started below
the page title, not at the top of the page:

  +-----------------------------------+
  | The Official FVWM Home Page       |
  |                                   |
  |+------------------------++-------+|
  || bla bla                || pager ||
  ||                        ||
  ...

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 21 Apr 2003 12:13:34 +0000

>  1) Any windows-like decorations have to vanish.  Especially the

I don't see currently any windows-like decorations, just cde-like ones.
I think that a missing close button is a feature (misfeature) of CDE/MWM,
it has nothing to do with our window manager that is configurable.

Besides, this "X" has a purpose, it is used to switch to another (plain)
layout, try it. :)

I thought about other buttons, something like:

  menu button - may open a real menu using javascript that for example
    shows a list of layouts (themes) and navigation tools to choose from
  maximize button - may disable pager (WindowList-like navigation?)
  close button - closes windows and pager like now

I also thought about using the maximize button to switch to plain layout,
but it's probably less intuitive for a random user. I let Uwe to decide.

I am not sure how this "X" may be confused with Windows. It is everywhere
now for usability. Does Windows support vector drawing? It is drawn from:

  ButtonStyle 2 Vector 17 \
    25x25@1 35x25@1 50x40@1 65x25@1 75x25@1 75x35@0 \
    60x50@0 75x65@1 75x75@0 65x75@0 50x60@0 35x75@0 \
    25x75@0 25x65@0 40x50@1 25x35@0 25x25@1

I think the following close button may look nicer, but less official:

  ButtonStyle 2 Vector 16 \
    20x20@1 30x20@1 50x40@1 70x20@1 80x20@1 80x30@0 \
    60x50@0 80x80@0 70x80@0 50x60@0 30x80@0 20x80@0 \
    20x70@0 40x50@1 20x30@0 20x20@1

>  2) The number of icons on the page has to reduce dramatically.

I think that we need an alternative navigation to the pager
(WindowList like or other). But the default may be a pager.

The plain layout is very fast, when a user sets it (later), it is
used for the entire site forever.

Alternativelly an option may be used to disable all pager icons
(but then the pager will not be compact and nice).

>     without loading a page that shows all the submitted logos.

The logo-competition/index page does not show any submitted logos, just
2 links, to the previous logos and to new ones (to be submitted yet).

> the page title, not at the top of the page:

I have no opinion here. I think the pager will not look nicer/more usable
if there is a void space. But maybe Uwe may suggest some nice layout. :)

I don't really see any of these as show stoppers. What others think?

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Mon, 21 Apr 2003 08:38:02 -0400

> I don't really see any of these as show stoppers. What others think?

It looks like a great improvement to me.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Marcus Lundblad <[email-masked]>
Date: Mon, 21 Apr 2003 17:17:22 +0200 (CEST)

> near future after error404 supports the old-to-new url mapping.

The window decorations don't render properly in Netscape 6 under Windows.
There is a grey border around, as if to much space is "reserved" before
drawing.
It works in IE 6, though...
And using Mozilla 1.4beta (Linux) works nicely.

//Marcus

---

From: [email-masked]
Date: Mon, 21 Apr 2003 21:22:32 +0200

> it has nothing to do with our window manager that is configurable.

But it has something to do with M$ Windows which introduced the X.
And I consider it a misfeature of said GUI.  Why do you need two
such buttons, one on the left and one on the right?

> Besides, this "X" has a purpose, it is used to switch to another (plain)

Yes, I tried it before, and it's a very good place to hide
something so that nobody will ever discover it is there.  I don't
get the connection between a "close window" button and the "change
layout" function either.

> but it's probably less intuitive for a random user. I let Uwe to decide.

Unless there is a big, fat, flashing arrow pointing to the buttons
saying "press here", people will discover the functions of the
window buttons only by chance.

> (but then the pager will not be compact and nice).

The icons on the front page serve no purpose and are too small.
Even if they were bigger I would not be able to determine what
clicking on them does.  Currently the icons serve no purpose, slow
down loading of the page and make it more difficult to focus on
the important information.  In other words:  they are un-fvwm-ish.

> 2 links, to the previous logos and to new ones (to be submitted yet).

I see.  Then it should be made clear that the images are links,
not logos.  Even after looking at the page again I did not
understand that this is not the gallery of submissions.

> I don't really see any of these as show stoppers. What others think?

I don't understand why we suddenly have to hurry.  There were a
number of things that were far more important to get done before
June that nobody cared about (like informing some magazines of
the birthday).

--

I've attached a screen shot that shows grey bars between the
window border and the title (same with the pager).  And there are
thick black bars between the desks of the pager.  Not sure if
they are there on purpose, but I think at most three or four
pixels are enough.  Currently it's a waste of space.
(Mozilla 1.0, Debian 3.0).

Bye

Dominik ^_^  ^_^

---

From: [email-masked]
Date: Mon, 21 Apr 2003 21:55:48 +0200

Some more bugs/typos on the pages:

 - The mailing list desk in the pager is labeled "Mailing Lis"
   Maybe the 't' is just out of the visible area.
 - The script that generated the page from the AUTHORS file ate
   up some of the whitespace , e.g. "emulation of" became
   "emulationof".  Probably the line breaks in the original
   entries.
 - The NEWS page always tries to be wider than the browser window.
   To access the pager at all, I have to use the scroll bar.
   Same on desktops.php and faq.php.
 - What exactly is the difference between the FVWM Screenshots
   page and desktops.php?  Looks like a duplicate page to me.
 - On the "Documentation" page there are some small pictures
   standing for the subsections.  The "man pages" picture 
 - There is no link to the mailing list archives in the pager,
   only in the "Quick jump" section.
 - I really dislike the nested pagers when descending too far down
   the pager hierarchy.  As far as i can see, it is used only on
   the "Developer Info" pages.  I'd rather have a whole new desk
   in the pager for it.
 - More superfluous icons on the Developer Info page.
 - The NEWS page is not up to date.
 - The birthday announcement is missing on the front page.

Bye

Dominik ^_^  ^_^

---

From: Bob Woodside <[email-masked]>
Date: Mon, 21 Apr 2003 17:38:13 -0400

> (Mozilla 1.0, Debian 3.0).

	Grrr!  Your [Mozilla 1.0] screen shot shows the same browser bug that
Marcus Lundblad reported in Netscape 6. Interestingly, this worked fine
in Netscape 4.7, and is fixed again in Netscape 7 (and as he reports, in
Mozilla 1.4beta).

	I suppose we'll have to find a way to hack around this bug, though.
There are still a lot of people using those versions of Netscape &
Mozilla.

Cheers,
Bob

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 22 Apr 2003 03:06:53 +0000

>    Maybe the 't' is just out of the visible area.

It is not me, but I think it is stripped to 11 chars on purpose.

>    "emulationof".  Probably the line breaks in the original

Fixed.

>    Same on desktops.php and faq.php.

NEWS "fixed". Desktops improved, but it should be really reformatted
not to contain any <pre>.

Still, if someone sets a too narrow window or too large fonts this always
can happen with any page especially if it uses <pre> ot tables.

>    page and desktops.php?  Looks like a duplicate page to me.

I think you speak about index.html and desktops.php, you should
instead see index.php and desktops.php. It is a temporary problem
that desktops.php links to ./ that currently defaults to index.html
on fvwm.org. Currently use Back button to return, not the pager.

>    standing for the subsections.  The "man pages" picture 

I think this sentense is not complete. I don't see a problem with
the "Documentation" page and the "man pages" picture.

You probably mean it is a picture shot from 2.4.x, not 2.5.x.

>    only in the "Quick jump" section.

It should be of course done later. There will be a page that links to all
mailing list archives and searches on the web, there are several with
some advantages and disadvatages. Maybe some search form too.

>    the "Developer Info" pages.  I'd rather have a whole new desk

No opinion here, and I do not do the section coding anyway :).
It probably may be done like you suggest later.

>  - More superfluous icons on the Developer Info page.

I think it is good to have one "item" icon for the main page and this
page. It will be loaded only once and will be cached for other pages.
I will try to find a nice "item" icon.

>  - The birthday announcement is missing on the front page.

Both done.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Apr 2003 10:00:06 +0200

> the "Documentation" page and the "man pages" picture.

I made up my mind while writing it and forgot to delete it.  I
wanted to say that the first thing that I noticed was the
"[-blackout]" option on the picture which is the one option that
is only supplied for backward compatibility.  Not really
important, just odd.

Bye

Dominik ^_^  ^_^

---

From: Uwe Pross <[email-masked]>
Date: Tue, 22 Apr 2003 12:43:57 +0200

Hi there,

On 21 Apr 2003 at 17:38:13 -0400, Bob Woodside wrote:

> Grrr!  Your [Mozilla 1.0] screen shot shows the same
> browser bug that Marcus Lundblad reported in Netscape
> 6. Interestingly, this worked fine in Netscape 4.7, and is
> fixed again in Netscape 7 (and as he reports, in Mozilla
> 1.4beta).
> 
> I suppose we'll have to find a way to hack around this
> bug, though.  There are still a lot of people using those
> versions of Netscape & Mozilla.

Mozilla 1.0 and netscape 6.0 had some problems with urls in
the document type declaration.
I removed this url in the current version - Hope that there
are no problems with other browsers now.

Regards, Uwe
-- 
  ,_,  Uwe Pross
 (O,O) mailto:[email-masked]
 (   ) http://www.tu-chemnitz.de/~uwp
=-"-"-================================
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Apr 2003 12:57:54 +0200

> are no problems with other browsers now.

Now the space between the page title and has shrunk to only about
half a line (mozilla 1.2.1, Debian 3.0).  See attachment.

Bye

Dominik ^_^  ^_^

---

From: Uwe Pross <[email-masked]>
Date: Tue, 22 Apr 2003 13:02:41 +0200

Hi there,

> half a line (mozilla 1.2.1, Debian 3.0).  See attachment.

The shot looks alright to me. Could you send a larger shot
to make to problem clearer? I use mozilla 1.2 and cannot see
any problems.

Regards, Uwe

---

From: Uwe Pross <[email-masked]>
Date: Tue, 22 Apr 2003 13:06:09 +0200

Hi there,

> It is not me, but I think it is stripped to 11 chars on purpose.

I stripped the desktop name to the first 11 or 12 characters
to limit the width of the pager.
This can be removed if it is not liked.

> some advantages and disadvatages. Maybe some search form too.

The mailing list archive does not belong to the
php-tree. Currently only pages php within the php tree are
displayed in the pager. It makes not that much sense to have
"external" pages displayed in the pager since the pager will
disapear when you go to them.

> >    the "Developer Info" pages.  I'd rather have a whole new desk

This may lead to a new layout style. The php-pages descibe a
navigation structure which is displayed by the layout
files. We may add a new layout which displays the nav
structure as you like.

> I will try to find a nice "item" icon.

The icons I used were just suggestions. I expected a
discussion about it.

Regards, Uwe

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Apr 2003 13:14:12 +0200

On Tue, Apr 22, 2003 at 01:02:41PM +0200, Uwe Pross wrote:
> The shot looks alright to me.

Before the last change, there was about three times as much space
above and below the page title.  That looked much better.

> Could you send a larger shot

Attached.

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Apr 2003 13:31:43 +0200

> The icons I used were just suggestions. I expected a

Okay, let's discuss it.  I think we do not need icons in the main
page area.  If people want icons to navigate they can click on the
pager.  In the text area they just mess up the layout without
providing easier access.

By the way, I suggest to reshuffle the links on the front page
like this:

Left side - project related information, sorted by importance

  Features
  FAQ
  Bug Reporting
  Mailing Lists
  Mailing List Archive
  Man pages
  Authors
  Developer Info

Right side - downloads and external links

  Download
  Decors
  Desktops
  Menus
  FVWM Themes
  Icons and Sounds
  Links
  Other Important Info ^_^

Bye

Dominik ^_^  ^_^

---

From: Uwe Pross <[email-masked]>
Date: Tue, 22 Apr 2003 13:43:22 +0200

Hi there,

On 21 Apr 2003 at 21:22:32 +0200, [email-masked] wrote:

> > I don't see currently any windows-like decorations, just
> > cde-like ones.  I think that a missing close button is a
> > feature (misfeature) of CDE/MWM, it has nothing to do
> > with our window manager that is configurable.
> 
> But it has something to do with M$ Windows which
> introduced the X.  And I consider it a misfeature of said
> GUI.  Why do you need two such buttons, one on the left
> and one on the right?

This a layout suggestion in the style of fvwm vector
buttons. It shows a possible fvwm window decoration. We may
add more or less buttons if or use graphical window
decoration like:
http://www.fvwm.org/index.php?decoration_path=pictures/decorations/window_deco_ice

> get the connection between a "close window" button and the "change

I put it on the "x" to close the window decoration. To put
it there was thought to be a fancy hidden feature. 
When I had the window layout inside my browser I tried
intuitively to press one of the window buttons ;-)

More layouts may be accessable via a separate layout
page. Which allows one to specify how layout information are
passed to sub pages (cookie, get, session, maybe post).

> >   menu button - may open a real menu using javascript
> >   that for example shows a list of layouts (themes) and
> >   navigation tools to choose from

You really want to have javascript on the fvwm web page?

> >   maximize button - may disable pager (WindowList-like
> >   navigation?)  close button - closes windows and pager
> >   like now

This can be done, but may take a while.

> > (but then the pager will not be compact and nice).

Currently I convert the layout defintion to php classes so
that further layouts can be derived from a layout base
class. Once this is done - we can easily make further
layouts with windowlist or other navigation styles.

> The icons on the front page serve no purpose and are too
> small.  Even if they were bigger I would not be able to
> determine what clicking on them does.  Currently the icons
> serve no purpose, slow down loading of the page and make
> it more difficult to focus on the important information.
> In other words: they are un-fvwm-ish.

Yes, you right. I thought it as a fancy add-on. I have removed
them for now.

Regards, Uwe

---

From: Uwe Pross <[email-masked]>
Date: Tue, 22 Apr 2003 13:44:39 +0200

Hi there,

> above and below the page title.  That looked much better.

The remaining space is wanted to separate the different desktops.

Regards, Uwe

---

From: Uwe Pross <[email-masked]>
Date: Tue, 22 Apr 2003 13:52:24 +0200

Hi there,

> By the way, I suggest to reshuffle the links on the front page

This can be done. It is not that fast to make since you want
to mix internal and external links. I have got a solution in
mind but it is a bit work - maybe tonight.

Regards, Uwe

---

From: Dan Espen <[email-masked]>
Date: Tue, 22 Apr 2003 08:38:23 -0400

> above and below the page title.  That looked much better.

The Title on the background seems redundant with a similar title
so close to it in the window titlebar.

How about eliminating the title on the background?
It doesn't fit into the desktop metaphor.

---

From: Uwe Pross <[email-masked]>
Date: Tue, 22 Apr 2003 14:48:22 +0200

Hi there,

> It doesn't fit into the desktop metaphor.

That's right, but a page should a have a proper title. The
title on the window decoration maybe empty or there are more
than one windows on one page.

How about making a FvwmButtonBar to display the title? It
could look more like a fvwm desktop.

Regards, Uwe

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Apr 2003 14:57:03 +0200

> so close to it in the window titlebar.

Currently we have

  +-----------------------------------------
  |
  |  THE OFFICIAL FVWM HOME PAGE
  |
  | +------------------------------+
  | | Welcome to FVWM              |
  | +------------------------------+
  | |                              |
  | | bla                          |
  | |                              |
  | |                              |

The logo is still missing on the front page.  How about this:

  +---------------------------------------------------
  |
  |  [FVWM LOGO]
  |
  | +----------------------------------------+
  | | Welcome to the official FVWM Home Page |
  | +----------------------------------------+
  | |                                        |
  | | bla                                    |
  | |                                        |
  | |                                        |

> It doesn't fit into the desktop metaphor.

Agreed, but on the other pages we need some place for a prominent
page title.

Bye

Dominik ^_^  ^_^

---

From: Dan Espen <[email-masked]>
Date: Tue, 22 Apr 2003 09:07:51 -0400

> than one windows on one page.

I only see one page with 2 windows (Logo competition).
I think it would look better as one window.

(I think the 2 big logos on the lower window look like the
only logos we have.  I had to hesitate a bit before I knew
I was supposed to click on them.)

Maybe if it said "View Old Logos".

> could look more like a fvwm desktop.

Sounds interesting.

Speaking of multiple windows on a page, I just noticed that
the pager makes it look like every page has 2 windows on it.
Not that it bothers me.

How come none of these links are underscored?

When I switch styles and then use the pager to go to a new
page or reload the page, it reverts to the original style.
Is that a problem on my end?

---

From: Dan Espen <[email-masked]>
Date: Tue, 22 Apr 2003 09:12:14 -0400

> Agreed, but on the other pages we need some place for a prominent

Why can't all the pages use the titlebar for the page title.

I run Mozilla with tabs.  I have the title in Mozilla's Titlebar,
in the tab, on the page above the window and on the page in the
simulated title bar.

I think its a little bit "over titled".

---

From: Uwe Pross <[email-masked]>
Date: Tue, 22 Apr 2003 15:17:58 +0200

Hi there,

> the pager makes it look like every page has 2 windows on it.

This can be changed. 
BTW: The pager on the web can only look like a pager on fvwm.
     The behaviour can be imitated only.

> How come none of these links are underscored?

css definitions. 

> Is that a problem on my end?

Changing the style using mozilla "View -> Use Style ..."? 

It is normal that this setting is discarded when you move to
subpages. To remain settings we must define a layout like
plain or default.

Regards, Uwe

---

From: Uwe Pross <[email-masked]>
Date: Tue, 22 Apr 2003 15:21:56 +0200

Hi there,

> I think its a little bit "over titled".

I will make a layout suggestion on this so we can decide if
this will be the default layout.

Regards, Uwe

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 22 Apr 2003 14:21:49 +0000

> > GUI.  Why do you need two such buttons, one on the left

I didn't want to comment on this. But I think the decision to combine
2 opposite actions in one button (window operation menu and close) was
a tragic error. This makes this button both dangerous for a menu and
inconvenient for close (double click with a menu poping in the middle).
If you have a mouse with a trembling button 1 you know what it means. :)

It is just so much convenient to have a separate close button. I am for
one is (was) addict for this cde-ish behaviour and I still have the menu
that closes a window, because I have a good mouse now. :)
But I mostly close a window with a comfort using the "X" button.

  menu button - Menu pops immediatelly on press, Close on double click
  close button - Delete on "C", Destroy on "D" and Nop on "M" and "H"

The close button is very convenient and it does not duplicate things.
You may even cancel the closing if you changed your mind after a press.

> http://www.fvwm.org/index.php?decoration_path=pictures/decorations/window_deco_ice

Can I please suggest the url to be shorter and more understandable:

  http://www.fvwm.org/?decoration=window_ice

> it there was thought to be a fancy hidden feature. 

Fancy hidden feature, and functional too. I like it. :)

> passed to sub pages (cookie, get, session, maybe post).

Good idea, this page may in the same section with Links, and the section
may be called "Web Site" or similar.

> You really want to have javascript on the fvwm web page?

Let's drop this idea for now.

I have a javascript code that popups a menu. It may be nice, but not
really an important thing.

The logic is, if javascript is disabled or unsupported, it does nothing,
otherwise it opens a popup (it is not a <select> popup, it is better).

> This can be done, but may take a while.

Not urgent in the next months at all.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Apr 2003 16:44:02 +0200

> Why can't all the pages use the titlebar for the page title.

I don't disagree in principle.  It's just that a 12 point font in
a window title does not match my definition of 'prominent'.  We'd
have to blow up the window title to a ridiculous height, including
the buttons.

Bye

Dominik ^_^  ^_^

---

From: Bob Woodside <[email-masked]>
Date: Tue, 22 Apr 2003 10:42:53 -0400

On Tue, 22 Apr 2003 13:43:22 +0200
Uwe Pross <[email-masked]> wrote:

dv > > I don't get the connection between a "close window" button
dv > > and the "change layout" function either.

uwp > I put it on the "x" to close the window decoration. To put
uwp > it there was thought to be a fancy hidden feature. 
uwp > When I had the window layout inside my browser I tried
uwp > intuitively to press one of the window buttons ;-)

	I've been doing that all along. Imagine my surprise the first time I
absent-mindedly clicked one and it actually did something.  ;-)

	I agree with Mikhael that the "X" has been pretty much ubiquitous for a
long time, and is not a concern per se. However, Dominik's point is
valid that the connection with what it does isn't too intuitive. Perhaps
the alt tag should say something like "Close FVWM Desktop Emulation".

	Of course, to make the "desktop illusion" complete, the Close button
should really remove the "window" from the page, leaving nothing but the
Pager. I'm not sure we want to follow the implications of this too
rigorously, though.

uwp > More layouts may be accessable via a separate layout
uwp > page. Which allows one to specify how layout information are
uwp > passed to sub pages (cookie, get, session, maybe post).

	Yes, I think we definitely need a page for explaining/setting the
various layout options, and a prominent link to call their attention to
it. The feature is too good to let people miss.

migo > > > I thought about other buttons, something like:
migo > > > 
migo > > >   menu button - may open a real menu using javascript
migo > > >   that for example shows a list of layouts (themes) and
migo > > >   navigation tools to choose from

uwp > You really want to have javascript on the fvwm web page?

	As long as one can navigate through all the basics without it, I think
it's a great idea. The titlebar buttons really cry out to be
clicked...and of course, once you click one you're disappointed if you
don't see something happen. A real menu popping up when you click a
button would definitely enhance the desktop illusion. I've been hesitant
about suggesting this myself, as I haven't had any time to work on the
Web pages lately.

	I believe that most people who disable JavaScript (or use really old
browsers) understand that they may not see everyhing a site has to offer
(and may not want to). They only get angry if they can't see *anything*
without xxx-Script or yyy-Plugin. We'd just want to consider carefully
these issues:

        1) You should be able to navigate through everything without the
JavaScript bells & whistles.
        2) Browsers without JavaScript support (e.g., Amaya) should
still display all the important stuff OK - not too difficult.
        3) We probably need the PHP code to analyze what browser is
being used and eliminate the fancy stuff for older browsers. Here I'm
not thinking so much of JavaScript support itseld, but the level of CSS
support - overlaying HTML elements and manipulating their visibility,
positioning,  and z-index attributes, etc. (Also to be considered is
whether we would want to insert special code for Netscape 4 layers or
just treat NS 4 as a disabled browser.)

migo > > >   maximize button - may disable pager (WindowList-like
migo > > >   navigation?)  close button - closes windows and pager
migo > > >   like now

	Actually, to follow the desktop illusion theme a bit, wouldn't it be
better just to drop the pager (and any other extras that may get added
to the page layout) and just have the "window" occupy the whole page
(desktop)?

Cheers,
Bob

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Apr 2003 16:50:10 +0200

> You may even cancel the closing if you changed your mind after a press.

Shrug.  As always, we sseem to have orthogonal opinions of window
buttons.  The only time I touch the mouse to trigger a window
operation is when I move or resize it, and if I need the window
menu to kill it when Close does not work.  For me the title
buttons are there only to give visual feedback about the window
state.

But this all has nothing to do with the issue at hand.  I don't
want decorations reminding me of M$ Windoze on the fvwm web page.

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 22 Apr 2003 15:01:13 +0000

> have to blow up the window title to a ridiculous height, including

Good point.

Although I can't deny, it is a bit over-titled, I think every title may
have its function, if no, it may be empty.

Waiting for Uwe to show another layout, but I am ok with the current one.

I think pages with several windows are ok when appropriate.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Apr 2003 17:08:08 +0200

> Waiting for Uwe to show another layout, but I am ok with the current one.

... but currently we have no logo on the page.  This is a must.

> I think pages with several windows are ok when appropriate.

No problem here.  By the way, I think the pager should have a
normal window border, perhaps three pixels wide.

Bye

Dominik ^_^  ^_^

---

From: Bob Woodside <[email-masked]>
Date: Tue, 22 Apr 2003 11:21:06 -0400

On Tue, 22 Apr 2003 14:21:49 +0000
Mikhael Goikhman <[email-masked]> wrote:

uwp > > This a layout suggestion in the style of fvwm vector
uwp > > buttons. It shows a possible fvwm window decoration. We may
uwp > > add more or less buttons if or use graphical window
uwp > > decoration like:
uwp > >
http://www.fvwm.org/index.php?decoration_path=pictures/decorations/window_deco_ice

migo > Can I please suggest the url to be shorter and more
migo > understandable:
migo > 
migo >   http://www.fvwm.org/?decoration=window_ice

	Or even just

         http://www.fvwm.org/?decor=ice

migo > > More layouts may be accessable via a separate layout
migo > > page. Which allows one to specify how layout information are
migo > > passed to sub pages (cookie, get, session, maybe post).
migo > 
migo > Good idea, this page may in the same section with Links, and the
migo > section may be called "Web Site" or similar.

	Or "Site Viewing Options"? "Customize This Web Site"? ("My FVWM"...? 
Nahhh!)

	I would favor pointing to it with one of the top level links rather
than having it buried in the Links section.

migo > > > > I thought about other buttons, something like:
migo > > > > 
migo > > > >   menu button - may open a real menu using javascript
migo > > > >   that for example shows a list of layouts (themes) and
migo > > > >   navigation tools to choose from

uwp > > You really want to have javascript on the fvwm web page?

migo > Let's drop this idea for now.

	For now, I agree, though I can't stop thinking about the possibilities 
:-). Let's get the basics on a really solid footing first. It doesn't
need to be in the first release. But we should keep it in mind for
later.

Cheers,
Bob

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 22 Apr 2003 16:37:20 +0000

On 22 Apr 2003 11:21:06 -0400, Bob Woodside wrote:
> uwp > > http://www.fvwm.org/index.php?decoration_path=pictures/decorations/window_deco_ice
> 

Actually, it may be "window_ice", because it is possible to have
a mere border, not a window, i.e. "border_seagreen". See the current:

  http://www.fvwm.org/index.php?decoration_path=pictures/decorations/border_seagreen

But with border-only the title text is lost. No idea what to do about it.
Probably not a big deal since the window title is more as a hint.

> than having it buried in the Links section.

I think it is a meta page and then may be in the last section.
Of course we may link to it from the home page too (in the quick jumps).

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 22 Apr 2003 16:55:47 +0000

> ... but currently we have no logo on the page.  This is a must.

But we will have a new logo only on August 1 accourding to your plan.
I prefer to be without a logo for now than with the old fvwm_smaller.gif.
I may use the following logo (probably smaller and not red) if you like:

  http://www.fvwm.org/logo-competition/logos/old/red_cursive_framed.png

If we launch (and announce) both the new site and the logo competition
now, we may have some other good logo submitted till Juny 1.

Regards,
Mikhael.

---

From: Bob Woodside <[email-masked]>
Date: Tue, 22 Apr 2003 16:39:10 -0400

On Tue, 22 Apr 2003 16:55:47 +0000

> I prefer to be without a logo for now than with the old

	Just out of curiosity, am I the only one who doesn't dislike the old
logo intensely? Not that I don't think having a new one is a good idea
for the 10th anniversary, but I never disliked the old one. Any other
opinions?

Cheers,
Bob

---

From: Dan Espen <[email-masked]>
Date: Tue, 22 Apr 2003 16:44:06 -0400

> for the 10th anniversary, but I never disliked the old one. Any other

I don't dislike it too.

:)

---

From: [email-masked]
Date: Wed, 23 Apr 2003 00:05:29 +0200

> > But we will have a new logo only on August 1 accourding to

First of September.

> > I prefer to be without a logo for now than with the old

Come on, we lived with it for years.  At least the new design
should have a defined place for the new logo.

> for the 10th anniversary, but I never disliked the old one. Any other

It's red.  Isn't that bad enough?  ;-)

Seriously, I personally don't care about how the logo looks since
I don't use logos.  But I guess that it is at least partially
responsible if people turn away from fvwm quickly after loading
the fvwm home page.

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 23 Apr 2003 00:39:22 +0000

> should have a defined place for the new logo.

We lived with the old design for years too. :)

> responsible if people turn away from fvwm quickly after loading

Ok, I added the logo that I like much more than the old one. It matches
our FvwmBanner, just nicer. If you want it in another color, tell me.
But I think this is a purpose of the logo competition. :)

I think it does not turn away quickly after loading the home page.

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Tue, 22 Apr 2003 22:19:10 -0400

Mikhael Goikhman <[email-masked]> writes:
> our FvwmBanner, just nicer.

I like the color.  Almost any shade of blue does it for me.

About 4 times larger it makes a good FvwmBanner default.

---

From: Uwe Pross <[email-masked]>
Date: Wed, 23 Apr 2003 07:53:52 +0200

Hi there,

On 23 Apr 2003 at 00:39:22 +0000, Mikhael Goikhman wrote:

> Ok, I added the logo that I like much more than the old
> one. It matches our FvwmBanner, just nicer. If you want it
> in another color, tell me.  But I think this is a purpose
> of the logo competition. :)

I changed the color a little bit so that it matches the
actual window decoration. Maybe we move the logo selection
(color selection) to the layout files, so that one layout
has a red colorized logo and another one a blue colorized
one.

I like the actual link colors more than the one I choosen
since the actual colors are not that bright. But I think
they do not match to the actual steelblue window
decor that good. Maybe we use a steelblue color for the
links as well.

Regards, Uwe

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Apr 2003 10:40:31 +0200

> I think it does not turn away quickly after loading the home page.

Yes, this looks much better, I think.  Nicely integrated with the
page title too and also adds the missing spacing above and below
the title.

The bullet in the Quick Jumps list looks good.  May I suggest to
use a different colour for the bullets?  At the moment, we have
too many different colours:  blue (logo), greenish blue ("Quick
Jumnps"), yellow (links), pale pink (selected links), and the
colour in the bullets (blueish red).  I have attached a new
version that uses blue tones instead and is slightly dimmed (in
PNG format, gimp does not like GIFs) as a suggestion.

And finally, the list of links on the front page should be
centered in the window.

Bye

Dominik ^_^  ^_^

---

From: Uwe Pross <[email-masked]>
Date: Wed, 23 Apr 2003 10:59:40 +0200

Hi there,

> And finally, the list of links on the front page should be

The actual version uses your bullet and less colors on the
same tone. The link and section colors might be a bit too
dark.

Regards, Uwe

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Apr 2003 11:31:01 +0200

> same tone. The link and section colors might be a bit too

I think the yellow links were fine.  The current blue is too
similar to the section title.  You can not distinguish between
links, visited links and normal titles anymore.

Bye

Dominik ^_^  ^_^

---

From: Uwe Pross <[email-masked]>
Date: Wed, 23 Apr 2003 13:09:29 +0200

Hi there,

> links, visited links and normal titles anymore.

I switched back to yellow links.

Uwe

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Apr 2003 13:33:56 +0200

> I switched back to yellow links.

Looks very nice.  The site is almost ready now.  There are a few
quirks left, though:

 - The pager is now wider than before (mozilla 1.2.1).  The pages
   do not have 4:3 ratio anymore.  It looks more like 2:1 (see
   attached picture).
 - Despite the additional space, the "Mailing List" desk still has
   the 't' cut off.
 - Visited links are not marked with a different colour.
 - On the logo page, when you move the pointer over one of the
   pictures, a yellow bar is drawn below them as if there were a
   link to hilight.

How do I change the order of the Quick Jumps and their names?

Bye

Dominik ^_^  ^_^

---

From: Uwe Pross <[email-masked]>
Date: Wed, 23 Apr 2003 13:50:09 +0200

Hi there,

>    do not have 4:3 ratio anymore.  It looks more like 2:1 (see

Yes, I have noticed this as well, but I am not sure why it
is like this. I will have a look ...

>  - Despite the additional space, the "Mailing List" desk still has

I have given one more character to destop names ;-)

>  - Visited links are not marked with a different colour.

Visited links are a bit darker now.

Fixed.

> How do I change the order of the Quick Jumps and their names?

Have a look in /index.php and search for
insert_quick_jump_list. The names for external links are
given there. The names for internal links, means to sub
pages, are given by the php-file header in the target file. 

e.g. in screenshots/desktops.php:
...
$link_name      = "Desktops";
...

Says that other pages refering to this pages use Desktops as
link name.

Regards, Uwe

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Apr 2003 14:58:57 +0200

> is like this. I will have a look ...

Now it has become even wider, about 5:2.  Are you tuning it in the
right direction? ;-)

> Visited links are a bit darker now.

A bit more, please.

> The names for internal links, means to sub

Is that the string that is displayed in the QJ list?

Bye

Dominik ^_^  ^_^

---

From: Uwe Pross <[email-masked]>
Date: Wed, 23 Apr 2003 15:13:04 +0200

Hi there,

> Now it has become even wider, about 5:2.  Are you tuning it in the

I found the bug. Should be fixed now.

> > Visited links are a bit darker now.

Changed to light blue

> Is that the string that is displayed in the QJ list?

Currently, yes. 

If you want to distiguish between link_name and a 
quick_jump_name we may add this in the file headers. The
link_name may be used if quick_jump_name is not
given. navgen.cli must be changed to support this.

If you are happy with one link_name and like to change the
link name for some pages, don't forget to run navgen
afterwards to get a actual navigation.inc.

Regards, Uwe

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Apr 2003 15:48:46 +0200

> > > Visited links are a bit darker now.

Perfect.  I see no more reason to delay going online.  The
remaining things are only cosmetic and can be done later.

Ah, well, there is one more thing:  The logo competition schedule
has to be updated.  I'll do that.  It will start on 1st of May so
we have a week to figure out where to announce it.

Bye

Dominik ^_^  ^_^

---

From: Uwe Pross <[email-masked]>
Date: Wed, 23 Apr 2003 16:00:03 +0200

Hi there,

> we have a week to figure out where to announce it.

What happend with the internal server error Mikhael reported
when he changed .htaccess? Was there a fix found?

If we don't want to use .htaccess settings we may remove all
index.html files. But I like changing .htaccess a bit more
since the old files are remaining.

Regards, Uwe

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 23 Apr 2003 14:09:33 +0000

> Jason, can you please make DirectoryIndex override-able?

Jason, you didn't answer this one, please answer.

Please uncomment the DirectoryIndex in .htaccess on the server for a
short time (because we don't want the site to be non accessible) and tell
us why apache throws Internal Error 500, it should not. Thanks.

Regards,
Mikhael.

---

From: Jason L Tibbitts III <[email-masked]>
Date: 23 Apr 2003 09:57:26 -0500

>>>>> "MG" == Mikhael Goikhman <[email-masked]> writes:

MG> Please uncomment the DirectoryIndex in .htaccess on the server for
MG> a short time (because we don't want the site to be non accessible)
MG> and tell us why apache throws Internal Error 500, it should
MG> not.

Umm, it doesn't?  I really don't see what you're talking about.  I
removed the octothorpe from the second line of the .htaccess file and
the behavior of the web site didn't change at all.  I've put it back
now.

 - J<

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 23 Apr 2003 15:17:06 +0000

> the behavior of the web site didn't change at all.  I've put it back

When I uncommented it in cvs 2.5 days ago it returned Internal Error 500
on all php files.

Anyway, please either make DirectoryIndex in the apache configuration
override-able, so that we may change the index.php vus index.html order
in .htaccess (preferable), or change this order explicetely in http.conf.

The goal is for http://fvwm.org/ to go to index.php, not index.html.

Regards,
Mikhael.

---

From: Jason L Tibbitts III <[email-masked]>
Date: 23 Apr 2003 10:21:31 -0500

>>>>> "MG" == Mikhael Goikhman <[email-masked]> writes:

MG> Anyway, please either make DirectoryIndex in the apache
MG> configuration override-able, so that we may change the index.php
MG> vus index.html order in .htaccess (preferable), or change this
MG> order explicetely in http.conf.

It already is.  That's what I'm not understanding about your problem.

 - J<

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 23 Apr 2003 16:38:06 +0000

> It already is.  That's what I'm not understanding about your problem.

Good that it works now.

I guess the error message for these Internal Error 500 that I got
may be found in error_log on the server.

Ok, now that we have the new design online, I will send a short
(non official if you like) notice about it to our users.

Regards,
Mikhael.