Subject: ./configure --without-... in 2.5.6

From: Alexander Kotelnikov <[email-masked]>
Date: Sat, 26 Apr 2003 22:16:22 +0400

Hello.

Is it a feature, that if I configure 2.5.6 as, say,
./configure --without-imlib
FvwmGtk still will be built *with* imlib, if a proper version is
installed?

-- 
Alexander Kotelnikov
Saint-Petersburg, Russia
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked]
Date: Sat, 26 Apr 2003 21:02:43 +0200

> FvwmGtk still will be built *with* imlib, if a proper version is

Kind of.  Some (all?) of the macros that control the
--with-foobar-prefix and --with-foobar-exec-prefix options to
configure simply do not support a --without-foobar option.  It
would be nice if they did, though.  A patch is welcome.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 26 Apr 2003 19:09:46 +0000

> FvwmGtk still will be built *with* imlib, if a proper version is

There is no such option --without-imlib, see "configure --help"
and INSTALL.fvwm for the list of all valid options.
There is also the section "Optional libraries used by FvwmGtk".

Regards,
Mikhael.