Subject: FVWM and GNOME2

From: Alexander Kotelnikov <[email-masked]>
Date: Mon, 21 Apr 2003 17:55:47 +0400

Hello.

I have got a report that FVWM 2.4 does not work with GNOME2.
Can anyone comment on this? 
http://bugs.debian.org/189664

Thanks,
-- 
Alexander Kotelnikov
Saint-Petersburg, Russia
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Alexander Kotelnikov <[email-masked]>
Date: Tue, 22 Apr 2003 14:09:11 +0400

>>>>> On Tue, 22 Apr 2003 09:51:21 +0200
>>>>> "DV" == Dominik Vogt <[email-masked]> wrote:
DV> 
>> http://bugs.debian.org/189664
DV> 
>>> Package: fvwm
>>> Version: 2.4.15-2
>>> Severity: normal
>>> 
>>> "Important Bug. Has a major effect on the usability of a package [...]"
>>> 
>>> fvwm 2.4.x just does not work with gnome (this is explained in the FAQ
>>> too). Please package a new developement release.
DV> 
DV> (Note:  you can dramatically improve our responsiveness by pasting
DV> bug reports into your mails).

Sorry. Original report was not clear and full transcript consists of
three messages available from provided URL. Here an excerpt from the
last message goes:
------
 >MdI> fvwm 2.4.x just does not work with gnome (this is explained in the FAQ
 >MdI> too). Please package a new developement release.
 >There are several issues on it:
 >1. Both FVWM and GNOME FAQ's I have just read say that from FVWM 2.3
 >they work together
Sadly this is not true. If you use gnome-session from gnome2 it will
hang for a few minutes waiting a timeout (I think it does not realize
that a window manager has been started).
See http://fvwm-ewmh.sourceforge.net/ for details.
...
It would fix my problem (I *did* try building an unofficial package for
fvwm 2.5 but I haven't been able to make it compile...) but please
remember that fvwm 2.4 cannot be used by gnome2 users.
------

DV> What exactly does this bug report tell us other than "it does not
DV> work"?  Without a description of the perceived problems there is
DV> nothing what we can do.  Did the reporter read FAQ 2.7?

He read even more :).

---

From: Dan Espen <[email-masked]>
Date: Tue, 22 Apr 2003 08:41:54 -0400

> DV> nothing what we can do.  Did the reporter read FAQ 2.7?

I read all the links and this mail, and I'm still not sure what the
problem is.

Is the problem the hang?

Is the problem that it won't compile?

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Alexander Kotelnikov <[email-masked]>
Date: Tue, 22 Apr 2003 18:33:33 +0400

>>>>> On Tue, 22 Apr 2003 08:41:54 -0400
>>>>> "DE" == Dan Espen <[email-masked]> wrote:
DE> 
DE> Is the problem the hang?

2.4 hang.

DE> Is the problem that it won't compile?

2.5 does not compile to him, but Marco belives, that it will work.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Apr 2003 09:51:21 +0200

>> too). Please package a new developement release.

(Note:  you can dramatically improve our responsiveness by pasting
bug reports into your mails).

What exactly does this bug report tell us other than "it does not
work"?  Without a description of the perceived problems there is
nothing what we can do.  Did the reporter read FAQ 2.7?

Bye

Dominik ^_^  ^_^