Subject: Notification: incoming/1001

From: [email-masked]
Date: Thu, 20 Mar 2003 07:26:52 -0600

FVWM Bug Tracking notification

new message incoming/1001

Message summary for PR#1001
	From: [email-masked]
	Subject: KDE Kicker Pager shows different virtual desktop number
	Date: Thu, 20 Mar 2003 07:26:51 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Thu Mar 20 07:26:52 2003
From: [email-masked]
To: [email-masked]
Subject: KDE Kicker Pager shows different virtual desktop number
Date: Thu, 20 Mar 2003 07:26:51 -0600

Full_Name: Robby Pählig
Version: 2.5.6
CVS_Date: 
OS: Linux 2.4.19
X_Server: XFree86 4.3
Submission from: (NULL) (212.202.167.112)

The KDE KIcker Pager shows a different virtual desktop number than
selected. The number is always the true desktop number plus 1. If I
reconfigure fvwm to use virtual desktops 0 to 11, the behaviour is the
same, but additionally the desktops 3 and 4 four are the same.

That's what I currently configured:

Style * EWMHDonateIcon EWMHDonateMiniIcon EWMHUseStackingOrderHints \ 
	EWMHIconicStateWorkaround
Style kicker Sticky,NoTitle,NeverFocus,StaysOnTop,BorderWidth 0,HandleWidth
0
EWMHNumberOfDesktops 12 12

I tried to configure KDE to use 1 or 12 Desktops. This setting doesn't seem
to have any effect.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "S. Anderson" <[email-masked]>
Date: Fri, 21 Mar 2003 16:30:10 -0700

On Thu, Mar 20, 2003 at 07:26:52AM -0600, [email-masked] wrote:
> Received: from util2.math.uh.edu ([129.7.128.23])
> 	by malifon.math.uh.edu with esmtp (Exim 3.20 #1)
> 	id 18w04J-0004Hb-00
> 	for [email-masked]; Thu, 20 Mar 2003 07:26:51 -0600
> Received: from malifon.math.uh.edu ([129.7.128.13] ident=mail)
> 	by util2.math.uh.edu with esmtp (Exim 4.10)
> 	id 18w04J-0004tS-00
> 	for [email-masked]; Thu, 20 Mar 2003 07:26:51 -0600
> Received: from localhost ([127.0.0.1] ident=65534)
> 	by malifon.math.uh.edu with esmtp (Exim 3.20 #1)
> 	id 18w04J-0004HX-00
> 	for [email-masked]; Thu, 20 Mar 2003 07:26:51 -0600
> Message-Id: <[email-masked]>

It seems the kicker's idea of desktops starts at 1 and fvwm starts 
its desktops at 0.

If you start FvwmPager with the following. It will rename the Desks. 
However if your FvwmPager is too small for the text "Desk ¿" to fit in, all that
is diplayed is the fvwm desk number. (ie, 0 1 2 3)
*FvwmPager: Label 0 "Desk 1"
*FvwmPager: Label 1 "Desk 2"
*FvwmPager: Label 2 "Desk 3"
*FvwmPager: Label 3 "Desk 4"

On the other hand if you make the FvwmPager Label only one characture
you wont have this problem.
*FvwmPager: Label 0 "1"
*FvwmPager: Label 1 "2"
*FvwmPager: Label 2 "3"
*FvwmPager: Label 3 "4"

does this help you?

cya,
sa