Subject: XRandR

From: "S. Anderson" <[email-masked]>
Date: Tue, 4 Mar 2003 18:43:41 -0700

Hello,

I am in the proccess of getting fvwm to support the randr extension.
So far I have got fvwm to see the RRScreenChangeNotify event, now I just
figure out what do do where it says "what else to do" in the following 
snippet of code. (mabey I should have fvwm restart there?)

void HandleRRScreenChangeNotify(const evh_args_t *ea)
{
    if (FRandrSupported)
    {
        if (XRRUpdateConfiguration( (ea->exc->x.etrigger) ) )
            fprintf(stderr,"XRRUpdateConfiguration success\n");
        else
            fprintf(stderr,"XRRUpdateConfiguration failed\n");

        fprintf(stderr,"RRScreenChangeNotify -- width %d, height %d\n",
                DisplayWidth(dpy, Scr.screen), DisplayHeight(dpy,Scr.screen));

        Scr.MyDisplayWidth = DisplayWidth(dpy, Scr.screen);
        Scr.MyDisplayHeight = DisplayHeight(dpy, Scr.screen);

        /* what else to do?*/
    }
    return;
}

does any one have a clue for me?

I have the somwhat incomplete and broken patch here, if any one 
is interested in looking at it. http://www.xmission.com/~sa/randr.patch

cya,
sa
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 5 Mar 2003 08:10:49 +0100

> does any one have a clue for me?

Uh, I fear changing the display size requires a major overhaul of
the code.  It's bad enough in fvwm, but it gets even worse when
modules come into play.

> is interested in looking at it. http://www.xmission.com/~sa/randr.patch

Bye

Dominik ^_^  ^_^

---

From: Dan Espen <[email-masked]>
Date: Wed, 05 Mar 2003 06:29:36 -0500

> snippet of code. (mabey I should have fvwm restart there?)

As Dominik said, changing the display size would affect all parts
of Fvwm including the modules, so I guess restarting Fvwm would be
the most logical thing to do.

I suppose that would still cause problems for the clients:
If they are maximized, would they be remaximized?
If they were placed with negative geometry, would their positions
be recalculated?

-- 
Dan Espen                           E-mail: [email-masked]