Subject: Notification: incoming/1003

From: [email-masked]
Date: Fri, 21 Mar 2003 07:49:58 -0600

FVWM Bug Tracking notification

new message incoming/1003

Message summary for PR#1003
	From: [email-masked]
	Subject: nedit windows get properties from other programs
	Date: Fri, 21 Mar 2003 07:49:58 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Fri Mar 21 07:49:58 2003
From: [email-masked]
To: [email-masked]
Subject: nedit windows get properties from other programs
Date: Fri, 21 Mar 2003 07:49:58 -0600

Full_Name: Volker Reichelt
Version: 2.4.16, 2.5.6
CVS_Date: 
OS: Linux 2.4.21
X_Server: 
Submission from: (NULL) (134.130.161.247)

I have the following line in my .fvwmrc2 file:
  Style XClock Sticky
to make xclock sticky.

If I open an nedit window for a file named "XClock" by issuing the command
"nedit XClock" the nedit window gets sticky, too.

I'm not sure whether this is a bug in fvwm or in nedit (version 5.3RC1)
or even a feature.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Fri, 21 Mar 2003 11:09:04 -0500

> I'm not sure whether this is a bug in fvwm or in nedit (version 5.3RC1)

Its a limitation of the way styles work.
They match on a windows name, class, or resource.
You can start xclock like this:

xclock -name MakeMeSticky

and then change the style like this:

Style MakeMeSticky Sticky

Please use [email-masked] before reporting a bug.

Thanks.
-- 
Dan Espen                           E-mail: [email-masked]