Subject: fvwm birthday planning / need volunteers

From: Dominik Vogt <[email-masked]>
Date: Mon, 10 Mar 2003 16:30:13 +0100

Since the birthday is only two and a half months from now (1st of
June), we really need to start thinking about what we want to
plan.  Here is what I suggest:

  1. IRC chat with the developers.
     [no planning required; just announce]
  2. Finally kick off the fvwm logo contest.
     [need to agree on the rules soon; the contest shouls be
     under way on the 1st of June; need a contest maintainer]
  3. Make a secret 2.4.x demo (possibly 2.4.15 too).
     [Who can do that?]
  4. Update the web site for the event, including some historical
     information.
     [soon]
  5. Announce the event on fvwm-announce and some other places.
     [what other places?]

I can help with (2), (4) and (5) and write down a roadmap, but I'd
be gratefull if someone else volunteered for the web stuff.  I can
*not* help with a demo.

Bye

Dominik ^_^  ^_^
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 10 Mar 2003 17:29:41 +0000

> be gratefull if someone else volunteered for the web stuff.  I can

After some busy months I am slowly returning. I will help with the event
organization. I can prepare the web (including a festive design of the
home page later and creating birthday/ tree now). You may send me some
initial plain texts to start from.

I tend to think we don't have enough time for a demo. And 2.4.15 is not
good enough for this, all cool features are in 2.5.x only. So probably we
should drop this idea or postpone it to 2.6.0.

Who else can help with organizing the event? Any artists?

I can think about contests for the best titlebar/menu/panel design.
The works can be posted on [email-masked] and voted by readers. The winner
works will be linked from the event page (i.e. birthday/index.html).
I think I can prepare birthday/contest.html with initial rules for
these contests (including a logo) in about a week.

I will gladly receive any help from anybody (Dan).

Regards,
Mikhael.

---

From: parv <[email-masked]>
Date: Tue, 11 Mar 2003 00:15:23 -0500

in message <[email-masked]>, wrote Mikhael
Goikhman thusly...
> >   5. Announce the event on fvwm-announce and some other places.

How about on "Window managers for X" (xwinman)...

  http://www.xwinman.org/

...and perhaps comp.windows.x newsgroup.

> Who else can help with organizing the event? Any artists?

Let me know if i can help w/ the HTML,  _light_ graphics,
announcements & such.

  - parv

--

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 11 Mar 2003 10:42:14 +0100

> these contests (including a logo) in about a week.

I think I still have a draft of the rules from the last attempt to
set up a logo context on my disk at home.  I will take a look.

Bye

Dominik ^_^  ^_^

---

From: Uwe Pross <[email-masked]>
Date: Tue, 11 Mar 2003 12:59:04 +0100

Hi there,

> > >   3. Make a secret 2.4.x demo (possibly 2.4.15 too).
...
> > 
> > I tend to think we don't have enough time for a demo.
> > And 2.4.15 is not good enough for this, all cool
> > features are in 2.5.x only. So probably we should drop
> > this idea or postpone it to 2.6.0.

What have you got in mind when saying making a demo? Do you
think a (quite large) set of configuration files which
provides access to most of the features of fvwm will do it? 
I am thinking of collecting some window decorations, menu
styles, key and mouse binding definitions, pixmaps and so
on, to show whats possible with fvwm. The different
features of fvwm could be turned on and off via menu
entries or FvwmButtons. Of course this is similar to
fvwm-theme but it will be within the fvwm-package and could
come with it in future.

Or did you mean a self-running demo like a movie?

To the web site: 
Does your web server support php? If so I could provide a
simple frame-work written in php3, which lets you handle
the contents of web sites entirely separated from its
layout. You can provide a web site in different layouts and
generate different navigation structures. At the moment
it is in beta state but can be already used. 

Regards Uwe
-- 
Uwe Pross
mailto:[email-masked]
http://www.tu-chemnitz.de/~uwp

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 11 Mar 2003 13:31:57 +0100

> Or did you mean a self-running demo like a movie?

We thought about a self-running demo, but that does not exclude
showing off fvwm's features.

Bye

Dominik ^_^  ^_^

---

From: Uwe Pross <[email-masked]>
Date: Tue, 11 Mar 2003 14:26:31 +0100

Hi there,

On Tue, 11 Mar 2003, Dominik Vogt wrote:

> > What have you got in mind when saying making a demo? Do
> > you think a (quite large) set of configuration files
> > which provides access to most of the features of fvwm
> > will do it? I am thinking of collecting some window
> > decorations, menu styles, key and mouse binding
> > definitions, pixmaps and so on, to show whats possible
> > with fvwm. The different features of fvwm could be
> > turned on and off via menu entries or FvwmButtons. Of
> > course this is similar to fvwm-theme but it will be
> > within the fvwm-package and could come with it in
> > future.
> > 
> We thought about a self-running demo, but that does not
> exclude showing off fvwm's features.

A X-Demo, Flash or something else? Partly interactive?
How about using the schedule-feature of 2.5.x to build a
demo?

Regards Uwe

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 11 Mar 2003 15:25:00 +0100

On Tue, Mar 11, 2003 at 02:26:31PM +0100, Uwe Pross wrote:
> A X-Demo, Flash or something else?

An fvwm demo.  It should run from inside fvwm, requiring as few
external programs as possible, especially X applications.

> Partly interactive?

Your choice.

> How about using the schedule-feature of 2.5.x to build a

No opinion.  Might work well, but maybe not.

Bye

Dominik ^_^  ^_^

---

From: Uwe Pross <[email-masked]>
Date: Tue, 11 Mar 2003 16:23:37 +0100

> external programs as possible, especially X applications.

This might be done be done by a file containing
fvwm-configuration statements and fvwm-commands or
FvwmCommand if I get it to work. Currently it claims:
"No such file or directory FvwmCommand error in opening message fifo"

> Your choice.

FvwmButtons could be used to select parts of the demo and
execute them step by step.

> No opinion.  Might work well, but maybe not.

Instead of the schedule command one could use constructs
like

PipeRead 'sleep 1; echo "Popup MAIN_MENU_popup"'

to achieve a delay between steps of fvwm commands.

Which features should be demonstrated (Moving, Shading,
FvwmCascade, Buttons, TaskBar, WindowList, Colorsets,
Menus, Functions, ...)? 

Uwe

---

From: Dan Espen <[email-masked]>
Date: Tue, 11 Mar 2003 10:31:17 -0500

> "No such file or directory FvwmCommand error in opening message fifo"

You have to start FvwmCommandS before FvwmCommand works.
Both comamnds have to be started with $DISPLAY set to the same
value.

Look in /var/tmp to see the FIFO its looking for.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Uwe Pross <[email-masked]>
Date: Wed, 12 Mar 2003 08:58:44 +0100

> Look in /var/tmp to see the FIFO its looking for.

I did. I had a try last night at home and it works as
expected (2.5.2). At work (2.5.3) it does not. I have tried
several combinations - setting DISPLAY by hand in fvwm and
in the shell which executes FvwmCommand and using the
options -S and -f - without success. In /var/tmp there are
two files:
   /var/tmp/FvwmCommand-gruenbube:0.0C
   /var/tmp/FvwmCommand-gruenbube:0.0M
which disapear when I kill FvwmCommandS. DISPLAY is set to
"gruenbube:0.0".

Uwe

---

From: Dan Espen <[email-masked]>
Date: Wed, 12 Mar 2003 06:25:48 -0500

> which disapear when I kill FvwmCommandS. DISPLAY is set to

Try :0.0.

---

From: Uwe Pross <[email-masked]>
Date: Wed, 12 Mar 2003 12:43:22 +0100

> Try :0.0.

I got it to work. It was actually my fault, since there are
two fvwm version installed on my computer at work. One is a
2.2 version and the other is 2.5.3. I am running fvwm
2.5.3. The FvwmCommand was taken from the 2.2 version and
the module FvwmCommandS as it should be form 2.5.3. If I
use FvwmCommand from version 2.5.3 it works beautifully.

Regards, Uwe

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 12 Mar 2003 13:54:28 +0100

> set up a logo context on my disk at home.  I will take a look.

Nope, the draft is gone along with Pat Rogan's contest site and
all the mails in the mail archive except one by Mikhael with a
broken link to the contest site. :-/

Bye

Dominik ^_^  ^_^

---

From: [email-masked]
Date: Wed, 12 Mar 2003 23:18:03 +0100

> Let me know if i can help w/ the HTML,  _light_ graphics,

Your help is greatly appreciated.  The most pressing issue is a
new web site.  Below are the steps from my draft of the birthday
planning document.  How much do you think you can tackle?

       Goal: Make a shiny new site for the celebration and keep the news up to
             date.
       Priority: high
       Responsible: volunteer needed, parv?
       Status: planning schedule

       10-Apr
        * Write a short announcement message for the 1st of June and discuss it
          on fvwm-workers.
          [pending]

       15-Apr
        * Put the announcement on the web page.
          [pending until 15-Apr]
        * Put the announcement for the logo competition on the web site.
          [pending until 15-Apr]
        * Make a web page for the logo competition.
          [pending]

       25-May
        * Make a shiny web site for the celebration and post it on fvwm-workers.
          [pending]
        * Make a web page with the pictures of the developers.
          [pending]

       30-May
        * Upload the celebration page.
          [pending until 30-May]

       30-Jun
        * Remove the celebration page or keep the page but remove references to
          the birthday event.
          [pending until 30-Jun]

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: parv <[email-masked]>
Date: Wed, 12 Mar 2003 21:52:15 -0500

in message <[email-masked]>,
wrote [email-masked] thusly...
>
> The most pressing issue is a new web site.

Do you mean wholly new web site, or will a separate directory for
the occasion (either on fvwm.org or under my own personal space
somewhere) be enough?

>        Goal: Make a shiny new site for the celebration and keep
>             the news up to date.
>        Priority: high

Yes. I do.

>         * Write a short announcement message for the 1st of June
>           and discuss it on fvwm-workers.
>           [pending]

Ok, Can do.

>         * Put the announcement for the logo competition on the web site.

ok.

>         * Make a web page for the logo competition.

I personally prefer little or no doodas on a web page.  Check
it yourself...

  http://www103.pair.com/parv/

..so if anybody else think that my style doesn't/won't fit the
celebration, by all means let me know & take over the design at any
point.

>         * Make a web page with the pictures of the developers.

See above "I personally...".

>         * Upload the celebration page.

Can do.

>        30-Jun
>         * Remove the celebration page or keep the page but remove
>           references to the birthday event.
>           [pending until 30-Jun]

I think this item would be responsibility of whomever ends up
designing/owning the related pages, right?

  - parv

--

---

From: Uwe Pross <[email-masked]>
Date: Thu, 13 Mar 2003 08:47:19 +0100

On Wed, 12 Mar 2003, [email-masked] wrote:

>        Goal: Make a shiny new site for the celebration
>              and keep the news up to date.
>        Priority: high

Again, I can offer a set of php-scripts (GPL) which can
either run on an apache server with php-modules installed
or which can be used to generate a whole html-tree runable
on a server without php.

The relation among the different pages belonging to a web
site is recongnized by the scripts so that changing one
page does not mean updating all other pages refering to
this site. One can choose different layout and navigation
styles.

To get an idea what it could look like have look at my
homepage (only in german at the moment). In the right upper
corner the is a link which toggles between two layout and
navigation styles. (Note the two different navigation
styles if you move to subpages.) The site is currently set
up using style sheets. Since this is not fully supported by
netscape 4.x it may look different with this browser. The
site should be displayed properly with mozilla, opera, msie
:-( and even with netscape 4.7x with JavaScript and
Stylesheets turned on (Netscape needs Javascript to display
style sheets properly).

The usage of style sheets is not mandatory. I used it since
it is efficient and easy to use. 

Uwe

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 13 Mar 2003 09:39:44 +0100

> >           and discuss it on fvwm-workers.

Forgot to mention that this is only the announcement message on
the (old) web page.

>   http://www103.pair.com/parv/

Sparse decorations are no problem.  The result should look more
professional than what we have now, and more eye friendly.  It
must be easy to read and the backgound must give a good contrast
to the text.  And, of course, it should not insult anybody's
aesthetic feeling (green text on red background, or a pink title
on grey background as we have now).

> celebration, by all means let me know & take over the design at any

I would like to keep the new design after the birthday.  For the
birthday it should be a bit mor colourful (with confetti and such
;-) ), but after that the more plain style is better.

> designing/owning the related pages, right?

Yes, it's not interesting now.  We can think about it later.

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 13 Mar 2003 09:43:37 +0100

> or which can be used to generate a whole html-tree runable

You have to as Jason what we can do on the web server (I have
CC'ed him).  See my other mail for more details on what we need.

> Stylesheets turned on (Netscape needs Javascript to display

Looks very good.

Bye

Dominik ^_^  ^_^

---

From: Uwe Pross <[email-masked]>
Date: Thu, 13 Mar 2003 10:06:14 +0100

On Thu, 13 Mar 2003, Dominik Vogt wrote:
> 
> You have to as Jason what we can do on the web server (I
> have CC'ed him).  See my other mail for more details on
> what we need.

How about if I make suggestion for a layout using the
navigation structure from the current web page. I might
have time on weekend to do it (or if it not in the
beginning of next week). For the first time I could put on
my personal webspace.

According to your other mail you are quite open regarding
to light/dark foreground/background. Or do you have any
preferences?

How about loading times? Do you want to keep the web page
as small as possible? One could do two versions of the
layout. One which is simple and small, and one which is
more shiny with a lot of pictures but may take a time to
load it with a modem. The user could choose which version
he wants. Using the php-scripts I mentioned this quite easy
to set up.

Uwe

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 13 Mar 2003 10:26:47 +0100

> beginning of next week). For the first time I could put on

No objections, but you and parv should tem up and coordinate your
efforts.

> to light/dark foreground/background. Or do you have any

No.

> he wants. Using the php-scripts I mentioned this quite easy

I don't know.  The only requirements I have are

 a) It must be easy on the eye and easy to read.
 b) It must not annoy anybody (e.g. with strange or too bright
    colours, bad text/background contrast, small font sizes,
    requiring large browser windows, etc.)

By the way, these are only *my* opinions.  All others have the
same right to talk about the web site design.

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 13 Mar 2003 10:30:00 +0100

> the occasion (either on fvwm.org or under my own personal space

Missed that when first reading it.  A wholly new site that is kept
in separate directories until the birthday.

Bye

Dominik ^_^  ^_^

---

From: Uwe Pross <[email-masked]>
Date: Fri, 14 Mar 2003 10:06:06 +0100

Hi Parv,

On Thu, 13 Mar 2003, parv wrote:

> Parv, from fvwm list, here.  Please let me know how can i
> help you. What have you have so far, and what needs to be
> done?

It was suggested making a web page in the look of fvwm.
Dominik sayed it would be nice if we could use the a
"FvwmPager"-style navigation and if the web page would be
available in different fvwm-designs used from fvwm-theme. I
like both ideas a lot. The pager navigation might not be
that easy but possible ;-)

Do you know php? It's a simple programming language which
can be embedded in html-code. It makes web design very
powerful since html-code can be generated at request time.
It makes it possible to separate the contents (e.g. text
and pictures) form a web site from its layout. The links to
other pages can be generated as well which allows different
types of navigation structures.  

I developed a simple concept which can be used to describe
web page contents and layout (almost) totally separated. 

I will describe its workings briefly:

Each (php)page consists two parts. One contains
informations about the page which may be useful to other
pages refering to this page (e.g. title name, link name,
link picture, file name, ...) and its relation to other
pages (parent site, child site). Here is an example usable
for fvwm:

$title          = "Fvwm Homepage"; 
$link_name      = "Home";
$link_picture   = "";
$parent_site    = "top"; 
$child_sites    = array("download","news","faq");
$requested_file = basename($PHP_SELF);
$this_site      = fvwm_home

if( strlen("$navigation_check") > 0 ) return;

if( strlen("$site_has_been_loaded") == 0 ) {
  $site_has_been_loaded = "true";
  include(sec_filename("$layout_file"));
  exit();
}

This "Header" is common to all pages belonging to a web
site. Below this header the contents of this page follow
which can be html or/and php. 

After all pages are described in this way. A php-script
called navgen.php is executed. It collects all
header-information from all php-files it founds and
performs simple checks to ensure consistence of the
navigation structure. This scripts generates a file which
contains array assignments like:

$top_array = array("download", "news", "faq" );

$fvwm_home["file"]         = "/afs/tu-chemnitz.de/home/urz/u/uwp/public_html/fvwm_home.php";
$fvwm_home["url"]          = "/~uwp/fvwm_home.php";
$fvwm_home["link_name"]    = "Home";
$fvwm_home["link_chapter"] = "";
$fvwm_home["link_pic"]     = "";
$fvwm_home["parent_site"]  = "top";
$fvwm_home["child_sites"]  = array("download", "news", "faq"); 
...

Note: Not all information in the header need to be exported
to the arrays and not all information exported need to be
defined in every header. The script needs to be ran only
once when something on the navigation structure was changed
e.g. web page was added, removed or renamed. When the script
reads the header information a variable "$navigation_check"
is set which causes to exit the the php-web-page at the
following line:

if( strlen("$navigation_check") > 0 ) return;

A the time of a page request (the page is displayed by
web-browser) this variable is not set so the page is
processed further where it includes a layout file. This
layout file defines a set of layout functions and uses them
to display the contents of the page. The layout file uses
the arrays generated by navgen.php to generate the
navigation part of the web page. From the layout file the
page is include again to get its real contents. 
   I have written a couple of php-functions which convert
the array-structure to a html-navigation. This functions
may be (re)used for the fvwm project.

I know this sounds a little bit confusing. I packed to
php-files of my web-page in a single archiv so that you can
download it:
http://www-user.tu-chemnitz.de/~uwp/download/navgen.tar.gz

Okay so far, what can we do next? I have downloaded all
html-files form fvwm.org and packed them in a tar archive:
 http://www-user.tu-chemnitz.de/~uwp/download/fvwm_14032003.tar.gz
This html-files can be used to write/generate the
php-files. All we need to do is add the header to this
pages and adapt them according to the fvwm site structure.
We may need to add some header information to get the
"navigation pager" work. But this can be done later. After
this we can run navgen.php and use one of the existing
layout files to display the pages.

After this we need to create a new layout file in fvwm
style and maybe redesign some of the existing fvwm pages.
For the fvwm-project I would like to put more php-functions
in the layout file which maybe used in the web page files
to insert some layout properties. 

We need probably a CVS repository to keep our files
consistent. I will ask fvwm-workers for this.

Please let me know what do you think.

Uwe