Subject: Working on new files of fvwm-web tree

From: Uwe Pross <[email-masked]>
Date: Mon, 31 Mar 2003 15:32:24 +0200

Hi Mikhael,

I realized that you changed some filenames in the fvwm-web
tree. The filenames are used to give the php files an
unique name which is used in the navigation array structure
and the child array entries. 

Therefore I tried to give the files unique names to avoid
using a name twice. 

Using short names like menu.php or icon.php may cause
problems if these file names appear twice in the file tree.
For example:
	download/icons.php
	screenshots/icons.php
Will be rejected by navgen.php since they have the same
site name.

Further the icon pictures belonging to a php-file have the same
name as the php-file e.g.
	doc_manpages_pager.gif belongs to doc_manpages.php

Currently there is an array entry ${$site}["link_pic"] for each
php file. This entry was going to be removed since the name of
the link picture can be derived from the name of the site
which is actually derived from the name of the php-file. So
the "link_pic" entry is not really needed.

For example:
	File: features.php 
	Internal name: features
	Mini Icon: features_mini.gif
	Pager pic: features_pager.gif
	...

BTW: navgen.php has to be ran each time you have changed
     something which may effect the entries in the file
     navigation.inc. Currently this are file names, link
     names, chapter names, picture names, parent sites and
     names of child sites.

Regards, Uwe
-- 
  ,_,  Uwe Pross
 (O,O) mailto:[email-masked]
 (   ) http://www.tu-chemnitz.de/~uwp
=-"-"-================================
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 31 Mar 2003 13:53:56 +0000

> Will be rejected by navgen.php since they have the same

I know this. This is why I wrote a comment in index.php that
navgen should be updated to handle subdirs. The id is better to be:

  download/icons
  documentation/faq

instead of the current forms:

  icons
  download_icons
  faq
  doc_faq

> 	doc_manpages_pager.gif belongs to doc_manpages.php

Well, it is not a rule, just a convention.
A convention may be to replace a slash in id with an undescore.

> 	Pager pic: features_pager.gif

Similarly, here just replace slash with underscore.

I simply changed the new version to handle things closer to the how we
do in the current old version. I hope it is ok with you.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 31 Mar 2003 16:01:21 +0200

> > 	doc_manpages_pager.gif belongs to doc_manpages.php
                          ^^^^
Just noticed that.

We can't have gifs for copyright reasons.

Bye

Dominik ^_^  ^_^

---

From: Uwe Pross <[email-masked]>
Date: Mon, 31 Mar 2003 16:06:12 +0200

Hi there,

> We can't have gifs for copyright reasons.

What else? png and xpm is not supported by all browsers and
jpg is not good for small pics. 

BTW: There gifs on the current web page.

Regards, Uwe

---

From: Uwe Pross <[email-masked]>
Date: Mon, 31 Mar 2003 16:30:45 +0200

Hi there,

On 31 Mar 2003 at 13:53:56 +0000, Mikhael Goikhman wrote:

> navgen should be updated to handle subdirs. 

Uups. I have not checked all files you have changed.

> The id is better to be:

Actually I have thought about this. But I decided to force
the user (and myself) to _give_ the sites unique names
instead of generating unique names. Generating the sites
names means that the user must know how this is done since
he needs to use the names in the child and parents entries.
I think that forcing the user to give uniqe names to the
sites/files is not a big restriction.

> Well, it is not a rule, just a convention. A convention
> may be to replace a slash in id with an undescore.

It becomes a rule if the names of the icons are obtained
from the site names and not from the "link_pic" entry. Well
in the current version is not the case. But it was planed.

> I simply changed the new version to handle things closer
> to the how we do in the current old version. I hope it is
> ok with you.

That's ok. I am happy if somebody helps working on the new
site since I think there is a lot work to do and there is
not that much time left.
I just wanted to mention that your changes may lead to
naming problems when we develop the site further, adding
new sub sites, etc.  

Regards, Uwe

---

From: Ethan Blanton <[email-masked]>
Date: Mon, 31 Mar 2003 11:17:22 -0500

> jpg is not good for small pics. 

I don't see why gifs would be a problem as long as they're not
LZW-compressed (the patented algorithm).

Ethan

-- 
I remember when I realized that I got a second chance to try again,
and make the same mistake.  Then my mind was rearranged, yes my entire
world had changed; I had nothing, nothing left to take.
                -- Walter Ego, "Plastic Skirt Girl"

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 31 Mar 2003 18:23:04 +0200

> LZW-compressed (the patented algorithm).

Ah, thanks for the information.  I was not aware that only the
compression algorithm is the problematic part.

Bye

Dominik ^_^  ^_^