Subject: Re: NEWS in unstable branch

From: [email-masked]
Date: Sun, 2 Mar 2003 22:55:25 +0100

On Fri, Feb 28, 2003 at 10:27:03PM +0100, Olivier Chapuis wrote:
> On Fri, Feb 28, 2003 at 11:08:58AM +0100, Dominik Vogt wrote:
> > I think we have too many messages in the NEWS for the unstable
> > branch right now.  In the past, I made entries for
> > 
> >   * New features and other important user visible changes
> > 
> > but not for
> > 
> >   * Bug fixes
> >   * Minor user visible changes
> >   * Changes in the documentation
> > 
> > Especially, when a feature was introduced in the unstable branch
> > and removed before the stable release, I remove any hints of that
> > feature from the NEWS.  If it is renamed before a stable release,
> > I replace its former name in the NEWS with the new name and do not
> > add a "renamed foo to bar" message in the NEWS.
> > 
> > What do you think about that?
> >
> 
> I prefer a too long NEWS file than a too short one. Numerous package
> has an obsolete NEWS file This is very frustrating when you upgrade or
> have to decide if you want to upgrade. The NEWS file is very useful.
> Anyway, as our NEWS file is well maintained I think that some cuts can
> be done if these cuts do not suppress information for the user (important
> or not). Not that it seems that a lot of users use 2.5.x as its regular
> window manager.

But I *definitely* do not want the clutter up the NEWS with things
like

  2.5.x: New experimental module foo
  2.5.x+1: Renamed module foo to foobar
  2.5.x+2: Removed module foobar becaus it sucks

I could be talked into including bug fixes in the NEWS if the
problem was already in the stable branch, but I think entries for
problems that were introduced in the unstable branch are moot.
Behaviuor within the unstable branch may change at any time,
without notice.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 3 Mar 2003 02:07:10 +0000

> Behaviuor within the unstable branch may change at any time,

I didn't want to interfere, because I mostly agreed with Dominik about 3
types of entries that should not be included (listed at the top), although
I understand the Olivier's reasons.

But I would not add anything above these 3 types. If there is a question
whether a change is minor or not, it is not minor, say, changes in spaces
or quotes may be considered minor, but not a name change. I *definitely*
want to see all user syntax changes in 2.5.x, 2.5.x+1, 2.5.x+2 sections.
Users use different versions, probably all of these, you can't provide a
support without pointing to versions when syntax was changed. For example,
I wanted to know when Style Border was renamed to Borders and I needed to
grep ChangeLog for this, because from just looking at NEWS it may seem
that there was never be "Border". Not very good for me.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 3 Mar 2003 10:32:36 +0100

> > > > add a "renamed foo to bar" message in the NEWS.

[snip]

> or quotes may be considered minor, but not a name change.

> I *definitely*

My approach is simple.  In the stable branch:

 - All code changes are mentioned.
 - The NEWS for the beginning of a stable branch contains a
   summary of all user visible changes.

And in the unstable branch:

 - Bug fixes are usually not in the NEWS.
 - All new features that appear in the unstable branch may be
   changed, renamed or removed without notice.

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 3 Mar 2003 10:03:13 +0000

>    changed, renamed or removed without notice.

Agree for the pre-alpha versions. But when 50% or more of the messages on
[email-masked] speak about 2.5.x I would prefer to start to have NEWS that
looks somewhat between these two opposite approaches.

Regards,
Mikhael.