Subject: Re: web site design thread

From: Uwe Pross <[email-masked]>
Date: Fri, 21 Mar 2003 23:04:23 +0100

Hi Bob!

On Fri, 21 Mar 2003, Bob Woodside wrote:

> 	This morning I tried to look at your designs for
> the new FVWM Web site, but I just get "404 Dokument nicht
> gefunden". I tried backing up to the University's
> personal home pages directory, and successfully followed
> the links to a couple of other people's home pages, but
> http://www-user.tu-chemnitz.de/~uwp (or anything under
> that) consistently gets a 404 response. Any idea what's
> gone wrong?

Actually you should have got a 503. At least I got it. Last
night the administrators at our university did some
maintance on the system which results that parts of the
raid array broke competely. Unfortunately my home directory
(and about 3000 other homedirs as well) was on this part. It
was said to be fixed in a couple of hours from this morning
but it seems to take longer since I still got this message.
I hope they have fixed it till monday morning.

To get you an idea about the actual version of the design I
ripped it on my computer at home, converted it to html (It
was php before) and put it on
http://home.arcor.de/uwe.pross/fvwm_web_site/
(Hope this works better)

I have not changed much on the design since last thursday
but I hope that I find some time to do further work at this
weekend.

I want to finish the menu structure, put a pager window in
the left upper corner of the page and (Dominik may forgive
me :) make a taskbar like navigation path on top of the page
which displays the path from fvwm-home page to the actual
site. (If the pager or other things on the pages are not
wanted they can be removed easily.)

Regards, Uwe
-- 
+----------------------------------------------
| Uwe Pross
|    mailto:[email-masked]
|    http://www.tu-chemnitz.de/~uwp
+----------------------------------------------
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Uwe Pross <[email-masked]>
Date: Sun, 23 Mar 2003 11:18:48 +0100

Hi Bob!

On Sat, 22 Mar 2003, Bob Woodside wrote:

> 	If you'd like, I'd be happy to try to help out with
> this project. I've got a fair amount of experience with
> HTML, CSS, PHP, and JavaScript. The way business has been
> lately, I've been doing more small Web site development
> than serious code hacking.

You are very welcome. Currently I work alone and I have got
not that much time for the project, so I could need some
help the get this web site ready in time.  

Half a year ago I thought about a concept which makes it
possible to separate the contents of a web site (almost)
completely from its layout. I used it to develop my
homepage and offered its use to fvwm. I did a posting to
fvwm-workers how it works.
Could you please read it to understand the next sayings
better?

For the fvwm web site I added a php interface which
provides access to all layout elements of the web design.
For example the file index.php which describes the contents
of uses 

<?php decoration_window_start("Official Homepage of Fvwm"); ?>

... contents of the window ...

<?php decoration_window_end(); ?>

to draw the window decoration. Please have a look in the
file layout_default.inc to understand it better.

I have put the actual version of the php-files to 

http://home.arcor.de/uwe.pross/fvwm_web_site/packed.tgz

Could you please download it from there, have a look to the
files and tell me what you could do? 

We need to convert the actual fvwm-html to php, finish the
actual layout file add some new functions to get a pager
and a taskbar/windowlist. Further we might do some new
design suggestions.

BTW: If we work both on the files we might need to set up a
cvs repository somewhere to keep or changes synchronous. 

Regards, Uwe