Subject: Re: Fvwm bug 762 Pager has drawing problem

From: [email-masked]
Date: Mon, 3 Mar 2003 00:47:39 +0100

On Tue, Feb 25, 2003 at 10:14:22PM -0500, Dan Espen wrote:
> 
> Back in August 2001, we had a problem report
> thats still open for FvwmPager.  Its still open as problem
> 762 and the only mail I can find is this 2 message thread:
> 
> http://www.hpc.uh.edu/fvwm/archive/0108/msg00262.html
> 
> I see that Dominik requested the config file and images.
> I have no problem accessing the images here:
> 
>  http://www.css.tayloru.edu/~bbell/pager1.png
>  http://www.css.tayloru.edu/~bbell/pager2.png
> 
> I don't know if Dominik ever got the config file.

If it's not in the mail archive I did not get the file., but at
that time I tried to reproduce virtually any bug.

> The images look like what happens if the pager is started
> at 1x1 and then the desktop size is changed to 3x3 after the pager
> was already started.
> 
> This can happen by doing this:
> 
> Module FvwmPager
> ...
> DesktopSize 3x3
> 
> (The pager should be started in the InitFunction, RestartFunction,
> or StartFunction to avoid this.)
> 
> I've noticed that the pager doesn't respond well to changes to
> desktop size changes after its started and I'd like to confirm
> that thats what happened here.

Well, if you are positive that this can be caused by desktop
layout changes (you did fix them, right?) I suggest we can close
the bug report.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sun, 02 Mar 2003 20:12:36 -0500

> that time I tried to reproduce virtually any bug.

Its not in the mail archive.  I only asked because you asked
for the file to be sent to you.  The users mail address isn't
any good anymore.

> layout changes (you did fix them, right?) I suggest we can close

Yes, I produced something very close to the images supplied.
I believe its fixed.  It works for me.
I closed the problem report a few hours ago.

We have  another one (861) that  claims  the pager comes  up the wrong
size about  half  the time.  It  doesn't  for me.  I'll  try the pager
under Purify when I get a chance and if it  doesn't spot anything I'll
close this one too.

-- 
Dan Espen                           E-mail: [email-masked]