Subject: [PATCH] fix flat borders

From: Tony Finch <[email-masked]>
Date: Wed, 26 Feb 2003 17:32:11 +0000

The development version of FVWM now draws 3D relief effects around
window handles even when the border is configured to be flat. This is
a regression from 2.4. Here's a patch to restore the old behaviour.

--- ChangeLog	26 Feb 2003 11:05:27 -0000	1.2246
+++ ChangeLog	26 Feb 2003 17:22:55 -0000
@@ -1,3 +1,8 @@
+2003-02-26  Tony Finch  <[email-masked]>
+
+	* fvwm/borders.c (border_draw_one_border_part):
+	Don't draw the handle relief marks when the border is flat.
+
 2003-02-26  olicha  <[email-masked]>
 
 	* fvwm/borders.c (border_setup_bar_pixmaps):
--- fvwm/borders.c	26 Feb 2003 11:05:27 -0000	1.235
+++ fvwm/borders.c	26 Feb 2003 17:22:55 -0000
@@ -1562,11 +1562,11 @@
 	if (!br->relief.is_flat)
 	{
 		border_draw_part_relief(br, frame_g, &part_g, p, is_inverted);
-	}
-	/* draw the handle marks */
-	if (br->marks.has_x_marks || br->marks.has_y_marks)
-	{
-		border_draw_part_marks(br, &part_g, part, p);
+		/* draw the handle marks */
+		if (br->marks.has_x_marks || br->marks.has_y_marks)
+		{
+			border_draw_part_marks(br, &part_g, part, p);
+		}
 	}
 	/* apply the pixmap and destroy it */
 	border_set_part_background(w, p);

Tony.
-- 
f.a.n.finch  <[email-masked]>  http://dotat.at/
MULL OF KINTYRE TO ARDNAMURCHAN POINT: SOUTHEAST 4 OR 5 OCCASIONALLY 6. HAZY
WITH RAIN TIMES. MODERATE OR GOOD. SLIGHT TIGHT INSHORE BUT MODERATE OVER OPEN
WATERS.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 27 Feb 2003 08:56:58 +0100

> a regression from 2.4. Here's a patch to restore the old behaviour.

Thanks.  I have applied the patch.

Bye

Dominik ^_^  ^_^