Subject: Notification: incoming/985

From: [email-masked]
Date: Tue, 04 Feb 2003 11:39:29 -0600

FVWM Bug Tracking notification

new message incoming/985

Message summary for PR#985
	From: [email-masked]
	Subject: fvwm closing stdin effects
	Date: Tue, 04 Feb 2003 11:39:28 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Tue Feb 04 11:39:29 2003
From: [email-masked]
To: [email-masked]
Subject: fvwm closing stdin effects
Date: Tue, 04 Feb 2003 11:39:28 -0600

Full_Name: Guillaume Chazarain
Version: 2.4.15
CVS_Date: 
OS: 
X_Server: 
Submission from: (NULL) (157.169.2.1)

Hi,

In the latest fvwm, stdin is closed for forked processes.
I don't have the knowledge to say if it's good or bad,
but it broke rxvt.

I don't ask a patch (I am able to comment a line), I just
want to know the motivation. I agree typical X programs
shouldn't use stdin but I don't see why they should be
disallowed to do so.

Thanks.

Guillaume

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Tue, 04 Feb 2003 16:41:19 -0500

[email-masked] writes:
> Message-Id: <[email-masked]>

Please send questions to [email-masked].
In this case, reply to fvwm-workers.

This is the thread that led to this change:

http://www.hpc.uh.edu/fvwm/archive/0301/msg00305.html

I run rxvt every day without problems.
What OS are you running?
What version of rxvt?
What does the menu entry that launches rxvt look like?
What does "broke rxvt" mean?

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Guillaume Chazarain <[email-masked]>
Date: Wed, 5 Feb 2003 13:54:38 +0100

On Tue, 04 Feb 2003 16:41:19 -0500
Dan Espen <[email-masked]> wrote:

Hello,

> I run rxvt every day without problems.

linux-2.4.20-ck2, XFree86-4.2.1

> What version of rxvt?

I use the latest development version: 2.7.9.
But you made a good point, since I just noticed
that the problem doesn't appear with 2.7.8.
So I think, it's more a rxvt problem.

> What does the menu entry that launches rxvt look like?

Exec rxvt
is enough to show the problem

> What does "broke rxvt" mean?

The window appears for less than a second and quickly
exits and sometimes it writes:

Xlib: sequence lost (0x10808 > 0x5a) in reply type 0x8!

or

Xlib: sequence lost (0x10d4b > 0x5a) in reply type 0x1b!

Thanks.
Guillaume