Subject: Notification: incoming/990

From: [email-masked]
Date: Fri, 21 Feb 2003 12:59:10 -0600

FVWM Bug Tracking notification

new message incoming/990

Message summary for PR#990
	From: [email-masked]
	Subject: fvwm compile issue
	Date: Fri, 21 Feb 2003 12:59:07 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Fri Feb 21 12:59:10 2003
From: [email-masked]
To: [email-masked]
Subject: fvwm compile issue
Date: Fri, 21 Feb 2003 12:59:07 -0600

Full_Name: shane
Version: fvwm-2.5.5
CVS_Date: 
OS: Linux wintermute 2.4.19-newpmac #1 Sat Aug 10 14:38:30 AKDT 2000
X_Server: 
Submission from: (NULL) (66.56.116.239)

make[2]: Entering directory `/home2/shane/fvwm-2.5.5/fvwm'
source='borders.c' object='borders.o' libtool=no \
depfile='.deps/borders.Po' tmpdepfile='.deps/borders.TPo' \
depmode=gcc3 /bin/sh ../depcomp \
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs  -I/usr/include/freetype2 
-I/usr/X11R6/include       
-DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.5\"
-DFVWM_DATADIR=\"/usr/local/share/fvwm\" -DFVWM_CONFDIR=\"/usr/local/etc\"
-DFVWM_COLORSET_PRIVATE=1 -DLOCALEDIR=\"/usr/local/share/locale\" -g -O2
-Wall -Wno-implicit-int -c `test -f 'borders.c' || echo './'`borders.c
borders.c: In function `border_get_tb_parts_to_draw':
borders.c:1007: could not split insn
(insn:TI 2756 3047 2962 (set (reg:SI 8 r8)
        (const_int 4290772992 [0xffc00000])) 296 {*movsi_internal1} (nil)
    (nil))
borders.c:1007: Internal compiler error in final_scan_insn, at
final.c:2622
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://www.gnu.org/software/gcc/bugs.html> for instructions.
make[2]: *** [borders.o] Error 1
make[2]: Leaving directory `/home2/shane/fvwm-2.5.5/fvwm'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home2/shane/fvwm-2.5.5'
make: *** [all] Error 2
wintermute:/home2/shane/fvwm-2.5.5# 

wintermute:/home2/shane/fvwm-2.5.5# gcc -v
Reading specs from /usr/lib/gcc-lib/powerpc-linux/3.2.2/specs
Configured with: ../src/configure -v
--enable-languages=c,c++,java,f77,proto,pascal,objc,ada --prefix=/usr
--mandir=/usr/share/man --infodir=/usr/share/info
--with-gxx-include-dir=/usr/include/c++/3.2 --enable-shared
--with-system-zlib --enable-nls --without-included-gettext
--enable-__cxa_atexit --enable-clocale=gnu --enable-java-gc=boehm
--enable-objc-gc powerpc-linux
Thread model: posix
gcc version 3.2.2

wintermute:/home2/shane/fvwm-2.5.5# cat /proc/cpuinfo 
cpu             : 7400, altivec supported
temperature     : 2-6 C (uncalibrated)
clock           : 450MHz
revision        : 2.8 (pvr 000c 0208)
bogomips        : 894.56
machine         : PowerMac3,1
motherboard     : PowerMac3,1 MacRISC Power Macintosh
detected as     : 65 (PowerMac G4 AGP Graphics)
pmac flags      : 00000000
L2 cache        : 1024K unified
memory          : 256MB
pmac-generation : NewWorld
wintermute:/home2/shane/fvwm-2.5.5# 

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Fri, 21 Feb 2003 15:07:25 -0500

[email-masked] writes:
> Message-Id: <[email-masked]>

Is there some reason I shouldn't remove this bug report?
It looks like a gcc problem.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 24 Feb 2003 10:42:26 +0100

> Is there some reason I shouldn't remove this bug report?

I do not see any.

> It looks like a gcc problem.

I don't see any re

Bye

Dominik ^_^  ^_^