Subject: Bug in Break command?

From: Marcin Pawlik <[email-masked]>
Date: Fri, 21 Feb 2003 21:39:04 +0100

I tried Break command and it doesn't seem to work. For example function:

DestroyFunc  MPTest
AddToFunc    MPTest
+ I Break
+ I Echo "Not working"

always prints the text.

Maybe I don't understand how it should be used...

Tested on current (Feb 21) CVS version.

Regards,

-- 
Marcin Pawlik
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Fri, 21 Feb 2003 15:45:04 -0500

> Tested on current (Feb 21) CVS version.

The man page has an example.
It has to be used in a conditional command.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Marcin Pawlik <[email-masked]>
Date: Fri, 21 Feb 2003 22:07:52 +0100

> It has to be used in a conditional command.

I didn't know. Man doesn't say it _has_ to be used that way. 
But even defined like that:

DestroyFunc  MPTest
AddToFunc    MPTest
 + I Cond (Match) Echo "Cond"
 + I Cond (Match) Break
 + I Echo "Not working"

echoes "Not working". 

I still don't understand.

Regards,

---

From: Dan Espen <[email-masked]>
Date: Fri, 21 Feb 2003 16:58:40 -0500

> I didn't know. Man doesn't say it _has_ to be used that way. 

I think I might have misunderstood how it works.
It seems to want to be able to break out of a function
the way you used it. But...

> I still don't understand.

Well, its broken.

I'll supply a fix soon.

---

From: [email-masked]
Date: Mon, 24 Feb 2003 00:46:08 +0100

> I didn't know. Man doesn't say it _has_ to be used that way. 

No, if should be possible to use break outside conditional
commands too.  At least that was what I intended.

>  + I Cond (Match) Echo "Cond"

Note that Cond should only be used immediately after a
conditional command.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]