Subject: Notification: incoming/991

From: [email-masked]
Date: Fri, 21 Feb 2003 18:53:20 -0600

FVWM Bug Tracking notification

new message incoming/991

Message summary for PR#991
	From: [email-masked]
	Subject: demaximizing an emacs window
	Date: Fri, 21 Feb 2003 18:53:20 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Fri Feb 21 18:53:20 2003
From: [email-masked]
To: [email-masked]
Subject: demaximizing an emacs window
Date: Fri, 21 Feb 2003 18:53:20 -0600

Full_Name: Piotr Zielinski
Version: 2.5.5
CVS_Date: 
OS: Debian 3.0r1 and Redhat 7.2
X_Server: XFree86 4.2.1-5
Submission from: (NULL) (217.40.62.229)

If I open an emacs window, maximize it, move the maximized window to a
different page, and demaximize it, the window is moved to the original
page.  Emacs is the only application that exhibits this behaviour. 
Moreover, this problem doesn't occur in fvwm 2.2.5. (This may be somehow
related to the fact that xlsclients doesn't show emacs windows.)

xwininfo output for the emacs window:

xwininfo: Window id: 0x2e0006c "*scratch*"

  Root window id: 0x36 (the root window) (has no name)
  Parent window id: 0xa00670 (has no name)
     1 child:
     0x2e0006d (has no name): ()  576x549+0+0  +443+214
        2 children:
        0x2e00072 (has no name): ()  576x26+0+0  +443+214
        0x2e0006e (has no name): ()  576x522+0+27  +443+241
           4 children:
           0x2e000a8 (has no name): ()  10x13+3+508  +446+749
           0x2e000a9 (has no name): ()  10x13+3+508  +446+749
           0x2e000a6 (has no name): ()  10x494+3+1  +446+242
           0x2e000a7 (has no name): ()  10x494+3+1  +446+242

  Absolute upper-left X:  443
  Absolute upper-left Y:  214
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 576
  Height: 549
  Depth: 24
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x20 (installed)
  Bit Gravity State: NorthWestGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +443+214  -5+214  -5-5  +443-5
  -geometry 80x40-0-0

  Bit gravity: NorthWestGravity
  Window gravity: NorthWestGravity
  Backing-store hint: NotUseful
  Backing-planes to be preserved: 0xffffffff
  Backing pixel: 0
  Save-unders: No

  Someone wants these events:
      KeyPress
      ButtonPress
      ButtonRelease
      EnterWindow
      LeaveWindow
      PointerMotion
      Exposure
      VisibilityChange
      StructureNotify
      SubstructureNotify
      FocusChange
      PropertyChange
      ColormapChange
  Do not propagate these events:
      ButtonPress
      ButtonRelease
  Override redirection?: No

  Window manager hints:
      Client accepts input or input focus: Yes
      Initial state is Normal State

  Normal window size hints:
      Program supplied size: 576 by 549
      Program supplied minimum size: 16 by 29
      Program supplied x resize increment: 7
      Program supplied y resize increment: 13
      Program supplied size in resize increments:  82 by 42
      Program supplied minimum size in resize increments: 2 by 2
      Program supplied window gravity: NorthWestGravity
  No zoom window size hints defined

  No window shape defined
  No border shape defined

xprop output for the emacs window:

WM_STATE(WM_STATE):
                window state: Normal
                icon window: 0x0
_WIN_AREA(CARDINAL) = 1, 0
_WIN_WORKSPACE(CARDINAL) = 0
_WIN_LAYER(CARDINAL) = 4
_WIN_STATE(CARDINAL) = 0
_NET_WM_ALLOWED_ACTIONS(ATOM) = _NET_WM_ACTION_CHANGE_DESKTOP,
_NET_WM_ACTION_CLOSE, _NET_WM_ACTION_MAXIMIZE_HORZ,
_NET_WM_ACTION_MAXIMIZE_VERT, _NET_WM_ACTION_MOVE, _NET_WM_ACTION_RESIZE,
_NET_WM_ACTION_SHADE, _NET_WM_ACTION_STICK
_KDE_NET_WM_FRAME_STRUT(CARDINAL) = 5, 5, 26, 26
_NET_WM_DESKTOP(CARDINAL) = 0
WM_PROTOCOLS(ATOM): protocols  WM_DELETE_WINDOW, WM_TAKE_FOCUS,
WM_SAVE_YOURSELF
WM_CLIENT_LEADER(WINDOW): window id # 0x2e0006c
WM_LOCALE_NAME(STRING) = "C"
WM_CLASS(STRING) = "emacs", "Emacs"
WM_HINTS(WM_HINTS):
                Client accepts input or input focus: True
                Initial state is Normal State.
WM_NORMAL_HINTS(WM_SIZE_HINTS):
                program specified size: 576 by 549
                program specified minimum size: 16 by 29
                program specified resize increment: 7 by 13
                window gravity: NorthWest
WM_CLIENT_MACHINE(STRING) = "pz215"
WM_ICON_NAME(STRING) = "*scratch*"
WM_NAME(STRING) = "*scratch*"

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 24 Feb 2003 10:55:43 +0100

> related to the fact that xlsclients doesn't show emacs windows.)

Which emacs version?

Please give me detailed step-by-step instructions.  It is very
important to know how exactly each step is done.  For example, I
need to know how the window was maximized (e.g. by clicking on a
title button, using a menu or a keystroke etc.), whether the emacs
window was on the current page when you unmacimized it, and so on.

Bye

Dominik ^_^  ^_^

---

From: Piotr Zielinski <[email-masked]>
Date: Mon, 24 Feb 2003 14:50:59 +0000

Sorry, reproducing this behaviour is more tricky than I thought.  It
appears that the culprit is the gnuserv program.  Those are the minimal
.emacs file that causes this behaviour 

(autoload 'gnuserv-start "gnuserv-compat"
          "Allow this Emacs process to be a server for client processes."
           t)
(gnuserv-start)

I assume gnuserv is installed in the system.  The version of gnuserv I
use is 3.12 with emacs 20.7.  The (minimal) .fvwm2rc file has the following
contents 

EdgeScroll 100 100
EdgeResistance 300 3
SnapAttraction 10 All Screen
DeskTopSize 2x2

Style "*" MWMDecor

ButtonStyle 4 vector 4 50x30@1 70x70@0 30x70@0 50x30@1
ButtonStyle 6 vector 4 50x70@1 30x30@1 70x30@1 50x70@0

Mouse 1         4       A       Maximize 0 93
Mouse 1         2       A       Delete
Mouse 1         6       A       Iconify

Those are the steps:
0. Go to page 0 0
1. Open emacs (emacs &)
2. Maximize the emacs window by clicking Button 4
3. Move it using mouse to page 1 0
4. You are on page 1 0 now
5. Click Button 4 again.
The effect is that the window returns to page 0 0.

And forget about what I said about other versions of fvwm.  I tested it
on other people's computers, but as it turned out today they don't use
gnuserv.

Thanks,

Piotr