Subject: One letter variables

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 2 Jan 2003 12:31:10 +0000

I would like to get rid of one-letter variables in the long run, since
they are very problematic. Some, like $d, are not consistent with all
other variables, and they all conflict with $width, $right and similar in
module lines, so one-letter variables are not expanded in module lines.

By converting them to $[] variable we solve all these problems.

  $d      - $[desk.num]
  $w      - $[w.id]
  $n      - $[w.name]
  $c      - $[w.class]
  $r      - $[w.resource]
  $v      - $[version.line], $[version.num], $[version.info]
  $x      - we already have $[vp.x] for this
  $y      - we already have $[vp.y] for this

Any comment are welcome.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 3 Jan 2003 05:23:19 +0100

>   $y      - we already have $[vp.y] for this

I've no objection against these changes. However, I think we
should support the one letter name for 2.6.

Olivier

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 3 Jan 2003 05:25:51 +0000

> > By converting them to $[] variable we solve all these problems.

Additional practical problem is SendToModule FvwmPerl eval $c++; then one
letter variables conflict with perl variables.

> >   $d      - $[desk.num]

I think it may be $[desk.n] for consistency with $[page.nx], $[page.ny].

> should support the one letter name for 2.6.

I think I didn't add any breakage of 2.4.x syntax during 2.5.x.
The idea is always document the new syntax, but still support the old one.
I will also backport these variables to 2.4.x, so there will be no any
reason to use the one latter variables anymore, unless I see objections.

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 4 Jan 2003 09:18:48 +0000

On 04 Jan 2003 09:08:29 +0000, Tim Phipps wrote:
> Mikhael Goikhman wrote:
> Desks only have a number and nothing else don't they?  So why not just 
> $[desk]?

Well, we already have $[desk.name<n>], $[desk.width], $[desk.height]
and in the future $[desk.pagesx] or $[desk.sizex].

Besides, $[desk] is a valid shell variable, like "SetEnv desk bla-bla".

Regards,
Mikhael.