Subject: Determining if a window is iconified.

From: Marcus Lundblad <[email-masked]>
Date: Mon, 27 Jan 2003 22:47:44 +0100 (CET)

Is there some good way (from a shell script) to determine if a window is
iconified? 
I'm writing tests for the new Closable, Maximizable etc. styles.

xwininfo gives the geometry of the windows normal size, so there is no
difference when iconifiying.

I guess an alternative is to have an interactive script where the user is
asked wuestions interactivly.

//Marcus

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Mon, 27 Jan 2003 17:01:10 -0500

> Is there some good way (from a shell script) to determine if a window is

This seems to work:

FvwmCommand 'Next (window1 iconic) echo "yesitsiconic"'

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Cameron Simpson <[email-masked]>
Date: Tue, 28 Jan 2003 09:29:20 +1100

On 22:47 27 Jan 2003, Marcus Lundblad <[email-masked]> wrote:
| Is there some good way (from a shell script) to determine if a window is
| iconified? 
| I'm writing tests for the new Closable, Maximizable etc. styles.
| 
| xwininfo gives the geometry of the windows normal size, so there is no
| difference when iconifiying.
| 
| I guess an alternative is to have an interactive script where the user is
| asked wuestions interactivly.

Maybe a tiny C program to check if the window id is mapped?
-- 
Cameron Simpson, DoD#743        [email-masked]    http://www.zip.com.au/~cs/

Don't close your eyes for the crash; you'll miss the best part.
	- Bruce MacInnes, Skip Barber Driving School instructor
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Kingsly John <[email-masked]>
Date: Tue, 28 Jan 2003 08:20:31 +0530

> difference when iconifiying.

in the output of xwininfo... 

Map State: IsViewable

becomes 

Map State: IsUnMapped

when the window is iconified.

Kingsly