Subject: FvwmTaskBar DeskOnly and PageOnly

From: Elliot Sowadsky <[email-masked]>
Date: Sun, 26 Jan 2003 21:03:07 -0800 (PST)

2.5.5 on Solaris 5.8

If I have in .fvwm2rc...

DeskTopSize 4x1

AddToFunc StartFunction
+	I Module FvwmPager * *

*FvwmTaskBar: DeskOnly
*FvwmTaskBar: PageOnly

AddToFunc GotoDesk_func
+	I GotoDesk 1 0 1
# work around Taskbar PageOnly bug
# +	I GotoPage prev
# +	I GotoPage prev

*FvwmTaskBar: StartCommand (Mouse 2) GotoDesk_func

then...

switching between desks ignores PageOnly and all of a desk's buttons
get displayed. Some even get displayed double.

Let me know if you cant easily repeat this.

Thanx

If it matters any, my FvwmTaskBar is actually...

*FvwmTaskBar: 3DFvwm
*FvwmTaskBar: Action Click3 Winlistfunc
*FvwmTaskBar: AutoStick
*FvwmTaskBar: ButtonWidth 421
*FvwmTaskBar: ClockFormat %e
*FvwmTaskBar: Colorset 5
*FvwmTaskBar: IconColorset 6
*FvwmTaskBar: FocusColorset 4
*FvwmTaskBar: Font -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*
*FvwmTaskBar: Geometry +150-0
*FvwmTaskBar: MailCommand Next ("Mailtool*") Op_Raise "Iconify off"
*FvwmTaskBar: DeskOnly
*FvwmTaskBar: PageOnly
*FvwmTaskBar: Rows 2
*FvwmTaskBar: ShowTips
*FvwmTaskBar: StartCommand (Mouse 1) Next (cm) Op_Raise "Iconify off"
*FvwmTaskBar: StartCommand (Mouse 2) GotoDesk_func
*FvwmTaskBar: StartIcon mini-pager.xpm
*FvwmTaskBar: StartName cm
*FvwmTaskBar: UseIconNames
*FvwmTaskBar: UseSkipList
*FvwmTaskBar: WindowButtonsLeftMargin 0
*FvwmTaskBar: WindowButtonsRightMargin 0
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 27 Jan 2003 09:46:52 +0100

> Let me know if you cant easily repeat this.

Fixed.

Bye

Dominik ^_^  ^_^