Subject: transforming image into container

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 17 Dec 2002 05:04:23 +0000

I think that given an image WxH and a container AxB, there are the
following useful options to fit one into another:

[the first means what to do for x direction, the second - for y direction]

  1) fit,     fit
  2) fit,     tile
  3) fit,     stretch
  4) tile,    fit
  5) tile,    tile
  6) tile,    stretch
  7) stretch, fit
  8) stretch, tile
  9) stretch, stretch

  10) aspect fit

In (10) image becomes AxB/W*A or A/H*BxB whichever is greater than AxB.
I think at least (3), (6) and (9) make a lot of sense for titles.

Do you think there are more options? Do you think some are redundant?
For example, since title has a fixed height (more or less) and fully
variable width, then (1), (4), (7) are not essential for the title design.

There are also partial images (that may fill only a part of AxB).

  11-19) center/left/right, center/top/bottom
  20-28) fit/tile/stretch,  center/top/bottom
  29-37) center/left/right, fit/tile/stretch

For me the first full-sized 10 are very useful for an arbitrary colorset.
Currently we only support (1), (5) and (10).

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: parv <[email-masked]>
Date: Tue, 17 Dec 2002 03:06:23 -0500

in message <[email-masked]>,
wrote Mikhael Goikhman thusly...
> [the first means what to do for x direction, the second - for y direction]
...
> Do you think there are more options?

besides stretching & compacting, is there any plan for other
transformations like mirroring/rotating?

given a small image, say 100x100 pix, i particularly like xv's
"root: symmetrical mirrored" (-rmode 9) option.  this option is best
suited for tile work on large backgrounds like root window or
WindowList menu.

  - parv

--

---

From: Dan Espen <[email-masked]>
Date: Tue, 17 Dec 2002 09:06:02 -0500

> Do you think there are more options?

I hope not.

-- 
Dan Espen                           E-mail: [email-masked]