Subject: Re: ClickToFocus/Maximize glitch ?

From: Giuseppe Della Ricca <[email-masked]>
Date: Sat, 21 Dec 2002 11:09:14 +0100 (CET)

Hi !

I have a button in the titlebar of all my windows, build as:

DestroyFunc Maximize-Func
AddToFunc Maximize-Func         C Maximize 0   100
+                               D Maximize 100 100

Mouse 0         2       A       Maximize-Func

If I have two xterm windows on my screen, and single-click on this button 
of the focussed one, the selected window is maximized, but 'underneath/below' 
the other one.

If the situation is like this:

+----------o
|    1     |
+----------+

  +------o
  |  2   |
  +------+

and the window 1 has focus, when I single-click on its button 'o', the 
result is like this:

+----------o
|          |
|    1     |
|          |
| +------o |
| |  2   | |
| +------+ |
+----------+

Window 1 still has focus, but is below window 2.
I would expect that the focussed window remains 'above' the other one.

I use:

Style * ClickToFocus, GrabFocus

I'm running fvwm 2.5.6 (from cvs) compiled on Dec 20 2002 at 09:48:04.

Thanks a lot, and ... Happy Holidays !

cheers,
Giuseppe.

PS: I'm not subscribed, so please Cc: if you need more details.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 21 Dec 2002 18:23:57 +0000

> If the situation is like this:

Focus, Maximize and Raise are independent. I would dislike it if the
focused (or maximized) window would be automatically raised. If you need
this, just add this line:

  AddToFunc Maximize-Func         C Raise

Or maybe this:

  AddToFunc Maximize-Func         C ThisWindow (Focused) Raise

Regards,
Mikhael.

---

From: Giuseppe Della Ricca <[email-masked]>
Date: Sat, 21 Dec 2002 21:13:51 +0100 (CET)

Hi Mikhael,

> focused (or maximized) window would be automatically raised.

ok, I understand: I thought that window I was maximizing was already both 
focussed and raised, and I was disappointed that it was remaining 
focussed, but that it was slipping below the unfocussed one.

So even when using ClickToFocus, one can have two nearby window, one 
focussed and the other one raised ?

It seems to me a bit 'unnatural', but ok ...

> If you need this, just add this line:
> 

+                               C Maximize 0   100
+                               D Maximize 100 100

seems to work as I was expecting.

Thanks a lot !

regards,
Giuseppe.