Subject: Plans, was: things to be done for 2.6

From: Marcus Lundblad <[email-masked]>
Date: Mon, 9 Dec 2002 20:34:04 +0100 (CET)

I have some plans for new menu functionallity. This will have to wait
until after the feature freeze for 2.6, ofcourse.

The idea (as discussed before) is to have conditional statements in menus.
For example have conditionals to make an item inactive (greyed out),
unavailable and choose different labels depending on conditionals.

For example:

AddToMenu WindowMenu
+	Inactive(!Maximized, !Iconified) "Restore" RestoreFunc
	...
+	Skip(FixedSize)	"Size"	Resize
	...
+	If(Sticky) "Unstick" Stick off 	Else "Stick" Stick on

Suggestions are ofcourse welcome.
I plan to use the code as the other conditional statements. And also I
plan to add conditionals for all function hints (I implemented
conditionals "FixedSize" and "HasHandles"). This would also involve new
styles "FixedPostion", "Uniconifiable" and so forth.
Yes I know, many people hate when these hints are used. But after all
these are styles so it means freedom for the user...

//Marcus

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 9 Dec 2002 20:37:59 +0000

> these are styles so it means freedom for the user...

You may read some discussions about a new menu syntax here:

  http://www.hpc.uh.edu/fvwm/archive/0203/msg00508.html

As for your examples, I suggest to use only the conditions we have now in
ThisWindow, i.e. (!Focused, !Maximized, !Iconic), not Inactive(...).

Regards,
Mikhael.

---

From: Marcus Lundblad <[email-masked]>
Date: Mon, 9 Dec 2002 21:40:02 +0100 (CET)

> ThisWindow, i.e. (!Focused, !Maximized, !Iconic), not Inactive(...).

Well, I inteded "Inactive" to describe the meu item (ie. shaded out)

//Marcus

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 9 Dec 2002 21:08:46 +0000

> Well, I inteded "Inactive" to describe the meu item (ie. shaded out)

Ok, "Disabled" is already covered by that link. There is no need in
Skip/If/Else (and if/else is just impossible to parse without conflicts).
Only one condition specifier "C" is needed to enhance that proposal:

  + I "Unstick"
  + C   (Sticky)
  + A   Stick off
  + I "Stick"
  + C   (!Sticky)
  + A   Stick on

Regards,
Mikhael.