Subject: CVS dane: * COMMANDS: Finish first pass.

From: FVWM CVS <[email-masked]>
Date: Wed, 11 Dec 2002 09:38:25 -0600

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	dane	02/12/11 09:38:25

Modified files:
	docs           : COMMANDS ChangeLog 

Log message:
* COMMANDS: Finish first pass.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 11 Dec 2002 11:36:40 -0500

> * COMMANDS: Finish first pass.

I marked some items with a question mark.

I just happened to catch the StickyAcrossxxx commands
and added them to the list.

It seems like a very useful thing to have a list like that,
but it seems like a bad idea to keep it separate from the
fvwm source code or the fvwm man page.  Its going to
get out of sync.

Extracting from the man page wouldn't be to hard, but
the command introductions need to be made more regular,
I saw:

.BI "Command"
.BI Command
.BI "Command ["
.IP "\fBCommand [[\fP"

Of course we could just do:

.\" ONELINE Command "One line description"

before each command.

I don't plan to do anything like that right now.
I'm just sharing some thoughts.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 12 Dec 2002 08:43:07 +0000

> I marked some items with a question mark.

I will proof read this later.

> I'm just sharing some thoughts.

I don't think having such comment line in the man page is the best.

I initialy created COMMANDS from functable.c, the man page is less
relable. If any automatization is to be done, I think, it is adding
52-char description in functable.c near every command in the list.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 12 Dec 2002 10:03:52 +0100

> I just happened to catch the StickyAcrossxxx commands
                                   ^^^

The name is "StickAcross...".

Bye

Dominik ^_^  ^_^

---

From: Dan Espen <[email-masked]>
Date: Thu, 12 Dec 2002 10:01:02 -0500

> The name is "StickAcross...".

Yep.  I got it right in the COMMANDS file.
Its easy to get confused with the Style option.
This might end up as FAQ question 0.2.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 12 Dec 2002 16:08:24 +0100

> This might end up as FAQ question 0.2.

Just like the "Stick" command and the "Sticky" style.

Bye

Dominik ^_^  ^_^

---

From: Dan Espen <[email-masked]>
Date: Thu, 12 Dec 2002 10:38:00 -0500

Mikhael Goikhman <[email-masked]> writes:
> reliable. If any automation is to be done, I think, it is adding

The closer to the source code, the better.
But:

There are commands in functable.c that are not meant for the end
user, for example "set_mask".  An additional flag in the macro call
could solve that.

The one line description is very close to the first sentence
in the man page that describes the command.  Very likely they
could be identical.  A program that used functable.c
to generate parts of fvwm.1.in could solve that too.