Subject: confused fvwm with 3200x1200 display

From: Brad Giaccio <[email-masked]>
Date: Thu, 19 Dec 2002 11:43:17 -0500

Well I seem to have confused fvwm I just got a video card that supports
to monitors as one screen.

Fvwm and a 3200 geometry are very confused. Most notablly when I drag
a window from montior one to the second I can watch the x coord go up
until I get to 1600 and then it resets to zero. this really brakes
things like the initail placement of FvwmButtons at -0+0 it winds up at
1600+0. but if i place it where I expect it to be and use FvwmIdent I
get correct screen coordinates in the 3thousandths.

I doubt anyone has the setup to reproduce this but its been a while
since I've done editing and I know you've made substantial event code
changes so some pointers would be helpful.

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 19 Dec 2002 17:59:59 +0100

> changes so some pointers would be helpful.

I rather guess the video card confuses the X server.  If what I
understand is correct, fvwm is not even aware of the second screen
(unless you use Xinerama or dual head).  That sounds as if the
display width is only 1600, not 3200.  What does

  $ xwininfo -root

say?

Bye

Dominik ^_^  ^_^

---

From: Brad Giaccio <[email-masked]>
Date: Thu, 19 Dec 2002 12:04:24 -0500

xwininfo -root

xwininfo: Window id: 0x89 (the root window) (has no name)

  Absolute upper-left X:  0
  Absolute upper-left Y:  0
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 3200
  Height: 1200
  Depth: 24
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x20 (installed)
  Bit Gravity State: NorthWestGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +0+0  -0+0  -0-0  +0-0
  -geometry 3200x1200+0+0

The video driver actually reports the combined size of 3200 
so as far as X is concenred it is just one wide screen.

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 20 Dec 2002 10:20:38 +0100

> so as far as X is concenred it is just one wide screen.

I have no idea where the 1600 is coming from.  Fvwm can not have
made it up by itself, it must have been reported by X.  Can you
put some debug output in fvwm.c that prints out Scr.MyDisplayWidth
right after line 1122 where it is set?

Bye

Dominik ^_^  ^_^

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 20 Dec 2002 11:40:20 -0500

Scr.MyDisplayWidth is equals to 3200 at that point.

I seem to have tracked down the problem X was running XINERMA 
and I didn't realize it, I'm still not sure I under stand the 
window placement but now I know what docs to brush up on.

Brad