Subject: Re: FvwmTaskBar name sort

From: Elliot Sowadsky <[email-masked]>
Date: Sat, 21 Dec 2002 18:32:34 -0800 (PST)

Oh i left out part of the change i made to my copy...

< Simple change that sorts the buttons by name...
< 
< in ButtonArray.c AddButton(), i added a string compare to the for loop.
< 
<     for (temp = array->head; temp->next; temp = temp->next)
<     	 if (strcmp(temp->next->title, title) > 0) break;
< 

     new->next=temp->next	// added before temp->next = new;
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Elliot Sowadsky <[email-masked]>
Date: Sat, 21 Dec 2002 22:59:25 -0800 (PST)

I'm not a developer....but i provide my changes, so that developers can incorperate mthem if they choose if think others would like them. I figger it's better to send out what i did than to merely say "I would like you guys to put in an option that... ".