Subject: FvwmWindowLister

From: Elliot Sowadsky <[email-masked]>
Date: Wed, 4 Dec 2002 17:17:19 -0800 (PST)

<<
> BTW, any chance of windowlist going to a user=specified menu
> format instead of canned format switches?
>
> For instance, i editted my windowlist.c to be the equivalent of...
>
> %h  %i %p %c %n
>
> h - hotkey
> i - iconic (iconic ? "I" : " ")
> p - page
> c - class
> n - name

There is some work going on with the new FvwmWindowLister module.
Personally I hope it will replace the whole WindowList command one
day.  It is a perl script and thus extensible much more easily.
Hopefully it will provide a much more flexible interface than
WindowList does now.

Is there any work in the near future on adding sorting by {type} to
FvwmWindowLister? I could then add what i added to my windowlist.c, where i
add a "null' entry where a multiple entry class is starting or ending.

I'm not familiar enough w/ perl to do much w/ it.
(awk is so much easier to work w/)
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Richard Lister <[email-masked]>
Date: Wed, 04 Dec 2002 20:37:34 -0500 (EST)

Elliot Sowadsky <[email-masked]> wrote on Wed, 4 Dec 2002 17:17:19 -0800 (PST):
>
> Subject: FvwmWindowLister
>

Elliot

I'm not quite sure what you mean here. Currently it sorts windows
into groups by title (or class, resource, etc) in a user-defined way,
and puts separators between those groups. Is that not what you're
after? Can you send me a screenshot of what your code does?

Cheers
Ric

Richard J Lister
Dept of Neuroscience
Georgetown University Medical Center
http://cns.georgetown.edu/~ric/