Subject: Please send a bug report to the application owner

From: Donn aka N5XWB <[email-masked]>
Date: Sun, 22 Dec 2002 20:09:00 -0600

Build Operating System: SuSE Linux [ELF] SuSE
Module Loader present
Markers: (--) probed, (**) from config file, (==) default
setting,
         (++) from command line, (!!) notice, (II)
informational,
         (WW) warning, (EE) error, (NI) not implemented,
(??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Sun Dec 22
19:01:30 2002
(==) Using config file: "/etc/X11/XF86Config"
[FVWM][GetWindowSizeHints]: <<WARNING>> Cddb error - K3b
window 0x800cb9 has broken (max_width) size hints
Please send a bug report to the application owner,
        you may use [email-masked] as a reference.
hint override = 0
flags = 23f
min_width = 189, min_height = 115, max_width = 188,
max_height = 114
width_inc = 136865616, height_inc = 137865840
min_aspect = 1086846882/1090849156, max_aspect =
137089888/-1073747816
base_width = 1093362570, base_height = 1094077400
win_gravity = 1

[FVWM][GetWindowSizeHints]: <<WARNING>> Cddb error - K3b
window 0x800cfc has broken (max_width) size hints
Please send a bug report to the application owner,
        you may use [email-masked] as a reference.
hint override = 0
flags = 23f
min_width = 189, min_height = 115, max_width = 188,
max_height = 114
width_inc = 137729288, height_inc = 137907928
min_aspect = 1086846882/1090849156, max_aspect =
137910200/-1073747816
base_width = 1093362570, base_height = 1094077400
win_gravity = 1

[FVWM][GetWindowSizeHints]: <<WARNING>> Cancel - K3b window
0x801af4 has broken (max_width) size hints
Please send a bug report to the application owner,
        you may use [email-masked] as a reference.
hint override = 0
flags = 23f
min_width = 275, min_height = 115, max_width = 274,
max_height = 114
width_inc = 137735792, height_inc = 138545576
min_aspect = 1086846882/1090849156, max_aspect =
138399496/-1073754900
base_width = 1093362570, base_height = 1094077400
win_gravity = 1

waiting for X server to shut down xterm:  fatal IO error 32
(Broken pipe) or KillClient on X server ":0.0"
X connection to :0.0 broken (explicit kill or server
shutdown).
xterm:  fatal IO error 32 (Broken pipe) or KillClient on X
server ":0.0"
xterm:  fatal IO error 32 (Broken pipe) or KillClient on X
server ":0.0"

This error comes after running a compiled K3B (built on
KDE3) music ripping program in fvwm2 2.4.14
-- 
73 de Donn Washburn     __ " http://www.hal-pc.org/~dwash "
Ham Callsign N5XWB     / /     __  __  __  __  __ __  __ 
307 Savoy St.         / /__   / / /  \/ / / /_/ / \ \/ /
Sugar Land, TX 77478 /_____/ /_/ /_/\__/ /_____/  /_/\_\
LL# 1.281.242.3256       a MSDOS Virus "Free Zone" OS
Email: [email-masked]   Info: http://www.austinlug.org
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sun, 22 Dec 2002 21:51:28 -0500

> (==) Log file: "/var/log/XFree86.0.log", Time: Sun Dec 22

You need to send this to the K3B developers.
I really don't know how QT3 works, but I downloaded K3B version
0.7.5 and I saw a few places where they set the minimum size
but not the maximum or aspect ratio.

My guess is that if you set some of the hints, you have to
set them all.

> xterm:  fatal IO error 32 (Broken pipe) or KillClient on X

I don't think the K3B problem would lead to the X server
shutting down.

> KDE3) music ripping program in fvwm2 2.4.14

Fvwm is telling you the application has set invalid size
hints.  Fvwm then ingore those hints and carries on.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 23 Dec 2002 02:52:33 +0000

> KDE3) music ripping program in fvwm2 2.4.14

So, why do you send this to us and not to K3B owners as the message
suggests? :)

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 23 Dec 2002 03:01:11 +0000

Dan, can you please replace English to be not ambiguous, something like
"This is an error in your application, not fvwm, please send a bug report
to the owners of the application that created this window.".

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Sun, 22 Dec 2002 22:27:47 -0500

> to the owners of the application that created this window.".

Done.
I'll do the stable branch in a day or three.