Subject: Re: FVWM: Premature close of OpenInterface GUI

From: Dan Espen <[email-masked]>
Date: Fri, 06 Dec 2002 13:20:34 -0500

Tomi Vainio - Sun Finland - <[email-masked]> writes:
> Dameron, Gregg writes:
>  > 
>  > Great.  What's our next step?  Tomi, do you see a workaround?
>  >
> If someone from development team can login to my machine using ssh and
> run RM6 application to see what the problem is?

(Note the change to fvwm-workers.)

Send me the information for system access.

Let me know if nights or weekends are OK, I probably won't
get to this right away.

-- 
Dan Espen                           E-mail: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "Dameron, Gregg" <[email-masked]>
Date: Mon, 16 Dec 2002 09:12:41 -0700

> > I don't see how I can make any more progress with this without
> > some help from the rm6 developers.
> 
> And I think we should not waste our time debugging broken
> applications.  I'd dispose of the problem by sending a bug report
> and hope they will fix it.

I'll get a bug report submitted to Sun.  I'm grateful to Tomi, Dan and
Dominik for their investigative work.  The fvwm workers went above and
beyond, once again.

Gregg Dameron

---

From: Dan Espen <[email-masked]>
Date: Sun, 22 Dec 2002 11:14:34 -0500

Ryan Daly <[email-masked]> writes:
> I had a hard time getting that error to appear.  Sometimes it does,
> sometimes it doesn't.  But, it finally did, and while the other window
> appeared briefly, I ran the xwininfo and grabbed the output.
> 
> Hopefully this is what you're looking for.  Let me know what else you
> need.
> 
> Thanks.
> 
> Here's the error:
> 
> X Error of failed request:  BadWindow (invalid Window parameter)
>   Major opcode of failed request:  3 (X_GetWindowAttributes)
>   Resource id in failed request:  0x2200001
>   Serial number of failed request:  121
>   Current serial number in output stream:  122
> 
> I've attached the xwininfo output.

(I'm only including what I think is the relevant part to fvwm-workers.
If anyone wants to see the whole think let me know.)

xwininfo: Window id: 0x68 (the root window) (has no name)

  Root window id: 0x68 (the root window) (has no name)
  Parent window id: 0x0 (none)
     67 children:
     0x2200016 (has no name): ()  32x32+0+0  +0+0
     0x2200012 "EDM(edm2): Help": ("openedit" "OpenInterface")  500x557+390+217  +390+217
     0x220000f "Error Window": ("openedit" "OpenInterface")  598x178+53+191  +53+191
     0x240000f "Error Window": ("openedit" "OpenInterface")  598x178+53+191  +53+191
     0x2400001 (has no name): ()  1x1+1+1  +1+1
     0x2200001 (has no name): ()  1x1+1+1  +1+1
     0x200002a (has no name): ()  32x32+0+0  +0+0
     0x2000022 (has no name): ("openedit" "OpenInterface")  300x200+200+200  +200+200
     0x200000f "Error Window": ("openedit" "OpenInterface")  598x178+53+191  +53+191
     0x2000001 (has no name): ()  1x1+1+1  +1+1
     0x400061 (has no name): ()  94x17+0+0  +0+0

The window that matches the error message is an 1x1 window at location
+1+1.  Based on traces I ran on rm6, I believe this must have never
been mapped so fvwm won't be doing anything with the window.

Its probably there for the toolkit to trace some property.

Unfortunately, I have no idea how this information helps solve the
problem.  It still looks to me like a problem with the application.