Subject: New style options and conditionals.

From: Marcus Lundblad <[email-masked]>
Date: Sun, 15 Dec 2002 20:58:33 +0100 (CET)

Here is the patch for the new styles:
Closable, Iconifiable, Maximizable and AllowMaximizeFixedSize
and conditionals
Closable, Iconifiable and Maximizable

The style AllowMaximizeFixedSize turns on and off the possibility to
maximise windows that are fixed size (ie. the function Resize is not
allowed).

//Marcus

---

From: Dan Espen <[email-masked]>
Date: Sat, 21 Dec 2002 17:30:19 -0500

> maximise windows that are fixed size (ie. the function Resize is not

Well, I finally got around to applying this one.
I did some tests and it seems to work as advertised.

That reminds me, the "tests" directory is not being updated.
There will never be a 2.6 unless there is an adequate set of
tests.

I had a question about this wording in the man page:

.IR AllowMaximizeFixedSize
enables the function 
.I Maximize
to be performed on windows that are not resizable, unless maximisation
has been disabled either using the style 
.I Unmaximizable
or throuth WM hints,
This on by default.
.IR DisallowMaximizeFixedSize
disables the function 
.I Maximize
for all windows that are not resizable.
Note that some applications set the window's minumum and maximum size
the same and and expect this to mean that the size is fixed.
This style forbids maximisation of such windows.

The last 2 sentences seem to say the same thing, and seem to
be out of place. Since this is disabling maximization, I don't
thing anything is necessary.

-- 
Dan Espen                           E-mail: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Marcus Lundblad <[email-masked]>
Date: Sun, 22 Dec 2002 10:38:11 +0100 (CET)

> thing anything is necessary.
Actually according to Dominic, setting min- and max-size doesn't inhibit
maximisation, unless maximisation is explicitly forbidden (through
mwm-hints or such).
And setting style "FixedSize" doesn't automatically disable maximisation
as one expects. So using Style !AllowMaximizeFixedSize always disables
maximisation on windows that are not resizable. Maybe I was´a bit unclear
in those sentences in the manual page.

And thanks for applying the patch.

And Merry Christmas, Ein frühlich Weinacht, God Jul and Happy New Year
and so on... to all on this list.

//Marcus

---

From: Marcus Lundblad <[email-masked]>
Date: Mon, 23 Dec 2002 18:40:05 +0100 (CET)

> There will never be a 2.6 unless there is an adequate set of

How much work is it to update the tests? I could perhaps "dive
 into" this at the end of next week.

Unfortunatly right now I'm stuck with  a Windows machine. (and downloading
cygwin over a modem is not fun...)

---

From: Dan Espen <[email-masked]>
Date: Mon, 23 Dec 2002 13:04:01 -0500

>  into" this at the end of next week.

Ideally, there would be a test for every statement made in
the man page.  Given the size of our man pages,  I guess there's
a lot of work to do.

For the changes you just made, it would be nice to have a test that
creates an xterm, makes it uncloseable, pops up a message saying
window should not close, then trys "close", "delete", "destroy".
Then asks, is window still open?  Then something similar
with closeable. And so on.  Perl Gtk might
be helpful, or even command line shell or perl.

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 23 Dec 2002 18:45:02 +0000

> be helpful, or even command line shell or perl.

Almost all tests may be done non-interactive. It is just a matter of
checking whether a window is still here:

  None (MyUniqueWindow) Echo BUG 1

or it is still has the needed geometry:

  Next (MyUniqueWindow) Exec test $[w.width] = 80 || echo Echo BUG 2

Only visual effects should be done interactive, i.e. I don't see a good
way to test whether the window decorations are transparent or have some
nifty multi colorset look without asking the tester.

Regards,
Mikhael.