Subject: GCC 3.2 compilation error for CVS version (patch)

From: [email-masked]
Date: Sun, 17 Nov 2002 06:19:14 +0300

Hello

With GCC 3.2 latest CVS version gives the following error:

gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs  -I/usr/include -I/usr/include/freetype2 -I/usr/include -I/usr/X11R6/include     -I/usr/X11R6/include              -DFVWM_MODULEDIR=\"/home/lazy/local//libexec/fvwm/2.5.5\"    -DFVWM_DATADIR=\"/home/lazy/local//share/fvwm\"         -DFVWM_CONFDIR=\"/home/lazy/local//etc\"        -DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c borders.c
cc1: warning: changing search order for system directory "/usr/include"
cc1: warning:   as it has already been specified as a non-system directory
borders.c: In function `border_get_tb_parts_to_draw':
borders.c:868: could not split insn
(insn 1169 1132 1228 (set (reg:SI 10 r10)
        (const_int 4290772992 [0xffc00000])) 296 {*movsi_internal1} (nil)
    (nil))
borders.c:868: Internal compiler error in final_scan_insn, at final.c:2622
Please submit a full bug report,
with preprocessed source if appropriate.
See  for instructions.
make[2]: *** [borders.o] Error 1
make[2]: Leaving directory `/home/lazy/developer/fvwm/fvwm'

The actuall problem and a quick solution see in the patch file
( it's only one line in a function ). Patched version seems to be working
correctly.
I didn't send the GCC bug, as I don't know the true origin of the problem.

My system is ppc:
Linux navi 2.4.19-r6 #14 Tue Nov 5 13:36:38 EST 2002 ppc  745/755 GNU/Linux
I don't know if there is a simillar problem on x86 machines.

...fuzzy

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 17 Nov 2002 07:37:03 +0000

> With GCC 3.2 latest CVS version gives the following error:

Well, this seems to be ppc dependent, not (just) GCC 3.2, so you should
probably send a bug report to gcc mac porters.

> cc1: warning:   as it has already been specified as a non-system directory

I would really like to find a gcc option to turn these warnings off.
We can't do anything about them until *-config owners "fix" their scripts.
I don't know where to find the gcc-3.2 switch to turn them off.

>From a quick look the patch does not seem to be correct.

~X is not the same as 0 ^ X. It is hovewer the same as ~0 ^ X, I think.
But I am not sure your gcc will not die on this too.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked]
Date: Mon, 18 Nov 2002 00:45:46 +0100

> I didn't send the GCC bug, as I don't know the true origin of the problem.

Well, I suggest you do send the gcc bug report and switch to a
working gcc version in the mean time (2.95.x4 is the last that I
know is working reliably).  We can do little about the problem
other than this.

> I don't know if there is a simillar problem on x86 machines.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]