Subject: re: fix for 2.5.4 xview

From: Elliot Sowadsky <[email-masked]>
Date: Wed, 13 Nov 2002 10:44:05 -0800 (PST)

<<
Finally, I think I understand what your problem is.  How am I
supposed to know that you have configured your paste key as a
*modifier* key?

Actually I didnt configure Paste as a modifier key.
The L8/Paste behavior comes w/ the system.

<< <<
> change:       if (!FP_IS_LENIENT(FW_FOCUS_POLICY(fw)) && !focus_does_accept_input_focus(fw) &&  sf != NULL && sf->Desk == Scr.CurrentDesk)
>
> to:   if (!FP_IS_LENIENT(FW_FOCUS_POLICY(fw)) && !focus_does_accept_input_focus(fw) && (sf == NULL || sf->Desk == Scr.CurrentDesk))
> >>

With that patch:
   If the window that is supposed to receive focus is an xview
   window.
AND
   No window has the focus yet.
THEN
  The window will not get focused.
That is just plain wrong.  You will be unable to focus any
xview window unless you focus another findow first.  In order to
fix a problem, I have to see it first.
Style * IconBox 176 -60 -60 -5

Hmmmm.....Ive been using this and havent had any focus problem.
The xview window does have (sf == NULL) and appears to want a return of
FALSE.

FVWMIdent says Glabally Active, Input Field False, WM_TAKE_FOCUS Present.

<<
Sigh!  You cut out all the relevant parts from the config.  With
the one you sent, icons are *supposed* to appear in the top left
corner.

Ack!!!

Style * IconBox 176 -60 -60 -5
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 13 Nov 2002 13:57:32 -0500

> The L8/Paste behavior comes w/ the system.

Heres what xmodmap says about the key:

    KeyCode	Keysym (Keysym)	...
    Value  	Value   (Name) 	...

     80    	0xffcf (F18)	0xffcf (F18)	0x1005ff74 (SunPaste)	

The output of xmodmap -pm references F18:

shift       Shift_L (0x6a),  Shift_R (0x75)
lock        Caps_Lock (0x7e)
control     Control_L (0x53)
mod1        Meta_L (0x7f),  Meta_R (0x81)
mod2        Mode_switch (0x14)
mod3        Num_Lock (0x69)
mod4        Alt_L (0x1a)
mod5        F13 (0x20),  F18 (0x50),  F20 (0x68)

I think that does make it a modifier...
At first I was sure it wasn't.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 13 Nov 2002 20:23:07 +0100

> At first I was sure it wasn't.

Anyway, that should be fixed now.

Bye

Dominik ^_^  ^_^