Subject: Style IconSize and application supplied icon windows

From: Marcus Lundblad <[email-masked]>
Date: Thu, 14 Nov 2002 22:42:47 +0100 (CET)

When an application supplies it's own window as an icon (for example
XJewel), the style IconSize has no effect.
I guess this is known problem, since this feature (IconSize) is quite new.
Just thought to point this out just incase...

//Marcus

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Steve Talley <[email-masked]>
Date: Thu, 14 Nov 2002 15:01:47 -0700

Application-provided icon windows are purposely not resized by
IconSize because the application may need the window to be a certain
size.  The window could provide more than just an icon, so resizing
may adversely affect the application's functionality.

There is a quick note about application-provided icons in the fvwm man
page.

Steve

Marcus Lundblad wrote:

> XJewel), the style IconSize has no effect.  I guess this is known
> problem, since this feature (IconSize) is quite new.  Just thought
> to point this out just incase...
>
> //Marcus

---

From: Marcus Lundblad <[email-masked]>
Date: Thu, 14 Nov 2002 23:14:43 +0100 (CET)

> may adversely affect the application's functionality.

Wouldn't it be possible to use the same technique as with
swallowed windows in FvwmButtons?
Just a thought. (Those icons break the nice symmetry :-) )

//Marcus

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 14 Nov 2002 22:42:24 +0000

On 14 Nov 2002 23:14:43 +0100, Marcus Lundblad wrote:
> 
> (Those icons break the nice symmetry :-) )

You may probably like:

  Style * IconOverride

Regards,
Mikhael.

---

From: Steve Talley <[email-masked]>
Date: Fri, 15 Nov 2002 16:52:06 -0700

Good point.  A little harder to implement, but might be worth
considering in the future.

Steve

Marcus Lundblad wrote:

> > IconSize because the application may need the window to be a
> > certain size.  The window could provide more than just an icon, so
> > resizing may adversely affect the application's functionality.
>
> Wouldn't it be possible to use the same technique as with swallowed
> windows in FvwmButtons?  Just a thought. (Those icons break the nice
> symmetry :-) )
>
> //Marcus

---

From: Marcus Lundblad <[email-masked]>
Date: Sat, 16 Nov 2002 01:02:36 +0100 (CET)

> considering in the future.

Yep.
I looked a little at the code.
MWM does someting like this, clipping the window into a frame.
And I guess since you work at Sun you have some familiarty with dtwm.

Pardon if I made some spellingmistakes (after 2 litres of beer :-) )