Subject: re: fix for 2.5.4 xview

From: Elliot Sowadsky <[email-masked]>
Date: Sat, 16 Nov 2002 00:37:22 -0800 (PST)

<<
> During this time (key held down), a mouse click should not cause
> a change in focus.  2.5.3 and prior didnt not cause change in
> focus. 2.5.4 does.

Finally, I think I understand what your problem is.  How am I
supposed to know that you have configured your paste key as a
*modifier* key?  The behaviour you describe is 100% correct, exect
for modifier key.  I can take care of this.

I was prinf'ing around in events.c

In 2.5.4, all mouse left button clicks (didnt try middle/right) cause
fvwmSelect() to return, thus i believe always triggering a focus change
event.

In 2.5.3, mouse clicks in the window having focus dont cause fvwmSelect() to return. Also, mouse clicks while L8 is held down dont cause fvwmSelect() to return.

fvwmSelect is in libs/fvwmsignal.c
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked]
Date: Mon, 18 Nov 2002 00:46:02 +0100

> fvwmSelect is in libs/fvwmsignal.c

Didn't I mention that the problem is already fixed? in CVS?

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]