Subject: Maximise and Fixed Size

From: Marcus Lundblad <[email-masked]>
Date: Wed, 13 Nov 2002 23:16:44 +0100 (CET)

I found a problem with windows that doesn't support resizing.

When using tear-off menus in Motif and GTK+ the window resize operation is
prohibited.
But still the maximise option in my window menu is available.
In Motif it just beeps when selected, in GTK+ it moves the window to the
upper left corner (maybe this is a bug in GTK+).
Also I assigned:

Style Menu	NoButton 2, NoButton 4, NoHandles, FixedSize

to get the same behaviour for the tear-offs in TK. But these are even
possible to maximise, although not resizable (as expevted).

I have a function assinged for maximising in the window menu. But the
behaviour is the same if I invoke "Maximize" from FvwmConsole so I don't
think this is the problem.

//Marcus 

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 14 Nov 2002 00:57:59 +0100

> think this is the problem.

Yes, I know this problem.  The application does not tell the wm
that it does not want to be maximized.  It simply assumes that
setting min size = max size is equivalent, but it's not in fvwm.
I'm not sure if the EWMH provides a "do not maximize" hint.  In
general it's not a good idea to add some heuristics to guess if
an application wants to maximizable or not.  A while ago I
extended the concept of the maximized state to a secondary
geometry that is not necessarily related to the window size.
(See MoveMaximize command et. al.).  I'd say it's better to let
the user choose if (s)he maximizes the window or not.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]