Subject: re: fix for 2.5.4 xview

From: Elliot Sowadsky <[email-masked]>
Date: Sat, 9 Nov 2002 23:02:21 -0800 (PST)

< Fix for this problem that appeared in 2.5.3 and is still in 2.5.4
< 
< < ie: Upon restart or some other fvwm activities (such as menus), xview
< < windows no longer accept (take) focus. It requires opening the window's menu
< < but not selecting anything from it for xview windows to take focus again.
< < Mailtool works fine tho somehow.
< < 
< < Lenience fixes this, but then the 1st click in the window isnt passed to the
< < window.
< < 
< < clicktofocus mode
< 
< 
< In focus,c
< 
< change:	if (!FP_IS_LENIENT(FW_FOCUS_POLICY(fw)) && !focus_does_accept_input_focus(fw) &&  sf != NULL && sf->Desk == Scr.CurrentDesk)
< 
< to:	if (!FP_IS_LENIENT(FW_FOCUS_POLICY(fw)) && !focus_does_accept_input_focus(fw) && (sf == NULL || sf->Desk == Scr.CurrentDesk))

Turns out theres a problem new to 2.5.4 (w or w/o my above fix) that didnt exist in 2.5.3.

xview secondary selections cause focus to change.

Bring up 2 xview (eg textedit) windows (1 and 2).
Type some text in window 2.
Click into window 1.
Hold down Paste (L8) and select some text from window 2.
Release Paste key,
Selected text will get copied to window 1..
Window 1 should keep focus (which 2.5.3 does).
In 2.5.4, window 2 gets focus upon release.

I have a textk app that also allows 2ndary edits.
It's also seeing a switching of focus i believe between key_down and
key_up.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 10 Nov 2002 23:54:09 +0100

Okay, this is my last attempt to get these xview issues resolved.
Please understand that I can not spend roughly a quarter of my
fvwm time trying to guess what you actually mean with your bug
reports.

I could not reproduce a single problem you reported in the last
few weeks, and I tried long and hard - several hours.  When I ask
you for configuration snippets and detailed instructions I almost
never get an answer.  When I ask you questions about the bug
reports I almost never get an answer.  When I make a patch and ask
if it helped to fix the problem, I rarely get an answer.  Instead,
the same problems are reported again and again after a while with
no additional information.  For example, you posted that patch
more than a year ago, and I explained why it will not be applied
and asked for further information which I never got.

Please understand that I can not continue to spend this much time
with your bug reports.  Their quality and your responsiveness has
to improve for me to work efficiently.

Now my last attempt to get feedback on the individual problems:

1) Send me your full configuration file and all icons that are
   necessary to demonstrate below problems.  Also, please state
   the command line which you use to start fvwm and the exact fvwm
   version in each bug report.

2) "My mozilla icon which used to be white is now grey."
   Again:  Is that and application provided icon or one set in
   fvwm?  I need at least the exact mozilla vertsion and that icon
   if it is a separate file.  This may be a side effect of the
   color limit rewrite and may already have changed since then.

3) You wrote:

> Start an xview application (cmdtool/textedit).
> Unfocus it, iconify it and reopen it using the windowlist menu
> (alternatively,  Rester) Click into the xview app. May want to use multiple
> xview windows to help the initial defocusing. 
>
> The window won't accept focus....until you bring up a menu in that window
> (need not select anything from menu) and then click in the window.

> An easier way...
>
> "FvwmIdent" an xview window.
> Click on the identfy window, closing it.
> This will cause the xview not take focus problem.   

   Both work perfectly for me with.  I need your configuration file.

4) "... the icons in to left corner upon Restart is back.  Once
   opened tho, icons obey iconbox upon iconifying."

   I need the configuration file, a specific application
   (preferredly *not* an xview application), and exact
   instructions ("click here, move mouse there, ...").

> It's also seeing a switching of focus i believe between key_down and

   - My keyboard does not have an L8 or Paste key.
   - I tried to bind XK_L8 to the F8 key.  Now, when I press that
     key in the textedit window, the text cursor disappears.
     Nothing else happens.  I have no idea how cut and paste works
     in textedit, what key I would have to press to cut a
     selection.  How am I supposed to mark text in window 2?  With
     keystrokes?  Or button presses?  I need instructions that an
     idiot can understand.
   - Is there another, mor mundane key that should have the same 
     effect as the Paste key?
   - What is a "secondary edit"?
   - What is a "secondary selection?"
   - How to I make a "secondary selection"?
   - Please do not assume that anybody is able to use xview
     applications.

Bye

Dominik ^_^  ^_^

P.S.:  Can someone please forward this mail to Elliot just in case
my mails are lost on the way?

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]