Subject: Notification: incoming/950

From: [email-masked]
Date: Fri, 01 Nov 2002 21:20:17 -0600

FVWM Bug Tracking notification

new message incoming/950

Message summary for PR#950
	From: [email-masked]
	Subject: xft font and TitleAtLeft or Right
	Date: Fri, 01 Nov 2002 21:20:16 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Fri Nov 01 21:20:16 2002
From: [email-masked]
To: [email-masked]
Subject: xft font and TitleAtLeft or Right
Date: Fri, 01 Nov 2002 21:20:16 -0600

Full_Name: Shawn Anderson
Version: fvwm 2.5.5 (from cvs)
CVS_Date: Fri Nov  1 20:08:17 MST 2002
OS: gentoo linux gcc 3.2
X_Server: XFree86 Version 4.2.1
Submission from: (NULL) (166.70.14.106)

start fvwm with no fvwm2rc file.

1) open FvwmConsole
2) Style FvwmConsole TitleAtLeft
   or Style FvwmConsole TitleAtRight
3) Style FvwmConsole font xft:arial
   (or any other font)

after this the titlebar font is not displayed properly. Only the lower half
of the font is visible, and it sorta looks backwards.

I am using xft2, but i think this happens with xft1 also.

If you need any more info, let me know.
thanks,
sa

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Sun, 3 Nov 2002 07:18:42 +0100

On Fri, Nov 01, 2002 at 09:20:17PM -0600, [email-masked] wrote:
> Message-Id: <[email-masked]>

Unfortunately, I am unable to reproduce this problem (tried
with 2 "versions" of Xft2/XFree).

Is this problem "new"? Can you try with xft1 (do so that 
fontconfig-config is no more in your path and then ./configure;
make install) ? Any info you think which may help a little bit is
welcome.

Regards, Olivier

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 4 Nov 2002 14:42:44 +0100

> of the font is visible, and it sorta looks backwards.

Can you send me your /etc/fonts/fonts.conf file and a screenshot of a
titlebar.  Note that I can reproduce problems with pcf font displayed
with xft (no title at all with vertical titlebar). But I've no problem
with ttf or Type1 fonts.

Olivier

---

From: "S. Anderson" <[email-masked]>
Date: Sun, 3 Nov 2002 19:31:21 -0700

> make install) ? Any info you think which may help a little bit is
ok, i tried it with xft1 and xft2, They both give this problem.
I also tried fvwm-2.5.1 through fvwm-2.5.4, and all of these dont work
properly either. It used to work for me! I will try some more things,
and report back any findings.

attached is a screenßhot of this problem.

thanks,
sa

---

From: "S. Anderson" <[email-masked]>
Date: Tue, 5 Nov 2002 03:17:22 -0700

> with xft (no title at all with vertical titlebar). But I've no problem

hello,
I was messing around with Fft.c and I kind of fixed my problem.
I'm sure this isn't the proper fix, because the text is still
upside down (style * TitleAtRight, RightTitleRotatedCCW is
doing what RightTitleRotatedCW is supposed to do.) and the
text is still not aligned properly by one or two pixels when 
there is no shadow defined...

--- Fft.c   2002-11-05 02:40:44.000000000 -0700
+++ Fft.c.test  2002-11-05 02:40:04.000000000 -0700
@@ -344,8 +344,8 @@
                          fws->flags.text_rotation);
        }
        uf = fftf->fftfont_rotated_90;
-       y = fws->y;
-       x = fws->x - FLF_SHADOW_BOTTOM_SIZE(flf);
+       y = fws->y + FftTextWidth(flf, fws->e_str, len);
+       x = (fws->x * 2) - FLF_SHADOW_BOTTOM_SIZE(flf);
    }
    else if (fws->flags.text_rotation == ROTATION_180)
    {
@@ -368,8 +368,8 @@
                          fws->flags.text_rotation);
        }
        uf = fftf->fftfont_rotated_270;
-       y = fws->y + FftTextWidth(flf, fws->e_str, len);
-       x = fws->x - FLF_SHADOW_UPPER_SIZE(flf);
+       y = fws->y;
+       x = (fws->x  / 2) - FLF_SHADOW_UPPER_SIZE(flf);
    }
    else
    {

If I figure out whats going on here, I'll let you know.
hth,
sa

---

From: "S. Anderson" <[email-masked]>
Date: Mon, 4 Nov 2002 18:27:41 -0700

> with xft (no title at all with vertical titlebar). But I've no problem
ok its attached, I also sent a message to the fvwm-workers list
yesterday, but it never arrived to the list :-(.

I tried fvwm-2.5.1 to fvwm-2.5.4 and th xft1 and 2, they all have
this problem.But i remember it used to work! so im thinking its a
problem with gentoo linux, i will check into it and report back.

thanks,
sa

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 5 Nov 2002 17:02:51 +0100

> there is no shadow defined...

If I apply the patch the text is not displayed well at all on my
machine.  Maybe there is a problem with freetype2.  What is the
version of freetype2 do you use?  (package version and freetype-config
--version which is different from the package version).  A typical pb
with freetype2 is that it is possible that your system has 2 freetype2
libs installed (one from XFree and the other one from a freetype2
package ...).

Also, Xft2/fontconfig is a recent library. I suggest you use the
latest version of this package (http://fontconfig.org). You say you
have pbs with Xft1. But which version of Xft1 do you use? There
is two Xft 1 library :o/ the one from XFree-4.2.x and the one from
fcpackage.

Finally, do you use a multi-head X setup?

Regards, Olivier

---

From: "S. Anderson" <[email-masked]>
Date: Tue, 5 Nov 2002 13:38:30 -0700

> libs installed (one from XFree and the other one from a freetype2

 % freetype-config --version
9.1.3
 % emerge -s freetype
      Latest version installed: 2.1.2-r1

X was built with this in my host.def.
#define HasFreetype2           YES
#define UseFreetype2           YES
#define Freetype2LibDir        /usr/lib

 # updatedb
 # locate libfreetype
/usr/lib/libfreetype.a
/usr/lib/libfreetype.la
/usr/lib/libfreetype.so
/usr/lib/libfreetype.so.6
/usr/lib/libfreetype.so.6.3.1
/usr/X11R6/lib/modules/fonts/libfreetype.a

hmm, so I have three versions?  9.1.3, 2.1.2 and 6.3.1 interesting.

> is two Xft 1 library :o/ the one from XFree-4.2.x and the one from

I just reinstalled my linux distribution (yesterday), So right now
I just have the xft1 from xfree86 4.2.1. In my previous installation,
I didnt try xft1 from fcpackage, but i did try xft2 from it.
(fcpackage.2_0).

> Finally, do you use a multi-head X setup?
nope

I'll let you know if I figure out anything.
thanks,
sa

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 5 Nov 2002 23:25:06 +0100

>       Latest version installed: 2.1.2-r1

Ok, this is the problem. It seems that there are changes in
freetype which cause the pbs. fvwm is ok with 2.1.0 but not
with 2.1.2 (do not try yet 2.1.1). Now we should know if
this a bug or a new feature of 2.1.2. Any way I will fix the
problem in the next few days.

Regards, Olivier

---

From: "S. Anderson" <[email-masked]>
Date: Tue, 5 Nov 2002 18:43:36 -0700

> problem in the next few days.

I dont think you need to fix anything, I just downloaded and installed 
freetype-2.1.3rc3 and everything works perfectly.

Thanks!
sa