Subject: [FVWM][ParseBinding]: <<ERROR>> No such key: KP_1

From: Jan Martinek <[email-masked]>
Date: Thu, 28 Nov 2002 09:10:14 +0100

Hello,

I have fvwm-2.4.13.
It seems to me that numeric keypad is ignored, this is what I tried:

1) In XF86Config commented out 
#  Option       "XkbLayout" "cz"
to make sure only US keyboard layout is turned on

2) my .xinitrc has the only line
exec fvwm2

3) I wrote only these two lines in my .fvwm2rc
Key KP_1           A       CM      Exec exec xterm
Key 2           A       CM      Exec exec rxvt

By pressing Alt+Ctrl+2 (not numeric) I can start rxvt
But I am unable to start xterm any way. I tried to run
xev
and it confirmes that the key I am pressing on numeric
keypad really is KP_1.

On the console I get error message
[FVWM][ParseBinding]: <<ERROR>> No such key: KP_1

Does KP_number have a different name?
Thank you,
Jan Martinek
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked]
Date: Thu, 28 Nov 2002 22:35:30 +0100

> Does KP_number have a different name?

No, the name is correct.  The error message means that the key
symbol is not bound to any key at the time the binding line is
processed.  "xmodmap -pke" should not list KP_1 anywhere (unless
the keymap is changed after fvwm already started up).

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: [email-masked]
Date: Sat, 30 Nov 2002 00:11:41 +0100

On Fri, Nov 29, 2002 at 08:24:54PM +0100, Jan Martinek wrote:

(Please always reply to the mailing list).

> no, I do not change the keymap (i hope) while fvwm is running. This
> is the result of the xmodmap test:
> 
> $  xmodmap -pke | grep KP_[[:digit:]]
> keycode  79 = KP_Home KP_7
> keycode  80 = KP_Up KP_8
> keycode  81 = KP_Prior KP_9
> keycode  83 = KP_Left KP_4
> keycode  84 = KP_Begin KP_5
> keycode  85 = KP_Right KP_6
> keycode  87 = KP_End KP_1
> keycode  88 = KP_Down KP_2
> keycode  89 = KP_Next KP_3
> keycode  90 = KP_Insert KP_0
> 
> So the numeric keys can be accessed only if numlock is on.

Ah, no.  If your X server works like mine, the config above states
that the KP_# keys can be accessed with shift held down, not
num-lock.  Actually, I don't know exactly how you have to
configure your Xmodmap for this.  Perhaps someone else can provide
a snippet of his configuration.

> To make sure this does not make the problem I added this line
> to .fvwm2rc
> IgnoreModifiers 2
> 
> But I am unable to successfuly bind the KP_number keys to any
> fvwm action, these are always ignored.
> How can I bind them?
>  

Bye

Dominik ^_^  ^_^

---

From: Dan Espen <[email-masked]>
Date: Fri, 29 Nov 2002 20:10:21 -0500

> Does KP_number have a different name?

Oops, sorry, I typed this yesterday, but forgot to send it:

The command parses and works OK for me.
However, I've never been happy with the default keymaps and
I do use modmap to make this change:

keycode 119=End KP_1

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Jan Martinek <[email-masked]>
Date: Sat, 30 Nov 2002 10:53:55 +0100

Oh, yes! That was my problem. I did not press the shift key
and wrongly expected that numlock does this job instead.
Thank you for advice and sorry for bothering.

Jan Martinek