Subject: Notification: incoming/953

From: [email-masked]
Date: Mon, 04 Nov 2002 16:32:27 -0600

FVWM Bug Tracking notification

new message incoming/953

Message summary for PR#953
	From: [email-masked]
	Subject: configure problem with IMLIB on Sun/Sol9
	Date: Mon, 04 Nov 2002 16:32:27 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Mon Nov 04 16:32:27 2002
From: [email-masked]
To: [email-masked]
Subject: configure problem with IMLIB on Sun/Sol9
Date: Mon, 04 Nov 2002 16:32:27 -0600

Full_Name: Ed Phillips
Version: 2.4.13
CVS_Date: 
OS: 
X_Server: 
Submission from: (NULL) (128.175.1.9)

configure fails to use -R/opt/sfw/lib even though
"--with-imlib-prefix=/opt/sfw/lib" is specified on Solaris 9, so the IMLIB
test fails.

I'm using gcc 2.95.3 on a Sun Ultra 10 with Solaris 9.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 5 Nov 2002 19:15:00 +0000

> "--with-imlib-prefix=/opt/sfw/lib" is specified on Solaris 9, so the IMLIB

"prefix" means the imlib installation prefix, not the library directory.

Try:

  --with-imlib-prefix=/opt/sfw

And please ensure you have a good $imlib_prefix/bin/imlib-config script.

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Tue, 05 Nov 2002 14:49:18 -0500

> And please ensure you have a good $imlib_prefix/bin/imlib-config script.

I'm jealous, I've yet to find any version of imlib that will build
on a Solaris system.  I could ask my admins to install the /opt/sfw
stuff, but what fun would that be.

Oh yeah, I had a point.
None of these "xxxx-config" things work correctly in Solaris.
I've modified them to add the -R flag where needed.  For example,
gtk-config:

glib_libs="-L/opt/public/lib -R/opt/public/lib -lgmodule -lglib -ldl"
                             ^^^^^^^^^^^^^^^^^
and so on.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Ed Phillips <[email-masked]>
Date: Wed, 6 Nov 2002 10:37:22 -0500 (EST)

Thanks... imlib-config that gets installed from the Sol9 Software
Companion CD appears to be broken (no -R/opt/sfw/lib).

On Tue, 5 Nov 2002, Mikhael Goikhman wrote:

> Date: Tue, 5 Nov 2002 19:15:00 +0000
> From: Mikhael Goikhman <[email-masked]>
> To: FVWM Workers <[email-masked]>
> Cc: Ed Phillips <[email-masked]>
> Subject: Re: Notification: incoming/953
>

Ed Phillips <[email-masked]> University of Delaware (302) 831-6082
Systems Programmer III, Network and Systems Services
finger -l [email-masked] for PGP public key