Subject: check-in: cycles and proxies

From: [email-masked]
Date: Sun, 24 Nov 2002 22:00:59 -0800

I just did a commit on a small core mod and some larger proxy changes.

The code czars may want to take look at fvwm/conditional.c to make sure
I didn't wreck the Direction command.  I'm pretty sure the non-cycle
code path is hardly even touched.

I did not edit the fvwm2 man page yet.  I'll update it if the changes
are welcomed.

Proxy has changed noticably based on the blend of suggestions I've gotten.
I updated the man page, but we may want to replace the sample to something
more palatable to the average user.  Suggestions welcome.

commit notes:
    * fvwm/conditional.c
    Extended Direction to allow CycleWest, CycleEast, etc that guarantees
    eventual traversal of all windows over repeated calls.  It also cycles
    back to the opposite extent when it hits the limit in the given direction.

    * FvwmProxy/ConfigFvwmProxyDefaults:
    * FvwmProxy/FvwmProxy.c (ProcessMessage):
    Twiddled with icon text placement rules.
    Added programmable Action options for Click1, Click2, ...
    Fixed background clear during internal Next/Prev
        (which we're getting rid of).
    Changed all the *Command options to the Action syntax.
    Added the Circulate command that used core fvwm functions instead
        of internal Next/Prev.
    Commented out lots of code being phased out.
    Added Unmark Action to mirror Mark Action.

    * FvwmProxy/FvwmProxy.1:
    Updated for Action commands and various formatting.

-- 
  _
 ( \      _  \    /_ /  _ _  Jason Weber                  (503) 380-7424
  \|(\/)()))  \/\/(-/_)(-/(  Infinite Monkeys Inc.        Aloha, Oregon
  //                         http://www.imonk.com/baboon  [email-masked]
 (/     [email-masked]        [email-masked]

     "Canister contains at least 50% recycled material; 15%
      post-consumer content."
   -- Pringles Fat-Free (side of can)
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 25 Nov 2002 12:21:09 +0100

> code path is hardly even touched.

I'll look at the functionality later.  But in the mean time some
rules of the road you should follow when you edit files in the
core that I maintain (conditionals.c):

  * Please always add all the names of the functions you touched
    in the ChangeLog.
  * 8 spaces per tab
  * no more than 79 characters per line
  * please keep the formatting style of the existing code (e.g.
    placement of spaces)
  * give flags a meaningful name, beginning with a modal verb,
    e.g. "do_forward" instead of "forward"
  * When you use the constants True and False only use them with
    variables of type Bool and never assume they have a specific.
    value.  The code below is problematic at best:

      int ordered = (forward == (cross < best_cross));

    Instead it should be

      ordered = (!!do_forward == (cross < best_cross));

Overall I would prefer to move the new functionality into a
separate function.

Bye

Dominik ^_^  ^_^