Subject: Problems compiling code from CVS

From: Marcus Lundblad <[email-masked]>
Date: Sat, 16 Nov 2002 21:28:46 +0100 (CET)

Right now I get a compilation error (actually a make-error) with the code
from CVS. Any idea when the code will be in a working state?

I get the following error:

Making all in FvwmProxy
make[3]: Entering directory `/home/marcus/prg/fvwm/modules/FvwmProxy'
make[3]: *** No rule to make target `all'.  Stop.
make[3]: Leaving directory `/home/marcus/prg/fvwm/modules/FvwmProxy'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/marcus/prg/fvwm/modules'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/marcus/prg/fvwm'
make: *** [all-recursive-am] Error 2
$ 

//Marcus 

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sat, 16 Nov 2002 15:39:04 -0500

> make: *** [all-recursive-am] Error 2

run:

utils/configure_dev.sh

or its equivalent.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: [email-masked]
Date: Sat, 16 Nov 2002 12:40:43 -0800

> make: *** [all-recursive-am] Error 2

I changed the FvwmProxy source files, but not the make/config files.
Can I assume you have a recent checkout and did the reconfig/etc commands?

Hmmm.  Hmm.  What does your modules/FvwmProxy/Makefile look like?
Can anyone else reproduce this?

-- 
  _
 ( \      _  \    /_ /  _ _  Jason Weber                  (503) 380-7424
  \|(\/)()))  \/\/(-/_)(-/(  Infinite Monkeys Inc.        Aloha, Oregon
  //                         http://www.imonk.com/baboon  [email-masked]
 (/     [email-masked]        [email-masked]

     "Canister contains at least 50% recycled material; 15%
      post-consumer content."
   -- Pringles Fat-Free (side of can)
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sat, 16 Nov 2002 15:53:19 -0500

> Can anyone else reproduce this?

Sure, I reproduced it last week when I first built after FvwmProxy
was added.

:)

It happens when you do a CVS update followed by a make
instead of using the configure_dev.sh shell.
Various things make reconfiguring necessary,
new modules is one example.

---

From: Marcus Lundblad <[email-masked]>
Date: Sun, 17 Nov 2002 00:26:15 +0100 (CET)

> new modules is one example.

Yep. After running utils/configure_dev.sh building works fine.

//Marcus

---

From: [email-masked]
Date: Mon, 18 Nov 2002 00:45:35 +0100

> Yep. After running utils/configure_dev.sh building works fine.

Running "make" can not handle when new Makefiles have to be
generated for the first time.  You need to run automake manually
to get them.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]