Subject: Notification: incoming/958

From: [email-masked]
Date: Fri, 22 Nov 2002 07:02:14 -0600

FVWM Bug Tracking notification

new message incoming/958

Message summary for PR#958
	From: [email-masked]
	Subject: dragging windows off screen can crash fvwm
	Date: Fri, 22 Nov 2002 07:02:13 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Fri Nov 22 07:02:14 2002
From: [email-masked]
To: [email-masked]
Subject: dragging windows off screen can crash fvwm
Date: Fri, 22 Nov 2002 07:02:13 -0600

Full_Name: Tom Jones
Version: 2.4.11 - 2.4.13
CVS_Date: 
OS: Solaris 8
X_Server: Xsun
Submission from: (NULL) (128.16.10.151)

Dragging a window off the top-right or bottom-left corners of the screen
causes an immediate crash of fvwm. This is with a fvwm compiled with gcc
2.95.2 under Solaris 8. 

The problem is only exhibited under Solaris 8. Using the same binaries
under 9, the problem doesn't occur. The problem also doesn't occur under
Solaris 7 (using binaries compiled under Solaris 7). Under 8, the problem
is perfectly reproducible.

The machines on which this bug was noticed are a SunBlade 100s. When trying
it on a SPARCstation 20 (which is not an ultra), this problem does not
occur.

You can drag windows off the top-left and bottom-right corners just fine.

The problem occurs with all configuration files we've tried, and it also
occurs in the absence of any configuration file.

The behaviour is identical in both versions of fvwm that I've tried: 2.4.11
and 2.4.13.

The last few lines of configure's output was:

FVWM Configuration:

  Version:     2.4.11

  Executables: /opt/UCLCSxcontrib/bin
  Man pages:   /opt/UCLCSxcontrib/man
  Modules:     /opt/UCLCSxcontrib/libexec/fvwm/2.4.11
  Data files:  /opt/UCLCSxcontrib/share/fvwm

  With GNOME Window Manager hints?   yes
  With GTK support for FvwmGtk?      no: Failed to detect GTK, see
config.log
  With Multibyte support?            no: Use --enable-multibyte to enable
  With ReadLine sup. in FvwmConsole? yes
  With RPlay support in FvwmEvent?   no: Can't find working librplay
  With Shaped window support?        yes
  With Session Management support?   yes
  With Stroke support?               no: Can't find working libstroke
  With Xinerama support?             no: Failed to detect libXinerama
  With XPM support?                  no: Can't find working libXpm

I'll stop there for now in case you already know what the problem is, but
I'm happy to do a more detailed bug report if not.

 thanks,
  Tom.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 22 Nov 2002 17:40:34 +0100

> I'm happy to do a more detailed bug report if not.

Can you compile fvwm with debug symbols enabled and fetch us a stack
trace?  With gcc/gdb:

   $ make CFLAGS="-g"

to build and then run and crash fvwm, locate the core file and run

  $ gdb fvwm2 core
  (gdb) where

Others may help out with the instructions for the SOlaris compiler
and debugger.

Bye

Dominik ^_^  ^_^

---

From: Tom JONES <[email-masked]>
Date: Fri, 22 Nov 2002 17:52:18 +0000

On Fri, 22 Nov 2002 17:40:34 +0100,

>Can you compile fvwm with debug symbols enabled and fetch us a stack

Sure, but I'm just about to go on holiday for a week, so I'll 
get back to you after that.

 cheers,
 Tom.