Subject: Notification: incoming/961

From: [email-masked]
Date: Sat, 23 Nov 2002 22:57:00 -0600

FVWM Bug Tracking notification

new message incoming/961

Message summary for PR#961
	From: [email-masked]
	Subject: duplicate sounds when using FvwmEvent
	Date: Sat, 23 Nov 2002 22:57:00 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Sat Nov 23 22:57:00 2002
From: [email-masked]
To: [email-masked]
Subject: duplicate sounds when using FvwmEvent
Date: Sat, 23 Nov 2002 22:57:00 -0600

Full_Name: Norvell Spearman
Version: 2.5.4, fvwm-snap-20021122
CVS_Date: 
OS: Mandrake Linux 8.1, kernel 2.4.18
X_Server: 4.1.0
Submission from: (NULL) (64.185.2.4)

When using FvwmEvent with esd/esdplay, I sometimes get two sounds (slightly
asynchronous) for one event.  Invoking FvwmEvent in FvwmAudio compatibility
mode seems to fix this problem --- that is, I can't reproduce it when in
FvwmAudio compatibility mode.  The following is from my .fvwm2rc file when
using FvwmEvent

########
AddToFunc StartFunction
+       I       Module FvwmEvent
*FvwmEvent:     Cmd "Exec esdplay"
########

Adding a ``*FvwmEvent:    Delay 5'' doesn't help.  When in FvwmAudio
compatibility mode, I have the following in my .fvwm2rc file

########
AddToFunc StartFunction
+       I       Module FvwmAudio

*FvwmAudio:     Cmd esdplay
########

If you need more details let me know.  Thanks.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked]
Date: Fri, 29 Nov 2002 20:25:07 +0100

> If you need more details let me know.  Thanks.

What are the events you get multiple times?   It may be necessary
to filter some events, for example when you a raise a windoe with
its transients, you get one event for each window that was raised,
not just one.  I can hardly believe it does not show the same
behaviour as it is virtually the same code being executed.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked]
Date: Sat, 30 Nov 2002 22:44:33 +0100

(Please reply to the mailing list, not to me personally).

On Fri, Nov 29, 2002 at 09:26:20PM -0600, Norvell Spearman wrote:
> On Fri, Nov 29, 2002 at 08:25:07PM +0100, [email-masked] wrote:
> I first noticed it with iconify and deiconify on all types of windows
> (from xterm to gvim to phoenix), but didn't try any other events.  With
> startup event I never remember noticing multiple sounds

> and (for some reason) I hardly ever hear the shutdown event sound
> at all.

Because FvwmEvent is already dying when this event arrives and may
not have to time to play it before it is killed.

> Now when it
> comes to xmms (with its equalizer and playlist windows), I expect and
> get three sounds on iconify and deiconify when using both FvwmEvent and
> FvwmAudio.

> But with the other window types this definitely happens with
> no transients present.

Does it happen with any application, or only with specific ones?
 
> If it helps, I tried different values (1, 2, and 5, if I recall
> correctly) with FvwmEvent's Delay option and I could tell no difference.
> I tried using FvwmAudio compatibility mode as kind of a last resort and
> was mildly surprised that the problem went away.

Are you *sure* you do not have another FvwmEvent running?  That
would explain everything.

If you can't figure it out alone, strip down your sonfig file as
much as possible so that it still happens and post it to the list.

> You say ``virtually the same code.''  Do FvwmEvent and FvwmAudio parse
> the Cmd argument in exactly the same way?

They parse it in the same way, but in audio mode the Cmd is run as
in a shell and in FvwmEvent mode it is sent to fvwm.  That is why
you nee to use Exec in front of the command line.  But otherwise
it is the same.

> I ask this because the error
> messages I'd get in my ~/.xsession-errors file seemed to indicate that
> esd was getting more requests than it could handle at once (although
> there's usually no problem with normal multiple sounds, e.g., if I
> iconify a window while xmms is playing through its esd output plugin).

> I apologize if those were a stupid question and observation; I'm not a
> programmer yet.

As I use to say:  there are no stupid questions, only stupid
answers. :-)

Bye

Dominik ^_^  ^_^