Subject: re: fix for 2.5.4 xview

From: Elliot Sowadsky <[email-masked]>
Date: Fri, 29 Nov 2002 15:08:46 -0800 (PST)

< I don't have cview.  Does that happen with textedit too?

happens w/ textedit.
Happens w/ a plain Restart from a menu tied to middle button.
Always happens....have never had a Restart that didnt cause focus problems.

< I can see that if the pointer is over the window after a restart,
< it does not take the focus upon the first click but only on the
< second one.

I see that it takes a shift-click to get focus initially.
W/ the Lenience switch however, i'd see the bahavior you saw instead.

< ClickToFocus is *really* not supported for xview windows.  You
< should rather use NeverFocus.

...and indeed it works.

Thanx

BTW, any chanv
ce of windowlist going to a user=specified menu format instead
of canned format switches?

For instance, i editted my windowlist.c to be the equivalent of...

%h  %i %p %c %n

h - hotkey
i - iconic (iconic ? "I" : " ")
p - page
c - class
n - name
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked]
Date: Sat, 30 Nov 2002 00:21:36 +0100

> W/ the Lenience switch however, i'd see the bahavior you saw instead.

No way.  I don't see what you describe, with or without lenience.
Maybe it's something in your xview libraries (?).

> BTW, any chance of windowlist going to a user=specified menu
> format instead of canned format switches?
> 

There is some work going on with the new FvwmWindowLister module.
Personally I hope it will replace the whole WindowList command one
day.  It is a perl script and thus extensible much more easily.
Hopefully it will provide a much more flexible interface than
WindowList does now.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]