Subject: CVS domivogt: * Fix for compilation without stroke. FYI: Variables declared with the

From: FVWM CVS <[email-masked]>
Date: Fri, 29 Nov 2002 06:50:42 -0600

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	02/11/29 06:50:42

Modified files:
	.              : ChangeLog 
	fvwm           : bindings.c 

Log message:
* Fix for compilation without stroke.  FYI:  Variables declared with the
STROKE_CODE macro must be declared last.  Without STROKE defined,

STROKE_CODE(int i);
int j;

becomes

;
int j;

This does not compile because its a declaration after a code statement.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 29 Nov 2002 14:06:30 +0000

> This does not compile because its a declaration after a code statement.

I think a more clean/correct form is:

  STROKE_CODE(int i;)

Then the order does not matter.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 29 Nov 2002 15:16:09 +0100

> Then the order does not matter.

Yes, but then it's not indented correctly.

Bye

Dominik ^_^  ^_^