Subject: Key vs PointerKey was: CVS domivogt: * Fixed key bindings w/ "A"ny context and Gnome panel / OpenOffice.

From: David Fries <[email-masked]>
Date: Tue, 12 Nov 2002 17:43:46 -0600

The side effect I'm seeing to this patch is the Key command is now
PointerKey.  I'm using sloppy focus and without the patch if my cursor
is over the root desktop and a window is in focus the key action
immediately affects the focused window, with the patch it askes me for
a window to click on.

Possibly there is some other solution to the problem without this
adverse side effect?

Index: bindings.c
===================================================================
RCS file: /home/cvs/fvwm/fvwm/fvwm/bindings.c,v
retrieving revision 1.76
retrieving revision 1.77
diff -u -r1.76 -r1.77
--- bindings.c  2002/10/21 11:10:40     1.76
+++ bindings.c  2002/10/30 23:45:23     1.77
@@ -106,7 +106,8 @@
        {       
                return;
        }
-       if (do_grab_root)
+       if (do_grab_root ||
+           (binding->type == KEY_BINDING && binding->Context == C_ALL))
        {       
                /* necessary for key bindings that work over unfocused windows
                 */

On Wed, Oct 30, 2002 at 05:45:23PM -0600, FVWM CVS wrote:
> CVSROOT:	/home/cvs/fvwm
> Module name:	fvwm
> Changes by:	domivogt	02/10/30 17:45:23
> 
> Modified files:
> 	.              : ChangeLog 
> 	fvwm           : bindings.c 
> 
> Log message:
> * Fixed key bindings w/ "A"ny context and Gnome panel / OpenOffice.
> 
> --
> Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
> To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
> body of a message to [email-masked].
> To report problems, send mail to [email-masked]

-- 
David Fries <[email-masked]>
http://fries.net/~david/pgpkey.txt

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 13 Nov 2002 10:40:24 +0100

> Possibly there is some other solution to the problem without this

Fixed.

To all:  slap me the next time I fiddle with the key/mouse binding
code in the stable brach.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 13 Nov 2002 12:06:09 +0100

> > Possibly there is some other solution to the problem without this

Oops, forgot to commit the patch. Later.

Bye

Dominik ^_^  ^_^

---

From: David Fries <[email-masked]>
Date: Wed, 13 Nov 2002 11:10:37 -0600

Actually I was using the development branch, cvs latest.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 14 Nov 2002 00:30:48 +0100

> Actually I was using the development branch, cvs latest.

I know.  I backported the bug to the stable branch :-P

Bye

Dominik ^_^  ^_^