Subject: re: fix for 2.5.4 xview

From: Elliot Sowadsky <[email-masked]>
Date: Tue, 19 Nov 2002 13:10:33 -0800 (PST)

fvwm-snap-20021119 fixes the xview "Paste/L8 changes focus" problem.

I still needed to make this change to focus.c to make xview take the focus
on a mouse click (clicktofocus).

> change:       if (!FP_IS_LENIENT(FW_FOCUS_POLICY(fw)) && !focus_does_accept_input_focus(fw) &&  sf != NULL && sf->Desk == Scr.CurrentDesk)
>
> to:   if (!FP_IS_LENIENT(FW_FOCUS_POLICY(fw)) && !focus_does_accept_input_focus(fw) && (sf == NULL || sf->Desk == Scr.CurrentDesk))

xview Icons hiding in top corner on Restart also seems to have been cured.

Thanx
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 20 Nov 2002 12:45:43 +0100

> on a mouse click (clicktofocus).

I still need a way to reproduce this.  The descriptions you posted
earlier were too vague.  I need the minimal config for that and
the precise instructions to reproduce it.

Bye

Dominik ^_^  ^_^