Subject: re: fix for 2.5.4 xview

From: Elliot Sowadsky <[email-masked]>
Date: Wed, 20 Nov 2002 10:12:24 -0800 (PST)

<<
I still need a way to reproduce this.  The descriptions you posted
earlier were too vague.  I need the minimal config for that and
the precise instructions to reproduce it.

After a Restart, clicking into an xview window, the window wont take focus.
Holding down shift will allow cview to take focus and things will work after that till some other event operation (including Restart) causes it to break again.

ImagePath          /home/elliot/bin/pixmaps

Style * ClickToFocus

AddToFunc StartFunction
+	I Exec xsetroot -solid #b15a27
+	I Module FvwmPager 0 0
+	I Module FvwmEvent

AddToFunc InitFunction
+	I	exec exec bin/start mailtool winmenu console
+	I	exec exec /usr/openwin/bin/cm

AddToFunc Clk-Dclk-HldMv
+	C $0
+	D $1
+	H $2
+	M $2

AddToFunc Clk-Hld-Mv
+	C $0
+	H $1
+	M $2

AddToFunc Op_Raise
+	I $0
+	I Raise

ExecUseShell /usr/bin/csh

AddToMenu Applications Applications Title
+	"$$ left"	Exec exec csh -f bin/xep left
+	"$$ right"	Exec exec csh -f bin/xep right
+	textk		Exec exec csh -f bin/xep textk

AddToMenu Quit-Verify "Really Quit Fvwm?" Title
+	"Yes, Really Quit" Quit
+	 Restart Restart
+	"Restart Fvwm253"    Restart /home/elliot_local/fvwma253/bin/fvwm
+	"Restart Fvwm254"    Restart /home/elliot_local/fvwm-2.5.4/bin/fvwm

AddToMenu Utilities Utilities Title
+	"Exit Fvwm" Popup Quit-Verify

AddToMenu WindowOps WindowOps Title

AddToMenu Ops "Root Operations" Title

AddToMenu "WindowOps2" "Move"  Clk-Dclk-HldMv Raise RaiseLower "Op_Raise Move"

AddToFunc window_ops_func 
+	C PopUp WindowOps2
+	M PopUp WindowOps2

Mouse 1         R	N       Clk-Hld-Mv Nop "Menu Applications" Nop
Mouse 2		R	N       Popup Utilities
Mouse 2		R	C	Popup WindowOps
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked]
Date: Fri, 29 Nov 2002 20:41:40 +0100

On Wed, Nov 20, 2002 at 10:12:24AM -0800, Elliot Sowadsky wrote:
> Holding down shift will allow cview to take focus and things will work
> after that till some other event operation (including Restart) causes it
> to break again.

I don't have cview.  Does that happen with textedit too?

I can see that if the pointer is over the window after a restart,
it does not take the focus upon the first click but only on the
second one.  Is that your problem?  If not, I need *precise*
instructions.  The instructions are still too vague.  I need step
by step instructions:  when and how are applications created (from
a menu, a shell, ...) where are they placed (do they overlap),
which window is above which, which window has the focus when you
restart, how you restart (the precise command of menu entry),
where the pointer is when you restart and where it is when the
windows get decorated.

> Style * ClickToFocus

ClickToFocus is *really* not supported for xview windows.  You
should rather use NeverFocus for them, e.g.

  Style textedit NeverFocus

The one problem I see goes away when using NeverFocus.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]