Subject: transparent pager glitch, maybe?

From: Denis Perelyubskiy <[email-masked]>
Date: Wed, 23 Oct 2002 12:25:13 -0700

Hello,

when I start my pager, my page backgrounds are all black,
when I really want them to be transparent.

however, it takes either switching pages, or even
ctrl-alt-f1 (switch to console) and back and the backgrounds
turn back into transparent ones.

   finch:~ $ local/fvwm-2.5/bin/fvwm2 --version
   fvwm 2.5.4 (from cvs) compiled on Oct 20 2002 at 00:42:44
   with support for: ReadLine, XPM, PNG, GNOME WM hints, EWMH
   hints, Shape, SM, Xinerama, XFT

I think all the relevant info is below... please let me know
if I'd missed something

.fvwm2rc:

# --------------------------------------------------------------------
Style FvwmPager     Sticky, StaysOnTop, Handles, HandleWidth 1, NoTitle 
Style FvwmPager     WindowListSkip
# parental relativity must be defined for pager to be
# transparent
Style FvwmPager     ParentalRelativity
Style FvwmPager     UsePPosition, UseUSPosition
# --------------------------------------------------------------------
*FvwmPager: Rows            1
*FvwmPager: Columns         1
*FvwmPager: NoStartIconic
*FvwmPager: Font            none
*FvwmPager: Geometry        259x45+134+0
*FvwmPager: SmallFont -*-times-medium-r-*-*-*-80-*-*-*-*-*-*
*FvwmPager: SolidSeparators
*FvwmPager: Balloons            All
*FvwmPager: BalloonYOffset      +2
*FvwmPager: BalloonBorderWidth  2
*FvwmPager: UseSkipList
# inactive/active window colors
*FvwmPager: WindowColorsets 5 6
# # this is how we hilight active in the pager
*FvwmPager: HilightColorset * 7
# # this is how we hilight baloons
*FvwmPager: BalloonColorset * 8
# # this is how all non-active desks are hilighted
*FvwmPager: Colorset * 9
# --------------------------------------------------------------------
# inactive windows
Colorset 5 fg white, bg #6e5b52, Plain, NoShape
# active windows
Colorset 6 fg NavajoWhite, bg #475293, VGradient 50 #6068DB #475293, NoShape
# desk hilighting (active)
Colorset 7 fg grey70, bg #475293, Plain, NoShape
# baloons in the pager
Colorset 8 fg NavajoWhite, bg Brown, Plain, NoShape
# desk hilighting (inactive)
Colorset 9 fg White, bg Brown, NoShape, Transparent

denis

-- 
// mailto: Denis Perelyubskiy <[email-masked]>
// icq   : 12359698
// PGP   : http://www.cs.ucla.edu/~denisp/files/pgp.asc
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 24 Oct 2002 06:41:17 +0200

> I think all the relevant info is below... please let me know

Is this problem new? In a message of the 20 october you say
that your transparent pager works as expected (after you add
the ParentalRelativity Style).

Regards, Olivier

---

From: Denis Perelyubskiy <[email-masked]>
Date: Wed, 23 Oct 2002 23:39:27 -0700

Hello, Olivier.

  >the ParentalRelativity Style).

I haven't noticed the problem at that time, but that does
not mean much. I might've been so happy to get a transparent
pager that I did not pay enough attention.

I am attaching a small .fvwm2rc with which I can
reproduce this problem.

Note, that the problem goes away if I restart fvwm. It only
appears to be there when fvwm2 starts for the first time.

denis

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 27 Oct 2002 19:15:51 +0100

> appears to be there when fvwm2 starts for the first time.

Is it possible that a different executable is started initially
than upon a restart?  Is $PATH the same on the console and within
a running fvwm?

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Denis Perelyubskiy <[email-masked]>
Date: Sun, 27 Oct 2002 12:46:04 -0800

* <[email-masked]> [27-Oct-02 10:14 -0800]:
  >Is it possible that a different executable is started
  >initially than upon a restart?  Is $PATH the same on the
  >console and within a running fvwm?

The path is the same, yes. However, I just went to try it
again, and I dont see the problem anymore. Sorry for wasting
your time. If I can track it down to the point where it is
reproducible every time again, I'll let you guys know.

thanks,

denis