Subject: CVS migo: * new WindowList option SortByResource

From: FVWM CVS <[email-masked]>
Date: Thu, 24 Oct 2002 02:21:44 -0500

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	migo	02/10/24 02:21:44

Modified files:
	.              : AUTHORS ChangeLog NEWS 
	docs           : ANNOUNCE COMMANDS FAQ ChangeLog 
	fvwm           : builtins.c fvwm.1.in style.c windowlist.c 
	libs           : FlocaleCharset.c 

Log message:
* new WindowList option SortByResource
* style.c, FlocaleCharset.c: fixed gcc warning
* AUTHORS: place recent authors to the top, not the bottom
* builtins.c: corrected typo in error message
* FAQ: reworded 6.7 question; added info to the 5.5 and 6.6 answers
* COMMANDS: list two new commands NoWindow and PrintInfo

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 24 Oct 2002 07:57:24 +0000

> * style.c, FlocaleCharset.c: fixed gcc warning

Actually, both of these seem more like bugs, than warnings.
Anyway, to be totally sure, in style.c I changed:

        if (FMiniIconsSupported && ret_style->change_mask.has_mini_icon ||
            S_DO_EWMH_MINI_ICON_OVERRIDE(SCC(*ret_style)))

to a not equivalent:

        if (FMiniIconsSupported && (ret_style->change_mask.has_mini_icon ||
            S_DO_EWMH_MINI_ICON_OVERRIDE(SCC(*ret_style))))

Regards,
Mikhael.