Subject: Menu colors are wrong

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 28 Oct 2002 18:58:53 +0000

Here is one more problem. I think, colors of almost everyone's menus
should be wrong.

1) Start fvwm without config. Open FvwmConsole.

  Style * Hilight3DThickness 3, HilightBack darkgreen

(Hilight3DThickness is just to make it more visual.)
Notice how gray shadows are used for active menu item instead green.

There is same problem if colorsets are used, the shadows for active menu
item are taken from MenuColorset and not from ActiveColorset.

2) Now, one more bug that is only visible without colorsets:

  Style * Background red

Menus are still gray, not red! Although red shadows are used everywhere.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 28 Oct 2002 20:50:04 +0100

>   Style * Hilight3DThickness 3, HilightBack darkgreen

  MenuStyle * Hilight3DThickness 3, HilightBack darkgreen

> Notice how gray shadows are used for active menu item instead green.

I think it always worked this way.  I didn't want to change that
with my latest menu changes because the feature is available
through colour sets.  I didn't want to add features that are
removed in 3.0 anyway.

> item are taken from MenuColorset and not from ActiveColorset.

Use

  MenuStyle * HilightRelief

to activate that.  It's not the default for backward
compatibility.

> 2) Now, one more bug that is only visible without colorsets:

  MenuStyle * Background red

> Menus are still gray, not red! Although red shadows are used everywhere.

Fixed.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 28 Oct 2002 20:40:32 +0000

> to activate that.  It's not the default for backward

Well, not quite. Without colorsets HilightRelief was off (I think it is a
bug that should be fixed) and with colorsets HilightRelief was on.

For example with any released 2.4.x >= 2.4.8 try this without any config:

  FvwmTheme
  Colorset 5 bg gray
  Colorset 6 bg darkgreen
  MenuStyle * MenuColorset 5, ActiveColorset 6
  MenuStyle * HilightBack  # this command is fully optional
 
I think a new option HilightRelief is redundant, it should always be
HilightRelief just like it was always with colorsets. IMHO, it's good to
correct this bug when wrong shadow colors were used without colorsets.
I am all for configurability, but having !HilightRelief is simply wrong.
What do you think?

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 29 Oct 2002 09:24:33 +0100

> I am all for configurability, but having !HilightRelief is simply wrong.

I had to introduce HilightRelief so that you can still have the
old behaviour.  But it's probably not critical at att.  What might
annoy the users more is that with HilightBack the title string is
not drawn hilighted anymore.

Bye

Dominik ^_^  ^_^