Subject: CVS domivogt: * Fixed binding problem with window context.

From: FVWM CVS <[email-masked]>
Date: Mon, 14 Oct 2002 06:19:12 -0500

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	02/10/14 06:19:12

Modified files:
	.              : ChangeLog 
	fvwm           : add_window.c bindings.c events.c focus.c 

Log message:
* Fixed binding problem with window context.
* Fixed stroke bindings not grabbing the buttons with window context.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 15 Oct 2002 18:52:27 +0000

> * Fixed stroke bindings not grabbing the buttons with window context.

After this commit the following my bindings do not work inside a window:

  Silent Mouse 6 A A ThisWindow Raise
  Silent Mouse 7 A A ThisWindow FourStateMachine RaiseLower
  Silent Mouse 8 A A ThisWindow MaximizeFullScreen
  Silent Mouse 8 WTFS S ThisWindow Move
  Silent Mouse 8 R S Menu MenuFvwmRoot

I would like my thumb button (8) and the second wheel (6, 7) to work as
they did before this commit. Note, no complex functions here, just press.

To emulate this hardware, you may execute: xmodmap -e "pointer = 1 6 8"

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 16 Oct 2002 10:23:31 +0200

> To emulate this hardware, you may execute: xmodmap -e "pointer = 1 6 8"

That worked without modifying defaults.h?  Let me think...

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 16 Oct 2002 10:40:25 +0200

> That worked without modifying defaults.h?  Let me think...

Does it work better now?

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 16 Oct 2002 15:14:20 +0000

> > That worked without modifying defaults.h?  Let me think...

I don't see a difference. I.e. these bindings are still sent to a window.
They always worked and work now on decorations.

On an other side, this does not work as advertised either:

  All (!CirculateHit) FvwmIdent

And I tested several times that I use the latest cvs.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 16 Oct 2002 17:54:25 +0200

> They always worked and work now on decorations.

Can you put a debug statement in __focus_grab_buttons() and check
which buttons are grabbed at which time and print out the value
of Scr.buttons2grab?

>   All (!CirculateHit) FvwmIdent

Fixed.

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 18 Oct 2002 16:21:18 +0000

On 16 Oct 2002 17:54:25 +0200, Dominik Vogt wrote:
> > > > > I would like my thumb button (8) and the second wheel (6, 7) to
> > > > > work as they did before this commit. Note, no complex functions
> > > > > here, just press.
> > > > > 

I always see Scr.buttons2grab=31 regardless of what I press.
So the last "if" is rarelly entered.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 21 Oct 2002 13:12:37 +0200

> So the last "if" is rarelly entered.

Fixed.  It was a problem in the code unbinding old bindings.  The
bug wasn't new, but was brought to the surface more often now.

Bye

Dominik ^_^  ^_^