Subject: Notification: incoming/933

From: [email-masked]
Date: Thu, 03 Oct 2002 11:14:41 -0500

FVWM Bug Tracking notification

new message incoming/933

Message summary for PR#933
	From: [email-masked]
	Subject: Bizarre behaviour with RelieveRectangle
	Date: Thu, 03 Oct 2002 11:14:38 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Thu Oct 03 11:14:41 2002
From: [email-masked]
To: [email-masked]
Subject: Bizarre behaviour with RelieveRectangle
Date: Thu, 03 Oct 2002 11:14:38 -0500

Full_Name: Beat Müller
Version: 2.4.11
CVS_Date: 
OS: Solaris 7
X_Server: Xsun
Submission from: (NULL) (129.132.29.7)

When I start fvwm these error messages show up, about 2 to 4 in a row:
   RelieveRectangle: called with w = 7, h = -1

Then I patched do_relieve_rectangle in Graphic.c so that it shows 
more info:
   RelieveRectangle: called with w = 7, h = -1, x = 0, y = 0

This didn't ptovide the necessary information because I have no object
in the (0, 0)-corner. I am puzzled...

I don't know where RelieveRectangle is called in this case, but according
to the sources RelieveRectangle and RelieveRectangle2 are used quite
often. In that stage it is not of great use to add my .fvwm2rc here,
but if you can give me some pointers how to track down the calling
module.

Cheers
Beat

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 6 Oct 2002 00:32:46 +0200

> but if you can give me some pointers how to track down the calling

You can ignore these messages for now.  I added them a while back
to catch bugs, but ironing out the places that call
RelieveRectangle with the incorrect height or width proved way too
difficult.  I will remove the message.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]