Subject: perllib compile error

From: Tim Freedom <[email-masked]>
Date: Fri, 25 Oct 2002 10:57:33 -0700 (PDT)

I've seen this on the past few snapshots,

make[4]: Entering directory `/home/tf/download/fvwm-snap-20021025/perllib/FVWM'
cd ../.. && CONFIG_FILES=perllib/FVWM/Module.pm CONFIG_HEADERS= /bin/sh
./config.status
creating perllib/FVWM/Module.pm
make[4]: *** No rule to make target `EventNames.pm', needed by `all-am'.  Stop.
make[4]: Leaving directory `/home/tf/download/fvwm-snap-20021025/perllib/FVWM'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/tf/download/fvwm-snap-20021025/perllib/FVWM'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/tf/download/fvwm-snap-20021025/perllib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/tf/download/fvwm-snap-20021025'
make: *** [all-recursive-am] Error 2

Thanks (please CC)

__________________________________________________
Do you Yahoo!?
Y! Web Hosting - Let the expert host your web site
http://webhosting.yahoo.com/
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 25 Oct 2002 22:38:36 +0000

> make: *** [all-recursive-am] Error 2

I think I fixed this, it should be in the next snapshot.

It seems that all snapshots since 2002/09/13 have this problem.
I have no idea how noone reported this. Probably everyone uses cvs?

I think we should add a "make; make install prefix=./tmp-root" test on the
resulting snapshot before releasing a snapshot.

I also don't see in the snapshots a patch we spoke about a month ago that
replaces VERSIONINFO in configure.in with " (snap-20021026)".
Jason, can you please add this patch? I may resend the exact perl command.

Please also think again about the idea of running utils/create_snap.sh,
so we may edit it as needed without asking you to change anything.

Regards,
Mikhael.