Subject: FvwmProxy 0.91 ready for CVS

From: [email-masked]
Date: Mon, 28 Oct 2002 22:49:02 -0800

I've posted my updated FvwmProxy on freshmeat.  Note the 2.5 patch,
fixed desk switching, Alt-Tab functionality, and no more crashes.

If everyone feels it's ready, we can hook it into the CVS tree.

Just have your lawyers fax me their NDA forms and I send it through
my IP legal team.  Oh, wrong job.

I'm still trying to figure out how to catch an Alt release in the .fvwm2rc
file to match 'Key Alt_L A N' for the press.  Then I could get rid of the
key polling.  Anybody got any ideas?

-- 
  _
 ( \      _  \    /_ /  _ _  Jason Weber                  (503) 380-7424
  \|(\/)()))  \/\/(-/_)(-/(  Infinite Monkeys Inc.        Aloha, Oregon
  //                         http://www.imonk.com/baboon  [email-masked]
 (/     [email-masked]        [email-masked]

     "Canister contains at least 50% recycled material; 15%
      post-consumer content."
   -- Pringles Fat-Free (side of can)
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 29 Oct 2002 10:47:37 +0100

> If everyone feels it's ready, we can hook it into the CVS tree.

Done.  I had do do some work on it first:

  - Removed C++ style comments

      Comments with "//" are not allowed by ANSI C.  Some
      compilers might not be able to compile it.

  - Fixed a few compile errors and warnings

      This is not allowed in C:

        {
          int x;
          x = 1;
          int y;
        }

      Declarations must be at the beginning of a block.
        
  - Split AdjustWindows() into two functions to reduce the levels
    of indentation

  - Include the standard fvwm include files.

        #include "config.h"

      must always the first file to be included.

  - Removed ConfigFvwmProxy

      Once colour set support is added it should just default to
      using colour set 0 and the colour related options can be
      removed.

[snip]

> key polling.  Anybody got any ideas?

Remove the key invocation code from the module and let fvwm do it
via the remote control interface.  There are plans to add a
command that triggers actions when a key is released, not pressed.

I think, ideally FvwmProxy would just provide the graphical
interface and let fvwm open or close it.  I'll take a closer look
later.

Oh, and you should contact Jason ( [email-masked] ) for write
access to the CVS repository.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 29 Oct 2002 12:25:56 +0000

>       Declarations must be at the beginning of a block.

I think this is already valid in C as stated in the ISO/IES 9899:1999
standard. :) I don't know which compilers except for gcc support it.

Now, a different issue.

How about renaming this module to something that is more intuitive?
I may think about FvwmProxyWindows, FvwmWindowMarks, FvwmIndicators.
I am sure you may find a better name.

Regards,
Mikhael.

---

From: "Paul Smith" <[email-masked]>
Date: 29 Oct 2002 10:38:08 -0500

%% Dominik Vogt <[email-masked]> writes:

  dv>   - Removed C++ style comments

  dv>       This is not allowed in C:

  dv>         {
  dv>           int x;
  dv>           x = 1;
  dv>           int y;
  dv>         }

Just a pedantic note; both of the above _are_ legal in C, as of the ISO
1999 standard.  However, I agree with Dominik that we should avoid them
in FVWM as compilers that support this syntax are still not ubiquitous.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]> HASMAT--HA Software Mthds & Tools
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 29 Oct 2002 17:04:22 +0100

> in FVWM as compilers that support this syntax are still not ubiquitous.

It's not a theoretic problem.  gcc (2.95.4) simply refuses to
compile the following test program.  Otherwise I would never have
noticed it.

----------------------- foo.c -----------------------
int main(void)
{
        int x;
        x = 1;
        int y;
        y = 1;

        return 0;
}
-----------------------------------------------------

  $ gcc -o foo foo.c
  foo.c: In function `main':
  foo.c:5: parse error before `int'
  foo.c:6: `y' undeclared (first use in this function)

Anyway, since we are concerned about protability we can just
forget about the 1999 "standard" and stick with the old draft.

Bye

Dominik ^_^  ^_^

---

From: Dan Espen <[email-masked]>
Date: Tue, 29 Oct 2002 11:11:41 -0500

> ----------------------- foo.c -----------------------

It doesn't compile on Solaris (Forte 6.2),
HPUX 11.11
or AIX 5.1
either.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: [email-masked]
Date: Tue, 29 Oct 2002 22:32:53 -0800

On Tue, Oct 29, 2002 at 12:25:56PM +0000, Mikhael Goikhman wrote:
> [...]

If its confusing that it might, say, route packets to other
managers or be used to visualize your firewall, I can be flexible.

To be consistant with existing modules, how about FvwmWinProxy?
Just so I don't have to change the dozens of instances of the
word 'proxy' in the source.

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 30 Oct 2002 09:08:27 +0000

> managers or be used to visualize your firewall, I can be flexible.

This was my first association. I also thought about something similar to
FvwmCommandS. I needed to look at the code and configuration to figure out
what it really does.

> word 'proxy' in the source.

FvwmWinProxy is fine with me although I myself would probably use plural.

Actually, the only module to be consistent with (FvwmWinList) together
with FvwmIconMan and FvwmTaskBar is likely to be replaced/united in the
long run. I suggested either FvwmWindowList (better, because this is a
new name) or FvwmWinList for such super window list modules.

So, please throw the final name.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 30 Oct 2002 11:27:14 +0100

> So, please throw the final name.

Some suggestions:

  FvwmMiniWindows
  FvwmLabels
  FvwmWinBanners

Bye

Dominik ^_^  ^_^