Subject: xpm sizes in windowlist

From: Denis Perelyubskiy <[email-masked]>
Date: Wed, 23 Oct 2002 13:30:48 -0700

Hello,

   fvwm 2.5.4 (from cvs) compiled on Oct 20 2002 at 00:42:44

I recall seeing someone state that there was a way to set
sizes of xpm icons in windowlist in 2.5.x versions.

Sorry, I can't seem to find the reference to this in the
archives , or in the manpages (presumably because I dont
quite know what I am looking for)

thanks,

denis

-- 
// Denis Perelyubskiy <[email-masked]>
// Software Engineer, NOMADIX Inc
// Phone: (818) 575 - 2462
// Fax  : (818) 597 - 1502
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Marcus Lundblad <[email-masked]>
Date: Wed, 23 Oct 2002 22:35:54 +0200 (CEST)

> quite know what I am looking for)

for example:
Style * IconSize 87 65

However, this doesn't resize the xpm:s. It pads the icons (for smaller
icons, more surrounding transparency) and crops (for bigger icons)

(Maybe I missed something though...)

//Marcus

---

From: Marcus Lundblad <[email-masked]>
Date: Wed, 23 Oct 2002 22:41:48 +0200 (CEST)

> icons, more surrounding transparency) and crops (for bigger icons)

Oops, maybe I should read the messages BEFORE replying... ofcourse
IconSize refers to ordinary icons...

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 23 Oct 2002 22:17:47 +0000

> sizes of xpm icons in windowlist in 2.5.x versions.

Can you be more specific? Do you mean switching sizes of mini application
icons used in WindowList (say, from 16x16 to 20x20) without redefining
new MiniIcon for all apps? If so, there is no such functionality except
for using wm-icons.

If you mean to control a vertical and horizontal space used in WindowList
items, this may be done using MenuStyle in 2.4.x+.

With wm-icons you may execute something like:

  wm-icons-config -p -f mini 16x16-gnome
  wm-icons-config -p -f mini 16x16-kde
  wm-icons-config -p -f mini 21x18-3dpixmaps
  wm-icons-config -p -f mini 22x22-aquafusion  # this requires cvs

Similarly you may change the icon set used for "norm" and "menu" icons.

Regards,
Mikhael.

---

From: Denis Perelyubskiy <[email-masked]>
Date: Wed, 23 Oct 2002 17:52:14 -0700

* <[email-masked]> [23-Oct-02 15:18 -0700]:
  >Can you be more specific? Do you mean switching sizes of
  >mini application icons used in WindowList (say, from
  >16x16 to 20x20) without redefining new MiniIcon for all
  >apps? If so, there is no such functionality except for
  >using wm-icons.
  >
  >If you mean to control a vertical and horizontal space
  >used in WindowList items, this may be done using
  >MenuStyle in 2.4.x+.
  >

I guess I was asking whether it was possible to scale icons
shown in the windowlist. For example, if I say that a
MiniIcon is myicon.xpm, but it happens to be 40x40, I wanted
to specify a maximum height, so that all images shown in
windowList were, say, 32 x 32. However, it seems that I will
be happy with wm-icons. I was not aware of their existence
before. My problem was that my xpms were not really all that
uniform :-)

thanks,

denis

-- 
// mailto: Denis Perelyubskiy <[email-masked]>
// icq   : 12359698
// PGP   : http://www.cs.ucla.edu/~denisp/files/pgp.asc
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]