Subject: FvwmPager incorrectly draws StayOnBottom windows

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 25 Oct 2002 09:59:02 +0000

I don't think it is a new probelem. It was reported (and confirmed by me)
on the xvirtualroot thread on another mailing list.

It seems that FvwmPager when draws a window, that is on a layer below
of other windows, initially draws such window *above* all windows.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 25 Oct 2002 13:20:03 +0200

> of other windows, initially draws such window *above* all windows.

Looks like FvwmPager completely ignores the initial stacking
information for the new window.  The same happens for
"StartsLowered" and I wouldn't be surprised if it treated all
layers the same.  I saw that in the past repeatedly, but could
never pin it down.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 26 Oct 2002 14:02:32 +0200

> of other windows, initially draws such window *above* all windows.

Fixed.  The problem is that numerous packets are sent to the
modules in AddWindow() before the initial M_ADD_WINDOW is sent.
This should all be cleaned up so that M_ADD_WINDOW is really the
first packet that the modules receive for a certain window.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]