Subject: Re: new release

From: Dominik Vogt <[email-masked]>
Date: Fri, 25 Oct 2002 10:05:31 +0200

(moved thread to fvwm-workers)

On Thu, Oct 24, 2002 at 01:32:30AM +0000, Mikhael Goikhman wrote:
> On 24 Oct 2002 02:51:13 +0200, Dominik Vogt wrote:
> > 
> > Why such an effort for a release marked as "experimental
> > unstable"?  Things will stabilize much faster with an early
> > release.
> 
> If someone wants an experimental unstable, he already may use daily
> snapshots or cvs. I would like to have 2.5.4 to be a hihger quolity than
> daily snapshots. Another reason is that I want to base an experimental
> fvwm-themes-0.7.0 on fvwm-2.5.4 later.

In my eyes, releases during the development phase are solely a
matter of convenience for the users and developers.  More people
download, install and test a tarball than a snapshot or cvs.

During the 2.4 development phase, I tried to make a release once a
month, just to have a fairly recent release.  THe only reason was
to not get bug reports for a release that is already 3 months old.

> If there will be no potentially problematic changes in a day or two,
> 2.5.4 will be released on the weekend.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 25 Oct 2002 09:48:46 +0000

> download, install and test a tarball than a snapshot or cvs.

I wrote an answer, but I removed it, because I just discovered stack bugs
that should be fixed before 2.5.4 (or at least you decide whether they
should be fixed).

> to not get bug reports for a release that is already 3 months old.

I have no problems if you release 2.5.x every month.
I just need some good release from time to time to base on it,
so I may sometimes ask to slow down for some days.

> > 2.5.4 will be released on the weekend.

I would say, after the recent stack fixes are fixed.

And after someone adds a --retain option to fvwm-root.
Cameron, Olivier or maybe me (I have no idea yet, but I can try cvs diff).

Regards,
Mikhael.

---

From: Cameron Simpson <[email-masked]>
Date: Tue, 29 Oct 2002 17:59:28 +1100

On 09:48 25 Oct 2002, Mikhael Goikhman <[email-masked]> wrote:
| > > If there will be no potentially problematic changes in a day or two,
| > > 2.5.4 will be released on the weekend.
| 
| I would say, after the recent stack fixes are fixed.
| 
| And after someone adds a --retain option to fvwm-root.
| Cameron, Olivier or maybe me (I have no idea yet, but I can try cvs diff).

The --retain-pixmap in fvwm-root is my chore. If you want to get 2.5.4
our the door please don't wait for me. The job is small, but may not be
ready until after the weekend.

My apologies.
-- 
Cameron Simpson, DoD#743        [email-masked]    http://www.zip.com.au/~cs/

I think there is a world market for maybe five computers.
      --Thomas Watson, chairman of IBM, 1943
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 29 Oct 2002 09:05:45 +0000

> ready until after the weekend.

Don't worry, it is already done by Olivier and it is in cvs.

I am happy now to release 2.5.4.

By the way, FvwmProxy will not be part of it.

Regards,
Mikhael.