Subject: WindowList bug

From: "S. Anderson" <[email-masked]>
Date: Fri, 11 Oct 2002 14:10:38 -0600

Hi, 
Im using fvwm cvs, updated Oct 11 2002. (today)

I found a bug in fvwm's WindowList, I think its been there for a while,
but I have just recently been able to reproduce it.

Start fvwm with this in your fvwm2rc:

Mouse 0 4 A Iconify
Mouse 0 I A Iconify
Mouse 3 R A WindowList
AddToFunc InitFunction
+ I Exec xterm
+ I Exec xterm
+ I Exec xterm

1) Iconify all three xterms,
2  Pass your mouse over one of the icon titles to focus it.
3) Go back to the root window and press button 3 for the WindowList

Notice The top entry in the WindowList, it gets messed up.
looks like:

Desk: 0         Geometry
-------------------------
0. sa@g: ~     (
1. sa@g: ~     (+00(4):80x24+0+346)
etc...

if you start a 4th xterm and give it focus, and then pop up the 
WindowList, the geometry is displayed correctly.

hth,
sa
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 12 Oct 2002 09:28:18 +0200

> Notice The top entry in the WindowList, it gets messed up.

Fixed.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]