Subject: Re: FVWM: Re: Colormap issues

From: Olivier Chapuis <[email-masked]>
Date: Wed, 9 Oct 2002 11:49:49 +0200

On Thu, Oct 03, 2002 at 02:02:33PM -0400, Dan Espen wrote:
> Olivier Chapuis <[email-masked]> writes:
> > On Thu, Oct 03, 2002 at 11:03:27AM +0200, Olivier Chapuis wrote:
> > > On Wed, Oct 02, 2002 at 05:41:44PM -0700, Tim Freedom wrote:
> > > 
> > > > And in the "XV Controls" window it notes using "24-bit mode. Using TrueCo
> > lor
> > > > visual" meaning the solaris Xserver (Xsun) is capable of 24-bit.  So I as
> > ked
> > > > a sys-admin friend and he noted that "xdpyinfo is probably unable to
> > > > understand 8+24 mode and is simply returning the first result it sees whe
> > n
> > > > multiple options are available."  So I'm not sure how fvwm determines wha
> > t
> > > > the X-server is capable of, but its figuring them to be 8-bit on this
> > > > machine when they really need to be 24-bit (is it grabbing xdpyinfo's
> > > > output ?).  Anything I can do to make fvwm resolve to 24-bit short of
> > > > restarting the server with that depth setting explicitly (meaning I'd
> > > > have to call the powers that be to change the configuration on this
> > > > machine - after a million+1 questions) ?  What do other window managers
> > > > (like CDE) do to resolve this ?
> > > 
> > > If you start fvwm without -visual{Id} it asks the server for the
> > > default visual and use it (I do not think that fvwm is broken here; it
> > > does not grep xdpyinfo, it uses the X library).
> > 
> > In fact I do not know what we should do with a card with 2 depths
> > for a given visual. I found nothing in the X lib (or in the Xevi
> > extension) for such a situation. I imagine that there is an X extension
> > to deal with this situation and we should use it to choose the desired
> > depth.
> 
> Why shouldn't the Fvwm command line arg work as advertised?
>

Ok, I think that I finally understand the situation. There is no
visual with two depths of course. The card has two hardware colormaps
and so it can has two installed colormap at once. I think that we can
detect this situation at fvwm startup and select the best visual
(if the -visual{ID} is not use).

- Call XListInstalledColormap, if we have only one cmap we have
nothing to do (just use the default visual).
- If we have 2 or more cmap choose the best one, found the associated
visual and use it.

The question is: should we use the best cmap/visual by default or
always use the default cmap/visual?

Olivier 
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 09 Oct 2002 07:30:02 -0400

Olivier Chapuis <[email-masked]> writes:
> and so it can has two installed colormap at once.

Yes, the card can support two visible colormaps at once.

> I think that we can

I've heard that some Sun systems can be noticably slow at higher
depths.

I think automatic selection of the best depth rather than
the default depth would be a good feature.

The user might still want to override that at the command line.

-- 
Dan Espen                           E-mail: [email-masked]