Subject: funny bitfield lengths in colorset_struct?

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Oct 2002 00:42:28 +0200

I don't understand some of the bit field sized of some members of
the colorset_struct.  Specifically:

  unsigned int fg_alpha : 7;
  unsigned int icon_alpha : 12;

What are these?  Are they pixel values?  Then they have to use the
"Pixel" type.  In any case, 7 or 12 bits seem very wrong to me.
In any case, the names are not descriptive enough.

  unsigned int tint_percent : 12;
  unsigned int icon_tint_percent : 12;

Percentages with 12 bit resolution?  I'd guess we nee 7 bits here.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 22 Oct 2002 08:01:56 +0200

> Percentages with 12 bit resolution?  I'd guess we nee 7 bits here.

Yes we should do:
	/fg_alpha/fg_alpha_percent/
	/icon_alpha/icon_alpha_percent/
and use 7 bits for all the *percent members

Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Oct 2002 11:15:47 +0200

> and use 7 bits for all the *percent members

Done.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]