Subject: CVS migo fvwm-web: * improved screenshot

From: FVWM CVS <[email-masked]>
Date: Wed, 09 Oct 2002 20:10:41 -0500

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm-web
Changes by:	migo	02/10/09 20:10:41

Modified files:
	.              : ChangeLog 
	generated/perllib: FVWM::Constants.html FVWM::Event.html 
	                   FVWM::EventNames.html FVWM::Module.html 
	                   FVWM::Module::Gtk.html FVWM::Module::Tk.html 
	                   General::FileSystem.html General::Parse.html 
	                   index.html perllib2html tutorial.html 
	screenshots    : Mikhael-desk-1280x1024.png 
	                 Mikhael-desk-thumbnail.jpg 
Added files:
	generated/manpages: FvwmGtkDebug.html 

Log message:
* improved screenshot
* regenerated some pages

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Eric Gillespie <[email-masked]>
Date: Thu, 10 Oct 2002 03:39:46 -0500

> * improved screenshot

I grabbed fvwm-themes CVS and ran through all the themes, but
could not find anything matching what's in this screenshot (the
RedmondXP stuff is nice, but didn't include the transparent
menus, for example).  Can you share this config?

Thanks.

--  
Eric Gillespie <*> [email-masked]

Build a fire for a man, and he'll be warm for a day.  Set a man on
fire, and he'll be warm for the rest of his life. -Terry Pratchett
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 11 Oct 2002 00:23:57 +0000

> menus, for example).  Can you share this config?

Transparent (and tinted) menus are very slow, I don't use this on the
daily basis (not that I use any predictable theme on a daily basis).
Hopefully transparent menus could be somehow speeded up, or maybe it is
just my video card and my 350Mhz processor.

Anyway, here are the full instructions:

  * install the latest fvwm-themes cvs
  * load components:
      colors@redmondxp
      modules@redmondxp
      buttons@ice
      color-decors@ice
      windowlook@qnx
      startup-extra@personal (after you created it, see below)
  * load desker from the panel, set it to the left, not the default right
  * optionally enable normal icons from panel (I can't live without them)
  * optionally install the latest wm-icons cvs and execute:
      % wm-icons-config -p -f -q norm 64x64-aquafusion
      % wm-icons-config -p -f -q menu 22x22-aquafusion
      % wm-icons-config -p -f -q mini 22x22-aquafusion
      % wm-icons-config -p -f -q 16x16 16x16-aquafusion

Now create ~/.fvwm/themes/personal/startup-extra that have one function:

DestroyFunc PrepareScreenshot
AddToFunc   PrepareScreenshot
#
# ---- make menus transparent/tinted, and use xft fonts ----
+ I Colorset 5 fg rgb:ff/ff/f0, bg rgb:46/74/9a, fgsh rgb:10/30/40, Transparent
+ I Colorset 6 fgsh rgb:10/30/40
+ I MenuStyle * Font 'shadow=1 r rb b:xft:Luxi Serif:Bold:size=15:minspace=true'
+ I *FvwmIconMan: Font 'shadow=1:xft:Adobe:Bold:size=12:minspace=true'
+ I Style * Font 'shadow=1 r rb b:xft:Luxi Sans:Bold:size=11'
#
# ---- make desker transparent and look specially ----
+ I Colorset 44 fg rgb:ff/ff/c4, Transparent
+ I *FvwmPager-Desker: Colorset * 44
+ I Style FvwmPager-Desker ParentalRelativity
#
+ I Colorset 15 bg rgb:28/58/78, fg rgb:ff/ff/c4
+ I Colorset 45 bg rgb:90/80/b0
+ I Style FvwmPager-Desker BorderColorset 45
+ I Style FvwmPager-Desker BorderWidth 4
#
# ---- set window list colors ----
+ I Colorset 17 IconTint cyan 5
+ I Colorset 18 IconTint yellow 12, fg rgb:ff/ff/b0
+ I Colorset 19 IconTint cyan 5, IconAlpha 73, fgAlpha 70
#
# ---- set iconbox, normal icon colors, border colors
+ I Style "*" IconBox screen w 110 5 -10 -40 p, IconGrid 80 10
+ I Colorset 1 IconAlpha 80, fg white, bg rgb:4a/6a/8c
+ I Colorset 2 IconAlpha 80, fg white, bg rgb:6a/8a/ae
+ I Colorset 3 bg rgb:7c/80/84
+ I Colorset 4 bg rgb:a6/aa/ae
+ I *FvwmPager-Desker: WindowColorsets 3 4
#
# ---- set background ----
+ I Exec exec fvwm-themes-images --sky --sky-colors rgb:1a/1a/1a,rgb:21/48/80,rgb:59/77/a7,rgb:21/54/90 --setroot --pattern-type uniform:1

Now you may either run PrepareScreenshot from FvwmConsole (Alt-F12) or
temporarily add these 2 lines to this startup-extra file (but don't do
this permanently, otherwise other themes will be always overriden by these
hardcoded changes):

  AddToFunc FuncFvwmStartAllHooks I PrepareScreenshot
  AddToFunc FuncFvwmLoadAllHooks I PrepareScreenshot

Load the newly created startup-extra@personal after refreshing themes.
If you don't see what is on the screenshot, don't blame me. :)

Regards,
Mikhael.

---

From: Eric Gillespie <[email-masked]>
Date: Thu, 10 Oct 2002 23:59:42 -0500

Mikhael Goikhman <[email-masked]> writes:

> Transparent (and tinted) menus are very slow, I don't use this
> on the daily basis (not that I use any predictable theme on a
> daily basis).  Hopefully transparent menus could be somehow
> speeded up, or maybe it is just my video card and my 350Mhz
> processor.

Yes, it is slow, but on my 1.2GHz Athlon system it is not
noticeable.  My configuration on this box is quite different from
that on my ancient Pentium 75 Thinkpad :).

> Now create ~/.fvwm/themes/personal/startup-extra that have one function:

These are the parts i wanted to see.  Thanks.

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 11 Oct 2002 12:17:51 +0200

> just my video card and my 350Mhz processor.

To get "fast" Transparent menu you should use:

        Colorset 5 RootTransparent buffer, Tint black 30
                                   ^^^^^^
and use fvwm-root or Esetroot to set the root bg. This can take a lot
of memory: each "buffered" RootTransparent colorset will load a tinted
version of the root pixmap. If the transparency is not buffered the
tinted menu bg is dynamically created/destroyed, so it is "slow".
With Tinted ParentRelative Transparency we should make in addition
a screenshot of the concerned part of the root window, so this is
"very slow".

Olivier

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 11 Oct 2002 21:26:07 +0000

> a screenshot of the concerned part of the root window, so this is

It is faster, thanks. The background now appears almost immediatelly after
some hardly noticable blink (it may be more noticable on other hardware).

Still, it is not fast, you may see how item by item is drawn on the
background. This may be because of tinted menu icons with alpha channel or
xft fonts. I think it is not because of tinted menu icons or xft fonts,
but because of png icons. I don't know what can be done here at least for
non-static background, becuase the icons should be applied to the
background every time a menu is poped up... But maybe there is a way.

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 12 Oct 2002 01:02:21 +0200

> some hardly noticable blink (it may be more noticable on other hardware).

I cannot see such a blinking (I get some blinking with fine gradient).
Do you see the blinking when you popup the menu for the second time
(with a given cset definition)? 

> but because of png icons.

I can reproduce this only with some xft fonts and some shadow. Xft
is slow I do not think we can do something (maybe recent version of
Xft2 is faster).

In fact I can "reproduce" this (without xft but with IconTint and IconAlpha)
when I run my Xserver with --depth 24 (almost not visible even with
very big menu, but I can see something).
However, in depth 24 I've _no_ XAA. Can you run your server with
--depth 16?

> I don't know what can be done here at least for

Yes, I think this the way: do you want to have in memory all the
menus in some pixmaps? Note also that it is not possible (in general)
to draw in a Pixmap with a ParentRelative "bg".

Olivier

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 12 Oct 2002 00:29:25 +0000

> (with a given cset definition)? 

Yes, on every menu popup the bg is visible for short time, try:

  Colorset 5 bg white  # or black

> However, in depth 24 I've _no_ XAA. Can you run your server with

Just started another X, it is faster with depth 16, because gradient is
not really smooth, but not too much.

It's faster with non-xft/non-shadow, but still blinks.

Now, problems. When I returned to my X with depth 24, the tinted
background image from another X was used in menus. How is it possible?
Are atoms shared among X's?

Another problem (unrelated) is that I always got

  [FVWM][NewMenuStyle]: <<ERROR>> menu style * is in use

so I was not be able to change the font in my menus without Restart.
But I am sure I didn't have any tear-off menus.

Generally, I don't see much differences between depth 16 and 24.

> to draw in a Pixmap with a ParentRelative "bg".

Well, it is possible to store static parts, like shadow text. :)

Regards,
Mikhael.