Subject: CVS olicha: * My God, Do not BroadcastColorset in CMD_Colorset, parse_colorset do that!!!

From: FVWM CVS <[email-masked]>
Date: Thu, 17 Oct 2002 06:41:05 -0500

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	olicha	02/10/17 06:41:05

Modified files:
	.              : ChangeLog NEWS 
	fvwm           : builtins.c 
	libs           : Colorset.c 
	modules        : ChangeLog 
	modules/FvwmBacker: FvwmBacker.1 

Log message:
* My God, Do not BroadcastColorset in CMD_Colorset, parse_colorset do that!!!
* Use a 1x1 pixmap and not a widthxheight pixmap for Plain color in
CreateBackgroundPixmap
* A bunch of news (last 4, needs lang check)
* Documented RetainPixmap FvwmBacker option (needs lang check)

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 18 Oct 2002 21:02:39 +0000

> * Documented RetainPixmap FvwmBacker option (needs lang check)

I think after this commit RootTransparent in menus does not work,
i.e. there is a solid background. Transparent works.
I use fvwm-root to set a background, so this is not a problem.

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 19 Oct 2002 01:47:12 +0200

> I use fvwm-root to set a background, so this is not a problem.

This is normal, fvwm-root will have an option -retain-pixmap
which allows RootTransparent to work (future patch by Cameron
Simpson I hope). At present time you should use Esetroot or
FvwmBaker with *FvwmBaker: RetainPixmap. It is absurd that
fvwm-root retain the pixmap by default (memory wasting), so
fvwm-root just signal that it change the root bg by setting
the _XSETROOT_ID property to None (so that the memory safe
ParentalRelativity method works). For root transparency
the  _XROOTPMAP_ID and ESETROOT_ID properties should be used.
This is coherent. The ParentalRelativity method use _XSETROOT_ID
and the "E" method use _XROOTPMAP_ID and is off by default
for memory reason.

Olivier

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 21 Oct 2002 17:38:07 +0000

> and the "E" method use _XROOTPMAP_ID and is off by default

I don't have a problem to add such option everywhere and will do this.
But it is not absurd for Esetroot to retain a pixmap by default.

Anyway, I think either the previous functionality should be restored or
this new option be added before the 2.5.4 release. Cameron, do you want to
provide a patch?

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 21 Oct 2002 21:53:57 +0200

> But it is not absurd for Esetroot to retain a pixmap by default.

I think it absurd in the sense that if no apps use E-transparent
background are used then you waste memory (e.g., 2.5 Mb with a 2 heads
1280x1024 system). Moreover, I know no program which use _XSETROOT_ID
which retains the pixmap. So, I think it is good idea to use
_XSETROOT_ID to just retain a None pixmap to warn pgs that
the bg change and use _XROOTPMAP_ID for retaining the pixmap.
 
> this new option be added before the 2.5.4 release. Cameron, do you want to

I do not want to restore the old functionnality. I can do the patch
to fvwl-root if Cameron does not have the time soon.

Olivier