Subject: Notification: incoming/924

From: [email-masked]
Date: Fri, 20 Sep 2002 17:47:35 -0500

FVWM Bug Tracking notification

new message incoming/924

Message summary for PR#924
	From: [email-masked]
	Subject: Conditional's criteria
	Date: Fri, 20 Sep 2002 17:47:34 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Fri Sep 20 17:47:35 2002
From: [email-masked]
To: [email-masked]
Subject: Conditional's criteria
Date: Fri, 20 Sep 2002 17:47:34 -0500

Full_Name: Rastislav Galia
Version: 2.4.9
CVS_Date: 
OS: 
X_Server: Red Hat 7.1
Submission from: (NULL) (195.163.152.136)

Degree of freedom in configuring Fvwm would be increased a lot by
introducing following criteria to conditional statements :

Focused, for exaplme ThisWindow (Focused) ..., meaning command is
performed
    only in case ThisWindow == Current

Window ID, for example Current ("ID:0x2e0000d") ..., meaning command is
    performed only in case focused window has Window ID 0x2e0000d

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 20 Sep 2002 23:40:30 +0000

>     only in case ThisWindow == Current

This is already available in 2.5.0+:

  ThisWindow (Focused) ...

>     performed only in case focused window has Window ID 0x2e0000d

WindowId is available in 2.2.x, but in 2.4.x you may pass conditions.
And in 2.5.x you may pass Focused among others:

  WindowId 0x2e0000d (Focused, !Maximized) ...

So, I move this to "existing enh.".

Regards,
Mikhael.

---

From: Rastislav Galia <[email-masked]>
Date: Sat, 21 Sep 2002 09:06:18 +0200 (CEST)

> So, I move this to "existing enh.".

Before I do so, I want to clarify that there is a difference between

WindowId 0x2e0000d (...) ...

and

Next/*or whatevet*/ ("0x2e0000d") ...

I know first option is available, but second option is 
not in 2.4.x documentation, so I didn't try it.
What did you by mean 'you can pass condition'. Is it this second way ? 
Then I change my proposal to 'include in documentation' ... :-)))

/Rastjo

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 21 Sep 2002 11:05:14 +0000

On 21 Sep 2002 09:06:18 +0200, Rastislav Galia wrote:
> Mikhael Goikhman wrote:

The second syntax does not match the window id, the first does. Think
about this (supposing FvwmEvent calls a function with a window id param):

  Next        ("XTerm", !Iconic) Iconify
  WindowId $0 ("XTerm", !Iconic) Iconify

The first operates on a random xterm, the second - on the one that
triggers the event.

> Then I change my proposal to 'include in documentation' ... :-)))

The condition is what is in parentheses. In 2.2.x, WindowId did not accept
parentheses. I don't see anything that is not documented.

What is the task you want to achieve using conditional commands?

Regards,
Mikhael.