Subject: Problems building snap-20020908

From: Jason L Tibbitts III <[email-masked]>
Date: Sun, 8 Sep 2002 06:31:42 -0500

? fvwm-snap-20020523.tar.gz
? fvwm-snap-20020524.tar.gz
P ChangeLog
P fvwm/fvwm.h
P fvwm/stack.c
configure.in:448: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:495: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:512: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:699: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:843: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:883: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:898: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:903: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:448: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:495: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:512: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:699: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:843: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:883: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:898: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:903: warning: AC_TRY_RUN called without default to allow cross compiling
loading cache ./config.cache
checking for a BSD compatible install... (cached) /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... (cached) yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... found
checking whether to enable command logging... no
checking whether to enable debugging messages... no
checking whether to enable fancy pixmap titlebars... yes
checking imagepath... /usr/include/X11/bitmaps:/usr/include/X11/pixmaps
checking for gcc... (cached) gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking how to run the C preprocessor... (cached) gcc -E
checking for POSIXized ISC... no
checking for minix/config.h... (cached) no
checking for X... (cached) libraries /usr/X11R6/lib, headers /usr/X11R6/include
checking for dnet_ntoa in -ldnet... (cached) no
checking for dnet_ntoa in -ldnet_stub... (cached) no
checking for gethostbyname... (cached) yes
checking for connect... (cached) yes
checking for remove... (cached) yes
checking for shmat... (cached) yes
checking for IceConnectionNumber in -lICE... (cached) yes
checking host system type... i686-pc-linux-gnu
checking whether to enable GNOME window manager hints... yes
checking whether to enable Extended WM Hints Support... yes
checking for SmcOpenConnection in -lSM... yes
checking for XShapeQueryExtension in -lXext... yes
checking for XineramaIsActive in -lXinerama... yes
checking whether to enable Xinerama emulation on one screen (useful only for developers)... no
checking for XRenderComposite in -lXrender... yes
checking for freetype-config... (cached) no
checking for FreeType - version >= 6.1.0... no
*** The freetype-config script installed by FreeType 2 could not be found.
*** If FreeType 2 was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the FT2_CONFIG environment variable to the
*** full path to freetype-config.
checking for XpmReadFileToXpmImage in -lXpm... yes
checking for X11/xpm.h... yes
checking for Xpm 3.4g or better... yes
checking for png_read_info in -lpng... yes
checking for png.h... yes
checking for libpng 1.0.4a or better... yes
checking whether byte ordering is bigendian... (cached) no
checking for rplay_create in -lrplay... no
checking for stroke_init in -lstroke... no
checking with termcap... checking for readline in -lreadline... no
checking with ncurses... checking for readline in -lreadline... yes
checking for readline/history.h... yes
checking for _Xsetlocale in -lX11... (cached) no
checking for XOpenOM in -lX11... (cached) yes
checking for libiconv_open in -liconv... (cached) no
checking for iconv_open... (cached) yes
checking check if second arg of iconv is const... no
checking for nl_langinfo (CODESET)... yes
checking for fribidi-config... no
checking for stdarg.h... (cached) yes
checking for vfprintf... (cached) yes
checking for waitpid... (cached) yes
checking for cpp... (cached) /usr/bin/cpp
checking for a BSD compatible install... /usr/bin/install -c
checking whether ln -s works... (cached) yes
checking whether make sets ${MAKE}... (cached) yes
checking for ranlib... (cached) ranlib
checking for perl... (cached) /usr/local/bin/perl
checking for perl 5.002 or better... no
configure: warning: /usr/local/bin/perl not found or too old
assuming /usr/local/bin/perl as perl location
checking for ANSI C header files... (cached) yes
checking for sys/wait.h that is POSIX.1 compatible... (cached) yes
checking for stdlib.h... (cached) yes
checking for fcntl.h... (cached) yes
checking for limits.h... (cached) yes
checking for malloc.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for unistd.h... (cached) yes
checking for getopt.h... (cached) yes
checking for sys/select.h... (cached) yes
checking for sys/systeminfo.h... (cached) no
checking for sys/time.h... (cached) yes
checking for working const... (cached) yes
checking for inline... (cached) inline
checking for off_t... (cached) yes
checking for pid_t... (cached) yes
checking for size_t... (cached) yes
checking whether time.h and sys/time.h may both be included... (cached) yes
checking return type of signal handlers... (cached) void
checking for working alloca.h... (cached) yes
checking for alloca... (cached) yes
checking for strftime... (cached) yes
checking whether setpgrp takes no argument... (cached) yes
checking for gettimeofday... (cached) yes
checking for mkfifo... (cached) yes
checking for putenv... (cached) yes
checking for setvbuf... (cached) yes
checking for socket... (cached) yes
checking for waitpid... (cached) yes
checking for strdup... (cached) yes
checking for strstr... (cached) yes
checking for strtol... (cached) yes
checking for memmove... (cached) yes
checking for memcpy... (cached) yes
checking for strchr... (cached) yes
checking for sysconf... (cached) yes
checking for uname... (cached) yes
checking for div... (cached) yes
checking for sigaction... (cached) yes
checking for siginterrupt... (cached) yes
checking for getpwuid... (cached) yes
checking for setpgrp... (cached) yes
checking for setpgid... (cached) yes
checking for sig_atomic_t... (cached) yes
checking whether setvbuf arguments are reversed... (cached) no
checking for select... (cached) yes
checking for unistd.h... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/time.h... (cached) yes
checking for sys/select.h... (cached) yes
checking for sys/socket.h... (cached) yes
checking argument types of select()... (cached) select(int,fd_set *,...)
checking for gethostname... (cached) yes
checking for strcasecmp... (cached) yes
checking for strncasecmp... (cached) yes
checking for strdup... (cached) yes
checking for strerror... (cached) yes
checking for usleep... (cached) yes
checking for atexit... (cached) yes
checking for gtk-config... (cached) no
checking for GTK - version >= 1.1.0... no
*** The gtk-config script installed by GTK could not be found
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG environment variable to the
*** full path to gtk-config.
checking for imlib-config... (cached) no
checking for GDK IMLIB - version >= 1.8.0... no
checking for gnome-config... (cached) no
checking for gnomeConf.sh file in /usr/local/lib... not found
creating ./config.status
creating Makefile
creating libs/Makefile
creating fvwm/Makefile
creating modules/Makefile
creating fvwm/fvwm.1
creating bin/Makefile
creating bin/fvwm-config
creating bin/fvwm-bug
creating bin/fvwm-perllib
creating bin/fvwm-menu-xlock
creating bin/fvwm-menu-directory
creating bin/fvwm-menu-desktop
creating bin/fvwm-menu-headlines
creating bin/fvwm-convert-2.4
creating bin/fvwm-convert-2.6
creating utils/Makefile
creating perllib/Makefile
creating perllib/General/Makefile
creating perllib/FVWM/Makefile
creating perllib/FVWM/Module/Makefile
creating perllib/FVWM/Module.pm
creating rpm/Makefile
creating rpm/fvwm.spec
creating docs/fvwm.lsm
creating docs/Makefile
creating sample.fvwmrc/Makefile
creating tests/Makefile
creating modules/FvwmAnimate/Makefile
creating modules/FvwmAuto/Makefile
creating modules/FvwmBacker/Makefile
creating modules/FvwmBanner/Makefile
creating modules/FvwmButtons/Makefile
creating modules/FvwmCommand/Makefile
creating modules/FvwmCommand/scripts/Makefile
creating modules/FvwmConsole/Makefile
creating modules/FvwmConsole/FvwmConsoleC.pl
creating modules/FvwmCpp/Makefile
creating modules/FvwmDebug/Makefile
creating modules/FvwmDragWell/Makefile
creating modules/FvwmEvent/Makefile
creating modules/FvwmForm/Makefile
creating modules/FvwmIconBox/Makefile
creating modules/FvwmIconMan/Makefile
creating modules/FvwmIdent/Makefile
creating modules/FvwmM4/Makefile
creating modules/FvwmPager/Makefile
creating modules/FvwmPerl/Makefile
creating modules/FvwmPerl/FvwmPerl
creating modules/FvwmRearrange/Makefile
creating modules/FvwmSave/Makefile
creating modules/FvwmSaveDesk/Makefile
creating modules/FvwmScript/Makefile
creating modules/FvwmScript/Scripts/Makefile
creating modules/FvwmScript/Widgets/Makefile
creating modules/FvwmScroll/Makefile
creating modules/FvwmTaskBar/Makefile
creating modules/FvwmTheme/Makefile
creating modules/FvwmWharf/Makefile
creating modules/FvwmWinList/Makefile
creating modules/FvwmGtk/Makefile
creating config.h
config.h is unchanged

FVWM Configuration:

  Version:     2.5.4 (from cvs)

  Executables: /usr/local/bin
  Man pages:   /usr/local/man
  Modules:     /usr/local/libexec/fvwm/2.5.4
  Data files:  /usr/local/share/fvwm
  Perl lib:    /usr/local/share/fvwm/perllib

  With Asian bi-direct. text support? no: No fribidi-config found in PATH
  With Extended Window Manager Hints? yes
  With GNOME Window Manager Hints?    yes
  With GTK required for FvwmGtk?      no: Failed to detect GTK, see config.log
  With PNG image support?             yes
  With ReadLine sup. in FvwmConsole?  yes
  With RPlay support in FvwmEvent?    no: Can't find working librplay
  With Shaped window support?         yes
  With Session Management support?    yes
  With Mouse strokes (gestures)?      no: Can't find working libstroke
  With Xinerama multi-head support?   yes
  With Xft anti-alias font support?   no: Failed to detect freetype2 (version >= 6.1.0 aka 2.0.6)
  With XPM image support?             yes
  With Xrender image support?         yes

See INSTALL.fvwm for the description of what this may mean.
cd . \
  && CONFIG_FILES=Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating Makefile
/usr/bin/make  all-recursive
make[1]: Entering directory `/home/tibbs/fvwm'
Making all in libs
make[2]: Entering directory `/home/tibbs/fvwm/libs'
cd .. \
  && CONFIG_FILES=libs/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating libs/Makefile
make[2]: Leaving directory `/home/tibbs/fvwm/libs'
make[2]: Entering directory `/home/tibbs/fvwm/libs'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/tibbs/fvwm/libs'
Making all in fvwm
make[2]: Entering directory `/home/tibbs/fvwm/fvwm'
cd .. \
  && CONFIG_FILES=fvwm/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating fvwm/Makefile
make[2]: Leaving directory `/home/tibbs/fvwm/fvwm'
make[2]: Entering directory `/home/tibbs/fvwm/fvwm'
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c menus.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c colorset.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c style.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c borders.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c move_resize.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c builtins.c
builtins.c: In function `CMD_DestroyDecor':
builtins.c:2631: `eventp' undeclared (first use in this function)
builtins.c:2631: (Each undeclared identifier is reported only once
builtins.c:2631: for each function it appears in.)
make[2]: *** [builtins.o] Error 1
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c events.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c add_window.c
add_window.c: In function `AddWindow':
add_window.c:2280: warning: passing arg 2 of `handle_stick' makes integer from pointer without a cast
add_window.c:2280: warning: passing arg 3 of `handle_stick' makes pointer from integer without a cast
add_window.c:2280: warning: passing arg 4 of `handle_stick' makes integer from pointer without a cast
add_window.c:2280: warning: passing arg 5 of `handle_stick' makes pointer from integer without a cast
add_window.c:2280: warning: passing arg 6 of `handle_stick' from incompatible pointer type
add_window.c:2280: too many arguments to function `handle_stick'
add_window.c:2299: warning: passing arg 2 of `CMD_Resize' makes integer from pointer without a cast
add_window.c:2299: warning: passing arg 3 of `CMD_Resize' makes pointer from integer without a cast
add_window.c:2299: warning: passing arg 4 of `CMD_Resize' makes integer from pointer without a cast
add_window.c:2299: warning: passing arg 5 of `CMD_Resize' makes pointer from integer without a cast
add_window.c:2299: warning: passing arg 6 of `CMD_Resize' from incompatible pointer type
add_window.c:2299: too many arguments to function `CMD_Resize'
make[2]: *** [add_window.o] Error 1
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c module_interface.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c icons.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c stack.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c functions.c
functions.c: In function `execute_complex_function':
functions.c:550: `eventp' undeclared (first use in this function)
functions.c:550: (Each undeclared identifier is reported only once
functions.c:550: for each function it appears in.)
functions.c: In function `execute_function':
functions.c:1087: warning: passing arg 2 of pointer to function makes integer from pointer without a cast
functions.c:1087: warning: passing arg 3 of pointer to function makes pointer from integer without a cast
functions.c:1087: warning: passing arg 4 of pointer to function makes integer from pointer without a cast
functions.c:1087: warning: passing arg 5 of pointer to function makes pointer from integer without a cast
functions.c:1087: warning: passing arg 6 of pointer to function from incompatible pointer type
functions.c:1087: too many arguments to function
functions.c:1108: warning: passing arg 2 of `execute_complex_function' makes integer from pointer without a cast
functions.c:1108: warning: passing arg 3 of `execute_complex_function' makes pointer from integer without a cast
functions.c:1108: warning: passing arg 4 of `execute_complex_function' makes integer from pointer without a cast
functions.c:1108: warning: passing arg 5 of `execute_complex_function' makes pointer from integer without a cast
functions.c:1108: warning: passing arg 6 of `execute_complex_function' from incompatible pointer type
functions.c:1108: too many arguments to function `execute_complex_function'
functions.c:1114: warning: passing arg 2 of `executeModuleDesperate' makes integer from pointer without a cast
functions.c:1114: warning: passing arg 3 of `executeModuleDesperate' makes pointer from integer without a cast
functions.c:1114: warning: passing arg 4 of `executeModuleDesperate' makes integer from pointer without a cast
functions.c:1114: warning: passing arg 5 of `executeModuleDesperate' makes pointer from integer without a cast
functions.c:1114: warning: passing arg 6 of `executeModuleDesperate' from incompatible pointer type
functions.c:1114: too many arguments to function `executeModuleDesperate'
make[2]: *** [functions.o] Error 1
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c virtual.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c session.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c fvwm.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c placement.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c focus.c
focus.c: In function `CMD_WarpToWindow':
focus.c:1213: `eventp' undeclared (first use in this function)
focus.c:1213: (Each undeclared identifier is reported only once
focus.c:1213: for each function it appears in.)
make[2]: *** [focus.o] Error 1
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c read.c
read.c: In function `CMD_Read':
read.c:302: `eventp' undeclared (first use in this function)
read.c:302: (Each undeclared identifier is reported only once
read.c:302: for each function it appears in.)
read.c: In function `CMD_PipeRead':
read.c:355: `eventp' undeclared (first use in this function)
make[2]: *** [read.o] Error 1
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c misc.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c conditional.c
conditional.c: In function `circulate_cmd':
conditional.c:181: `eventp' undeclared (first use in this function)
conditional.c:181: (Each undeclared identifier is reported only once
conditional.c:181: for each function it appears in.)
conditional.c: In function `select_cmd':
conditional.c:218: `eventp' undeclared (first use in this function)
conditional.c: In function `CMD_Prev':
conditional.c:737: `eventp' undeclared (first use in this function)
conditional.c:737: warning: passing arg 3 of `circulate_cmd' makes pointer from integer without a cast
conditional.c:737: warning: passing arg 4 of `circulate_cmd' makes integer from pointer without a cast
conditional.c:737: warning: passing arg 5 of `circulate_cmd' makes pointer from integer without a cast
conditional.c:737: warning: passing arg 6 of `circulate_cmd' from incompatible pointer type
conditional.c:737: warning: passing arg 7 of `circulate_cmd' makes integer from pointer without a cast
conditional.c:737: too many arguments to function `circulate_cmd'
conditional.c: In function `CMD_Next':
conditional.c:745: `eventp' undeclared (first use in this function)
conditional.c:745: warning: passing arg 3 of `circulate_cmd' makes pointer from integer without a cast
conditional.c:745: warning: passing arg 4 of `circulate_cmd' makes integer from pointer without a cast
conditional.c:745: warning: passing arg 5 of `circulate_cmd' makes pointer from integer without a cast
conditional.c:745: warning: passing arg 6 of `circulate_cmd' from incompatible pointer type
conditional.c:745: warning: passing arg 7 of `circulate_cmd' makes integer from pointer without a cast
conditional.c:745: too many arguments to function `circulate_cmd'
conditional.c: In function `CMD_None':
conditional.c:753: `eventp' undeclared (first use in this function)
conditional.c:753: warning: passing arg 3 of `circulate_cmd' makes pointer from integer without a cast
conditional.c:753: warning: passing arg 4 of `circulate_cmd' makes integer from pointer without a cast
conditional.c:753: warning: passing arg 5 of `circulate_cmd' makes pointer from integer without a cast
conditional.c:753: warning: passing arg 6 of `circulate_cmd' from incompatible pointer type
conditional.c:753: warning: passing arg 7 of `circulate_cmd' makes integer from pointer without a cast
conditional.c:753: too many arguments to function `circulate_cmd'
conditional.c: In function `CMD_Current':
conditional.c:768: `eventp' undeclared (first use in this function)
conditional.c:768: warning: passing arg 3 of `circulate_cmd' makes pointer from integer without a cast
conditional.c:768: warning: passing arg 4 of `circulate_cmd' makes integer from pointer without a cast
conditional.c:768: warning: passing arg 5 of `circulate_cmd' makes pointer from integer without a cast
conditional.c:768: warning: passing arg 6 of `circulate_cmd' from incompatible pointer type
conditional.c:768: warning: passing arg 7 of `circulate_cmd' makes integer from pointer without a cast
conditional.c:768: too many arguments to function `circulate_cmd'
conditional.c: In function `CMD_All':
conditional.c:832: `eventp' undeclared (first use in this function)
conditional.c: In function `CMD_Direction':
conditional.c:1031: `eventp' undeclared (first use in this function)
conditional.c: In function `CMD_WindowId':
conditional.c:1134: `eventp' undeclared (first use in this function)
conditional.c: In function `CMD_Cond':
conditional.c:1236: `eventp' undeclared (first use in this function)
conditional.c: In function `CMD_CondCase':
conditional.c:1253: `eventp' undeclared (first use in this function)
conditional.c:1253: warning: passing arg 3 of `CMD_Cond' makes pointer from integer without a cast
conditional.c:1253: warning: passing arg 4 of `CMD_Cond' makes integer from pointer without a cast
conditional.c:1253: warning: passing arg 5 of `CMD_Cond' makes pointer from integer without a cast
conditional.c:1253: warning: passing arg 6 of `CMD_Cond' from incompatible pointer type
conditional.c:1253: too many arguments to function `CMD_Cond'
make[2]: *** [conditional.o] Error 1
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c colormaps.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c repeat.c
repeat.c: In function `CMD_Repeat':
repeat.c:153: `eventp' undeclared (first use in this function)
repeat.c:153: (Each undeclared identifier is reported only once
repeat.c:153: for each function it appears in.)
make[2]: *** [repeat.o] Error 1
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c decorations.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c bindings.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c colors.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c cursor.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c update.c
update.c: In function `apply_window_updates':
update.c:132: warning: passing arg 2 of `handle_stick' makes integer from pointer without a cast
update.c:132: warning: passing arg 3 of `handle_stick' makes pointer from integer without a cast
update.c:132: warning: passing arg 4 of `handle_stick' makes integer from pointer without a cast
update.c:132: warning: passing arg 5 of `handle_stick' makes pointer from integer without a cast
update.c:132: warning: passing arg 6 of `handle_stick' from incompatible pointer type
update.c:132: too many arguments to function `handle_stick'
update.c:135: warning: passing arg 2 of `handle_stick' makes integer from pointer without a cast
update.c:135: warning: passing arg 3 of `handle_stick' makes pointer from integer without a cast
update.c:135: warning: passing arg 4 of `handle_stick' makes integer from pointer without a cast
update.c:135: warning: passing arg 5 of `handle_stick' makes pointer from integer without a cast
update.c:135: warning: passing arg 6 of `handle_stick' from incompatible pointer type
update.c:135: too many arguments to function `handle_stick'
update.c:146: warning: passing arg 2 of `handle_stick' makes integer from pointer without a cast
update.c:146: warning: passing arg 3 of `handle_stick' makes pointer from integer without a cast
update.c:146: warning: passing arg 4 of `handle_stick' makes integer from pointer without a cast
update.c:146: warning: passing arg 5 of `handle_stick' makes pointer from integer without a cast
update.c:146: warning: passing arg 6 of `handle_stick' from incompatible pointer type
update.c:146: too many arguments to function `handle_stick'
make[2]: *** [update.o] Error 1
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c windowlist.c
windowlist.c: In function `CMD_WindowList':
windowlist.c:960: `eventp' undeclared (first use in this function)
windowlist.c:960: (Each undeclared identifier is reported only once
windowlist.c:960: for each function it appears in.)
make[2]: *** [windowlist.o] Error 1
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c modconf.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c gnome.c
gnome.c: In function `CMD_GnomeButton':
gnome.c:1034: `eventp' undeclared (first use in this function)
gnome.c:1034: (Each undeclared identifier is reported only once
gnome.c:1034: for each function it appears in.)
make[2]: *** [gnome.o] Error 1
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c geometry.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c icccm2.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c ewmh.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c ewmh_events.c
ewmh_events.c: In function `ewmh_DesktopGeometry':
ewmh_events.c:56: warning: passing arg 2 of `CMD_DesktopSize' makes integer from pointer without a cast
ewmh_events.c:56: warning: passing arg 4 of `CMD_DesktopSize' makes integer from pointer without a cast
ewmh_events.c:56: warning: passing arg 5 of `CMD_DesktopSize' makes pointer from integer without a cast
ewmh_events.c:56: warning: passing arg 6 of `CMD_DesktopSize' from incompatible pointer type
ewmh_events.c:56: too many arguments to function `CMD_DesktopSize'
ewmh_events.c: In function `ewmh_CloseWindow':
ewmh_events.c:98: warning: passing arg 2 of `CMD_Close' makes integer from pointer without a cast
ewmh_events.c:98: warning: passing arg 3 of `CMD_Close' makes pointer from integer without a cast
ewmh_events.c:98: warning: passing arg 4 of `CMD_Close' makes integer from pointer without a cast
ewmh_events.c:98: warning: passing arg 5 of `CMD_Close' makes pointer from integer without a cast
ewmh_events.c:98: warning: passing arg 6 of `CMD_Close' from incompatible pointer type
ewmh_events.c:98: too many arguments to function `CMD_Close'
ewmh_events.c: In function `ewmh_WMDesktop':
ewmh_events.c:113: warning: passing arg 2 of `CMD_Stick' makes integer from pointer without a cast
ewmh_events.c:113: warning: passing arg 3 of `CMD_Stick' makes pointer from integer without a cast
ewmh_events.c:113: warning: passing arg 4 of `CMD_Stick' makes integer from pointer without a cast
ewmh_events.c:113: warning: passing arg 5 of `CMD_Stick' makes pointer from integer without a cast
ewmh_events.c:113: warning: passing arg 6 of `CMD_Stick' from incompatible pointer type
ewmh_events.c:113: too many arguments to function `CMD_Stick'
ewmh_events.c:118: warning: passing arg 2 of `CMD_Stick' makes integer from pointer without a cast
ewmh_events.c:118: warning: passing arg 3 of `CMD_Stick' makes pointer from integer without a cast
ewmh_events.c:118: warning: passing arg 4 of `CMD_Stick' makes integer from pointer without a cast
ewmh_events.c:118: warning: passing arg 5 of `CMD_Stick' makes pointer from integer without a cast
ewmh_events.c:118: warning: passing arg 6 of `CMD_Stick' from incompatible pointer type
ewmh_events.c:118: too many arguments to function `CMD_Stick'
ewmh_events.c: In function `ewmh_MoveResize':
ewmh_events.c:216: warning: passing arg 2 of `CMD_WarpToWindow' makes integer from pointer without a cast
ewmh_events.c:216: warning: passing arg 3 of `CMD_WarpToWindow' makes pointer from integer without a cast
ewmh_events.c:216: warning: passing arg 4 of `CMD_WarpToWindow' makes integer from pointer without a cast
ewmh_events.c:216: warning: passing arg 5 of `CMD_WarpToWindow' makes pointer from integer without a cast
ewmh_events.c:216: warning: passing arg 6 of `CMD_WarpToWindow' from incompatible pointer type
ewmh_events.c:216: too many arguments to function `CMD_WarpToWindow'
ewmh_events.c:218: warning: passing arg 2 of `CMD_Move' makes integer from pointer without a cast
ewmh_events.c:218: warning: passing arg 3 of `CMD_Move' makes pointer from integer without a cast
ewmh_events.c:218: warning: passing arg 4 of `CMD_Move' makes integer from pointer without a cast
ewmh_events.c:218: warning: passing arg 5 of `CMD_Move' makes pointer from integer without a cast
ewmh_events.c:218: warning: passing arg 6 of `CMD_Move' from incompatible pointer type
ewmh_events.c:218: too many arguments to function `CMD_Move'
ewmh_events.c:220: warning: passing arg 2 of `CMD_Resize' makes integer from pointer without a cast
ewmh_events.c:220: warning: passing arg 3 of `CMD_Resize' makes pointer from integer without a cast
ewmh_events.c:220: warning: passing arg 4 of `CMD_Resize' makes integer from pointer without a cast
ewmh_events.c:220: warning: passing arg 5 of `CMD_Resize' makes pointer from integer without a cast
ewmh_events.c:220: warning: passing arg 6 of `CMD_Resize' from incompatible pointer type
ewmh_events.c:220: too many arguments to function `CMD_Resize'
ewmh_events.c: In function `ewmh_WMState':
ewmh_events.c:295: warning: passing arg 2 of `CMD_Maximize' makes integer from pointer without a cast
ewmh_events.c:295: warning: passing arg 3 of `CMD_Maximize' makes pointer from integer without a cast
ewmh_events.c:295: warning: passing arg 4 of `CMD_Maximize' makes integer from pointer without a cast
ewmh_events.c:295: warning: passing arg 5 of `CMD_Maximize' makes pointer from integer without a cast
ewmh_events.c:295: warning: passing arg 6 of `CMD_Maximize' from incompatible pointer type
ewmh_events.c:295: too many arguments to function `CMD_Maximize'
ewmh_events.c: In function `ewmh_WMStateHidden':
ewmh_events.c:393: warning: passing arg 2 of `CMD_Iconify' makes integer from pointer without a cast
ewmh_events.c:393: warning: passing arg 3 of `CMD_Iconify' makes pointer from integer without a cast
ewmh_events.c:393: warning: passing arg 4 of `CMD_Iconify' makes integer from pointer without a cast
ewmh_events.c:393: warning: passing arg 5 of `CMD_Iconify' makes pointer from integer without a cast
ewmh_events.c:393: warning: passing arg 6 of `CMD_Iconify' from incompatible pointer type
ewmh_events.c:393: too many arguments to function `CMD_Iconify'
ewmh_events.c: In function `ewmh_WMStateShaded':
ewmh_events.c:594: warning: passing arg 2 of `CMD_WindowShade' makes integer from pointer without a cast
ewmh_events.c:594: warning: passing arg 3 of `CMD_WindowShade' makes pointer from integer without a cast
ewmh_events.c:594: warning: passing arg 4 of `CMD_WindowShade' makes integer from pointer without a cast
ewmh_events.c:594: warning: passing arg 5 of `CMD_WindowShade' makes pointer from integer without a cast
ewmh_events.c:594: warning: passing arg 6 of `CMD_WindowShade' from incompatible pointer type
ewmh_events.c:594: too many arguments to function `CMD_WindowShade'
ewmh_events.c:598: warning: passing arg 2 of `CMD_WindowShade' makes integer from pointer without a cast
ewmh_events.c:598: warning: passing arg 3 of `CMD_WindowShade' makes pointer from integer without a cast
ewmh_events.c:598: warning: passing arg 4 of `CMD_WindowShade' makes integer from pointer without a cast
ewmh_events.c:598: warning: passing arg 5 of `CMD_WindowShade' makes pointer from integer without a cast
ewmh_events.c:598: warning: passing arg 6 of `CMD_WindowShade' from incompatible pointer type
ewmh_events.c:598: too many arguments to function `CMD_WindowShade'
ewmh_events.c: In function `ewmh_WMStateSticky':
ewmh_events.c:850: warning: passing arg 2 of `CMD_Stick' makes integer from pointer without a cast
ewmh_events.c:850: warning: passing arg 3 of `CMD_Stick' makes pointer from integer without a cast
ewmh_events.c:850: warning: passing arg 4 of `CMD_Stick' makes integer from pointer without a cast
ewmh_events.c:850: warning: passing arg 5 of `CMD_Stick' makes pointer from integer without a cast
ewmh_events.c:850: warning: passing arg 6 of `CMD_Stick' from incompatible pointer type
ewmh_events.c:850: too many arguments to function `CMD_Stick'
ewmh_events.c:854: warning: passing arg 2 of `CMD_Stick' makes integer from pointer without a cast
ewmh_events.c:854: warning: passing arg 3 of `CMD_Stick' makes pointer from integer without a cast
ewmh_events.c:854: warning: passing arg 4 of `CMD_Stick' makes integer from pointer without a cast
ewmh_events.c:854: warning: passing arg 5 of `CMD_Stick' makes pointer from integer without a cast
ewmh_events.c:854: warning: passing arg 6 of `CMD_Stick' from incompatible pointer type
ewmh_events.c:854: too many arguments to function `CMD_Stick'
make[2]: *** [ewmh_events.o] Error 1
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c ewmh_icons.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c ewmh_names.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c ewmh_conf.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c schedule.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c menuitem.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c menustyle.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c menucmd.c
menucmd.c: In function `menu_func':
menucmd.c:103: `eventp' undeclared (first use in this function)
menucmd.c:103: (Each undeclared identifier is reported only once
menucmd.c:103: for each function it appears in.)
make[2]: *** [menucmd.o] Error 1
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c windowshade.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c frame.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c expand.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs   	 -I/usr/X11R6/include   	    -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.4\" 	-DFVWM_DATADIR=\"/usr/local/share/fvwm\" 	-DFVWM_CONFDIR=\"/usr/local/etc\" 	-DFVWM_COLORSET_PRIVATE=1 -g -O2 -Wall -Wno-implicit-int -c functable.c
cd .. && CONFIG_FILES=fvwm/fvwm.1 CONFIG_HEADERS= /bin/sh ./config.status
creating fvwm/fvwm.1
make[2]: Target `all' not remade because of errors.
make[2]: Leaving directory `/home/tibbs/fvwm/fvwm'
Making all in modules
make[2]: Entering directory `/home/tibbs/fvwm/modules'
cd .. \
  && CONFIG_FILES=modules/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/Makefile
make[2]: Leaving directory `/home/tibbs/fvwm/modules'
make[2]: Entering directory `/home/tibbs/fvwm/modules'
Making all in FvwmAnimate
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmAnimate'
cd ../.. \
  && CONFIG_FILES=modules/FvwmAnimate/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmAnimate/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmAnimate'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmAnimate'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmAnimate'
Making all in FvwmAuto
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmAuto'
cd ../.. \
  && CONFIG_FILES=modules/FvwmAuto/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmAuto/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmAuto'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmAuto'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmAuto'
Making all in FvwmBacker
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmBacker'
cd ../.. \
  && CONFIG_FILES=modules/FvwmBacker/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmBacker/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmBacker'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmBacker'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmBacker'
Making all in FvwmBanner
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmBanner'
cd ../.. \
  && CONFIG_FILES=modules/FvwmBanner/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmBanner/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmBanner'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmBanner'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmBanner'
Making all in FvwmButtons
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmButtons'
cd ../.. \
  && CONFIG_FILES=modules/FvwmButtons/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmButtons/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmButtons'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmButtons'
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..   -I/usr/X11R6/include 	       -g -O2 -Wall -Wno-implicit-int -c FvwmButtons.c
gcc  -g -O2 -Wall -Wno-implicit-int  -o FvwmButtons  FvwmButtons.o button.o draw.o icons.o misc.o output.o parse.o dynamic.o -L../../libs -lfvwm  -L/usr/X11R6/lib -lXpm  	-lSM -lICE -lXinerama -lXext -lX11 -lm  	 -lXrender  -lpng -lz 
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmButtons'
Making all in FvwmCommand
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmCommand'
cd ../.. \
  && CONFIG_FILES=modules/FvwmCommand/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmCommand/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmCommand'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmCommand'
Making all in scripts
make[4]: Entering directory `/home/tibbs/fvwm/modules/FvwmCommand/scripts'
cd ../../.. \
  && CONFIG_FILES=modules/FvwmCommand/scripts/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmCommand/scripts/Makefile
make[4]: Leaving directory `/home/tibbs/fvwm/modules/FvwmCommand/scripts'
make[4]: Entering directory `/home/tibbs/fvwm/modules/FvwmCommand/scripts'
make[4]: Nothing to be done for `all'.
make[4]: Leaving directory `/home/tibbs/fvwm/modules/FvwmCommand/scripts'
make[4]: Entering directory `/home/tibbs/fvwm/modules/FvwmCommand'
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..   -I/usr/X11R6/include    -g -O2 -Wall -Wno-implicit-int -c FvwmCommand.c
gcc  -g -O2 -Wall -Wno-implicit-int  -o FvwmCommand  FvwmCommand.o -L../../libs -lfvwm 
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..   -I/usr/X11R6/include    -g -O2 -Wall -Wno-implicit-int -c FvwmCommandS.c
gcc  -g -O2 -Wall -Wno-implicit-int  -o FvwmCommandS  FvwmCommandS.o -L../../libs -lfvwm 
make[4]: Leaving directory `/home/tibbs/fvwm/modules/FvwmCommand'
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmCommand'
Making all in FvwmConsole
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmConsole'
cd ../.. \
  && CONFIG_FILES=modules/FvwmConsole/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmConsole/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmConsole'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmConsole'
cd ../.. && CONFIG_FILES=modules/FvwmConsole/FvwmConsoleC.pl CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmConsole/FvwmConsoleC.pl
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmConsole'
Making all in FvwmCpp
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmCpp'
cd ../.. \
  && CONFIG_FILES=modules/FvwmCpp/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmCpp/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmCpp'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmCpp'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmCpp'
Making all in FvwmDebug
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmDebug'
cd ../.. \
  && CONFIG_FILES=modules/FvwmDebug/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmDebug/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmDebug'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmDebug'
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..   -I/usr/X11R6/include    -g -O2 -Wall -Wno-implicit-int -c FvwmDebug.c
gcc  -g -O2 -Wall -Wno-implicit-int  -o FvwmDebug  FvwmDebug.o -L../../libs -lfvwm 
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmDebug'
Making all in FvwmDragWell
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmDragWell'
cd ../.. \
  && CONFIG_FILES=modules/FvwmDragWell/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmDragWell/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmDragWell'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmDragWell'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmDragWell'
Making all in FvwmEvent
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmEvent'
cd ../.. \
  && CONFIG_FILES=modules/FvwmEvent/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmEvent/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmEvent'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmEvent'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmEvent'
Making all in FvwmForm
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmForm'
cd ../.. \
  && CONFIG_FILES=modules/FvwmForm/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmForm/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmForm'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmForm'
echo "#!/bin/sh" > FvwmTalk
echo exec /usr/local/libexec/fvwm/2.5.4/FvwmForm '$@' FvwmForm-Talk>> FvwmTalk
rm -f FvwmForm-Setup
sed -e 's,xFVWM_DATADIRx,/usr/local/share/fvwm,' ../../modules/FvwmForm/FvwmForm-Setup.in > FvwmForm-Setup-t
mv FvwmForm-Setup-t FvwmForm-Setup
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmForm'
Making all in FvwmGtk
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmGtk'
cd ../.. \
  && CONFIG_FILES=modules/FvwmGtk/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmGtk/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmGtk'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmGtk'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmGtk'
Making all in FvwmIconBox
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmIconBox'
cd ../.. \
  && CONFIG_FILES=modules/FvwmIconBox/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmIconBox/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmIconBox'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmIconBox'
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..   -I/usr/X11R6/include 	       -g -O2 -Wall -Wno-implicit-int -c FvwmIconBox.c
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..   -I/usr/X11R6/include 	       -g -O2 -Wall -Wno-implicit-int -c icons.c
gcc  -g -O2 -Wall -Wno-implicit-int  -o FvwmIconBox  FvwmIconBox.o icons.o -L../../libs -lfvwm  -L/usr/X11R6/lib -lXpm  	-lSM -lICE -lXinerama -lXext -lX11 -lm  	 -lXrender  -lpng -lz 
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmIconBox'
Making all in FvwmIconMan
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmIconMan'
cd ../.. \
  && CONFIG_FILES=modules/FvwmIconMan/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmIconMan/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmIconMan'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmIconMan'
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..   -I/usr/X11R6/include 	      -g -O2 -Wall -Wno-implicit-int -c FvwmIconMan.c
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..   -I/usr/X11R6/include 	      -g -O2 -Wall -Wno-implicit-int -c debug.c
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..   -I/usr/X11R6/include 	      -g -O2 -Wall -Wno-implicit-int -c functions.c
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..   -I/usr/X11R6/include 	      -g -O2 -Wall -Wno-implicit-int -c fvwm.c
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..   -I/usr/X11R6/include 	      -g -O2 -Wall -Wno-implicit-int -c globals.c
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..   -I/usr/X11R6/include 	      -g -O2 -Wall -Wno-implicit-int -c readconfig.c
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..   -I/usr/X11R6/include 	      -g -O2 -Wall -Wno-implicit-int -c winlist.c
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..   -I/usr/X11R6/include 	      -g -O2 -Wall -Wno-implicit-int -c x.c
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..   -I/usr/X11R6/include 	      -g -O2 -Wall -Wno-implicit-int -c xmanager.c
gcc  -g -O2 -Wall -Wno-implicit-int  -o FvwmIconMan  FvwmIconMan.o debug.o functions.o fvwm.o globals.o readconfig.o winlist.o x.o xmanager.o -L../../libs -lfvwm  -L/usr/X11R6/lib 	-lSM -lICE -lXinerama -lXext -lX11  	 -lXrender -lm  
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmIconMan'
Making all in FvwmIdent
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmIdent'
cd ../.. \
  && CONFIG_FILES=modules/FvwmIdent/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmIdent/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmIdent'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmIdent'
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..    	-I/usr/X11R6/include      -g -O2 -Wall -Wno-implicit-int -c FvwmIdent.c
gcc  -g -O2 -Wall -Wno-implicit-int  -o FvwmIdent  FvwmIdent.o -L../../libs -lfvwm  -L/usr/X11R6/lib -lXpm 	-lpng -lz -lSM -lICE -lXinerama -lXext -lX11 -lm 	   
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmIdent'
Making all in FvwmM4
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmM4'
cd ../.. \
  && CONFIG_FILES=modules/FvwmM4/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmM4/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmM4'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmM4'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmM4'
Making all in FvwmPager
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmPager'
cd ../.. \
  && CONFIG_FILES=modules/FvwmPager/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmPager/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmPager'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmPager'
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..    	-I/usr/X11R6/include       -g -O2 -Wall -Wno-implicit-int -c FvwmPager.c
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..    	-I/usr/X11R6/include       -g -O2 -Wall -Wno-implicit-int -c x_pager.c
gcc  -g -O2 -Wall -Wno-implicit-int  -o FvwmPager  FvwmPager.o x_pager.o -L../../libs -lfvwm  -L/usr/X11R6/lib -lXpm 	-lpng -lz -lSM -lICE -lXinerama -lXext -lX11 	 -lm -lXrender   
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmPager'
Making all in FvwmPerl
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmPerl'
cd ../.. \
  && CONFIG_FILES=modules/FvwmPerl/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmPerl/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmPerl'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmPerl'
cd ../.. && CONFIG_FILES=modules/FvwmPerl/FvwmPerl CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmPerl/FvwmPerl
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmPerl'
Making all in FvwmRearrange
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmRearrange'
cd ../.. \
  && CONFIG_FILES=modules/FvwmRearrange/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmRearrange/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmRearrange'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmRearrange'
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..  -I/usr/X11R6/include    -g -O2 -Wall -Wno-implicit-int -c FvwmRearrange.c
gcc  -g -O2 -Wall -Wno-implicit-int  -o FvwmRearrange  FvwmRearrange.o -L../../libs -L/usr/X11R6/lib -lfvwm  	-lSM -lICE -lXinerama -lXext -lX11  
echo "#!/bin/sh" > FvwmCascade
echo 'modargs="$1 $2 $3 $4 $5"' >> FvwmCascade
echo 'shift;shift;shift;shift;shift' >> FvwmCascade
echo exec /usr/local/libexec/fvwm/2.5.4'/FvwmRearrange $modargs -cascade $@' >> FvwmCascade
echo "#!/bin/sh" > FvwmTile
echo 'modargs="$1 $2 $3 $4 $5"' >> FvwmTile
echo 'shift;shift;shift;shift;shift' >> FvwmTile
echo exec /usr/local/libexec/fvwm/2.5.4'/FvwmRearrange $modargs -tile $@' >> FvwmTile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmRearrange'
Making all in FvwmSave
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmSave'
cd ../.. \
  && CONFIG_FILES=modules/FvwmSave/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmSave/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmSave'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmSave'
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..  -I/usr/X11R6/include    -g -O2 -Wall -Wno-implicit-int -c FvwmSave.c
gcc  -g -O2 -Wall -Wno-implicit-int  -o FvwmSave  FvwmSave.o -L../../libs -L/usr/X11R6/lib -lfvwm  	-lSM -lICE -lXext -lX11  
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmSave'
Making all in FvwmSaveDesk
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmSaveDesk'
cd ../.. \
  && CONFIG_FILES=modules/FvwmSaveDesk/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmSaveDesk/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmSaveDesk'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmSaveDesk'
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..  -I/usr/X11R6/include    -g -O2 -Wall -Wno-implicit-int -c FvwmSaveDesk.c
gcc  -g -O2 -Wall -Wno-implicit-int  -o FvwmSaveDesk  FvwmSaveDesk.o -L../../libs -L/usr/X11R6/lib -lfvwm  	-lSM -lICE -lXext -lX11  
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmSaveDesk'
Making all in FvwmScript
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmScript'
cd ../.. \
  && CONFIG_FILES=modules/FvwmScript/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmScript/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmScript'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmScript'
Making all in Scripts
make[4]: Entering directory `/home/tibbs/fvwm/modules/FvwmScript/Scripts'
cd ../../.. \
  && CONFIG_FILES=modules/FvwmScript/Scripts/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmScript/Scripts/Makefile
make[4]: Leaving directory `/home/tibbs/fvwm/modules/FvwmScript/Scripts'
make[4]: Entering directory `/home/tibbs/fvwm/modules/FvwmScript/Scripts'
rm -f FvwmScript-Setup95
sed -e 's,xFVWM_DATADIRx,/usr/local/share/fvwm,' -e 's,xPERLx,/usr/local/bin/perl,' -e 's,xFVWM_IMAGEPATHx,/usr/include/X11/bitmaps:/usr/include/X11/pixmaps,' ../../../modules/FvwmScript/Scripts/FvwmScript-Setup95.in > FvwmScript-Setup95-t
mv FvwmScript-Setup95-t FvwmScript-Setup95
rm -f FvwmScript-ComExample
sed -e 's,xFVWM_DATADIRx,/usr/local/share/fvwm,' -e 's,xPERLx,/usr/local/bin/perl,' ../../../modules/FvwmScript/Scripts/FvwmScript-ComExample.in > FvwmScript-ComExample-t
mv FvwmScript-ComExample-t FvwmScript-ComExample
make[4]: Leaving directory `/home/tibbs/fvwm/modules/FvwmScript/Scripts'
Making all in Widgets
make[4]: Entering directory `/home/tibbs/fvwm/modules/FvwmScript/Widgets'
cd ../../.. \
  && CONFIG_FILES=modules/FvwmScript/Widgets/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmScript/Widgets/Makefile
make[4]: Leaving directory `/home/tibbs/fvwm/modules/FvwmScript/Widgets'
make[4]: Entering directory `/home/tibbs/fvwm/modules/FvwmScript/Widgets'
make[4]: Nothing to be done for `all'.
make[4]: Leaving directory `/home/tibbs/fvwm/modules/FvwmScript/Widgets'
make[4]: Entering directory `/home/tibbs/fvwm/modules/FvwmScript'
make[4]: Nothing to be done for `all-am'.
make[4]: Leaving directory `/home/tibbs/fvwm/modules/FvwmScript'
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmScript'
Making all in FvwmScroll
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmScroll'
cd ../.. \
  && CONFIG_FILES=modules/FvwmScroll/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmScroll/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmScroll'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmScroll'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmScroll'
Making all in FvwmTaskBar
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmTaskBar'
cd ../.. \
  && CONFIG_FILES=modules/FvwmTaskBar/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmTaskBar/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmTaskBar'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmTaskBar'
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..    	-I/usr/X11R6/include       -g -O2 -Wall -Wno-implicit-int -c FvwmTaskBar.c
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..    	-I/usr/X11R6/include       -g -O2 -Wall -Wno-implicit-int -c List.c
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..    	-I/usr/X11R6/include       -g -O2 -Wall -Wno-implicit-int -c Goodies.c
gcc  -g -O2 -Wall -Wno-implicit-int  -o FvwmTaskBar  FvwmTaskBar.o List.o ButtonArray.o Mallocs.o Colors.o Start.o Goodies.o -L../../libs -L/usr/X11R6/lib -lfvwm -lm -lXpm -lpng -lz 	 -lSM -lICE -lXinerama -lXext -lX11  	-lXrender   
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmTaskBar'
Making all in FvwmTheme
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmTheme'
cd ../.. \
  && CONFIG_FILES=modules/FvwmTheme/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmTheme/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmTheme'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmTheme'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmTheme'
Making all in FvwmWharf
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmWharf'
cd ../.. \
  && CONFIG_FILES=modules/FvwmWharf/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmWharf/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmWharf'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmWharf'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmWharf'
Making all in FvwmWinList
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmWinList'
cd ../.. \
  && CONFIG_FILES=modules/FvwmWinList/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating modules/FvwmWinList/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmWinList'
make[3]: Entering directory `/home/tibbs/fvwm/modules/FvwmWinList'
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..  -I/usr/X11R6/include  	     -g -O2 -Wall -Wno-implicit-int -c ButtonArray.c
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..  -I/usr/X11R6/include  	     -g -O2 -Wall -Wno-implicit-int -c FvwmWinList.c
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..  -I/usr/X11R6/include  	     -g -O2 -Wall -Wno-implicit-int -c List.c
gcc  -g -O2 -Wall -Wno-implicit-int  -o FvwmWinList  ButtonArray.o FvwmWinList.o List.o Mallocs.o -L../../libs -lfvwm  -L/usr/X11R6/lib 	-lSM -lICE -lXinerama -lXext -lX11 -lm  	-lXrender   
make[3]: Leaving directory `/home/tibbs/fvwm/modules/FvwmWinList'
make[3]: Entering directory `/home/tibbs/fvwm/modules'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/home/tibbs/fvwm/modules'
make[2]: Leaving directory `/home/tibbs/fvwm/modules'
Making all in bin
make[2]: Entering directory `/home/tibbs/fvwm/bin'
cd .. \
  && CONFIG_FILES=bin/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating bin/Makefile
make[2]: Leaving directory `/home/tibbs/fvwm/bin'
make[2]: Entering directory `/home/tibbs/fvwm/bin'
cd .. && CONFIG_FILES=bin/fvwm-config CONFIG_HEADERS= /bin/sh ./config.status
creating bin/fvwm-config
cd .. && CONFIG_FILES=bin/fvwm-bug CONFIG_HEADERS= /bin/sh ./config.status
creating bin/fvwm-bug
cd .. && CONFIG_FILES=bin/fvwm-perllib CONFIG_HEADERS= /bin/sh ./config.status
creating bin/fvwm-perllib
cd .. && CONFIG_FILES=bin/fvwm-convert-2.4 CONFIG_HEADERS= /bin/sh ./config.status
creating bin/fvwm-convert-2.4
cd .. && CONFIG_FILES=bin/fvwm-convert-2.6 CONFIG_HEADERS= /bin/sh ./config.status
creating bin/fvwm-convert-2.6
cd .. && CONFIG_FILES=bin/fvwm-menu-xlock CONFIG_HEADERS= /bin/sh ./config.status
creating bin/fvwm-menu-xlock
cd .. && CONFIG_FILES=bin/fvwm-menu-directory CONFIG_HEADERS= /bin/sh ./config.status
creating bin/fvwm-menu-directory
cd .. && CONFIG_FILES=bin/fvwm-menu-desktop CONFIG_HEADERS= /bin/sh ./config.status
creating bin/fvwm-menu-desktop
cd .. && CONFIG_FILES=bin/fvwm-menu-headlines CONFIG_HEADERS= /bin/sh ./config.status
creating bin/fvwm-menu-headlines
make[2]: Leaving directory `/home/tibbs/fvwm/bin'
Making all in utils
make[2]: Entering directory `/home/tibbs/fvwm/utils'
cd .. \
  && CONFIG_FILES=utils/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating utils/Makefile
make[2]: Leaving directory `/home/tibbs/fvwm/utils'
make[2]: Entering directory `/home/tibbs/fvwm/utils'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/tibbs/fvwm/utils'
Making all in perllib
make[2]: Entering directory `/home/tibbs/fvwm/perllib'
cd .. \
  && CONFIG_FILES=perllib/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating perllib/Makefile
make[2]: Leaving directory `/home/tibbs/fvwm/perllib'
make[2]: Entering directory `/home/tibbs/fvwm/perllib'
Making all in FVWM
make[3]: Entering directory `/home/tibbs/fvwm/perllib/FVWM'
cd ../.. \
  && CONFIG_FILES=perllib/FVWM/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating perllib/FVWM/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/perllib/FVWM'
make[3]: Entering directory `/home/tibbs/fvwm/perllib/FVWM'
Making all in Module
make[4]: Entering directory `/home/tibbs/fvwm/perllib/FVWM/Module'
cd ../../.. \
  && CONFIG_FILES=perllib/FVWM/Module/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating perllib/FVWM/Module/Makefile
make[4]: Leaving directory `/home/tibbs/fvwm/perllib/FVWM/Module'
make[4]: Entering directory `/home/tibbs/fvwm/perllib/FVWM/Module'
make[4]: Nothing to be done for `all'.
make[4]: Leaving directory `/home/tibbs/fvwm/perllib/FVWM/Module'
make[4]: Entering directory `/home/tibbs/fvwm/perllib/FVWM'
cd ../.. && CONFIG_FILES=perllib/FVWM/Module.pm CONFIG_HEADERS= /bin/sh ./config.status
creating perllib/FVWM/Module.pm
make[4]: Leaving directory `/home/tibbs/fvwm/perllib/FVWM'
make[3]: Leaving directory `/home/tibbs/fvwm/perllib/FVWM'
Making all in General
make[3]: Entering directory `/home/tibbs/fvwm/perllib/General'
cd ../.. \
  && CONFIG_FILES=perllib/General/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating perllib/General/Makefile
make[3]: Leaving directory `/home/tibbs/fvwm/perllib/General'
make[3]: Entering directory `/home/tibbs/fvwm/perllib/General'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/tibbs/fvwm/perllib/General'
make[3]: Entering directory `/home/tibbs/fvwm/perllib'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/home/tibbs/fvwm/perllib'
make[2]: Leaving directory `/home/tibbs/fvwm/perllib'
Making all in docs
make[2]: Entering directory `/home/tibbs/fvwm/docs'
cd .. \
  && CONFIG_FILES=docs/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating docs/Makefile
make[2]: Leaving directory `/home/tibbs/fvwm/docs'
make[2]: Entering directory `/home/tibbs/fvwm/docs'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/tibbs/fvwm/docs'
Making all in rpm
make[2]: Entering directory `/home/tibbs/fvwm/rpm'
cd .. \
  && CONFIG_FILES=rpm/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating rpm/Makefile
make[2]: Leaving directory `/home/tibbs/fvwm/rpm'
make[2]: Entering directory `/home/tibbs/fvwm/rpm'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/tibbs/fvwm/rpm'
Making all in sample.fvwmrc
make[2]: Entering directory `/home/tibbs/fvwm/sample.fvwmrc'
cd .. \
  && CONFIG_FILES=sample.fvwmrc/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating sample.fvwmrc/Makefile
make[2]: Leaving directory `/home/tibbs/fvwm/sample.fvwmrc'
make[2]: Entering directory `/home/tibbs/fvwm/sample.fvwmrc'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/tibbs/fvwm/sample.fvwmrc'
Making all in tests
make[2]: Entering directory `/home/tibbs/fvwm/tests'
cd .. \
  && CONFIG_FILES=tests/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating tests/Makefile
make[2]: Leaving directory `/home/tibbs/fvwm/tests'
make[2]: Entering directory `/home/tibbs/fvwm/tests'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/tibbs/fvwm/tests'
make[2]: Entering directory `/home/tibbs/fvwm'
make[2]: Leaving directory `/home/tibbs/fvwm'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/tibbs/fvwm'
make: *** [all-recursive-am] Error 2
make: Target `all' not remade because of errors.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mattias Andersson <[email-masked]>
Date: Tue, 10 Sep 2002 17:59:46 +0200

Before I succeded to compile everything I checked carefully all
libraries and that the kernel source with links were intsalled.
You seem to be missing GDK libs and certain Gnome libs.
And also Freetype2, check at their site for info. After a few tips
from this list it worked. Even on a Mac (LinuxPPC)!
Thanks all!

Mattias Andersson, Falun Sweden

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 10 Sep 2002 16:32:48 +0000

> from this list it worked. Even on a Mac (LinuxPPC)!

Yes, it usually compiles fine, but not for the last 5 days.
It is ok to get all "no" answers in the list of the supported features.

These are automatical messages meaning the daily snapshot was not built.
Unless there are local problems on that system (disk full, no more
processes, network errors) they indicate C or Makefile errors in cvs.

I bet, even on a Mac with GNOME you can't build the today's cvs code. :)

Regards,
Mikhael.