Subject: CVS migo: * ImagePath now supports directories in form "/some/directory;.png"

From: FVWM CVS <[email-masked]>
Date: Sat, 21 Sep 2002 16:12:00 -0500

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	migo	02/09/21 16:12:00

Modified files:
	.              : ChangeLog NEWS 
	fvwm           : cursor.c execcontext.h fvwm.1.in 
	                 module_interface.c 
	libs           : Picture.c PictureBase.c System.c 
	modules        : ChangeLog 
	modules/FvwmPager: x_pager.c 

Log message:
* ImagePath now supports directories in form "/some/directory;.png"
_ (where semicolon delimits a file extension that all files in
_  /some/directory have.  This file extension replace the original
_  image extension (if any) or it is added if an image has no one.
* FvwmPager: don't send end-of-line in SendText
* execcontext.h: use 'M' for EXCT_MODULE not 'O', use 'I'nit for EXCT_NULL
* minor reindentation in other files

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 21 Sep 2002 21:36:45 +0000

> _  image extension (if any) or it is added if an image has no one.

This is useful for users that converted KDE and GNOME images to .xpm
in the past, but now may use the original .png images without changing
their xpm based configuration, except for one ImagePath line.

This is also useful for wm-icons. In fact this is the only way the next
wm-icons version (that includes some icon sets in .xpm and some in .png)
may work. Here are examples.

  ImagePath $HOME/.wm-icons:$HOME/.wm-icons;.png
  Style XTerm Icon norm/terminal.xpm, MiniIcon mini/terminal.xpm

The following files are searched with this config:

  $HOME/.wm-icons/norm/terminal.xpm
  $HOME/.wm-icons/norm/terminal.png
  $HOME/.wm-icons/mini/terminal.xpm
  $HOME/.wm-icons/mini/terminal.png

It is now even possible to supress the file extension at all if all
directories in ImagePath define their extensions:

  ImagePath /some/dir;.png:/some/dir;.xbm:/another/dir;.xpm
  AddMenu SomeMenu "%calculator%Calculator" Exec xcalc

The following files are searched:

  /some/dir/calculator.png
  /some/dir/calculator.xbm
  /another/dir/calculator.xpm

There is still a logic to search all images twice, once without ".gz"
extension and once with it. I think it is pretty redundant now.
Because this may be done by "ImagePath /my/gzipped/pixmaps;.xpm.gz".
Does anyone think similarly about removing this ".gz" logic?

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Sep 2002 11:08:22 +0200

On Sat, Sep 21, 2002 at 04:12:00PM -0500, fvwm-workers wrote:
> * execcontext.h: use 'M' for EXCT_MODULE not 'O',

Actually, I chose 'O' so that we don't have two 'm', 'M' contexts,
which can be confusing.  That menus still had the lower case 'm'
was a mistake, but I don't care much.

> use 'I'nit for EXCT_NULL

Originally I had a 'startup' context but gave it up because it
could not be defined well.  But calling the NULL context "Init" is
not right.  It applies to many other situations too that are not
even remotely related to initialization.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 23 Sep 2002 09:34:41 +0000

> even remotely related to initialization.

I used these values, just because I use command-log sometimes and for me
I: looks a bit better (and more informative) than -:.

I didn't see any of 'I' other than on startup. Why exec context type would
not be defined after fvwm enters the event loop?

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Sep 2002 12:54:30 +0200

> not be defined after fvwm enters the event loop?

Okay "many" was a bit exaggerated.  Currently, the NULL context is
used:

 * in StartupStuff()
 * in SetRCDefaults()
 * in main() when the cfg file is read
 * in CoerceEnterNotifyOnCurrentWindow()
 * in the CMD_Schedule call in colorset.c
 * in the first PlaceWindow() call when a window is added
 * when the exit function is executed
 * in HandleMapRequestKeepRaised() when calles to create a tear
   off menu
 * when applying window updates in update.c

Only the first four are related to initialization.  I have added
two new contexts for 'I'nit and 'E'xit stuff.

Bye

Dominik ^_^  ^_^