Subject: Style * NoHandles bug?

From: "S. Anderson" <[email-masked]>
Date: Fri, 13 Sep 2002 19:42:26 -0600

When I use Style * NoHandles in my .fvwm2rc, CursorStyle definitions
using xpm don't work anymore, and the border width for windows is set 
to 1 pixel. You can reproduce by putting just the following in your 
.fvwm2rc:

# start
Style * NoHandles
CursorStyle LEFT            /home/sa/.fvwm/cursors/resize_side.xpm
# end

% cat /home/sa/.fvwm/cursors/resize_side.xpm
/* XPM */
static char * resize_side_xpm[] = {
"15 10 3 1 8 5",
"       c None",
".      c #000000",
"o      c #FFFFFF",
"    .     .    ",
"   ..     ..   ",
"  .o.     .o.  ",
" .oo.......oo. ",
".ooooooooooooo.",
".ooooooooooooo.",
" .oo.......oo. ",
"  .o.     .o.  ",
"   ..     ..   ",
"    .     .    "};

I am using todays cvs fvwm, but this bug has been happening for at least
a couple of weeks.

hth,
sa
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 14 Sep 2002 11:59:26 +0000

> CursorStyle LEFT            /home/sa/.fvwm/cursors/resize_side.xpm

I think it worked this way always (2.2.x, 2.4.x).
Without handles it is pretty difficult to determine where a corner
and where starts and ends LEFT.

If you want cursors on borders you may use this:

  Style * Handles
  BorderStyle -- HiddenHandles

Regards,
Mikhael.

---

From: "S. Anderson" <[email-masked]>
Date: Mon, 16 Sep 2002 23:54:29 -0600

>   BorderStyle -- HiddenHandles

ok, I assumed "Style * NoHandles" was supposed to do the same thing as
"BorderStyle -- HiddenHandles", which is what I usualy use.

but, I still think there is some wierdness going on here,
for instance if you do this in FvwmConsole:

Style * BorderWidth 5
Style * NoHandles
CursorStyle LEFT  gumby
#or CursorStyle LEFT resize_side.xpm

Then the border cursors work for all existing windows, but when
you open any new windows, the border cursors don't work on the new
windows only.

Is this how its supposed to work?

thanks,
sa

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 17 Sep 2002 11:04:12 +0200

> Is this how its supposed to work?

No, that's a bug.  When the CursorStyle command is issued, all the
cursors come back.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 17 Sep 2002 12:25:10 +0200

> No, that's a bug.  When the CursorStyle command is issued, all the

Fixed.

Bye

Dominik ^_^  ^_^