Subject: Re: FVWM: FVWM crashes when typing "Q" on Pine

From: Wolfgang Pfeiffer <[email-masked]>
Date: Thu, 12 Sep 2002 03:29:00 +0200 (CEST)

On Sep 8, 2002, 19:55 (-0000) Mikhael Goikhman wrote:

> On 08 Sep 2002 21:38:20 +0200, Wolfgang Pfeiffer wrote:
> >
> > On Sep 8, 2002, 18:59 (-0000) Mikhael Goikhman wrote:
> >
> > > On 08 Sep 2002 20:43:02 +0200, Wolfgang Pfeiffer wrote:
> > > >
> > > > On Sep 8, 2002, 08:51 (-0000) Mikhael Goikhman wrote:
> > > >
> > > > > Can you reproduce the crash with this two line .xinirc:
> > > > >
> > > > >   xterm -geometry 92x50+1550+60 -e /usr/bin/pine &
> > > > >   /usr/bin/fvwm -cmd 'AddToFunc StartFunction I FvwmPager'
> > > >
> > > > these 2 lines when starting fvwm or fvwm-themes-start ?
> > >
> > > The second line already starts fvwm in foreground, don't put any other
> > > lines into ~/.xinitrc except for maybe "sleep 3" in the middle.
> >
> > The same as with the old .xinitrc: XCrash if I type a 'q' on Pine in
> > an xterm
>
> So this happens with no config at all. Fine. Forget fvwm-themes for now.
>
> Please recompile 2.5.3 from sources and install it (say into /usr/local).
> Then run the same 2 line .xinitrc, but with /usr/local/bin/fvwm instead.
> When you get core, run "gdb /usr/local/bin/fvwm core" and then "where".
> Send the stack trace (5-20 lines), preferably to [email-masked].
> Thank you very much.
>
> Regards,
> Mikhael.

OK: I installed FVWM from source to the default directories with:
./configure
 make
 make check (not being sure whether this was useful .. :)
 make install

I didn't touch any config.files for the build: just ran the 4 commands
from above. Didn't even install fribidi from source (tho there is
fribidi installed from an RPM ...)

then running:

###########################################
$ gdb /usr/local/bin/fvwm core
GNU gdb 19991004
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and
you are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for
details.
This GDB was configured as "i386-redhat-linux"...
Core was generated by `/usr/local/bin/fvwm -cmd AddToFunc
StartFunction I FvwmPager'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/X11R6/lib/libXpm.so.4...done.
Reading symbols from /usr/lib/libstroke.so.0...done.
Reading symbols from /usr/X11R6/lib/libSM.so.6...done.
Reading symbols from /usr/X11R6/lib/libICE.so.6...done.
Reading symbols from /usr/X11R6/lib/libXext.so.6...done.
Reading symbols from /usr/X11R6/lib/libX11.so.6...done.
Reading symbols from /lib/libm.so.6...done.
Reading symbols from /usr/lib/libpng.so.2...done.
Reading symbols from /usr/lib/libz.so.1...done.
Reading symbols from /lib/libc.so.6...done.
Reading symbols from /lib/ld-linux.so.2...done.
Reading symbols from /usr/lib/gconv/ISO8859-1.so...done.
#0  0x80a590c in FlocaleFreeNameProperty (ptext=0x80effe8) at
Flocale.c:1569
---Type <return> to continue, or q <return> to quit---
1569                    if (ptext->name != NULL && ptext->name !=
*ptext->name_list)
(gdb) where
#0  0x80a590c in FlocaleFreeNameProperty (ptext=0x80effe8) at
Flocale.c:1569
#1  0x8074355 in free_window_names (fw=0x80effe0, nukename=0,
nukeicon=1)
    at add_window.c:2812
#2  0x8072651 in destroy_icon (fw=0x80effe0) at add_window.c:1255
#3  0x80744bd in destroy_window (fw=0x80effe0) at add_window.c:2915
#4  0x8070141 in HandleUnmapNotify () at events.c:3228
#5  0x80703a1 in DispatchEvent (preserve_Fw=0) at events.c:3358
#6  0x8070432 in HandleEvents () at events.c:3413
#7  0x808398a in main (argc=3, argv=0xbffffa64) at fvwm.c:2251
(gdb)

##############################################
Hoping it helps

Wolfgang

-- 
Key on: http://home.t-online.de/home/520050060325-0001/
Key fingerprint = 5FFA E2D1 6DB5 C023 0C5F  3FA7 4E08 5F9F 1560 0BA8

Home Page: www.geocities.com/wolfgangpfeiffer/

                            -- END TRANSMISSION --

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 12 Sep 2002 11:14:23 +0200

> fribidi installed from an RPM ...)
[snip]
> #7  0x808398a in main (argc=3, argv=0xbffffa64) at fvwm.c:2251

The DeferExecution() function is trashing memory.  I ran into the
same problem yesterday and have hopefully fixed it in current CVS.
(But be aware that fvwm will probably crash anyway.)

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Wolfgang Pfeiffer <[email-masked]>
Date: Thu, 12 Sep 2002 19:01:50 +0200 (CEST)

> (But be aware that fvwm will probably crash anyway.)

... I didn't find any explanations on how to use CVS when searching
on:
ftp://ftp.fvwm.org/pub/fvwm/devel/sources/

But is the fix for the problem already built into
ftp://ftp.fvwm.org/pub/fvwm/devel/snapshots/fvwm-snap-20020912.tar.gz
??

Or are there so many more instabilities (additional to the ones that
are already in 2.5.3) that it doesn't make much sense to install a
snapshot?

In case someone is answering: If you please Cc me to my private email
address, too: I'm not on the fvwm-workers list.

Best regards
Wolfgang

                            -- END TRANSMISSION --

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 12 Sep 2002 19:24:39 +0200

> ftp://ftp.fvwm.org/pub/fvwm/devel/sources/

  Look on our web site:  http://fvwm.org/cvs.html

> ftp://ftp.fvwm.org/pub/fvwm/devel/snapshots/fvwm-snap-20020912.tar.gz

I'm not sure, but the fix will be in the next snapshot.

> are already in 2.5.3) that it doesn't make much sense to install a

It makes sense to try it out, but not to use it on your system.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Wolfgang Pfeiffer <[email-masked]>
Date: Thu, 12 Sep 2002 20:17:44 +0200 (CEST)

Dominik,
Thanks for your fast answer:

>   Look on our web site:  http://fvwm.org/cvs.html

I'll have a look at it ..

> > ftp://ftp.fvwm.org/pub/fvwm/devel/snapshots/fvwm-snap-20020912.tar.gz

I just tried to build an RPM/SRC.RPM from this snapshot (I have, as,
IIRC, previously told in this thread, RedHat 6.2 here): it didn't
work:

##########################
error: Bad exit status from /var/tmp/rpm-tmp.79583 (%build)

RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.79583 (%build)
###########################

> I'm not sure, but the fix will be in the next snapshot.

let's hope it builds RPM's here :)

> It makes sense to try it out, but not to use it on your system.

Ummmh, you probably mean: not trying it in a production environment
or so, right? I mean, I have just one machine here, so I'll install it
on this one or nowhere ... :)

But at any rate: I will try to build and install the RPM.

Best regards
Wolfgang

Please reply to: [email-masked]
-- 
Key on: http://home.t-online.de/home/520050060325-0001/
Key fingerprint = 5FFA E2D1 6DB5 C023 0C5F  3FA7 4E08 5F9F 1560 0BA8

                            -- END TRANSMISSION --

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 12 Sep 2002 21:59:44 +0200

> IIRC, previously told in this thread, RedHat 6.2 here): it didn't

Actually I wanted to say:  expect trouble and be prepared to
downgrade to a more stable release.

Bye

Dominik ^_^  ^_^