Subject: Notification: incoming/925

From: [email-masked]
Date: Sat, 21 Sep 2002 10:04:09 -0500

FVWM Bug Tracking notification

new message incoming/925

Message summary for PR#925
	From: [email-masked]
	Subject: Key binding problem
	Date: Sat, 21 Sep 2002 10:04:06 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Sat Sep 21 10:04:09 2002
From: [email-masked]
To: [email-masked]
Subject: Key binding problem
Date: Sat, 21 Sep 2002 10:04:06 -0500

Full_Name: Jens Thoms Törring
Version: 2.4.0
CVS_Date: 
OS: Linux
X_Server: XF86
Submission from: (NULL) (62.104.208.78)

Hi,

What I found isn't actually a bug but more king of an annoyance:
I can't bind keys like XF86AudioRaiseVolume or XF86AudioLowerVolume.
The reason is simple: in bindings.c in function ParseBinding() the
maximum length of a key name is restricted to 19 characters (plus one
for the trailing '\0'. But both the key names are already 20 chars
long.

A patch is simple: increase the size of the char array key in
ParseBinding() to e.g. 0 and allow lengths of up to 29 characters,
i.e. change the line
 n1 = sscanf(token,"%19s",key)
to
 n1 = sscanf(token,"%29s",key)

As far as I can see this breaks nothing and testing results in
correct key bindings also for unusually long key names.

                                    Regards, Jens

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 21 Sep 2002 17:38:02 +0000

> correct key bindings also for unusually long key names.

This is already fixed in 2.4.6. Try fvwm-2.4.11.

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 21 Sep 2002 17:56:48 +0000

Hmm, forgot to add "<reporter.email.address>". :)

It is pretty tricky to reply to bug messages, because:

  1) The reporter name and his email are in 2 different places.
     Would be nice if the summary include From: Reporter Name <[email-masked]>

  2) The subject line is overwritten by "Notification:" line, it would be
     better if the original subject is not changed (probably prepended
     with a short "Bug #id: ").

Jason, is it possible to tweak the script to do these 2 simple things?

I have forwarded the parent message to Jens.Toerring.

Regards,
Mikhael.

---

From: Jason L Tibbitts III <[email-masked]>
Date: 21 Sep 2002 14:24:30 -0500

>>>>> "MG" == Mikhael Goikhman <[email-masked]> writes:

MG> Jason, is it possible to tweak the script to do these 2 simple
MG> things?

There's no simple script; these messages are generated by Jitterbug.
I'm not really a C programming expert, but I'll be happy to look at a
patch if you care to send me one.

 - J<

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Sep 2002 13:07:52 +0200

> This is already fixed in 2.4.6. Try fvwm-2.4.11.

Anyway, to have some more safety in the future I have increased
the number of allowed letters in a key name to 200.  It may never
be necessary, but if it is we can save us another bug report.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]