Subject: Style * IconSize...

From: "S. Anderson" <[email-masked]>
Date: Wed, 18 Sep 2002 18:00:25 -0600

greetings.
I might have some bugs for you guys.

Using fvwm 2.5.4 (from cvs) updated on Sep 18 2002
with support for: ReadLine, XPM, PNG, GNOME WM hints, EWMH hints, Shape,
SM, Xinerama, XFT

First of all when I issue a "Style * IconSize 64 64" in FvwmConsole
nothing happens, to get it to work I have to put it in my .fvwm2rc
and restart, not sure if its supposed to work like that.

When I use a png Icon that is smaller than the IconSize, The png Icon
gets messed up.

You can reproduce this by putting just the following in your .fvwm2rc
(test.png attached to this mail)

Style * IconSize 64 64
Style * icon test.png
Mouse 0 2 A Iconify
Mouse 0 I A Iconify

thanks,
sa

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 19 Sep 2002 00:29:41 +0000

> and restart, not sure if its supposed to work like that.

It requires Recapture.

> When I use a png Icon that is smaller than the IconSize, The png Icon

Yes, I also saw this. But only if png has alpha channel, non-transparent
pngs seem to be ok.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 19 Sep 2002 10:47:52 +0200

> > and restart, not sure if its supposed to work like that.

Then it must be rewritten not to require a recapture.

> Yes, I also saw this. But only if png has alpha channel, non-transparent

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 19 Sep 2002 12:29:36 +0200

> Then it must be rewritten not to require a recapture.

Done.

Bye

Dominik ^_^  ^_^

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 20 Sep 2002 12:00:05 +0200

> When I use a png Icon that is smaller than the IconSize, The png Icon

Fixed in the current cvs.
Regards, Olivier