Subject: locale error messages

From: Dominik Vogt <[email-masked]>
Date: Fri, 20 Sep 2002 16:12:22 +0200

What do these error messages try to tell me:

--
[FvwmButtons][FlocaleSetlocaleForX]: ERROR -- Cannot set locale. Please
check your $LC_CTYPE or $LANG.
[FvwmPager][FlocaleSetlocaleForX]: ERROR -- Cannot set locale. Please
check your $LC_CTYPE or $LANG.
Warning: locale not supported by C library, locale unchanged
[FvwmPager][FlocaleSetlocaleForX]: ERROR -- Cannot set locale. Please
check your $LC_CTYPE or $LANG.
[FvwmIconMan][FlocaleSetlocaleForX]: ERROR -- Cannot set locale. Please
check your $LC_CTYPE or $LANG.
Warning: locale not supported by C library, locale unchanged
--

This is what I have set:

  $ locale
  LANG=C
  LC_CTYPE=de_DE@euro
  ...
  LC_*="C"
  ...
  LC_ALL=

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 21 Sep 2002 07:04:39 +0200

> What do these error messages try to tell me:

It means that the libc function setlocale return a NULL pointer
when it is call as setlocale(LC_TYPE, ""). My libc manual says that:

- Passing "" means to read the appropriate environment variable and use
its value to select the locale for LC_CTYPE.
- If you specify an invalid locale name, `setlocale' returns a null
pointer and leaves the current locale unchanged.

So it seems to me that the locale de_DE@euro is not supported by
your libc. This seems strange and IMHO your system is miss-configured.
Maybe your locale definitions of de_DE@euro (found somewhere
under (/usr/share/locale/) is incomplete or does not match your libc.
Maybe you have upgraded your libc without upgrading your locales
(or inversely).

Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Sep 2002 11:18:34 +0200

> Maybe you have upgraded your libc without upgrading your locales

Sigh!  Today the error message is gone without changing anything.
Might the setlocale function just throw random results from time
to time?

Bye

Dominik ^_^  ^_^