Subject: Active Desk Label

From: Suzanne Skinner <[email-masked]>
Date: Wed, 18 Sep 2002 02:35:44 -0400

The active desk label in the pager is not being hilighted properly at startup
(unless Xft is used?). I think this bug was introduced via the change "Use
clipping redrawing for the desk label" to DrawGrid(), as the hilight
background is never initially drawn.

The attached patch fixes the problem but it's probably overkill :-)

Suzanne

-- 
[email-masked] - http://www.igs.net/~tril/
--- x_pager.c.orig	Wed Sep 18 01:40:57 2002
+++ x_pager.c	Wed Sep 18 01:41:56 2002
@@ -1663,7 +1663,7 @@
 	}
 	if(((Scr.CurrentDesk - desk1) == desk) && !ShapeLabels)
 	{
-		if (uselabel && erase)
+		if (uselabel)
 		{
 			XFillRectangle(
 				dpy,Desks[desk].title_w,Desks[desk].HiliteGC,

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 18 Sep 2002 15:38:36 +0200

> The attached patch fixes the problem but it's probably overkill :-)

No, no it is ok, applied.
Thanks, Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]