Subject: CVS dane: * FvwmCpp/FvwmCpp.1:

From: FVWM CVS <[email-masked]>
Date: Fri, 13 Sep 2002 07:45:24 -0500

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	dane	02/09/13 07:45:24

Modified files:
	docs           : ChangeLog FAQ 
	modules        : ChangeLog 
	modules/FvwmCpp: FvwmCpp.1 
	modules/FvwmM4 : FvwmM4.1 

Log message:
* FvwmCpp/FvwmCpp.1:
* FvwmM4/FvwmM4.1: New way to present module synopsis,
more prominent discussion of ModuleSynchronous.
* FAQ: Update 4.3 for ModuleSynchronous vs. FvwmM4/Cpp.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Fri, 13 Sep 2002 08:49:54 -0400

> * FvwmM4/FvwmM4.1: New way to present module synopsis,

I think I finally figured out a better way to present the
SYNOPSIS for modules.  The old wording always confused me.
I'll propagate the change to the other modules after a few days
if there are no objections.

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 13 Sep 2002 13:31:38 +0000

> if there are no objections.

I have no objections. I think the old way was choosen, because
the section (1) of manual pages contains commands supposed to be run
from the command line. Probably, the original intend was to do this.
But since this is not possible, at least currently, it makes sense
to move module man pages to section (3) or (4) or (11).

Actually the following info that was removed from FAQ worths mentioning
somewhere (I don't know where, the original place seems ok):

  fvwm -cmd "FvwmCpp .fvwmrc.cpp"

  Version 2.4 has a more compete fix that makes the above line work
  reliably: any module started by command line arguments is assumed to be
  a module that sends back config commands.  All command line modules
  have to quit before fvwm will proceed on to the InitFunction and
  setting border decorations and styles.  There is a potential deadlock
  if you start a module other than FvwmCpp/FvwmM4 but there is a timeout
  so fvwm will eventually get going.

I knew that starting the pager this way hangs fvwm, and this works:

  fvwm -cmd "AddToFunc StartFunction I FvwmPager"

But the reason for this was not obvious. I am not sure this is a very
good functionality, since there is a synchronous way to run FvwmCpp.
But I myself don't use -cmd except for tests.

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Fri, 13 Sep 2002 10:08:59 -0400

> to move module man pages to section (3) or (4) or (11).

Interesting point about the manual sections.

I suppose using a different section
would be technically correct, but I don't know if it would
add any information for the average end user.
Especially since no particular section seems to apply.

I don't think modules were ever intended to be invoked
from the command line.  (FvwmCommand (not really a module)
is pretty recent.)  

> But I myself don't use -cmd except for tests.

I didn't see any description of this in the fvwm man page, so
I put it there.  It didn't seem to be necessary for question 4.3
in the FAQ.

On a related note, I think documenting module invocation
without the "Module" keyword is confusing to the beginner,
so I'm trying to remedy that.