Subject: CVS migo: * Enhanced commands [Add]ButtonStyle, [Add]TitleStyle. ButtonState.

From: FVWM CVS <[email-masked]>
Date: Tue, 03 Sep 2002 14:01:39 -0500

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	migo	02/09/03 14:01:39

Modified files:
	.              : ChangeLog NEWS 
	fvwm           : borders.c builtins.c fvwm.1.in fvwm.c screen.h 
	libs           : defaults.h 

Log message:
* Enhanced commands [Add]ButtonStyle, [Add]TitleStyle. ButtonState.

Titles and buttons now have 4 main states instead of 3: ActiveUp,
ActiveDown, InactiveUp and InactiveDown, plus 4 Toggled variants.
Several shortcuts added: Active means ActiveUp + ActiveDown,
Inactive means InactiveUp + InactiveDown, similarly for shortcuts
ToggledActive and ToggledInactive.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 3 Sep 2002 19:28:58 +0000

> ToggledActive and ToggledInactive.

Having only one inactive title and button state is, of course, incomplete
for windows that never take focus, like xclock, or for NeverFocus windows.

So states in ButtonStyle and TitleStyle are fully symmetrical now; states
are symmetrical in BorderStyle too with only 2 names Active and Inactive.
This enhancement is backward compatible.

ButtonStyle and TitleStyle accept now 6 main state names and 6 Toggled
state names, a plus denotes the new name:

  ActiveUp
  ActiveDown
+ Active
+ InactiveUp
+ InactiveDown
  Inactive
  ToggledActiveUp
  ToggledActiveDown
+ ToggledActive
+ ToggledInactiveUp
+ ToggledInactiveDown
  ToggledInactive

Regards,
Mikhael.