Subject: CVS migo: * vpacket.h: fixed buggy MiniIconPacket definition: s/char *name/char name[1]/

From: FVWM CVS <[email-masked]>
Date: Fri, 20 Sep 2002 15:43:14 -0500

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	migo	02/09/20 15:43:14

Modified files:
	.              : ChangeLog 
	libs           : vpacket.h 
	modules        : ChangeLog 
	modules/FvwmGtk: FvwmGtk.c 
	perllib        : ChangeLog 
	perllib/FVWM   : Event.pm EventNames.pm Module.pm.in 
	tests/random   : randomsc.db 

Log message:
* vpacket.h: fixed buggy MiniIconPacket definition: s/char *name/char name[1]/
* FvwmGtk: reindented; use MiniIconPacket again, since it does not core dumps
* perllib: reworked internal event object implementation

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 20 Sep 2002 20:50:28 +0000

> 	s/char *name/char name[1]/

Some profiling tools may complain, I guess, but this is probably better
than the trailing char name[BIG_NUMBER] in text-based packets.

Not that this is actually used in modules currently.

Regards,
Mikhael.