Subject: Notification: incoming/912

From: [email-masked]
Date: Thu, 08 Aug 2002 08:20:41 -0500

FVWM Bug Tracking notification

new message incoming/912

Message summary for PR#912
	From: [email-masked]
	Subject: _NET_WM_DESKTOP ignored for initial placement
	Date: Thu, 08 Aug 2002 08:20:40 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Thu Aug 08 08:20:41 2002
From: [email-masked]
To: [email-masked]
Subject: _NET_WM_DESKTOP ignored for initial placement
Date: Thu, 08 Aug 2002 08:20:40 -0500

Full_Name: Matthias Clasen
Version: 
CVS_Date: 
OS: 
X_Server: 
Submission from: (NULL) (195.243.100.246)

Metacity recently started handling the WM_Sn manager selection, so I 
took the opportunity to test the handshaking between metacity and fvwm
2.5.2.
Works nice in general, but for one thing: 

When fvwm takes over from metacity, it seems to ignore the _NET_WM_DESKTOP
properties left behind by metacity. Worse, windows which are not on the
first desk sometimes get completely lost - they don't appear on any desk,
but switching back to metacity makes them reappear at the right position.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 8 Aug 2002 19:26:23 +0200

> but switching back to metacity makes them reappear at the right position.

Could you point me to the spec and the specific place that states
how the _NET_WM_DESTOP property should be handled?  I'd assume the
window manager is resposible of deleting this property from the
client window and map all windows on all desks when it terminates.
How else should the WM find out about windows that are not mapped
when it starts and that are never mapped by the application?

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: 08 Aug 2002 23:34:38 +0200

> when it starts and that are never mapped by the application?

Yes, the leaving WM is responsible for mapping all windows (actually I
think this is automatic as part of save-set handling). The CVS version 
of the EWMH 1.2 draft (still not available online...) specifies that 
the _NET_WM_DESKTOP and _NET_WM_STATE properties should be cleared upon
withdrawal of a window, but left in place in case of loosing ownership
of the manager selection, so that the next wm can pick them up.

Matthias

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 9 Aug 2002 11:15:08 +0200

> of the manager selection, so that the next wm can pick them up.

So, is the "windows don't appear on any desk" part a bug or not?

Bye

Dominik ^_^  ^_^