Subject: Re: xview program resize delay

From: Dominik Vogt <[email-masked]>
Date: Wed, 21 Aug 2002 10:35:29 +0200

On Tue, Aug 20, 2002 at 11:43:03AM -0700, elliot sowadsky wrote:
> 
> < > Hmmm....on the 20020817 snap, i'm finding that on opening new windows, i'm
> < > getting blocked from focusing windows. No matter what i click into, it wont
> < > take focus.
> 
> < You need the next snapshot.  I fixed/implemented both only
> < yesterday.
> 
> Same problem in 20020820.
> Turns out i need a <Modifier>click to get focus after a map.
> Using clicktofocus mode.

Let's keep any further discussion on the list, please.  The focus
code is changing rapidly at the moment.  It makes little sense for
me to get reports about the snapshots because most of the time the
buggy code has already changed.  Could you switch to using 

> The ShowPage thing (just left of title) shows either 0 or nothing,
> w/ no correlation to which page it's on or stickyness.

The layout is:

  <hotkey>  <window name>  desk@screen+pagex+pagey(layer):geometry

To enable the pagex/y display use ShowPage:

  WindowList ShowPage, ... (other options)

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 23 Aug 2002 10:46:39 +0200

On Thu, Aug 22, 2002 at 12:24:34PM -0700, elliot sowadsky wrote:
> 
> >From man...
> 
> <<
> NoGeometryWithInfo  removes the geometries, but keep the desktops
> information
> >>
> 
> 
> It doesnt keep the desktops information.

The "x:" printed before the window name is the desk number.

> It seems to do the same as NoGeometry.

P.S.: Please keep the mail on the list.

Bye

Dominik ^_^  ^_^

---

From: elliot sowadsky <[email-masked]>
Date: Fri, 23 Aug 2002 15:00:07 -0700 (PDT)

<<
> Turns out i need a <Modifier>click to get focus after a map.

Traced this to focus.c __check_allow_focus

xview appears to want to refuse focus in order to get focus. (?)
xview window often has sf == NULL.

Hence __check_allow_focus returns True and xview window doesnt get focus.

I added

if (sf == NULL) return False;  // xview may have this condition

Well, this isnt quite right.
tk also has nulls.

But this seems to be better...

Fix the window does not want focus line in __check_allow_focus to look like
this...

	if (!FP_IS_LENIENT(FW_FOCUS_POLICY(fw)) && !focus_does_accept_input_focus(fw) && (sf == NULL || sf->Desk == Scr.CurrentDesk))