Subject: Re: The "great focus policy rewrite"

From: Giuseppe Della Ricca <[email-masked]>
Date: Sun, 11 Aug 2002 14:18:15 +0200 (CEST)

Hi Dominik,

> THe new code is in place.  In the current state it should behave
> exactly like the old code, so please report any oddities, even
> minor changes in behaviour.

ok, since you asked ... ;-)

I've just updated from CVS, and I have a problem with ClickToFocus:

Style * ClickToFocus
ClickTime 150

Mouse 1         R       A       Menu Root-Menu
Mouse 2         R       A       Menu Window-Ops
Mouse 3         R       A       WindowList

Mouse 1         FS      A       Resize-or-Raise
Mouse 1         IT      A       Move-or-Raise
Mouse 1         W       M       Move-or-Raise
Mouse 2         I       A       Iconify

DestroyFunc Move-or-Raise
AddToFunc Move-or-Raise         I Raise
+                               M Move

DestroyFunc Resize-or-Raise
AddToFunc Resize-or-Raise       I Raise
+                               M Resize

before the GFPR I used to be able to focus _and_ raise any window by 
clicking anywhere inside it

now, the window is focussed but not raised any more (I have the same focus 
options for all my windows)

also, to do the paste of a 'cut-and-paste' between two xterm windows now I 
need 2 clicks (the first changes the focus, the second is the real paste)

I can partly solve this defining

Mouse 1         W       A       Raise

but then I loose the ability to paste ...

Another possibility is 'FvwmAuto 0', but this does not solve the problem 
of the additional 'click' needed to paste.

Let me know if I can be of some help in solving these problems.

Please CC: for a faster answer, since I'm not on the list.

cheers,
Giuseppe.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Giuseppe Della Ricca <[email-masked]>
Date: Sun, 11 Aug 2002 18:14:06 +0200 (CEST)

Hi Dominik,

> Fixed.

no, I'm sorry, I don't think so ...

the windows are focussed after I click in them ('W') but not raised

if I start 'FvwmAuto 0' I get what I was used to have, though ...

> Fixed.

YES !

> These are not really bugs in the code, but wrong default settings
> for the four predifined focus policies.  It's a bit difficult to
> get all of these right so that there is no change in behaviour.
> 
> When the work is done, it must not be necessary to change existing
> configurations (except perhaps in a few *very* strange setups).

Please feel free to fix it when you think is appropriate !
There's no hurry !!

but there's a new thing now: 4 more buttons, 2 on the left and 2 on the 
right in each window title .... I already have 3+3 buttons, so the corners 
are really crowded now ... ;-)

(I'm always restarting fvwm using 'kill -USR1')

cheers,
Giuseppe.