Subject: re: xview program resize delay/windowlist

From: elliot sowadsky <[email-masked]>
Date: Tue, 27 Aug 2002 10:41:20 -0700 (PDT)

<<
> if (sf == NULL) return False;  // xview may have this condition

Ahem, this effectively prevents that any window not using the
WM_TAKES_FOCUS protocol ever gets focus unless another window is
already focused.

Have you looked at my newer fix i sent?

focus.c

changed if (!FP_IS_LENIENT(FW_FOCUS_POLICY(fw)) && !focus_does_accept_input_focus(fw) && sf == NULL && sf->Desk == Scr.CurrentDesk)

to

if (!FP_IS_LENIENT(FW_FOCUS_POLICY(fw)) && !focus_does_accept_input_focus(fw) && (sf == NULL || sf->Desk == Scr.CurrentDesk))

For windowlist, how about using a user-defined format list instead of the
present if/then/else tree?

For instance, mine would be

Windowlist Hotkey " " Flags Pagex " " Class Name 

The " " are for me to insert an extra space, but they could be any literal

Flags:
S for sticky, I for iconic, correct # of spaces to keep later fields aligned
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 28 Aug 2002 11:05:59 +0200

> Have you looked at my newer fix i sent?

Yes, but the old code and the patched code both look weird and
wrong.  I want to see the problem myself before doing anything
(please provide the necessary config/instructions).

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]