Subject: Core dump in FvwmIconBox

From: Tim Phipps <[email-masked]>
Date: Wed, 28 Aug 2002 12:40:29 +0100

Hi All,
    I was just trying to have a look at the new spangly mozilla icons 
and found a core dump in FvwmIconBox. Patch attached.

Cheers,
Tim.

Index: modules/ChangeLog
===================================================================
RCS file: /u/phippst/share/cvsroot/fvwm/modules/ChangeLog,v
retrieving revision 1.31
diff -u -r1.31 ChangeLog
--- modules/ChangeLog	2002/08/27 11:46:33	1.31
+++ modules/ChangeLog	2002/08/28 11:32:24
@@ -1,3 +1,7 @@
+2002-08-28  Hippo
+	* FvwmIconBox/icons.c:
+	Fixed core dump
+	
 2002-08-26  Mikhael Goikhman  <[email-masked]>
 
 	* FvwmButtons/dynamic.c:
Index: modules/FvwmIconBox/icons.c
===================================================================
RCS file: /u/phippst/share/cvsroot/fvwm/modules/FvwmIconBox/icons.c,v
retrieving revision 1.7
diff -u -r1.7 icons.c
--- modules/FvwmIconBox/icons.c	2002/08/14 13:14:57	1.7
+++ modules/FvwmIconBox/icons.c	2002/08/28 11:28:31
@@ -236,9 +236,15 @@
  ****************************************************************************/
 void GetIconFromFile(struct icon_info *item)
 {
-	char *path = NULL;
+	char *path = PictureFindImageFile(item->icon_file, imagePath, R_OK);
 	FvwmPictureAttributes fpa;
 
+	if (NULL == path)
+	{
+		fprintf(stderr, "[FvwmIconBox] cannot find %s on ImagePath %s\n",
+			item->icon_file, imagePath);
+		return;
+	}
 	fpa.mask = FPAM_NO_ALLOC_PIXELS; /* olicha why ? */
 	if (Iconcolorset >= 0 && Colorset[Iconcolorset].do_dither_icon)
 	{

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 28 Aug 2002 13:49:36 +0200

> and found a core dump in FvwmIconBox. Patch attached.

CVS, or 2.4.x or both?

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Wed, 28 Aug 2002 13:02:33 +0100

>CVS, or 2.4.x or both?
CVS, but it might be in older releases

Cheers,
Tim.