Subject: Crash with Multiple IconBox's

From: "S. Anderson" <[email-masked]>
Date: Mon, 12 Aug 2002 04:27:17 -0600

Hi,
I just updated to test the latest cvs fvwm. I can get fvwm to crash if I
issue this:
Style * IconBox 0 -0 620 -1, IconBox 0 -170 640 60, IconBox 0 -270 640 60

It looks like style.c is being worked on, so you probably already know
about this :-), thought I would report it anyway.

cya,
sa

(gdb) backtrace
#0  0x0805d61c in style_parse_icon_box_style (ret_ib=0xbffff074, 
    option=0x80d6880 "60", rest=0x8112217 "", ps=0x81125a8) at style.c:1344
#1  0x0805f1ba in style_parse_one_style_option (token=0x80d6880 "60", 
    rest=0x811220a "0 -170 640 60", ps=0x81125a8) at style.c:2310
#2  0x0806105c in parse_and_set_window_style (
    action=0x811258c " IconBox 0 -270 640 60", ps=0x1) at style.c:3639
#3  0x08061bc4 in CMD_Style (cond_rc=0x0, eventp=0x80d8020, w=104, fw=0x0, 
    context=8, 
    action=0x8112560 "IconBox 0 -0 620 -1,  IconBox 0 -170 640 60, IconBox 0 -270 640 60", Module=0xbffff1f8) at style.c:4388
#4  0x0808650c in execute_function (efa=0xbffff1e0) at functions.c:915
#5  0x080867bf in old_execute_function (cond_rc=0x0, action=0x0, fw=0x0, 
    eventp=0x0, context=0, Module=0, exec_flags=0 '\000', args=0x0)
    at functions.c:1000
#6  0x080934e0 in run_command_stream (f=0x80cc874, eventp=0x80d8020, fw=0x0, 
    context=8, Module=1) at read.c:143
#7  0x08093674 in run_command_file (
    filename=0x80d9b70 "Veranda:minspace=True:pixelsize=14,-schumacher-clean-medium-r-normal-*-*-120-*-*-c-*-iso646.1991-irv:encoding=ISO8859-1", eventp=0x0, 
    fw=0x0, context=0, Module=0) at read.c:218
#8  0x0808f00f in main (argc=1, argv=0xbffff1e0) at fvwm.c:2182
#9  0x4022f142 in __libc_start_main () from /lib/libc.so.6

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 12 Aug 2002 12:39:30 +0200

> about this :-), thought I would report it anyway.

Fixed.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]