Subject: MenuFace TiledPixmap (patch)

From: Suzanne Skinner <[email-masked]>
Date: Sat, 24 Aug 2002 16:12:18 -0400

Developers,

Here's a patch for the MenuFace TiledPixmap bug that I submitted yesterday :-)

Suzanne

-- 
[email-masked] - http://www.igs.net/~tril/
--- fvwm/menus.c.orig	Sat Aug 24 13:45:58 2002
+++ fvwm/menus.c	Sat Aug 24 13:48:36 2002
@@ -4155,6 +4155,8 @@
 		/* be smart about handling the expose, redraw only the entries
 		 * that we need to */
 		if (pevent == NULL ||
+                    (ms && (ST_FACE(ms).type == PixmapMenu ||
+                            ST_FACE(ms).type == TiledPixmapMenu)) ||
 		    (pevent->xexpose.y < (MI_Y_OFFSET(mi) + MI_HEIGHT(mi)) &&
 		     (pevent->xexpose.y + pevent->xexpose.height) >
 		     MI_Y_OFFSET(mi)))

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 25 Aug 2002 12:36:11 +0200

> Here's a patch for the MenuFace TiledPixmap bug that I submitted yesterday :-)

Actually, that patch removes only the symptom, not the root cause
of the problem.  The parts not covered by the sub menu should have
never been cleared in the first place.  I'll commit a fix.

> +++ fvwm/menus.c	Sat Aug 24 13:48:36 2002

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]