Subject: Notification: incoming/907

From: [email-masked]
Date: Fri, 02 Aug 2002 07:27:28 -0500

FVWM Bug Tracking notification

new message incoming/907

Message summary for PR#907
	From: [email-masked]
	Subject: Makefile.am patches for 100% DESTDIR support
	Date: Fri, 02 Aug 2002 07:27:28 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Fri Aug 02 07:27:28 2002
From: [email-masked]
To: [email-masked]
Subject: Makefile.am patches for 100% DESTDIR support
Date: Fri, 02 Aug 2002 07:27:28 -0500

Full_Name: Matt Behrens
Version: 2.4.8
CVS_Date: 
OS: Gentoo Linux 1.3-ish
X_Server: 
Submission from: (NULL) (207.170.35.10)

Patch available in the shar archive obtainable here (in the 'files'
directory):

http://bugs.gentoo.org/attachment.cgi?id=2732&action=view

This permits DESTDIR to be used in order to do "fake" installs necessary
for Gentoo portage as well as binary packages on other platforms.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 2 Aug 2002 18:38:48 +0200

> for Gentoo portage as well as binary packages on other platforms.

The link is broken.  Please post that patch directly to
[email-masked] , preferrably with a description what it
does.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 2 Aug 2002 16:45:40 +0000

> for Gentoo portage as well as binary packages on other platforms.

Ok, I will apply this DESTDIR fix, since it patches my lines.

I think, you still may build everything without DESTDIR if you do:

  ./configure --whatever-you-like
  make
  make install prefix=<tmp-build-root><real-prefix>

At least this is how rpms are built.

Regards,
Mikhael.