Subject: CVS migo: * FvwmButtons: new button option Id

From: FVWM CVS <[email-masked]>
Date: Sun, 25 Aug 2002 22:45:13 -0500

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	migo	02/08/25 22:45:13

Modified files:
	.              : ChangeLog configure.in 
	libs           : Picture.c Picture.h 
	modules        : ChangeLog 
	modules/FvwmButtons: FvwmButtons.1 FvwmButtons.c FvwmButtons.h 
	                     Makefile.am button.c button.h icons.h 
	                     parse.c 
Added files:
	modules/FvwmButtons: dynamic.c dynamic.h 

Log message:
* FvwmButtons: new button option Id
* FvwmButtons: new dynamical messages ChangeButton and ExpandButtonVars
* configure: applied the --disable-ewmh fix
* added "const" in several places to make API more clear

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 26 Aug 2002 04:03:22 +0000

> * FvwmButtons: new dynamical messages ChangeButton and ExpandButtonVars

The old undocumented SendToModule syntax is removed. Instead, use
something like:

  *FvwmButtons: (Id note1, Title "13:30 - Dinner", Icon dinner.xpm)

  SendToModule FvwmButtons ChangeButton note1 \
      Title "18:00 - Go Home", Icon go.xpm

You don't need to always define Id, the old-style id (number or +x+y)
works as usual.

The ExpandButtonVars is intended to expand $title, $icon and similar in
the button context, but currently it only expands $bg, $top, $left etc.

  -SendToModule FvwmButtons ExpandButtonVars note1 \
      Exec xmessage "The current title: $title, fg: $fg"

Regards,
Mikhael.