Subject: Notification: incoming/902

From: [email-masked]
Date: Fri, 05 Jul 2002 12:54:59 -0500

FVWM Bug Tracking notification

new message incoming/902

Message summary for PR#902
	From: [email-masked]
	Subject: comicscartoon font no longer works as titlebar font
	Date: Fri, 05 Jul 2002 12:54:55 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Fri Jul 05 12:54:59 2002
From: [email-masked]
To: [email-masked]
Subject: comicscartoon font no longer works as titlebar font
Date: Fri, 05 Jul 2002 12:54:55 -0500

Full_Name: Wesley Tanaka
Version: 2.2.5
CVS_Date: 
OS: RedHat 7.2
X_Server: XFree86 version: 4.1.0
Submission from: (NULL) (209.246.29.222)

I am using comicscartoon from the sharefonts package
<ftp://rpmfind.net/linux/contrib/noarch/noarch/sharefonts-0.10-9.noarch.rpm>
as my titlebar font by including the following line:

WindowFont "-*-comicscartoon-*-*-*-*-14-*-*-*-*-*-*-*"

in my .fvwm2rc file.

In fvwm2 version 2.2.4, the font was displayed correctly.  However, when I
upgraded to version 2.2.5, the font was instead silently replaced with a
different font.

The comicscartoon font was still loaded on my system -- when I tried to do
an xfontsel -pattern "-*-comicscartoon-*-*-*-*-14-*-*-*-*-*-*-*"

the correct font displayed in the window.

Steps to reproduce:

1) install sharefonts package from
ftp://rpmfind.net/linux/contrib/noarch/noarch/sharefonts-0.10-9.noarch.rpm
2) install fvwm2 2.2.4  from
ftp://rpmfind.net/linux/redhat/7.1/en/os/i386/RedHat/RPMS/fvwm2-2.2.4-9.i386.rpm
3) add WindowFont "-*-comicscartoon-*-*-*-*-14-*-*-*-*-*-*-*"
to .fvwm2rc
4) run fvwm2
5) the font is correctly displayed
6) install fvwm2 2.2.5 from
ftp://rpmfind.net/linux/redhat/7.2/en/os/i386/RedHat/RPMS/fvwm2-2.2.5-4.i386.rpm
8) restart fvwm2
9) the font has been replaced with a different font

expected behavior: comicscartoon font is displayed in the titlebars of
windows
actual behavior: some other font is displayed instead

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 6 Jul 2002 22:25:19 +0200

> the correct font displayed in the window.

Please upgrade to the latest stable fvwm release (2.4.8).  We have
done a lot of work related to the parsing of fonts.  You should
not encounter this problem anymore.  If the problem persits,
please report back.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 7 Jul 2002 11:33:14 +0200

On Sat, Jul 06, 2002 at 04:09:46PM -0700, Wesley Tanaka wrote:
> Dominik,
> 
> Based you your suggestion, I installed
> http://prdownloads.sourceforge.net/fvwm-ewmh/fvwm-2.4.8-1ewmh_0.7.i586.rpm
> 
> and this bug did, as you predicted, go away.

I am glad to hear it.  Don't hesitate to ask on the mailing list
should you encounter any problems with the transition from 2.2
to 2.4.

Bye

Dominik ^_^  ^_^