Subject: Notification: incoming/900

From: [email-masked]
Date: Wed, 03 Jul 2002 11:29:13 -0500

FVWM Bug Tracking notification

new message incoming/900

Message summary for PR#900
	From: [email-masked]
	Subject: Windows disappear after moving in pager
	Date: Wed, 03 Jul 2002 11:29:08 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Wed Jul 03 11:29:13 2002
From: [email-masked]
To: [email-masked]
Subject: Windows disappear after moving in pager
Date: Wed, 03 Jul 2002 11:29:08 -0500

Full_Name: Petr Nejedly
Version: 2.5.2
CVS_Date: 
OS: Solaris 8
X_Server: 
Submission from: (NULL) (192.18.1.9)

I have a FvwmPager swallowed in FvwmButtons on-top panel.
If i move a window using middle mouse button dragging in pager,
the window will bo moved correctly but disapear from the pager
and also from the IconManager for that page.
If I then move the window by dragging it directly, it will appear again
in both Pager and IconMan.

During the time the window is missing in pager, its geometry is like:
(correct width)x(correct height)+(correct x)+(correct y+1703936).
Note that 1703936 is quite round number :-), 26*2^16

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 4 Jul 2002 11:57:51 +0200

On Wed, Jul 03, 2002 at 11:29:13AM -0500, fvwm-bug wrote:
> the window will be moved correctly but disapear from the pager

So the window disappears from the modules, but is still visible on
the desktop?

> Note that 1703936 is quite round number :-), 26*2^16

If the window is still visible, its real y coordinate can not have
this value.  How did you find out the geometry?

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Petr Nejedly <[email-masked]>
Date: Mon, 08 Jul 2002 09:33:15 +0200

> So the window disappears from the modules, but is still visible on

Yes

>From the WinList.

Bye,
  Nenik

-- 
Petr "Nenik" Nejedly, NetBeans/Sun Microsystems, http://www.netbeans.org
355/113 -- Not the famous irrational number PI, but an incredible simulation!
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 8 Jul 2002 10:54:31 +0200

> > this value.  How did you find out the geometry?

Have you tried the latest snapshot?  It has a patch for the
problem, but I can test it only on i386 machines.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Petr Nejedly <[email-masked]>
Date: Mon, 08 Jul 2002 11:46:39 +0200

> problem, but I can test it only on i386 machines.

Yes.
I've backported changes in fvwm/module_interface.c
and lib/vpacket.h to my 2.5.2 and it works perfectly.

Thanks much for fvwm, the best window manager ever!