Subject: Notification: incoming/899

From: [email-masked]
Date: Wed, 03 Jul 2002 08:56:09 -0500

FVWM Bug Tracking notification

new message incoming/899

Message summary for PR#899
	From: [email-masked]
	Subject: segfault on startup
	Date: Wed, 03 Jul 2002 08:56:09 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Wed Jul 03 08:56:09 2002
From: [email-masked]
To: [email-masked]
Subject: segfault on startup
Date: Wed, 03 Jul 2002 08:56:09 -0500

Full_Name: Rob Costello
Version: 2.5.2
CVS_Date: 
OS: Linux - Redhat 7.1
X_Server: XFree86 4.2.0
Submission from: (NULL) (195.99.244.5)

I can successfully compile fvwm 2.5.2 as long as I don't select
--enable-debug-msgs which causes a compile error due to : 

module_interface.c: In function `ExecuteCommandQueue': 
module_interface.c:1676: `temp' undeclared (first use in this function) 
module_interface.c:1676: (Each undeclared identifier is reported only once

module_interface.c:1676: for each function it appears in.) 
make[2]: *** [module_interface.o] Error 1 
make[2]: Leaving directory `/opt/fvwm/fvwm-2.5.2/fvwm' 
make[1]: *** [all-recursive] Error 1 
make[1]: Leaving directory `/opt/fvwm/fvwm-2.5.2' 
make: *** [all-recursive-am] Error 2 

The configuration is as below: 

FVWM Configuration: 

  Version:     2.5.2 

  Executables: /usr/local/bin 
  Man pages:   /usr/local/man 
  Modules:     /usr/local/libexec/fvwm/2.5.2 
  Data files:  /usr/local/share/fvwm 
  Perl lib:    /usr/local/share/fvwm/perllib 

  With Asian bi-direct. text support? no: No fribidi-config found in PATH 
  With Extended Window Manager Hints? yes 
  With GNOME Window Manager Hints?    yes 
  With GTK required for FvwmGtk?      yes 
  With GDK image support in FvwmGtk?  yes 
  With GNOME libs support in FvwmGtk? yes 
  With PNG image support?             yes 
  With ReadLine sup. in FvwmConsole?  yes 
  With RPlay support in FvwmEvent?    yes 
  With Shaped window support?         yes 
  With Session Management support?    yes 
  With Mouse strokes (gestures)?      yes 
  With Xinerama multi-head support?   yes 
  With Xft anti-alias font support?   yes (version 1) 
  With XPM image support?             yes 
  With Xrender image support?         yes 

the output from gdb is: 

gdb ./fvwm 
GNU gdb Red Hat Linux (5.1-0.7) 
Copyright 2001 Free Software Foundation, Inc. 
GDB is free software, covered by the GNU General Public License, and you
are 
welcome to change it and/or distribute copies of it under certain
conditions. 
Type "show copying" to see the conditions. 
There is absolutely no warranty for GDB.  Type "show warranty" for details.

This GDB was configured as "i386-redhat-linux"... 
(gdb) run 
Starting program: /opt/fvwm/fvwm-2.5.2/fvwm/./fvwm 

Program received signal SIGSEGV, Segmentation fault. 
0x4000acd0 in ?? () 
(gdb) bt 
#0  0x4000acd0 in ?? () 
#1  0x40002902 in ?? () 
#2  0x4000f8f6 in ?? () 
#3  0x40002332 in ?? () 
#4  0x4000217f in ?? () 
(gdb) 

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 3 Jul 2002 19:30:09 +0200

> make: *** [all-recursive-am] Error 2 

I've fixed that one.  You don't need tho enable debug messages
anyway.  It's a relic of the past that may eventually be removed
completely.  It suggests that it provides some useful information,
but it doesn't.  Not even to the developers.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 5 Jul 2002 15:32:15 +0200

On Fri, Jul 05, 2002 at 02:32:12PM +0100, Rob Costello wrote:
> hi, Dominik
> 
> Thanks for the update.
> 
> Sorry to ask directly, but has my bug been split into two? The serious
> problem I am experiencing is the core dump on startup...

Actually, how did you get a core dump if you could not even compile
fvwm?  The stack trace in the bug report isn't very helpful.  The
executable has no debug symbols.  When you compile again, please
do not strip the executable and fetch a stack trace again.

Bye

Dominik ^_^  ^_^

P.S.: Please no fvwm related mail to my private address.  I
forward everything to the mailing lists anyway.

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 5 Jul 2002 17:57:42 +0200

On Fri, Jul 05, 2002 at 02:56:09PM +0100, Rob Costello wrote:
> hi, Dominik
> 
> I have not stripped the executable.
> 
> If I compile without --enable-debug-msgs, fvwm compiles successfully.
> 
> I have tried disabling and enabling all the extra features with no
> success.
> 
> I ran the test_options script at level 0 - no errors were reported...
>
> I tried running fvwm -debug, but it core dumped before outputting any
> debug info.

Forget about the debug stuff in the distribution.  It's not
helpful for anything else but running a few sanify checks before a
release.

Did you install the new fvwm with

  $ make install

?  Are you sure the correct executable is being executed?  It it
in your shell PATH?  If you compiled with just "make", the
executable *has* debug information.  When gdb does not display any
useful information that means that either the executable that was
run has no debug info or gdb did not find the sources.

> As a background, I searched for the memory location error in google, and
> found a similar bug report (unresolved) on the Flight Gear mailing
> list...

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 8 Jul 2002 14:15:57 +0200

On Mon, Jul 08, 2002 at 12:17:27PM +0100, Rob Costello wrote:
> hi, Dominik
> 
> Yes, I ran make install....
> 
> fvwm-config -i reports:
> 
> Package: fvwm
> Version: 2.5.2
> 
> Instalation options:
> 	prefix: /usr/local
> 	exec-prefix: /usr/local
> 	bindir: /usr/local/bin
> 	datadir: /usr/local/share
> 	libexecdir: /usr/local/libexec
> 	sysconfdir: /usr/local/etc
> 	mandir: /usr/local/man
> 
> Compiled-in paths:
> 	Module directory: /usr/local/libexec/fvwm/2.5.2
> 	Data directory: /usr/local/share/fvwm
> 	Perl lib directory: /usr/local/share/fvwm/perllib
> 	Default ImagePath: /usr/include/X11/bitmaps:/usr/include/X11/pixmaps
> 	Default UserDir: $HOME/.fvwm

Aha!  As I said, you're having a path problem.  You installed to
/usr/local, but when you ran gdb it used
/opt/fvwm/fvwm-2.5.2/fvwm/fvwm.  I repeat:  are you *sure* that
/usr/local/bin/fvwm is run and not /opt/fvwm/fvwm-2.5.2/fvwm/fvwm?

> On Fri, 2002-07-05 at 16:57, Dominik Vogt wrote:

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 8 Jul 2002 15:35:42 +0200

On Mon, Jul 08, 2002 at 02:10:06PM +0100, Rob Costello wrote:
> I ran gdb against the compiled version in my source tree.....  it was
> after doing a make install. I have now run gdb against the installed
> version with the same results.
> 
> [root@eagle /root]# gdb /usr/local/bin/fvwm
> Starting program: /usr/local/bin/fvwm 
> 

That looks as if the SIGSEGV happens before fvwm is even started.
Please throw away the whole source tree, compile and install from
scratch and delete the core file.  If the problem persists, run
fvwm from gdb:

  $ gdb /usr/local/bin/fvwm
  (gdb) break main
  (gdb) run

If is doesn't reach the breakpoint, something must have gone very
wrong at compilation time.  If it does run into the breakpoint,
please single step throgh the code to find out where it crashes.

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 8 Jul 2002 15:49:46 +0200

On Mon, Jul 08, 2002 at 02:53:47PM +0100, Rob Costello wrote:
> hi, Dominik
> 
> You are correct.
> 
> I ran gdb as suggested, and the output does indicate that main() is not
> reached....
> Must be something to do with one of my libs
> 
> Is there a dependancy document anywhere, so I can check my installed
> libraries against those recommended?

Check the INSTALL.fvwm file and the output of configure.  But this
should never happen anyway.

Bye

Dominik ^_^  ^_^