Subject: dragging + MouseFocus/SloppyFocus broken

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 17 Jul 2002 16:57:17 +0000

This is probably started after the rxvt/aterm copying workaround commit.
Regardless of whether this is related or not, I think rxvt bugs are better
to be fixed in rxvt, not in fvwm, it is not a closed product.

I can always reproduce this with no config (MouseFocus) or SloppyFocus.
Place 2 xterms or rxvts like this:

           _________ 
          |         |
          |         |
    ______|         |
   |   abc|    B    |
   |      |         |
   |      |_________|
   |    A    |
   |         |
   |_________|

or this:

           _________
          |         |
          |         |
   _______|__       |
   |   abcde | B    |
   |         |      |
   |         |______|
   |    A    |
   |         |
   |_________|

Now, Raise/Lower B several times (for this bug to work it is important
that B is the last dealt window before you start copying in A).
Using mouse button 1, copy text "abc" and continue with a pointer to the
right, so it ends up in B. Release the mouse button. B is not focused.
The same happens if you drag some url from browser (A) to xterm (B).

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 17 Jul 2002 19:13:33 +0200

> to be fixed in rxvt, not in fvwm, it is not a closed product.

No I don't think that is the cause.  If it were, you would get the
wait cursor after half a second.  It's either that the button
grabs on the window are not correct, or HandleEnterNotify() does
something wrong.  And the internal window list is probably
involved too.

> Place 2 xterms or rxvts like this:

I find it much easier to reproduce.  I just open two overlapping
xterms, then click-drag from A to B and from B to A.  One of the
two directions always fails as long as I don't pass over a third
window (in which case the working and failing directions swap).

> The same happens if you drag some url from browser (A) to xterm (B).

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 17 Jul 2002 20:15:56 +0000

> window (in which case the working and failing directions swap).

Not for me. As I said, one of the two windows should be the last dealt
window. If some third window (even on another desk) was last Raise'd,
your instructions do not work.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 17 Jul 2002 23:54:58 +0200

> your instructions do not work.

Fixed.  The Enter/LeaveNotify code got confused about which window
has last lost the pointer due to a pointer grab. 

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 17 Jul 2002 23:00:32 +0200

> your instructions do not work.

Probably a button grab problem.  I'm digging into it ...

Bye

Dominik ^_^  ^_^