Subject: Sticky Panel

From: Olivier Chapuis <[email-masked]>
Date: Sat, 8 Jun 2002 08:46:37 +0200

Hello,

The pbs: A sticky FvwmButtons panel is not Sticky. I've noted
that since a long time, but I've just found the reason.

The reason: When a panel is mapped, FvwmButtons move the
panel to the current desk. But, on the other hand since
the 2002-03-09  Dominik Vogt  <[email-masked]>,
a sticky window is unsticked when MoveToDesk is used.
I am not sure that this is a so good idea. Moreover
removing this new feature is the only way I see to
fix this sticky panel problem. Dominik?

Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 8 Jun 2002 16:10:38 +0200

> fix this sticky panel problem. Dominik?

I've added a "(!Sticky)" condition to the command:

  Silent WindowId 0x%08x (!Sticky) MoveToDesk 0

Works fine now.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 9 Jun 2002 20:33:10 +0000

>   Silent WindowId 0x%08x (!Sticky) MoveToDesk 0

Well, here sprintf line is a bit redudant, just:

  SendText(fd, "ThisWindow (!Sticky) MoveToDesk", b->PanelWin);

But this is not my point. I thought about this "feature" of MoveToDesk
and MoveToPage, and I can't find a usage for it. For me this is more a
misfeature, because every time now I should prepend a condition (!Sticky)
before issuing these commands on an arbitrary window or a window group.
If I would want to unstick my sticky windows I would explicitely request
"Stick false" together with MoveToPage. Just like I don't want MoveToPage
to deiconify, unshade or unmaximize. Moving sticky windows that are out
of screen to be visible is reasonable, but not unsticking them IMHO.

P.S. A month ago I almost convinced myself that unsticking is ok, but
this bug proved this is not ok.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 10 Jun 2002 12:19:52 +0200

> this bug proved this is not ok.

Unsticking is more intuitive if you invoke the action manually,
but I agree that it isn't a good for complex functions.  I
wouldn't complicate things by checking if the window was actually
moved before unsticking.  There is a good chance nobody will miss
this feature.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 18 Jun 2002 11:47:29 +0200

> moved before unsticking.  There is a good chance nobody will miss

I have removed this feature.

Bye

Dominik ^_^  ^_^