Subject: Re: ActiveColorset in MenuStyle does not work properly

From: [email-masked]
Date: Fri, 07 Jun 2002 08:09:49 -0500

> > It works without problems for me. What is your colorset 2
definition?
> 
> Well, ok, you should specify:
> 
>   Style * HilightBack
> 
> HilightBackOff will give the effect you describe.

Specifying

MenuStyle * ActiveColorset 2
MenuStyle * HilightBack

seems to work properly (HilightBackOff does not work).  This seems
vaguely unintuitive--although it *is* documented in the manual (doh!).
 Was there a reason for this choice?

-Nathan
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 7 Jun 2002 20:23:57 +0000

>  Was there a reason for this choice?

HilightBack was introduced long before colorsets were invented.
MenuStyle fvwm (this is a default) and mwm both imply HilightBackOff.

I didn't worried about this, because for ages we have

  MenuStyle * MenuFace, ActiveFore, HilightBack

hardcoded in fvwm-themes, so menu colorsets are fully respected.
But it probably makes sence for ActiveColorset to imply HilightBack and
probably ActiveFore, and for MenuColorset to imply MenuFace.
I will not change this though. If Dominik agrees he may do this.
My opinion is to remove these 3 options in the future anyway.

Regards,
Mikhael.