Subject: 2.5.1 build fails on Solaris 8 without Xpm

From: Andy Isaacson <[email-masked]>
Date: Thu, 20 Jun 2002 14:31:22 -0500

I'm trying to build fvwm 2.5.1 on Solaris 8 10/01.  It fails while
trying to build fvwm-root, because fvwm-root.c unconditionally depends
on Xpm.

gcc -DHAVE_CONFIG_H -I. -I. -I.. -I..       -g -O2 -Wall
    -Wno-implicit-int -c fvwm-root.c
fvwm-root.c:17: X11/xpm.h: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `fvwm-root.o'

Since I don't want fvwm-root, I just commented it out of bin/Makefile
and re-built without problems.

Full build log or configure.log on request.

-andy
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 20 Jun 2002 21:27:53 +0000

> trying to build fvwm-root, because fvwm-root.c unconditionally depends

I will fix this before 2.5.2 and test no-png and no-xpm cases.
I think it is ok to install it unconditionally, since it supports xbm.

> Full build log or configure.log on request.

Not needed, thanks.

Regards,
Mikhael.