Subject: fvwm/fvwm.1 spelling fixes

From: Anders Andersson <[email-masked]>
Date: Mon, 24 Jun 2002 18:42:10 +0200

Here is a patch against todays CVS version of fvwm.1 which fixes some
spelling errors.

-- 
Anders Andersson <[email-masked]>
UNIX, Networking and Security consultant
+46 (0)705 87 53 35
Index: fvwm.1
===================================================================
RCS file: /home/cvs/fvwm/fvwm/fvwm/fvwm.1,v
retrieving revision 1.24
diff -u -r1.24 fvwm.1
--- fvwm.1	2002/06/24 10:53:07	1.24
+++ fvwm.1	2002/06/24 16:40:05
@@ -61,7 +61,7 @@
 .if t .sp .5
 ..
 .ta .3i .6i .9i 1.2i 1.5i 1.8i
-.TH FVWM 1 "24 Juny 2002" FVWM "FVWM 2.5.2"
+.TH FVWM 1 "24 June 2002" FVWM "FVWM 2.5.2"
 .UC
 .SH NAME
 
@@ -452,7 +452,7 @@
 Style * IconBox 64x300-0-0@p
 .EE
 
-Xinerama support can be configured to use a primary screen.  Fwvm
+Xinerama support can be configured to use a primary screen.  Fvwm
 can be configured to place new windows and icons on this screen.
 The primary screen is screen 0 by default but can be changed with
 the
@@ -1034,7 +1034,7 @@
 .EE
 then, if either loading the Xft font fails or fvwm has no Xft support,
 fvwm loads the font "-adobe-courier-bold-r-normal--14-*". This
-allows for writting portable configuration files.
+allows for writing portable configuration files.
 
 .SH FONT AND STRING ENCODING
 
@@ -1459,7 +1459,7 @@
 + I Echo $$d $[page.nx] $c
 .EE
 
-Note: If this funtion is called outside a window context, it will
+Note: If this function is called outside a window context, it will
 print "$c" instead of the class name.  It is usually not enough to
 have the pointer over a window to have a context window.  To force
 using the window with the focus, the
@@ -1656,7 +1656,7 @@
 $[pointer.cy]
 .in +.3i
 These return the position of the pointer in the client portion of
-th eselected window.  If the pointer is not on the screen, the
+the selected window.  If the pointer is not on the screen, the
 window is shaded or iconified or no window is selected, these
 variables are not expanded.
 
@@ -2601,7 +2601,7 @@
 requires an integer value between 51 and 100.  Normally, when the
 pointer is over a menu item with a sub menu and the pointer enters
 the area that starts at 75% of the menu width, the sub menu is
-shown immediately.  This percantage can be changed with
+shown immediately.  This percentage can be changed with
 .IR PopupActiveArea .
 Setting this value to 100 disables this kind of automatic popups
 altogether.  The default value is restored if no or an illegal
@@ -2685,7 +2685,7 @@
 .B WindowList
 navigation.  The key name is a standard X11 key name as defined in
 .IR /usr/include/X11/keysymdef.h ,
-with the leading "XK_" omitted.  To disable this behaviour, omit
+with the leading "XK_" omitted.  To disable this behavior, omit
 the key name.
 
 Note: Some X servers do not support KeyRelease events.
@@ -3720,7 +3720,7 @@
 .B Deschedule
 command to remove the scheduled command before it is executed.  If
 no id is given, fvwm uses negative id numbers, starting with -1
-and descreasing by one with each use of the
+and decreasing by one with each use of the
 .B Schedule
 command.
 Note that the
@@ -3911,7 +3911,7 @@
 .I CurrentAtEnd
 option the currently focused window (if any) is shown at the bottom
 of the list.  This is mostly intended for simulating the Alt-Tab
-behaviour in another GUI.
+behavior in another GUI.
 
 .I IconifiedAtEnd
 makes iconified windows be moved to the end of the list.  This is also
@@ -4813,7 +4813,7 @@
 .IR WindowShadeAlwaysLazy " and " WindowShadeBusy .
 option of the
 .B Style
-command.  Exmaples:
+command.  Examples:
 .EX
 Style * WindowShadeShrinks, WindowShadeSteps 20, WindowShadeLazy
 Mouse 1 S - WindowShade North
@@ -4888,7 +4888,7 @@
 .EE
 If the
 .I Modifiers
-arggument is the string "default", fvwm reverts back to the
+argument is the string "default", fvwm reverts back to the
 default value "L".
 
 .I Important Note:
@@ -5034,7 +5034,7 @@
 the root window, 'W' for an application window, 'D' for a desktop
 application (as kdesktop or Nautilus desktop), 'T' for a window
 title-bar, 'S' for a window side, top, or bottom bar, '[', ']',
-\'-' and '_' for the left, rigth, top or bottom side only, 'F' for
+\'-' and '_' for the left, right, top or bottom side only, 'F' for
 a window frame (the corners), '<', '^', '>' and 'v' for the top
 left, top right, bottom right or bottom left corner, 'I' for an
 Icon window, or '0' through '9' for title-bar buttons, or any
@@ -5556,7 +5556,7 @@
 .IR RightTitleRotatedCCW " if " TitleAtRight
 is used.  The defaults can be restored with
 .IR LeftTitleRotatedCCW " and " RightTitleRotatedCW .
-A normal horisontal text may be rotated as well with
+A normal horizontal text may be rotated as well with
 .IR TopTitleRotated " if " TitleAtTop
 is used, and with
 .IR BottomTitleRotated " if " TitleAtBottom
@@ -5574,7 +5574,7 @@
 
 .I Color
 takes two arguments.  The first is the window-label text color and
-the second is the window decoration's normal background color. The
+the second is the window decorations normal background color. The
 two colors are separated with a slash.  If the use of a slash
 causes problems then the separate
 .IR ForeColor " and " BackColor
@@ -6012,7 +6012,7 @@
 .IR VariablePPosition " or " VariablePSize
 style.  These styles may sometimes affect the initial placement
 and dimensions of new windows (depending on the application).  If
-windows are created at strange places, try eihter the
+windows are created at strange places, try either the
 .IR VariablePPosition " or " NoPPosition
 styles.  The
 .I FixedPSize
@@ -6043,7 +6043,7 @@
 all windows in the same window group are iconified at once when
 group leader is iconified.  The default is
 .IR IconifyWindowGroupsOff ,
-which disables this behaviour.  Although a number of applications
+which disables this behavior.  Although a number of applications
 use the window group hint, it is rarely used in a proper way, so
 it is probably best to use
 .I IconifyWindowGroups
@@ -6420,7 +6420,7 @@
 .I KeepWindowGroupsOnDesk
 makes new windows that have the window group hint set appear on
 the same desk as the other windows of the same group.  Since this
-bevhaviour may be confusing, the default setting is
+behavior may be confusing, the default setting is
 .IR ScatterWindowGroups .
 The window group hint is ignored when placing windows in this
 case.
@@ -6515,7 +6515,7 @@
 size (i.e., height and width less than or equal to 22), then fvwm
 uses this icon as its mini icon.
 .I EWMHMiniIconOverride
-instructs fvwm to ignore emwh icons and to use the mini icon
+instructs fvwm to ignore ewmh icons and to use the mini icon
 provided by the
 .I MiniIcon
 style.
@@ -6646,7 +6646,7 @@
 GNOME hints to force the window manager to ignore the user's
 preferences.  The
 .I GNOMEUseHints
-style switches back to the default behaviour.
+style switches back to the default behavior.
 
 .I UseDecor
 accepts one argument: the name of a decor created with
@@ -7125,7 +7125,7 @@
 
 .I UseTitleStyle
 causes the given button state to render the current title style
-before rendering the button's own styles.  The
+before rendering the buttons own styles.  The
 .IR Raised ", " Flat " and " Sunk
 .B TitleStyle
 flags are ignored since they are redundant in this context.
@@ -7929,7 +7929,7 @@
 The primary screen is used in some of the modules and for the
 default icon box too.  Any number that is zero or more is taken as
 the primary screen's number.  Instead, the letter 'c' indicates to
-use the curent screen (containing the pointer) whenever the
+use the current screen (containing the pointer) whenever the
 primary screen is used.  This may be very confusing under some
 circumstances.  With
 \'g', the global screen is used as the primary screen, effectively
@@ -8018,7 +8018,7 @@
 .I name
 must not contain embedded whitespace.  No guarantees are made
 whether function names with embedded whitespace work or not.  This
-behaviour may also change in the future without further notice.
+behavior may also change in the future without further notice.
 The letter before the
 .I action
 tells what kind of action triggers the command which follows it.
@@ -8303,13 +8303,13 @@
 this disables error messages.
 
 .B Silent
-also disables the error message for non-existant commands.
+also disables the error message for non-existent commands.
 
 Examples:
 .EX
 Silent Move 0 0
 Silent User_defined_function
-# don't complain on keabords without "Help" key
+# don't complain on keyboards without "Help" key
 Silent Key Help R A Popup HelpMenu
 .EE
 
@@ -8364,7 +8364,7 @@
 (if a window matching all conditions was found) or 0 (if no such
 window was found)the condition was not met).  A few commands
 deviate slightly from this scheme or can even return -1 which
-means that an error occured and the return code is useless.
+means that an error occurred and the return code is useless.
 The return code is used by the commands
 .B Cond
 and
@@ -8781,7 +8781,7 @@
 At the current time the available modules (included with fvwm) are
 .B FvwmAnimate
 (produces animation effects when a window is iconified or
-de-iconifed),
+de-iconified),
 .B FvwmAudio
 (makes sounds to go with window manager actions),
 .B FvwmAuto
@@ -9138,7 +9138,7 @@
 then the ending color.  Each subsequent segment begins with the
 second color of the last segment.  The lengths may be any
 non-negative integers.  The length of one segment divided by the
-sum of all segment's lengths is the fraction of the colors that
+sum of all segments lengths is the fraction of the colors that
 are used for the segment.
 .in -2

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 24 Jun 2002 17:16:15 +0000

It seems you verified the whole man page. :)
I am sure man pages of the modules have some spelling errors too...

Sometimes in the future please do "cvs diff -D 2002-02-24 -D now fvwm.1"
and continue to keep it correct.

Just a small note, "behaviour" is a correct alternative (or even primary)
spelling by my dictionary.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Anders Andersson <[email-masked]>
Date: Mon, 24 Jun 2002 22:00:42 +0200

> I am sure man pages of the modules have some spelling errors too...

Yeah, I will put my ispell scripts to more work soon :-)

> and continue to keep it correct.

I will try to do that, but first I will try to make the man-page
consistent and perhaps some re-wording of some phrases I thought was
wrong, but please bear with me since I'm not a native english speaker.

> spelling by my dictionary.

Yes, I noted this also, but 'behavior' got more hits then 'behaviour',
like Websters proffered my selection and then I just wanted to make it
consistent.
-- 
Anders Andersson <[email-masked]>
UNIX, Networking and Security consultant
+46 (0)705 87 53 35
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 29 Jun 2002 21:29:16 +0200

> Yes, I noted this also, but 'behavior' got more hits then 'behaviour',

According to my dictionary:

  behavior = American English
  behaviour = British English

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]