Subject: FvwmPager crashas

From: Giuseppe Della Ricca <[email-masked]>
Date: Wed, 22 May 2002 11:12:41 +0200 (CEST)

Hi !

after the latest changes to FvwmPager.c

        * FvwmPager/FvwmPager.c (list_new_desk):
        always display current desk in window title

my FvwmPager randomly core dumps after desk switches.

#0  0x42080b1b in strlen () from /lib/i686/libc.so.6
(gdb) where
#0  0x42080b1b in strlen () from /lib/i686/libc.so.6
#1  0x400b43e4 in XStoreName () from /usr/X11R6/lib/libX11.so.6
#2  0x0804c8b8 in list_new_desk (body=0x8063c70) at FvwmPager.c:978
#3  0x0804d345 in My_XNextEvent (dpy=0x806b9e8, event=0xbffff1a0)
    at FvwmPager.c:1464
#4  0x0804bd73 in Loop (fd=0x80642cc) at FvwmPager.c:478
#5  0x0804bd3c in main (argc=8, argv=0xbffff3c4) at FvwmPager.c:455
#6  0x42017499 in __libc_start_main () from /lib/i686/libc.so.6

this is my Pager setup:

DestroyModuleConfig FvwmPager: *

*FvwmPager: Colorset * 1
*FvwmPager: WindowColorsets 1 0
*FvwmPager: Geometry -0-0
*FvwmPager: Font -adobe-helvetica-bold-r-*-*-11-*-*-*-*-*-*-*
*FvwmPager: SmallFont 6x9
*FvwmPager: HilightColorset * 0
*FvwmPager: Label 0 Misc
*FvwmPager: Label 1 Work
*FvwmPager: Label 2 Net
*FvwmPager: Label 3 Doc
*FvwmPager: Label 4 Mail

*FvwmPager: MiniIcons

*FvwmPager: Balloons
*FvwmPager: BalloonColorset * 0
*FvwmPager: BalloonFont -adobe-helvetica-bold-r-*-*-11-*-*-*-*-*-*-*
*FvwmPager: BalloonBorderWidth 1
*FvwmPager: BalloonYOffset -1

Pleas let me know if you need any further information: please CC for 
faster reply.

Thanks a lot !!

Cheers,
Giuseppe.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 22 May 2002 11:55:19 +0200

> my FvwmPager randomly core dumps after desk switches.

Is it fixed with my latest commit?

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]