Subject: Re: ideas about future frame layout?

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 22 May 2002 14:57:58 +0000

On 11 Mar 2002 21:05:49 +0100, Dominik Vogt wrote:
> 
> On Mon, Mar 11, 2002 at 05:00:55PM +0000, Mikhael Goikhman wrote:
> > 
> > And while you are at it. Please add boolean NoBorder/Border style option
> > that is similar to NoHandle/Handle. I want to add this for some time now,
> > this enables to temporarily remove borders without reseting BorderWidth.
> 
> Please remind me of that in a few weeks :-)

A polite reminder to add NoBorders/Borders. :)

I think NoBorders should remove the borders completely overwritting such
options as BorderWidth, Handles, HandleWidth. "Borders" restores borders.

> > This also raises a question of disabling only parts of a border, for
> > example only side borders suggested by Olivier in another thread.
> 
> dito

Ok, if you are in a mood for a new interesting quest, here are the needs.

I think we may want to be able to remove all 4 side borders independently.
And it seems 2 types of options are needed, because of side titles:

  NoTopBorder, NoLeftBorder, NoBottomBorder, NoRightBorder
  NoTitleBorder, NoSideBorders, NoOppositeBorder

The first 4 are needed for this case. Suppose (well, it's a known fact)
you have FvwmButtons at the bottom-left of the page. You may want to add
NoLeftBorder and NoBottomBorder to this panel. If a panel covers the
bottom fully, also add NoRightBorder. Generally someone may want to add
No<Direction>Border to his FixedPosision window at the <Direction> edge.
Shading of such window works as expected, but we have one border on the
bottom, instead of two borders. I don't know how NoBorders/NoTitle window
should be shaded.

Now, I hope we agree how is a border near the title defined.
If a window has a title, there is a title-border that looks like |~~~~~~|
and 3 other direct borders.

   +--- TitleBorder   +--- SideBorders
   v                  v
  +--- ------------------------------------ +
  |+-+ +----------------------------------+ |
  ||t| |                                  | |
  ||i| |                                  | |
  ||t| |           client window          | | <-- OppositeBorder
  ||l| |                                  | |
  ||e| |                                  | |
  |+-+ +----------------------------------+ |
  +--- ------------------------------------ +

This is a normal case. 2 more cases may be seen in other desktop systems:

   NoTitleBorder    +--- SideBorders
                    v
  +-+ ------------------------------------ +
  | | +----------------------------------+ |
  |t| |                                  | |
  |i| |                                  | |
  |t| |          client window           | | <-- OppositeBorder
  |l| |                                  | |
  |e| |                                  | |
  | | +----------------------------------+ |
  +-+ ------------------------------------ +

and:

   NoTitleBorder    NoSideBorders
                      
  +-+ +----------------------------------+ |
  |t| |                                  | |
  |i| |                                  | |
  |t| |          client window           | | <-- OppositeBorder
  |l| |                                  | |
  |e| |                                  | |
  +-+ +----------------------------------+ |

I intentionally used 2 space columns and a single line for a border,
but otherwise the schemes are what I mean.

But maybe we don't need options NoSideBorders and NoOppositeBorder, only
one NoTitleBorder. A lot of window decoration designs assume titlebar
has no additional border in the |~~~~~~| like form.

Ideally every border may have different width, but removing individual
borders would be enough for now. So to sum this message up:

  Style * Borders/NoBorders
  Style * TopBorder/NoTopBorder, BottomBorder/NoBottomBorder
  Style * LeftBorder/NoLeftBorder, RightBorder/NoRightBorder
  Style * TitleBorder/NoTitleBorder

What do you think?

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 22 May 2002 21:43:45 +0200

On Wed, May 22, 2002 at 02:57:58PM +0000, Mikhael Goikhman wrote:
> 
> So to sum this message up:
> 

Of course Dominik should answer. But, I would like to say that I
think that it will be good to have these new styles.

Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 23 May 2002 11:40:57 +0200

> think that it will be good to have these new styles.

Uh, I'm going on a holiday for the next eight months ;-)

This all makes sense.  Luckily, all the frame layout calculations
are now in geometry.c, so it's not that hard to do - much of the
work is already done.  I'll take a look at the (No)Borders style
soon, but I'd rather finalize the tear off menu code before
starting with the rest.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]