Subject: Notification: incoming/888

From: [email-masked]
Date: Tue, 07 May 2002 06:36:37 -0500

FVWM Bug Tracking notification

new message incoming/888

Message summary for PR#888
	From: [email-masked]
	Subject: ClickToFocusDoesntRaise DoesntWork
	Date: Tue, 07 May 2002 06:36:35 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Tue May 07 06:36:36 2002
From: [email-masked]
To: [email-masked]
Subject: ClickToFocusDoesntRaise DoesntWork
Date: Tue, 07 May 2002 06:36:35 -0500

Full_Name: Mark D
Version: 2.2.5
CVS_Date: 
OS: OpenBSD (default wm)
X_Server: XF86_SVGA (XFree 3.3.6)
Submission from: (NULL) (198.164.220.146)

Setting the 'ClickToFocusDoesntRaise' globalopt doesn't have desired
effect.
Clicking in the window frame raises the window nomatter how this option is
set.  The following hack deactivates the offending behaviour, perhaps
inelegantly, but might be useful in tracking the problem.  Fvwm 2.2.5 is
the
default window manager for OpenBSD to this day, so the problem is relevent
(at least to me!).

# 1093c1093
# <     if (Scr.ClickToFocusRaises ||
# ---
# > /*    if (Scr.ClickToFocusRaises ||
# 1097c1097
# <        (Event.xbutton.subwindow != Tmp_win->Parent)))
# ---
# >        (Event.xbutton.subwindow != Tmp_win->Parent))) */
# 1098a1099
# >    if (Scr.ClickToFocusRaises)

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 7 May 2002 16:43:08 +0200

> default window manager for OpenBSD to this day, so the problem is relevent

This bug has long been fixed in later versions.  Please upgrade to
the latest stable release (2.4.7).  The 2.2.x stable releases are
no longer maintained (i.e. no bug fixes made).

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]