Subject: Notification: incoming/886

From: [email-masked]
Date: Fri, 03 May 2002 13:40:53 -0500

FVWM Bug Tracking notification

new message incoming/886

Message summary for PR#886
	From: [email-masked]
	Subject: FvwmEvent bug for Exec
	Date: Fri, 03 May 2002 13:40:53 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Fri May 03 13:40:53 2002
From: [email-masked]
To: [email-masked]
Subject: FvwmEvent bug for Exec
Date: Fri, 03 May 2002 13:40:53 -0500

Full_Name: David A. Rogers
Version: 2.4.6
CVS_Date: 
OS: Debian (Woody current testing)
X_Server: xfree86 4.1
Submission from: (NULL) (192.207.190.2)

In 2.4.6 FvwmEvent, Cmd Exec does not work properly.

The following minimal rc file exhibits the behavior.

The FvwmEvent setting:

*FvwmEvent: Cmd Exec /usr/bin/play

never results in play being called.  It appears that it is trying to Exec
the parameter (the sound file) instead of play.  The rc below results in
the .xsession-errors file below.

Using a function to call exec _does_ work and I am using that as my
work-around. (See the commented Cmd PlaySound).

Thanks for looking at this.

dar

#===========The .fvwm2rc file ==================================
Mouse 0 3 A WindowShade

#===============================================================
# Sound Stuff
#===============================================================
DestroyFunc PlaySound
AddToFunc PlaySound
+ I Exec exec /usr/bin/play $0

#*FvwmEvent: Cmd PlaySound
*FvwmEvent: Cmd Exec /usr/bin/play

*FvwmEvent: windowshade ~/sounds/science_maximize.wav 
*FvwmEvent: dewindowshade ~/sounds/science_minimize.wav 

Module FvwmEvent

============ The .xsession-errors file ================================
[FVWM][GetFontSetOrFixed]: WARNING -- can't get fontset 'fixed', trying
'-*-fixed-medium-r-normal-*-14-*-*-*-*-*-*-*'
/bin/sh: /home/drogers/sounds/science_maximize.wav: cannot execute binary
file
/bin/sh: /home/drogers/sounds/science_minimize.wav: cannot execute binary
file

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 4 May 2002 20:39:15 +0000

> work-around. (See the commented Cmd PlaySound).

Cmd gets one word parameter, so the correct syntax here is:

  *FvwmEvent: Cmd "Exec /usr/bin/play"

Regards,
Mikhael.