Subject: autoconf weirdness

From: Dominik Vogt <[email-masked]>
Date: Fri, 3 May 2002 12:58:10 +0200

Recently I have a problem with autoconf/configure.  This is
probably caused by updating the system:

  m4-1.4o-76
  automake-1.4_p5-44
  autoconf-2.52-44

With "./configure --help" I get lines like these for the configure
options that use the smr_SWITCH macro in acinclude.m4:

  --enable-command-log substr(             , 11) enable command logging
  --enable-debug-msgs substr(             , 10) enable debugging messages
  --disable-multipixmap-titles substr(             , 18) disable fancy pixmap ti

The responsible code from acinclude.m4:
  AC_DEFUN(smr_SWITCH, [
    AC_MSG_CHECKING(whether to enable $2)
    AC_ARG_ENABLE(
        $1,
        ifelse($3, on,
            [  --disable-[$1]substr([             ], len([$1])) disable [$2]],
            [  --enable-[$1] substr([             ], len([$1])) enable [$2]]),
  ...

It seems that the substr() m4 macro inside the ifelse() macro is
no longer expanded but taken literally.  I could not find a way to
make the expansion work again.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 5 May 2002 11:15:40 +0000

> probably caused by updating the system:

I think it is a time to make autoconf-2.52 (or maybe 2.53?) a requirement
and start to use its features and bug fixes over autoconf-2.13.

I am not sure yet about m4, I should see first how compatible are m4-1.4,
m4-1.4o and m4-1.4.1.

> make the expansion work again.

I will take a look at it after I get a chance to upgrade.
Currently you may remove substr(...) completely if it creates problems.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 7 May 2002 12:14:08 +0200

> Currently you may remove substr(...) completely if it creates problems.

Well, it's not really a serious problem.  The 'substr(...)' part
is simply displayed in the help message.

Bye

Dominik ^_^  ^_^