Subject: Colorset in 2.4.x

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 19 May 2002 03:01:19 +0000

When I used new configuration with fvwm-2.4.x, it crashed when trying to
broadcast Colorset that was not initialized from FvwmTheme.

It should not crash. It should not try to broadcast a non-dumped format.
Tim, can you please fix 2.4.x, so it either ignores a Colorset command
that is not in the old form or maybe even supports FvwmTheme syntax too?

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 19 May 2002 21:11:59 +0000

> that is not in the old form or maybe even supports FvwmTheme syntax too?

Don't worry about this. I already did both things (no log emails).
I added this code to CMD_Colorset:

  char *ptr;
  for (ptr = action; *ptr; ptr++)
  {
    if (*ptr != ' ' && !isxdigit(*ptr))
    {
      /* suppose it is a new Colorset command and pass it to FvwmTheme */
      char *old_action = action;
      action = CatString2("FvwmTheme Colorset ", action);
      CMD_SendToModule(F_PASS_ARGS);
      action = old_action;
      return;
    }
  }  

and:

  /* add a check to avoid crash in intentionally-incorect-config */
  if (LoadColorset(action) < 0)
    return;

Regards,
Mikhael.