Subject: CVS domivogt: * Implemented NoBorder/Border styles.

From: FVWM CVS <[email-masked]>
Date: Sun, 26 May 2002 16:47:32 -0500

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	02/05/26 16:47:32

Modified files:
	.              : ChangeLog NEWS 
	fvwm           : add_window.c borders.c decorations.c frame.c 
	                 fvwm.1 fvwm.h module_interface.c style.c 
	                 style.h window_flags.h 
	modules        : ChangeLog 
	modules/FvwmCommand: FvwmCommand.c 
	modules/FvwmDebug: FvwmDebug.c 

Log message:
* Implemented NoBorder/Border styles.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 26 May 2002 22:32:39 +0000

> * Implemented NoBorder/Border styles.

Ok, here is a new MaximizeFullScreen function:

  DestroyFunc MaximizeFullScreen
  AddToFunc   MaximizeFullScreen
  + I ThisWindow (Maximized) Style $n Title, Border
  + I CondCase (NoMatch) Style $n NoTitle, NoBorder
  + I CondCase (NoMatch) Raise
  + I CondCase (NoMatch) UpdateStyles
  + I Maximize

  Key F11  A  SC  Pick MaximizeFullScreen

Conditions HasBorder and HasTitle would help to restore the original
settings (that are stored in 2 window State-s).

I thought names NoBorders/Borders would be more logical if we have four
individual borders, but this is not very important.

Regards,
Mikhael.