Subject: readability of shadow text

From: Dominik Vogt <[email-masked]>
Date: Sun, 26 May 2002 17:18:57 +0200

I wonder if it's possible to improve the readability of shadow
text a bit.  With my default palette (pale blue window titles,
orange title on the focused window, black text), it's quite
difficult to read the title.  Two ideas to improve the
situation:

- Better contrast between shadow and text colours.
  Probably won't help much.

- Offset the shadow text by another pixel
  E.g.

  X    X
   X  X
    XX   .
   X .X .
  X   .X
     .  .
    .    .

  Instead of

  X    X
   X  X .
    XX .
   X .X
  X .  X
   .    .

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 26 May 2002 17:26:40 +0000

>   Probably won't help much.

Black text is not very good for shadowing, but this depends on font.
Try white text with your palettes. It looks very well.

Ideally shadow should enable more text colors to be readable on any bg.
I got very good results without changing the default fgsh calculations
with both black text and white text in your theme. Try:

  Style * Font "shadowsize=3:xft:Luxi Sherif:Bold:size=13"

Shadow size 2 is good too (and shadow size 1 with white).

> - Offset the shadow text by another pixel

Hmm, I though this will be even more ugly, but I am not sure now.
I patched the source (currently lines 1009-1010 in Flocale.c) and
offset 2 looks good with bold or Xft fonts, but not with others.

So, probably we may add a third argument to shadow:

  shadow=size[,directions[,offset]]

I also want to see whether shadow=1,br+b is ugly or not. Something like:

  X    X
  .X  X..
   .XX..
   X..X
  X.. .X
  ..   ..

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 26 May 2002 22:01:27 +0200

> Shadow size 2 is good too (and shadow size 1 with white).

Hm, I see no big difference with lucidasanstypewriter-12.  I took
a closer look:  what really irritates me is that the shadows fill
the inside of some letters, like O:

   XXX
  X   X
  X ..X 
  X.  X.
  X.  X.
   XXX .
   .   .
    ...
I think it might look better if the shadow is limited to the area
not covered by the regular text:

   XXX
  X   X
  X   X 
  X   X 
  X   X 
   XXX  
   .   .
    ...

This could be an option.

Bye

Dominik ^_^  ^_^

---

From: Olivier Chapuis <[email-masked]>
Date: Sun, 26 May 2002 22:36:23 +0200

> not covered by the regular text:

Yes this will be good, but ...
 
> This could be an option.

I do not see how to implement this in a simple way. It seems
to me that such rendering should be handled at an other
level than the fvwm library level.

Olivier

---

From: Olivier Chapuis <[email-masked]>
Date: Sun, 26 May 2002 22:39:58 +0200

>   shadow=size[,directions[,offset]]

 shadow=size [offset] directions

seems more logic for me.

> I also want to see whether shadow=1,br+b is ugly or not. Something like:

So ?

Olivier

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 26 May 2002 21:31:46 +0000

>  shadow=size [offset] directions

I have no objection. Although I don't see how it would be possible to
extend such syntax in the future, for example add outside-only boolean.

> > I also want to see whether shadow=1,br+b is ugly or not. Something like:

Yes, "br b" seems better than just "br" with good font and white text. :)
As I expected "1 all" gives really fun results, say: fg yellow, fgsh black

But it seems it makes sense to use more than 1 direction only with
size=1, otherwise the shadow is strewn, especialy with big sizes.
I think we may forse size=1 when more than 1 from 8 directions specified.
Or invent 24 (16) directions for size=2; 48 (24) directions for size=3...

Thank you. :)

Regards,
Mikhael.