Subject: Re: Notification: incoming/876

From: Dominik Vogt <[email-masked]>
Date: Mon, 27 May 2002 02:19:16 +0200

On Wed, Apr 17, 2002 at 05:34:05PM -0500, fvwm-bug wrote:
> FVWM Bug Tracking notification
> 
> new message incoming/876
> 
> Full_Name: Jan Echternach
> Version: 2.4.7
> CVS_Date: 
> OS: Linux
> X_Server: XFree86 3.3.6
> Submission from: (NULL) (62.104.208.83)
> 
> 
> Szenario: netscape uses a private colormap.  A transient window is opened
> (e.g. the "Find" dialog with Alt+F), also with a private colormap.  This
> new window gets the focus even if the pointer (FocusFollowsMouse) is not
> inside it.  Esc is pressed to close the transient window.
> 
> Case 1: Pointer is in the transient window: no problem.
> 
> Case 2: Pointer is outside the transient window, but inside the main
> netscape
> window: The colormap of the main window won't be restored properly, even
> though it gets the focus and the pointer is inside it.

Should be fixed with the next release.  Could you please try the
latest CVS code or tomorrow's snapshot and report back if the
problem goes away?

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Jan Echternach <[email-masked]>
Date: Wed, 29 May 2002 00:04:32 +0200

> latest CVS code or tomorrow's snapshot and report back if the

I have tried fvwm-snap-20020528.tar.gz.  The colormap problem has
disappeared, but now the netscape window has the effect of SloppyFocus
(other windows like xterm don't have it, and with fvwm-2.4.7 no
window has SloppyFocus).  I've used the same .fvwm2rc file with both
fvwm versions.

BTW, my keyboard bindings (e.g. "Key Left A 3 Scroll -100 0") don't work
with fvwm-snap-20020528.

-- 
Jan                           fortune: can't load library '/libc.so.4'
                                      No such library.

---

From: Jan Echternach <[email-masked]>
Date: Wed, 29 May 2002 00:17:12 +0200

> window has SloppyFocus).  I've used the same .fvwm2rc file with both

That diagnosis was too quick.  The netscape window actually loses the
focus as it should, but the color map of the root window is not restored.
So it looks as if netscape still has the focus at the first glance, but
F1, for example, does open fvwm's builtin menu, and upon showing the
popup window (or when the pointer is moved into another window), the
normal colormap is restored and the desktop looks normal again.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 29 May 2002 14:04:06 +0200

> normal colormap is restored and the desktop looks normal again.

Can you please give me step by step instructions to reproduce the
problem, including the relevant config lines?  I don't know how to
test this in the first place, but I think the colour map focus and
the keyboard focus should stay in the same window.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Jan Echternach <[email-masked]>
Date: Thu, 30 May 2002 00:22:42 +0200

> the keyboard focus should stay in the same window.

Open a window (e.g. "netscape -install", "xv -owncmap"), move pointer into
window, move pointer out of window (to the root window).  Now the xv or
netscape window has its color map still installed (i.e. it looks good,
the rest of the screen is garbled), but the application's key bindings
are no longer active ('q' doesn't quit xv etc.).  The root window's key
bindings are active instead (e.g. F1 opens fvwm's builtin menu).

I have noticed a short screen flicker when the pointer is moved out
of an xv window to its border or title bar.  And if the pointer is
moved very quickly out of the window, the root window's color map _is_
restored properly.  The netscape window doesn't show this behaviour.

Style * ForeColor       Black
Style * BackColor       DarkOliveGreen4
Style * HilightFore     Black
Style * HilightBack     "indian red"
Style * BorderWidth 5, HandleWidth 5
Style   "*"     FvwmBorder  # MWMBorder
Style   "*"     FvwmButtons
HideGeometryWindow Never
SnapAttraction 0 SameType Screen
OpaqueMoveSize 100
Style * WindowShadeSteps 0
EdgeScroll 100 100
EdgeResistance 250 20
EdgeThickness 1
Style * MinOverlapPlacement
Style * MWMFunctions
Style * MWMDecor
Style * HintOverride
Style * OLDecor
Style * DecorateTransient, RaiseTransient, LowerTransient, StackTransientParent