Subject: dynamism in FvwmButtons

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 29 May 2002 20:59:58 +0000

I miss some dynamism in FvwmButtons. Here are some my future plans.

I will replace the currently undocumented syntax:

  SendToModule FvwmButtons Title/Icon <button-id> text

with:

  SendToModule FvwmButtons ChangeButton <button-id> Title/Icon <value>

I will add changing Font and maybe some more button properties as well.

<value> will be a token for consistency, i.e. should be enclosed into
quotes if it has spaces. This is to enable changing of more than 1
property at once, i.e.: ChangeButton 5 Title "abc", Icon "my.png"

<button-id> may be as it is now, number starting from 0 or "+x+y".
I will also add a syntax similar to "2/3" meaning the button number 3
in the container number 2. Should the syntax start counting from 0 or 1?

I may think about adding other actions like:

  AddToButton <button-id> <property> <value>
  DeleteFromButton <button-id> <property>
  AddEmptyButtonToEnd
  AddEmptyButtonToContainer <container-number>
  AddEmptyContaner...

but I am not sure yet that I will really need them.
Some of these action should change the geometry of FvwmButtons...
What I do need is this action:

  ChangeContainer <container-id> <property> <value>

I also need a Show/Hide boolean option in containers (and possibly in
single buttons) that will (statically or dynamically) show/hide a whole
container or a button. I.e. something like this:

  *FvwmButtons: (Show, Title title1, Font font1, Icon icon1)
  *FvwmButtons: (Hide, Title title2, Font font2, Icon icon2)

Then dynamically:

  SendToModule FvwmButtons ChangeButton 1 Hide; 2 Show

Here ";" unlike "," belongs to ChangeButton, compare with the following:

  SendToModule FvwmButtons ChangeButton 1 Hide, Show, Title my-text

I will not do everything, but I will start this.
Any other ideas or volunteers to do some of the work are welcome.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 29 May 2002 21:22:16 +0000

> in the container number 2. Should the syntax start counting from 0 or 1?

One addition. Id will be optionally specified in any button, i.e.:

  *FvwmButtons: (Id current_time, Title 14:00)

  SendToModule FvwmButtons ChangeButton current_time Title 14:01

Regards,
Mikhael.