Subject: [<[email-masked]>] Bug#145315: fvwm: Using color blue for window backgrounds or button backgrounds looks wierd

From: Alexander Kotelnikov <[email-masked]>
Date: Wed, 01 May 2002 16:11:46 +0400

Hello.

Note, right and down side of 3D buttons are _lighter_ than button
itself as well as left and up sides.

Subject: Bug#145315: fvwm: Using color blue for window backgrounds or button backgrounds looks wierd
From: <[email-masked]>
To: [email-masked]
Date: Tue, 30 Apr 2002 12:57:16 -0400

Package: fvwm
Version: 2.4.6-2
Severity: normal

If I set a window's title background to a blue color (style * backcolor blue),
the window looks wierd.  It doesn't do this with red,cyan,purple.  It also
does this same thing with FvwmButtons.

If you want to see what I mean, look at
http://animx.eu.org/~wakko/fvwm-weird.png

Just incase the server's down, I uuencoded this and attached it.

-- System Information
Debian Release: 3.0
Kernel Version: Linux nec 2.4.14 #1 Wed Nov 14 09:07:50 EST 2001 i586 unknown

Versions of the packages fvwm depends on:
ii  libc6          2.2.5-4        GNU C Library: Shared libraries and Timezone
ii  libglib1.2     1.2.10-4       The GLib library of C routines
ii  libgtk1.2      1.2.10-11      The GIMP Toolkit set of widgets for X
ii  libncurses5    5.2.20020112a- Shared libraries for terminal handling
ii  libreadline4   4.2a-5         GNU readline and history libraries, run-time
ii  libstroke0     0.5.1-2        support for mouse strokes like those in Ment
ii  xlibs          4.1.0-16       X Window System client libraries

--- Begin fvwm-weird.png
begin-base64 644 fvwm-weird.png
====
--- End fvwm-weird.png

-- 
Alexander Kotelnikov
Saint-Petersburg, Russia

---

From: Dan Espen <[email-masked]>
Date: Wed, 01 May 2002 08:47:38 -0400

> itself as well as left and up sides.

The image contains 2 examples:

base color hilight  shadow
========== =======  ======
00/00/70   78/7c/b8 48/4c/98
60/00/60   88/00/88 00/00/00

The first one 00/00/70 (blue) is considered too dark
so instead of using black for a shadow, it uses something
lighter.  This is by design.  (Whether its correct, is debatable.)
The way my monitor is adjusted, I think black would be OK next to this
color.

To gain more control of shadow/highlight colors, you can use
colorsets.

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]