Subject: CVS migo: * Changed the syntax of FvwmIconMan to conform to other modules.

From: FVWM CVS <[email-masked]>
Date: Sat, 06 Apr 2002 18:35:35 -0600

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	migo	02/04/06 18:35:35

Modified files:
	.              : ChangeLog INSTALL.fvwm NEWS 
	modules        : ChangeLog 
	modules/FvwmIconMan: ConfigFvwmIconMan FvwmIconMan.1 
	                     readconfig.c 
	modules/FvwmTheme: FvwmTheme.1 
	sample.fvwmrc  : new-features system.fvwm2rc 
	                 system.fvwm2rc-sample-95 

Log message:
* Changed the syntax of FvwmIconMan to conform to other modules.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 7 Apr 2002 00:54:40 +0000

> * Changed the syntax of FvwmIconMan to conform to other modules.

The old syntax that uses asterisks is still supported.
So currently all 4 syntaxes below work:

  *FvwmIconMan: Resolution page
  *FvwmIconMan: 1 Font 7x13
  *FvwmIconMan:   transient   Resolution   global

  *FvwmIconMan: *Resolution page
  *FvwmIconMan: *1*Font 7x13
  *FvwmIconMan: *transient*Resolution   global

  *FvwmIconMan Resolution page
  *FvwmIconMan 1 Font 7x13
  *FvwmIconMan   transient   Resolution   global

  *FvwmIconMan*Resolution page
  *FvwmIconMan*1*Font 7x13
  *FvwmIconMan*transient*Resolution   global

But please use the syntax documented in the man page, the first one.

I hope I didn't break anything. I tested it, but please test too.

Regards,
Mikhael.