Subject: FvwmForm glitches

From: Giuseppe Della Ricca <[email-masked]>
Date: Sat, 6 Apr 2002 09:58:25 +0200 (CEST)

Hi !

from time to time (yes ... this is one of those non-easily-reproducible 
things !!), the FvwmForm panel I use to restart fvwm shows a strange 
behaviour when I click on the 'Restart' button: as usual, when I move on 
the button the pointer changes to 'hand2', and as usual, when I click on 
the button the 'hand' colors are reversed, but then nothing happens (fvwm 
is not restarted), the 'hand' colors stay reversed and I have to click on 
the button once again.

I can just guess that the click is 'eaten' somewhere between the change of 
the pointer colors and the Command in the FvwmForm panel ...

I'm using the following config for FvwmForm:

DestroyModuleConfig FvwmForm-Restart: *
*FvwmForm-Restart: GrabServer
*FvwmForm-Restart: WarpPointer
*FvwmForm-Restart: Colorset 1
*FvwmForm-Restart: ItemColorset 1
*FvwmForm-Restart: Font       -adobe-helvetica-bold-r-*-*-14-*-*-*-*-*-*-*
*FvwmForm-Restart: ButtonFont -adobe-helvetica-bold-r-*-*-11-*-*-*-*-*-*-*
*FvwmForm-Restart: InputFont  -adobe-helvetica-bold-r-*-*-14-*-*-*-*-*-*-*
# begin items
*FvwmForm-Restart: Line       center
*FvwmForm-Restart: Text       "Do you really want to restart FVWM?"
*FvwmForm-Restart: Line       expand
*FvwmForm-Restart: Button     quit "Restart" ^M
*FvwmForm-Restart: Command    Restart
*FvwmForm-Restart: Button     quit "Cancel"
*FvwmForm-Restart: Command    Nop
*FvwmForm-Restart: Timeout    10 Restart "Automatic restart will occur in %% seconds."

I'm using the CVS version. I'll be happy to do tests and provide more 
informations if needed. Please CC for a faster feedback, since I'm not 
subscribed.

Cheers,
Giuseppe.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sat, 06 Apr 2002 07:22:23 -0500

> the pointer colors and the Command in the FvwmForm panel ...

I don't think its the change in pointer colors,
I believe the problem was there before that.

The problem won't occur if you use "Activate on Press".

I'm not sure what causes it.

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Giuseppe Della Ricca <[email-masked]>
Date: Sat, 6 Apr 2002 15:14:14 +0200 (CEST)

Thanks !!!

for both the FvwmForm (Dan) and the PNG/configure.in (Olivier) fixes !

Bye,
Giuseppe.