Subject: Two small fixes

From: Giuseppe Della Ricca <[email-masked]>
Date: Sat, 6 Apr 2002 09:46:27 +0200 (CEST)

Hi !

I have PNG installed on my RH7.2 Linux box, but configure fails checking 
png.h, with the error (from config.log):

configure:3308: checking for png.h
configure:3318: gcc -E   -lz -lm conftest.c >/dev/null 2>conftest.out
gcc: -lz: linker input file unused since linking not done
gcc: -lm: linker input file unused since linking not done
configure: failed program was:
#line 3313 "configure"
#include "confdefs.h"
#include <png.h>

The problem seems to be around line 3301 of configure:
    CPPFLAGS="$CPPFLAGS -lz -lm"
Changing it to
    CPPFLAGS="$CPPFLAGS"
fixes it (but I don't know how to propagate the fix to the right place in 
configure.in, sorry ....).

I've also noticed in FvwmForm.c a double debug statement (around line 1840):

    myfprintf((stderr, "Final command[%d]: [%s]\n", k, parsed_command));
    fprintf(stderr, "Final command[%d]: [%s]\n", k, parsed_command);

I guess the second one can be safely removed.

Thanks a lot !!

Cheers,
Giuseppe.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Giuseppe Della Ricca <[email-masked]>
Date: Sat, 6 Apr 2002 10:02:47 +0200 (CEST)

OOpps ... I forgot to add that I'm using the latest CVS version.
Please CC if you need faster feedback, since I'm not subscribed.

Giuseppe.

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 6 Apr 2002 14:34:35 +0200

> configure.in, sorry ....).

I think this is fixed now I've inverted two parameters of smr_CHECK_LIB
(defined in acinclude.m4).

Olivier