Subject: test -e not supported on Solaris (configure.in perl test)

From: tim phipps <[email-masked]>
Date: Fri, 19 Apr 2002 11:21:09 +0100

Configuration Information [Automatically generated, do not change]:
uname: SunOS silver 5.5.1 Generic_103640-39 sun4u sparc SUNW,Ultra-5_10
compiler flags: gcc -g -O2 -Wall -Wno-implicit-int

FVWM Version:	2.5.1
FVWM_MODULEDIR:	/u/phippst/sunos/libexec/fvwm/2.5.1
FVWM_DATADIR:	/u/phippst/sunos/share/fvwm
FVWM_USERDIR:	/u/phippst/.fvwm

Description:
	configure bombs out becasue /bin/sh on Solaris 2.5 doesn't
	do [ -e "$PERL" ]

	-f works for me but it's probably not the right thing because
	that just tests for a regular file.
	
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Cameron Simpson <[email-masked]>
Date: Fri, 26 Apr 2002 19:10:00 +1000

On 11:21 19 Apr 2002, tim phipps <[email-masked]> wrote:
| Description:
| 	configure bombs out becasue /bin/sh on Solaris 2.5 doesn't
| 	do [ -e "$PERL" ]
| 
| 	-f works for me but it's probably not the right thing because
| 	that just tests for a regular file.

-x (executable regular file) and -d (directory) are also fairly specific
and portable, depending what you're testing.
-- 
Cameron Simpson, DoD#743        [email-masked]    http://www.zip.com.au/~cs/

..to know him was to love him. And to love him was to know him. Those who
know him LOVED him - while those who did not know him, loved him from afar...
	- Data/Graves, "The Schizoid Man", stardate 42437.5
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 26 Apr 2002 10:17:49 +0000

> and portable, depending what you're testing.

There is no portable way to test for symlinks that I know of, except
for replacing ancient /bin/sh like the ones in ULTRIX, AIX, SunOS.
Anyway, this is not needed, since we test perl by running.

Regards,
Mikhael.