Subject: CVS olicha: * Added PNG support and Dominikisation of the XPM support

From: FVWM CVS <[email-masked]>
Date: Fri, 05 Apr 2002 03:24:36 -0600

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	olicha	02/04/05 03:24:36

Modified files:
	.              : ChangeLog acconfig.h configure.in 
	fvwm           : Makefile.am add_window.c builtins.c cursor.c 
	                 ewmh_icons.c fvwm.h icons.c menus.c menustyle.c 
	                 modconf.c move_resize.c 
	libs           : ColorUtils.c Colorset.c Fft.c Flocale.c 
	                 Graphics.c Makefile.am Picture.c Picture.h 
	                 fvwmlib.h 
	modules        : ChangeLog 
	modules/FvwmAnimate: FvwmAnimate.c Makefile.am 
	modules/FvwmAuto: Makefile.am 
	modules/FvwmBacker: Makefile.am 
	modules/FvwmBanner: FvwmBanner.c Makefile.am 
	modules/FvwmButtons: FvwmButtons.c FvwmButtons.h Makefile.am 
	                     icons.c 
	modules/FvwmCpp: FvwmCpp.c Makefile.am 
	modules/FvwmDragWell: Makefile.am fvwmDragWell.c 
	modules/FvwmEvent: Makefile.am 
	modules/FvwmForm: FvwmForm.c Makefile.am 
	modules/FvwmGtk: FvwmGtk.c Makefile.am menu.c 
	modules/FvwmIconBox: FvwmIconBox.h Makefile.am icons.c 
	modules/FvwmIconMan: Makefile.am 
	modules/FvwmIdent: Makefile.am 
	modules/FvwmM4 : FvwmM4.c Makefile.am 
	modules/FvwmPager: Makefile.am 
	modules/FvwmRearrange: Makefile.am 
	modules/FvwmSave: Makefile.am 
	modules/FvwmSaveDesk: Makefile.am 
	modules/FvwmScript: FvwmScript.c Makefile.am types.h 
	modules/FvwmScript/Widgets: Tools.c 
	modules/FvwmScroll: FvwmScroll.c GrabWindow.c Makefile.am 
	modules/FvwmTaskBar: ButtonArray.h Makefile.am Start.c 
	modules/FvwmTheme: FvwmTheme.c Makefile.am 
	modules/FvwmWharf: FvwmWharf.c Makefile.am Wharf.h icons.c 
	                   stepgfx.c 
	modules/FvwmWinList: Makefile.am 
	utils          : ChangeLog Makefile.am fvwm-menu-desktop.in 
	                 xpmroot.c 
Added files:
	libs           : FImageLoader.c FImageLoader.h Fpng.h Fxpm.h 
	                 InitPicture.c InitPicture.h 
	modules/FvwmBanner: fvwm-logo-current.xbm 

Log message:
* Added PNG support and Dominikisation of the XPM support
* PNG support and now ewmh icons use ColorLimit
* These is achieved with new libs stuff and segmentation of libs/Picture
* Use the libs to load image everywhere: no more real XPM ifdef in fvwm code
* Added XBM (and of course PNG) support to FvwmBanner and xpmroot, there
are now compiled and installed even if !XPM
* Fixed FvwmScript icon loading, compile and install it even if !XPM
* Some include clean up and links the modules against Xpm and png only
if needed, hum...
* fvwm-menus-desktop allows png image in fvwm menu
* TODO: doc, maybe ColorLimit works, alpha rendering: need discussion and
probably colorlimit works, maybe some cleanup , may be some renaming :o(

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 8 Apr 2002 10:45:30 +0200

> * Added PNG support and Dominikisation of the XPM support

ROFL :-)=)

I'll be back to work this evening.  Needed a week off.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]