Subject: Notification: incoming/880

From: [email-masked]
Date: Fri, 19 Apr 2002 20:32:51 -0500

FVWM Bug Tracking notification

new message incoming/880

Message summary for PR#880
	From: [email-masked]
	Subject: feature request: ResizeUnshades
	Date: Fri, 19 Apr 2002 20:32:50 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Fri Apr 19 20:32:51 2002
From: [email-masked]
To: [email-masked]
Subject: feature request: ResizeUnshades
Date: Fri, 19 Apr 2002 20:32:50 -0500

Full_Name: Neil Zanella
Version: 2.4.6
CVS_Date: 
OS: 
X_Server: 
Submission from: (NULL) (129.128.206.232)

It would be nice if there were an option called ResizeUnshades such that
when a window is shaded and the user resizes it the window becomes
automatically unshaded so that when the mouse button is released
the whole window is visible once again.

Thanks,

Neil

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 22 Apr 2002 12:17:35 +0200

> the whole window is visible once again.

You don't need a new option to do this.  Use this function:

  AddToFunc ResizeUnshade
  + I WindowShade off
  + I Resize $*

Now, replace "Resize" with "ResizeUnshade" whereever you need it.
 
Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]