Subject: Naming problems

From: Olivier Chapuis <[email-masked]>
Date: Sat, 6 Apr 2002 22:48:33 +0200

Hello,

I've a few (re)naming problems.

1 - As fvwm, XRender use Picture as its main "picture" structure.
This is currently solved by the following lines in Fft.h

#ifdef HAVE_XFT
#define Picture XRenderPicture
#include <X11/Xft/Xft.h>
#undef Picture
#define Picture Picture
#endif

Not terrible ... specially if we use XRender for alpha rendering.
So I suggest to rename the fvwm Picture structure by FvwmPicture.
And so also rename libs/Picture.{c,h}: FvwmPicture.{c,h} or
FPicture.{c,h}. Any better idea?

2 - When I split Picture into Picture and InitPicture I was not very
inspired for the name of "InitPicture" and I have still no good idea.
InitPicture contains the visual stuff init (Pvisual, Pdepth, Pcmap)
and the image path stuff and the fvwm Picture structure  (as picture
contains picture manipulation). Any suggestions for a better
name for InitPicture?

3 - Now that xpmroot support PNG (and XBM) should we rename it (with a
symbolic link from xpmroot to the new name)? If yes one may think
that fvwm-root is a good name, but I do not think so because in fvwm
"-" separated names are scripts. FvwmRoot is obviously bad, but what
about "fvwmroot" ?

Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 6 Apr 2002 21:41:25 +0000

> "-" separated names are scripts. FvwmRoot is obviously bad, but what

If you ask me, I think every executable we install except for fvwm itself
(current fvwm2) should be prefixed with "fvwm-".  fvwm-bug, fvwm-root,
fvwm-convert-2.4. fvwm-convert-2.6, fvwm-config.

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Sun, 07 Apr 2002 16:45:16 -0400

> I've a few (re)naming problems.

Opinions follow.

> FPicture.{c,h}. Any better idea?

FPicture.{c,h} is good.

> contains picture manipulation). Any suggestions for a better

Name it after its externs, PPicture.c.

> "-" separated names are scripts. FvwmRoot is obviously bad, but what

fvwm-root, I don't see why the fvwm- rule can't be used for binaries.

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 8 Apr 2002 10:52:21 +0200

> > FPicture.{c,h}. Any better idea?

The original idea was to replace the 'X' with an 'F' where
appropriate (Xft -> Fft, XShape -> FShape).  If there is no chance
that we need FPicture for something different the name is good.

> fvwm-root, I don't see why the fvwm- rule can't be used for binaries.

I agree.  Especially since there's some other tool named xpmroot
on the net.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 8 Apr 2002 14:25:54 +0000

On 08 Apr 2002 10:52:21 +0200, Dominik Vogt wrote:
> 
> Especially since there's some other tool named xpmroom on the net.

I think we own exclusive rights on xpmroot (well, Rob Nation). :)
So we may continue with it, symlinked.

It was xselection that there is on the net. But I removed it from
installation a year ago.

Regards,
Mikhael.

---

From: Cameron Simpson <[email-masked]>
Date: Tue, 9 Apr 2002 13:45:57 +1000

On 21:41 06 Apr 2002, Mikhael Goikhman <[email-masked]> wrote:
| On 06 Apr 2002 22:48:33 +0200, Olivier Chapuis wrote:
| > 3 - Now that xpmroot support PNG (and XBM) should we rename it (with a
| > symbolic link from xpmroot to the new name)? If yes one may think
| > that fvwm-root is a good name, but I do not think so because in fvwm
| > "-" separated names are scripts. FvwmRoot is obviously bad, but what
| > about "fvwmroot" ?
| 
| If you ask me, I think every executable we install except for fvwm itself
| (current fvwm2) should be prefixed with "fvwm-".  fvwm-bug, fvwm-root,
| fvwm-convert-2.4. fvwm-convert-2.6, fvwm-config.

I second this opinion. It shouldn't matter whther something's implementation
is a script or not.
-- 
Cameron Simpson, DoD#743        [email-masked]    http://www.zip.com.au/~cs/

Heaven could change from chocolate to vanilla without violating perfection.
	- [email-masked] (Ken Arromdee)
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 12 Apr 2002 21:39:54 +0200

> that we need FPicture for something different the name is good.

Yep, but so the F is not really needed? So I think that:

PictureCommon (the depth, visual, ..., the FvwmPicture structure, path stuff,
               it is at present time InitPicture)
Picture       (elementary FvwmPicture manimulation)
PictureImageLoader (image loading, at the present time FImageLoader)
PictureGraphics    (rendering Picture or set of Pixmaps: a set of warpers
                    for XCopyArea, XFillRectangle and XRenderComposite;
                    on my machine  only :o), 

or the same with a F as prefix?

Olivier