Subject: EILSEQ not defined

From: Dave Trollope <[email-masked]>
Date: Wed, 03 Apr 2002 21:12:20 -0600

Hi All,

I'm trying to compile the latest code, and am getting an EILSEQ
undefined in Ficons.c. This was in ewmh_names.c in the 3/17 snapshot.

I'm using cygwin, and don't see this define in sys/errno.h. Can someone
explain what this error code represents? Perhaps configure can check for
this in /usr/include/sys/errno and set a flag to include it if it
exists, or perhaps there is a more common error code that can be
checked?

Cheers
Dave
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 03 Apr 2002 22:35:35 -0500

Dave Trollope <[email-masked]> writes:
> explain what this error code represents?

This is in bits/errno.h on Linux:

#if !defined _ERRNO_H && defined __need_Emath
/* This is ugly but the kernel header is not clean enough.  We must
   define only the values EDOM and ERANGE in case __need_Emath is
   defined.  The value is the same for all Linux ports.  */
# define EDOM	33	/* Math argument out of domain of function.  */
# define EILSEQ	84	/* Illegal byte sequence.  */
# define ERANGE	34	/* Math result not representable.  */
#endif /* !_ERRNO_H && __need_Emath */

> Perhaps configure can check for

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dave Trollope <[email-masked]>
Date: Wed, 03 Apr 2002 21:48:47 -0600

Hi Dan,

bits doesn't exist in cygwin. Does it exist on solaris? I can check at work
tomorrow. Is the dir bits Linux specific?

Cheers
Dave

---

From: Dan Espen <[email-masked]>
Date: Wed, 03 Apr 2002 22:56:33 -0500

> tomorrow. Is the dir bits Linux specific?

Hi Dave,

Nope, its not Linux specific, I see the definitions on Solaris, HPUX,
and AIX.

---

From: Dan Espen <[email-masked]>
Date: Wed, 03 Apr 2002 23:07:23 -0500

> tomorrow. Is the dir bits Linux specific?

I'm sorry, I just noticed you asked about the "bits" directory.

That value in defined in 2 subdirectories to /usr/include
on my Linux machine, bits and asm.  On each system I checked
it was in a different location, but I believe all the definitions
occurred if you included errno.h.