Subject: Re: png loader

From: "Suzanne Skinner" <[email-masked]>
Date: Sat, 6 Apr 2002 03:02:35 -0500

On Sun, Mar 31, 2002 at 10:33:42PM +0200, Dominik Vogt wrote:

> Well, if you have time to spare you could take a look at the
> FANCY_TITLE_BAR ifdefs.  I didn't test that at all when I rewrote
> the decoration layout code and it's very likely to be completely
> broken now :-)

Could do, if desired. I wouldn't want to step on Michael Goikhman's feet,
though :-) I think he wants to maintain it now?

Suzanne

-- 
[email-masked] - http://www.igs.net/~tril/
"That's when it dawned on me that what I really disliked about procmail was the
recipe format. I didn't want to handle my mail with a collection of colons,
zeroes, and single-letter commands that made sendmail.cf look like a
Shakespearean sonnet."      -- Simon Cozens
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 6 Apr 2002 15:27:40 +0000

> though :-) I think he wants to maintain it now?

Suzanne, I like your idea and may commit patches, but why I would want to
maintain it if the author may do this better? :)

It would be very nice if you may adapt it to the new decoration code.

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 6 Apr 2002 22:00:10 +0200

On Sat, Mar 30, 2002 at 03:11:56PM -0500, Suzanne Skinner wrote:
> > Hum, I do not promise alpha rendering (at least for the moment).
> > The first approach will map the alpha channel (which goes from 0 to 255)
> > to {0,1} something like: if alpha > 150 then render the point as is if
> > the alpha <= 150 put the point out of the mask.
> 
> Well, given that foundation to work from, I may be able to hack alpha-blending
> myself :-)
>

Here my plan: fist I think that it will be cool to have alpha rendering
now that we have basic PNG support. I make a few test with the XFree XRender
extension and I think that it is the more easy way to take (and the most
fast too). So, if there is no objection I will see if it is possible
to add new libs stuff "FRenderPicture" to render image/icons all around
fvwm code (partially done with FvwmTheme).
After that if one wish it will be possible to write by hands some
replacement for the magic XRender function.

Olivier

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 22 Apr 2002 18:41:53 +0000

On 06 Apr 2002 03:02:35 -0500, Suzanne Skinner wrote:
> Could do, if desired.

We did not release 2.5.x for a long time. I think we should release 2.5.1
in a week or so, since the new window decoration code works well now.
Basically everything seems to work now except for TitleStyle MultiPixmap
and ButtonStyle Solid.

Suzanne, can you please estimate the amount of work needed?
Should we release 2.5.1 with or without working TitleStyle MultiPixmap?

Regards,
Mikhael.

---

From: "Suzanne Skinner" <[email-masked]>
Date: Mon, 22 Apr 2002 19:33:33 -0400

> Should we release 2.5.1 with or without working TitleStyle MultiPixmap?

Hmm....I guess I finally need to learn how to use CVS :-)

I'll take a look at it and try to get a response back on this tonight.

Suzanne

---

From: "Suzanne Skinner" <[email-masked]>
Date: Mon, 22 Apr 2002 21:55:00 -0400

> I'll take a look at it and try to get a response back on this tonight.

Hmm...I'm having a hard time getting the latest snapshot to compile. Maybe
I should go All The Way to current CVS.

I'm not sure if I'll be able to get the titlebars working again, but I'll
give it a shot and probably let you guys know within a few days if I can
manage it.

Suzanne

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 23 Apr 2002 11:36:54 +0200

> Basically everything seems to work now except for TitleStyle MultiPixmap

I would have fixed the solid button style already if somebody told
me what was broken.  I tried it and it works fine for me.  I need
a config example.

> Should we release 2.5.1 with or without working TitleStyle MultiPixmap?

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 23 Apr 2002 12:51:45 +0000

> me what was broken.  I tried it and it works fine for me.  I need

Solid just does nothing. A minimal rc file:

  TitleStyle      Inactive Solid darkcyan
  ButtonStyle All Inactive Solid navy

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 23 Apr 2002 15:42:35 +0200

>   ButtonStyle All Inactive Solid navy

Fixed.

Bye

Dominik ^_^  ^_^

---

From: "Suzanne Skinner" <[email-masked]>
Date: Tue, 23 Apr 2002 11:12:58 -0400

> Should we release 2.5.1 with or without working TitleStyle MultiPixmap?

I'd say without. I've just started playing with CVS and I'm mystified as
to why it's not working. I don't know if I'll figure it out in time for
the next release.

(BTW, you guys aware that fvwm doesn't compile with ----disable-multibyte?)

Suzanne

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 23 Apr 2002 15:26:19 +0000

> to why it's not working. I don't know if I'll figure it out in time for

Strange, when I first learned cvs using http://fvwm.org/cvs.html
it worked from the first time for me. :)

> (BTW, you guys aware that fvwm doesn't compile with --disable-multibyte?)

Now when you reported, yes. There is one missing #if and one warning
in Flocale.c, I may fix it.

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 24 Apr 2002 06:16:27 +0200

> give it a shot and probably let you guys know within a few days if I can

What about using colorsets in the place of image files?
 
Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 24 Apr 2002 13:25:10 +0200

> What about using colorsets in the place of image files?

That's an *excellent* idea.  The colorset code is also the right
place to implement pixmap rotation and/or mirroring if we want to
go this way.

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 25 Apr 2002 00:54:30 +0000

> place to implement pixmap rotation and/or mirroring if we want to

The idea is right, but is it a time to implement it?

If this is implemented the rest of TitleStyle <style> functionality may be
removed, because all Solid, XGradient, TiledPixmap are already included in
MultiPixmap (i.e. MultiColorset).

Some of the options in the current MultiPixmap affect ButtonStyle with
UseTitleStyle, so probably ButtonStyle should be converted to colorsets
as well, otherwise UseTitleStyle will not work.

Currently the syntax may be the old one, but new options are colorsets.

  ButtonStyle <which> <when> Colorset <n> -- <flags>

  TitleStyle <when> MainColorset <n> -- <flags>

ButtonStyle Vector and MiniIcon should be drawn above colorset area.
Flags probably can't be integrated into colorset, so should stay.

New MainColorset option replaces the old ones Solid, XGradient and
TiledPixmap, should they still be supported?

Other colorsets that TitleStyle should support (see "MultiPixmap" in the
man page):

  MainColorset
  LeftMainColorset
  RightMainColorset
  UnderTextColorset
  LeftOfTextColorset
  RightOfTextColorset
  LeftEndColorset
  RightEndColorset
  ButtonsColorset
  LeftButtonsColorset
  RightButtonsColorset

Too much colorsets, but not all are used for a specific titlebar design.
Only one MainColorset is needed for the 2.4.x themes.

If "ButtonStyle Colorset" and "TitleStyle MainColorset" are implemented,
the rest seems not very hard. Removing flickering seems harder.

But who is a volunteer to implement TitleStyle MainColorset? :)
Olivier, Dominik?

Anyway, this is not for 2.5.1, which I want to release in a few days.

Regards,
Mikhael.