Subject: no edge resistance?

From: Richard Lister <[email-masked]>
Date: Thu, 25 Apr 2002 17:41:49 -0400 (EDT)

Hi folks

I briefly tried running fvwm-snap-20020425 and don't get edge resistance
when moving a window using meta+mouse-3, i.e. the following binding:

  Mouse 3 	W M	Move-or-Raise

  DestroyFunc Move-or-Raise
  AddToFunc Move-or-Raise	"I" Raise
  +				"M" Move
  +  				"D" Lower

Dragging by mouse-1 in the titlebar works correctly.

Everything works fine in 2.5.0.

Cheers
Ric

Richard J Lister
Dept of Neuroscience, Georgetown University Medical Center
Email: [email-masked] 
Web: http://cns.georgetown.edu/~ric/
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 25 Apr 2002 22:02:21 +0000

> Everything works fine in 2.5.0.

  http://www.hpc.uh.edu/fvwm/archive/0204/msg00192.html

Regards,
Mikhael.

---

From: Richard Lister <[email-masked]>
Date: Thu, 25 Apr 2002 18:15:48 -0400 (EDT)

From: Mikhael Goikhman <[email-masked]>
Subject: Re: no edge resistance?
Date: Thu, 25 Apr 2002 22:02:21 +0000

>   http://www.hpc.uh.edu/fvwm/archive/0204/msg00192.html

Great, thanks. I should have checked the archive. Is there a way to
disable Alt's new behaviour?

I think this one may catch out a few people who originally came from twm.

Ric

Richard J Lister

---

From: Cameron Simpson <[email-masked]>
Date: Sat, 27 Apr 2002 21:36:45 +1000

On 18:15 25 Apr 2002, Richard Lister <[email-masked]> wrote:
| From: Mikhael Goikhman <[email-masked]>
| >   http://www.hpc.uh.edu/fvwm/archive/0204/msg00192.html
| 
| Great, thanks. I should have checked the archive. Is there a way to
| disable Alt's new behaviour?

Me too! I use Alt-M2 to move, and find this, well, disconcerting.
I don't use snap attraction myself, but I use EdgeResistance.

Can this be modified to
	- be off altogether
	- be attached to something else: a different modifier maybe
	- just be an attribute of move eg "Move (NoConstraints)" or something
	  so people can just pick one move or other?

Is this documented? I spent quite some time today rereading the manual,
but it is quite long and I could have missed it.

| I think this one may catch out a few people who originally came from twm.

Heh. People who came from Fvwm 2.4.4 too.
-- 
Cameron Simpson, DoD#743        [email-masked]    http://www.zip.com.au/~cs/

I'm a 47-year-old middle-class male with a job.  Every hippy-dippy thing
that's thought up--from heroin addiction to special vegan lunch lines in the
high school cafeteria--I get to pay for. Of course I'm Republican.
	-  P. J. O'Rourke
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 27 Apr 2002 22:17:11 +0000

> I don't use snap attraction myself, but I use EdgeResistance.

Ok, snap is always initially enabled now. You should press Alt for the
second time to disable snap, see url.

Regards,
Mikhael.