Subject: core dump in menus with SelectOnRelease

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 26 Apr 2002 19:48:19 +0000

I can reproduce this easily. Press the default Alt-Tab, move mouse outside
of the menu, release Alt. The problem is not in 2.4.x.

#0  0x08050c1c in MenuInteraction (pmp=0xbfffedd0, pmret=0xbfffed40,
    pdkp=0xbfffeb50, pdo_warp_to_title=0x80b2058) at menus.c:2449
2449      if (pmret->rc == MENU_SELECTED && MI_FUNC_TYPE(mi) == F_TEARMENUOFF)
(gdb) where
#0  0x08050c1c in MenuInteraction (pmp=0xbfffedd0, pmret=0xbfffed40,
    pdkp=0xbfffeb50, pdo_warp_to_title=0x80b2058) at menus.c:2449
#1  0x08055721 in do_menu (pmp=0xbfffedd0, pmret=0xbfffed40) at menus.c:6039
#2  0x0808dfa3 in CMD_WindowList (cond_rc=0x0, eventp=0x80b57e0, w=4198014,
    fw=0x81719a0, context=1,
    action=0x81765bb "Root c c NoDeskSort, SelectOnRelease Meta_L",
    Module=0xbfffef08) at windowlist.c:639
#3  0x0807c5e5 in execute_function (efa=0xbfffeef0) at functions.c:1394
#4  0x0807c744 in old_execute_function (cond_rc=0x0,
    action=0x80d9f50 "WindowList Root c c NoDeskSort, SelectOnRelease Meta_L",
    fw=0x81719a0, eventp=0x80b57e0, context=1, Module=-1, exec_flags=0,
    args=0x0) at functions.c:1467
#5  0x0806e41f in HandleKeyPress () at events.c:1757
#6  0x0806fe72 in DispatchEvent (preserve_Fw=0) at events.c:3096
#7  0x0806ff14 in HandleEvents () at events.c:3151
#8  0x08082b3a in main (argc=3, argv=0xbffff434) at fvwm.c:718
#9  0x42017499 in __libc_start_main () from /lib/i686/libc.so.6
(gdb) print mi
$1 = (MenuItem *) 0x0

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 28 Apr 2002 22:24:36 +0000

> of the menu, release Alt. The problem is not in 2.4.x.

Fixed.

Regards,
Mikhael.