Subject: More menu position hints

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 3 Mar 2002 22:26:45 +0000

There are the following needs for menu position hints.

  * open a submenu (using Menu command) at the same position as parent
  * open a submenu at the same x position as parent, and in the y of
    the mouse pointer, plus/minus offset
  * open a submenu at the same context (store it if needed) as parent

Note that the first and the last are not always equivalent, but probably
having only one of two would be enough.

The second may be used in "fvwm-menu-directory --reuse" or
fvwm_make_browse_menu.sh instead of the current WarpTitle although
WarpTitle is very good here too.

And finally (this is badly needed for the start menu of FvwmTaskBar):

  * the left-bottom corner of a menu is at left-top of the client window
    (FvwmTaskBar) or the frame, plus/minus offset

+------+----------
| Menu | the rest of FvwmTaskBar
+------+----------

 |          |
 |          |
+|__________|-----
| Menu | the rest of FvwmTaskBar
+------+----------

Try to specify a good position for the start menu (remember, FvwmTaskBar
may be resized) and you can't do this. The best tries are:

  *FvwmTaskBar: StartMenu MenuFvwmRoot Mouse c  # not aligned, not nice
  *FvwmTaskBar: StartMenu MenuFvwmRoot Root +1p +27p  # bad if resized

This is all not not very critical, but would be nice to have.
I am sure, you, Dominik, as usual may find a good generic solution. :)

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 3 Mar 2002 22:37:29 +0000

>   *FvwmTaskBar: StartMenu MenuFvwmRoot Mouse c  # not aligned, not nice

I copied from the top FvwmTaskBar, for the bottom one this is better:

  *FvwmTaskBar: StartMenu MenuFvwmRoot Mouse -100m -102m  # not aligned

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 4 Mar 2002 08:26:51 +0100

>     (FvwmTaskBar) or the frame, plus/minus offset

With the latest CVS:

  *FvwmTaskBar: StartCommand Popup RootMenu rectangle $widthx$height+$left+$top 0 -100m

(remove the StartMenu option if you used any).

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]