Subject: Notification: incoming/863

From: [email-masked]
Date: Sat, 30 Mar 2002 13:47:33 -0600

FVWM Bug Tracking notification

new message incoming/863

Message summary for PR#863
	From: [email-masked]
	Subject: Java windows: 2 problems: (a) wrong resizing: setSize(x, y) and pack() not honored, (b) no deiconification on setVisible(true)
	Date: Sat, 30 Mar 2002 13:47:32 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Sat Mar 30 13:47:33 2002
From: [email-masked]
To: [email-masked]
Subject: Java windows: 2 problems: (a) wrong resizing: setSize(x, y) and pack() not honored, (b) no deiconification on setVisible(true)
Date: Sat, 30 Mar 2002 13:47:32 -0600

Full_Name: 
Version: 2.4.2
CVS_Date: 
OS: Linux 2.4.8
X_Server: XFree86 4.0
Submission from: (NULL) (24.70.95.204)

Hello,

There is a problem with fvwm2 displaying Java 1.3.1_02 Swing JFrame
windows
which are popped up from other JFrame windows. What fvwm2 often does with
these is it resizes them so that they are so small on the screen that the
user can hardly see them. Even when the user calls setSize(x, y) and
pack()
on the created JFrame fvwm2 often still does the resizing leading to 16x16
windows or so. This happens roughly 60% of the time. This also happens
under the gnome window manager but never happens under window maker.
The code was compiled using Sun's JDK for Linux and other users
experienced the same problem with their own code.

The other Java problem which has to do with window management is that
when setVisible(true) is called on the window often it appears as an
fvwm2 icon, which is not what is supposed to happen. When
setVisible(false) is called on a JDK JFrame the window is
supposed to disappear and when setVisible(true) is called
on that window later it is supposed to appear deiconified.

Thanks,

Neil

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 31 Mar 2002 22:12:07 +0200

> on that window later it is supposed to appear deiconified.

If you provide *detailed* instructions on what you are doing, I
can take a look at what happens.  By detailed I mean:

 1) A location with the Java package you are using (the exact
    version).  If there is anything to take into account when
    installing it, please say so.
 2) A piece of Java code that shows the problem.  The code must
    run out of the box.
 3) Any settings that have to be made to run that code.
 4) Detailed instructions what to do with the program.
 
Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]