Subject: core dumps

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 26 Mar 2002 21:21:06 +0000

I get core dumps. The problem is that the stack trace is unusible.
gdb complains about "DW_FORM_strp pointing outside of .debug_str section"
and gives ??? in the stack.

Maybe others may reproduce these core dumps and get a good stack.

1) Simply run kcalc shipped with kdeutils-2.2 -> core dump.
I have all feature supports on (except for multibyte).

2) Set LANG to ar_JO or ar_JO.utf8 before running fvwm. The message I get
(before core dump) is that libc and Xlib do not support these locales.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 27 Mar 2002 08:00:04 +0100

> I have all feature supports on (except for multibyte).

So you compile fvwm with --disable-multibyte (it seems that
now multibyte is on by default).

When I run kcalc I get the following core dump:

[olivier@snoopy graphviz-1.7.15]$ gdb /opt/fvwm/bin/fvwm2 ~/core
GNU gdb 4.18
Core was generated by `fvwm2 -f themes-rc'.
Program terminated with signal 11, Erreur de segmentation.
Reading symbols from /opt/X11R6/lib/libXpm.so.4...done.
Reading symbols from /usr/local/lib/libstroke.so.0...done.
Reading symbols from /opt/X11R6/lib/libSM.so.6...done.
Reading symbols from /opt/X11R6/lib/libICE.so.6...done.
Reading symbols from /opt/X11R6/lib/libXext.so.6...done.
Reading symbols from /opt/X11R6/lib/libX11.so.6...done.
Reading symbols from /lib/libm.so.6...done.
Reading symbols from /usr/local/lib/libiconv.so.2...done.
Reading symbols from /opt/X11R6/lib/libXft.so.1...done.
Reading symbols from /opt/X11R6/lib/libfreetype.so.6...done.
Reading symbols from /usr/local/lib/libfribidi.so.0...done.
Reading symbols from /lib/libc.so.6...done.
Reading symbols from /lib/libdl.so.2...done.
Reading symbols from /opt/X11R6/lib/libXrender.so.1...done.
Reading symbols from /lib/ld-linux.so.2...done.
Reading symbols from /opt/X11R6/lib/X11/locale/common/xlcDef.so.2...done.
Reading symbols from /usr/lib/gconv/ISO8859-1.so...done.
Reading symbols from /opt/X11R6/lib/X11/locale/common/xomGeneric.so.2...done.
#0  0x402dbcf6 in vfprintf () from /lib/libc.so.6
(gdb) where
#0  0x402dbcf6 in vfprintf () from /lib/libc.so.6
#1  0x402deaf6 in vfprintf () from /lib/libc.so.6
#2  0x402da54c in vfprintf () from /lib/libc.so.6
#3  0x8087193 in fvwm_msg (type=WARN, id=0x80aa2d7 "GetWindowSizeHints", 
    msg=0x80aa300 "%s window %#lx has broken (%s) size hints\nPlease send a bug report to the application owner,\n\tyou may use [email-masked] as a reference.\nhint override = %d\nflags = %lx\nmin_width = %d, min_heigh"...)
    at misc.c:394
#4  0x80725f9 in GetWindowSizeHints (tmp=0x818f9f0) at add_window.c:2655
#5  0x807184e in AddWindow (w=31457288, ReuseWin=0x0, win_opts=0xbffff424)
    at add_window.c:2059
#6  0x806c075 in HandleMapRequestKeepRaised (KeepRaised=0, ReuseWin=0x0, 
    win_opts=0x0) at events.c:994
#7  0x806bf8e in HandleMapRequest () at events.c:940
#8  0x806e7d6 in DispatchEvent (preserve_Fw=0) at events.c:2964
#9  0x806e86e in HandleEvents () at events.c:3020
#10 0x8082079 in main (argc=3, argv=0xbffff924) at fvwm.c:719

> (before core dump) is that libc and Xlib do not support these locales.

I get the same core dump with or without "problems" with the locale.

Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 27 Mar 2002 11:27:48 +0100

> #4  0x80725f9 in GetWindowSizeHints (tmp=0x818f9f0) at add_window.c:2655

Damn, that's because fvwm_msg is called with

  fvwm_msg(..., "...%s...", tmp->name);

But tmp->name is a structure, not a string.  gcc doesn't complain
about that because it doesn't know that fvwm_msg uses printf
syntax.  I guess there are dozens of similar places in the code.
Is there any way to inform gcc about the fvwm_msg syntax?

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 27 Mar 2002 11:43:48 +0100

> Is there any way to inform gcc about the fvwm_msg syntax?

Ignore me.  We already have this in the code - it had only to be
enabled for fvwm_msg too.

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 27 Mar 2002 10:53:24 +0000

> now multibyte is on by default).

Actually, configure sets with_multibyte to "no", so it is reported as
missing in the listing and in fvwm-config, although MULTIBYTE is set.
Don't you get the same "no multibyte support"? I may fix this.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 27 Mar 2002 11:54:05 +0100

> I have all feature supports on (except for multibyte).

Fixed.  BTW, kcalc requests a max_height of 0.  Anybody cares to
report this?

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 27 Mar 2002 12:03:47 +0100

> Don't you get the same "no multibyte support"? I may fix this.

You can't compile with --disable-multibyte anymore - it's
unconditionally enableb.  I didn't notice that it's reported as
missing when I changed that.  I'd like to remove that option
completely in the near future.

Bye

Dominik ^_^  ^_^

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 27 Mar 2002 16:05:05 +0100

> Fixed.  BTW, kcalc requests a max_height of 0.  Anybody cares to

I've sent a bug report, Olivier