Subject: Demo of new windowshade features

From: Dominik Vogt <[email-masked]>
Date: Sun, 24 Mar 2002 03:05:12 +0100

Here is a little script that demonstrates what the new window
shading code can do (ignore the border drawing problem, I'll
fix that).  If your machine is too fast or too slow, change the
number behind windowshadesteps.

------------------- snip --------------------
style * windowshadesteps 200
style * windowshadeshrinks

AddToFunc WindowShadeDemo
+ i windowshade n
+ i windowshade e
+ i windowshade s
+ i windowshade w
+ i windowshade ne
+ i windowshade sw
+ i windowshade se
+ i windowshade nw
+ i windowshade n
+ i windowshade ne
+ i windowshade e
+ i windowshade se
+ i windowshade s
+ i windowshade sw
+ i windowshade w
+ i windowshade off

function WindowShadeDemo
------------------- snip --------------------

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sat, 23 Mar 2002 21:55:27 -0500

> number behind windowshadesteps.

Wow!  That is really cool.

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 24 Mar 2002 11:28:55 +0100

> Wow!  That is really cool.

Yup, I could watch it for hours.  And with a well written
application you don't even see the redraws.  Now, how about this
function:

  exec xterm -T "kill me!" -e sleep 100
  wait foobar
  AddToFunc my_destroy_window
  + i windowshade n
  + i windowshade nw
  + i destroy
  my_destroy_window

Shading a window to the center would be nice also :)

Bye

Dominik ^_^  ^_^