Subject: "This" command is a show stopper for 2.4.6

From: Dominik Vogt <[email-masked]>
Date: Wed, 6 Mar 2002 19:12:29 +0100

Before we can release 2.4.6 we have to think of a different name
for the "This" command.  It collides with the "This" context
rectangle in the menu position hints.  How about "ThisWindow"?

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 6 Mar 2002 22:21:14 +0000

> rectangle in the menu position hints.  How about "ThisWindow"?

First, I think the syntax of Menu is very bad. A better one would be:

  Menu menu-name (position-hints) double-click-action

Now, we already have 2 collisions with it: "Mouse" and "Menu"!
I would not rename anything, i.e. leave "This" as is, and change the
"Menu" syntax in 2.5.x.

Second, "ThisWindow" is ok, but "This" fits better into existing names.
Probably there is a better name, like "WorkingWindow". But I can't find
anything that is better than "This".

I have no problem if we rename all (or none) conditionals:

  Next -> NextWindow
  Prev -> PrevWindow
  Current -> FocussedWindow
  Direction -> WindowAtDirection
  All -> AllWindows
  Any -> AnyWindow
  None -> NoWindow
  Pick -> PickWindow
  This -> CurrentWindow, ActiveWindow, WorkingWindow, OperandWindow?

As for what to do (if at all) about "This" now, I would ask someone
independent. Tim?

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 7 Mar 2002 10:24:26 +0100

> As for what to do (if at all) about "This" now, I would ask someone

I don't care what we do in 2.5.x, but introducing something in
2.4.x that might have to be changed soon is a very bad idea.
You're right about the naming.  I'm not very happy with "This"
anyway since it's too un-intuitive.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Mon, 11 Mar 2002 15:25:54 +0000

> As for what to do (if at all) about "This" now, I would ask someone

Don't ask me, I came up with the Current command and I think that has a 
bad name now :-)

I'm happy "ThisWindow" but I think "This" is OK. "Context" may be better 
but that clashes with the menu syntax as well.  In your list above it 
looks the word Window is redundant and it also might imply that there 
are things other than windows which could be selected (e.g. is there a 
NextDesk command?)

Cheers,
Tim.