Subject: PipeRead requires quotes, Exec doesn't

From: tim phipps <[email-masked]>
Date: Fri, 15 Mar 2002 13:33:54 +0000

Configuration Information [Automatically generated, do not change]:
uname: SunOS silver 5.5.1 Generic_103640-39 sun4u sparc SUNW,Ultra-5_10
compiler flags: gcc -g -O2 -Wall -Wno-implicit-int

FVWM Version:	2.5.1
FVWM_MODULEDIR:	/u/phippst/sunos/libexec/fvwm/2.5.1
FVWM_DATADIR:	/u/phippst/sunos/share/fvwm
FVWM_USERDIR:	/u/phippst/.fvwm

Description:
	I just got locked out of X for several hours because I changed
	an Exec to a Piperead in StartFunction:
	
<	+ I Exec display -window root ~/.backing.png
>	+ I PipeRead display -window root ~.backing.png

	I did this to get the root background set before starting
	any fvwm modules. Since I forgot the quotes Piperead just ran
	"display" which tried to open a window. It was blocked waiting
	for fvwm to reparent the window and fvwm was blocked waiting
	for display to quit: deadlock with no timeout: very annoying
	
	Is it possible to change PipeRead to work like Exec?

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 15 Mar 2002 15:05:45 +0100

> 	Is it possible to change PipeRead to work like Exec?

That's because someone thought it would be a good idea to add the
"quiet" option after the command string.  I agree that this is
most unfortunate.  Should we break compatibility here?

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Fri, 15 Mar 2002 09:14:35 -0500

> most unfortunate.  Should we break compatibility here?

Probably copied over from Read, where its not such a big problem.

I don't think we'd really have to break compatibility, just
check if the last token is "quiet", if not, use the whole line.

No, I'm not volunteering.  At least not today.

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Fri, 15 Mar 2002 14:19:50 +0000

> most unfortunate.  Should we break compatibility here?

I vote yes since I've never used the quiet option, it only puts messages 
in the log file and you can easily get the same effect with >/dev/null.

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 15 Mar 2002 18:09:06 +0100

> check if the last token is "quiet", if not, use the whole line.

But then the whole command has to be quoted already :-P

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 15 Mar 2002 17:12:22 +0000

> in the log file and you can easily get the same effect with >/dev/null.

I hope you don't suggest to break the current first argument. I don't
worry if the second argument "quiet" is removed. But it is not hard to
strip leading and trailing quotes that can't start a shell command anyway.
Again I don't worry if the \` inside backticks is not expanded to a simply
backtick as it is not.

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Fri, 15 Mar 2002 12:50:51 -0500

> But then the whole command has to be quoted already :-P

I don't think I understand.  Existing use of quiet takes 2 forms:

PipeRead command quiet
PipeRead "command args" quiet

If we allow:

PipeRead command args quiet

then the only restriction is, if you want to pass the arg "quiet"
to a command, you have to quote the command and its args.

Thats a little strange, but it doesn't look too bad to me.