Subject: CVS olicha: * Fixed compilation for system without XOpenOM in Xlib.h

From: FVWM CVS <[email-masked]>
Date: Wed, 27 Mar 2002 01:12:44 -0600

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	olicha	02/03/27 01:12:44

Modified files:
	.              : ChangeLog acconfig.h configure.in 
	fvwm           : fvwm.c 
	libs           : Ficonv.c FlocaleCharset.c 

Log message:
* Fixed compilation for system without XOpenOM in Xlib.h
* Be more safe in Ficonv.c and FlocaleCharset.c
* include only libs/Flocale.h in fvwm.c

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 27 Mar 2002 11:08:18 +0100

> * Fixed compilation for system without XOpenOM in Xlib.h

Hm, what's XOpenOM again?

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 27 Mar 2002 15:17:54 +0100

> Hm, what's XOpenOM again?

This function open a locale "output method" (XOM). An output method
is needed by the X functions which depend on the locale. But this is
not visible, for example, XCreateFontSet first open an XOM and then
create the FontSet (in fact an XOC) with this XOM and XCreateOC
(and then close the XOM).
Unfortunately it seems that some Xlib do not have these functions
available for the programmers (or are available via an other header
than Xlib.h). So, I will probably remove the fvwm XOM code and use
an other (less clean!) method.
You may try "man XOpenOM" and  "man XCreateOC".

Olivier