Subject: Flocale error message

From: Dominik Vogt <[email-masked]>
Date: Wed, 6 Mar 2002 11:01:36 +0100

What does this message mean:

  [FVWM][FInitCharset]: WARNNING -- Cannot set locale
  1796553776

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 6 Mar 2002 13:41:19 +0100

>   [FVWM][FInitCharset]: WARNNING -- Cannot set locale

It means that your 'echo $LC_CTYPE' locale is not supported
by your libc I think. Do you have a similar message with
2.4.6 (recompiled after my last commit)? The locale is set
in a different way. What gives 'echo $LC_CTYPE' and 'locale'?
Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 6 Mar 2002 14:35:01 +0100

On Wed, Mar 06, 2002 at 01:41:19PM +0100, Olivier Chapuis wrote:
> 2.4.6 (recompiled after my last commit)?

I'll check later.

> The locale is set

  $ echo $LC_CTYPE 
  de_DE
  $ locale
  LANG=en_US
  LC_CTYPE="en_US"
  LC_NUMERIC="en_US"
  LC_TIME="en_US"
  LC_COLLATE="en_US"
  LC_MONETARY="en_US"
  LC_MESSAGES="en_US"
  LC_PAPER="en_US"
  LC_NAME="en_US"
  LC_ADDRESS="en_US"
  LC_TELEPHONE="en_US"
  LC_MEASUREMENT="en_US"
  LC_IDENTIFICATION="en_US"
  LC_ALL=en_US

Funny.  locale and LC_CTYPE don't agree about the value of
LC_CTYPE.

Bye

Dominik ^_^  ^_^

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 6 Mar 2002 14:51:18 +0100

> Funny.  locale and LC_CTYPE don't agree about the value of

As LC_ALL is set I think this is normal as LC_ALL should override
the other locale env var and locale take this in account.
As 2.4.6 use setlocale(LC_CTYPE, "") to set the locale I conjecture
that you will have no warnning message with 2.4.6.
2.5.1 use  setlocale(LC_CTYPE, getenv("LC_CTYPE")) to setlocale
it seems to me that you have no "de" locale on your machine:

[olivier@snoopy olivier]$ rpm -qa |grep locale
locales-he-2.3-3mdk
locales-ar-2.3-3mdk
locales-2.3-3mdk
locales-en-2.3-3mdk
locales-fr-2.3-3mdk
locales-ja-2.3-3mdk
locales-ru-2.3-3mdk

Any way, the 2.4.6 method to set the locale seems better
(I will commit the change soon but not at once).

Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 6 Mar 2002 18:32:32 +0100

> that you will have no warnning message with 2.4.6.

Here at home I don't get the message at all, not with 2.4.6 and
not with 2.5.1 (same setup). :-P

> [olivier@snoopy olivier]$ rpm -qa |grep locale

SuSE does not have separate packets to install the locales.
They probably install every locale from the CD.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 7 Mar 2002 08:59:37 +0100

> not with 2.5.1 (same setup). :-P

I hope that now you will not have the message at work too.
Olivier

---

From: Alexander Kotelnikov <[email-masked]>
Date: Thu, 07 Mar 2002 12:00:04 +0300

>>>>> On Wed, 6 Mar 2002 14:35:01 +0100
>>>>> "Dominik" == Dominik Vogt <[email-masked]> wrote:
Dominik> 
>> 2.4.6 (recompiled after my last commit)?
Dominik> 
Dominik> I'll check later.
Dominik> 
>> in a different way. What gives 'echo $LC_CTYPE' and 'locale'?
Dominik> 
Dominik> 
Dominik>   $ echo $LC_CTYPE 
Dominik>   de_DE
Dominik>   $ locale
Dominik>   LANG=en_US
Dominik>   LC_CTYPE="en_US"
Dominik>   LC_NUMERIC="en_US"
Dominik>   LC_TIME="en_US"
Dominik>   LC_COLLATE="en_US"
Dominik>   LC_MONETARY="en_US"
Dominik>   LC_MESSAGES="en_US"
Dominik>   LC_PAPER="en_US"
Dominik>   LC_NAME="en_US"
Dominik>   LC_ADDRESS="en_US"
Dominik>   LC_TELEPHONE="en_US"
Dominik>   LC_MEASUREMENT="en_US"
Dominik>   LC_IDENTIFICATION="en_US"
Dominik>   LC_ALL=en_US
Dominik> 
Dominik> Funny.  locale and LC_CTYPE don't agree about the value of
Dominik> LC_CTYPE.

Setting LC_ALL is bogus. Only application should do this, and even if
it really needs.

-- 
Alexander Kotelnikov
Saint-Petersburg, Russia

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 7 Mar 2002 10:16:46 +0100

> I hope that now you will not have the message at work too.

*Sigh* now the message is gone at work too, without changing
anything.  I didn't try 2.4.x yet.

Bye

Dominik ^_^  ^_^