Subject: fribidi detection - expected result?

From: Dominik Vogt <[email-masked]>
Date: Tue, 26 Mar 2002 12:41:56 +0100

With current cvs I get

  With Bi-directional text support?   no: Bad fribidi version, see config.log

Is that the expected result?

>From config.log:

------------------------- snip ---------------------------
configure:5956: checking for fribidi-config
configure:5973: found /usr/bin/fribidi-config
configure:5984: result: /usr/bin/fribidi-config
configure:5997: checking for fribidi_log2vis in -lfribidi
configure:6024: gcc -o conftest -g -O2 -Wall   conftest.c -lfribidi -L/usr/lib -lfribidi -lglib -I/usr/include/glib-1.2 -I/usr/lib/glib/include  >&5
configure:6027: $? = 0
configure:6030: test -s conftest
configure:6033: $? = 0
configure:6044: result: yes
configure:6082: gcc -o conftest -g -O2 -Wall -I/usr/include/glib-1.2 -I/usr/lib/glib/include   conftest.c  -L/usr/lib -lfribidi -lglib >&5
configure: In function `main':
configure:6074: warning: implicit declaration of function `fribidi_parse_charset'
configure:6075: warning: passing arg 3 of `fribidi_charset_to_unicode' makes pointer from integer without a cast
configure:6075: too many arguments to function `fribidi_charset_to_unicode'
configure:6085: $? = 1
configure: program exited with status 1
configure: failed program was:
#line 6066 "configure"
#include "confdefs.h"
#include <stdlib.h>
#include <fribidi/fribidi.h>
int main()
{
        FriBidiChar *logical_unicode_str =
                (FriBidiChar *)malloc((4 + 1) * sizeof(FriBidiChar));
        fribidi_charset_to_unicode(
                fribidi_parse_charset("iso8859-8"), "test", 4,
                logical_unicode_str);
        return 0;
}
------------------------- snip ---------------------------

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 26 Mar 2002 14:42:09 +0000

> Is that the expected result?

Yes, this is intended. They totally changed API from 0.9.0 to 0.10.1,
there is no point to support unsupported API. So, 0.10.1 is required.

BTW, bidi works now, at least for 8-bit texts. Hebrew and Arabic fonts
*-iso8859-8 and *-iso8859-6 or similar are needed to see this in action.
With european fonts bidi is not applied. More work is needed.

Regards,
Mikhael.