Subject: Re: Another bug to fix!

From: Dominik Vogt <[email-masked]>
Date: Sun, 3 Mar 2002 08:25:33 +0100

On Sun, Feb 24, 2002 at 05:29:02PM +1030, Alex Wallis wrote:
> FVWM CVS wrote:
> > 
> > CVSROOT:        /home/cvs/fvwm
> > Module name:    fvwm
> > Changes by:     domivogt        02/02/22 16:07:48
> > 
> > Modified files:
> >         .              : Tag: branch-2_4 ChangeLog NEWS
> >         fvwm           : Tag: branch-2_4 events.c windowlist.c
> > 
> > Log message:
> > * Fixed mouse bindings on root window w/ xfishtank.
> > * Fixed Xinerama placement of WindowList.
> > 
> 
> That fix for WindowList works beautifully.
> Any chance you can apply the same principle to the menus that popup when
> you select the More.. option in the window-ops menu with fvwm-themes? On
> the second xinerama screen the MoveToPage, Group Operations, Window
> Style, etc..., menus popup on the primary screen for me. 

Can you give exact instructions to reproduce this bug?  For me,
all continuation menus are placed on the same screen as the
parent, but I dind't use fvwm-themes.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 3 Mar 2002 13:04:42 +0000

> parent, but I dind't use fvwm-themes.

I may provide the relavant (slightly modified) config, but I have a single
screen, so I don't know whether it is enough to reproduce the problem.

Mouse 1 	1	A	Menu MenuFvwmWindowOps2
Mouse 3 	TSF	A	Menu MenuFvwmWindowOps2

DestroyMenu MenuFvwmWindowOps2
AddToMenu   MenuFvwmWindowOps2
+ "Restore	Alt-F6%menu/window.xpm%"           FuncFvwmRestore
+ "&Move	Alt-F7%menu/window-move.xpm%"      Move
+ "&Resize	Alt-F8%menu/window-resize.xpm%"    Resize
+ "&Iconify	Alt-F9%menu/window-iconify.xpm%"   Iconify
+ "Ma&ximize	Alt-F10%menu/window-maximize.xpm%" Maximize
+ "R&aise	Alt-F5%menu/window-raise.xpm%"     RaiseLower
+ "" Nop
+ "&Close	Alt-F4%menu/window-close.xpm%"     Close
+ "" Nop
+ "Identify	Alt-F11%menu/window-identify.xpm%" Module FvwmIdent
+ "More&...	Alt-F3%menu/window.xpm%"      Menu MenuFvwmWindowOps This 0 0

DestroyMenu MenuFvwmWindowOps
AddToMenu   MenuFvwmWindowOps "Window Operations" Title
+ "&Move%menu/window-move.xpm%"                 Move
+ "&Resize%menu/window-resize.xpm%"             Resize
+ "(De)&Iconify%menu/window-iconify.xpm%"       Iconify
+ "(Un)Ma&ximize%menu/window-maximize.xpm%"     Maximize
+ "(Un)Shade%menu/window-shade.xpm%"            WindowShade
+ "(Un)Stick%menu/window-stick.xpm%"            Stick
+ "R&aise%menu/window-raise.xpm%"               Raise
+ "&Lower%menu/window-lower.xpm%"               Lower
+ "" Nop
+ "&Delete%menu/window-delete.xpm%"             Delete
+ "&Close%menu/window-close.xpm%"               Close
+ "Destroy%menu/window-destroy.xpm%"            Destroy
+ "" Nop
+ "Move to Page%menu/window-move.xpm%"          Popup MenuFvwmWindowMove
+ "Group Operations%menu/windows.xpm%"          Popup MenuFvwmWindowGroupOps
+ "Window Style%menu/window.xpm%"               Popup MenuFvwmWindowStyle
+ "Maximize Window%menu/window-maximize.xpm%"   Popup MenuFvwmWindowMaximize
+ "Refresh Window%menu/refresh.xpm%"            Popup MenuFvwmWindowRefresh
+ "Rearrange All%menu/refresh.xpm%"             Popup MenuFvwmRearrangeWindows
+ "Window Utility%menu/utility.xpm%"            Popup MenuFvwmWindowUtility
+ "" Nop
+ "Identify%menu/window-identify.xpm%"          Module FvwmIdent
+ "Switch to...%menu/windows.xpm%"              WindowList

DestroyMenu  MenuFvwmWindowMove
AddToMenu    MenuFvwmWindowMove "Move to ..." Title
+ "Page 	&Right%menu/window-move.xpm%"   AnimatedMove w+100 w
+ "Page 	&Left %menu/window-move.xpm%"   AnimatedMove w-100 w
+ "Page 	&Down %menu/window-move.xpm%"   AnimatedMove w w+100
+ "Page 	&Up   %menu/window-move.xpm%"   AnimatedMove w w-100
+ "" Nop
+ "Desk 	0%menu/window-move.xpm%"        MoveToDesk 0 0
+ "Desk 	1%menu/window-move.xpm%"        MoveToDesk 0 1
+ "Desk 	2%menu/window-move.xpm%"        MoveToDesk 0 2
+ "Desk 	3%menu/window-move.xpm%"        MoveToDesk 0 3

DestroyMenu  MenuFvwmWindowGroupOps
AddToMenu    MenuFvwmWindowGroupOps "Resource Group Ops" Title
+ "&Iconify%menu/window-iconify.xpm%"   Pick All ($r) Iconify on
+ "De&Iconify%menu/window-iconify.xpm%" Pick All ($r) Iconify off
+ "&Shade%menu/window-shade.xpm%"       Pick All ($r) WindowShade on
+ "Un&Shade%menu/window-shade.xpm%"     Pick All ($r) WindowShade off
+ "R&aise%menu/window-raise.xpm%"       Pick All ($r) Raise
+ "Lo&wer%menu/window-lower.xpm%"       Pick All ($r) Lower
+ "" Nop
+ "&Delete%menu/window-delete.xpm%"     Pick All ($r) Delete
+ "&Close%menu/window-close.xpm%"       Pick All ($r) Close
+ "Destroy%menu/window-destroy.xpm%"    Pick All ($r) Destroy
+ "" Nop
+ "Quick Move To ...%menu/window-move.xpm%" Popup MenuFvwmWindowGroupQuickMove

DestroyMenu MenuFvwmWindowStyle
AddToMenu   MenuFvwmWindowStyle "Window Style" Title
+ "%menu/window.xpm%TitleAtTop"    Pick (CirculateHit) Style $n TitleAtTop
+ "%menu/window.xpm%TitleAtBottom" Pick (CirculateHit) Style $n TitleAtBottom
+ "%menu/window.xpm%Title"         Pick (CirculateHit) Style $n Title
+ "%menu/window.xpm%NoTitle"       Pick (CirculateHit) Style $n NoTitle
+ "" Nop
### long menu stripped

DestroyMenu MenuFvwmWindowMaximize
AddToMenu   MenuFvwmWindowMaximize "Maximize Window" Title
+ "%menu/window-maximize.xpm%Maximize Fully     Alt-F10" Maximize On 100 100
+ "%menu/window-maximize.xpm%Unmaximize         Alt-F10" Maximize Off
+ "" Nop
### long menu stripped

XineramaSls False   # there is also a choice for True here in fvwm-themes
Xinerama True

Regards,
Mikhael.

---

From: Alex Wallis <[email-masked]>
Date: Mon, 04 Mar 2002 03:22:02 +1030

> screen, so I don't know whether it is enough to reproduce the problem.

Thanks Mikhael, I saved this config to test-config and tried it with
Restart fvwm -f test-config and it still happens with that. I've been
trying to track down why I'm getting this and all i can come up with is
maybe this line below.

> + "More&...     Alt-F3%menu/window.xpm%"      Menu MenuFvwmWindowOps This 0 0

I'm not sure if the "This 0 0" may have something to do with it. If I
take out the "0 0" the first menu pops up on the secondary screen, but
all child popups appear on primary.
However invoking the menu with Alt-F3 with fvwm-themes all menus work
properly as expected. It only happens when I select the
MenuFvwmWindowOps2 menu from the button 1 on windows. I also get a lot
of these messages too....
[FVWM][get_menu_options]: <<ERROR>> invalid position arguments
[FVWM][get_menu_options]: <<ERROR>> invalid position arguments
[FVWM][get_menu_options]: <<ERROR>> invalid position arguments

I get a lot of those when I flip through various menus in the
MenuFvwmWindowOps from More...
This may be an issue with fvwm-themes and not fvwm itself but I'll keep
looking I guess and will let you know if I come up with anything more
informative.

Alex

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 3 Mar 2002 18:16:12 +0100

> screen, so I don't know whether it is enough to reproduce the problem.

  ./configure --with-xinerama-emulation

Should do the trick.  I rarely start my multi head setup nowadays
(it runs on my second machine and I've only one keyboard/mouse).

> XineramaSls False   # there is also a choice for True here in fvwm-themes

I'll try that later.

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 3 Mar 2002 21:38:28 +0100

On Mon, Mar 04, 2002 at 03:22:02AM +1030, Alex Wallis wrote:
> I'm not sure if the "This 0 0" may have something to do with it.

Ah, yes, that's probably the culprit.  Mikhael, you probably
wanted to tie the "more" menu to the same postition as the
previous one.  I'm afraid that only works by chance.  It depends
on the events the 'parent' menu got before and may as well select
the FvwmWindow it was called from or any other window.  Maybe
another position hint a la "SelectForceContext" would help, but
maybe not.

> If I take out the "0 0"

If you take that out, the line has a syntax error.  The "0 0"
belongs to "This" either take everything out or nothing.

> the first menu pops up on the secondary screen, but

Hm.

> [FVWM][get_menu_options]: <<ERROR>> invalid position arguments

That's cause by the syntax error.

> looking I guess and will let you know if I come up with anything more

It is an fvwm-themes issue (that I don't know what to do about).

BTW, Mikhael, "This" might not be such a good name for a command
after all: the word is already reserved for menu position hints,
so you can't have a menu double click action that issues the
"This" command.

Bye

Dominik ^_^  ^_^