Subject: XSetLocaleModifiers is _must_

From: Alexander Kotelnikov <[email-masked]>
Date: Mon, 11 Mar 2002 01:46:16 +0300

And I wrote about it here.

man XSetLocaleModifiers
Clients should always call XSetLocaleModifiers with a non-NULL
modifier_list after setting the locale before they call any
locale-dependent Xlib routine.

--- fvwm/fvwm.c.orig	Wed Mar  6 10:20:22 2002
+++ fvwm/fvwm.c	Mon Mar 11 00:50:19 2002
@@ -212,6 +212,11 @@
     {
       fvwm_msg(WARN, "main", "X does not support current locale: %s\n", s);
     }
+    else
+    {
+      if (XSetLocaleModifiers("") == NULL)
+	fvwm_msg(ERR, "main", "Can't set locale modifiers.\n");
+    }
   }
 #endif

-- 
Alexander Kotelnikov
Saint-Petersburg, Russia

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 11 Mar 2002 00:36:18 +0100

> locale-dependent Xlib routine.

This is already done in 2.4.6 (released on sunday) and in the
devel branch.
Olivier

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Alexander Kotelnikov <[email-masked]>
Date: Mon, 11 Mar 2002 18:42:14 +0300

>>>>> On Mon, 11 Mar 2002 00:36:18 +0100
>>>>> "Olivier" == Olivier Chapuis <[email-masked]> wrote:
Olivier> 
>> locale-dependent Xlib routine.
Olivier> 
Olivier> This is already done in 2.4.6 (released on sunday) and in the
Olivier> devel branch.

Think you are wrong about 2.4.6:
18:26 pts/10 sacha@pale:../f/fvwm/2.4.6/1/1/fvwm-2.4.6 16> fgrep -r XSetLocaleModifiers *
debian/patches/00_xsetlocalemodifiers.diff:+      if (XSetLocaleModifiers("") == NULL)

cvs version has libs/Flocale.c

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 11 Mar 2002 16:46:52 +0100

> Think you are wrong about 2.4.6:

Yes, this will be in 2.4.7 ...
Olivier