Subject: CVS domivogt: * Almost finished button drawing.

From: FVWM CVS <[email-masked]>
Date: Thu, 21 Mar 2002 19:03:25 -0600

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	02/03/21 19:03:25

Modified files:
	.              : ChangeLog 
	fvwm           : borders.c builtins.c events.c frame.c fvwm.c 
	                 fvwm.h screen.h update.c 
	libs           : Graphics.c 

Log message:
* Almost finished button drawing.
* Fixed transparent vector lines.
* Some bug fixes.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Johannes Gajdosik <[email-masked]>
Date: Mon, 25 Mar 2002 22:43:03 +0100

> * Fixed transparent vector lines.

I have checked out your code from CVS
and you have implemented everything
I wanted to do with the vector buttons, although
in a differen way. Thank you!
There also seems to be a new feature which
switches colors 0 and 1 when a vector is toggled.

Nevertheless you seem to have forgotten to free
the array of the vector line colors in
FreeDecorFace (builtins.h, line 984).

Yours, Johannes Gajdosik

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 25 Mar 2002 23:48:44 +0100

> in a differen way. Thank you!

No problem.  I had to change most of the code anyway because it
was in my way with rewriting the window decoration code.

> switches colors 0 and 1 when a vector is toggled.

Nope, that's not new.

> FreeDecorFace (builtins.h, line 984).

Thanks for the pointer.  Will be fixed in a minute.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]