Subject: CVS olicha: * Reworked the I18N_MB patch:

From: FVWM CVS <[email-masked]>
Date: Sat, 09 Feb 2002 10:32:52 -0600

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	olicha	02/02/09 10:32:52

Modified files:
	.              : ChangeLog acconfig.h configure.in 
	fvwm           : add_window.c borders.c builtins.c events.c 
	                 fvwm.c fvwm.h icons.c icons.h menus.c menus.h 
	                 misc.c misc.h move_resize.c read.c screen.h 
	libs           : Flocale.c Flocale.h fvwmlib.h 
	modules        : ChangeLog 
	modules/FvwmButtons: FvwmButtons.c FvwmButtons.h button.c 
	                     button.h draw.c icons.c output.c 
	modules/FvwmCpp: FvwmCpp.c 
	modules/FvwmIconBox: FvwmIconBox.c FvwmIconBox.h icons.c 
	modules/FvwmIconMan: FvwmIconMan.c FvwmIconMan.h x.c xmanager.c 
	                     xmanager.h 
	modules/FvwmIdent: FvwmIdent.c FvwmIdent.h 
	modules/FvwmM4 : FvwmM4.c 
	modules/FvwmPager: FvwmPager.c FvwmPager.h x_pager.c 
	modules/FvwmScript: FvwmScript.c Instructions.c types.h 
	modules/FvwmScript/Widgets: CheckBox.c HScrollBar.c ItemDraw.c 
	                            List.c Menu.c PopupMenu.c 
	                            PushButton.c RadioButton.c 
	                            TextField.c Tools.c Tools.h 
	                            VScrollBar.c 
	modules/FvwmTaskBar: ButtonArray.c FvwmTaskBar.c Goodies.c 
	                     Start.c 
	modules/FvwmWinList: ButtonArray.c FvwmWinList.c 

Log message:
* Reworked the I18N_MB patch:
* Rename I18N_MB to MULTIBYTE
* New Font and Text API in libs/Flocale.{c,h}.
* A cache is used for fonts information. Font loading is more powerful as
both font or fontset can be loaded. See Flocale.h for details, more comments
will be added soon.
* Fortunately, it seems that there are no more memory problems with
--enable-multibyte!
* Added --disable-compound-text (COMPOUND_TEXT), so this is on by default:
If COMPOUND_TEXT, then non XA_STRING text properties are converted
with XmbTextPropertyToTextList. Of course MULTIBYTE "implies" COMPOUND_TEXT.
We should decide if this default is good. IMHO --enable_multibyte should be the
default.
* Used the new API everywhere, but in Form, Gtk and Wharf. I do not know
the i18n status of FvwmGtk (this depends on gtk I imagine). Form may be
multibyted (Dan?). I will not multibyte the Wharf.
* I do not remove GetFont.c because at present time it is used in FvwmForm.
Should we remove it in the future? The problem is that maybe external
modules use it.
* My TODO (monday): more doc (NEWS, Flocale.h, INSTALL.fvwm, web)
* (My) TODO: FvwmForm, right to left text support and make some tests

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Mon, 11 Feb 2002 12:12:50 -0500

> Form may be multibyted (Dan?).

Hey, you turned "multibyted" into a verb just like an American!

:)

I think I've changed everything that should change.

> Should we remove it in the future? The problem is that maybe external

I think it can be safely removed.

It takes a while to figure out, but I didn't find it that hard to
change FvwmForm.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]