Subject: CVS domivogt: * FvwmBUttons: Added a new way to specify the button that title or icon is to

From: FVWM CVS <[email-masked]>
Date: Sat, 09 Feb 2002 08:00:53 -0600

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	02/02/09 08:00:53

Modified files:
	modules        : ChangeLog 
	modules/FvwmButtons: FvwmButtons.c button.c button.h 

Log message:
* FvwmBUttons: Added a new way to specify the button that title or icon is to
be changed:

SendToModule FvwmButtons Title <row> <column> ...

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 9 Feb 2002 14:53:16 +0000

> SendToModule FvwmButtons Title <row> <column> ...

It probably makes sence to add an Id option to a button. And the commands:

  SendToModule FvwmButtons ChangeTitle <id> "text"
  SendToModule FvwmButtons ChangeIcon <id> file

By default button's id (if not specified) may be set to +<row>+<column>
or =<total_order_number_without_containers> which ever is better.

Regards,
Mikhael.