Subject: automake warning

From: Dominik Vogt <[email-masked]>
Date: Wed, 27 Feb 2002 06:26:48 +0100

Mikhael, with your latest commit I get a message from automake:

  fvwm/Makefile.am:30: variable `FT2_LIBS' not defined

(one for each Makefile).  This only goes away after I run
autoreconf and then automake again.  I assume this is a bug in the
Makefile setup.  To get a proper build I now have to call

  $ automake; autoreconf; automake; autoreconf

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 27 Feb 2002 13:31:54 +0000

>   fvwm/Makefile.am:30: variable `FT2_LIBS' not defined

I did not add FT2 code, but it seems ok at a glance.

>   $ automake; autoreconf; automake; autoreconf

It should be "autoreconf; automake", so the first automake may not help.
Or maybe "aclocal; automake; autoconf; autoheader".

I didn't need to run "autoreconf; automake; ./configure; make" twice.
Anyway, I don't think we may fix this Makefile circular dependancies hell.

  * autoreconf is a script manipulating aclocal + autoconf + autoheader
  * aclocal produces aclocal.m4 from acinclude.m4
  * automake produces Makefile.in files from Makefile.am files
  * autoconf produces configure from configure.in and aclocal.m4
  * autoheader produces config.h.in from configure.in
  * configure produces Makefile files from Makefile.in files
  * configure produces config.h from config.h.in
  * configure produces executable config.status to rebuild files from *.in
  * config.status --recheck regenerates itself from configure
  * make _should_ run everything above automatically using Makefile

Now you may guess what happens when Makefile itself should be regenerated
when you issue "make foobar". I.e. it should first produce a new Makefile
instead of the currently run one, and then rerun "make foobar" on it.

Regards,
Mikhael.

---

From: Jason L Tibbitts III <[email-masked]>
Date: 27 Feb 2002 13:30:40 -0600

>>>>> "MG" == Mikhael Goikhman <[email-masked]> writes:

MG> It should be "autoreconf; automake", so the first automake may not
MG> help. Or maybe "aclocal; automake; autoconf; autoheader".

Do I need to change how snapshots are built?  This looks like what
caused this morning's failure.  The current script is:

#!/bin/zsh
VERSION=snap-`/bin/date +%Y%m%d`;
SNAPDIR=/usr/local/sina-ftp/pub/fvwm/devel/snapshots;
TMPF=/tmp/fvwm.snap.$$
rm -f $TMPF
cd ~/fvwm
/usr/bin/cvs -q update -dPA                 >> $TMPF 2>&1 && \
/usr/bin/automake --add-missing             >> $TMPF 2>&1 && \
/usr/bin/autoreconf                         >> $TMPF 2>&1 && \
./configure                                 >> $TMPF 2>&1 && \
/usr/bin/make -k                            >> $TMPF 2>&1 && \
/usr/bin/make dist VERSION=$VERSION         >> $TMPF 2>&1 && \
mv fvwm-$VERSION.tar.gz $SNAPDIR            >> $TMPF 2>&1 && \
cp -p ChangeLog NEWS $SNAPDIR               >> $TMPF 2>&1
if [ ! -f $SNAPDIR/fvwm-$VERSION.tar.gz ]; then
  mail -s "Problems building $VERSION" [email-masked] < $TMPF;
fi
rm $TMPF

 - J<

---

From: Dan Espen <[email-masked]>
Date: Thu, 28 Feb 2002 09:04:05 -0500

> /usr/bin/autoreconf                         >> $TMPF 2>&1 && \

Jason, I think you might have missed Mikhael's answer.

At least for me, it showed up as an attachment I couldn't extract.

Heres his answer:

Yes, of course, this is incorrect when acinclude.m4 is changed.
I believe that switching of these lines should be enough.

But if you really want to be sure, add aclocal without parameters:

  aclocal
  automake -a
  autoreconf

Regards,
Mikhael.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Jason L Tibbitts III <[email-masked]>
Date: 28 Feb 2002 09:41:43 -0600

>>>>> "DE" == Dan Espen <[email-masked]> writes:

DE> Jason, I think you might have missed Mikhael's answer.

Ah, there was an answer in there.  I've added the call to aclocal;
let's see how another snapshot builds.  (Sorry about the two false
starts, BTW.)

 - J<

---

From: "S. Anderson" <[email-masked]>
Date: Thu, 28 Feb 2002 15:46:14 -0700

> But if you really want to be sure, add aclocal without parameters:

I was wondering. Would you guys would consider adding a bootstrap
script for cvs, something similar to the above like:

#!/bin/sh
aclocal
automake -a
autoreconf

This would save me from having to remember so much :-)

sa

---

From: Dan Espen <[email-masked]>
Date: Thu, 28 Feb 2002 17:59:39 -0500

> This would save me from having to remember so much :-)

utils/configure_dev.sh

Its missing the aclocal right now, but someone might add it.
It also invokes configure without args, but you might find that
acceptable.

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]