Subject: detecting fribidi?

From: Dominik Vogt <[email-masked]>
Date: Mon, 25 Feb 2002 11:36:52 +0100

I've installed the fribidi library (because I like to compile with
all possible libraries), but the configure script fails with an
(incorrect) error message:

  With Bi-directional support?        no: Can't find required fribidi/fribidi.h

And the output from config.log:

  configure:5496: result: yes
  configure:5538: checking for fribidi_log2vis in -lfribidi
  configure:5565: gcc -o conftest -g -O2 -Wall   conftest.c -lfribidi -lfribidi  >&5
  configure:5568: $? = 0
  configure:5571: test -s conftest
  configure:5574: $? = 0
  configure:5585: result: yes
  configure:5614: checking for fribidi/fribidi.h
  configure:5624: gcc -E   conftest.c
  In file included from /usr/include/fribidi/fribidi.h:27,
                   from configure:5621:
  /usr/include/fribidi/fribidi_types.h:27: glib.h: No such file or directory
  configure:5630: $? = 1
  configure: failed program was:
  #line 5620 "configure"
  #include "confdefs.h"
  #include <fribidi/fribidi.h>
  configure:5649: result: no

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 25 Feb 2002 13:32:03 +0000

>   configure:5649: result: no

This is a generic error message. You will get it if you have a non correct
xpm or rplay or stroke headers too. You need glib-devel rpm in this case.
But if you have gtk support you already have glib-devel. I don't know.
Moreover my version of fribidi (I installed fribidi{-devel}-0.10.1-2 PLD
rpms) does not include glib.h at all.

I may replace "Can't find required foo.h" with "Can't find working foo.h".

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 26 Feb 2002 06:09:42 +0100

On Mon, Feb 25, 2002 at 01:32:03PM +0000, Mikhael Goikhman wrote:
> But if you have gtk support you already have glib-devel.

glib-devel is installed (1.2.10), this is not the problem.  The
glib.h file is in /usr/include/glib-1.2, but the include path is
not set.  The fribidi version is 0.9.0.  To work with this
version, the flags from glib-config have to be added to the
gcc calls.  Is there any documentation about the dependencies of
the fribidi library?

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 26 Feb 2002 06:21:40 +0100

> gcc calls.  Is there any documentation about the dependencies of

As an addendum:  it's sufficient if gcc finds an empty glib.h in
the include path.  It doesn't have to be linkes with glib either.
If I issue

  # touch /usr/lib/glib.h

configure and make run without a problem.

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 26 Feb 2002 19:06:06 +0000

> > not set.  The fribidi version is 0.9.0.  To work with this

There is nothing about glib in 0.10.1 sources. The ChangeLog is not clear,
it just says something was removed regarding glib. I don't think we should
support 0.9.0 if it is different from 0.10.1, but if it has fribidi-config
it should say "yes" when I replace the detection mechanism.

> > gcc calls.  Is there any documentation about the dependencies of

  fribidi-config --cflags --libs
  glib-config --cflags --libs  # this is not needed, just for comparision

> configure and make run without a problem.

This is because HAVE_FRIBIDI is not really used yet anywhere.
Olivier, you may do it before me if you like. I am busy with perl now. :)

Regards,
Mikhael.