Subject: configure and gnomeConf.sh

From: "Dmitry Yu. Bolkhovityanov" <[email-masked]>
Date: Thu, 7 Feb 2002 15:42:56 +0600

Hi!

	I've just downloaded fvwm-snap-20020206 and tried to compile it
with installdir ~/usr/ .  The commandline was

	./configure --prefix=$HOME/usr

	There was a line in configure output:

checking for gnomeConf.sh file in /export/ring1/bolkhov/usr/lib... not found

(my $HOME is /export/ring1/bolkhov) and finally a

  With GNOME support in FvwmGtk?      no: Can't find working gnome-config

	There is /usr/lib/gnomeConf.sh, so I modified the command line to

	./configure --prefix=$HOME/usr --with-gnome-libs=/usr/lib/

but that had no effect -- configure still looks in ~/usr/lib/.  I've
skimmed through the script itself, and there's a code to set $gnome_prefix
to the argument of --with-gnome-libs, but later there's some alchemy with
--with-gnome, which probably overrides the value of $gnome_prefix.

	Not that I care about Gnome, but just for correctness...  Am I
missing something, or is there really a mistake in configure script?

	_________________________________________
	  Dmitry Yu. Bolkhovityanov
	  The Budker Institute of Nuclear Physics
	  Novosibirsk, Russia

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 7 Feb 2002 11:11:00 +0100

> missing something, or is there really a mistake in configure script?

Probably a bug in the configure script.  According to the
documentation --prefix sets only the install path.  You can get
Gnome support running with --with-gnome-libs and
--with-gnome-includes (I hope).

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 22 Feb 2002 21:06:53 +0100

> --with-gnome-includes (I hope).

Hm, who added that check to configure originally?  Could someone
who knows how all this GNOME stuff works take a look at it?

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 23 Feb 2002 13:01:17 +0000

> missing something, or is there really a mistake in configure script?

gnomeConf.sh is used as the last resort. First gnome-config executable is
searched. The question is why you don't have it in your path?

The logic about where to search for gnomeConf.sh (last resort) is from
gnome.m4, which is included in a lot of other projects, you may write to
authors of this macro if you don't agree with this logic.

I may fix this (risking to break something else), but is it really needed?
Just ensure you have the correct gnome-config in $PATH, as it should be.
In RedHat or similar it is /usr/bin/gnome-config from gnome-libs-devel rpm.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 23 Feb 2002 20:31:04 +0100

> In RedHat or similar it is /usr/bin/gnome-config from gnome-libs-devel rpm.

I've no opinion about if it's needed or not, but looking for
the script in the path given with --prefix is *definitely*
wrong.  This path is reserved for things that get installed, not
for the dependencies.  Well, adding an additional check with the
path given in --with-gnome-libs shouldn't break anything.

Bye

Dominik ^_^  ^_^