Subject: CVS migo: * New FvwmRearrange arguments -maximize, -nomaximize, -animate, -noanimate.

From: FVWM CVS <[email-masked]>
Date: Wed, 27 Feb 2002 12:07:18 -0600

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	migo	02/02/27 12:07:18

Modified files:
	.              : NEWS 
	modules        : ChangeLog 
	modules/FvwmRearrange: FvwmRearrange.1 FvwmRearrange.c 

Log message:
* New FvwmRearrange arguments -maximize, -nomaximize, -animate, -noanimate.
_ Do Resize/Move in one command. Take outside duplicated code.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 27 Feb 2002 18:37:18 +0000

> _ Do Resize/Move in one command. Take outside duplicated code.

This works ok, except for -maximize. The last affected window borders
are highlighted, although the window under cursor has keyboard focus.
The pager may show one or another highlighted window.

I am not sure, but I think there is a problem in ResizeMoveMaximize,
because all others (ResizeMove, Move, AnimatedMove) work well. I will post
a minimal rc file if you can't reproduce it with FvwmCascade -m -maximize.

The point of -maximize is to help to restore the original window geometry.
Also, if we would have ResizeMove, the patch may be 1-2 lines shorter. :-)

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 27 Feb 2002 18:42:30 +0000

> Also, if we would have ResizeMove, the patch may be 1-2 lines shorter. :-)

I mean MoveMaximize not ResizeMove.

I don't really request it, ResizeMoveMaximize keep keep emulates it well.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 28 Feb 2002 08:54:19 +0100

> a minimal rc file if you can't reproduce it with FvwmCascade -m -maximize.

Can you demonstrate the problem with simple commands instead of
FvwmCascade?

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 28 Feb 2002 18:30:50 +0000

> Can you demonstrate the problem with simple commands instead of

Yes run xv in the top-left corner and FvwmConsole at bottom-right.
In FvwmConsole (it is focused with SloppyFocus) type:

  Next (xv) ResizeMoveMaximize 100p 100p +10p +10p

xv is highlighted, but keyboard correctly goes to FvwmConsole.

Regards,
Mikhael.