Subject: core dump in MenuStyle

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 11 Feb 2002 17:36:04 +0000

When trying http://problemlos.ch/tmp/fvwm2rc with the current cvs:

6649        gcv.font = ST_PSTDFONT(ms)->font->fid;
(gdb) where
#0  UpdateMenuStyle (ms=0x80e3e28) at menus.c:6649
#1  0x805725a in NewMenuStyle (eventp=0x80a9260, w=50, tmp_win=0x0, context=8, 
    action=0x80e3bdf "", Module=0xbfffe8f4) at menus.c:7393
#2  0x8057aef in CMD_MenuStyle (eventp=0x80a9260, w=50, tmp_win=0x0, 
    context=8, action=0x80e3bba "*\tForeground white, Background grey22", 
    Module=0xbfffe8f4) at menus.c:7713
#3  0x807bc9d in execute_function (efa=0xbfffe8e0) at functions.c:1305
#4  0x807bdf6 in old_execute_function (
    action=0xbfffe940 "MenuStyle\t*\tForeground white, Background grey22", 
    tmp_win=0x0, eventp=0x80a9260, context=8, Module=1, exec_flags=0, args=0x0)
    at functions.c:1374
#5  0x808622b in run_command_stream (f=0x80c5490, eventp=0x80a9260, 
    tmp_win=0x0, context=8, Module=1) at read.c:143
#6  0x8086381 in run_command_file (filename=0x80c5478 "test/andre-fvwm2rc", 
    eventp=0x80a9260, tmp_win=0x0, context=8, Module=1) at read.c:217
#7  0x80864b0 in CMD_Read (eventp=0x80a9260, w=50, tmp_win=0x0, context=8, 
    action=0x80c545d "test/andre-fvwm2rc", Module=0xbfffeeb4) at read.c:269
#8  0x807bc9d in execute_function (efa=0xbfffeea0) at functions.c:1305
#9  0x807bdf6 in old_execute_function (
    action=0x80aaff0 "Read test/andre-fvwm2rc", tmp_win=0x0, eventp=0x80a9260, 
    context=8, Module=1, exec_flags=0, args=0x0) at functions.c:1374
#10 0x8081b21 in main (argc=3, argv=0xbffff374) at fvwm.c:645
#11 0x401876b7 in __libc_start_main (main=0x8080bc0 <main>, argc=3, 
    ubp_av=0xbffff374, init=0x804b690 <_init>, fini=0x809c9f0 <_fini>, 
    rtld_fini=0x4000db64 <_dl_fini>, stack_end=0xbffff36c)
    at ../sysdeps/generic/libc-start.c:129

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 11 Feb 2002 18:36:11 +0100

> When trying http://problemlos.ch/tmp/fvwm2rc with the current cvs:

The core dump is caused by the new multibyte code. I will take a look
on this soon. Do you use --enable-multibyte?

Olivier

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 11 Feb 2002 17:45:39 +0000

> on this soon. Do you use --enable-multibyte?

No.

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 12 Feb 2002 07:02:40 +0100

Fixed, Olivier