Subject: make dist errors with new perllib module

From: Alex Wallis <[email-masked]>
Date: Tue, 26 Feb 2002 08:35:42 +1030

When I run make dist now, these errors have begun showing up since the
new perllib module has been added.

make[3]: Entering directory `/home/awol/cvs/fvwm/perllib/FVWM/Module'
make[3]: *** No rule to make target `distdir'.  Stop.
make[3]: Leaving directory `/home/awol/cvs/fvwm/perllib/FVWM/Module'
make[2]: *** [distdir] Error 1
make[2]: Leaving directory `/home/awol/cvs/fvwm/perllib/FVWM'
make[1]: *** [distdir] Error 1
make[1]: Leaving directory `/home/awol/cvs/fvwm/perllib'
make: *** [distdir] Error 1

Perhaps an oversight?

Alex
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 26 Feb 2002 06:30:03 +0100

> make: *** [distdir] Error 1

Did you run automake and autoconf before "make dist"?  For me, it
runs through.  On the other hand, "make distcheck" throws an error:

  $ make distcheck
  ...
  Making all in Module
  make[5]: Entering directory `/net/lifelux/lifeshare/home/luthien/src/fvwm/fvwm-2.5.1/=build/perllib/FVWM/Module'
  make[5]: *** No rule to make target `Gtk.pm', needed by `all-am'.  Stop.
  ...

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Alex Wallis <[email-masked]>
Date: Tue, 26 Feb 2002 16:35:00 +1030

>   make[5]: *** No rule to make target `Gtk.pm', needed by `all-am'.  Stop.

I actually had tried autoreconf and automake first, but now that you
mention it, I've just tried everything I can think of, and I've run cvs
update with -A and -P with -R flags even. Still always get the same
error as above.

All the make dist, distcheck, dist2, rpm-dist, etc.. options return
those same errors for me.

Alex

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 26 Feb 2002 20:03:02 +0000

> >   make[5]: *** No rule to make target `Gtk.pm', needed by `all-am'.  Stop.

Ok, fixed locally.

> those same errors for me.

Run ./configure before make, it's not done automatically in some cases...
Or, run "make" before "make dist", this after "autoreconf; automake"
usually runs ./configure with original params.

Regards,
Mikhael.