Subject: CVS dane: * fvwm-menu-xlock.1:

From: FVWM CVS <[email-masked]>
Date: Fri, 01 Feb 2002 20:11:42 -0600

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	dane	02/02/01 20:11:42

Modified files:
	modules        : ChangeLog 
	modules/FvwmCpp: FvwmCpp.1 
	modules/FvwmDragWell: FvwmDragWell.1 
	modules/FvwmIconMan: FvwmIconMan.1 
	modules/FvwmIdent: FvwmIdent.1 
	modules/FvwmM4 : FvwmM4.1 
	modules/FvwmPager: FvwmPager.1 
	modules/FvwmSave: FvwmSave.1 
	modules/FvwmScript: FvwmScript.1 
	modules/FvwmScroll: FvwmScroll.1 
	modules/FvwmWinList: FvwmWinList.1 
	utils          : ChangeLog fvwm-menu-desktop.1 
	                 fvwm-menu-directory.1 fvwm-menu-headlines.1 
	                 fvwm-menu-xlock.1 

Log message:
* fvwm-menu-xlock.1:
* fvwm-menu-headlines.1:
* fvwm-menu-directory.1:
* fvwm-menu-desktop.1: fvwmrc -> .fvwm2rc
* FvwmWinList/FvwmWinList.1:
* FvwmScroll/FvwmScroll.1:
* FvwmScript/FvwmScript.1:
* FvwmSave/FvwmSave.1:
* FvwmPager/FvwmPager.1:
* FvwmM4/FvwmM4.1:
* FvwmIconMan/FvwmIconMan.1:
* FvwmDragWell/FvwmDragWell.1:
* FvwmCpp/FvwmCpp.1: .fvwmrc -> .fvwm2rc

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 2 Feb 2002 23:00:53 +0000

> * fvwm-menu-desktop.1: fvwmrc -> .fvwm2rc

The first 3 man pages are autogenerated from perl scripts.

Actually, fvwmrc was used intentionally to specify any fvwm config file,
not just .fvwm2rc. Never mind.

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Sun, 03 Feb 2002 11:46:06 -0500

> not just .fvwm2rc. Never mind.

I'd like to fix the mess I made, but I'm not clear on the process.
The instruction in fvwm-menu-xlock.in isn't it:

#   pod2man -c "Fvwm Utility" fvwm-menu-xlock | nroff -man | less -e

The Changelog mentions the make target, _fvwm-menu-xlock.1 but that
doesn't work in the source or target directory.

The command:

 pod2man -c "Fvwm Utility" fvwm-menu-xlock.in > fvwm-menu-xlock.1

in the source directory comes pretty close.  We must be running different
versions of pod2man because my .IX records are at the end of
the file and a lot of stuff is indented differently.

> pod2man --version
Unknown option: version
/usr/bin/pod2man: Usage error!
usage: /usr/bin/pod2man [options] podpage
Options are:
	--section=manext      (default "1")
	--release=relpatch    (default "perl 5.005, patch 03")
	--center=string       (default "User Contributed Perl Documentation")
	--date=string         (default "3/Feb/2002")
	--fixed=font	      (default "CW")
	--official	      (default NOT)
	--lax                 (default NOT)

I understand your point about a generic "fvwmrc" and I wouldn't have
changed this if we didn't get a comment about it being confusing.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 3 Feb 2002 17:18:08 +0000

> doesn't work in the source or target directory.

Sorry, no suggestions why "make" does not work for you.

But unless you create a new documentation section, you don't need to
regenerate anything. Just do the same word replace in the .in files too.

> We must be running different versions of pod2man because my .IX records
> are at the end of the file and a lot of stuff is indented differently.

We use perl 5.6.x, it's pod2man generates a bit richier man pages.

Regards,
Mikhael.