Subject: xinerama windowlist patch

From: Darren Marshall <[email-masked]>
Date: Thu, 21 Feb 2002 12:20:28 +0000

Attached is a patch to fix a problem where clicking the mouse button to popup
the windowlist on the secondary screen of an xinerama setup always pops up on
the primary screen.

------------
This e-mail and any attachments are confidential.  If you are not the intended recipient, please notify us immediately by reply e-mail and then delete this message from your system. Do not copy this e-mail or any attachments, use the contents for any purpose, or disclose the contents to any other person: to do so could be a breach of confidence.
--- windowlist.c.orig	Thu Feb 21 11:59:52 2002
+++ windowlist.c	Thu Feb 21 12:01:31 2002
@@ -158,6 +158,11 @@
 
   memset(&mops, 0, sizeof(mops));
   memset(&mret, 0, sizeof(MenuReturn));
+
+  /* parse postitioning args - must call this even if no action is given
+   * because it sets the xinerama screen origin */
+  opts = get_menu_options(action, w, tmp_win, eventp, NULL, NULL, &mops);
+
   if (action && *action)
   {
     /* Look for condition - CreateFlagString returns NULL if no '(' or '[' */
@@ -175,10 +180,6 @@
       CreateConditionMask(cond_flags, &mask);
       free(cond_flags);
     }
-
-    /* parse postitioning args - must call this even if no action is given
-     * because it sets the xinerama screen origin */
-    opts = get_menu_options(action, w, tmp_win, eventp, NULL, NULL, &mops);
 
     /* parse options */
     while (opts && *opts)

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 22 Feb 2002 22:43:37 +0100

> the windowlist on the secondary screen of an xinerama setup always pops up on

I'll apply the patch shortly.  Thanks for your help.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]