Subject: perl module library

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 10 Feb 2002 20:22:25 +0000

I've committed an initial perl module library so that it may be tested.

This new perl library is based on the old X11::Fvwm module, but I redid it
and simplified. Hopefully it is more clean now. It should also support
extended module messages, but this is not really tested.

Here is a simple auto-raise module in perl:

  use FVWM::Module;
  my $module = new FVWM::Module;
  $module->mask(M_FOCUS_CHANGE);
  $module->addHandler(M_FOCUS_CHANGE, sub { $_[0]->sendInfo($_[2], "Raise") });
  $module->eventLoop();

The things that I will like to do sometimes soon:

  * implement missing module config methods
  * implement some alias handling (?)
  * finalize API
  * write documentation
  * think about an optional Perl/GTK and Perl/Tk support

There are 2 simple test modules in tests/perl directory, just run them
in FvwmConsole using their full path, after "make; make install".

A testing is needed. If someone searches for a challenging toy to program,
implement a one page pager in text mode inside xterm. No ncurses is needed
(unless you want to implement window dragging too), just standard terminal
escape sequenses and maybe pseudo-graphics. It should be not hard in perl.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 22 Feb 2002 21:08:53 +0100

> extended module messages, but this is not really tested.

What impact does this have on future module interface changes?

> escape sequenses and maybe pseudo-graphics. It should be not hard in perl.

Gee.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 22 Feb 2002 23:11:13 +0000

> What impact does this have on future module interface changes?

Nothing special. I will try to keep a synchronization between C and perl
libraries. If and when incompatible changes will be introduced, I will
increase the library version. I.e. future scripts containing the line:

  use FVWM::Module 2.1;  # at least version 2.1 is needed

will fail with the current library (version 1.1).

In the future we may use the same version number in both libraries,
making it a part of the module protocol if you think this is needed.
But the perl module library is not more special than the C one, except
that most of perl constants are autogenerated from C ones.

Regards,
Mikhael.