Subject: compiling with -Wall -Werror seems to be broken

From: Dominik Vogt <[email-masked]>
Date: Thu, 31 Jan 2002 22:22:35 +0100

I just noticed that when I compile with

  make CFLAGS="-g -Wall -Werror"

I get no warnings at all.  I believe that worked a while ago, but
I'm not sure.  When I compile with

  make CFLAGS="-g -Wall -Werror -O2"

the warnings work fine.  Could that have anything to do with hard
coding some of the options in the Makefile?  Or is this a gcc bug?

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tomas Ogren <[email-masked]>
Date: Fri, 1 Feb 2002 01:57:44 +0100

> coding some of the options in the Makefile?  Or is this a gcc bug?

Some warning stuff won't be found until the compiler starts shuffling
stuff around, noticing new angles of the same data...

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student at Computing Science, University of Umeå
`- Sysadmin at {cs,ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]