Subject: Re: Focusing ..

From: Arvind <[email-masked]>
Date: Wed, 9 Jan 2002 06:37:28 +0530

Dane Espen wrote:

When I asked about writing modules:
> > > Did you go to http://www.fvwm.org,
> > > select "Developer Info (CVS, Modules)",
> > > then select "Module Developer Information"?
> > 
> > Yes, I did. That was the first place I looked. It doesn't have
> > too much of info. It didn't even answer my first question, what
> > can I send using SendInfo (or SendText, ie). Well, I guess I have
> > to learn from previous modules.
> 
> Looking at the other modules is a very good idea, even if
> the documentation covers everything.

[snip]

My question for the gang:

> > I'm using fvwm 2.4.4. I use virtual workspaces a lot. I
> > switch workspaces using the keyboard. I use sloppyfocus. When
> > I switch, the top-most window isn't focused. Is there any way
> > to do that? I tried a function which sets the layer to 10
> > when switching to a workspace and focusing the window with
> > layer 10 when switching back. It didn't work too well.

I want to focus the topmost window when switching screens using
"Scroll". I don't care where the mouse is. Any ideas? Maybe it
could be an option like "GrabFocus".

> Sorry again about my mail problem, we don't have too many desktop
> Linux machines here yet, so I was mostly on my own setting it
> up.

Sure, no problem.

Arvind
-- 
QOTD:
	"Every morning I read the obituaries; if my name's not there,
	I go to work."
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 9 Jan 2002 13:07:31 +0100

> could be an option like "GrabFocus".

Try something like

  AddToFunc MyScroll
  + Scroll $0 $1
  + Next (raised) focus

Then use "MyScroll" instead of "Scroll".  This doesn't work well
if multiple windows are raised, i.e. fully visible.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]