Subject: Regarding WindowShade again

From: "Dmitry Yu. Bolkhovityanov" <[email-masked]>
Date: Tue, 15 Jan 2002 12:00:36 +0600

Hi!

	A few days ago here was a discussion about Olivier's patches for
"smooth" windowshading.  I haven't tried CVS version yet, so, maybe this
is about nothing.  Everything below applies to 2.4.4.

	Anyway: when a window is shaded which overlaps other windows,
borders of those windows aren't redrawn until the shading is complete.  As
I understand, this is because shading is done in a loop which doesn't do
anything besides taking care of the window being shaded, right?

	And the second thing regarding 2.4.4: when I issue 

	Style "*" WindowShadeSteps 100

command, it doesn't affect already mapped windows, only Recapture solves
the problem.  This wasn't the case in 2.4.0.

	_________________________________________
	  Dmitry Yu. Bolkhovityanov
	  The Budker Institute of Nuclear Physics
	  Novosibirsk, Russia

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 15 Jan 2002 12:35:56 +0100

> the problem.  This wasn't the case in 2.4.0.

Right, I noticed that too and already fixed it in CVS.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]