Subject: Notification: incoming/847

From: [email-masked]
Date: Tue, 22 Jan 2002 03:55:48 -0600

FVWM Bug Tracking notification

new message incoming/847

Message summary for PR#847
	From: [email-masked]
	Subject: Bug in window Title with iso8859-15
	Date: Tue, 22 Jan 2002 03:55:43 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Tue Jan 22 03:55:48 2002
From: [email-masked]
To: [email-masked]
Subject: Bug in window Title with iso8859-15
Date: Tue, 22 Jan 2002 03:55:43 -0600

Full_Name: Nicolas CRoiset
Version: 2.4.4
CVS_Date: 
OS: linux RH 7.2
X_Server: XFree86-4.1.0
Submission from: (NULL) (80.65.226.85)

When you have a title with accents on characters, the Title is not display
correctly.

For example "Mise à jour de l'heure".

we installed fvwm with fvwm-2.4.4-2.rh7.i386.rpm

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 22 Jan 2002 16:46:24 +0100

> we installed fvwm with fvwm-2.4.4-2.rh7.i386.rpm

Hello,

Do this happen with all applications?

What happen with

xterm -T "¤éèàç"

and 

env LC_CTYPE=fr_FR xterm -T "¤éèàç"

(the first characters is the EuroSign). If you have rxvt can
you try with it too.

This seems strange but you may have to compile fvwm yourself
with --enable-multibyte as option to ./configure
(I need to do that so that xterm works properly with fvwm
and an "@euro" locale).

Regards, Olivier

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 22 Jan 2002 21:25:38 +0100

> (I need to do that so that xterm works properly with fvwm

I've got some feedback from Nicolas Croiset. Compiling
fvwm with --enable-multibyte fix the problems.

Any way I do not understand why xterm considers
iso-8859-15 string as multibyte string if the string
contains non ascii characters (with an iso-8859-15 locale).

I do not know if we should close this bug report. I think
that we can put it in confirmed, do so that --enable-multibyte
can be the default and then close it.

BTW, Mikhael, what about distributing i18n rpms?

Olivier

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 22 Jan 2002 22:28:42 +0000

> contains non ascii characters (with an iso-8859-15 locale).

Someone said previously that this is not multibyte for one-byte non
iso8859-1 charsets, but escape sequences containing charset as a hint.

Maybe we should just write a filter that strips these escape sequences
with --disable-multibyte, if we don't use this charset info anyway?

> BTW, Mikhael, what about distributing i18n rpms?

I would not double the number of rpms.

Are --enable-multibyte problems easily solvable for it to be a default?
If not, stripping escape sequences would be a good solution.

Regards,
MIkhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Jan 2002 11:53:18 +0100

> can be the default and then close it.

Isn't that a bug in xterm?

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "Nicolas Croiset (VDL)" <[email-masked]>
Date: Wed, 23 Jan 2002 13:30:12 +0100

Hello,

no it's not a problem from xterm, because this problem is also on all
window title from everywhere (xmixer for example)...

But there is something different beetween redhat 7.0 (this problem does not
exist) and redhat 7.2 where the problem exist. But the configuration option
solve the problem.

Bye.

Nicolas CROISET
VDL
http://www.vdl.fr/dab/
Tel : +33 4 72 84 06 04   Fax : +33 4 72 84 06 02

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 23 Jan 2002 14:57:14 +0100

> with --disable-multibyte, if we don't use this charset info anyway?

I think that this is a good idea. But, is there a place where
this escape sequence is documented? Is this can depend on
how the locale is build?

Olivier