Subject: Re: Exec in fvwm

From: Alexander Kotelnikov <[email-masked]>
Date: Sun, 13 Jan 2002 16:35:29 +0300

FVWM Bug Tracking notification

new message incoming/843

Message summary for PR#843
	From: [email-masked]
	Subject: FvwmIconBox bug and feature request
	Date: Sun, 13 Jan 2002 00:34:14 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Sun Jan 13 00:34:15 2002
From: [email-masked]
To: [email-masked]
Subject: FvwmIconBox bug and feature request
Date: Sun, 13 Jan 2002 00:34:14 -0600

Full_Name: MonMotha
Version: 2.4.3
CVS_Date: 
OS: Linux 2.4.15-pre8
X_Server: XFree86 4.1.0
Submission from: (NULL) (24.208.196.74)

FvwmIconBox module has a delay of almost exactly one second between click
and defined action being performed (in my case Iconify on button 1 click).

Also, I'd like to request text-less (no labels) icons in the box.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Cameron Simpson <[email-masked]>
Date: Thu, 17 Jan 2002 14:00:43 +1100

On 17:13 13 Jan 2002, Alexander Kotelnikov <[email-masked]> wrote:
| >> BTW, I was surprised finding out fvwm use fork instead of vfork for
| >> Exec. There is a note about that not all platforms support vfork butwe
| >> can easily check it in configure time.

Or just stay the hell away from it. It's evil. Even the BSD man pages
(where it originated) said it was a temporary kludge until they had fork()
being more efficient, which it is on all modern systems.

| Dmitry> 	vfork() is a disaster and shouldn't be used.  For a historic
| Dmitry> description, read the Linux manpage for vfork(2), especially the 2nd
| Dmitry> paragraph in the BUGS section.
| 
| both setpgrp and vfork are *standard*, if the implemented or not. But I
| have to admit that vfork hurts me badly on Debian unstable.

And in what standard is vfork() specified? AFAIK, none, because it's an
ugly kludge. Now fork(), _that's_ standard. Maybe you meant "common".
-- 
Cameron Simpson, DoD#743        [email-masked]    http://www.zip.com.au/~cs/

It is the cunning of form to veil itself continually in the evidence
of content.  It is the cunning of the code to veil itself and to produce
itself in the obviousness of value.	- Baudrillard
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]