Subject: Notification: incoming/839

From: [email-masked]
Date: Wed, 09 Jan 2002 08:56:47 -0600

FVWM Bug Tracking notification

new message incoming/839

Message summary for PR#839
	From: [email-masked]
	Subject: No Expose Events allthough Backing Store = Always
	Date: Wed, 09 Jan 2002 08:56:46 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Wed Jan 09 08:56:47 2002
From: [email-masked]
To: [email-masked]
Subject: No Expose Events allthough Backing Store = Always
Date: Wed, 09 Jan 2002 08:56:46 -0600

Full_Name: Roman Fietze
Version: 2.4.0, 2.4.4
CVS_Date: 
OS: Server Linux 2.0.x, Client 2.4.x
X_Server: XFree 3
Submission from: (NULL) (195.244.234.130)

When starting rdesktop (www.rdesktop.org), a client to access Windows
servers via RDP, I get Always when I request DoesBackingStore of my
window.
This is the same on fvwm2 2.0.x and 2.4.x. But on fvwm2 2.4.x there are no
Expose events generated when uncovering parts or all of rdesktop and these
parts remain black. The whole rdesktop window gets black when I do the
fvwm2
Refresh command.

With fvwm2 2.0.x and all other WM's I tested everything is fine. rdesktop
is
the only app where I detected this problem.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 17 Jan 2002 00:48:30 +0100

> the only app where I detected this problem.

There is a bug in rdesktop:  It assumes that if its window has
backing store enabled, it will never get Expose events.  It even
disables Expose events for its window.  This is wrong for two
reasons:

 a) The X server may not have the window contents in backing
    store because it is out of memory.
 b) Fvwm *disables* backing store for all windows by default.

The problem you're running into is (b).  You can circumvent this
if you put

  Style rdesktop BackingStore

in your .fvwm2rc.  I'll file a bug report with the rdesktop folks.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]