Subject: Re: Notification: incoming/843

From: Dominik Vogt <[email-masked]>
Date: Mon, 14 Jan 2002 12:32:03 +0100

On Sun, Jan 13, 2002 at 12:34:15AM -0600, fvwm-bug wrote:
> FVWM Bug Tracking notification
> 
> new message incoming/843
> 
> Full_Name: MonMotha
> Version: 2.4.3
> CVS_Date: 
> OS: Linux 2.4.15-pre8
> X_Server: XFree86 4.1.0
> Submission from: (NULL) (24.208.196.74)
> 
> 
> FvwmIconBox module has a delay of almost exactly one second between click
> and defined action being performed (in my case Iconify on button 1 click).

Can you please send the lines regarding icons and FvwmIconBox from
your .fvwm2rc?

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 14 Jan 2002 17:37:29 +0100

> Can you please send the lines regarding icons and FvwmIconBox from

I do not think that there is a real bug here or the bug concerns
the ClickTime command. With FvwmIconBox you can define double click
action, so it has to wait to see if it is a double click or a
simple click. Maybe the bug here is that if the user does
not define a double click action FvwmIconBox should not
check for a double click. I think that unfortunately FvwmIconBox
do that.

MonMotha, you may try to add "ClickTime 150"
to your configuration file and see if the delay
is now around 0.15 sec

Olivier

---

From: MonMotha <[email-masked]>
Date: Mon, 14 Jan 2002 16:30:50 -0500

Config as requested:

DestroyModuleConfig FvwmIconBox*
*FvwmIconBox: Colorset 1
*FvwmIconBox: MaxIconSize 16x16
*FvwmIconBox: Geometry    10x1+0-0
*FvwmIconBox: HideSC Vertical
*FvwmIconBox: HideSC Horizontal
*FvwmIconBox: FrameWidth 2 2
*FvwmIconBox: Font -*-nil-*-*-*-*-*-*-*-*-*-*-*-*
*FvwmIconBox: Resolution Desk
*FvwmIconBox: SetWMIconSize
*FvwmIconBox: Padding 0
*FvwmIconBox: IconColorSet 1
*FvwmIconBox: IconHiColorSet 1
*FvwmIconBox: Mouse     1       Click   Iconify

That's the entire config for my iconbox.  Someone reccomended setting 
the font really tiny and using the same colorset to get what looks like 
transparent text, but it still draws the raised border thingy for the text.

Still have no idea what's up with the "delay" issue I'm seeing.

--MonMotha

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 15 Jan 2002 12:03:11 +0100

> Still have no idea what's up with the "delay" issue I'm seeing.

With your config I can see the problem.  If you use

  ClickTime 150

*before* you start FvwmIconBox, the delay decreases.  Furthermore
I have problems with iconifying/deiconifying windows.  About every
second click is completely ignored.  I'll look into that.

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 15 Jan 2002 11:33:55 +0000

> transparent text, but it still draws the raised border thingy for the text.

To get rid of label borders, add sh and hi to your colorset definition:

*FvwmTheme: Colorset 1 bg cyan, fg cyan, hi cyan, sh cyan

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 15 Jan 2002 12:55:03 +0100

> second click is completely ignored.  I'll look into that.

I've already a fix on my machine for that (if there is no double
click action defined the action is executed "immediately" with the
method 4 below). The only problem is the "usual problem": if there is
no double click action should we do the action at:
 1 - button press (do not think so).
 2 - button release; action executed on the window of the button release 
  (bad to ? FvwmWinList and FvwmTaskBar do that!)
 3 - button release; action executed on the window of the button press
  (bad to ? FvwmIconMan do this (not always))
 4 - button release; action only if the button release window is the same
  than the button press window and do not care here about motion or
  timeout (seems good)

Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 15 Jan 2002 13:48:18 +0100

On Tue, Jan 15, 2002 at 12:55:03PM +0100, Olivier Chapuis wrote:
> method 4 below).

I've already committed a fix.  I couldn't reproduce the other
problem (clicks being ignored) though.

> The only problem is the "usual problem": if there is

FvwmIconMan has a copy of the action checking code in functions.c.
It works quite the same, it even has a move threshold and its own
click time.  It would be good to use fvwm's ClickTime and
MoveThreshold settings at run time, but otherwise it works nicely
now.

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 16 Jan 2002 10:07:04 +0000

On 15 Jan 2002 21:18:47 -0500, MonMotha wrote:
> 
> Thanks for the suggestion on getting rid of the text borders, I'll throw 
> that in until/if a notext option is implemented.  Also, is there a way 
> to change the size of that textbox border?  I don't see any mention of 
> it in the manpage (if I could set it to 1, it would allow me to get my 
> invisible text and textbox down to 3 pixels, which while still noticable 
> on a 240x320 screen, isn't detrimental).

Only the settings documented in the man page are configurable.
A label border width is hardcoded to 2 in RelieveRectangle().

There are some constants before main() at FvwmIconBox.c that you may
change. You may also completely disable the lines drawing the label.

Regards,
Mikhael.