Subject: multibyte redesign

From: Dominik Vogt <[email-masked]>
Date: Tue, 29 Jan 2002 09:23:56 +0100

Olivier, since you plan to rewrite the infamous multibyte support,
do you already have a design in mind?  I already spent some though
on that topic and concluded that font and string objects should
get their own data type that is managed exclusively in a library
module.  So in the end the only ifdefs should be in the library.
Other than that my only conclusion was that it would be a whole
lot of work and that someone had to address it one day ;-)

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Alexander Kotelnikov <[email-masked]>
Date: Tue, 29 Jan 2002 11:59:29 +0300

>>>>> On Tue, 29 Jan 2002 09:23:56 +0100
>>>>> "Dominik" == Dominik Vogt <[email-masked]> wrote:
Dominik> 
Dominik> Olivier, since you plan to rewrite the infamous multibyte support,
Dominik> do you already have a design in mind?  I already spent some though
Dominik> on that topic and concluded that font and string objects should
Dominik> get their own data type that is managed exclusively in a library
Dominik> module.  So in the end the only ifdefs should be in the library.

One thought about this is to switch from FvwmFont to FvwmGC which
should be something like
struct FvwmGC{
  GC gc;
# ifdef I18N_MB
  XFontSet fontset;
# endif
}
if this switch is possible. Overwise we just need to add FvwmGC, since
xlib's GC does not handle fontsets.

-- 
Alexander Kotelnikov
Saint-Petersburg, Russia

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 29 Jan 2002 10:51:00 +0100

> lot of work and that someone had to address it one day ;-)

I will try to do it like this.

Olivier