Subject: Unconstrained Move

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 30 Jan 2002 11:59:11 +0000

I want to add an option to interactive Move, so snap is ignored.

What do you think is a preferable syntax approach?
I may think about 2 possible solutions.

1) New command UnconstrainedMove with the same arguments as Move.
2) An option to Move and AnimatedMove (other *Move* commands are not
interactive) called NoSnap.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 30 Jan 2002 13:56:24 +0100

> interactive) called NoSnap.

Why?  What is the advantage to turning SnapAttraction off before
moving and enabling it afterwards?

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 30 Jan 2002 14:09:08 +0000

> moving and enabling it afterwards?

This is not only SnapAttraction, but SnapGrid and EdgeResistance too.
There is no way to restore their previous state.

Thinking about this, it may be done by adding a new command Snap:

  Snap Disable
  Snap Enable

This would affect snap in interactive Move and interactive placement.

Still having an option to do an unconstrained Move would be ok.
I myself would bind it to decoration dragging when shift is pressed.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 30 Jan 2002 19:44:11 +0100

> Still having an option to do an unconstrained Move would be ok.

An option for the move command should be good enough, I guess.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "Dmitry Yu. Bolkhovityanov" <[email-masked]>
Date: Thu, 31 Jan 2002 11:32:59 +0600

> I myself would bind it to decoration dragging when shift is pressed.

	Wouldn't it be better to simply modify the behaviour of "Move"
instead of adding new command?  I.e., use the Alt/Meta modifier
interactively to switch off snapping/edgeresistance?  (Shift and Ctrl are
already used for large/precise movement via keyboard.)

	This approach gives the user an ability to "change his mind" on
the fly and is consistent with behaviour in many other programs (Gimp uses
"Shift" in "pencil" tool to draw lines; Windoze Explorer uses Shift/Ctrl 
to force move/copy when dragging a file; and there is definitely some prog
which uses modifiers exactly to switch off snapping (was it XFig?)).

	_________________________________________
	  Dmitry Yu. Bolkhovityanov
	  The Budker Institute of Nuclear Physics
	  Novosibirsk, Russia

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 31 Jan 2002 08:31:08 +0000

> which uses modifiers exactly to switch off snapping (was it XFig?)).

I thought about this too, but there are some problems with this.
Let me think more whether I can find a good solution.

Bad, I already implemented NoSnap option to Move/AnimatedMove. :)

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 31 Jan 2002 14:09:29 +0000

> which uses modifiers exactly to switch off snapping (was it XFig?)).

Ok, done.

Now on interactive move or manual placement holding Alt/Meta ignores all
kind of snaps. The change is activated on an arrow key press or a mouse
movement, but it is possible to activate it immediately on press/release
of Alt if someone wants this.

The small problem is that, for example, I have an "Alt + dragging client
window with mouse 2" binding, that immeadiately enters into no-snap mode,
I should release Alt to enable snap. But it's ok, I can live with this.

Regards,
Mikhael.