Subject: redesign of wire frame move/resize look?

From: Dominik Vogt <[email-masked]>
Date: Mon, 28 Jan 2002 01:15:27 +0100

Isn't it time to get rid of these silly grid lines?  This only
makes the code much more complicated and slower and - in my eyes -
servers no purpose at all. 

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Mon, 28 Jan 2002 17:03:34 -0500

Dominik Vogt <[email-masked]> writes:
> serves no purpose at all. 

Running FVWM remotely, it serves a big purpose.
Its dramatically faster.

Didn't we just have a user complain about  the grab with the grid, and
then  when  I suggested resizeopaque,  he said  he  preferred the grid
lines.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 29 Jan 2002 00:28:42 +0100

> then  when  I suggested resizeopaque,  he said  he  preferred the grid

I'm agree with Dan. But what about using (no grab) override redirect grid?
Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 29 Jan 2002 01:36:34 +0100

> then  when  I suggested resizeopaque,  he said  he  preferred the grid

Um, I wanted to suggest to remove the lines inside the window.

Now:

  +-----------+
  |   |   |   |
  +-----------+
  |   |   |   |
  +-----------+
  |   |   |   |
  +-----------+

After the suggested change:

  +-----------+
  |           |
  |           |
  |           |
  |           |
  |           |
  +-----------+

This is a relic from twm.  I can't think of any other window
manager that still has these additional lines in the middle of the
window.

Bye

Dominik ^_^  ^_^

---

From: Dan Espen <[email-masked]>
Date: Mon, 28 Jan 2002 19:54:43 -0500

> Um, I wanted to suggest to remove the lines inside the window.

Objection withdrawn.

For a long time, Fvwm had a problem with the resize grid not being visible.
I'd guess thats why the extra lines are there.  The visibility problem
was solved years ago.

---

From: "Dmitry Yu. Bolkhovityanov" <[email-masked]>
Date: Tue, 29 Jan 2002 13:13:14 +0600

> Um, I wanted to suggest to remove the lines inside the window.

	In fact, there IS a case when these lines are usable: when some
app maps a huge window, which doesn't fit to screen (a frequent case is a
Netscape driven by poorly written javascript).  And with these two 
additional rectangles you can at leat understand how much of a window is
on the screen when you drag it.

	BTW, what's that with these frames which "makes the code much more
complicated and slower"?  The get_outline_rects() looks simple.

	_________________________________________
	  Dmitry Yu. Bolkhovityanov
	  The Budker Institute of Nuclear Physics
	  Novosibirsk, Russia

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 29 Jan 2002 09:14:20 +0100

> complicated and slower"?  The get_outline_rects() looks simple.

Without the interior lines one could simply draw a rectangle in a
single call.  Currently we have to draw ten rectangles.  I think
I can therefore call it "much more complicated" and definitely
"slower" too.  If you call it "much slower" depends on the point
of view.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Charles Hines <[email-masked]>
Date: Tue, 29 Jan 2002 10:32:16 -0500

>>>>> "DV" == Dominik Vogt <[email-masked]> writes:

>> > Um, I wanted to suggest to remove the lines inside the window.
...

I actually like the interior lines myself and would be saddened to see them
go, but I'm not sure why... :)

DV> Without the interior lines one could simply draw a rectangle in a
DV> single call.  Currently we have to draw ten rectangles.  I think
DV> I can therefore call it "much more complicated" and definitely
DV> "slower" too.  If you call it "much slower" depends on the point
DV> of view.

It's been a long time since I looked at that code, but if it's drawing 10
rectangles that certainly seems wrong.  3 should do it, I would think (outer,
middle vertical, middle horizontal).  Oh, unless it's drawing 10 to avoid
"odd" intersections due to the XOR...eh, that might not look too bad anyways.

Chuck

-- 
Charles K. Hines   <[email-masked]>   <[email-masked]>
Principal Scientist at ReQuest Technologies Inc   (http://www.ReQuestTech.com/)

         "You tell him and I will smack you.  I will smack you like a
            bad bad donkey, okay!" - Pepe in 'Muppets From Space'

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 29 Jan 2002 18:12:44 +0100

> "odd" intersections due to the XOR...eh, that might not look too bad anyways.

It has something to do with the xor lines painting over each
other.

Bye

Dominik ^_^  ^_^