Subject: CVS domivogt: * New command "Schedule" that executes commands delayed. May be used to

From: FVWM CVS <[email-masked]>
Date: Tue, 29 Jan 2002 16:37:17 -0600

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	02/01/29 16:37:16

Modified files:
	.              : ChangeLog NEWS 
	fvwm           : Makefile.am commands.h events.c functions.c 
	                 functions.h fvwm2.1 icccm2.c misc.c misc.h 

Log message:
* New command "Schedule" that executes commands delayed.  May be used to
implement FvwmAuto in fvwm itself.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Wed, 30 Jan 2002 13:03:11 +0000

> implement FvwmAuto in fvwm itself.

Is it possible to have a function self destruct with this? e.g.

AddToFunc once_only
+ I FvwmBanner
+ I Schedule 0 DestroyFunc once_only
+ I Schedule 0 AddToFunc once_only I NOP

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 30 Jan 2002 15:57:13 +0100

> + I Schedule 0 AddToFunc once_only I NOP

Yes.  At the moment, there are no guarantees when the scheduled
code is executed though.  The schedule table is processed only when
no X events or module input is coming in.  In theory it could take
hours before the code is actually executed.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Cameron Simpson <[email-masked]>
Date: Thu, 31 Jan 2002 12:10:42 +1100

On 15:57 30 Jan 2002, Dominik Vogt <[email-masked]> wrote:
| Yes.  At the moment, there are no guarantees when the scheduled
| code is executed though.  The schedule table is processed only when
| no X events or module input is coming in.  In theory it could take
| hours before the code is actually executed.

Wouldn't it be work at least polling it every 100 or 1000 input events
when busy?
-- 
Cameron Simpson, DoD#743        [email-masked]    http://www.zip.com.au/~cs/

Politics - From the Greek Poly, meaning many, and the English Tics, meaning
little blood sucking insects.
	- copyright 1991, Joshua J. Fielek, DoD#385, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Cameron Simpson <[email-masked]>
Date: Thu, 31 Jan 2002 15:52:58 +1100

On 12:10 31 Jan 2002, Cameron Simpson <[email-masked]> wrote:
| On 15:57 30 Jan 2002, Dominik Vogt <[email-masked]> wrote:
| | Yes.  At the moment, there are no guarantees when the scheduled
| | code is executed though.  The schedule table is processed only when
| | no X events or module input is coming in.  In theory it could take
| | hours before the code is actually executed.
| 
| Wouldn't it be work at least polling it every 100 or 1000 input events
                 ^^^^-- "worth"
| when busy?

Whoops.

The way to control people's thoughts is not to lock them out of information,
but feed them a steady diet of dross.	- Clifford Stoll
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]