Subject: cvs checkout is broken

From: Alexander Kotelnikov <[email-masked]>
Date: Sat, 05 Jan 2002 16:08:32 +0300

cvs -d :pserver:[email-masked]:/home/cvs/fvwm checkout fvwm
...
cvs server: Updating fvwm/tests/hints
cvs server: failed to create lock directory for `/home/cvs/fvwm/fvwm/tests/hints' (/home/cvs/fvwm/fvwm/tests/hints/#cvs.lock): Permission denied
cvs server: failed to obtain dir lock in repository
`/home/cvs/fvwm/fvwm/tests/hints

-- 
Alexander Kotelnikov
Saint-Petersburg, Russia
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sat, 05 Jan 2002 08:44:44 -0500

Alexander Kotelnikov <[email-masked]> writes:
> cvs server: failed to create lock directory for `/home/cvs/fvwm/fvwm/tests/hi
> nts' (/home/cvs/fvwm/fvwm/tests/hints/#cvs.lock): Permission denied

It seems to be working from here.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Alexander Kotelnikov <[email-masked]>
Date: Sat, 05 Jan 2002 16:52:32 +0300

>>>>> On Sat, 05 Jan 2002 08:44:44 -0500
>>>>> "Dan" == Dan Espen <[email-masked]> wrote:
Dan> 
>> `/home/cvs/fvwm/fvwm/tests/hints
Dan> 
Dan> It seems to be working from here.

Still does not here.

BTW there is a mistake in fvwm/read.c

      fvwm_msg(DBG,"ReadSubFunc","Module switch %d, about to exec: '%.*s'",
               Module,strlen(tline)-1,tline);

strlen should not be subctracted by 1.

---

From: Dan Espen <[email-masked]>
Date: Sat, 05 Jan 2002 09:40:33 -0500

> Dan> It seems to be working from here.

You're right, I should have let the command run to completion.
I see the same problem.

> strlen should not be subctracted by 1.

That was put in there because tline had a newline.
I guess you are seeing lines that don't have newlines.
Someone must have fixed something.

If the newline is gone, the right fix would be to remove the strlen
and the ".*".

---

From: Alexander Kotelnikov <[email-masked]>
Date: Sat, 05 Jan 2002 18:09:14 +0300

>>>>> On Sat, 05 Jan 2002 09:40:33 -0500
Dan> 
>> strlen should not be subctracted by 1.
Dan> 
Dan> That was put in there because tline had a newline.
Dan> I guess you are seeing lines that don't have newlines.

no I saw (when run fvwm -debug) lines without last significant
character, like "fvw" instead of "fvwm". This is case of
null-terminated string. If it is not terminaded strlen() result is
rather undefined.

Due to tline construction it cannot contain any '\n' and is null
terminated, so, anyway your conclusion about the fix is right.

Dan> Someone must have fixed something.
Dan> 
Dan> If the newline is gone, the right fix would be to remove the strlen
Dan> and the ".*".

---

From: Olivier Chapuis <[email-masked]>
Date: Sun, 6 Jan 2002 14:51:06 +0100

> `/home/cvs/fvwm/fvwm/tests/hints

I created this directory recently. I think I used the usual method.
Unfortunately, I do not know how to fix this ...
Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Alexander Kotelnikov <[email-masked]>
Date: Mon, 07 Jan 2002 00:59:31 +0300

>>>>> On Sun, 6 Jan 2002 14:51:06 +0100
>>>>> "Olivier" == Olivier Chapuis <[email-masked]> wrote:
Olivier> 
>> `/home/cvs/fvwm/fvwm/tests/hints
Olivier> 
Olivier> I created this directory recently. I think I used the usual method.
Olivier> Unfortunately, I do not know how to fix this ...

May be you should have a look at info cvs, "Several developers
simultaneously attempting to run CVS"?

---

From: Dan Espen <[email-masked]>
Date: Sun, 06 Jan 2002 18:23:56 -0500

Alexander Kotelnikov <[email-masked]> writes:
> >> cvs server: failed to create lock directory for `/home/cvs/fvwm/fvwm/tests
> >> /hints' (/home/cvs/fvwm/fvwm/tests/hints/#cvs.lock): Permission denied

I read the info, but it doesn't suggest a solution any of us can
do.

Jason?

---

From: Jason L Tibbitts III <[email-masked]>
Date: 06 Jan 2002 18:02:57 -0600

Is it better now?

 - J<

---

From: Dan Espen <[email-masked]>
Date: Sun, 06 Jan 2002 19:15:03 -0500

> Is it better now?

Checkouts work fine now.

Thanks.

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 7 Jan 2002 13:40:11 +0100

> Is it better now?

Thanks.
It seems that I do

	cvs add hints/ -m "new directory"

in the place of

	cvs add -m "new directory" hints/

and this probably cause the problem.

Olivier