Subject: [Fwd: Re: 2.5.0 problems]

From: Tim Phipps <[email-masked]>
Date: Mon, 28 Jan 2002 12:27:35 +0000

[email-masked] wrote:

 > On Sun, Jan 27, 2002 at 07:55:20PM -0800, Elliot Sowadsky wrote:
 >
 >>Solaris 2.5.1
 >>
 >>1) Warning on startup and window updates...
 >> [FVWM][convert_charsets]: <<WARNING>> conversion from `' to `UTF8' 
fail (init)
 >>
 >>What is this convert_charsets?
 >>
 >>
 >
 > This came from the "extended window manager hints" fvwm support.
 > fvwm detects that your locale charset is "". It seems to me
 > that your locale is broken but of course there is a fvwm bug here.
 > You can try to export to the world the env variable CHARSET and
 > set it to "ISO-8859-1" for example.

Part of this problem is that UTF8 isn't a valid charset. The GNU
libiconv documentation says UTF-8 is the correct name. Does anyone know
what the correct name for glibc is?

The other part of the problem is that Solaris 2.5.1 has its own iconv
which doesn't appear to dor UTF at all. I think you may get further if
you can force fvwm to be linked with the gnu libiconv.

Cheers,
Tim.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 28 Jan 2002 13:50:07 +0100

> what the correct name for glibc is?

The glibc support UTF8 and UTF-8 (>= 2.1.x). At least iconv --list gives
the two names.
I will be surprised that the gnu libiconv does not understand the
two names too.

> you can force fvwm to be linked with the gnu libiconv.

I will limit the errors messages as well as the use of the conversion
in a near future.
An other things which can cause trouble is nl_langinfo. I do not know
if Solaris (and other non glibc system) has it.

Olivier

---

From: Tim Phipps <[email-masked]>
Date: Mon, 28 Jan 2002 14:07:47 +0000

> I will be surprised that the gnu libiconv does not understand the

http://www.gnu.org/software/libiconv only mentions UTF-8. Since glibc 
does both could you patch ewmh_names.c to use UTF-8?

Cheers,
Tim.