Subject: Notification: incoming/822

From: [email-masked]
Date: Mon, 03 Dec 2001 11:25:03 -0600

FVWM Bug Tracking notification

new message incoming/822

Message summary for PR#822
	From: [email-masked]
	Subject: xemacs startup width problem
	Date: Mon, 03 Dec 2001 11:25:02 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Mon Dec 03 11:25:03 2001
From: [email-masked]
To: [email-masked]
Subject: xemacs startup width problem
Date: Mon, 03 Dec 2001 11:25:02 -0600

Full_Name: Ryan Eatmon
Version: 2.4.0-3
CVS_Date: 
OS: Debian
X_Server: 4.1.0-9
Submission from: (NULL) (192.91.75.30)

For the past few months I've been having the problem that xemacs comes up
as 79x40 instead of 80x40 like it is supposed to.

I sat down today to figure this out because I finally got raelly really
annoyed.  First I thought it might be an xemacs thing.  I tried older
versions, but they gave me the same problem.

So I tried a different window manager and it came up 80x40.  next I tried
an older version of fvwm2 (2.2.4-2) and now the window is coming up 80x40
like it supposed to.

I'm not sure where the porblem is.  If it's in xemacs, fvwm2, or both
talking to each other.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 4 Dec 2001 09:30:19 +0100

> I'm not sure where the porblem is.  If it's in xemacs, fvwm2, or both

I have already tried to debug this problem.  My conclusion was
that - under certain circumstances - xemacs totally freaks out
during startup.  It repeatedly asks for different sizes (which
fvwm grants), finally loses track of its own size and comes up
with a more or less random geometry.  I have already reported this
to the xemacs developers more than a year ago, but was ignored
completely.  Please try reporting this problem there again,
perhaps they will finally do something about it.

Recently, I noticed that it depends on the xemacs configuration.
Without a $HOME/.emacs file, everything works fine.  I suspect
that this does not happen if you just use the default fonts
(changing the font resizes the window).

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Ryan Eatmon <[email-masked]>
Date: Tue, 04 Dec 2001 07:26:23 -0600

That matches with what I noticed.  Changing the font size changes the
geometry it starts up with.  A really really small font gives 78x40,
where as a bigger font gives you 80x40.  I will ping the xemacs guys
with this.

-- 

Ryan Eatmon            [email-masked]
-------------------------------------
High Performance Analog EDA Core Team
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]