Subject: Notification: incoming/829

From: [email-masked]
Date: Fri, 14 Dec 2001 23:46:41 -0600

FVWM Bug Tracking notification

new message incoming/829

Message summary for PR#829
	From: [email-masked]
	Subject: wrong symbols in titles, icons when in foreign language
	Date: Fri, 14 Dec 2001 23:46:40 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Fri Dec 14 23:46:41 2001
From: [email-masked]
To: [email-masked]
Subject: wrong symbols in titles, icons when in foreign language
Date: Fri, 14 Dec 2001 23:46:40 -0600

Full_Name: Grigory
Version: 2.4.3
CVS_Date: 
OS: freebsd 4.3 release
X_Server: 4.0.3
Submission from: (NULL) (193.232.112.69)

may be it is not a bug but anyway:

i'm a russian user. i use true type fonts everywhere
so when for example i view a russian site then in the title of the window
there symbols which must not be there
same thing in icon descriptions, winlist etc

for example when you visit the site www.rambler.ru (russian search)
in the title you will see some thing like (* - undisplayable symbol here):

*/%1**koi8-r* russian word /%1**koi8-r* russian word /%1**koi8-r* etc

the font I have for titles is (from my config file):
-microsoft-tahoma-medium-r-normal--*-110-75-75-p-*-koi8-r

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 16 Dec 2001 19:46:02 +0100

> -microsoft-tahoma-medium-r-normal--*-110-75-75-p-*-koi8-r

Non Latin character set support has to be compiled into fvwm.  Use
the --enable-multibyte option to the configure script before
compiling:

  $ ./configure --enable-multibyte
  $ make

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]