Subject: Notification: incoming/824

From: [email-masked]
Date: Thu, 06 Dec 2001 03:23:26 -0600

FVWM Bug Tracking notification

new message incoming/824

Message summary for PR#824
	From: [email-masked]
	Subject: BUG in "Resize" command
	Date: Thu, 06 Dec 2001 03:23:25 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Thu Dec 06 03:23:25 2001
From: [email-masked]
To: [email-masked]
Subject: BUG in "Resize" command
Date: Thu, 06 Dec 2001 03:23:25 -0600

Full_Name: Marc-Jano Knopp
Version: 2.4.3
CVS_Date: 
OS: GNU/Linux 2.4.13
X_Server: XFree86 4.0.x
Submission from: (NULL) (130.83.244.129)

I have functions for resizing my windows without
mouse. There seems to be a bug in Resize:

  + I Resize br w-10p keep    - works like a charm
  + I Resize br w+10p keep    - works like a charm
  + I Resize br keep w-10p    - works like a charm
  + I Resize br keep w+10p    - does nothing!

I then tried
 
  + I Resize br keep 10p+w
 
instead, but obviously, '+' is not commutative, as it reduces the
height of my xterm always to one line.
 
Using a percent-of-screen value works, though:
 
  + I Resize br keep w+10     - works like a charm

Marc-Jano

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 7 Dec 2001 08:57:01 +0100

>   + I Resize br keep w+10     - works like a charm

This is not a bug.  Applications can tell fvwm a step width for
resizing.  Most of the time, this is the font width/height.  Now
assume the font is 8 pixels wide and 12 pixels high.  If you make
the window 10 pixels shorter, fvwm rounds down and shrinks the
window by 12 pixels.  But if you add 10 pixels, fvwm again rounds
down to 0 pixels.  This is why the window does not grow.

You can use w+1c and w-1c instead.  The 'c' stands for the step
width the 'c'lient application requested.  But that does not work
very well for applications that do not define a step width.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]