Subject: Notification: incoming/833

From: [email-masked]
Date: Wed, 19 Dec 2001 22:16:43 -0600

FVWM Bug Tracking notification

new message incoming/833

Message summary for PR#833
	From: [email-masked]
	Subject: Focus inconsistent when deiconfing under mouse
	Date: Wed, 19 Dec 2001 22:16:42 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Wed Dec 19 22:16:42 2001
From: [email-masked]
To: [email-masked]
Subject: Focus inconsistent when deiconfing under mouse
Date: Wed, 19 Dec 2001 22:16:42 -0600

Full_Name: Stephen Krauth
Version: 2.4.3
CVS_Date: 
OS: FreeBSD 4.3
X_Server: Xfree86 3.3.5
Submission from: (NULL) (63.124.250.99)

(Somewhat similar to bug 679.)

Upgraded from fvwm2.2.4 and this problem just started happening.  When I
deiconify a window (OK, it's only happening with Netscape that I know of,
and I'm running 4.75) and the mouse is inside the Netscape window as it
appears, SOMETIMES the window gets focus, and sometimes it doesn't.  At
this point I have to move the mouse outside the window and back in to get
focus.

I use FvwmIconMan to do the deiconifying (config below) and the problem
only seems to happen if there are multiple Netscape windows in existence.

(Note: the config below makes two iconmans, one for xterms and the other
for everything else including Netscape; it may be out of date for 2.4.3):

*FvwmIconMan*numManagers 2
*FvwmIconMan*Resolution  page
*FvwmIconMan*background  #303030
*FvwmIconMan*foreground  #a0a0a0
*FvwmIconMan*font        fixed
*FvwmIconMan*action      Mouse  1 N sendcommand Iconify
*FvwmIconMan*action      Mouse  2 N sendcommand Raise
*FvwmIconMan*action      Mouse  3 N sendcommand "Module FvwmIdent
FvwmIdent"
*FvwmIconMan*action      Key    q N quit
*FvwmIconMan*followfocus true
*FvwmIconMan*selectbutton down white
*FvwmIconMan*focusbutton up #ffe0e0 #604040
*FvwmIconMan*focusandselectButton down #ffe0e0 #604040

*FvwmIconMan*1*sort       name
*FvwmIconMan*1*managergeometry   1x0+1-1
*FvwmIconMan*1*buttongeometry   80x0
*FvwmIconMan*1*show       class=XTerm
*FvwmIconMan*1*dontshow   icon=Pine
*FvwmIconMan*1*title      "Terminals"
*FvwmIconMan*1*iconname   "FvwmIconMan: Terminals"
*FvwmIconMan*1*format     "%t"

*FvwmIconMan*2*sort       none
*FvwmIconMan*2*managergeometry   1x0+1+205
*FvwmIconMan*2*buttongeometry   80x0
*FvwmIconMan*2*title      "Apps"
*FvwmIconMan*2*iconname   "FvwmIconMan: Apps"
*FvwmIconMan*2*format      "%i"

- Steve K.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 20 Dec 2001 13:02:12 +0100

> only seems to happen if there are multiple Netscape windows in existence.

Do you use SloppyFocus, MouseFocus or ClickToFocus for netscape?
Which does your FvwmIconMan use?
 
> *FvwmIconMan*2*format      "%i"

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Stephen Krauth <[email-masked]>
Date: Thu, 20 Dec 2001 10:29:07 -0500 (EST)

> Which does your FvwmIconMan use?

Oh sorry, Netscape uses the default which is never set, so is probably
MouseFocus (focused only when mouse inside) and IconMan uses NeverFocus.

Steve K.                         U.F.O. - "For the feeler gauge in you."