Subject: CVS olicha: * Some new ewmh styles (really I think that all these are needed)

From: FVWM CVS <[email-masked]>
Date: Wed, 05 Dec 2001 01:41:41 -0600

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	olicha	01/12/05 01:41:41

Modified files:
	.              : ChangeLog NEWS configure.in 
	fvwm           : ConfigFvwmDefaults add_window.c add_window.h 
	                 borders.c builtins.c events.c ewmh.c ewmh.h 
	                 ewmh_conf.c ewmh_events.c ewmh_icons.c 
	                 ewmh_names.c fvwm.h fvwm2.1 icons.c 
	                 move_resize.c placement.c placement.h session.c 
	                 stack.c style.c style.h update.c update.h 
	                 window_flags.h windowlist.c 
	libs           : defaults.h 

Log message:
* Some new ewmh styles (really I think that all these are needed)
* New styles ExtendedWindowName / SimpleWindowName and
ExtendedIconName / SimpleIconName. TODO: the modules implementation.
I will come on this in an email.
* New styles PlacementOverlapPenalties and PlacementOverlapPercentPenalties
* Some ewmh fixes
* New doc in fvwm2.1: 4847-4871, 5231-5233, 5242-5244, 5246-5314, 5637-5640,
5668-5710.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Tue, 11 Dec 2001 21:44:16 -0500

> * New doc in fvwm2.1: 4847-4871, 5231-5233, 5242-5244, 5246-5314, 5637-5640,

I think you must have made more changes so these line numbers aren't
accurate any more.  I need help finding your changes.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 12 Dec 2001 08:38:09 +0100

> accurate any more.  I need help finding your changes.

Ok, lines are not good info.
- pargraph which document the IndexedWindowName style
  (begin at line 4879 at present time)
- last sentence of the paragraph which document MinOverlapPlacement
  (lines 5263-5265 apt)
- last sentence of the paragraph which document MinOverlapPercentPlacement
  (lines 5274-5276 apt)
- The two paragraphs which document PlacementOverlapPenalities and
  PlacementOverlapPercentPenalities (lines 5278-5323 apt)
- The consecutive paragraphs which document the ewmh styles
	EWMHMaximizeIgnoreWorkingArea / EWMHMaximizeUseWorkingArea /
	EWMHMaximizeUseDynamicWorkingArea,
	EWMHPlacementIgnoreWorkingArea / EWMHPlacementUseWorkingArea
	EWMHPlacementUseDynamicWorkingArea,
	EWMHUseStackingOrderHints / EWMHIgnoreStackingOrderHints,
	EWMHIgnoreStateHints / EWMHUseStateHints,
	EWMHIgnoreStrutHints / EWMHUseStrutHints
  (lines 5701-5743 apt)

It is not easy to write doc ... specially for me in English
(get always problems with ending "s"). Thanks again for the
reviews, but some times as I know this, I do not rerecheck it ...

Regards, Olivier

---

From: Dan Espen <[email-masked]>
Date: Sat, 15 Dec 2001 10:39:53 -0500

> > FVWM CVS <[email-masked]> writes:
...
> Ok, lines are not good info.
...
> reviews, but some times as I know this, I do not rerecheck it ...

You have my sympathy.  English seems pretty random to me too.

I had a question about your latest change.
I put in comments framing the area I didn't understand, like this:

.\"needswork
...
.\"end needswork

If you can mark areas of the man page you would like reviewed,
that would get rid of the line number problem.

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 17 Dec 2001 12:30:25 +0100

> I put in comments framing the area I didn't understand, like this:

I've tried to clarify this.
 
> that would get rid of the line number problem.

Oh yes, good idea, I will use

.\"needs_lang_check
...
.\"end needs_lang_check

from now.

Regards, Olivier