Subject: kcalc and latin9

From: Peter Münster <[email-masked]>
Date: Sat, 29 Dec 2001 01:07:18 +0100 (CET)

Hello,
when I invoke "kcalc", I get the following message:

[FVWM][GetWindowSizeHints]: <<WARNING>> KCalc window 0x3000009 has broken (max_height) size hints
Please report this to [email-masked]
hint override = 0
flags = 23f
min_width = 376, min_height = 271, max_width = 32767, max_height = 0
width_inc = 389, height_inc = 271
min_aspect = 1079017468/1082363536, max_aspect = 134692872/-1073745492
base_width = 1078971376, base_height = -1073745500
win_gravity = 1

fvwm2 -version:
FVWM version 2.4.0 compiled on Sep 24 2001 at 02:41:34
with support for: ReadLine, Stroke, XPM, GNOME WM hints, SM, Multibyte

Another little problem:
when using latin9, for example
*FvwmPagerSmallFont	-misc-fixed-medium-r-normal--7-70-75-75-c-50-iso8859-15
the font is not displayed.

Cheers and thanks for this very great windowmanager!
Peter

-- 
http://pmrb.free.fr/contact/

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sat, 29 Dec 2001 15:14:17 -0500

> with support for: ReadLine, Stroke, XPM, GNOME WM hints, SM, Multibyte

What version of kcalc is this?  The version I have (1.2.7), doesn't
have this problem.

If your version is later, consider notifying the kcalc developer.
Kcalc is setting window size hints that are contradictory.
They don't need Fvwm to see this, they can run "xwininfo -size".

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sat, 29 Dec 2001 15:51:48 -0500

> Hello,
...
> the font is not displayed.

The "smallFont" is used to label windows  in the pager.  You will only
see the smallFont when you don't use miniIcons in the pager.

I tried the above font and it seemed to work for me.
If you are still having a problem, send us the complete FvwmPager
configuration you are using.

---

From: Peter Münster <[email-masked]>
Date: Sun, 30 Dec 2001 00:06:46 +0100 (CET)

> configuration you are using.

Here the complete configuration:
Style	"FvwmPager"	NoTitle, Sticky, WindowListSkip
*FvwmPagerRows	1
*FvwmPagerColumns	1
*FvwmPagerGeometry	-0+0
*FvwmPagerFore	Black
*FvwmPagerBack	grey67
*FvwmPagerHilight	grey50
*FvwmPagerFont	none
*FvwmPagerSmallFont	-misc-fixed-medium-r-normal--7-70-75-75-c-50-iso8859-15

When I replace the last line with
*FvwmPagerSmallFont	-misc-fixed-medium-r-normal--7-70-75-75-c-50-iso8859-1
it works.

Cheers, Peter

---

From: Dan Espen <[email-masked]>
Date: Sat, 29 Dec 2001 19:34:16 -0500

> *FvwmPagerSmallFont	-misc-fixed-medium-r-normal--7-70-75-75-c-50-iso8859-1

Well, I'm mystified.  If I send you a source file for part of
FvwmPager with some additional error tracing, would you compile
it and try it out?

---

From: Peter Münster <[email-masked]>
Date: Sun, 30 Dec 2001 12:39:55 +0100 (CET)

> FvwmPager with some additional error tracing, would you compile

Yes, no problem! But you've noted, that my fvwm version is not the newest?
It's 2.4.0.
Also, I've just noticed, that it works, when I set the environment variable
LC_CTYPE=fr_FR@euro. But then, the following warning appears:
[FVWM][GetFontSetOrFixed]: WARNING -- can't get fontset fixed, trying 'fixed'
Cheers, Peter

---

From: Dan Espen <[email-masked]>
Date: Sun, 30 Dec 2001 16:25:56 -0500

> [FVWM][GetFontSetOrFixed]: WARNING -- can't get fontset fixed, trying 'fixed'

If you have your stuff working, I think I'll skip having you do testing.

I just commited a bunch of fixes in the 2.5.0 branch that should clean
up some of the issues you encountered, like that message above where
if warns about not getting "fixed" but then implies that its going to
try "fixed".  (It actually tries a different font.)

I also made the pager use the same font logic that other parts of FVWM
use, so there should be less problems in the future.

Thank you for your patience.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 31 Dec 2001 17:49:22 +0100

> Thank you for your patience.

I think there is a report in Jitterbug for that warning (trying
'fixed').  Could wou please take a look and close that report if
it's fixed?

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Mon, 31 Dec 2001 12:02:27 -0500

...

Searching using the keyword "fixed" the only candidate I see is #790:

> From: [email-masked]
> To: [email-masked]
> Subject: Error in font-handling
> Date: Mon, 08 Oct 2001 08:48:03 -0500
> 
> Full_Name: Matthias Meixner
> Version: 2.4.2
> OS: Linux (Suse 7.2)
> X_Server: XFree86
> Submission from: (NULL) (130.83.244.130)
> 
> If $LANG is set to use a different language, the font-handling does
> not work any more. Fvwm does not find any single font in this case.
> It reports the following error message:
> 
> [FVWM][GetFontSetOrFixed]: WARNING -- can't get fontset
> <insert-any-fontname-here>, trying 'fixed'
> 
> Unsetting $LANG before starting fvwm removes this error message.

It mentions the message but doesn't point out the fix I made.
I didn't remember a problem report for the specific fix I made.