Subject: Event

From: Olivier Chapuis <[email-masked]>
Date: Sat, 1 Dec 2001 18:29:29 +0100

Hello,

Is it possible to know which window send an Event?

More precisely, when we get an XClientEvent ev with
ev->xany.send_event = True can we know which window
send this event. Unfortunately, in the case I am
interest in, ev->xany.window and ev->xclient.window
are not the window id of the sender but the window id
on which the sender want to act.

Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 3 Dec 2001 12:00:38 +0100

> on which the sender want to act.

Windows can't send events at all, only applications can do so.
You could only place that in the ClientEvent itself.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]