Subject: CVS domivogt: * Actions can be bound to windows swallowed in FvwmButtons.

From: FVWM CVS <[email-masked]>
Date: Thu, 13 Dec 2001 03:23:37 -0600

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	01/12/13 03:23:37

Modified files:
	.              : NEWS 
	modules        : ChangeLog 
	modules/FvwmButtons: FvwmButtons.c 

Log message:
* Actions can be bound to windows swallowed in FvwmButtons.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 13 Dec 2001 21:07:51 +0100

> * Actions can be bound to windows swallowed in FvwmButtons.

Hello,
It seems to me that there a problem here. Say that
we have a *shaped* application that you sallow in a
FvwmButtons and that app needs buttons click (as a
mini cd player). With the old code, as the application
is shaped you can define FvwmButtons Actions that are
executed when you click on the FvwmButtons button
that swallow the app but "out of the mask" and the
click on the swallowed app is still passed to the
app.
With the new code this does not work any more, as
the mouse buttons are grabbed, a mouse click never
goes to the swallowed app and the FvwmButtons Actions
is always executed.
I see two solutions:
1) do not grab the mouse buttons in the case of
the swallowed app is shaped.
2) add a new action command: GrabedAction which do
what the new code do and keep the old code for the
Action.

Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 14 Dec 2001 11:57:17 +0100

> what the new code do and keep the old code for the

3) Pass the click to the application despite of the click.

I'll try that first.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 19 Dec 2001 10:50:48 +0100

> 3) Pass the click to the application despite of the click.

Is that a real or a theoretical problem?  I can't find any shaped
application I might want to swallow in FvwmButtons that does
something with mouse clicks.

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 19 Dec 2001 14:16:14 +0000

> something with mouse clicks.

It is now really broken. Try to swallow xterm, with Action defined.
xterm gets focus, but not mouse presses, Action is always executed.

For a transparent example, you may try "xdaliclock -transparent".

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 19 Dec 2001 15:16:07 +0100

> something with mouse clicks.

It is a real problem: I discover this because I used such app
(with action defined when I click on the shapped part):
There are a lot of Window Maker and AfterStep applet which needs
mouse click and which have shape.

I do not think it is difficult to add a GrabedAction command.
I can add it if you want.

Olivier

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 19 Dec 2001 14:35:27 +0000

> For a transparent example, you may try "xdaliclock -transparent".

I want to paraphrase myself. I prefer the previous Action behaviour,
even I myself only swallow applications without mouse press handling.
The Olivier's suggestion about 2 types of Action makes sence.

Regards,
Mikhael.