Subject: Notification: incoming/813

From: [email-masked]
Date: Tue, 27 Nov 2001 06:23:22 -0600

FVWM Bug Tracking notification

new message incoming/813

Message summary for PR#813
	From: [email-masked]
	Subject: Dragging button 3 with FvwmPager
	Date: Tue, 27 Nov 2001 06:23:21 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Tue Nov 27 06:23:22 2001
From: [email-masked]
To: [email-masked]
Subject: Dragging button 3 with FvwmPager
Date: Tue, 27 Nov 2001 06:23:21 -0600

Full_Name: Guillaume Chazarain
Version: 2.4.3
CVS_Date: 
OS: 
X_Server: 4.1.0
Submission from: (NULL) (134.59.2.127)

In the FvwmPager manual page it is stated that :

---
Clicking mouse button 3 on a location will cause the viewport to move to
the
selected location and switch desks if necessary
---
Dragging button 3 will cause the viewport to move as you drag but not
switch desktops, even if the pointer moves to another desktop.
---

I don't understand what 'not switch desktops' means because it is the same
if I drag the button 3 or if I continually click it while moving the
mouse.

Another problem I have, is that sometimes (actually most of the times),
dragging the button 3 has the same effect as if I clicked it just once.
That is, the viewport is not smoothly moved.
I think I found where it comes from :

The dragging is activated if we are in a MotionNotify event and
(Event->xmotion.state == Button3MotionMask) but what I have on my system
is
(Event->xmotion.state == (Button3MotionMask | EnterWindowMask))
so the following patch fixes the problem for me.

I understand that the bug may not be in fvwm2 but in X or whatever, but
the
easiest solution for me was to fix it in fvwm2.

---

diff -u fvwm-2.4.3/modules/FvwmPager/x_pager.c
fvwm-2.4.3-button3pager/modules/F
vwmPager/x_pager.c
--- fvwm-2.4.3/modules/FvwmPager/x_pager.c      Sun Sep 16 17:51:18 2001
+++ fvwm-2.4.3-button3pager/modules/FvwmPager/x_pager.c Fri Nov 23 22:42:18
2001
@@ -1156,7 +1156,7 @@
     while(XCheckMaskEvent(dpy, PointerMotionMask |
ButtonMotionMask,Event))
       ;
 
-    if(Event->xmotion.state == Button3MotionMask)
+    if(Event->xmotion.state & Button3MotionMask)
     {
       for(i=0;i<ndesks;i++)
       {

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 28 Nov 2001 06:18:04 +0100

> if I drag the button 3 or if I continually click it while moving the

Note the difference between multiple pages on a single desk and
multiple desktops.  If you have this in your config file:

  DesktopSize 3x3
  FvwmPager 0 1

the pager displays two independent desktops (0 and 1) with 3 by 3
pages each.  Now lets assume you press and hold button 3 over page
0 0 on desk 0.  By moving the mouse you can center the current
viewport anywhere on desk 0, but it won't switch to desk 1 if you
move the mouse there.

> easiest solution for me was to fix it in fvwm2.

It's not an 'EnterWindowMask' you see (an xmotion event can not
contain this) but 'Mod2Mask' (which has the same value).  You
probably have Num-Lock active when this happens.  Anyway,
comparing with '==' isn't a good idea, so I'll commit your patch.

> +++ fvwm-2.4.3-button3pager/modules/FvwmPager/x_pager.c Fri Nov 23 22:42:18

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]