Subject: Problems with FvwmScript on HPUX

From: TKB Sebastian Henkel <[email-masked]>
Date: Mon, 19 Nov 2001 09:10:07 +0100

Hello,

I do have a problem with FVWM running on HPUX. The problem became
visible after installing Fvwm-Themes as well.
Having experienced the problem with Fvwm-Themes I exchanged some
e-mails with Mikhael Goikhman. He suggested that I should contact the
people on this list to get the problem solved.

I compile FVWM on my HPUX workstation (HPUX 10.20) using the
HP-Compilers. 
FVWM worked and I had nothing to complain. GTK+ and Gnome options were
used and everything seemed to work.
Then I installed Fvwm-Themes using the same compilers. I got the
themes to work as well. But it is impossible to change themes in the
planned way.
Mikhael suggested to test if FvwmScript is working. It turned out that
it doesn't work. Even the most simple scripts like 
FvwmScript FvwmScript-NoteMessage Test 
didn't work.

If you have an idea what I should try please tell me. Unfortunatly I
am no C/C++-programmer (Just a Fortran programmer as far as it is
necessary) I can only contribute in compiling and testing.

Best regards,

Sebastian Henkel
-- 

Dipl.-Ing. Sebastian Henkel, Naval Architect, TKB Basic Design

Tel.  : +49 461 4940-508    FLENSBURGER SCHIFFBAU-GESELLSCHAFT mbH & Co. KG
Fax   : +49 461 4940-217    Batteriestrasse 52,  D-24939 Flensburg, Germany
E-Mail: [email-masked]  http://www.fsg-ship.de

The Information contained in this  E-Mail and any subsequent correspondence
is private and is intended solely for the intended recipient(s).
For those  other than the recipient any  disclosure, copying, distribution, 
or any action taken or omitted to be taken in  reliance on such information
is prohibited and may be unlawful.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 20 Nov 2001 12:11:51 +0100

> Hello,

Hello

[snip]
> used and everything seemed to work.

do you have --enable-multibyte at compile time?

> FvwmScript FvwmScript-NoteMessage Test 

Do you have any error message when FvwmScript FvwmScript-NoteMessage Test
fail to start? Do you have a core file? If yes can you type
"gdb module_path/FvwmScript core"
and at the prompt "where" and send us the output (if you have such a tool,
I do not know if HPUX produces core files).

If you have gcc you can try to compile fvwm with it and see if
FvwmScript works (but this is not a solution).

Regards, Olivier