Subject: CVS domivogt: * -Wall fix (2nd parameter of iconv).

From: FVWM CVS <[email-masked]>
Date: Fri, 23 Nov 2001 06:35:31 -0600

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	01/11/23 06:35:31

Modified files:
	.              : ChangeLog 
	fvwm           : ewmh_names.c 

Log message:
* -Wall fix (2nd parameter of iconv).
* Replaced a 'goto' with a loop.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 23 Nov 2001 18:18:16 +0100

> * -Wall fix (2nd parameter of iconv).

The amusing thing here is that now I have a warning:

ewmh_names.c: In function `convert_charsets':
ewmh_names.c:132: warning: passing arg 2 of `iconv' from incompatible pointer type

I do not think that this can cause a problem.
It is probably my glibc which is broken as the glib developers
do as you commit.

> * Replaced a 'goto' with a loop.

Ah yes, cut and past from the glib (as mentionned in this file).

Olivier

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 23 Nov 2001 19:58:20 +0100

> * Replaced a 'goto' with a loop.

Yes, but ... fixed.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 26 Nov 2001 11:50:01 +0100

> It is probably my glibc which is broken as the glib developers

Doh.  It should be possible to pass in a (char *) to a function
expecting a (const char *) without a warning.  After all, the
const is just some kind of information for the caller that the
provided pointer will be used read-only.  If there is no way to
make -Wall happy in all circumstances I'd prefer to avoid the
iconv() function altogether.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 27 Nov 2001 12:12:17 +0100

> iconv() function altogether.

I hope that I've suppressed the warnings.
Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 27 Nov 2001 12:38:18 +0100

> I hope that I've suppressed the warnings.

If you don't get the warning, I don't either.

Bye

Dominik ^_^  ^_^