Subject: CVS olicha: * Remove most of the ewmh ifdef

From: FVWM CVS <[email-masked]>
Date: Thu, 22 Nov 2001 16:04:51 -0600

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	olicha	01/11/22 16:04:51

Modified files:
	.              : ChangeLog acconfig.h configure.in 
	fvwm           : ConfigFvwmDefaults Makefile.am add_window.c 
	                 bindings.c events.c ewmh.c ewmh.h ewmh_events.c 
	                 ewmh_icons.c ewmh_intern.h functions.c 
	                 functions.h fvwm.c fvwm.h fvwm2.1 placement.c 
	                 screen.h session.c style.c update.c update.h 
	                 window_flags.h 
	libs           : Bindings.c Picture.c Picture.h fvwmlib.h 

Log message:
* Remove most of the ewmh ifdef
* New commands EWMHBaseStrut and EWMHNumberOfDesktops
* Some minor ewmh fixes
* Warning: document the new commands and more doc in the ewmh section.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 23 Nov 2001 11:18:55 +0100

> * Warning: document the new commands and more doc in the ewmh section.

I noticed a macro IS_EWMH_DESKTOP() in the code.  Do I understand
it correctly that the virtual root window of KDE is stored in a
regular FvwmWindow structure?  Wouldn't it be easier then to give
it a special treatment so that we don't need these IS_EWMH_DESKTOP
checks all over the place?

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 23 Nov 2001 18:06:43 +0100

On Fri, Nov 23, 2001 at 11:18:55AM +0100, Dominik Vogt wrote:
> regular FvwmWindow structure?

Yes, there is also a new context for this type of application: 'D'.

> Wouldn't it be easier then to give

The point is that it should be managed by fvwm (at least for bindings
and other small things). Then, we need to know its "fvwm" parent for
computing the 'D' context, so I use a full FvwmWindow structure for
it (and not just a window id, but this is probably possible).
In any case I do not see how to remove all these IS_EWMH_DESKTOP check
without going into a lot of problems.

Olivier