Subject: Notification: incoming/810

From: [email-masked]
Date: Fri, 16 Nov 2001 09:37:54 -0600

FVWM Bug Tracking notification

new message incoming/810

Message summary for PR#810
	From: [email-masked]
	Subject: bugfix for txt2html.sh
	Date: Fri, 16 Nov 2001 09:37:53 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Fri Nov 16 09:37:53 2001
From: [email-masked]
To: [email-masked]
Subject: bugfix for txt2html.sh
Date: Fri, 16 Nov 2001 09:37:53 -0600

Full_Name: George Herson
Version: ?
CVS_Date: ?
OS: linux redhat 7.1
X_Server: ?
Submission from: (NULL) (64.252.0.136)

Hi.  I have a file called txt2html.sh on my system.  It says "The Official
FVWM Homepage" in it so I came to your site.

I fixed the script's disregard of multiple &, <, and > characters on a line
by adding "g":

diff /tmp/txt2html.sh /usr/share/doc/fvwm2-2.2.4/docs/txt2html.sh
34,36c34,36
< sed -e 's/&/\&amp;/' \
< -e 's/</\&lt;/' \
< -e 's/>/\&gt;/' $1 >> $outfile
---
> sed -e 's/&/\&amp;/g' \
> -e 's/</\&lt;/g' \
> -e 's/>/\&gt;/g' $1 >> $outfile

To id my version, the top of txt2html has:

#!/bin/sh

# Modification History

# Changed on 11/05/98 by DanEspen (dje):
# - Changed from ksh to sh for extra portability.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Fri, 16 Nov 2001 11:35:26 -0500

[email-masked] writes:
> Received: from karazm.math.uh.edu ([129.7.128.1])
> 	by malifon.math.uh.edu with esmtp (Exim 3.20 #1)
> 	id 164l3x-00010T-00
> 	for [email-masked]; Fri, 16 Nov 2001 09:37:53 -0600
> Received: from malifon.math.uh.edu (malifon.math.uh.edu [129.7.128.13])
> 	by karazm.math.uh.edu (8.9.3/8.9.3) with ESMTP id JAA18651
> 	for <[email-masked]>; Fri, 16 Nov 2001 09:37:53 -0600 (CST)
> From: [email-masked]
> Received: from localhost ([127.0.0.1])
> 	by malifon.math.uh.edu with esmtp (Exim 3.20 #1)
> 	id 164l3x-00010R-00
> 	for [email-masked]; Fri, 16 Nov 2001 09:37:53 -0600
> To: [email-masked]
> Message-Id: <[email-masked]>

You must have an old version.
The current version contains this fix.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]