Subject: Notification: incoming/809

From: [email-masked]
Date: Mon, 12 Nov 2001 14:17:08 -0600

FVWM Bug Tracking notification

new message incoming/809

Message summary for PR#809
	From: [email-masked]
	Subject: configure bug in finding Xpm libs
	Date: Mon, 12 Nov 2001 14:17:07 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Mon Nov 12 14:17:08 2001
From: [email-masked]
To: [email-masked]
Subject: configure bug in finding Xpm libs
Date: Mon, 12 Nov 2001 14:17:07 -0600

Full_Name: Jeff Solomon
Version: 2.4.3
CVS_Date: 
OS: N/A
X_Server: N/A
Submission from: (NULL) (171.64.72.46)

This is an easy bug to fix.

My Xpm libraries are in a non-standard place so I have to include       
--with-xpm-library=

--with-xpm-includes=

on my ./configure command line. This is fine.

In the configure script itself, though, the link line that is being
generated does not work because it puts -lXpm *before* the -L/path/to/Xpm

Is is line 2515 in the script:

LIBS="-l${smr_lib} ${xpm_LIBS} $X_LIBS $X_PRE_LIBS -lX11 $X_EXTRA_LIBS
$LIBS"

The fix is to either make -l${smr_lib} come after ${xpm_LIBS} or to simply
remove -l${smr_lib} altogether since I believe that xpm_LIBS will always
contain -lXpm.

I had to manually edit this line to convince the script that I do indeed
have xpm installed.

I know that configure scripts are themselves autogenerated by autoconf, so
the fix might not be as easy as I imagine, but I still consider it a bug.

Thanks,

Jeff

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 13 Nov 2001 10:27:53 +0100

> the fix might not be as easy as I imagine, but I still consider it a bug.

The xpm checks are generated from the configure.in script.  Could
you please make a patch to that file?  I'm not sure I understand
you correctly and I don't want to make a mistake and break things.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 15 Nov 2001 12:39:27 +0000

> you correctly and I don't want to make a mistake and break things.

I believe, external AC_CHECK_LIB from autoconf should be patched.
If there is a patch to fvwm, I would like to verify it.

Jeff Solomon, to solve this problem with Solaris cc, you may try this:
  * read solutions in INSTALL.fvwm and FAQ (search for "Solaris")
  * use gcc (should work unless there is a fundamental problem on Solaris)
  * use --with-xpm-library=/library/dir/libXpm.a and not =/library/dir

Regards,
Mikhael.