Subject: a ClickToFocus thing

From: Giuseppe Della Ricca <[email-masked]>
Date: Wed, 24 Oct 2001 13:58:51 +0200 (CEST)

Dear fvwm-workers,

I'm using fvwm 2.5.0 out of CVS:

FVWM version 2.5.0 compiled on Oct 23 2001 at 14:23:23
with support for: ReadLine, XPM, GNOME WM hints, Shape, SM, Xinerama

starting from the following commit:

2001-10-15  Dominik Vogt  <[email-masked]>

        * fvwm/bindings.c (activate_binding):
        * libs/Bindings.c (GrabWindowKeyOrButton):
        activate mouse/stroke bindings immediately

        * fvwm/events.c (HandleButtonPress):
        it is possible to bind actions to the 'ClickToFocus' click

I'm having some problems with 'Style * ClickToFocus'.

Two examples:

- Netscape/Mozilla: if the window is not focussed, I have to click twice 
  on links/buttons (one for the focus, the second for the action)

- xterm: if the xterm is not focussed, I have to tip 3 times to select 
  something (as above, one for the focus, the other two for the selection)

It seems to me that maybe the ClickToFocusPassesClick stopped working 
after that commit.

Please let me know if I can help somehow in solving this thing.

Thanks in advance,
Giuseppe.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 24 Oct 2001 14:35:56 +0200

> It seems to me that maybe the ClickToFocusPassesClick stopped working 

Hm, I don't see any probelm, ClickToFocusPassesClick still works
fine for me.  Are you sure you have this in your config file and
that it is indeed executed?

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Giuseppe Della Ricca <[email-masked]>
Date: Thu, 25 Oct 2001 13:12:48 +0200 (CEST)

Hi Dominik,

yes, I have Style * ClickToFocus in my .fvwm2rc and it was working before 
that commit ...

I've also tried adding Style * ClickToFocusPassesClick (even if these 
should be the default), but I still see the same effect.

I'll send you my .fvwm2rc: maybe there's something conflicting with it.

Thanks a lot in advance.

Cheers,
Giuseppe.