Subject: valid alias char

From: Olivier Chapuis <[email-masked]>
Date: Fri, 19 Oct 2001 06:50:46 +0200

Hello,

An alias name for a module should be constituted by
a...z, A...Z, 0...9, - or . characters a should begin
with a letter. This cause problems with FvwmScript as
typically (not in fvwm neither in fvwm-themes) you may
start a FvwmScript as:

FvwmScript scripts/MyScript
or
FvwmScript /full-path/MyScript

So it seems that we should add "/" to the list.
Is this can cause problems?

Regards, Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 20 Oct 2001 00:45:16 +0000

> Is this can cause problems?

I would think that in both cases the alias name could be MyScript.
Or yet better, it should be set independently from the file name.

If you decide to use the file name as the alias, then yes, you may add "/"
to the list of valid chars. Hopefully this will not break anything.

Of course the correct solution is to formalize (and standardize) aliases,
so that fvwm and modules would not guess and not use their own heuristics.
Something for the future, not very easy if we think about compatibility.

Regards,
Mikhael.