Subject: Re: man page formatting

From: Dominik Vogt <[email-masked]>
Date: Tue, 10 Jul 2001 18:57:07 +0200

On Sat, Jul 21, 2001 at 07:48:17PM +0000, Mikhael Goikhman wrote:
> On 21 Jul 2001 19:26:09 +0200, Dominik Vogt wrote:
> > 
> > The recent fixes in the man page for Solaris etc. (\f...) broke
> > the bold typeface of the reformatted sections.  For example: 
> > 
> >   .TP
> >   .BI "Menu " menu-name " [ " position " ] [ " double-click-action " ]"
> > 
> > was changed to
> > 
> >   .IP "Menu \fImenu-name\fP [ \fIposition\fP ] [ \fIdouble-click-action\fP ]"
> > 
> > The "Menu", "[" and "]" parts of the old version are bold while
> > they are not in the new one.  Of course this can be fixed by
> > adding more \fB...\fP pairs, but I'd *really* prefer to find a way
> > to do that without \f...  Isn't there a way to split the .BI lines
> > into several?  Any ideas are welcome.
> 
> I suggest the following style for all commands:
> 
>   .B "Menu "
>   .I     menu-name
>   .BI    "[ " position " ]"
>   .BI    "[ " double-click-action " ]"
> 
>   .B Popup
>   .I      popup-name
>   .BI     "[ " position " ]"
>   .BI     "[ " default-action " ]"
> 
> I.e. use .B for command, .I for mandatory parameters, .BI for optional.
> I also think, the spaces in braces are not really needed: .BI [ position ]

Looks good to me.  The only thing I don't get working is the
indentation of the text paragraphs:

  .TP
  .B "Menu "
  .I     menu-name
  .BI    "[ " position " ]"
  bla blub

results in

  Menu menu-name [ position ] bla blub

and

  .TP
  .B "Menu "
  .I     menu-name
  .BI    "[ " position " ]"

  bla blub

gives me

  Menu menu-name [ position ] bla blub

        bla blub

but we want

  Menu menu-name [ position ] bla blub
        bla blub

> This syntax is more readable in my opinion. I may do all these changes.

Bye

Dominik ^_^  ^_^

 --

> 
> I.e. use .B for command, .I for mandatory parameters, .BI for optional.
> I also think, the spaces in braces are not really needed: .BI [ position ]

Looks good to me.  The only thing I don't get working is the
indentation of the text paragraphs:

.TP
.B "Menu "
.

> 
> This syntax is more readable in my opinion. I may do all these changes.
> 
> Regards,
.

> 
> This syntax is more readable in my opinion. I may do all these changes.
> 
> Regards,
> Mikhael.
> --
> Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
> To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
> body of a message to [email-masked].
> To report problems, send mail to [email-masked]

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 10 Oct 2001 13:02:42 -0400

> > On 21 Jul 2001 19:26:09 +0200, Dominik Vogt wrote:

Looks like somebody unplugged a clogged mail server.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 10 Oct 2001 17:25:58 +0000

[Sorry to quote it all, not everyone keeps July threads.]

>   Menu menu-name [ position ] bla blub

My own conclusion in July was we should write our own macro instead of
.TP, but looking at /usr/lib/groff/tmac/tmac.an where .de TP is defined
gave me headache. This is learnable for sure, but may be someone else
is already familar with this hieroglyphic language?

And I am still sure we don't need spaces (remember, braces are in bold
or even in different color), i.e. I prefer this bold-inverse output:

  Menu menu-name [position] [double-click-action]
        bla blub

Regards,
Mikhael.