Subject: Re: RelieveRectangle: called with w = -10, h = 1

From: Dominik Vogt <[email-masked]>
Date: Thu, 30 Sep 2021 18:35:03 +0200

On Sat, Sep 29, 2001 at 08:42:14PM -0700, Elliot Sowadsky wrote:
> fvwm prints out "RelieveRectangle: called with w = -10, h = 1"
> 
> when i resize my mailtool winow.
> Message started w/ 2.4.2 i believe.

I added this debug output some time around then since I thought
calling functions with illegal arguments isn't a good idea.  Can
you try to find out which piece of decoration causes this message
by disabling the title buttons, the title and the border
successively?  Unfortunately I don't have access to mailtool
myself.

> The function works as intended tho.
> 
> 
> 
> AddToFunc "Max2Size"
> +	"I" Maximize
> +	"I" ResizeMove $0p $1p $2p $3p
> +	"I" Resize br w-10p w-27p  # account for borders and title
> 
> AddToFunc "Tile"
> +	"I" Resize 0 0
> +	"I" Maximize grow grow
> +	"I" Max2Size $[w.width] $[w.height] $[w.x] $[w.y]
> 
> Mouse 1		T	SC	Tile

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Elliot Sowadsky <[email-masked]>
Date: Mon, 1 Oct 2001 14:46:24 -0700 (PDT)

> fvwm prints out "RelieveRectangle: called with w = -10, h = 1"

Resize generates the message if the sticky title text does not fit in the
resized title bar.

Non-sticky doesnt print the message.

Resize 0 0 was what i originally had that generated the message.

Resize 250p 0  was a little past the end of the text and gave
RelieveRectangle: called with w = -2, h = 1

Resize 260p 0  was further past then end and gave no warning.