Subject: Some Xinerama problems

From: Olivier Chapuis <[email-masked]>
Date: Fri, 28 Sep 2001 17:23:18 +0200

Hello,
I make some Xinerama test recently using Sls 1x2 on
my poor 800x600 screen:

   ---------------
  |       |       |
  |   0   |   1   |
  |       |       |
   ---------------

The support seems really great! (BTW, does there exits
laptop with a double head video card?).

I've noted a few problems with menu position and IconBox

1. if WindowList is called without argument as well as
if a menu key binding of the form
   Key key Context Modifier Menu MyMenu _No_arg_
is activate, then the window list (or the menu) always
popup on screen 0.   

These problems has been already remarked on this list.
I've a very simple fix for this bug, but maybe, Dominik,
you prefer to fix it.

2. For testing let say we have the following binding:

   Mouse 1 A M Menu MenuFvwmRoot Rectangle 1x1+200+200@c +0 +0

(the @c is not really important). So when I activate this
bindings the menu popup at 200+200@c but if I am on screen
0 and I popup submenus (and subsubmenus) then the menu
go into screen 1 (so it is exactly as if I've no XineramaSls
support). This does not happen on screen 1 (but here the
left limit is my monitor).
Similarly if I use:

   Mouse 1 A M Menu MenuFvwmRoot Rectangle 1x1+390+200@g +0 +0

(and MenuFvwmRoot is larger than 10p) the menu appear in between
screen 0 and 1 as it should appear on screen 0 (as it will do
with 1x1+790+200@g on screen 1).

3. It seems natural for me that iconification happen on the
current screen, so I test IconBox with 

Style "*" IconBox 370x400+10-10@c, IconGrid 64 10, IconFill left bottom

In "normal" use this work fine. However, if the above command
is entered in a way or an other when the mouse cursor is on
screen 1 the icons on screen 0 go in a random location (in the
top of screen 0). Similar things happen with

All (CurrentScreen Iconic) RecaptureWindow

Also if I have a window which is almost all in screen 1
and if I Iconify it with a title button on screen 0, then
the icon go in a random location. More important, if
I have a window on screen 1 and if I Iconify it with IconMan
which is on screen 0, then again the icon go in a
bad location (in screen 0).

In the above, screen 0 and 1 are interchangeable.

I've not investigate problem 2. & 3. I may take a look
if no other (more competent than me for these) have the
time to fix it (before 2.4.3?).

Olivier

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "Dmitry Yu. Bolkhovityanov" <[email-masked]>
Date: Sat, 29 Sep 2001 12:26:02 +0700

> I make some Xinerama test recently using Sls 1x2 on

	Most modern laptops are "dual-headed": first head is laptop's flat
panel, the second is VGA output.  While VGA typically duplicates the
panel, at least those with ATI cards (e.g. Compaq Presario 1700 with ATI
Rage Mobility M2) and with Permedia ones are able of displaying different
pictures on these heads, and even with different resolutions.

	_________________________________________
	  Dmitry Yu. Bolkhovityanov
	  [email-masked]
	  The Budker Institute of Nuclear Physics