Subject: 'fluttering' icons on lower

From: David Fries <[email-masked]>
Date: Fri, 28 Sep 2001 01:05:12 -0500

I'm using Fvwm 2.4.0-3 (Debian package) and what I see is this.  When
iconified the titles are limited to the width of the icon.  When the
mouse moves into the title focus the title raises to the top and it
expands to the entire title (ok so far).  I have right click set to
"RaiseLower" and if the icron is on top of another window and I click
on the title to lower the icon below the app the title will flutter
between unfocused unexpanded, and focused expanded, but not lower
until I move the mouse outside of the title area.

I see this at work where I have a much less accelerated video card.  I
run debian both at home and at work, so I don't know why I don't see
the problem at home.

I don't know if this problem is worth mentioning, it just sounds like
there is some race condition in the focus, unfocus, raise, lower, of
icons.

-- 
		+---------------------------------+
		|      David Fries                |
		|      [email-masked]        |
		+---------------------------------+

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 28 Sep 2001 12:44:39 +0200

> until I move the mouse outside of the title area.

I can see that too.  Consider this layout:

        +-----------------+
        |                 |
        |                 |
      +---+               |
      |   |               |
      | I |    Window     |
    +-------+             |
    | L | R |             |
    +-------+             |
        |                 |
        |                 |
        +-----------------+

(I=Icon, L/R=Left/right half of expanded icon title)

  Mouse 3 i a RaiseLower

Sometimes, when clicking into the right half of the title, fvwm
goes into a loop of raising/lowering the icon title.  I'll try to
fix that.

> run debian both at home and at work, so I don't know why I don't see

The video card has nothing to do with it.

> there is some race condition in the focus, unfocus, raise, lower, of

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]