Subject: Notification: incoming/778

From: [email-masked]
Date: Fri, 14 Sep 2001 14:15:52 -0500

FVWM Bug Tracking notification

new message incoming/778

Message summary for PR#778
	From: [email-masked]
	Subject: FVWM Window Title
	Date: Fri, 14 Sep 2001 14:15:50 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Fri Sep 14 14:15:52 2001
From: [email-masked]
To: [email-masked]
Subject: FVWM Window Title
Date: Fri, 14 Sep 2001 14:15:50 -0500

Full_Name: Ilya Pizik
Version: 2.4.0
CVS_Date: 
OS: FreeBSD 4.4-STABLE
X_Server: XFree86-4.1.0
Submission from: (NULL) (212.192.230.96)

In fvwm-2.4.0 there is a problem when using Russian fonts;
If window title includes Russian letters (for example when watching web
pages in own russian language or somthing else) it doesn't properly
displayed
somthing like: "%/1 koi8-r NEWS: %/1 koi8-r September, 2001..."
Instead of: "NEWS: September, 2001..."
Where "NEWS" and "SEPTEMBER" are russian translations (rus variant) of this
words.
In fvwm-2.3.39 everything is OK.
Plaese check this error.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 14 Sep 2001 23:03:27 +0200

> Where "NEWS" and "SEPTEMBER" are russian translations (rus variant) of this

This probably means that fvwm wasn't compiled with nls support.
If you run configure again with

  $ ./configure --enable-multibyte

(yes, I know the name of the option is confusing) then your window
titles should display nicely.

> In fvwm-2.3.39 everything is OK.

Do you mean 2.3.30?

> Plaese check this error.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]