Subject: Notification: incoming/788

From: [email-masked]
Date: Thu, 27 Sep 2001 16:52:47 -0500

FVWM Bug Tracking notification

new message incoming/788

Message summary for PR#788
	From: [email-masked]
	Subject: Moving/resizing windows via alt-click
	Date: Thu, 27 Sep 2001 16:52:46 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Thu Sep 27 16:52:46 2001
From: [email-masked]
To: [email-masked]
Subject: Moving/resizing windows via alt-click
Date: Thu, 27 Sep 2001 16:52:46 -0500

Full_Name: Suzanne Britton
Version: 2.4.1
CVS_Date: 
OS: Redhat 6.2 / Linux 2.4.10
X_Server: XFree86 4.1.0
Submission from: (NULL) (216.58.96.66)

Here's a weird one for you. WindowMaker has a nifty feature of grabbing
the
mouse when a meta key is pressed, so you can click anywhere in a window
and then move/resize it. I've tried to duplicate this behavior in fvwm
with the following keybindings:

Mouse 1 A M Move
Mouse 3 A M Resize

They work...sometimes. The bindings seem to come and go sporadically, with
no apparent rhyme or reason. Opening and closing windows, changing
pages...
almost any action can result in the mouse-grab behavior disappearing
or returning. When it's gone, applications receive the mouse click as they
normally would.

I can still move/resize windows by alt-clicking on the root window, then
selecting a window. But that brings up another oddity. If I alt-lclick on
root, then release the key and mouse button, select and move a window--it
won't move across page boundaries. If I leave the alt key pressed down,
though, page switching works as usual (same thing when clicking on the
window directly, I have to leave alt down while dragging--but this seems
somehow more reasonable in that context).

I hope someone can figure out this mystery! :-)

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 28 Sep 2001 12:29:51 +0200

> I hope someone can figure out this mystery! :-)

Thanks for the detailed report.  Can you please send your fvwm
configuration file to the [email-masked] mailing list so
that I can take a look myself?  I suspect that some of the focus
related settings play a role in this.

(Please do not answer to me directly - I will not be able to read
the mail at home then).

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]