Subject: Notification: incoming/789

From: [email-masked]
Date: Thu, 27 Sep 2001 19:36:31 -0500

FVWM Bug Tracking notification

new message incoming/789

Message summary for PR#789
	From: [email-masked]
	Subject: ~/.fvwm2rc not the default
	Date: Thu, 27 Sep 2001 19:36:27 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Thu Sep 27 19:36:31 2001
From: [email-masked]
To: [email-masked]
Subject: ~/.fvwm2rc not the default
Date: Thu, 27 Sep 2001 19:36:27 -0500

Full_Name: Neil Zanella
Version: 2.4.2
CVS_Date: 
OS: linux 2.4.2
X_Server: XFree86 4.0 SVGA server
Submission from: (NULL) (129.128.207.226)

When I start fvwm2 from a nondecorated window and do not specify a file
name my $HOME/.fvwm2rc is not read. Instead, some other system.fvwm2rc
by redhat is used. The same applies to when I click restart from a menu.
If I say fvwm2 -f $HOME/.fvwm2rc though, the file is found and used, but
not upon restarting. According to the manual $HOME/.fvwm2rc should be
searched first.

Thanks,

Neil

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 28 Sep 2001 13:11:44 +0000

> by redhat is used.

Are you sure you start the correct fvwm2 executable?
There is no way a redhat config is used if you run a non-redhat fvwm2.

You may run "fvwm2 -version" and "strace fvwm2 2>&1 | grep open"
to get more information about a version and config files read.

> The same applies to when I click restart from a menu.
> not upon restarting.

If you have "Restart fvwm2" command in your menus, this is expected.
Just like the man page in 2.4.x versions says, replace all "Restart fvwm2"
in your fvwm2rc with simply "Restart", so you restart the same WM.

> According to the manual $HOME/.fvwm2rc should be searched first.

Well, $HOME/.fvwm/.fvwm2rc is searched first.
Other than that I can't explain why some system.fvwm2rc is used in your
case (which one, BTW?), you didn't supply enough information.

Regards,
Mikhael.