Subject: FScreen.c

From: Giuseppe Della Ricca <[email-masked]>
Date: Fri, 7 Sep 2001 09:39:23 +0200 (MET DST)

Hi !

I suggest the following change in FScreen.c (or something equivalent):

cvs diff -r 1.5 FScreen.c
Index: FScreen.c
===================================================================
RCS file: /home/cvs/fvwm/fvwm/libs/FScreen.c,v
retrieving revision 1.5
diff -r1.5 FScreen.c
319c319
<       screens = (XineramaScreenInfo *)safemalloc(sizeof(XineramaScreenInfo)*1);
---
>       screens_xi = (XineramaScreenInfo *)safemalloc(sizeof(XineramaScreenInfo)*1);

i.e. I've changed screens to screens_xi. Without it screens_xi = 0x0 and
fvwm2 crashes in screens_xi[0].screen_number = -1 (I don't have Xinearama).

cheers,
Giuseppe.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 9 Sep 2001 02:11:44 +0200

> cvs diff -r 1.5 FScreen.c

Thanks, I'll apply the fix as soon as possible.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]