Subject: Notification: incoming/771

From: [email-masked]
Date: Tue, 04 Sep 2001 07:29:17 -0500

FVWM Bug Tracking notification

new message incoming/771

Message summary for PR#771
	From: [email-masked]
	Subject: configure check for xpm version
	Date: Tue, 04 Sep 2001 07:29:16 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Tue Sep 04 07:29:17 2001
From: [email-masked]
To: [email-masked]
Subject: configure check for xpm version
Date: Tue, 04 Sep 2001 07:29:16 -0500

Full_Name: Richard Curnow
Version: 2.4.0
CVS_Date: 
OS: 
X_Server: MIT X11R6
Submission from: (NULL) (164.129.1.38)

When the check for Xpm version >=3.4g is done, I initially got a failure
even though I have 3.4k installed.
I am specifying both --with-xpm-includes and --with-xpm-library.
I tracked the problem down to the following.  In the gcc line used to do
this check, the order of the -L arguments needs changing, so that the
directory provided by --with-xpm-library overrides the directory where
libX11 etc are.  (i.e. in line 2481 of configure, the xpm_LIBS and X_LIBS
fields need swapping.  Then, if a newer version of xpm is installed in a
non-standard place, and it occludes an obsolete version in the X11
installation, it will be picked up correctly.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 5 Sep 2001 13:18:08 +0200

> installation, it will be picked up correctly.

Thanks.  I'll make the necessary change soon.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]