Subject: Patch for fvwm & modules man pages

From: "Dmitry Yu. Bolkhovityanov" <[email-masked]>
Date: Sat, 15 Sep 2001 21:39:43 +0700

Hi!

	Attached is a patch which a) adds a formal description of how fvwm
maintains module's configs; b) corrects man pages for individual modules.

Changelog entry: 
	* Add a formal description of how fvwm maintains module's configs
	* Change manpages of individual modules to refer to fvwm2(1) for
	  details about specifying configuration

	Previously many man pages contained a sentense like "During
initialization FvwmFoo reads the same config file as fvwm".  The
replacement template is

"On startup" | "During initialization" | "...." /*optional*/
\fBFvwmFoo\fP gets config info from \fBfvwm\fP's module configuration
database (see 
.IR fvwm2 (1),
section
.BR "MODULE COMMANDS" ).

Additionally, some manpages (e.g. FvwmScroll) included two references to
config file: first in "DESCRIPTION" and than in "INITIALIZATION".  In
such cases the one in "DESCRIPTION" is removed, since it is redundant.

BTW1: I changed only those manpages which included those wrong sentences,
but it is probably worth modifying other manpages too.

BTW2: FvwmSave manpage wasn't changed, since it is completely broken: most
text in it refers to "NoClutter" (?!?!?!). 

	_________________________________________
	  Dmitry Yu. Bolkhovityanov
	  [email-masked]
	  The Budker Institute of Nuclear Physics

Index: fvwm/fvwm2.1
===================================================================
RCS file: /home/cvs/fvwm/fvwm/fvwm/fvwm2.1,v
retrieving revision 1.400
diff -u -r1.400 fvwm2.1
--- fvwm/fvwm2.1	2001/09/05 16:39:56	1.400
+++ fvwm/fvwm2.1	2001/09/15 14:15:39
@@ -7179,6 +7179,28 @@
 
 .SS MODULE COMMANDS
 
+Fvwm maintains a database of module configuration lines in a form
+.EX
+.BI "*" "<ModuleName>" ": " "<Config-Resource>"
+.EE
+where
+.I "<ModuleName>"
+is either a real module name or an alias.
+
+This database is initially filled from config file (or from
+output of
+.B \-cmd
+config command), and can be later modified either by user (via 
+.BR FvwmCommand )
+or by modules.
+
+When modules are run, they read appropriate portion of database.
+(The concept of this database is similar to one used in X resource
+database).
+
+Commands for manipulating module configuration database are
+described below.
+
 .TP
 .BI "*" module_config_line
 Defines a module configuration.
Index: modules/FvwmAnimate/FvwmAnimate.1
===================================================================
RCS file: /home/cvs/fvwm/fvwm/modules/FvwmAnimate/FvwmAnimate.1,v
retrieving revision 1.13
diff -u -r1.13 FvwmAnimate.1
--- modules/FvwmAnimate/FvwmAnimate.1	2001/07/03 07:23:04	1.13
+++ modules/FvwmAnimate/FvwmAnimate.1	2001/09/15 14:15:48
@@ -51,8 +51,11 @@
 the \fBFvwmAnimate\fP module, you don't really have to know what any
 of the configuration commands are.  This section describes them anyway.
 
-\fBFvwmAnimate\fP reads the same \fI.fvwm2rc\fP file as \fBfvwm\fP
-reads when it starts up.
+\fBFvwmAnimate\fP gets config info from \fBfvwm\fP's module configuration
+database (see 
+.IR fvwm2 (1),
+section
+.BR "MODULE COMMANDS" ).
 In addition, \fBFvwmAnimate\fP reads the file $HOME/.FvwmAnimate,
 and accepts commands from fvwm and its modules as it runs.
 
Index: modules/FvwmBacker/FvwmBacker.1
===================================================================
RCS file: /home/cvs/fvwm/fvwm/modules/FvwmBacker/FvwmBacker.1,v
retrieving revision 1.9
diff -u -r1.9 FvwmBacker.1
--- modules/FvwmBacker/FvwmBacker.1	2001/08/25 14:45:19	1.9
+++ modules/FvwmBacker/FvwmBacker.1	2001/09/15 14:15:49
@@ -24,9 +24,12 @@
 for any purpose as long as the copyright is kept intact.
 
 .SH INITIALIZATION
-During initialization, \fIFvwmBacker\fP will scan the same
-configuration file that FVWM used during startup to find the options
-that pertain to it.  These options are discussed in a later section.
+During initialization, \fIFvwmBacker\fP gets config info from 
+\fBfvwm\fP's module configuration database (see 
+.IR fvwm2 (1),
+section
+.BR "MODULE COMMANDS" ).
+Available options are discussed in a later section.
 
 .SH INVOCATION
 FvwmBacker can be invoked by fvwm during initialization by inserting
Index: modules/FvwmDragWell/FvwmDragWell.1
===================================================================
RCS file: /home/cvs/fvwm/fvwm/modules/FvwmDragWell/FvwmDragWell.1,v
retrieving revision 1.6
diff -u -r1.6 FvwmDragWell.1
--- modules/FvwmDragWell/FvwmDragWell.1	2001/08/02 23:06:18	1.6
+++ modules/FvwmDragWell/FvwmDragWell.1	2001/09/15 14:15:51
@@ -15,9 +15,12 @@
 drops of type "text/uri-list".
 
 .SH INITIALIZATION
-During initialization, \fIFvwmDragWell\fP will search a configuration
-file which is the same file that fvwm used during initialization.  If
-the FvwmDragWell executable is linked to another name, i.e. ln -s
+During initialization, \fIFvwmDragWell\fP gets config info from
+\fBfvwm\fP's module configuration database (see 
+.IR fvwm2 (1),
+section
+.BR "MODULE COMMANDS" ).
+If the FvwmDragWell executable is linked to another name, i.e. ln -s
 FvwmDragWell OtherDragWell, then another module called OtherDragWell
 can be started, with a completely different configuration than
 FvwmDragWell, simply by changing the keyword FvwmDragWell to
Index: modules/FvwmEvent/FvwmEvent.1
===================================================================
RCS file: /home/cvs/fvwm/fvwm/modules/FvwmEvent/FvwmEvent.1,v
retrieving revision 1.14
diff -u -r1.14 FvwmEvent.1
--- modules/FvwmEvent/FvwmEvent.1	2001/07/03 07:23:06	1.14
+++ modules/FvwmEvent/FvwmEvent.1	2001/09/15 14:15:56
@@ -64,8 +64,12 @@
 .sp
 
 .SH CONFIGURATION OPTIONS
-\fIFvwmEvent\fP reads the same \fI.fvwm2rc\fP file as \fIfvwm\fP
-reads when it starts up, and looks for certain configuration options:
+\fIFvwmEvent\fP gets config info from \fBfvwm\fP's module configuration
+database (see 
+.IR fvwm2 (1),
+section
+.BR "MODULE COMMANDS" ),
+and looks for certain configuration options:
 
 .IP "*FvwmEvent: Cmd \fIcommand\fP"
 This determines the \fIfvwm\fP function that is to be called with the
Index: modules/FvwmGtk/FvwmGtk.1
===================================================================
RCS file: /home/cvs/fvwm/fvwm/modules/FvwmGtk/FvwmGtk.1,v
retrieving revision 1.16
diff -u -r1.16 FvwmGtk.1
--- modules/FvwmGtk/FvwmGtk.1	2001/07/03 07:23:06	1.16
+++ modules/FvwmGtk/FvwmGtk.1	2001/09/15 14:15:58
@@ -45,8 +45,13 @@
 This includes the labels and pixmaps to show; configuration of the appearance
 must be done through the GTK rc file mechanism.
 
-\fBFvwmGtk\fP reads the same configuration file as \fBfvwm\fP when it starts
-up. In addition, \fBFvwmGtk\fP accepts commands from fvwm and its modules as
+\fBFvwmGtk\fP gets config info from \fBfvwm\fP's module configuration
+database (see 
+.IR fvwm2 (1),
+section
+.BR "MODULE COMMANDS" )
+when it starts up.
+In addition, \fBFvwmGtk\fP accepts commands from fvwm and its modules as
 it runs.
 
 If the optional \fIname\fP is used to start FvwmGtk, \fIname\fP is used
Index: modules/FvwmIconBox/FvwmIconBox.1
===================================================================
RCS file: /home/cvs/fvwm/fvwm/modules/FvwmIconBox/FvwmIconBox.1,v
retrieving revision 1.12
diff -u -r1.12 FvwmIconBox.1
--- modules/FvwmIconBox/FvwmIconBox.1	2001/08/07 06:13:20	1.12
+++ modules/FvwmIconBox/FvwmIconBox.1	2001/09/15 14:16:00
@@ -14,9 +14,6 @@
 operations, like iconify and de-iconify, for each icon shown in the
 module via mouse and keyboard.
 
-FvwmIconBox reads the same .fvwm2rc file as fvwm reads when it starts up,
-and looks for lines similar to "*FvwmIconBox: Fore green".
-
 .SH COPYRIGHTS
 The FvwmIconBox program is original work of Nobutaka Suzuki.
 
@@ -27,9 +24,11 @@

 .SH INITIALIZATION
-During initialization, \fIFvwmIconBox\fP will eventually search a
-configuration file. The configuration file is the same file that fvwm
-used during initialization.
+During initialization, \fIFvwmIconBox\fP gets config info from \fBfvwm\fP's
+module configuration database (see 
+.IR fvwm2 (1),
+section
+.BR "MODULE COMMANDS" ).
 
 If the FvwmIconBox executable is linked to another name, i.e. ln -s
 FvwmIconBox MoreIconBox, then another module called MoreIconBox can be
Index: modules/FvwmIdent/FvwmIdent.1
===================================================================
RCS file: /home/cvs/fvwm/fvwm/modules/FvwmIdent/FvwmIdent.1,v
retrieving revision 1.8
diff -u -r1.8 FvwmIdent.1
--- modules/FvwmIdent/FvwmIdent.1	2001/07/03 07:23:06	1.8
+++ modules/FvwmIdent/FvwmIdent.1	2001/09/15 14:16:01
@@ -13,9 +13,6 @@
 After that, it pops up a window with information about the window
 which was selected.
 
-FvwmIdent reads the same .fvwmrc file as fvwm reads when it starts up,
-and looks for lines similar to "*FvwmIdent: Fore green".
-
 .SH COPYRIGHTS
 The FvwmIdent program, and the concept for
 interfacing this module to the Window Manager, are all original work
@@ -29,9 +26,12 @@

 .SH INITIALIZATION
-During initialization, \fIFvwmIdent\fP will eventually search a
-configuration file which describes the colors and font to use.
-The configuration file is the same file that fvwm used during initialization.
+During initialization, \fIFvwmIdent\fP gets config info from \fBfvwm\fP's
+module configuration database (see 
+.IR fvwm2 (1),
+section
+.BR "MODULE COMMANDS" )
+to determine which colors and font to use.
 
 If the FvwmIdent executable is linked to another name, ie ln -s
 FvwmIdent MoreIdentify, then another module called MoreIdentify can be
Index: modules/FvwmPager/FvwmPager.1
===================================================================
RCS file: /home/cvs/fvwm/fvwm/modules/FvwmPager/FvwmPager.1,v
retrieving revision 1.33
diff -u -r1.33 FvwmPager.1
--- modules/FvwmPager/FvwmPager.1	2001/08/07 11:34:31	1.33
+++ modules/FvwmPager/FvwmPager.1	2001/09/15 14:16:02
@@ -125,9 +125,11 @@

 .SH INITIALIZATION
-During initialization, \fIFvwmPager\fP will eventually search a
-configuration file which describes the time-outs and actions to take.
-The configuration file is the same file that fvwm used during initialization.
+During initialization, \fIFvwmPager\fP gets config info from \fBfvwm\fP's
+module configuration database (see 
+.IR fvwm2 (1),
+section
+.BR "MODULE COMMANDS" ).
 
 To use FvwmPager with several different configurations, you can
 invoke FvwmPager with an optional parameter, which it will use
@@ -154,9 +156,6 @@
 The invocation method was shown in the synopsis section
 
 .SH CONFIGURATION OPTIONS
-FvwmPager reads the same .fvwmrc file as fvwm reads when it starts up,
-and looks for certain configuration options:
-
 .IP "*FvwmPager: Geometry \fIgeometry\fP"
 Completely or partially specifies the pager windows location and
 geometry, in standard X11 notation.
Index: modules/FvwmScript/FvwmScript.1
===================================================================
RCS file: /home/cvs/fvwm/fvwm/modules/FvwmScript/FvwmScript.1,v
retrieving revision 1.22
diff -u -r1.22 FvwmScript.1
--- modules/FvwmScript/FvwmScript.1	2001/07/03 07:23:07	1.22
+++ modules/FvwmScript/FvwmScript.1	2001/09/15 14:16:04
@@ -47,7 +47,11 @@
 button or keystroke to invoke it later.
 
 .SH CONFIGURATION OPTIONS
-The following commands can be placed in the .fvwm2rc file. They are used
+The following commands can be used in config (see 
+.IR fvwm2 (1),
+section
+.B "MODULE COMMANDS"
+for details). They are used
 only if the corresponding script commands are not used in the script.
 
 .IP "*FvwmScript: DefaultFont \fIfont\fP"
Index: modules/FvwmScroll/FvwmScroll.1
===================================================================
RCS file: /home/cvs/fvwm/fvwm/modules/FvwmScroll/FvwmScroll.1,v
retrieving revision 1.8
diff -u -r1.8 FvwmScroll.1
--- modules/FvwmScroll/FvwmScroll.1	2001/07/03 07:23:07	1.8
+++ modules/FvwmScroll/FvwmScroll.1	2001/09/15 14:16:04
@@ -13,10 +13,6 @@
 After that, it adds scroll bars to the selected window, to reduce the
 total desktop space consumed by the window.
 
-
-FvwmScroll reads the same .fvwmrc file as fvwm reads when it starts up,
-and looks for lines similar to "*FvwmScroll: Back green".
-
 FvwmScroll should not be used with windows which move or resize
 themselves, nor should it be used with windows which set the
 WM_COLORMAP_WINDOWS property. Operation is fine with windows that have
@@ -35,9 +31,12 @@

 .SH INITIALIZATION
-During initialization, \fIFvwmScroll\fP will eventually search a 
-configuration file which describes the colors to use.
-The configuration file is the same file that fvwm used during initialization.
+During initialization, \fIFvwmScroll\fP gets config info from \fBfvwm\fP's
+module configuration database (see 
+.IR fvwm2 (1),
+section
+.BR "MODULE COMMANDS" )
+to determine which colors to use.
 
 If the FvwmScroll executable is linked to another name, ie ln -s
 FvwmScroll MoreScroll, then another module called MoreScroll can be
@@ -58,9 +57,6 @@
 want to.
 
 .SH CONFIGURATION OPTIONS
-FvwmScroll reads the same .fvwmrc file as fvwm reads when it starts up,
-and looks for lines as listed below:
-
 .IP "*FvwmScroll: Colorset \fIn\fP"
 Tells the module to use colorset \fIn\fP. See FvwmTheme.
 
Index: modules/FvwmWharf/FvwmWharf.1
===================================================================
RCS file: /home/cvs/fvwm/fvwm/modules/FvwmWharf/FvwmWharf.1,v
retrieving revision 1.12
diff -u -r1.12 FvwmWharf.1
--- modules/FvwmWharf/FvwmWharf.1	2001/07/03 07:23:08	1.12
+++ modules/FvwmWharf/FvwmWharf.1	2001/09/15 14:16:05
@@ -31,11 +31,13 @@

 .SH INITIALIZATION
-During initialization, \fIFvwmWharf\fP will search for a configuration
-file which describes the button panel geometry, color, icons, and
-actions. The format of
-this file will be described later. The configuration file will be the
-one which Fvwm used during its initialization.
+During initialization, \fIFvwmWharf\fP gets config info from \fBfvwm\fP's
+module configuration database (see 
+.IR fvwm2 (1),
+section
+.BR "MODULE COMMANDS" )
+to obtain a description of button panel geometry, color, icons, and
+actions.
 
 If the FvwmWharf executable is linked to another name, ie ln -s
 FvwmWharf Pier, then another module called Pier can be
@@ -48,8 +50,6 @@
 Fvwm modules.
 
 .SH CONFIGURATION OPTIONS
-The following options can be placed in the .steprc file
-
 .IP "*FvwmWharfAnimate"
 If specified, the opening and closing of Folders will be animated,
 rather than simply drawn in one frame.
Index: modules/FvwmWinList/FvwmWinList.1
===================================================================
RCS file: /home/cvs/fvwm/fvwm/modules/FvwmWinList/FvwmWinList.1,v
retrieving revision 1.23
diff -u -r1.23 FvwmWinList.1
--- modules/FvwmWinList/FvwmWinList.1	2001/08/07 06:13:20	1.23
+++ modules/FvwmWinList/FvwmWinList.1	2001/09/15 14:16:06
@@ -25,9 +25,12 @@
 as the copyright is kept intact.
 
 .SH INITIALIZATION
-During initialization, \fIFvwmWinList\fP will scan the same configuration file
-that FVWM used during startup to find the options that pertain to it.  These
-options are discussed in a later section.
+During initialization, \fIFvwmWinList\fP gets config info from \fBfvwm\fP's
+module configuration database (see 
+.IR fvwm2 (1),
+section
+.BR "MODULE COMMANDS" ).
+Available options are discussed in a later section.
 
 .SH INVOCATION
 FvwmWinList can be invoked by fvwm during initialization by inserting the
@@ -41,8 +44,6 @@
 of FVWM for it to be executed by FVWM.
 
 .SH CONFIGURATION OPTIONS
-The following options can be placed in the .fvwmrc file
-
 .IP "*FvwmWinList: Geometry \fI{+-}<X>{+-}<Y>\fP"
 Specifies the location and gravity of the FvwmWinList window.  At the current
 time, size is not supported and FvwmWinList will resize itself as buttons are

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 15 Sep 2001 23:52:22 +0200

> maintains module's configs; b) corrects man pages for individual modules.

Applied.

> but it is probably worth modifying other manpages too.

Feel free to make another patch.

> text in it refers to "NoClutter" (?!?!?!). 

NoClutter is an ancient fvwm1 module.  Since I never used fvwm1
myself I have no idea what it does.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "Dmitry Yu. Bolkhovityanov" <[email-masked]>
Date: Sun, 16 Sep 2001 13:16:33 +0700

> myself I have no idea what it does.

	Mmmm...  What I meant is that FvwmSave.1 is just *completely 
wrong*.  It isn't a man page for FvwmSave, *half of it is a man page for
"NoClutter"*.  Probably nobody uses FvwmSave, since nobody reported this
as a bug? ;-)

	BTW, I've just looked at fvwm-1.24 sources.  It already had no
"NoClutter" module, and FvwmSave.1 had already been broken (talking about
NoClutter).  The scenario of how this artefact had appeared is obvious
;-).

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 16 Sep 2001 14:31:54 +0200

> "NoClutter"*.  Probably nobody uses FvwmSave, since nobody reported this

Funny.  Perhaps the FvwmSave module should be removed completely.
>From the description of NoClutter I assume that its the forefather
of FvwmAuto.

Bye

Dominik ^_^  ^_^