Subject: Notification: incoming/770

From: [email-masked]
Date: Mon, 03 Sep 2001 21:57:58 -0500

FVWM Bug Tracking notification

new message incoming/770

Message summary for PR#770
	From: [email-masked]
	Subject: fast unmap/map causes window to be destroyed
	Date: Mon, 03 Sep 2001 21:57:57 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Mon Sep 03 21:57:57 2001
From: [email-masked]
To: [email-masked]
Subject: fast unmap/map causes window to be destroyed
Date: Mon, 03 Sep 2001 21:57:57 -0500

Full_Name: Björn Englund
Version: 2.4.0
CVS_Date: 
OS: solaris8
X_Server: openwindows
Submission from: (NULL) (129.16.30.81)

create and map a window (win)

then run the following loop
  
while(1) {
  XUnmapWindow(dpy, win);
  /* Wait for window to become unmapped */
  do {
    XNextEvent(dpy, &ev);
  } while(ev.type != UnmapNotify);

  XMapWindow(dpy, win);
  /* wait for the window to become mapped */
  do {
    XNextEvent(dpy, &ev);
  } while(ev.type != MapNotify);
}

the window will be destroyed after a few loops...
this does not happen with fvwm2.2

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 10 Sep 2001 22:33:35 +0200

> this does not happen with fvwm2.2

Fixed.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]