Subject: Re: CVS domivogt: * Fixed transient placement problem and introduced some new styles.

From: Olivier Chapuis <[email-masked]>
Date: Sat, 1 Sep 2001 07:39:56 +0200

On Fri, Aug 31, 2001 at 01:32:42PM -0500, FVWM CVS wrote:
> CVSROOT:	/home/cvs/fvwm
> Module name:	fvwm
> Changes by:	domivogt	01/08/31 13:32:42
> 
> Modified files:
> 	.              : ChangeLog NEWS 
> 	fvwm           : fvwm.h fvwm2.1 placement.c style.c style.h 
> 
> Log message:
> * Fixed transient placement problem and introduced some new styles.
>

I like the new position styles.

It seems that there is a problem if a program specify a user position
*and* a program position. In this case both positions hints are ignored
by fvwm2 if *only one* of the NoUSPosition or NoPPosition style is
set. In this case the position hints should be ignored only if
both styles are set. The same thing happen with the new transient
position style.

BTW, fvwm2 neither a module can known if a window has been placed by
fvwm2. Is there any objection for adding a new window special flags
is_placed_by_fvwm and a new condition PlacedByFvwm. This will allows
to perform
	All (PlacedByFvwm CurrentPage) PlaceAgain
and also a module (as FvwmNetHints) will be able to place again
a window (if it is mapped on the current page).

Regards, Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 1 Sep 2001 12:21:46 +0200

> both styles are set. The same thing happen with the new transient

Doh.  Which applications does this?

> a window (if it is mapped on the current page).

I have no objections.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 1 Sep 2001 12:45:21 +0200

> both styles are set. The same thing happen with the new transient

Fixed.

Bye

Dominik ^_^  ^_^

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 1 Sep 2001 14:38:45 +0200

> Doh.  Which applications does this?

A kde application of course: kppp and its transient.
Olivier

---

From: Olivier Chapuis <[email-masked]>
Date: Sun, 2 Sep 2001 17:59:55 +0200

> A kde application of course: kppp and its transient.

FvwmTaskBar do that too ...
Olivier