Subject: CVS domivogt: * Applied Xinerama patch for Maximize command but changed syntax to

From: FVWM CVS <[email-masked]>
Date: Sun, 19 Aug 2001 09:17:27 -0500

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	01/08/19 09:17:27

Modified files:
	.              : ChangeLog NEWS todo-xinerama 
	fvwm           : fvwm2.1 move_resize.c placement.c screen.h 
	                 update.c virtual.c 
	libs           : XineramaSupport.c XineramaSupport.h 
	modules/FvwmIconMan: x.c 
	modules/FvwmTaskBar: FvwmTaskBar.c 
	modules/FvwmWinList: FvwmWinList.c 

Log message:
* Applied Xinerama patch for Maximize command but changed syntax to
"Maximize Screen <screen-spec>".

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "Dmitry Yu. Bolkhovityanov" <[email-masked]>
Date: Mon, 20 Aug 2001 16:40:52 +0700

> "Maximize Screen <screen-spec>".

	fvwm.org seems to be offline, so the question: would it be
possible to maximize on the same screen where the window currently is?
I.e., if the window is completely on screen 2, and I'm issuing "Next
(WINNAME) Maximize" from FvwmCommand on screen 3 (i.e. "c"==3), the window
gets geometry 100%x100%+0+0@2?

	_________________________________________
	  Dmitry Yu. Bolkhovityanov
	  [email-masked]
	  The Budker Institute of Nuclear Physics

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 20 Aug 2001 11:15:28 +0200

> gets geometry 100%x100%+0+0@2?

Isn't that the default behaviour of your patch without "global"?
I only changed the syntax of the additional key words:

  Maximize global ...

becomes

  Maximize screen g ...

Im addition you can specify

  Maximize screen p ...
  Maximize screen c ...
  Maximize screen 0 ...
  Maximize screen 1 ...
  ...

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]