Subject: Core in Xinerma logic

From: Dan Espen <[email-masked]>
Date: Tue, 07 Aug 2001 11:42:04 -0400

This is from current CVS on Solaris:

fork> gdb /opt/public/src/fvwm/2.4.1-beta1/fvwm2 core
GNU gdb 4.18
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "sparc-sun-solaris2.5.1"...
Core was generated by `/opt/public/src/fvwm/2.4.1-beta1/fvwm2'.
Program terminated with signal 11, Segmentation Fault.
Reading symbols from /opt/public/lib/libXpm.so.4.10...done.
Reading symbols from /usr/lib/libSM.so.6...done.
Reading symbols from /usr/lib/libICE.so.6...done.
Reading symbols from /usr/lib/libXext.so.0...done.
Reading symbols from /usr/lib/libX11.so.4...done.
Reading symbols from /usr/lib/libsocket.so.1...done.
Reading symbols from /usr/lib/libnsl.so.1...done.
Reading symbols from /usr/lib/libm.so.1...done.
Reading symbols from /usr/lib/libc.so.1...done.
Reading symbols from /usr/lib/libdl.so.1...done.
Reading symbols from /usr/openwin/lib/libdga.so.1...done.
Reading symbols from /usr/lib/libmp.so.2...done.
Reading symbols from /usr/platform/SUNW,Ultra-5_10/lib/libc_psr.so.1...done.
#0  0xff0329ec in strlen () from /usr/lib/libc.so.1
(gdb) where
#0  0xff0329ec in strlen () from /usr/lib/libc.so.1
#1  0xff0812c0 in _doprnt () from /usr/lib/libc.so.1
#2  0xff082d68 in fprintf () from /usr/lib/libc.so.1
#3  0x6b010 in XineramaSupportParseGeometryWithScreen (
    parsestring=0x2f <Address 0x2f out of bounds>, x_return=0x8b458, 
    y_return=0x8b45c, width_return=0xffbece30, height_return=0xffbece2c, 
    screen_return=0xffbecd9c)
    at ../../version-2_4_1-beta1/libs/XineramaSupport.c:701
#4  0x6b050 in XineramaSupportParseGeometry (
    parsestring=0x87428 "1040x20+0-40", x_return=0x8b458, y_return=0x8b45c, 
    width_return=0xffbece30, height_return=0xffbece2c)
    at ../../version-2_4_1-beta1/libs/XineramaSupport.c:733
#5  0x316c8 in CMD_Style (eventp=0xffff8000, w=2415919103, tmp_win=0x6e400, 
    context=570368, action=0x974c0 "  IconGrid 80 80, IconFill r t", 
    Module=0x80000) at ../../version-2_4_1-beta1/fvwm/style.c:1600
#6  0x495e0 in execute_function (efa=0xffbecf88)
    at ../../version-2_4_1-beta1/fvwm/functions.c:1096
#7  0x4977c in old_execute_function (
    action=0xffbed020 "Style \"*\" IconBox -80 240 -1 -1, IconGrid 80 67,", ' ' <repeats 11 times>, "IconBox 1040x20+0-40,  IconGrid 80 80, IconFill r t", 
    tmp_win=0x0, eventp=0x87e08, context=8, Module=1, exec_flags=0 '\000', 
    args=0x0) at ../../version-2_4_1-beta1/fvwm/functions.c:1165
#8  0x2e998 in run_command_stream (f=0x88200, eventp=0x87e08, tmp_win=0x0, 
    context=8, Module=1) at ../../version-2_4_1-beta1/fvwm/read.c:146
#9  0x2eaf8 in run_command_file (filename=0x0, eventp=0x87e08, tmp_win=0x0, 
    context=8, Module=1) at ../../version-2_4_1-beta1/fvwm/read.c:220
#10 0x5df7c in main (argc=2, argv=0x88744)
    at ../../version-2_4_1-beta1/fvwm/fvwm.c:665
(gdb) 

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214             E-mail: [email-masked]
Piscataway, NJ 08854                       Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 8 Aug 2001 21:39:13 +0200

> This is from current CVS on Solaris:

Another NULL pointer in debug output.  Fixed.

>     at ../../version-2_4_1-beta1/libs/XineramaSupport.c:701

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]