Subject: Notification: incoming/769

From: [email-masked]
Date: Mon, 27 Aug 2001 02:43:05 -0500

FVWM Bug Tracking notification

new message incoming/769

Message summary for PR#769
	From: [email-masked]
	Subject: FvwmAuto SIGFPEs when iterations=0
	Date: Mon, 27 Aug 2001 02:43:04 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Mon Aug 27 02:43:05 2001
From: [email-masked]
To: [email-masked]
Subject: FvwmAuto SIGFPEs when iterations=0
Date: Mon, 27 Aug 2001 02:43:04 -0500

Full_Name: Dmitry Bolkhovityanov
Version: 2.4
CVS_Date: 
OS: Red Hat Linux 7.1
X_Server: XFree86 4.0.3
Submission from: (NULL) (140.221.9.192)

To reproduce:

1. Start FvwmAnimate
2. Run "FvwmForm FormFvwmAnimate"
3. In the form: set "Effect:" to "Lines", "Iterations:" to "0" and press
[F1-Apply]
4. Try to iconify/deiconify some window and voila -- FvwmAnimate is dead
with strace telling about SIGFPE.

Looks like a trivial division by zero due to lack of checking.  A value of
-1 doesn't cause any problems.

Also a value of "-1" for "LineWidth:" causes flickering effect -- seems to
be a line width of 65K.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Tue, 28 Aug 2001 13:45:45 -0400

> with strace telling about SIGFPE.

Fixed.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]