Subject: Re: What to do for next release?

From: "Dmitry Yu. Bolkhovityanov" <[email-masked]>
Date: Sat, 4 Aug 2001 20:36:27 +0700

BTW, would it be possible to make --enable-multibyte a default in 2.4.1?

    As I understand, most of the people are lucky with 8859-1, but that's
not the case for us, koi8-r'ers.  In most of the modern apps (Netscape is
most popular) russian titles are displayed as raw 2022 strings, i.e. the
titles are interweaved with "koi8-r" strings and 2022 escapes.  (Sure, my
students now better understand how i18n works in X, but I'd prefer them to
use their time for other work.)

    Is there something critical and untested in multibyte code?

       ___________________________________________________________________
       Dmitry Yu. Bolkhovityanov  |  Novosibirsk, RUSSIA
       phone (383-2)-39-49-56     |  The Budker Institute of Nuclear Physics
                                  |  Lab. 5-13
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 5 Aug 2001 11:19:25 +0200

>     Is there something critical and untested in multibyte code?

The whole multibyte support is basically untested :-)  I can't
remember the minute details, but there are several places where
internationalised strings are not yet handled.  Then there was
this font problem you reported a while ago.  Finally, it's
implemented using dozens of ifdefs all over the code.  This can
not be the final solution.  A library like implementation like the
Xinerama library is needed.  This includes a font/fontlist
management module that hides the details from the caller.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "Dmitry Yu. Bolkhovityanov" <[email-masked]>
Date: Wed, 8 Aug 2001 18:08:06 +0700

> management module that hides the details from the caller.

	Okay, this answers the question I haven't asked yet -- regarding
antialiased text.  The Xft library becomes very polular, and is already
used in Qt, Gtk and some other WMs.  I've skimmed through fvwm code, and
it has too close relations with X core fonts.  But if a dedicated library
is already planned for i18n, adding support for antialiased text will be
easy.

	_________________________________________
	  Dmitry Yu. Bolkhovityanov
	  [email-masked]
	  The Budker Institute of Nuclear Physics

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 8 Aug 2001 15:00:21 +0200

> is already planned for i18n, adding support for antialiased text will be

Planned is perhaps not the right term.  "Needed urgently" might be
a better one.  We don't have anyone here on the list who is
experienced in mb support *and* willing to do the work.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]