Subject: Notification: incoming/758

From: [email-masked]
Date: Sun, 12 Aug 2001 02:54:38 -0500

FVWM Bug Tracking notification

new message incoming/758

Message summary for PR#758
	From: [email-masked]
	Subject: Strange behaviour with XForms "sliderall" demo
	Date: Sun, 12 Aug 2001 02:54:37 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Sun Aug 12 02:54:38 2001
From: [email-masked]
To: [email-masked]
Subject: Strange behaviour with XForms "sliderall" demo
Date: Sun, 12 Aug 2001 02:54:37 -0500

Full_Name: Dmitry Bolkhovityanov
Version: 2.4
CVS_Date: 
OS: Red Hat Linux 7.1
X_Server: XFree86 4.0.3
Submission from: (NULL) (140.221.9.192)

How to reproduce: install
redhat-6.2/powertools/**/xforms{,-demos,-devel}-0.88-9, than run
/usr/lib/xforms/DEMOS/sliderall.
It creates an OverrideRedirect window (looking kinda TV onscreen menu). 
When cursor passes over this window, something strange happens to fvwm (the
cursor can be moved away from sliderall window). First sign is that it
stops reacting to hotkeys (like CSM-Arrows, Alt-Tab etc.).  And it shows a
previously focused window as focused, while the window itself realizes that
it had lost focus (xterm changes the cursor).  These lasts until focusing
another window.

While this seems to be something wrong with "sliderall" app, fvwm
definitely shouldn't show a non-focused window as focused, so there's
something with fvwm too.

P.S. I'm using fvwm with AnotherLevel as config (AnotherLevel-1.0.1-1 from
RedHat-6.2), with Lesstif style selected (Style * SloppyFocus).

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 13 Aug 2001 12:46:16 +0200

> it had lost focus (xterm changes the cursor).  These lasts until focusing

Is it possible to run this on a SuSE system?  Could you try to
isolate the necessary files from the RH system and send them to
me?

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "Dmitry Yu. Bolkhovityanov" <[email-masked]>
Date: Mon, 13 Aug 2001 18:08:44 +0700

> isolate the necessary files from the RH system and send them to

	As I understand, SuSE is rpm-based?  If true, it has to be able to
use RedHat's .rpms.  For case it isn't, I've put the necessary files to
http://ulpc08.gsi.de/~yakimenk/tmp/xforms.tar.bz2 (that's just the
contents of xforms{,-demos}.rpm).

	_________________________________________
	  Dmitry Yu. Bolkhovityanov
	  [email-masked]
	  The Budker Institute of Nuclear Physics