Subject: Notification: incoming/751

From: [email-masked]
Date: Wed, 01 Aug 2001 03:50:43 -0500

FVWM Bug Tracking notification

new message incoming/751

Message summary for PR#751
	From: [email-masked]
	Subject: FvwmIconBox dies on starting acroread/netscape
	Date: Wed, 01 Aug 2001 03:50:42 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Wed Aug 01 03:50:43 2001
From: [email-masked]
To: [email-masked]
Subject: FvwmIconBox dies on starting acroread/netscape
Date: Wed, 01 Aug 2001 03:50:42 -0500

Full_Name: Chris Drexler
Version: 2.3.31,2.3.33,2.4.0
CVS_Date: 
OS: SuSE Linux 7.2, Kernel 2.4.4 (4Gb enhanced)
X_Server: XFree 4.0.3
Submission from: (NULL) (131.188.35.226)

FvwmIconBox dies on starting either acroread or netscape (versions:
acroread 4.05, netscape 4.77). I couldn't find any other program causes the
the same result (up to now). 
Everything else works fine. 

The following error message is given in the log when FvwmIconBox dies:

FvwmIconBox: Cause of next X Error.
   Error: 2 (BadValue)
   Major opcode of failed request:  53 (CreatePixmap)
   Minor opcode of failed request:  0
   Resource id of failed request:  0x0
 Leaving a core dump now

Fvwm V2.3.31 comes from SuSE 7.2, the other two versions (2.3.33 and 2.4.0)
were compiled by myself. 

A drawback might be that the .fvwm2rc file has a long history and might
contain entries which causes the probelem. But I couldn't find anything in
the docs. 

The complete .fvwm2rc is attached at the end.

Thank you a lot for you efforts,

Best Regards,
Chris

------------------------- .fvwm2rc ------------------------------------

############################################################################
# Now the fonts - one for menus/icons, another for window titles
#Font           -adobe-helvetica-medium-r-*-*-*-120-*-*-*-*-*-*
WindowFont      -adobe-helvetica-bold-r-*-*-*-120-*-*-*-*-*-*
IconFont        -adobe-helvetica-medium-r-*-*-*-100-*-*-*-*-*-*
# PagerFont is used to mark windows in the Pager with their icon names.
# This is really only useful for DeskTopScale < 20 or so
#PagerFont      5x8

###########################################################################
# Set up the virtual desktop and pager
#set the desk top size in units of physical screen size
DeskTopSize 2x2

# be sure to customize these paths for your installation:
#ModulePath /usr/lib/X11/fvwm2
ImagePath /usr/include/X11/pixmaps
ImagePath /usr/include/X11/bitmaps

EdgeResistance 10000 100
EdgeScroll 0 0
ClickTime 750

#ColormapFocus FollowsMouse

MenuStyle black grey60 grey40
-adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-* fvwm

HilightColor black #c06077

# default Styles:
Style "*"           BorderWidth 7, HandleWidth 7
Style "*"           Color black/#60a0c0
Style "*"           MWMFunctions, MWMDecor, HintOverride, MWMButtons
Style "*"           DecorateTransient, NoPPosition, StickyIcon
#Style "*"           IconBox 1 -300 -280 -1
#Style "*"           IconBox -70 250 -1 -1
Style "*"           FocusFollowsMouse, SloppyFocus
Style "*"           SmartPlacement

# Styles for various Fvwm modules:
Style "Fvwm*"       NoTitle,  Sticky, WindowListSkip
Style "Fvwm*"       CirculateSkipIcon, CirculateSkip
Style "Fvwm*"       BorderWidth 4, HandleWidth 4
Style "FvwmPager"   WindowListSkip, NoHandles, Sticky, NoTitle
Style "FvmwPager"   DumbPlacement, StaysOnTop
Style "FvwmBanner"  StaysOnTop
Style "FvwmButtons" Icon toolbox.xpm, ClickToFocus, DumbPlacement
#Style "FvwmTaskBar" NoTitle,BorderWidth 4, HandleWidth
4,Sticky,StaysOnTop,WindowListSkip,CirculateSkip

# Styles for your common terminal emulator programs:
#Style "XTerm"       SloppyFocus

# Styles for various common programs:
Style "*lock"       NoTitle, NoHandles, Sticky, WindowListSkip,
ClickToFocus
Style "*lock"       BorderWidth 4, HandleWidth 4, Color Black/#60a0c0
Style "xload"       NoTitle, NoHandles, Sticky, WindowListSkip
Style "xload"       BorderWidth 4, HandleWidth 4, Color Black/#60a0c0
Style "xbiff"       NoTitle, NoHandles, Sticky, WindowListSkip
Style "xbiff"       BorderWidth 4, HandleWidth 4, Color Black/#60a0c0
Style "xcalc"       Icon xcalc.xpm, NoButton
2,RandomPlacement,ClickToFocus
Style "xmh"         Icon mail1.xpm, NoIconTitle,StickyIcon
Style "xmh"         RandomPlacement, NoButton 2
Style "xman"        Icon xman.xpm, RandomPlacement, ClickToFocus
Style "xmag"        Icon mag_glass.xpm, RandomPlacement, ClickToFocus
Style "xgraph"      Icon graphs.xpm, RandomPlacement, ClickToFocus
Style "xmosaic"     Color Green/Yellow, ClickToFocus
Style "tkirc"       Borderwidth 4, HandleWidth 4, NoTitle, Sticky
Style "xawtv"       Borderwidth 4, HandleWidth 4, NoTitle, Sticky

Style "gr_osview"   NoTitle, ClickToFocus,Borderwidth 4, HandleWidth 4,
Sticky
Style "gr_osview"   WindowListSkip

Style "XOsview"     NoTitle, ClickToFocus,Borderwidth 4, HandleWidth 4,
Sticky
Style "XOsview"     WindowListSkip
Style "xconsole"    NoTitle, ClickToFocus,Borderwidth 4, HandleWidth 4,
Sticky
Style "xconsole"    WindowListSkip
Style "XMcd"        NoTitle, ClickToFocus,Borderwidth 4, HandleWidth 4,
Sticky
Style "XMcd"        WindowListSkip

Style "*"           NoIcon
############################################################################
# Now some keyboard shortcuts.

Key F11          A       M       Prev [ CurrentPage !iconic ] Focus
Key F12         A       M       Next [ CurrentPage !iconic ] Focus

# some simple default mouse bindings:
#   for the root window:
Mouse 1 R       A       Menu RootMenu Nop
Mouse 2 R       A       Menu Window-Ops Nop
Mouse 3 R       A       WindowList

#   for the title bar buttons:
Mouse 0 1       A       Menu Window-Ops2 Close
#Mouse 0    2       A       Maximize-Func
Mouse 0 2       A       Maximize 100 100
Mouse 0 4       A       Iconify

#   for other parts of the window/borders/icons:
Mouse 1 F   A   Resize-or-Raise
Mouse 1 TS  A   Move-or-Raise
Mouse 1 I   A   Move-or-Iconify
Mouse 2 I   A   Iconify
Mouse 2 FST A   Menu Window-Ops2 Nop
Mouse 3 TSIF    A   RaiseLower

######################## Initialization Functions
############################
AddToFunc InitFunction  
+   "I" Exec /usr/bin/X11/xsetroot -solid steelblue
+   "I" Module FvwmButtons
+   "I" wait FvwmButtons
+   "I" Module FvwmIconBox
+   "I" NmWindows
#+  "I" Module FvwmAuto 200

AddToFunc RestartFunction 
+   "I" Module FvwmButtons
+   "I" Module FvwmIconBox
#+  "I" Module FvwmAuto 200

AddToFunc NmWindows
#                                              B   H  X   Y
#    LINKER OBERER Quadrant
#
+   "I" Exec xclock -digital -update 1 -font fixed -padding 2 -geometry 
154x17+210+0 
+   "I" Exec xterm -n "1-Fenster" -geometry 100x40+180+210
+   "I" Exec xterm -n "2-Fenster" -geometry 100x40+210+180
+   "I" Exec xterm -n "3-Fenster" -geometry 100x40+240+150 -iconic
+   "I" Exec xterm -n "4-Fenster" -geometry 100x40+270+120 -iconic
+       "I" Exec xterm -n "4a-Fenster" -geometry 56x6+125+550  -iconic
+       "I" Exec xterm -n "4b-Fenster" -geometry 56x6+125+655  -iconic
+   "I" Exec xterm -n "5-Fenster" -geometry 100x40+300+90  -iconic
+   "I" Exec xterm -n "6-Fenster" -geometry 100x40+330+60  -iconic
+   "I" Exec xterm -n "7-Fenster" -geometry 100x40+360+30 
+   "I" Exec xterm -n "8-Fenster" -geometry 100x40+390+0 
+       "I" Exec xterm -n "8a-Fenster" -geometry 84x6+485+550
+       "I" Exec xterm -n "8b-Fenster" -geometry 84x6+485+655

+
# RECHTER OBERER Quadrant
#
+       "I" Exec xterm -n "A-Fenster" -geometry  90x45+1479+251 -font 7x13

+       "I" Exec xterm -n "B-Fenster" -geometry  90x45+1538+216 -font 7x13
-iconic
+       "I" Exec xterm -n "C-Fenster" -geometry  90x45+1597+180 -font 7x13
-iconic
+       "I" Exec xterm -n "C1-Fenster" -geometry 85x6+1281+807 -font 7x13
+       "I" Exec xterm -n "C2-Fenster" -geometry 85x6+1281+915 -font 7x13
+       "I" Exec xterm -n "D-Fenster" -geometry  90x45+165
====> MESSAGE TRUNCATED AT 8192 <====

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 6 Aug 2001 02:26:14 +0200

> Thank you a lot for you efforts,

To the list:  Is that the same problem that was fixed a while ago?

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]