Subject: Re: Notification: incoming/750

From: Dominik Vogt <[email-masked]>
Date: Thu, 2 Aug 2001 21:24:27 +0200

On Mon, Jul 30, 2001 at 05:38:53AM -0500, fvwm-bug wrote:
> FVWM Bug Tracking notification
> 
> new message incoming/750
> 
> Message summary for PR#750
> 	From: [email-masked]
> 	Subject: FvwmButtons button update
> 	Date: Mon, 30 Jul 2001 05:38:52 -0500
> 	0 replies 	0 followups
> 
> Full_Name: Jacek Kopecky
> Version: 
> CVS_Date: 
> OS: 
> X_Server: 
> Submission from: (NULL) (194.213.203.154)
> 
> 
> Hi. In my FvwmButtons I have four buttons that display the led status.
> These buttons contain the titles "mse", "num", "cap" and "cze" and
> swallow xkbvleds windows. The problem is that when FvwmButtons start, 
> the titles are drawn in the vertical center, and when the swallowed
> windows appear, the title is repositioned without clearing the previous.
> 
> See http://www.inf.upol.cz/~kopeckyj/buttons.png to see what results. 
> Again xrefresh or any other means of forcing redraw result in proper
> clearing of the garbage.

Again, I have to ask for your FvwmButtons configuration.  I could not
find a way to reproduce this bug.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Jacek Kopecky <[email-masked]>
Date: Fri, 3 Aug 2001 09:35:57 +0200 (CEST)

Hi, this is the full config of my FvwmButtons. I think the Size
attribute on the third button should make your FvwmButtons
instance as big as mine, that is 108x416 pixels.

Hopefully the config doesn't get wrapped in some weird way. All
the following lines start with *FvwmButtons: .

*FvwmButtons: Fore Black
*FvwmButtons: Frame 1
*FvwmButtons: Back #ccac90
*FvwmButtons: Font -adobe-helvetica-bold-r-*-*-12-*-*-*-*-*-*-*
*FvwmButtons: Geometry +0+0
*FvwmButtons: Columns 12
*FvwmButtons: (4x4, Title main, Action "GotoDesk 0 0", Action (Mouse 2) "Function gostickdesk 0", Action (Mouse 3) "Function movedesk 0")
*FvwmButtons: (4x4, Title dev, Action "GotoDesk 0 1", Action (Mouse 2) "Function gostickdesk 1", Action (Mouse 3) "Function movedesk 1")
*FvwmButtons: (4x4, Size 32 22, Title info, Action "GotoDesk 0 2", Action (Mouse 2) "Function gostickdesk 2", Action (Mouse 3) "Function movedesk 2")
*FvwmButtons: (12x18, Swallow   "FvwmPager" "FvwmPager * *")
*FvwmButtons: (6x8, Frame 1, Swallow (UseOld, NoClose, Respawn) "xbiff" "Exec exec ssh -n mail /usr/X11R6/bin/xbiff -bg \\\\#ccac90 -fg red -update 1")
*FvwmButtons: (6x8, Frame 1, Padding 7 7, Swallow (UseOld, NoClose, Respawn) "LicqWharf" "Exec exec licq")
*FvwmButtons: (12x4, Frame 1, Title netscape, Action (Mouse 1) Function new-netscape, Action (Mouse 2) Function paste-netscape, Action (Mouse 3) Function focus-next-netscape)
*FvwmButtons: (12x14, Frame 1, Swallow (UseOld, NoClose, Respawn) "xclock" "exec exec xclock -padding 5 -bg rgb:cc/ac/90")
*FvwmButtons: (3x4, Frame 1, Title mse, Swallow (UseOld, NoClose, Respawn) "xleds mouse" "Exec exec /usr/X11R6/bin/xkbvleds -watch 32 -bg rgb:cc/ac/90 -xrm '*title: xleds mouse'")
*FvwmButtons: (3x4, Frame 1, Title num, Swallow (UseOld, NoClose, Respawn) "xleds num" "Exec exec /usr/X11R6/bin/xkbvleds -watch 2 -bg rgb:cc/ac/90 -xrm '*title: xleds num'")
*FvwmButtons: (3x4, Frame 1, Title cap, Swallow (UseOld, NoClose, Respawn) "xleds caps" "Exec exec /usr/X11R6/bin/xkbvleds -watch 1 -bg rgb:cc/ac/90 -xrm '*title: xleds caps'")
*FvwmButtons: (3x4, Frame 1, Title cze, Swallow (UseOld, NoClose, Respawn) "xleds cze" "Exec exec /usr/X11R6/bin/xkbvleds -watch 16 -bg rgb:cc/ac/90 -xrm '*title: xleds cze'")

In my .Xdefaults I have the additional lines that make xkbvleds as
big as you see on the .png file I linked before:

xkbvleds*LED.width: 25
xkbvleds*LED.height: 16
xkbvleds*offColor: rgb:cc/ac/90
xkbvleds*LED.bevel: 0
xkbvleds*LED.topColor: white
xkbvleds*LED.bottomColor: rgb:66/56/48
xkbvleds*xkbleds.vSpace: 0
xkbvleds*xkbleds.hSpace: 0

                            Jacek Kopecky

                            Idoox
                            http://www.idoox.com/

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 5 Aug 2001 12:09:27 +0200

> windows appear, the title is repositioned without clearing the previous.

Fixed.

Bye

Dominik ^_^  ^_^