Subject: Forcing focus

From: Dan Espen <[email-masked]>
Date: Fri, 03 Aug 2001 22:18:20 -0400

Mikhael Goikhman <[email-masked]> writes:
> [I had no email for 3 days so answering only now.]
> 
> On 03 Aug 2001 19:08:08 -0400, Sean Morgan wrote:
> > 
> > On Wed, Aug 01, 2001 at 09:37:29AM -0400, Dan Espen wrote:
> > > 
> > > I don't think so, I don't see anything in the "Next" logic that
> > > would make it wrap around.
> 
> This is not correct. Next and Prev are circular commands.

For some reason, now I can see the program logic quite clearly.
The man page isn't specific.

> > So does anyone know how do wrap around focus
> > switching without the window list?
> 
> This question was asked several times, so I will add it to FAQ.
> 
> "Next Focus" should normaly circulate around all matching windows.
> But if some window does not accept focus, it may break circulation,
> because "Next Focus" makes the problematic window current and tries to
> give it the focus, this fails and the previous window stays focused
> forever while you execute "Next Focus".
> 
> Receiving the focus may fail becuase either a program sets "Focus Policy"
> to "No input" or a user explicitely gives a window NeverFocus style.
> 
> There are 2 solutions to solve breaking circulation. The first is:
> 
>   Style * Lenience
> 
> This instructs all (or some) windows to accept focus regardless of what
> the program requests. The second solution is to find a problematic window
> and make it CirculateSkip, for example:
> 
>   Style XClock CirculateSkip
>   Style FvwmPager CirculateSkip, WindowListSkip

Isn't something in fvwm broken?

How about:

Next (AcceptsFocus) Focus
Next (*) Focus Force

Or just default to Lenience.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 5 Aug 2001 12:22:09 +0200

> Isn't something in fvwm broken?

I wouldn't call it broken.  It depends on what you want to do with
the window.  If you want to give the window the focus the windows
should be skipped, but not if the action is "Raise".

> Next (AcceptsFocus) Focus

Looks good.  I'll see what I can do.

> Next (*) Focus Force

I don't think this is necessary or even useful.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 6 Aug 2001 02:22:28 +0200

> Looks good.  I'll see what I can do.

Done.

Bye

Dominik ^_^  ^_^