Subject: Pegasus Mail

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 4 Aug 2001 13:31:56 +0000

Dmitry, you use Pegasus Mail. I don't know whether you noticed, but this
mailer is the only one (there is also /bin/mail) that does not support
threads. When you get dozens of emails daily, threads are essential.
Most mailers (I can list 20) support In-reply-to: header (used to
show threads), some also support References: header (this is used by mail
archives to add links to related messages, usually to all parents).

Take a look at http://www.hpc.uh.edu/fvwm/archive/0107/threads.html .
You always start a new thread although most of messages are Re: ones.

Is it an option to change your mailer to a more standard-compliant one?
I can suggest pine for DOS, but there are more (I didn't use any though).
I know it may be a pain. But it was your decision (a bad decision :) )
to use a non free software, patching a free program to set In-reply-to:
header in replies should not take more than an hour.

P.S. I remember pmail in 1993, a nice colorfull pseudographics text toy.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 5 Aug 2001 13:48:04 +0200

> You always start a new thread although most of messages are Re: ones.

Perhaps you should consider using mutt.  It can even identify the
correct thread without one of those headers (I guess it's using
the subject).  Although it's not perfect (such mails are always
shown as a reply to the first mail in the thread), at least you
get the mails sorted into threads:

   Jul-29  To fvwm-workers  What to do for next release?
   Jul-30  To fvwm-workers  |->
   Aug-02  To fvwm-workers  | `->
   Aug-04  To fvwm-workers  |   `->
   Aug-04  To fvwm-workers  `*>

The last line shows a reply without thread information (indicated
by the asterisk).

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "Michael Kirby" <[email-masked]>
Date: Sun, 5 Aug 2001 09:27:46 -0400

Open you fvwm folder, and choose sort by threads.

You can also ctrl-click on the subject header, and it will sort by threads.

Mike

> The last line shows a reply without thread information (indicated

---
[email-masked]
To obtain my PGP public key, mail "SEND PUB KEY" in the 
subject to "[email-masked]"
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 5 Aug 2001 13:34:39 +0000

> Perhaps you should consider using mutt.  It can even identify the

If you press 'h' in your mutt, you will see that I am using mutt.

> The last line shows a reply without thread information (indicated

I know that mutt guesses that a message belong to a thread by its subject
and adds it to the end of thread. But this does not help for comunication.
Consider a not very complex tree:

   1350 Jul-22 Dominik Vogt        (2.9K) Some subject
   1351 Jul-22 Mikhael Goikhman    (3.7K) |->
   1352 Jul-22 Dan Espen           (2.7K) | |->
   1353 Jul-22 Mikhael Goikhman    (1.3K) | | `->
   1354 Jul-22 Dominik Vogt        (6.7K) | `->
   1355 Jul-22 Dmitry Yu. Bolkhovi (7.5K) `*>
   1356 Jul-22 Dominik Vogt        (4.9K)   `->

There is no any chance to know whether 1355 is a reply to Dominik, Dan or
me (and if to me, to which message) if a mailer does not supply this info.

It is unfortunate that someone uses closed non-standard mailer, that
breaks a thread into 2 threads exponentially every time a message is sent.
I would just patch it and not whine. Now I can only suggest to switch.

Regards,
Mikhael.

---

From: "Michael Kirby" <[email-masked]>
Date: Sun, 5 Aug 2001 09:44:44 -0400

> P.S. I remember pmail in 1993, a nice colorfull pseudographics text toy.

As a member of the Pegasus Mail tech support team, I do take exception to that 
remark. 

Pegasus Mail is live & well, and works just fine.  You will find it supports In-reply-to 
headers.  It is considered the most RFC compliant mail-tool on the market.  Most of its 
problems have to do with non-compliant messages from outlook.  (basically forcing 
non-compliance so that other mail tools are not compatable). (And its free!!)

<Pause...While I go scan headers>

Eee Gads.  Dmitry.  You are using Pegasus Mail 3.50 for Dos???  Alas, that version is 
no longer supported.  The lastest version is 3.12c for windows.  Version 4.0 is due out 
within the next several weeks (that is the version I am using now).

You should seriously consider upgrading (www.pmail.com).  But, if DOS is the 
requirement 3.50 should work just fine for you.  I'll check to see if 3.50 supports reply-
to.

Mike

---
[email-masked]