Subject: --prefix include dir problem

From: "Nils Lohner" <[email-masked]>
Date: Wed, 29 Aug 2001 14:20:13 +0200

There's a slight includ edir problem in 2.4.0 I think.

/sup/build/fvwm-2.4.0 > ./configure --prefix=/sup
creating cache ./config.cache
...
checking for XpmReadFileToXpmImage in -lXpm... yes
checking for X11/xpm.h... no
...
  Have XPM support?                  no: Can't find required X11/xpm.h

Strange, because:
~ > ll /sup/include/X11/xpm.h 
-r--r--r--   1 lohner   TAG         16644 Aug  8 13:50 /sup/include/X11/xpm.h

I think it's logical that if I specify a --prefix=/sup that /sup/include
should be considered as an include directory.  lXpm is found in /sup/lib
so it would be reasonable to expect that the include files are in the
same dir structure.

The compilation does not contain a -I/sup/include which it would ned ot
compile properly with xpm support.

Regards,
Nils.

---

From: Tim Phipps <[email-masked]>
Date: Wed, 29 Aug 2001 13:41:56 +0100

>   Have XPM support?                  no: Can't find required X11/xpm.h

Does setting $CPPFLAGS to "-I/sup/include" help?

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 30 Aug 2001 09:32:34 +0000

> compile properly with xpm support.

This seems useful, but the questions are should -I/sup/include be added to
the end or to the beginning? Should autoconf do the work for us?
Are there other packages handling prefix this way, so I can take a look?

Regards,
Mikhael.