Subject: Notification: incoming/740

From: [email-masked]
Date: Fri, 13 Jul 2001 13:15:34 -0500

FVWM Bug Tracking notification

new message incoming/740

Message summary for PR#740
	From: [email-masked]
	Subject: fvwm-2.4.0 fails to build on Digital UNIX V4.0E
	Date: Fri, 13 Jul 2001 13:15:33 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Fri Jul 13 13:15:34 2001
From: [email-masked]
To: [email-masked]
Subject: fvwm-2.4.0 fails to build on Digital UNIX V4.0E
Date: Fri, 13 Jul 2001 13:15:33 -0500

Full_Name: Bernhard Simon
Version: 2.4.0
CVS_Date: N/A
OS: Digital UNIX V4.0E
X_Server: N/A
Submission from: (NULL) (128.130.36.4)

fvwm/module_interface.c fails to compile
cc -DHAVE_CONFIG_H ... -O -c module_interface.c
cc: Warning: module_interface.c, line 1646: # not in column 1 \
    is ignored, skipping to end of line. (ignoretokens)
  #define is_valid_first_alias_char(ch) (isalpha(ch))
--^
cc: Warning: module_interface.c, line 1647: # not in column 1 \
    is ignored, skipping to end of line. (ignoretokens)
  #define is_valid_alias_char(ch) (is_valid_first_alias_char(ch) \
--^
 :
cc -O -o fvwm2  ... -lfvwm -lXpm -lSM -lICE -lXext -lX11 -ldnet_stub -lm
ld:
Unresolved:
is_valid_first_alias_char
is_valid_alias_char

Same problem on ULTRIX V4.5
cc -DHAVE_CONFIG_H ... -O -Olimit 2000 -c module_interface.c
cfe: Warning: module_interface.c, line 1646: Unknown Control Statement
   #define is_valid_first_alias_char(ch) ...
 ---^
cfe: Warning: module_interface.c, line 1647: Unknown Control Statement
   #define is_valid_alias_char(ch) (is_valid_first_alias_char(ch) \
 ---^
cfe: Error: module_interface.c, line 1648: Syntax Error

Remark: There seems to be a problem with FvwmIconBox on Digital UNIX
V4.0E.
   FvwmIconBox disappears (process dies) when trying to deiconify (double
   click on an icon in the Box) a window. There is a similar report (Id
736).
   Note: On AIX 3.2.5 this works as expected.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 15 Jul 2001 00:51:57 +0000

> Same problem on ULTRIX V4.5

Fixed.

>    click on an icon in the Box) a window. There is a similar report (Id 736).

Do you get the same error message as in #736? I.e.:

FvwmIconBox: Cause of next X Error.
   Error: 2 (BadValue)
   Major opcode of failed request:  53 (CreatePixmap)
   Minor opcode of failed request:  0 
   Resource id of failed request:  0x0 
 Leaving a core dump now

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 16 Jul 2001 13:34:48 +0000

On 16 Jul 2001 08:51:27 +0200, Bernhard Simon wrote:
> Mikhael,
> sorry, FvwmIconBox only exits. I cannot find any core or error messages in
> /var/dt/Xerrors.
> 
> Do you have an idea what I can do next to help finding the problem?

I suppose you don't have limit coredumpsize 0. I can suggest to add debug
statements to FvwmIconBox and try to determine what causes it to exit.
Or you may hope that someone else can reproduce this problem and fix it.

Regards,
Mikhael.

---

From: Bernhard Simon <[email-masked]>
Date: Tue, 17 Jul 2001 11:38:27 +0200 (MET DST)

> Or you may hope that someone else can reproduce this problem and fix it.

Mikhael,
just to check if the problem is a compiler issue, I compiled fvwm
 - without optimization
 - with gcc (2.8.1)
But this did not change anything. Then I tried FvwmDebug and found the
following in its output (pointer to first icon in IconBox and double click):

Focus
         ID 1c00004
         frame ID 800080
         focus not by builtin 1
Error
         [FVWM][HandleModuleInput]: <<ERROR>> Module(2) \
         command is too big (7957688231770718215), limit is 1000

Destroy
         ID 1c00004
         frame ID 800080
         fvwm ptr 140127aa0

Maybe this is a first hint to locate the problem.
Thanks - Bernhard

---

From: Dan Espen <[email-masked]>
Date: Tue, 17 Jul 2001 14:21:45 -0400

Bernhard Simon <[email-masked]> writes:
> > > Mikhael,
> > > sorry, FvwmIconBox only exits. I cannot find any core or error messages
> > > in /var/dt/Xerrors.
> > > 

And a good hint it was.

I've committed a fix that should fix the problem.
Please let us know if this actually does fix the problem.

Thanks,
-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]