Subject: Notification: incoming/737

From: [email-masked]
Date: Mon, 09 Jul 2001 23:00:36 -0500

FVWM Bug Tracking notification

new message incoming/737

Message summary for PR#737
	From: [email-masked]
	Subject: system.fvwm2rc file
	Date: Mon, 09 Jul 2001 23:00:31 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Mon Jul 09 23:00:36 2001
From: [email-masked]
To: [email-masked]
Subject: system.fvwm2rc file
Date: Mon, 09 Jul 2001 23:00:31 -0500

Full_Name: Bill West
Version: 2.2.4
CVS_Date: 
OS: Debian Linux
X_Server: 
Submission from: (NULL) (204.87.151.2)

After adding a ~/.fvwm/menudefs.hook file to create a new popup menu,
the addition of the popup to the main main in ~/.fvwm/main-menu.hook
would not work.  This is because main-menu.hook (both system and user
versions) are expecting to have continuation lines for the last section
in /etc/X11/fvwm/system.fvwm2rc, which is an AddToMenu /Debian section.

Adding this line to system.fvwm2rc

AddToMenu /Debian

immediately before the line

Read /etc/X11/fvwm/main-menu.hook Quiet

corrects the problem.

Sorry this isn't more clear but the Web-based editor is kind of
limited.  I can send you the relevant files if you need them, but
this is a pretty simple bug.

Thanks for fvwm.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Thu, 19 Jul 2001 09:11:59 -0400

> this is a pretty simple bug.

The problems you are having must be coming from some Debian customizations.
There are no read commands in the system.fvwm2rc that comes with Fvwm.
Please report the problem to Debian.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]