Subject: Notification: incoming/743

From: [email-masked]
Date: Thu, 19 Jul 2001 03:24:16 -0500

FVWM Bug Tracking notification

new message incoming/743

Message summary for PR#743
	From: [email-masked]
	Subject: Shaded windows still receive keypresses
	Date: Thu, 19 Jul 2001 03:24:15 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Thu Jul 19 03:24:16 2001
From: [email-masked]
To: [email-masked]
Subject: Shaded windows still receive keypresses
Date: Thu, 19 Jul 2001 03:24:15 -0500

Full_Name: Dmitry Bolkhovityanov
Version: 2.4
CVS_Date: 
OS: Red Hat Linux 7.1
X_Server: XFree86 4.0.3
Submission from: (NULL) (140.221.9.192)

The subject says it all -- if one presses keys when a shaded window is
focused, that app receives key events.

Since shading is like iconifying (i.e. "minimizing" a space, occupied by a
window, to some "icon"), it is wise to prevent keys from going to shaded
windows.  Other WMs (at least AfterStep) do so.

(Frankly speaking, I've tried adding "if (!IS_SHADED(sf&Tmp_win))" before
XSendEvent()s in events.c:HandleKeyPress(), but, strangely, it changed
nothing.)

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 21 Jul 2001 19:36:30 +0200

> windows.  Other WMs (at least AfterStep) do so.

Yes, shading is like iconifying.  Fvwm treats shaded windows like
iconified ones:  they both get keyboard input.  This can come in
handy if you have to paste the same text into 20 windows.  This was
a very conscious choice we made (okay: I made).  Where exactly is
the problem?

> XSendEvent()s in events.c:HandleKeyPress(), but, strangely, it changed

Hm.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]