Subject: Re: Xinerama w/ EdgeResistance problem

From: "Dmitry Yu. Bolkhovityanov" <[email-masked]>
Date: Sun, 29 Jul 2001 14:07:20 +0700

On 28 Jul 01 at 18:00, [email-masked] wrote:

> There is a problem with Xinerama Edgeresistance and different
> screen sizes on the screens:
>
> Layout:
>
>     screen 1     screen 2
>   +----------+------------+
>   |          |+------+    |
>   |          ||      |    |
>   |          ||window|    |
>   |          ||      |    |
>   +----------+|      |    |
>              |+------+    |
>              |            |
>              +------------+
>
> When you move a window that is taller than screen 1 along the top
> edge of screen 2 and finally move it against or over the border
> between the screens it will then snap to the bottom border of
> screen 1:
>
>          +------+
>   +------|      |---------+
>   |      |      |         |
>   |      |      |         |
>   |      |      |         |
>   |      +------+         |
>   +----------+            |
>              |            |
>              |            |
>              +------------+
>
> This can be very confusing, especially if the pointer is still on
> the second screen.  One way to handle this may be to snap only to
> the screen that contains the pointer (?)

    There's no such thing as "the decision" for this problem.  Some people
will prefer current behaviour, while some -- current-pointer-screen-based one
you suggest.  IMHO the current bahaviour can be left as is to watch feedback
after 2.4.1 release.

    EdgeResistance is a non-trivial concept on itself (remember what happens
to windows with e.g. width>screen_width && width<screen_width+edge_moving),
and when combined with even more non-trivial concept of Xinerama, it can
really confuse people (they wouldn't know themselves what they want fvwm to
do).

       ___________________________________________________________________
       Dmitry Yu. Bolkhovityanov  |  Novosibirsk, RUSSIA
       phone (383-2)-39-49-56     |  The Budker Institute of Nuclear Physics
                                  |  Lab. 5-13
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 29 Jul 2001 15:42:36 +0200

> really confuse people (they wouldn't know themselves what they want fvwm to

I think it's easy to describe what the average user wants:  When
(s)he move the window to the left (s)he expects that the left edge
of the window will be aligned with the left edge of the screen
respectively the right edge of other windows.  It would also be
desirable that a previous alignment with the top/bottom edges is
not broken while moving to the left.  But (s)he would definitely
not expect to align window on the right side.  The same applies to
all other directions, of course.

The problem is that fvwm usually can't guess in which direction
the user wants to move a window and mouse input is way too
unreliable.

At present I am using big values for SnapAttraction (20),
SnapGrid (8 8) and EdgeResistance (128) for a screen with quite a
few windows and it often causes trouble.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]