Subject: Notification: incoming/749

From: [email-masked]
Date: Sun, 29 Jul 2001 08:20:47 -0500

FVWM Bug Tracking notification

new message incoming/749

Message summary for PR#749
	From: [email-masked]
	Subject: toggled button style not updated
	Date: Sun, 29 Jul 2001 08:20:46 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Sun Jul 29 08:20:47 2001
From: [email-masked]
To: [email-masked]
Subject: toggled button style not updated
Date: Sun, 29 Jul 2001 08:20:46 -0500

Full_Name: Jacek Kopecky
Version: 2.4.0
CVS_Date: 
OS: 
X_Server: 
Submission from: (NULL) (194.213.203.154)

I have a button for (un)sticking a window that 
changes looks different in the toggled state. 
It works like a charm when I use this button 
to stick the window but the button doesn't get
updated when I use different means to (un)stick
the window. The button only gets updated when 
something forces it to redraw, like xrefresh does.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 30 Jul 2001 11:41:11 +0200

> something forces it to redraw, like xrefresh does.

Can you please provide the definition of the ButtonStyle?

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Jacek Kopecky <[email-masked]>
Date: Mon, 30 Jul 2001 12:18:40 +0200 (CEST)

Here is the definition of my default decor (I removed all IMHO
irrelevant stuff):

AddToDecor default \
  ButtonStyle All \
        ActiveUp   (VGradient 20 #ffdfc3 #ccac90) \
        ActiveDown (VGradient 20 red     #ccac90) \
        Inactive   (VGradient 20 #ffdfc3 #ccac90) \
 ToggledActiveUp   (VGradient 20 #ffdfc3 #ccac90) \
 ToggledActiveDown (VGradient 20 red     #ccac90) \
 ToggledInactive   (VGradient 20 #ffdfc3 #ccac90)
+    ButtonStyle All -- flat
+ AddButtonStyle 1 miniIcon
+    ButtonStyle 1 - MwmDecorMenu
+ AddButtonStyle 3 vector 5 20x20@0 20x30@1 80x30@0 \
		80x20@0 20x20@1
+ AddButtonStyle 3 \
        ActiveUp   (vector 8 50x30@1 30x50@1 45x50@0 \
		45x70@1 55x70@1 55x50@0 70x50@0 50x30@0) \
        ActiveDown (vector 8 50x30@1 30x50@1 45x50@0 \
		45x70@1 55x70@1 55x50@0 70x50@0 50x30@0) \
        Inactive   (vector 8 50x30@1 30x50@1 45x50@0 \
		45x70@1 55x70@1 55x50@0 70x50@0 50x30@0) \
 ToggledActiveUp   (vector 7 55x30@0 55x50@1 70x50@0 \
		50x70@1 30x50@0 45x50@0 45x30@0) \
 ToggledActiveDown (vector 7 55x30@0 55x50@1 70x50@0 \
		50x70@1 30x50@0 45x50@0 45x30@0) \
 ToggledInactive   (vector 7 55x30@0 55x50@1 70x50@0 \
		50x70@1 30x50@0 45x50@0 45x30@0)
+    ButtonStyle 3 - MwmDecorShade
+ AddButtonStyle 5 \
        ActiveUp   (vector 4 20x20@0 50x70@1 80x20@0 20x20@1) \
        ActiveDown (vector 4 20x20@0 50x70@1 80x20@0 20x20@1) \
        Inactive   (vector 4 20x20@0 50x70@1 80x20@0 20x20@1) \
 ToggledActiveUp   (vector 4 20x70@0 50x20@0 80x70@1 20x70@1) \
 ToggledActiveDown (vector 4 20x70@0 50x20@0 80x70@1 20x70@1) \
 ToggledInactive   (vector 4 20x70@0 50x20@0 80x70@1 20x70@1)
+    ButtonStyle 5 - MwmDecorStick

+ AddButtonStyle 6 vector 5 45x45@0 45x55@1 55x55@0 55x45@0 45x45@1
+    ButtonStyle 6 - MwmDecorMin
+ AddButtonStyle 4 vector 5 20x20@0 20x80@1 80x80@0 80x20@0 20x20@1
+    ButtonStyle 4 - MwmDecorMax
+ AddButtonStyle 2 vector 13 35x50@0 20x65@1 35x80@1 \
                             50x65@0 65x80@1 80x65@0 \
                             65x50@0 80x35@0 65x20@0 \
                             50x35@1 35x20@0 20x35@1 35x50@1
+    ButtonStyle 2 - Clear
+ BorderStyle -- hiddenHandles noinset

and the binding for the problematic button number 5 is

Mouse 1 5 A Stick

If I use mouse to stick the window, the button updates itself to
the upward triangle (from the default downward one), if I use
other means of sticking the window the triangle stays downward
until it's forced to redraw (e.g. xrefresh).

                            Jacek Kopecky

                            Idoox
                            http://www.idoox.com/

---

From: Jacek Kopecky <[email-masked]>
Date: Mon, 30 Jul 2001 12:18:40 +0200 (CEST)

AddToDecor default \
  ButtonStyle All \

Mouse 1 5 A Stick

                            Jacek Kopecky

                            Idoox
                            http://www.idoox.com/

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 30 Jul 2001 13:23:44 +0200

On Mon, Jul 30, 2001 at 12:18:40PM +0200, Jacek Kopecky wrote:
>...

Thanks for your help.  The bug is fixed in the development
version.  The fix will be released with 2.4.1.

Bye

Dominik ^_^  ^_^