Subject: Notification: incoming/735

From: [email-masked]
Date: Sat, 07 Jul 2001 18:37:09 -0500

FVWM Bug Tracking notification

new message incoming/735

Message summary for PR#735
	From: [email-masked]
	Subject: Problem setting font for default Style
	Date: Sat, 07 Jul 2001 18:36:59 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Sat Jul 07 18:37:09 2001
From: [email-masked]
To: [email-masked]
Subject: Problem setting font for default Style
Date: Sat, 07 Jul 2001 18:36:59 -0500

Full_Name: Beiad Ian Q. Dalton
Version: 2.4.0
CVS_Date: 
OS: Debian Sid
X_Server: Xfree86 4.0.3
Submission from: (NULL) (65.5.95.44)

Okay. I'm trying to use a scalable font in the window title, by defining
it
with the Style command in the config. I'm okay to use a 100 DPI font such
as "-adobe-helvetica-medium-r-*-*-20-*" but I am not okay to use a font
such as "-urw-urw bookman l-regular-r-normal-*-20-*-*-*-*-*-*-*" which is
a
scalable font. However, I'm able to use this font for my menus with the
MenuStyle command in my config.

If I type into FvwmConsole the Style command, I am told:
[FVWM][CMD_Style]:
<<ERROR>> Bad style option: "<font string here>"
If I type into FvwmConsole a similar MenuStyle command with the same font
string, it is accepted and used.

Also, and this may be an X server issue instead, if I attempt to use a
19-point helvetica instead of 20-point, it will fall back to the 'fixed'
font, even though (as far as I can tell) I have a scalable version of
helvetica installed. If I specify 19-point urw bookman l, I get 19 point.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Lorenz Minder <[email-masked]>
Date: Sun, 8 Jul 2001 13:40:03 +0200

Hello.

The font name contains spaces, therefore you have to quote it, like this:

Style * Font "-urw-urw bookman l-regular-r-normal-*-20-*-*-*-*-*-*-*"

Greetings,
--Lorenz