Subject: CVS domivogt: * First version of Xinerama support.

From: FVWM CVS <[email-masked]>
Date: Sat, 21 Jul 2001 14:29:27 -0500

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	01/07/21 14:29:27

Modified files:
	.              : ChangeLog NEWS configure.in 
	fvwm           : Makefile.am builtins.c functions.c functions.h 
	                 fvwm.c fvwm2.1 menus.c move_resize.c 
	                 move_resize.h screen.h virtual.c virtual.h 
	libs           : Makefile.am defaults.h 
	modules/FvwmForm: FvwmForm.c Makefile.am 
	tests/menus    : menus.read 

Log message:
* First version of Xinerama support.
* Reformatted man page suorce to improve readability.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 22 Jul 2001 01:48:00 +0000

> * First version of Xinerama support.

I don't think that HAS_XINERAMA is ever defined (because XINERAMA_CPPFLAGS
is nowhere used) and thus parts of the xinerama code are ever compiled in,
although it is reported as such.

It is also buggy. Windows get Y coordinate -99999, i.e. disappear, when
trying to move them...

I don't have any real hardware xinerama setup, but X supports it.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 22 Jul 2001 09:29:00 +0200

> although it is reported as such.

I don't know.  At least for my Xinerama setup it works: the
Xinerama code is compiled in.  The code in configure.in sure looks
different.  Shouldn't this HAS_XINERAMA macro end up in config.h?
Perhaps this would be a good practice for me to learn writing
configure code.

> It is also buggy. Windows get Y coordinate -99999, i.e. disappear, when

I don't have this problem.  Was Xinerama support compiled in?
Can you have a look what's happening?

> I don't have any real hardware xinerama setup, but X supports it.

I will add some code to simulate Xinerama on a single screen.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 22 Jul 2001 16:49:43 +0000

> Perhaps this would be a good practice for me to learn writing

Do you say you ever got "Xinerama" in "fvwm -version"? I don't think so.

You almost fixed it on the second commit, but did a typo
s/XINERAMA/HAVE_XINERAMA/. Also building of libfvwm.a failed, because
-lXinerama was not passed to it.

Now it should work.

> Can you have a look what's happening?

Yes, Xinerama support is on after "configure; make install".
I have a single screen.

When a window is dragged (mouse moved) or a window is shaded, it gets
Y coordinate -99999.

When printing xl and yt in moveLoop() before loop or even on MotionNotify
they seem ok, although I don't understand their exact meaning yet. But on
ButtonRelease yt becomes -99999.

The window disappear when mouse is moved, not only when mouse is released.
In addition, the feedback window is not visible.

> I will add some code to simulate Xinerama on a single screen.

Ok, I may try it later, but for now I have problems without simulating
black holes on a single screen.

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 22 Jul 2001 18:18:57 +0000

> Yes, Xinerama support is on after "configure; make install".

The same problem happens with "configure --disable-xinerama".

BTW, I can't reproduce the problem with WindowShade now.
Only interactive Move is problematic.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 22 Jul 2001 23:36:38 +0200

> Only interactive Move is problematic.

Somehow, several dozens lines of old or trash code had slipped
into DoSnapAttraction() in move_resize.c.  I have removed this
code and it works for me again.  The problem only showed up if you
did not use SnapGrid.

Bye

Dominik ^_^  ^_^