Subject: Re: Solaris Xinerama

From: "Dmitry Yu. Bolkhovityanov" <[email-masked]>
Date: Wed, 25 Jul 2001 21:24:15 +0700

On 25 Jul 01 at 10:06, [email-masked] wrote:

> Based on the man page, Solaris 8's Xserver supports Xinerama.
> There is no libXinerama so the configure test fails.
> There is also no header in X11/extensions.

    Can you compile fvwm w/Xinerama under XFree86 and run it with -display
to Solaris' X?  Or simply do xdpyinfo on Solaris box and look if XINERAMA is
present in the list of extensions.

    Sun had a habit of shipping various libraries and utilities in separate
optional packages, so...  Anyway,

    find / | egrep -i 'xinerama|panoramix'

will be a good source of information ("Panoramix" is Xinerama's old name).

> I don't know if there is some other way to detect Xinerama.
> I didn't see anything obvious in libs/XineramaSupport.c.

    No, AFAIK, what is currently used is the only way (well, how can we
support Xinerama w/o libXinerama)?

    BTW, official X.org's R6.5.1 (or whatever is current) is a good place to
look at, I'll do it.

       ___________________________________________________________________
       Dmitry Yu. Bolkhovityanov  |  Novosibirsk, RUSSIA
       phone (383-2)-39-49-56     |  The Budker Institute of Nuclear Physics
                                  |  Lab. 5-13
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 25 Jul 2001 11:04:43 -0400

"Dmitry Yu. Bolkhovityanov" <[email-masked]> writes:
> to Solaris' X?

Not right now.

> Or simply do xdpyinfo on Solaris box and look if XINERAMA is

That I can do:

name of display:    :0.0
version number:    11.0
vendor string:    Sun Microsystems, Inc.
vendor release number:    6410
maximum request size:  262140 bytes
motion buffer size:  256
bitmap unit, bit order, padding:    32, MSBFirst, 32
image byte order:    MSBFirst
number of supported pixmap formats:    4
supported pixmap formats:
    depth 1, bits_per_pixel 1, scanline_pad 32
    depth 8, bits_per_pixel 8, scanline_pad 32
    depth 16, bits_per_pixel 16, scanline_pad 32
    depth 24, bits_per_pixel 32, scanline_pad 32
keycode range:    minimum 8, maximum 132
focus:  window 0x1400001, revert to Parent
number of extensions:    28
    AccessX
    Adobe-DPS-Extension
    DOUBLE-BUFFER
    DPMS
    DPSExtension
    Extended-Visual-Information
    FBPM
    LBX
    MIT-SCREEN-SAVER
    MIT-SHM
    MIT-SUNDRY-NONSTANDARD
    Multi-Buffering
    RECORD
    SECURITY
    SHAPE
    SUN_ALLPLANES
    SUN_DGA
    SUN_OVL
    SUN_SME
    SYNC
    SolarisIA
    TOG-CUP
    XC-APPGROUP
    XC-MISC
    XIE
    XInputDeviceEvents
    XInputExtension
    XTEST

Odd that it doesn't list Xinerama.
The Xsun man page says I should do "xinit +xinerama" to get Xinerama
support.  Perhaps the extension only shows when you do that.

I'm not at work so I can't do that right now.

> will be a good source of information ("Panoramix" is Xinerama's old name).

A find like that would run for months on our file systems,
even if I pruned out the 11 .snapshot subdirectories from our
NetApp filers.

Running it against /usr/openwin turns up nothing.

> support Xinerama w/o libXinerama)?

I did find this:

http://mail.gnome.org/archives/gtk-devel-list/2001-June/msg00279.html

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Danek Duvall <[email-masked]>
Date: Wed, 25 Jul 2001 08:21:27 -0700

> A find like that would run for months on our file systems,

For installed Solaris packages (assuming you haven't messed with the
installation), you can run that grep on /var/sadm/install/contents.  I find
that to be incredibly useful.

Nothing turns up in the filesystem, but

/usr/openwin/bin% nm Xsun | grep -i xinerama
[5176]  |    702552|      60|FUNC |GLOB |0    |9      |ForceXineramaApiImport
[1661]  |    934356|     384|FUNC |LOCL |0    |9      |ProcXineramaGetInfo
[1535]  |    887704|     384|FUNC |LOCL |0    |9      |ProcXineramaInfo
[4029]  |    935088|    1648|FUNC |GLOB |0    |9      |XineramaGetImageData
[4787]  |    973208|     128|FUNC |GLOB |0    |9      |XineramaGetScreenList
[5303]  |    973336|      44|FUNC |GLOB |0    |9      |XineramaGetXIDList
[3102]  |    973160|      48|FUNC |GLOB |0    |9      |isXineramaScreen
[1684]  |         0|       0|FILE |LOCL |0    |ABS    |xinerama_api.c

/usr/openwin/lib% nm -A *.so | grep -i xinerama
libXext.so: [428]       |     80156|     404|FUNC |GLOB |0    |10     |XGetXineramaInfo
libXext.so: [383]       |     80576|     704|FUNC |GLOB |0    |10     |XineramaGetCenterHint
libXext.so: [277]       |     79688|     468|FUNC |GLOB |0    |10     |XineramaGetInfo
libXext.so: [395]       |     79616|      72|FUNC |GLOB |0    |10     |XineramaGetState
libdga.so: [256]        |     29548|     380|FUNC |GLOB |0    |10     |XDgaGetXineramaInfo

Doesn't look like there are any mentions of it in any header files, though,
so you'd have to provide the declarations yourself.

HTH,
Danek