Subject: Notification: incoming/731

From: [email-masked]
Date: Wed, 04 Jul 2001 03:34:11 -0500

FVWM Bug Tracking notification

new message incoming/731

Message summary for PR#731
	From: [email-masked]
	Subject: Reproducible
	Date: Wed, 04 Jul 2001 03:34:05 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Wed Jul 04 03:34:11 2001
From: [email-masked]
To: [email-masked]
Subject: Reproducible 
Date: Wed, 04 Jul 2001 03:34:05 -0500

Full_Name: Marc-Jano Knopp
Version: 2.3.33
CVS_Date: 
OS: GNU/Linux 2.4.5
X_Server: XFree86 4.0.2
Submission from: (NULL) (195.252.197.77)

Yo!

Just as wanted to write this bug report, you released
2.4.0. That's not fair!! ;-)

I'm writing this anyway, since the 'Latest News' link on
the FVWM page doesn't say that this bug has been fixed.

Do the following:

- Setup your fvwm so that it has a pager
- the pager must be sticky
- the pager should have 4 or 9 pages (probably any number >= 2
  will do)
- On the first page (I'll call it page 0), start an xterm (or
  probably just any program)
- Now click on page 1 (the one to the right of page 0) in the
  pager and - Tadaaaa! The xterm vanishes in the pager!
  Instead, you see a very tiny (3x3 pixels) object in the upper
  left corner of page 1 in the pager. If you have configured
  'bubble help', moving the mouse over this object will reveal
  its name: xterm
- Click on any other page on the pager, and everything seems
  fine again.
- Now go to page 0 again, and open another xterm. To be sure,
  make the new xterm overlap the old xterm.
- Go to page 1 and - Tadaaa! Now the _new_ xterm will vanish!
  In fact, the topmost window of page 0 will vanish.

This bug also occurs with the following files removed
from my ~/.fvwm:
- decorations
- desktop
- iconstyles
- modules
- startup
- styles

Happy fixing! :-)

  Marc-Jano

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 5 Jul 2001 10:33:58 +0200

>   In fact, the topmost window of page 0 will vanish.

Works fine for me.  Please post detailed instructions (fvwm
commands) along with a minimal config file to reproduce the
problem.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Marc-Jano Knopp <[email-masked]>
Date: Thu, 5 Jul 2001 20:45:15 +0200

> On Wed, Jul 04, 2001 at 03:34:11AM -0500, fvwm-bug wrote:
[...]
> > 	Date: Wed, 04 Jul 2001 03:34:05 -0500
[...]
> > Version: 2.3.33

Also reproducible in 2.4.0 btw.

> > X_Server: XFree86 4.0.2

[windows on page 0 vanish from pager when selecting page 1 in pager]

> commands) along with a minimal config file to reproduce the

Okay, I attached a reduced version of my ~/.fvwm as a tar.bz2,
which extracts into the directory .fvwm.bug.

  cd
  mv .fvwm .fvwm-$(date)	# backup your original .fvwm
  cp -a .fvwm.bug .fvwm
  startx	       		# start X11
  
  - click with mouse 1 on the root window, and select 'Modules | Pager'
  - click with mouse 2 (middle mouse button) on the title bar of the
    pager and select '(Un)Stick' to make it sticky
  - click with mouse 1 on the root window, and select 'Terminal'
  - now click on the page to the right of the current page in the pager
    et voila! - the terminal window vanishes from the pager
  - fix bug :-)
  
  Ctrl-Alt-Backspace
  rm -r .fvwm
  cp -a .fvwm-$(date) .fvwm

Bye!

  Marc-Jano

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 6 Jul 2001 02:56:48 +0000

> [windows on page 0 vanish from pager when selecting page 1 in pager]

BTW, while I tried to reproduce what you initially wrote, I was able to do
this twice (of course, not with instructions you gave), but I can't
reproduce it anymore. It included 7 interactive commands in FvwmConsole
including GotoPage, but it requires some specific window stack.

> which extracts into the directory .fvwm.bug.

It seems you didn't attach, or I didn't get anything.

>   cp -a .fvwm-$(date) .fvwm

FYI, this may be done without (re)moving directories and shutting down X.
Just execute in FvwmConsole (tilde is expanded by Restart) the command:

  Restart env FVWM_USERDIR=~/.fvwm-test fvwm2
  Restart env FVWM_USERDIR=~/.fvwm fvwm2

Or if you write relocable config (i.e. use $. in all Read commands), even:

  Restart fvwm2 -f ~/.fvwm-test/.fvwm2rc
  Restart fvwm2 -f ~/.fvwm/.fvwm2rc

The second pair is an example only, the first should be used to be sure.

Regards,
Mikhael.