Subject: FvwmTheme mix up with shadow colors

From: Tim Phipps <[email-masked]>
Date: Tue, 24 Jul 2001 15:20:39 +0100

Configuration Information [Automatically generated, do not change]:
uname output: SunOS silver 5.5.1 Generic_111442-01 sun4u sparc SUNW,Ultra-5_10
Compiler: gcc
Compilation CFLAGS: -g -O2
prefix: /u/phippst/sunos

FVWM Version:	2.4.1
FVWM_MODULEDIR:	/u/phippst/sunos/libexec/fvwm/2.4.1
FVWM_DATADIR:	/u/phippst/sunos/share/fvwm
FVWM_USERDIR:	/u/phippst/.fvwm

Description:
	Some typos in FvwmTheme.c mean you can't set the shadow color on it's own

Fix:

Index: FvwmTheme.c
===================================================================
RCS file: /u/phippst/cvsroot/fvwm/modules/FvwmTheme/FvwmTheme.c,v
retrieving revision 1.1
diff -u -r1.1 FvwmTheme.c
--- FvwmTheme.c 2001/05/08 10:48:11     1.1
+++ FvwmTheme.c 2001/07/24 14:13:24
@@ -930,11 +930,11 @@
   if (has_sh_changed || has_bg_changed)
   {
     has_sh_changed = 1;
-    if ((cs->color_flags & HI_SUPPLIED) && sh != NULL)
+    if ((cs->color_flags & SH_SUPPLIED) && sh != NULL)
     {
       /* user specified colour */
       if (privateCells) {
-       MyXParseColor(dpy, Pcmap, hi, &color);
+       MyXParseColor(dpy, Pcmap, sh, &color);
        color.pixel = cs->shadow;
        XStoreColor(dpy, Pcmap, &color);
       } else {
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 24 Jul 2001 17:52:06 +0200

> 	Some typos in FvwmTheme.c mean you can't set the shadow color on it's own

Applied in a moment.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]