Subject: Notification: incoming/739

From: [email-masked]
Date: Fri, 13 Jul 2001 13:06:05 -0500

FVWM Bug Tracking notification

new message incoming/739

Message summary for PR#739
	From: [email-masked]
	Subject: fvwm-2.4.0 fails to build on AIX 3.2.5
	Date: Fri, 13 Jul 2001 13:05:59 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Fri Jul 13 13:06:05 2001
From: [email-masked]
To: [email-masked]
Subject: fvwm-2.4.0 fails to build on AIX 3.2.5
Date: Fri, 13 Jul 2001 13:05:59 -0500

Full_Name: Bernhard Simon
Version: 2.4.0
CVS_Date: N/A
OS: AIX 3.2.5
X_Server: N/A
Submission from: (NULL) (128.130.36.4)

fvwm/menus.c fails to compile
cc -DHAVE_CONFIG_H ... -O -c menus.c
"menus.c", line 1066.8: 1506-045 (S) Undeclared identifier XK_Page_Up.
"menus.c", line 1072.8: 1506-045 (S) Undeclared identifier XK_Page_Down.

On AIX 3.2.5 only XK_Prior and XK_Next are defined in
/usr/include/X11/keysymdef.h

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Fri, 13 Jul 2001 14:46:28 -0400

> /usr/include/X11/keysymdef.h

Just a note,
on my AIX 4.3 box, those keysyms are defined.
Isn't 3.2.5 pretty old?

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 15 Jul 2001 00:41:29 +0000

> /usr/include/X11/keysymdef.h

Fixed.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 15 Jul 2001 15:15:24 +0200

> > /usr/include/X11/keysymdef.h

Hm, is there a way to provide these macros via configure so that
we won't have to remember this pitfall each time?  There isn't
much to it:

  #include <X11/keysydef.h>
  #ifndef XK_Page_Up
  #define XK_Page_UP XK_Prior
  #endif
  #ifndef XK_Page_Down
  #define XK_Page_Down XK_Next
  #endif

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 16 Jul 2001 23:23:14 +0000

>   #define XK_Page_Down XK_Next

FYI, keysymdef.h does not do anything good, keysym.h does.

Ok, I implemented some generic mechanism for this kind of things.
This should be used with great care not to break anything.

Regards,
Mikhael.