Subject: Notification: incoming/734

From: [email-masked]
Date: Wed, 04 Jul 2001 06:43:53 -0500

FVWM Bug Tracking notification

new message incoming/734

Message summary for PR#734
	From: [email-masked]
	Subject: Bug or Feature?
	Date: Wed, 04 Jul 2001 06:43:48 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Wed Jul 04 06:43:53 2001
From: [email-masked]
To: [email-masked]
Subject: Bug or Feature?
Date: Wed, 04 Jul 2001 06:43:48 -0500

Full_Name: Marc-Jano Knopp
Version: 2.4.0
CVS_Date: 
OS: GNU/Linux 2.4.5
X_Server: XFree86 4.0.2
Submission from: (NULL) (195.252.198.192)

Hi!

It looks like a bug, but it could also be a feature...

Some icons (apparently with only few colors)
have a border around them, while others do not.

I could not see any option for setting the icon
border, but maybe I'm blind...

A few examples can be found here:

http://mjk.c64.org/ns4.xpm			- no border
http://mjk.c64.org/ebay2.xpm			- border
http://mjk.c64.org/willget2.xpm			- border
http://mjk.c64.org/YellowBlueRedGeometry.xpm	- no border

If it's not a bug: what am I doing wrong?

Best regards,

  Marc-Jano

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 4 Jul 2001 19:26:21 +0000

> Full_Name: Marc-Jano Knopp
...
> If it's not a bug: what am I doing wrong?

It is a feature. Any transparent icons be without border.
A transparency is defined by presence or absence of "None" color.
For example in ebay2.xpm replace "#0000FFFF0000" with "None".
If the icons is not really transparent, but you want it without border,
you should add one color "None", don't forget to increase color number.

Regards,
Mikhael.