Subject: Notification: incoming/733

From: [email-masked]
Date: Wed, 04 Jul 2001 04:44:52 -0500

FVWM Bug Tracking notification

new message incoming/733

Message summary for PR#733
	From: [email-masked]
	Subject: [patch] "checking whether trivial gnome compilation passes" fails
	Date: Wed, 04 Jul 2001 04:44:49 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Wed Jul 04 04:44:51 2001
From: [email-masked]
To: [email-masked]
Subject: [patch] "checking whether trivial gnome compilation passes" fails
Date: Wed, 04 Jul 2001 04:44:49 -0500

Full_Name: Adrian Bunk
Version: 2.4.0
CVS_Date: 
OS: NetBSD/sparc-1.5
X_Server: 
Submission from: (NULL) (141.84.69.17)

..
checking whether trivial gnome compilation passes... no
...

config.log says:
...
In file included from configure:5913:
/usr/local/include/gnome.h:14: gtk/gtk.h: No such file or directory
In file included from /usr/local/include/gdk_imlib.h:5,
                 from /usr/local/include/gnome.h:15,
                 from configure:5913:
/usr/local/include/gdk_imlib_types.h:1: gdk/gdk.h: No such file or
directory
...

The problem is the moved location of the GTK header files in the latest
versions of GTK.

The following patch fixed it for me (and FVWM compiled and runs
successfully):

--- acinclude.m4.old    Wed Jul  4 09:37:46 2001
+++ acinclude.m4        Wed Jul  4 09:38:10 2001
@@ -888,7 +888,7 @@
                AC_MSG_CHECKING(whether trivial gnome compilation passes)
                my_CPPFLAGS="$CPPFLAGS"
                my_LIBS="$LIBS"
-               CPPFLAGS="$CPPFLAGS $GNOME_INCLUDEDIR"
+               CPPFLAGS="$CPPFLAGS $GNOME_INCLUDEDIR $GTK_CFLAGS"
                LIBS="$LIBS $GNOME_LIBDIR $GNOMEUI_LIBS"
                AC_TRY_RUN([
                        #include <gnome.h>

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 4 Jul 2001 19:35:35 +0000

...
> +++ acinclude.m4        Wed Jul  4 09:38:10 2001

I don't know. This is almost the stock gnome.m4, so many gnome programs
will fail on your system.

If `gnome-config --cflags gnorba gnomeui` does not return the correct gtk
include dir like "-I/usr/include/gtk-1.2", gnome instalation is flawed.

But it seems that this patch is safe.

Regards,
Mikhael.