Subject: man page formatting

From: Dominik Vogt <[email-masked]>
Date: Sat, 21 Jul 2001 19:26:09 +0200

The recent fixes in the man page for Solaris etc. (\f...) broke
the bold typeface of the reformatted sections.  For example: 

  .TP
  .BI "Menu " menu-name " [ " position " ] [ " double-click-action " ]"

was changed to

  .IP "Menu \fImenu-name\fP [ \fIposition\fP ] [ \fIdouble-click-action\fP ]"

The "Menu", "[" and "]" parts of the old version are bold while
they are not in the new one.  Of course this can be fixed by
adding more \fB...\fP pairs, but I'd *really* prefer to find a way
to do that without \f...  Isn't there a way to split the .BI lines
into several?  Any ideas are welcome.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 21 Jul 2001 19:48:17 +0000

> into several?  Any ideas are welcome.

I suggest the following style for all commands:

  .B "Menu "
  .I     menu-name
  .BI    "[ " position " ]"
  .BI    "[ " double-click-action " ]"

  .B Popup
  .I      popup-name
  .BI     "[ " position " ]"
  .BI     "[ " default-action " ]"

I.e. use .B for command, .I for mandatory parameters, .BI for optional.
I also think, the spaces in braces are not really needed: .BI [ position ]

This syntax is more readable in my opinion. I may do all these changes.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 21 Jul 2001 20:28:22 +0200

> I also think, the spaces in braces are not really needed: .BI [ position ]

But they *are* needed:

  .BI Menu [ option ]

would look like this (minus typefaces):

  Menu[option]

Of course one could argue about the spaces inside the brackets:

  .BI "Menu [ " option " ]"
  Menu [ option ]

versus

  .BI "Menu [" option "]"
  Menu [option]

> This syntax is more readable in my opinion. I may do all these changes.

Yes, the syntax looks mush better.  But then, you will have to add
something like ".IP" behind the syntax or you will get the text
right behind the syntax:

  .B Popup
  .I      popup-name
  .BI     "[ " position " ]"
  blabla bla

-->

  Popup popup-name [ position ] blabla bla
 
With .IP the next paragraph is properly indented, but a blank line
is inserted too:

  .B Popup
  .I      popup-name
  .BI     "[ " position " ]"
  .IP
  blabla bla
 
--> 

  Popup popup-name [ position ]

        blabla bla

Currently, there is no such blank line.  Perhaps there is a way to
suppress it?

Bye

Dominik ^_^  ^_^

---

From: Dan Espen <[email-masked]>
Date: Sat, 21 Jul 2001 18:32:12 -0400

> Currently, there is no such blank line.  Perhaps there is a way to

I tried using multiple .BI commands but the text ran into the paragraph.

I wonder if the .BI command used in Linux would work with the vendors
nroff/troff, perhaps all we need to do is copy the .BI macro into the
file(s) we need it in.

Maybe I'll have some time to check later...

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sun, 22 Jul 2001 10:48:41 -0400

Dan Espen <[email-masked]> writes:
> > > >   .IP "Menu \fImenu-name\fP [ \fIposition\fP ] [ \fIdouble-click-action

I meant to mark them as bold, oh, I see, the first 2 that I did
I copied verbatim from the 2.2.x version of the manual.

...

> Maybe I'll have some time to check later...

It looks to me like the Linux .BI command is dependent on groff's
".while" command which doesn't appear to available on Solaris.

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 22 Jul 2001 15:43:51 +0200

> ".while" command which doesn't appear to available on Solaris.

And what about macros like .BR or .IR?  Do they suffer from the
same problem?

Bye

Dominik ^_^  ^_^

---

From: Dan Espen <[email-masked]>
Date: Sun, 22 Jul 2001 12:35:06 -0400

Dominik Vogt <[email-masked]> writes:
> > > > > >   .BI "Menu " menu-name " [ " position " ] [ " double-click-action 
> > > > > > 
> > > > > > was changed to
> > > > > > 
> > > > > >   .IP "Menu \fImenu-name\fP [ \fIposition\fP ] [ \fIdouble-click-ac
> > 

Yes they do, but I didn't see any instances of those macros
with more than 6 arguments.

The only man page I've looked at so far is the fvwm man page.

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 22 Jul 2001 23:39:38 +0200

> The only man page I've looked at so far is the fvwm man page.

The other man pages still use the \f... approach.

Bye

Dominik ^_^  ^_^