Subject: Notification: incoming/748

From: [email-masked]
Date: Sat, 28 Jul 2001 16:37:38 -0500

FVWM Bug Tracking notification

new message incoming/748

Message summary for PR#748
	From: [email-masked]
	Subject: button stays depressed in FvwmButtons
	Date: Sat, 28 Jul 2001 16:37:37 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Sat Jul 28 16:37:38 2001
From: [email-masked]
To: [email-masked]
Subject: button stays depressed in FvwmButtons
Date: Sat, 28 Jul 2001 16:37:37 -0500

Full_Name: Jacek Kopecky
Version: 2.4.0
CVS_Date: 
OS: 
X_Server: 
Submission from: (NULL) (194.213.203.154)

I have three buttons in FvwmButtons panel. These 
buttons have as their Action the command Desk a b, 
so that I can switch between three desktops very easily.

In 2.2 the appropriate button was depressed 
depending on the current desktop. That held true 
even if I changed the desktop _not_ using these buttons.

In 2.4.0 I didn't succeed to configure the panel 
so that the behavior would be the same. Somehow just 
the first of the three is usually depressed, but with
weird combinations of doubleclicks and clicks I can achieve
just about any combination of depressed and released buttons.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 29 Jul 2001 15:45:28 +0200

> just about any combination of depressed and released buttons.

It's hard to say what the problem is without knowing the details
of your configuration.  Please post the relevant configuration to
the [email-masked] mailing list.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Jacek Kopecky <[email-masked]>
Date: Sun, 29 Jul 2001 20:33:34 +0200 (CEST)

Hi, this is the relevant config part from my old (2.2.4) config
and under it I'll describe what it did:

*FvwmButtons (2x4, Title main, Action (Mouse 1) Desk 0 0, \
    Action (Mouse 2) Function gostickdesk 0, \
    Action (Mouse 3) Function movedesk 0)
*FvwmButtons (2x4, Title dev, Action (Mouse 1) Desk 0 1, \
    Action (Mouse 2) Function gostickdesk 1, \
    Action (Mouse 3) Function movedesk 1)
*FvwmButtons (2x4, Size 32 22, Title info, \
    Action (Mouse 1) Desk 0 2, \
    Action (Mouse 2) Function gostickdesk 2, \
    Action (Mouse 3) Function movedesk 2)

With this config I had three buttons named "main", "dev" and
"info" that I used to switch between desks. Of these three
buttons the one representing the current desk was always
depressed, the others were released. This worked automagically.
gostickdesk and movedesk are my functions, should be irrelevant.

In 2.4, the config is as follows:

*FvwmButtons: (4x4, Title main, Action "Desk 0 0", \
   Action (Mouse 2) "Function gostickdesk 0", \
   Action (Mouse 3) "Function movedesk 0")
*FvwmButtons: (4x4, Title dev, Action "Desk 0 1", \
   Action (Mouse 2) "Function gostickdesk 1", \
   Action (Mouse 3) "Function movedesk 1")
*FvwmButtons: (4x4, Size 32 22, Title info, \
   Action "Desk 0 2", \
   Action (Mouse 2) "Function gostickdesk 2", \
   Action (Mouse 3) "Function movedesk 2")

and the buttons are depressed rather randomly. If I change the
command Desk to GotoDesk, they are all released all the time. I
traced it to some code in FvwmButtons where there is a check for
"Desk"; I didn't have the time or will to go deeper. I can live
with them being released all the time for now. 8-)

                            Jacek Kopecky

                            Idoox
                            http://www.idoox.com/

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 30 Jul 2001 13:50:33 +0200

> with them being released all the time for now. 8-)

Fixed.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]