Subject: Notification: incoming/744

From: [email-masked]
Date: Fri, 20 Jul 2001 11:04:16 -0500

FVWM Bug Tracking notification

new message incoming/744

Message summary for PR#744
	From: [email-masked]
	Subject: FVWM ignores CirculateHitIcon when CirculateSkipIcon style is specified
	Date: Fri, 20 Jul 2001 11:04:15 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Fri Jul 20 11:04:16 2001
From: [email-masked]
To: [email-masked]
Subject: FVWM ignores CirculateHitIcon when CirculateSkipIcon style is specified
Date: Fri, 20 Jul 2001 11:04:15 -0500

Full_Name: Gilles Charron
Version: 2.4.0
CVS_Date: 
OS: Linux with Kernel 2.4.2
X_Server: Xfree 4.1.0
Submission from: (NULL) (24.201.99.186)

When the "CirculateSkipIcon, NoIcon" Style is generated, the "Next"
"Previous"
"None" and other window list searching mechanism don't circulate
through the Icons even if the CirculateHitIcon flag is specified.

Use the following exercise to demonstrate:

1 - Start fvwm 2.4.0 with an empty cfg file.
2 - with the build in menu, launch the FvwmConsole module
    (4) and an xterm with the name "test" (xterm -name test)
3 - type the following in the FvwmConsole window:

    Style "test" NoIcon, CirculateSkipIcon
    Key F3 A N Next (test CirculateHitIcon) Iconify

4 - Press "F3" and watch the window disappear because it has no
    Icon. Pressing F3 again should bring back the window but
    currently nothing happens!!!

I beleive this also happens when the "NoIcon" Style is not specified.

Regards,
Gilles

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 21 Jul 2001 20:14:25 +0200

> I beleive this also happens when the "NoIcon" Style is not specified.

It does.  Even more, CirculateSkipShaded does not work either.
Both problems will be fixed in the next release and snapshot.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]