Subject: Regarding XQueryPointer

From: "Dmitry Yu. Bolkhovityanov" <[email-masked]>
Date: Wed, 25 Jul 2001 14:51:20 +0700

Hi!

    Forgot to ask before: what's the performance problem with XQueryPointer?
Is it because this query syncs the X connection, or something else?  And how
did you notice it?  I have only 10/100Mb ethernet and can't correctly slow it
down to effectively simulate modem connection, so haven't noticed any
problems.

       ___________________________________________________________________
       Dmitry Yu. Bolkhovityanov  |  Novosibirsk, RUSSIA
       phone (383-2)-39-49-56     |  The Budker Institute of Nuclear Physics
                                  |  Lab. 5-13
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 25 Jul 2001 11:55:02 +0200

On Wed, Jul 25, 2001 at 02:51:20PM +0700, Dmitry Yu. Bolkhovityanov wrote:
> Is it because this query syncs the X connection, or something else?

Yes.

> And how did you notice it?

By reading the documentation :-)

> I have only 10/100Mb ethernet and can't correctly slow it

I have spent a lot of time to make the move/resize code work as
smooth as possible.  With too much stuff going on over the
network this becomes jerky.  A single call causing network
traffic does not slow things down much, but it accumulates with
other calls.  Fvwm once became so slow that moving was very
jerky, even with the X server on the local machine.  Since then
I allways look at new code in the move/resize loops twice.

Anyway, yesterday's commit drastically reduces the number of
XQueryPointer calls.  It allows to pass in an event that may hold
the last pointer position.  The position is taken from the event
if possible and only queried if the event does not have this
information.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]