Subject: FvwmTheme troubles

From: Brad Giaccio <[email-masked]>
Date: Wed, 27 Jun 2001 06:19:45 -0400

I hate to say it but I have a slight problem with CVS as of about 10
minutes ago.  I last updated on May 9.

My problem is that it would seem that FvwmTheme is not parsing my config
or accepting input from FvwmConsole

In my rc I had 
*FvwmThemeColorset 0 fg #d7dde8, bg #979797 # default color
*FvwmThemeColorset 1 fg #d7dde8, bg #596eb1 # hilight color
*FvwmThemeColorset 2 fg #d7dde8, bg #5b74a2, Transparent
*FvwmThemeColorset 3 fg #d7dde8, bg #43608e, CGradient 128 #979797 #596eb1
*FvwmThemeColorset 4 fg gold,    bg #43608e, Transparent #DGradient 128 #444444 #8b9dc3
*FvwmThemeColorset 5 fg pink,    bg #43608e, Transparent #DGradient 128 #444444 #8b9dc3
*FvwmThemeColorset 6 fg #d7dde8, bg #000e4f
which worked fine with the 2.3.33

After checking the man page I converted to 
*FvwmTheme: Colorset 0 fg #d7dde8, bg #979797 # default color
*FvwmTheme: Colorset 1 fg #d7dde8, bg #596eb1 # hilight color
*FvwmTheme: Colorset 2 fg #d7dde8, bg #5b74a2, Transparent
*FvwmTheme: Colorset 3 fg #d7dde8, bg #43608e, CGradient 128 #979797 #596eb1
*FvwmTheme: Colorset 4 fg gold,    bg #43608e, Transparent #DGradient 128 #444444 #8b9dc3
*FvwmTheme: Colorset 5 fg pink,    bg #43608e, Transparent #DGradient 128 #444444 #8b9dc3
*FvwmTheme: Colorset 6 fg #d7dde8, bg #000e4f

in FvwmConsole id do
echo $[fg.cs0] $[fg.cs1] $[fg.cs2] $[fg.cs3] $[fg.cs4] $[fg.cs5] $[fg.cs6]
I get: [FVWM][Echo]:  rgb:d7d7/dddd/e8e8 rgb:d7d7/dddd/e8e8 rgb:d7d7/dddd/e8e8 rgb:d7d7/dddd/e8e8 rgb:d7d7/dddd/e8e8 rgb:d7d7/dddd/e8e8 rgb:d7d7/dddd/e8e8 
So I try 
*FvwmTheme: Colorset 0 fg black
echo $[fg.cs0]
[FVWM][Echo]:  rgb:d7d7/dddd/e8e8

SendToModule FvwmTheme Colorset 0 fg black
echo $[fg.cs0]
[FVWM][Echo]:  rgb:d7d7/dddd/e8e8

*SendToModule FvwmTheme Colorset 0 fg  rgb:0000/0000/0000
echo $[fg.cs0]
[FVWM][Echo]:  rgb:d7d7/dddd/e8e8

It seems like all 7 colorsets I use are getting the bg, and fg of Colorset 0.
I'm at a loss I'm going to take a look at FvwmTheme now but maybe someone else could confirm this.

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 27 Jun 2001 12:45:45 +0200

> I'm at a loss I'm going to take a look at FvwmTheme now but maybe someone else could confirm this.

FvwmTheme crashes when parsing this line:

Stack trace:

#0  0x804dca4 in CreateGradientPixmap (dpy=0x80575e8, d=12582913, 
    gc=0x8058d60, type=67, g_width=255, g_height=255, ncolors=128, 
    pixels=0x8059120, in_drawable=0, d_x=0, d_y=0, d_width=0, d_height=0, 
    rclip=0x0) at Graphics.c:718
#1  0x804e316 in CreateGradientPixmapFromString (dpy=0x80575e8, d=12582913, 
    gc=0x8058d60, type=67, action=0x80590d3 "128 #979797 #596eb1", 
    width_return=0xbffff3f8, height_return=0xbffff3f4, 
    pixels_return=0x8059760, nalloc_pixels=0x8059764) at Graphics.c:857
#2  0x804af9f in parse_colorset (line=0x8057106 "") at FvwmTheme.c:682
#3  0x8049f6c in parse_config_line (
    line=0x80570bc "*FvwmThemeColorset 3 fg #d7dde8, bg #43608e, CGradient 128 #979797 #596eb1") at FvwmTheme.c:240
#4  0x8049e96 in main_loop () at FvwmTheme.c:204
#5  0x8049d0c in main (argc=6, argv=0xbffff60c) at FvwmTheme.c:164
#6  0x4017fbaf in __libc_start_main () from /lib/libc.so.6

I'll take a look.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]