Subject: Notification: incoming/720

From: [email-masked]
Date: Fri, 22 Jun 2001 07:42:45 -0500

FVWM Bug Tracking notification

new message incoming/720

Message summary for PR#720
	From: [email-masked]
	Subject: Disappearing Icons (reproducible)
	Date: Fri, 22 Jun 2001 07:42:44 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Fri Jun 22 07:42:45 2001
From: [email-masked]
To: [email-masked]
Subject: Disappearing Icons (reproducible)
Date: Fri, 22 Jun 2001 07:42:44 -0500

Full_Name: Marc-Jano Knopp
Version: 2.3.32
CVS_Date: 
OS: Linux 2.4.5
X_Server: XFree86 4.0.2
Submission from: (NULL) (195.252.203.87)

Hi!

If a window's icon is sticky, but not the window itself, and
you restart fvwm 2.2.32 with a current desk other than 0, then
this window will disappear from the desktop. As I have StickyIcons
by default, this makes _all_ icons disappear - ARGH! :)

The icon will still be shown in both FvwmPager and in FvwmWinList.
The only way to restore the normal behavior is to a) deiconify
the window once (using FvwmWinList or FvwmPager), or b) restart
fvwm with the current desktop 0.

When the icons are invisible, new icons are positioned correctly
within the icon box, i.e. if I had three icons before, then the
next icon will correctly place itself next to the three invisible
icons.

Best regards,

  Marc-Jano

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 22 Jun 2001 22:59:01 +0200

> next icon will correctly place itself next to the three invisible

I have fixed this in the next beta release (or current CVS).

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]