Subject: Keyboard is locked after canceling window selection

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 8 May 2001 21:20:35 +0000

This bug should be related to keyboard grab changes done on 2001-04-15.

Execute Move (or similar command) without a window-context, press Escape,
woops, the keyboard is locked. The mouse works, so hopefully you will be
able to Restart, which restores the keyboard.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 9 May 2001 01:39:37 +0200

> This bug should be related to keyboard grab changes done on 2001-04-15.

Partially.  The lockup was there for a long time, but fvwm did not
balance XGrabKeyboard versus XUngrabKeyboard calls, so it got
unlocked after a while.
> able to Restart, which restores the keyboard.

Fixed.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]