Subject: SetEnv not expanding environmental variables itself

From: An Thi-Nguyen Le <[email-masked]>
Date: Thu, 10 May 2001 09:49:41 -0500

Version: cvs (as of May 10 09:35:30 CDT 2001)

Maybe this is documented somewhere.  Set up some environment stuff, like
so:

  SetEnv fvwmdir ${HOME}/.fvwm
  SetEnv bindir $fvwmdir/bin

'Exec echo <blah>' should fully expand these variables, then.  However, 
this happens:

  Exec echo $fvwmdir
                ===> ${HOME}/.fvwm
  Exec echo $bindir
                ===> $fvwmdir/bin
  
The second one should be something like maybe '${HOME}/.fvwm/bin'.  Unless, 
of course, SetEnv's not supposed to expand environment variables.

-- 
An Thi-Nguyen Le
|Beauty seldom recommends one woman to another.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: An Thi-Nguyen Le <[email-masked]>
Date: Thu, 10 May 2001 09:55:33 -0500

[An Thi-Nguyen Le - Thu, 10 May 2001 09:50:34 AM CDT]
> of course, SetEnv's not supposed to expand environment variables.

Some more possibly strange things:

  ImagePath /usr/share/icons
  ImagePath +:$fvwmdir/pixmaps

doesn't work either.  However, using

  SetEnv fvwmdir /home/viper/.fvwm

*does* work.

-- 
An Thi-Nguyen Le
|It may be better to be a live jackal than a dead lion, but it is better
|still to be a live lion.  And usually easier.
|		-- Lazarus Long
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Thu, 10 May 2001 10:59:42 -0400

> of course, SetEnv's not supposed to expand environment variables.

Use the notation:

Exec echo $[bindir]

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: An Thi-Nguyen Le <[email-masked]>
Date: Thu, 10 May 2001 14:48:53 -0500

[Dan Espen - Thu, 10 May 2001 10:14:34 AM CDT]
> Exec echo $[bindir]

Ah.  Okay.  Never mind...

Embarassed...

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 10 May 2001 23:09:30 +0000

On 10 May 2001 09:49:41 -0500, An Thi-Nguyen Le wrote:
> 
> Maybe this is documented somewhere.

Yes, in the man page. Enter /environment and press 'n' several times.
You will find everything you wanted to know, including the fact that only
3 commands ImagePath, ModulePath and Restart expand environment variables
$var and ${var} themselves, and for other commands $[var] should be used.

Regards,
Mikhael.