Subject: Focus and override redirect window

From: Olivier Chapuis <[email-masked]>
Date: Mon, 7 May 2001 11:37:09 +0200

Hello,
I do not know if we have to take care of that now.
Moreover, this problem is maybe a bug of the applications
and not a FVWM bug (I do not know).
Here the problem.
Say that we have a NeverFocus window A and a window B with the
focus (say SloppyFocus and ClickToFocusClickRaise).
Now if I pop up (and pop down) a menu of the window A (override redirect),
then some times: 
   (i) window B lost the keyboard input (always happen if A is a qt app)
   (ii) I cannot raise window B by clicking inside it (tested with Xemacs)

Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 7 May 2001 12:59:18 +0200

>    (ii) I cannot raise window B by clicking inside it (tested with Xemacs)

Could you try if

  BugOpts FlickeringQtDialogsWorkaround On

helps?

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 7 May 2001 17:26:40 +0200

Le Lundi  7 Mai 2001 12:59, vous avez écrit :
> > Now if I pop up (and pop down) a menu of the window A (override
> > redirect), then some times:

I try and if fact this is a default I think.
Unfortunately this change nothing. I've not yet tested
your last "icon/focus" commit.
Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 27 May 2001 20:37:32 +0200

>    (ii) I cannot raise window B by clicking inside it (tested with Xemacs)

I tried this out and can reproduce (ii) (fixed) but not (i). I
tried with kedit, kfm, kmag and xterm for window A and FvwmConsole
and xemacs for window B.  I opened various menus of A, but I never
saw any problem with the focus.  I started testing this thoroughly
only after I wrote the fix for (ii), so the problem may have gone
away in the wake of the patch, but I don't believe it.  Can you
give more details?

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 28 May 2001 11:11:44 +0200

> away in the wake of the patch, but I don't believe it.  Can you

I can confirm that (ii) is fixed. (i) is still here. I will try to give more explaination on
(i) (however, I really do not think that this is a critical bug):
    
Reproduction:  - Style "kedit" NeverFocus
                     - start kedit and an xterm
                     - give the focus to the xterm (say the xterm is SloppyFocus )
                     - go to the kedit window (the xterm have still the focus)
                     - Popup the file menu and cancel it by a click somewhere (on the
                      root window or on kedit or on the xterm).
                     - Then, the xterm is still decorated as a window with the focus, but
                    the xterm has no more the keyborad focus.

So that the xterm get again the keyboard focus I need to give the focus to an other window
and come back to the xterm. In fact, kedit (or the kedit menu?) take the keyboard focus
when I popup the file menu so that  the arrows key can be used for menu navigation.

Maybe an important point is that I used KDE version 2 (2.1.1) with QT 2.3.0. Also there
is a QT option --nograb (say to do not grab the keyboard and the mouse), but this change
nothing to the problem.

Really, I think this is not a critical bug at all: who want to use kedit with a NeverFocus style?
The only K apps which may need a NeverFocus policy are apps as kicker (kpanel KDE
version 2 analogue) or kpager which do not work with FVWM. So this is a fvwm-ewmh
problem and not a FVWM problem and if you do not see an obvious solution I think you
do not have to lost your time with this. When I will have some time I will take a look on this
problem, but I think we can safelly release 2.4.0 whithout a fix to this.

Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 28 May 2001 11:31:43 +0200

>                     the xterm has no more the keyborad focus.

No, I have no problem at all, even with your instructions.

> Maybe an important point is that I used KDE version 2 (2.1.1) with QT 2.3.0.

 - Qt version 2.2.3
 - Kde 2.0.1

Bye

Dominik ^_^  ^_^