Subject: Re: X Application crashes

From: Dan Espen <[email-masked]>
Date: Thu, 31 May 2001 08:05:47 -0400

Please make sure to copy the fvwm list.

Nils Lohner <[email-masked]> writes:
> On Thu, 31 May 2001 06:54:48 -0400, Dan Espen wrote:
> >Nils Lohner <[email-masked]> writes:
> >Yes gdb will work as well.
> >Just put the pid at the end of the command line.
> >
> >You could attach either to fvwm and then type "cont" but thats not
> >necessary, just wait for it to hang, then find some way to telnet or
> >rlogin to the machine, get the pid of fvwm and do:
> >
> >gdb pathtofvwm pidoffvwm
> Seems to be in the main event loop already; attaching it to my running 
> fvwm.  My xinitrc is minimal; the xsetroot -solid midnightblue from my 
> fvwmrc didn't happen when it froze (or when the session login stopped 
> continuing).

Is xsetroot run from fvwm's InitFunction?

> Here's the stack trace from a session that locked up on login.  The 
> thing is that if I attach the gdb to a running, working fvwm session it 
> looks the same.  How should fvwm be invoked from the .xinitrc?  With 
> 'exec fvwm2' or just 'fvwm2' ?  Does it make a difference?

No it  won't make any  difference.   exec fvwm2  just  gets rid of the
.xinitrc process.

> I've commented out almost everything from my .xinitrc and two lines 
> that might have impacted it (I'll have to wait and see over the next 
> few days) are:
> 
> xmodmap -e 'keysym F1 = Help'
> eval `svenv -env`                      # SunView binary compatibility

I don't think either of those commands would make any difference.
For me, just typing in "svenv -env" doesn't print anything.  I don't
see any man page for it.

> /sup/bin > sudo gdb fvwm2 5910
> 
> We trust you have received the usual lecture from the local System
> Administrator. It usually boils down to these two things:
> 
>         #1) Respect the privacy of others.
>         #2) Think before you type.
> 
> Password:
> GNU gdb 5.0
> Copyright 2000 Free Software Foundation, Inc.
> GDB is free software, covered by the GNU General Public License, and 
> you are
> welcome to change it and/or distribute copies of it under certain 
> conditions.
> Type "show copying" to see the conditions.
> There is absolutely no warranty for GDB.  Type "show warranty" for 
> details.
> This GDB was configured as "sparc-sun-solaris2.7"...
> /sup/bin/5910: No such file or directory.
> Attaching to program `/sup/bin/fvwm2', process 5910
> Reading symbols from /sup/lib/libXpm.so.4.11...done.
> Loaded symbols for /sup/lib/libXpm.so.4.11
> Reading symbols from /usr/openwin/lib/libSM.so.6...done.
> Loaded symbols for /usr/openwin/lib/libSM.so.6
> Reading symbols from /usr/openwin/lib/libICE.so.6...done.
> Loaded symbols for /usr/openwin/lib/libICE.so.6
> Reading symbols from /usr/openwin/lib/libXext.so.0...done.
> Loaded symbols for /usr/openwin/lib/libXext.so.0
> Reading symbols from /usr/openwin/lib/libX11.so.4...done.
> Loaded symbols for /usr/openwin/lib/libX11.so.4
> Reading symbols from /usr/lib/libsocket.so.1...done.
> Loaded symbols for /usr/lib/libsocket.so.1
> Reading symbols from /usr/lib/libnsl.so.1...done.
> Loaded symbols for /usr/lib/libnsl.so.1
> Reading symbols from /usr/lib/libm.so.1...done.
> Loaded symbols for /usr/lib/libm.so.1
> Reading symbols from /usr/lib/libc.so.1...done.
> Loaded symbols for /usr/lib/libc.so.1
> Reading symbols from /usr/lib/libdl.so.1...done.
> Loaded symbols for /usr/lib/libdl.so.1
> Reading symbols from /usr/lib/libmp.so.2...done.
> Loaded symbols for /usr/lib/libmp.so.2
> Reading symbols from /usr/platform/SUNW,Ultra-5_10/lib/libc_psr.so.1...d
> one.
> Loaded symbols for /usr/platform/SUNW,Ultra-5_10/lib/libc_psr.so.1
> Retry #1:
> Retry #2:
> Retry #3:
> Retry #4:
> [New LWP 1]
> Symbols already loaded for /sup/lib/libXpm.so.4.11
> Symbols already loaded for /usr/openwin/lib/libSM.so.6
> Symbols already loaded for /usr/openwin/lib/libICE.so.6
> Symbols already loaded for /usr/openwin/lib/libXext.so.0
> Symbols already loaded for /usr/openwin/lib/libX11.so.4
> Symbols already loaded for /usr/lib/libsocket.so.1
> Symbols already loaded for /usr/lib/libnsl.so.1
> Symbols already loaded for /usr/lib/libm.so.1
> Symbols already loaded for /usr/lib/libc.so.1
> Symbols already loaded for /usr/lib/libdl.so.1
> Symbols already loaded for /usr/lib/libmp.so.2
> Symbols already loaded for /usr/platform/SUNW,Ultra-5_10/lib/libc_psr.so
> .1
> 0xff1144cc in _poll () from /usr/lib/libc.so.1
> (gdb) where
> #0  0xff1144cc in _poll () from /usr/lib/libc.so.1
> #1  0xff0ce444 in select () from /usr/lib/libc.so.1
> #2  0x60354 in fvwmSelect (nfds=64, readfds=0xffbeed08, 
> writefds=0xffbeec88,
>     exceptfds=0x0, timeout=0x0) at fvwmsignal.c:154
> #3  0x34a4c in My_XNextEvent (dpy=0x7e698, event=0x7b9b8) at 
> events.c:2619
> #4  0x34e88 in HandleEvents () at events.c:2800
> #5  0x555b0 in main (argc=2, argv=0xffbef2ec) at fvwm.c:742

If fvwm is in its main event loop, then I'm not sure its actually
hung.  Does the mouse pointer move?  Do windows focus?  If you log
in from some other machine, can you create windows?

Maybe someone else has some more ideas?

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Nils Lohner <[email-masked]>
Date: Thu, 31 May 2001 15:05:03 +0200

>Please make sure to copy the fvwm list.

Sorry, I had the same mail ready for the list and forgot to send it :)

>Is xsetroot run from fvwm's InitFunction?

Yes: + "I" Exec xsetroot -solid midnightblue&

>No it  won't make any  difference.   exec fvwm2  just  gets rid of the

OK, good to know.

>For me, just typing in "svenv -env" doesn't print anything.  I don't

That's what I thought; I see no difference.

>> /sup/bin > sudo gdb fvwm2 5910
...
>in from some other machine, can you create windows?

Well, on the screen it looks like FVWM's never even started (the 
process and pager processes are running, though); I get the openwin 
startup screen with their X/hourglass cursor, and that's it.  Sometimes 
it goes to the clock-busy cursor and back to the X cursor  The cursor 
moves fine; a few versions ago (around .26-.28 maybe?) it sometimes 
would let me right-click to get a menu.

 I'll try starting a window.  It shows the rubber band and the 
coordinates (I can even middle-button resize it while placing), I can 
place the window but it disappears (visually; the process is still 
running).  When I move the cursor to the area where teh window should 
be and try to 'touch' a file, the file does not created so the window 
appears to not really be there.

>Maybe someone else has some more ideas?

Thanks for the help so far...

Nils.