Subject: Re: Notification: incoming/709

From: Dominik Vogt <[email-masked]>
Date: Tue, 1 May 2001 12:52:13 +0200

On Sat, Apr 28, 2001 at 07:27:58AM -0500, fvwm-bug wrote:
> FVWM Bug Tracking notification
> 
> new message incoming/709
> 
> Full_Name: Slaven Rezic
> Version: 2.3.31
> CVS_Date: 
> OS: FreeBSD-3.5
> X_Server: XFree86 3.3.5
> Submission from: (NULL) (62.104.208.72)
> 
> 
> Although marked as fixed, the Tk raise problem still exists. The following
> patch works for me:
> 
> --- old.work/fvwm-2.3.31/fvwm/events.c  Sat Apr 28 13:15:53 2001
> +++ work/fvwm-2.3.31/fvwm/events.c      Sat Apr 28 13:18:50 2001
> @@ -2067,6 +2067,9 @@
>         cre->value_mask |= (ecre->value_mask & CWStackMode);
>         cre->above = ecre->above;
>         cre->detail = ecre->detail;
> +
> +       /* srt: see below about Tk note */
> +       do_send_event = True;
>        }
>      } /* while */
>    } /* if */
> @@ -2365,6 +2368,10 @@
>        */
>        BroadcastRestackThisWindow(Tmp_win);
>      }
> +
> +    /* srt (28-Apr-2001): Tk needs a ConfigureNotify event after a raise,
> +     * otherwise it would hang for two seconds */
> +    do_send_event = True;
>    }
>  
>  #if 1

Thanks. I will apply that patch shortly.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Tue, 01 May 2001 15:13:47 -0400

> Thanks. I will apply that patch shortly.

Dominik, you applied that patch, but also added this:

  if (!(sf = get_focus_window()) || HAS_MOUSE_FOCUS(sf))
  {
    DeleteFocus(1);
  }

around line 1880, that causes the problem Paul and I see with
unclutter.

And as Paul reported, you left some debug stuff too.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]