Subject: Re: Notification: incoming/707

From: Dominik Vogt <[email-masked]>
Date: Tue, 29 May 2001 22:37:40 +0200

On Wed, Apr 18, 2001 at 11:31:10AM -0400, Eric Ding wrote:
> Hi Dominik,
> 
> I've included below a sample Java application (source code) that tickles
> the bug in fvwm 2.2.5.  I haven't had the time to try this out with the
> latest FVWM2 beta version, so I don't know if it works from there.

I installed Java2 and tried to run your sample program, but the
VM dumps core withut doing anything useful.  The same problem
occurs when compiling the program with javac.  Could anybody
else try this?  (sample program attached again).

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: André Dahlqvist <[email-masked]>
Date: Tue, 29 May 2001 23:41:24 +0200

> else try this?  (sample program attached again).

I tried running this program, and it seams to work. It is a small app with
a button in it. I have the normal toolbar buttons, but I noticed this
message in my .xsession-errors file:

[FVWM][GetWindowSizeHints]: <<WARNING>> Hello World window 0x1a00028 has broken 
(max_width) size hints
Please report this to [email-masked]
hint override = 0
flags = 23c
min_width = 0, min_height = 0, max_width = 0, max_height = 0
width_inc = 0, height_inc = 0
min_aspect = 0/0, max_aspect = 0/0
base_width = 0, base_height = 0
win_gravity = 1

Let me know if you need more help.
-- 

André Dahlqvist <[email-masked]>
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 30 May 2001 02:03:07 +0200

> Let me know if you need more help.

Is there any chance to compile a stand alone executable for a
Linux 2.4 system (SuSE 7.1) from this?  You can find the original
bug report in our bug databes (#707).

Bye

Dominik ^_^  ^_^

---

From: André Dahlqvist <[email-masked]>
Date: Wed, 30 May 2001 10:22:38 +0200

> bug report in our bug databes (#707).

I've attached the bytecode file to this e-mail, which should run on your
system. I'll look at the bugreport once I've done my exam today:-)
--

---

From: André Dahlqvist <[email-masked]>
Date: Wed, 30 May 2001 12:04:05 +0200

In case you guys can't get it running, I have attached a picture how the
app looks on my box. Is this how it is supposed to look?
--

---

From: André Dahlqvist <[email-masked]>
Date: Wed, 30 May 2001 12:05:05 +0200

I should add that fvwm2 obeys the call to frame.setResizable(false) in
this application, because I can't resize it.
--