Subject: FvwmTaskBar core dumps when restarting in FvwmScript-Setup95

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 8 May 2001 21:32:17 +0000

After choosing "Rebuild Sample 95" from a menu, configuring it and
restarting (via FvwmScript-Setup95) the following happens:

*FvwmTaskBar: Cause of next X Error.
   Error: 4 (BadPixmap)
   Major opcode of failed request:  56 (ChangeGC)
   Minor opcode of failed request:  0
   Resource id of failed request:  0x400072
 Leaving a core dump now

#3  0x8054e0a in PrintXErrorAndCoredump () at XError.c:59
#4  0x804d7c3 in ErrorHandler (d=0x8059b78, event=0xbfffe708)
    at FvwmTaskBar.c:2061
#5  0x400b5d87 in _XError () from /usr/X11R6/lib/libX11.so.6
#6  0x400b3141 in _XEventsQueued () from /usr/X11R6/lib/libX11.so.6
#7  0x400a714e in XPending () from /usr/X11R6/lib/libX11.so.6 
#8  0x804c3cc in LoopOnEvents () at FvwmTaskBar.c:1385
#9  0x804a75a in EndLessLoop () at FvwmTaskBar.c:389
#10 0x804a66b in main (argc=6, argv=0xbffff3bc) at FvwmTaskBar.c:350

Can someone else reproduce and take a look into this?

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 14 May 2001 07:18:12 +0200

> restarting (via FvwmScript-Setup95) the following happens:

Fixed I think, Olivier

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 14 May 2001 06:20:43 +0200

> restarting (via FvwmScript-Setup95) the following happens:

I already get the core dump you describe.
But, I fail to find a method to reproduce this problem. 
I suspect a mini icon problem. I will try to work more on this.
Olivier