Subject: Notification: incoming/713

From: [email-masked]
Date: Tue, 08 May 2001 09:26:04 -0500

FVWM Bug Tracking notification

new message incoming/713

Message summary for PR#713
	From: [email-masked]
	Subject: FvwmButtons with mouse buttons > 3
	Date: Tue, 08 May 2001 09:26:02 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Tue May 08 09:26:04 2001
From: [email-masked]
To: [email-masked]
Subject: FvwmButtons with mouse buttons > 3
Date: Tue, 08 May 2001 09:26:02 -0500

Full_Name: Cameron Kerr
Version: 2.2.4
CVS_Date: 
OS: Slackware Linux 7.1
X_Server: XFree86 4.0.2
Submission from: (NULL) (203.96.111.200)

I would like to have a FvwmButton that responds to inputs from the scroll
wheel of my
mouse. I would like to use this to change the volume on my system. Idealy,
I would do
this my specifying the (Mouse 4) or (Mouse 5) option in the call to
FvwmButtons.

I know that FvwmButtons can accept such inputs, since if I scroll over a
button which
has no (Mouse X) option (let's say its a button to bring up the `top`
program), then I get
a whole lot of xterms running top starting to load.

If I specify (Mouse 4),  then the FvwmButton module fails to load.

I've currently got mouse 1 to lower the volume, and mouse 3 to increase the
volume, thusly,

*FvwmButtons(3x1, Action (Mouse 1) `Exec exec echo "vol Vol +" | smixer -s
-`,\
                  Action (Mouse 3) `Exec exec echo "vol Vol -" | smixer -s
-`)\
                  "Volume Up(M1)/Down(M3)"

Which works perfectly well, except that I can't scroll on it.

Thanks in advance.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 8 May 2001 20:08:07 +0000

On 08 May 2001 09:26:04 -0500, [email-masked] wrote:
> I would like to have a FvwmButton that responds to inputs from the
> scroll wheel of my mouse. I would like to use this to change the volume
> on my system. Idealy, I would do this my specifying the (Mouse 4) or
> (Mouse 5) option in the call to FvwmButtons.

[...]

> *FvwmButtons(3x1,\
>   Action (Mouse 1) `Exec exec echo "vol Vol +" | smixer -s -`,\
>   Action (Mouse 3) `Exec exec echo "vol Vol -" | smixer -s -`)
> 

Starting from 2.3.24 you may do the same for Mouse 4 and Mouse 5.
I have moved this bug to "existing enhancements" section.

Regards,
Mikhael.