Subject: Re: FVWM: Gnome panel and sounds

From: Olivier Chapuis <[email-masked]>
Date: Sat, 19 May 2001 06:25:52 +0200

Le Vendredi 18 Mai 2001 21:18, vous avez écrit :
> On 11 May 2001 16:38:18 +0000, Subba Rao wrote:
> > I am running FVWM2 2.2.32 with gnome enabled. How do I start gnome panel
> > when I start my X session? Right now, I am starting it in .xinitrc. There
> > must be a way to start from .fvwm2rc.
>
>   AddToFunc InitFunction
>   + I Exec exec panel
>
> I also have the following line
>
>   Style panel GNOMEIgnoreHints
>
> because it seems that either panel in GNOME 1.4 does not use GNOME hints
> correctly (it is first shaded when collapsed) or FVWM has no fully correct
> GNOME hints support, I can't check right now which one.
>

Fixed, can you confirm I've not GNOME 1.4 on my machine (I've the
current GNOME 2 cvs and the panel is far from being compilable o:)
Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 19 May 2001 11:23:42 +0000

> Le Vendredi 18 Mai 2001 21:18, vous avez écrit :

I think s/vous/real-name/ would be more informative. :)

> current GNOME 2 cvs and the panel is far from being compilable o:)

Yes, this is fixed, nice. The problem was using 0/1 instead of 1/2 in
WindowShade. On/Off works, but accourding to the man page this is as
obsolete as 1 and 2. The only non-obsolete arguments for toggle commands
(Iconify, Maximize, Stick, WindowShade) are True/False/Toggle.

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 19 May 2001 13:35:55 +0200

> (Iconify, Maximize, Stick, WindowShade) are True/False/Toggle.

No I do not think so. The fvwm2 man page say that:
"yes",  "on", "true",  "t" , "y"  and  "no", "off", "false", "f",
"n" are all valide arguments for a boolean argument
(section BOOLEAN ARGUMENT, and WindowShade section
just say that 1 and 2 are obsolet but equivalent to On and Off).
Moreover, this seems natural for me (as 1,2 are really not good
as the bug shows).
Olivier 
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 21 May 2001 13:18:19 +0200

> Moreover, this seems natural for me (as 1,2 are really not good

Right.  I coded every "true/false" pair I could think of for
boolean arguments :-)

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]