Subject: import -frame fails

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 15 May 2001 22:10:01 +0000

import utility from ImageMagick without parameters works well.
With -frame it behaves strangely now. It worked well some time ago.
It seems that import and fvwm do not agree about what is window frame.

On my machine "import -frame image.gif" on xv or xcalc produces an image
without client window (it is empty). If trying to capture xterm, it exits
with "Can't allocate memory" error. rxvt being captured does not exit
itself, but eats all memory and then is killed by kernel.

Tried with ImageMagick-5.2.2 and ImageMagick-5.3.3 - the same problems.
Tried with fvwm-2.2.5 and fvwm-2.3.22 - everything is fine.

Please comment.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Tue, 15 May 2001 21:21:12 -0400

> Tried with fvwm-2.2.5 and fvwm-2.3.22 - everything is fine.

I tried an rxvt and an xv with titlebars and pixmap border,
both worked fine.

ImageMagick 5.1.1, Exceed 6.1.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 16 May 2001 01:39:09 +0000

> ImageMagick 5.1.1, Exceed 6.1.

Can you try a more current ImageMagick by a chance?

For me "import -frame" works fine with fvwm-2.3.22 release and no rc.
And the same "import -frame" fails with fvwm-2.3.32 release and no rc.

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Tue, 15 May 2001 23:02:52 -0400

> Can you try a more current ImageMagick by a chance?

With 5.3.3 I got a cpu loop with an rxvt.
It didn't seem to growing, but I didn't watch it long.

The rest will have to wait til tomorrow, its getting late.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 16 May 2001 10:55:23 +0200

> Tried with fvwm-2.2.5 and fvwm-2.3.22 - everything is fine.

For me it works but does weird things (how do I find out the IM
version?).  With an rxvt window, the client part of the window is
shifted about 23.5 rows upwards and 10 columns to the left before
the image is captured.  With xterm it is the same.  An xv client
window is reduced to about 10 pixels in height before capturing.
The windows stay in the screwed up state until they get a
ConfigureNotify (e.g.  after moving or resizing the window).  The
frame is included in the image in both cases.

To me it seems that import is making assumptions about the
internal layout of the window manager frame and fiddles with
windows of other clients.  This looks pretty broken to me, but I
will look at what happens in fvwm anyway.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 16 May 2001 10:43:28 +0000

On 16 May 2001 10:55:23 +0200, Dominik Vogt wrote:
> version?).

% rpm -q ImageMagick
% import -help | head -1

> With an rxvt window, the client part of the window is

Yes, it seems that some client windows are resized first depending on the
original structure and size. Some clients don't survive this resizing.

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Wed, 16 May 2001 11:30:05 -0400

> It didn't seem to growing, but I didn't watch it long.

Giving it a really long time, it eventually completes,
using a serious amount of CPU.  It does capture the rxvt window
and its borders correctly.

> The rest will have to wait til tomorrow, its getting late.

With xv, for some reason, when I click in the xv window
it doubles the size of all the information in the xv window.
Other than that, it captures the borders without a problem
except that it cut off the right and bottom borders from the resized
window.

These tests were run on Solaris, using XSun.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 16 May 2001 16:44:47 +0200

> > For me it works but does weird things (how do I find out the IM

  ImageMagick-5.2.6-4

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 May 2001 22:40:51 +0200

> Tried with fvwm-2.2.5 and fvwm-2.3.22 - everything is fine.

Fixed.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]