Subject: Notification: incoming/714

From: [email-masked]
Date: Tue, 22 May 2001 10:13:21 -0500

FVWM Bug Tracking notification

new message incoming/714

Message summary for PR#714
	From: [email-masked]
	Subject: Java 1.2/1.3 problems with initial window size
	Date: Tue, 22 May 2001 10:13:14 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Tue May 22 10:13:21 2001
From: [email-masked]
To: [email-masked]
Subject: Java 1.2/1.3 problems with initial window size
Date: Tue, 22 May 2001 10:13:14 -0500

Full_Name: An Thi-Nguyen Le
Version: cvs
CVS_Date: May 20th
OS: Linux (kernel 2.2)
X_Server: XFree86 4.0.3
Submission from: (NULL) (128.174.0.218)

I noticed a problem that probably has its roots in bug report #664, 
and is demonstratable through Sun's beans development kit.  This bug 
does not appear in any other window manager I've tried, ranging from 
the simple (flwm) to the complex (enlightenment), so it's odd that it 
pops up in fvwm.

Instructions for reproducing:

1. Download the BDK from Sun.  I can send you the original zip archive 
   or a tar/gzipped archive.

2. Unarchive the BDK, and change into the beans directory.

3. Execute 'make run'.

4. Notice that there are three tiny windows: the Beanbox, the Toolbox,
   and the properties window, which definitely shouldn't be that size.  
   The other windows are of the right size.

5. Resize the windows. You might have to bind some form of Maximize to 
   a key stroke in order to be able to get a handle on the window to 
   resize it.  Everything works more or less properly from this point.

6. Now start up Xnest with an unused display:
     Xnest :1 &

7. Start up an xterm in it:
     xterm -display :1 &

8. In that xterm, start up another window manager, preferably something 
   light like wm2, flwm, aewm, or twm.
     twm &

9. In that xterm, enter the beans directory and make run.

10. Everything is happy on the first go for some reason.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 28 May 2001 11:08:42 +0200

>    or a tar/gzipped archive.

Whatever you mean with "BDK" (I could not find this name on the
Sun web page) I downloaded the Netbeans 3.2 executable
distribution.  It has not makefile anywhere and dumps core when I
try to run it.  All attempts to download the source distribution
ended in netscape crashes until now.  I'm still trying.  (Please
do *not* email the sources to me).

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: An Thi-Nguyen Le <[email-masked]>
Date: Mon, 28 May 2001 10:37:10 -0500

[Dominik Vogt - Mon, 28 May 2001 04:09:37 AM CDT]
> do *not* email the sources to me).

I meant the 'Beans Development Kit', from www.java.com.  For easy access, 
I am temporarily providing it at 

 http://srh1171.urh.uiuc.edu/~anle/misc/bdk1_1.zip

You need unzip.

-- 
An Thi-Nguyen Le
|FORTRAN is for pipe stress freaks and crystallography weenies.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 29 May 2001 16:46:55 +0200

>  http://srh1171.urh.uiuc.edu/~anle/misc/bdk1_1.zip

I have looked into what happens for hours, but I can't make any
sense of it.  These windows specifically request or are even 
created with the bogus size.  Sometimes they come up with the
correct width and a height of one or vice versa.  This seems to
be totally random.

I tried several other window managers.  The application behaved
well under icewm, olvwm and enlightenment but had the same problem
under blackbox.  The application is definitely freaking out, but I
do not understand why this happens with some window managers but
not with others.  There is little doubt that the same problem
would occur with other window managers if the application sent the
same size requests to them, but it doesn't.

Bye

Dominik ^_^  ^_^