Subject: Re: LDFLAGS or LD_OPTIONS or LDOPTS

From: "Dmitry Yu. Bolkhovityanov" <[email-masked]>
Date: Mon, 28 May 2001 11:12:15 +0700

On 27 May 01 at 9:21, [email-masked] wrote:

>
> Our INSTALL.fvwm file suggests that the user should export LDFLAGS
> on Solaris (for example).  The Solaris man pages for Solaris 2.6 and
> 2.8 identify LD_OPTIONS as the right variable.
> HPUX11.11 uses LDOPTS.  AIX 4.3 doesn't seem to have anything.
>
> Anyone know where LDFLAGS works?

    All the following supposes that you refer to Make (is there such a thing
as non-GNU autoconf?).

    Well, of course in GNU `Make' it is well documented ;-)

    * Solaris 2.5 (uname -sr: SunOS 5.5.1) make(1): mentions $(LDFLAGS) in
all LINK.* rules.

    * Digital UNIX (OSF1 V4.0) make(1):
        LDFLAGS
            For ld flags. Default is null.

    * IRIX (IRIX64 6.5) make(1):
        LFLAGS= LDFLAGS=
and later
        .c:
                $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $<

(what is interesting that it actually places $(LDFLAGS) *at the end* of
commandline:
    sky:~% export LDFLAGS=-zzz
    sky:~% make -n -f /dev/tty req
    req: req.c
    <Ctrl+D>
            cc -O -o req req.c -zzz
)

    * FreeBSD (very old, FreeBSD 2.2-970625-RELENG): make(1) doesn't mention
LDFLAGS, but it works exactly as specified in IRIX make(1).

    * OpenBSD (OpenBSD 2.7) behaves exactly as FreeBSD.

    * BSD/OS (BSD/OS 3.1, old -- 1998) doesn't mentions any *FLAGS (except
MAKEFLAGS) in man(1), doesn't seem to honour $LDFLAGS and "strings `which
make`" shows that the binary doesn't contain any references to it.

       ___________________________________________________________________
       Dmitry Yu. Bolkhovityanov  |  Novosibirsk, RUSSIA
       phone (383-2)-39-49-56     |  The Budker Institute of Nuclear Physics
                                  |  Lab. 5-13
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Mon, 28 May 2001 08:30:12 -0400

"Dmitry Yu. Bolkhovityanov" <[email-masked]> writes:
>     All the following supposes that you refer to Make

I feel dumb.  I was looking at ld options.  LDFLAGS seems to be
a standard part of make.

Thanks,
-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]