Subject: FVWM compilation fails when using autoconf 2.50

From: Heikki Kantola <[email-masked]>
Date: Sun, 27 May 2001 15:34:56 +0300 (EEST)

Configuration Information [Automatically generated, do not change]:
uname output: Linux cumulonimbus 2.2.18pre24 #1 Thu Nov 30 21:45:24 EET 2000 i686 unknown
Compiler: gcc
Compilation CFLAGS: -g -O2
prefix: /usr/local

FVWM Version:	2.3.33
FVWM_MODULEDIR:	/usr/local/libexec/fvwm
FVWM_DATADIR:	/usr/local/share/fvwm
FVWM_USERDIR:	unset

Description:
	I have been running CVS-versions of FVWM for quite some time,
	however in last few days the compilation has failed with:
	
	 In file included from ../libs/fvwmlib.h:19,
                 from Graphics.c:20:
	 ../config.h:145: #error The stuff above TOP goes to the top of 
	 config.h.in
	 ../config.h:146: #error What appears below BOTTOM goes to the bottom
	 ../config.h:147: #error This text should not appear anywhere!

	This seems to be caused by the new autoconf 2.50, which has 
	recently became the default autoconf version on Debian "unstable"
	distribution.

Repeat-By:
	Use autoconf 2.50 to generate config.in etc.

Fix:
	The ugly solution is of course to use autoconf 2.13.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 29 May 2001 19:20:10 +0000

> 	The ugly solution is of course to use autoconf 2.13.

It seems that autoheader in 2.50 was changed so it does not remove this
part anymore, so I disabled this #error part. The new version of autoconf
works well for me with no other changes, which is quite surprizing.

Still we should have autoconf-2.13 as a reference until we all together
move to autoconf-2.50. Probably immediately after opening fvwm-2.5.0.

Regards,
Mikhael.