Subject: Icon titles not retracting

From: An Thi-Nguyen Le <[email-masked]>
Date: Sun, 6 May 2001 01:06:46 -0500

Version: 2.3.32

When icons are focused on via the keyboard (e.g., binding 'Next [Iconic] Focus'
to a key sequence), the icon title expands (as expected), but when focus leaves
via the keyboard, the icon title stays expanded instead of contracting or
retracting or whatnot.  This doesn't appear to happen when focus enters and
leaves via the mouse.

-- 
An Thi-Nguyen Le
|As the poet said, "Only God can make a tree" -- probably because it's
|so hard to figure out how to get the bark on.
|		-- Woody Allen
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Alex Wallis <[email-masked]>
Date: Sun, 06 May 2001 19:21:21 +0930

> retracting or whatnot.  This doesn't appear to happen when focus enters and
With the most recent cvs I see this too, and also the icon title appears
to remain in the topmost layer above all other windows.

Alex

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 6 May 2001 15:26:30 +0200

On Sun, May 06, 2001 at 01:06:46AM -0500, An Thi-Nguyen Le wrote:
> to a key sequence), the icon title expands (as expected),

No, that's not expected at all.  Expanding the title should only
occur when the pointer enters the icon, it has nothing to do with
the focus.  It never occured to me that this could be useful.  Can
you please strip down your config file as much as possible so that
this still happens and send it along with step by step
instructions so that I can try to reproduce it here?  The simple
binding you gave does not show the bug for me.

> but when focus leaves

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 7 May 2001 11:27:30 +0200

On Mon, May 07, 2001 at 12:50:39AM +0930, Alex Wallis wrote:
> Dominik Vogt wrote:
> But when you use the pointer it hilights and expands as its supposed to.
> 
> > 
> > > but when focus leaves
> And then using Alt-Tab to switch to another window leaves the icon title
> expanded but without focus as the colorset changes in fvwm-themes easily
> demonstrates. The icon title is also in the uppermost layer, overlaying
> even xscreensaver. 
> 
> Is this normal? I kinda like it! ;)

Yes, that's absolutely correct.  As long as the pointer stays over
the icon, the title is not collapsed.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 7 May 2001 11:31:36 +0200

On Sun, May 06, 2001 at 11:30:53AM -0500, An Thi-Nguyen Le wrote:
> [Dominik Vogt - Sun,  6 May 2001 08:26:26 AM CDT]
> > the focus.  
> Ah, I should have been more explicit.  I have things set up so that 
> I focus *and* warp to the icon via the keyboard.  Here is a stripped 
> down configuration:
> 
>   Key Tab A C Function NextIconWarp
>   
>   DestroyFunc NextIconWarp
>   AddToFunc   NextIconWarp
>   + I Next (CurrentPage Iconic) Focus
>   + i Current WarpToWindow 50 50
> 
> Then 
>   1. iconify some windows with long icon names.  They will be initially 
>      contracted.
>   2. hit control-tab to go through them, which focuses and then warps
>      the pointer to each icon.  
>     
> The icon name of each window focus/warped in such a manner remains
> expanded and, as someone else noted, some of them seem to be in a layer
> higher than other windows.

Ah, yes, now I can see it too.  Thanks for the nice instructions.
Somehow fvwm misses that the pointer leaves the icon.  I will try
to fix that.  BTW, the expanded titles are indeed above all other
windows.  The purpose behind this to improve their visibility.
 
Bye

Dominik ^_^  ^_^

---

From: Alex Wallis <[email-masked]>
Date: Mon, 07 May 2001 19:26:24 +0930

> the icon, the title is not collapsed.
But with fvwm-themes at least, Alt-Tab warps the pointer to the window,
allowing free movement of the mouse to other windows and desks/pages,
while the icon title remains still expanded and raised?
In other words it doesn't collapse until it is mouse'd over again. And
moving the pointer into a thusly raised icon title then raises the icon
to the topmost layer too. If you just leave the icon normally with mouse
movement, it behaves normally. It is only moving the pointer from the
icon via a keyboard event.

Alex

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 7 May 2001 13:47:09 +0200

> windows.  The purpose behind this to improve their visibility.

Fixed.

Bye

Dominik ^_^  ^_^