Subject: Notification: incoming/711

From: [email-masked]
Date: Fri, 04 May 2001 14:59:00 -0500

FVWM Bug Tracking notification

new message incoming/711

Message summary for PR#711
	From: [email-masked]
	Subject: Unbinding keys
	Date: Fri, 04 May 2001 14:58:58 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Fri May 04 14:59:00 2001
From: [email-masked]
To: [email-masked]
Subject: Unbinding keys
Date: Fri, 04 May 2001 14:58:58 -0500

Full_Name: Ben Gamsa
Version: 2.3.31
CVS_Date: 
OS: RedHat 7/Linux 2.4.1
X_Server: XFree86 4001
Submission from: (NULL) (216.126.67.39)

Unbinding a key by supplying the command "-" to a key binding command
only seems to fully take effect for new windows created after unbinding
the key.  The original effect of the key binding is removed for all
windows, but the key doesn't seem to be passed through to any of the
existing windows.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 6 May 2001 15:15:58 +0200

> windows, but the key doesn't seem to be passed through to any of the

This works perfectly for me:

  key f6 w s move

(hit shift-f6 over a shell window, the move cursor appear)

  key f6 w s -

(hit shift-f6 over a shell window, the escape sequence is printed
into the window)

Please provide an example that shows the symptom.  As a last
resort you can use the Recapture command to redo all key and
mouse bindings on all windows.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 7 May 2001 15:03:43 +0200

On Sun, May 06, 2001 at 10:52:51AM -0400, Ben Gamsa wrote:
> Dominik Vogt wrote:
> With the following as my .fvwmrc file:
> 
> key f6 w s move
> Key   F10       FTIWS   N       key f6 w s move
> Key   F10       FTIWS   C       key f6 w s -
> 
> S-F6 initially works to move the window.  I then hit C-F10 and
> S-F6 then does nothing, including not putting the escape sequence
> into the xterm.  Hitting F10 will turn on the move-windows function,
> and C-F10 again will cause the key to do nothing.
> 
> If however, I just have
> 
> Key   F10       FTIWS   N       key f6 w s move
> Key   F10       FTIWS   C       key f6 w s -
> 
> Then S-F6 initially causes the xterm to print the escape sequences,
> hitting F10 causes the move function to work, and hitting C-F10
> causes the escape sequences to appear.
> 
> On the otherhand, as you suggested, if I have the following:
> 
> key f6 w s move
> Key   F10       FTIWS   N       key f6 w s move
> Key   F10       FTIWS   C       key f6 w s -
> Key   F10       FTIWS   1       Recapture
> 
> Then turning off the move binding does not let the function key
> through to the xterm, but doing a M-F10 to Recapture does fix it
> so that the xterm sees the function key.
> 
> I tested these latest examples using fvwm-2.3.32 under RedHat 6.0
> kernel 2.2.5-15 using Xnest and a .fvwmrc file with nothing but
> what I listed above for each example.
> 
> I hope this helps isolate the problem.

I had already given up trying to reproduce this but then I got it
too.  This problem seems to be a specific xterm problem:

 1) Make the settings above.
 2) Start an xterm.
 3) Follow the procedure above.

==> Problem is there.

 1) Start an xterm.
 2) Make the settings above.
 3) Follow the procedure above.

==> everything is fine.

Use rxvt, aterm, Eterm or wterm instead of xterm and it works all
the time.  It seems that xterm looks at the key combinations that
are grabbed on its window by some other application upon startup
and ignores them even after they are unbound.  Let me think about
this.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "Ben Gamsa" <[email-masked]>
Date: Sun, 06 May 2001 10:52:51 -0400

key f6 w s move

If however, I just have

key f6 w s move

	ben

---

From: Ben Gamsa <[email-masked]>
Date: Mon, 07 May 2001 12:51:29 -0400

[ Apologies if you get this twice; my mailer crashed on sending it. ]

> too.  This problem seems to be a specific xterm problem:

It seems to be more than just an xterm problem.  I noticed when testing
with xev, that when I unbound the key, it would see a keypress for
F6 and the shift key, then it would get some extra focus events and
then a release for the shift key but no release for the F6 key.  I
also found that xemacs wouldn't see the function key after unbinding it.

> and ignores them even after they are unbound.  Let me think about

Ok, thanks.  At least for now, the Recapture seems to work well enough.

	ben

---

From: Ben Gamsa <[email-masked]>
Date: Mon, 07 May 2001 09:53:41 -0400

ben

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 29 May 2001 22:19:36 +0200

> also found that xemacs wouldn't see the function key after unbinding it.

I don't have the slightest idea why, but the order in which keys
are grabbed seem to play a role.  If we grab all keys on the
client window first an then all keys on the decorations, the bug
is there.  If keys are grabbed on all parts of the windows
simultaneously, the problem goes away.  Althoug I don't understand
why, we have a fix at last.

Bye

Dominik ^_^  ^_^