Subject: fvwm2 = broken wm?

From: Andre Bonhote <[email-masked]>
Date: Tue, 29 May 2001 16:29:22 +0200

hi workers!

the sentence in the subject is *NOT* my opinion! that's for sure!

i just found a funny lil program called "wmfishtime" [1] which does
nothing than display a clock. when i start it under my fvwm2 [2], it
just shows a gray box.

in the tarfile, there's also a file called "ALL_I_GET_IS_A_GRAY_BOX"
which refers to the INSTALL file. there it says that my windowmanager
sucks because it's broken, i should use -b to run it.

i don't really know much about c programming, even less about
xwindows-coding. all i found in fishmon.c was this:

...
 /* actually draw the rgb buffer to screen */
  if (!broken_wm)
      gdk_draw_rgb_image(bm.iconwin, bm.gc, 4, 4, 56, 56,
        GDK_RGB_DITHER_NONE, bm.rgb, 56 * 3);
  else
      gdk_draw_rgb_image(bm.win, bm.gc, 4, 4, 56, 56,
        GDK_RGB_DITHER_NONE, bm.rgb, 56 * 3);
    }
...

that's it. i don't know what's so bad bout using either of these
methods. but the author of this program says my fvwm2 sucks, and i
wanted you to know. perhaps there's really a bug or sth you didn't
notice.

thx

andré

[1]: 
http://www.ne.jp/asahi/linux/timecop/
http://www.ne.jp/asahi/linux/timecop/software/wmfishtime-1.23.tar.gz

[2]:
FVWM version 2.3.33 compiled on May 28 2001 at 15:40:08
with support for: ReadLine, XPM, GNOME WM hints, SM

-- 
The clansmen of my elders have come!
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 29 May 2001 15:02:09 +0000

> http://www.ne.jp/asahi/linux/timecop/software/wmfishtime-1.23.tar.gz

This app is broken itself, although funny. :)
It ignores delete window protocol, so only Destroy works on it.

It lists E and kwm as broken WMs too, but I see nothing broken here.
It asks to draw on the icon window not on the main window, so if you
iconify wmfishtime (without -b) in normal WMs, you will see an animation.

The --broken option should be correctly named --not-in-icon.
And I think it should be a default, while --in-icon may be an option.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 29 May 2001 17:16:49 +0200

> iconify wmfishtime (without -b) in normal WMs, you will see an animation.

It simply does not request to be iconig.  If I change this line

    wmhints.initial_state = WithdrawnState;

to this, all works well:

    wmhints.initial_state = IconicState;

Furthermore the applications uses the USSize hint without user
request which is absolutely forbidden.  I think I'll send a patch
to the author.

> And I think it should be a default, while --in-icon may be an option.

Right.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 29 May 2001 17:09:15 +0200

> sucks because it's broken, i should use -b to run it.

Gee, and that from a person who names a simple, uncompressed atar
archive .tar.gz :-)

> wanted you to know. perhaps there's really a bug or sth you didn't

If the author said *what* the bug was he would be much more helpful.

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 29 May 2001 18:28:56 +0000

> Gee, and that from a person who names a simple, uncompressed atar

This is probably a misfeature of Netscape, which uncompresses the archive
on the fly, but don't change the file name from .tar.gz to .tar.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 29 May 2001 21:04:01 +0200

> on the fly, but don't change the file name from .tar.gz to .tar.

Yes.  At work netscape unzipped it, at home it didn't.  Pretty
strange behaviour for two installations off the same CD with the
same config file.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Jason Thomas <[email-masked]>
Date: Wed, 30 May 2001 09:56:25 +1000

> > And I think it should be a default, while --in-icon may be an option.

that would be excellent, I packaged it for debian and then handed over
to Marcel May <[email-masked]>, he is still working on the
package, it is yet to be put into debian.

here's an some code from wmtime which I think does a similiar thing.
It looks like it just draws both.

void RedrawWindow(void) {
        
        flush_expose(iconwin);
        XCopyArea(display, wmgen.pixmap, iconwin, NormalGC, 
                                0,0, wmgen.attributes.width, wmgen.attributes.he
ight, 0,0);
        flush_expose(win);
        XCopyArea(display, wmgen.pixmap, win, NormalGC,
                                0,0, wmgen.attributes.width, wmgen.attributes.he
ight, 0,0);
}

wonder if that's a solution. I don't really know much about this stuff.

-- 
Jason Thomas                           Phone:  +61 2 6257 7111
System Administrator  -  UID 0         Fax:    +61 2 6257 7311
tSA Consulting Group Pty. Ltd.         Mobile: 0418 29 66 81
1 Hall Street Lyneham ACT 2602         http://www.topic.com.au/

---

From: [email-masked]
Date: Thu, 31 May 2001 07:18:05 +0900 (JST)

> It looks like it just draws both.
No shit, sherlock. And that's the problem. Try drawing the same shit
twice 33 times a second, when the user only sees one? This behaviour will
stay the same way, however I plan to include the position / size hint
changes, and also replace -b with "withdrawn" | "normal window". There is
little point supporting iconic stuff.

tim
> wonder if that's a solution. I don't really know much about this stuff.
If you have a PIII1024 you probably wouldn't care.

-- 
・‥…━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━…‥・
     timecop at japan.co.jp | ＯＡ通信サービス株式会社 | NTT DoCoMo
  I thought everything that Linus Torvalds is involved with was divine
  perfection? Must be a problem with NEC and Sony -about Crusoe recall
・‥…━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━…‥・