Subject: Notification: incoming/707

From: [email-masked]
Date: Mon, 09 Apr 2001 11:35:02 -0500

FVWM Bug Tracking notification

new message incoming/707

Message summary for PR#707
	From: [email-masked]
	Subject: window not properly decorated, internal errors...
	Date: Mon, 09 Apr 2001 11:34:57 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Mon Apr 09 11:35:02 2001
From: [email-masked]
To: [email-masked]
Subject: window not properly decorated, internal errors...
Date: Mon, 09 Apr 2001 11:34:57 -0500

Full_Name: Eric Ding
Version: 2.2.5
CVS_Date: 
OS: RedHat Linux 6.2
X_Server: XFree86 4.0.2
Submission from: (NULL) (192.229.37.90)

I'm running a Java application which pops up a new window corresponding
to a "floating" toolbar.  When I try to pop up the window, I get console
errors from fvwm2, the window comes up without decorations, and a small
bordered window appears in the upper left hand corner.  The errors I see
in the console:

[FVWM][FvwmErrorHandler]: <<ERROR>> *** internal error ***
[FVWM][FvwmErrorHandler]: <<ERROR>> Request 1, Error 2, EventType: 20
[FVWM][FvwmErrorHandler]: <<ERROR>> *** internal error ***
[FVWM][FvwmErrorHandler]: <<ERROR>> Request 12, Error 2, EventType: 20
[FVWM][FvwmErrorHandler]: <<ERROR>> *** internal error ***
[FVWM][FvwmErrorHandler]: <<ERROR>> Request 12, Error 2, EventType: 23

The empty bordered window returns nothing in xprop, and xwininfo -all
returns the following:

xwininfo: Window id: 0x8000e5 (has no name)

  Root window id: 0x31 (the root window) (has no name)
  Parent window id: 0x31 (the root window) (has no name)
     3 children:
     0x8000e9 (has no name): ()  17x17+-17+5  +-16+6
     0x8000e8 (has no name): ()  17x17+-17+5  +-16+6
     0x8000e7 (has no name): ()  1x17+-10+5  +-9+6

  Absolute upper-left X:  1
  Absolute upper-left Y:  1
  Relative upper-left X:  1
  Relative upper-left Y:  1
  Width: 10
  Height: 27
  Depth: 24
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x20 (installed)
  Bit Gravity State: ForgetGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +1+1  -1269+1  -1269-996  +1-996
  -geometry 10x27+1+1

  Bit gravity: ForgetGravity
  Window gravity: NorthWestGravity
  Backing-store hint: NotUseful
  Backing-planes to be preserved: 0xffffffff
  Backing pixel: 0
  Save-unders: No

  Someone wants these events:
      ButtonPress
      ButtonRelease
      EnterWindow
      LeaveWindow
      Exposure
      VisibilityChange
      SubstructureRedirect
  Do not propagate these events:
  Override redirection?: No

  No window manager hints defined

  No normal window size hints defined
  No zoom window size hints defined

  No window shape defined
  No border shape defined

For the borderless toolbar window, xwininfo -all and xprop return the
following:
xwininfo: Window id: 0x2200079 "Recording User Actions"

  Root window id: 0x31 (the root window) (has no name)
  Parent window id: 0x31 (the root window) (has no name)
     1 child:
     0x220007a (has no name): ()  224x28+0+0  +1+1
        1 child:
        0x220007b (has no name): ()  224x28+0+0  +1+1
           1 child:
           0x220007c (has no name): ()  224x28+0+0  +1+1

  Absolute upper-left X:  1
  Absolute upper-left Y:  1
  Relative upper-left X:  1
  Relative upper-left Y:  1
  Width: 224
  Height: 28
  Depth: 24
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x20 (installed)
  Bit Gravity State: ForgetGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +1+1  -1055+1  -1055-995  +1-995
  -geometry 224x28+1+1

  Bit gravity: ForgetGravity
  Window gravity: NorthWestGravity
  Backing-store hint: NotUseful
  Backing-planes to be preserved: 0xffffffff
  Backing pixel: 0
  Save-unders: No

  Someone wants these events:
      KeyPress
      KeyRelease
      EnterWindow
      LeaveWindow
      Exposure
      StructureNotify
      FocusChange
      PropertyChange
      ColormapChange
  Do not propagate these events:
      ButtonPress
      ButtonRelease
  Override redirection?: No

  Window manager hints:
      Client accepts input or input focus: Yes
      Initial state is Normal State

  Normal window size hints:
      Program supplied location: -3185, -1002
      Program supplied size: 224 by 28
      Program supplied minimum size: 0 by 0
      Program supplied maximum size: 0 by 0
      Program supplied window gravity: NorthWestGravity
  No zoom window size hints defined

  No window shape defined
  No border shape defined

[eding@wus-eding001 eding]$ xprop
WM_STATE(WM_STATE):
                window state: Normal
                icon window: 0x0
_MOTIF_DRAG_RECEIVER_INFO(_MOTIF_DRAG_RECEIVER_INFO) = 0x6c, 0x0, 0x5, 0x8,
0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x8c, 0x8, 0x10, 0x0, 0x0, 0x0
_MOTIF_WM_MESSAGES(ATOM) = _MOTIF_WM_OFFSET
WM_PROTOCOLS(ATOM): protocols  _MOTIF_WM_MESSAGES, WM_DELETE_WINDOW,
WM_TAKE_FOCUS
_MOTIF_WM_HINTS(_MOTIF_WM_HINTS) = 0x3, 0x2c, 0x3a, 0xffffffff, 0x0
WM_CLIENT_LEADER(WINDOW): window id # 0x2200079
WM_LOCALE_NAME(STRING) = "en_US"
WM_CLASS(STRING) = "AWTapp", "VendorShell"
WM_HINTS(WM_HINTS):
                Client accepts input or input focus: True
                Initial state is Normal State.
WM_NORMAL_HINTS(WM_SIZE_HINTS):
                program specified location: -3185, -1002
                program specified size: 224 by 28
                program specified minimum size: 0 by 0
                program specified maximum size: 0 by 0
                window gravity: NorthWest
WM_CLIENT_MACHINE(STRING) = "wus-eding001"
WM_NAME(STRING) = "Recording User Actions"

The application works without a problem in Sawmill 0.24 (as distributed
with Ximian Gnome).

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 14 Apr 2001 21:27:34 +0200

On Mon, Apr 09, 2001 at 11:35:02AM -0500, fvwm-bug wrote:
> Received: from karazm.math.uh.edu ([129.7.128.1])
> 	by malifon.math.uh.edu with esmtp (Exim 3.20 #1)
> 	id 14med4-0006VY-00
> 	for [email-masked]; Mon, 09 Apr 2001 11:35:02 -0500
> Received: from malifon.math.uh.edu (IDENT:[email-masked] [129.7.128.13])
> 	by karazm.math.uh.edu (8.9.3/8.9.3) with ESMTP id LAA01733
> 	for <[email-masked]>; Mon, 9 Apr 2001 11:35:01 -0500 (CDT)
> Received: from localhost ([127.0.0.1] ident=65534)
> 	by malifon.math.uh.edu with esmtp (Exim 3.20 #1)
> 	id 14mecz-0006VU-00
> 	for [email-masked]; Mon, 09 Apr 2001 11:34:57 -0500
> To: [email-masked]
> Message-Id: <[email-masked]>

Well, that's very hard to debug without the application.  Can I
lay my hands on it somehow?  Could you also try the current beta
release (2.3.31) and see if it still has the same problem?

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Eric Ding <[email-masked]>
Date: Sat, 14 Apr 2001 23:20:40 -0400

Hi Dominik,

I couldn't find a way to add this to the bug... I realized that the
problem occurs when we, using Java 2 and the Swing widget kit, set the
visible attribute to false before setting the resizable attribute to
true.  If we call setVisible(false) after calling setResizable(true),
then all is well.

I'll see if I can write a quick and dirty sample app sometime next week
that y'all could run with the Blackdown.org JRE.

Eric

>>>>> Dominik Vogt <[email-masked]> writes:

---

From: Eric Ding <[email-masked]>
Date: Wed, 18 Apr 2001 11:31:10 -0400

Hi Dominik,

I've included below a sample Java application (source code) that tickles
the bug in fvwm 2.2.5.  I haven't had the time to try this out with the
latest FVWM2 beta version, so I don't know if it works from there.

Eric

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 19 Apr 2001 11:05:16 +0200

> latest FVWM2 beta version, so I don't know if it works from there.

I tried to compile and run this, but I get an error:

  luthien: ~ 1 > javac HelloWorldApp.java 
  HelloWorldApp.java:13: Package javax.swing not found in import.
  import javax.swing.*;
         ^
  1 error

I guess I have to install swing here.  Where do I get that (Linux
2.4 PC w/ SuSE 7.1)?

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 21 Apr 2001 09:02:23 -0500

> I guess I have to install swing here.  Where do I get that (Linux

Final swing is included with recent java (1.3), so you may upgrade jdk.
I used rpm from Caldera (works well on RedHat, and maybe on SuSE):

  http://rpmfind.net/linux/RPM/openlinux/ltp/col/install/RPMS/jdk-1.3-11.i386.html
  http://rpmfind.net/linux/RPM/openlinux/ltp/col/install/RPMS/jre-1.3-11.i386.html

These rpms have all files in /opt/java-1.3/.
  PATH=/opt/java-1.3/bin:$PATH
  JAVA_HOME=/opt/java-1.3

After running this test app: "java -cp . HelloWorldApp" for the first time
the window appears for me, but it disappears shortly on the following runs.
I don't get "*** internal error ***".

Regards,
Mikhael.