Subject: Re: Markus Grunwald: Re: FVWM: Quick hint please...

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 4 Apr 2001 10:25:45 -0500

On 04 Apr 2001 17:08:52 +0200, Dominik Vogt wrote:
> 
> On Wed, Apr 04, 2001 at 08:48:50AM -0500, Mikhael Goikhman wrote:
> > 
> > You should get the message on your standard error: [FVWM][AddToFunction]:
> > <<ERROR>> Got 'Click' instead of a valid function specifier
> > 
> > The man page suggests to use M, H, C and D letters for specifiers.
> > I am not sure whether we should support the old syntax ("Click", "Motion").
> > In 2.2 versions even word "Close" would pass as "Click", now it does not.
> 
> Well, using more than a single letter was never officially
> supported, but many config files had it in the past.  I can't
> remember when or why this was changed, but it probably happened by
> accident.

This was done on purpose, not to allow commands started with these 5
letters to be taken as specifiers. If you want to restore this unsupported
old syntax (I don't think this is needed), you may add 5 string
constants ("Click" and so on) in functions.h and check against them.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 4 Apr 2001 18:47:25 +0200

> constants ("Click" and so on) in functions.h and check against them.

The config files coming with SuSE still use that old 'syntax' and
thus many config files will be broken.  I see thre possible
solutions:

 1) Disallow the old syntax completely, enhance fvwm24_convert to
    make all necessary changes and add a comprehensive error
    message explaining the change.
 2) Restore the old behaviour.
 3) Allow multi letter specifiers but print a warning if the token
    is the name of a built in command or a function.

In my eyes, (3) is the best solution to have compatibility *and*
enhanced error checking.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mike Fabian <[email-masked]>
Date: 04 Apr 2001 18:58:04 +0200

Dominik Vogt <[email-masked]> writes:

> thus many config files will be broken.

I fixed this for SuSE 7.2.

-- 
Mike Fabian   <[email-masked]>   http://www.suse.de/~mfabian

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 4 Apr 2001 12:41:16 -0500

>     is the name of a built in command or a function.

(2) is problematic. (3) seems as overhead to me.
I would do either (1) or (4):

4) Allow only 10 case insensitive words, "C", "Click" etc.
   Optionally print an "obsolete syntax" warning on the full word.

> In my eyes, (3) is the best solution to have compatibility *and*

I am not against (3) if there is no time penalty for correct specifiers.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 5 Apr 2001 10:59:53 +0200

> (2) is problematic. (3) seems as overhead to me.

Actually, (3) is trivial to code but costs the time spent
searching for function or command names for long specifiers.

> I am not against (3) if there is no time penalty for correct specifiers.

I already comitted the change yesterday.  For one letter
specifiers there is no change to the old stuff and no penalty.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 5 Apr 2001 08:21:13 -0500

> specifiers there is no change to the old stuff and no penalty.

You commited a change for the problematic (2).
I can do (3) or (4), just tell me which you prefer.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 5 Apr 2001 16:25:34 +0200

> I can do (3) or (4), just tell me which you prefer.

Er, the second patch is lying on my disk at home.  Apparently I
forgot to commit it.

Bye

Dominik ^_^  ^_^