Subject: Next and Prev on window id's

From: Joshua Redstone <[email-masked]>
Date: Tue, 17 Apr 2001 14:40:07 -0700

In case anyone's interested, I found a useful hack to fvwm is to
make Next and Prev commands match on window id's as well as the other
window properties it matches on.  This allows one to write a module
that implementes a fancier version of window cycling (choosing which
window to switch to) then is possible with just Next and Prev.  The mod to
fvwm/buitins.c is adding the lines:

  {
     char tmpid[200];
     sprintf(tmpid, "%x", fw->w);
     fMatchesName |= (strcmp(mask->name, tmpid) == 0);
  }

to MatchesConditionMask in the appropriate place.

Cheers.

josh

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 18 Apr 2001 10:26:07 +0200

> to MatchesConditionMask in the appropriate place.

You can simply use the WindowId command instead:

  WindowId 0x12345678 focus

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Joshua Redstone <[email-masked]>
Date: Wed, 18 Apr 2001 11:24:14 -0700

Thanks.  Ooops.  I totall7y missed that one.
josh