Subject: Small bug with pixmap decorations

From: Heikki Kantola <[email-masked]>
Date: Sun, 8 Apr 2001 15:14:13 +0300 (EEST)

Configuration Information [Automatically generated, do not change]:
uname output: Linux cumulonimbus 2.2.18pre24 #1 Thu Nov 30 21:45:24 EET 2000 i686 unknown
Compiler: gcc
Compilation CFLAGS: -g -O2
prefix: /usr/local

FVWM Version:	2.3.32
FVWM_MODULEDIR:	/usr/local/libexec/fvwm
FVWM_DATADIR:	/usr/local/share/fvwm
FVWM_USERDIR:	unset

Description:
	If you have set pixmap decoration for active window titles, but
	not for inactive windows, the pixmap is still shown also in
	inactive window when you move focus directly to some other 
	window. If moving pointer (and focus) from an active window into
	root window there is no similar problem.

Repeat-By:
	The offending decoration is:
	
	AddToDecor "Default"
	+ ButtonStyle All --  UseTitleStyle
	# small up triangle
	+ ButtonStyle 2 4 50x35@1 65x65@0 35x65@0 50x35@1
	# small down triangle
	+ ButtonStyle 4 4 50x65@1 35x35@1 65x35@1 50x65@0
	+ ButtonStyle 1 MiniIcon
	+ TitleStyle ActiveUp TiledPixmap paper.xpm
	+ TitleStyle ActiveDown TiledPixmap paper.xpm
	+ BorderStyle Inactive Solid black
	
	And the focus policy is the default, MouseFocus.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 8 Apr 2001 15:15:12 +0200

> 	And the focus policy is the default, MouseFocus.

Fixed.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]