Subject: Parent Colorset background is not reused in FvwmButtons

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 14 Apr 2001 07:55:21 -0500

If there is a container without the Colorset definition, the parent pixmap
background (defined by Colorset in parent) is not used for buttons (unless
the button itself has Colorset definition). IMO, this is incorrect.

Rewording: there is global Colorset, there is container without Colorset,
there is button without Colorset => solid global Colorset bg is used, but
not its Pixmap or XGradient.

To see this, just add a Container around any single button.
It is tricky to do this in Dominik's FvwmButtons sample, because it uses
position coordinates, so replacing a line

  *FvwmButtons: (3x2+6+1, Icon my_move.xpm, Action Move)

with

  *FvwmButtons: (3x2+6+1, Padding 0 0, Container (Columns 1, Rows 1))
  *FvwmButtons: (1x1, Icon my_move.xpm, Action Move)
  *FvwmButtons: (End)
  
does not work.
I would expect this to work, like it works without position coordinates.

I have managed to insert a container by commenting global Rows and Columns
lines and adding one container over all buttons:

  #*FvwmButtons: Rows     5
  #*FvwmButtons: Columns  68
  *FvwmButtons: (Padding 0 0, Container (Columns 68, Rows  5))
  ... all buttons ...
  *FvwmButtons: (End)

This problem is not critical, because there is a workaround - adding an
explicit Colorset in Container.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 14 Apr 2001 08:12:27 -0500

> explicit Colorset in Container.

Actually, this workaround does not give exactly the same result.
With it, a colorset rectangle is limited to a container, while it is
somewhat expected that a container without Colorset would be transparent,
like any non-container buttons without Colorset.

Should this be a feature request?

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 14 Apr 2001 21:07:43 +0200

> not its Pixmap or XGradient.

Yes, containers do not inherit the colour set from the parent.  We
would probably need an option like 'ParentRelative'.  Colour sets
do not support using parts of a global background inside smaller
rectangles thus faking transparency.

But that's nothing to do before 2.4.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]