Subject: CVS migo: * fixed a core dump in menus with ampersand-tab

From: FVWM CVS <[email-masked]>
Date: Fri, 06 Apr 2001 19:34:36 -0500

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	migo	01/04/06 19:34:36

Modified files:
	.              : ChangeLog 
	fvwm           : fvwm2.1 menus.c 

Log message:
* fixed a core dump in menus with ampersand-tab
* fvwm2.1: use bold instead of quotes in "initialization functions" section

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 7 Apr 2001 11:14:30 +0200

> * fixed a core dump in menus with ampersand-tab

What was the problem and the fix?

> * fvwm2.1: use bold instead of quotes in "initialization functions" section

That breaks consistency with the rest of the man page.  Names which
can be chosen by the user are always put in double quotes.  Since
function names are usually not predefined by fvwm, the start up
functions have to use the same funt and quoting as other function
names.  So either we back out that change or remove the quoting of
all other function names too.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 7 Apr 2001 10:48:16 -0500

>From ChangeLog:
	* fvwm/menus (scanForHotkeys):
	don't set hotkey if a string after a mark is empty, this fixes the
	core dump later in draw_underline(txt=0x0) -> XTextWidth()

% cvs diff -D 07-Apr-2001 -D 08-Apr-2001 fvwm/menus.c
        /* It's a hot key marker - work out the offset value */
        MI_HOTKEY_COFFSET(it) = txt - start;
        MI_HOTKEY_COLUMN(it) = column;
-       MI_HAS_HOTKEY(it) = 1;
+       MI_HAS_HOTKEY(it) = (txt[1] != '\0');
        MI_IS_HOTKEY_AUTOMATIC(it) = 0;
        for (; *txt != '\0'; txt++)
        {

> all other function names too.

You speak about examples, which is not what I changed.

In the section, which I rewrote 2 years ago, I replaced "InitFunction"
with .B InitFunction and other 6 function names, which are not changable
by a user. I see that StrokeFunc is bold too, I would also add bold to
UrgencyFunc and WindowListFunc for consistency.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 7 Apr 2001 19:46:46 +0200 (MEST)

> UrgencyFunc and WindowListFunc for consistency.

I'm not really concerned about bold or double quotes, only about
consistency.

  (a) All user settable names should bet typeset the same.
  (b) All function names should be typeset the same.
  (c) Some function names are user settable.

 ==>

  (d) Alle function names should be typeset like all user
  settable names.

Not that I care much about readability. There is one minor
reason why I would prefer double quotes over bold and thas
is that bold font is already used excessively in the man
page, so double quoting may be less confusing.

Bye

Dominik ^_^ ^_^

-- 
GMX - Die Kommunikationsplattform im Internet.
http://www.gmx.net

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 7 Apr 2001 17:22:41 -0500

> page, so double quoting may be less confusing.

For me bold for the definied term is less confusing than quotes.
I think we may use different styles in the definition and references.
But I don't worry and if you think otherwise, just change it.

Regards,
Mikhael.