Subject: Notification: incoming/703

From: [email-masked]
Date: Sat, 10 Mar 2001 07:28:46 -0600

FVWM Bug Tracking notification

new message incoming/703

Message summary for PR#703
	From: [email-masked]
	Subject: xmms and singit plugin (coredump of fvwm)
	Date: Sat, 10 Mar 2001 07:28:45 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Sat Mar 10 07:28:46 2001
From: [email-masked]
To: [email-masked]
Subject: xmms and singit plugin (coredump of fvwm)
Date: Sat, 10 Mar 2001 07:28:45 -0600

Full_Name: Tilmann Bitterberg
Version: 2.3.29
CVS_Date: 
OS: GNU/Linux 2.4
X_Server: XFree86 4.0.2
Submission from: (NULL) (193.196.136.173)

Hi

This didn't happened with version 2.3.28. It is reproducible. When I start
xmms with the singit! plugin, which displays the text to the song fvwm2
coredumps and kills X. I don't use gnome.

If you need more info, I am happy to help

Detailed Info:
$ fvwm2 -version
FVWM version 2.3.29 compiled on Mar  8 2001 at 11:08:39
with support for: ReadLine, Stroke, XPM, GNOME WM hints, SM
$ file core
core: ELF 32-bit LSB core file of 'fvwm2' (signal 11), Intel 80386, ..
$ gdb /usr/local/bin/fvwm2 ./core
[...]
(gdb) where
#0  0x806401e in mark_transient_subtree (t=0x80c16b0, layer=4, mark_mode=0,

    do_ignore_icons=1, use_window_group_hint=0) at stack.c:1157
#1  0x80640f3 in collect_transients_recursive (t=0x80c16b0, 
    list_head=0xbffff0b4, layer=4, do_lower=0) at stack.c:1203
#2  0x80641a9 in new_layer (tmp_win=0x80c16b0, layer=6) at stack.c:1239
#3  0x80869ad in GNOME_ProcessClientMessage (fwin=0x80c16b0, ev=0x80991a0)
    at gnome.c:895
#4  0x8065996 in HandleClientMessage () at events.c:823
#5  0x8067d8e in DispatchEvent (preserve_Tmp_win=0) at events.c:2676
#6  0x8067e28 in HandleEvents () at events.c:2729
#7  0x8083d2e in main (argc=1, argv=0xbffff8bc) at fvwm.c:751
#8  0x40175c7f in __libc_start_main (main=0x8082990 <main>, argc=1, 
    argv=0xbffff8bc, init=0x804b0c8 <_init>, fini=0x808e14c <_fini>, 
    rtld_fini=0x4000c2c0 <_dl_fini>, stack_end=0xbffff8b4)
    at ../sysdeps/generic/libc-start.c:92
(gdb)

Tilmann

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 10 Mar 2001 19:50:46 +0100

>     at ../sysdeps/generic/libc-start.c:92

I see.  I think I have fixed this.  Please try the next snapshot
or CVS code and see if it's gone.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tilmann Bitterberg <[email-masked]>
Date: Sun, 11 Mar 2001 12:01:21 +0100 (CET)

>> If you need more info, I am happy to help

[..]

>or CVS code and see if it's gone.

I am now running fvwm-snap-20010310 and it still persists.
Basically the same gdb backtrace.

If I compile with --disable-gnome, everything is fine. Maybe I
should do that.

Tilmann
-- 
If something can go wrong, it w
fortune: segmentation fault.  core dumped

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 11 Mar 2001 16:59:44 +0100

> If I compile with --disable-gnome, everything is fine. Maybe I

Nope, just use the next snapshot.  The snapshots are generated
only once per day, so you have to wait up to 24 hours to be sure
you get a certain patch.  My changes have not made it into the
0310 snapshot.

Bye

Dominik ^_^  ^_^