Subject: broken titlebar button presses with complex functions

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 22 Mar 2001 10:52:28 -0600

This is broken recently. Consider this minimal rc file:

# --------------------------------------------------------------------
DestroyFunc FuncFvwmMaximize
AddToFunc   FuncFvwmMaximize
+ M Beep  # originally: Nop
+ H Maximize 0 95
+ C Maximize 100 95
+ D Maximize 100 100

DestroyFunc FuncFvwmMaximizeVertically
AddToFunc   FuncFvwmMaximizeVertically
+ H Maximize 0 100
+ M Maximize 0 100
+ C Maximize 0 100

DestroyFunc FuncFvwmMaximizeHorizontally
AddToFunc   FuncFvwmMaximizeHorizontally
+ H Maximize 100 0
+ M Maximize 100 0
+ C Maximize 100 0

Mouse 1  4  A  FuncFvwmMaximize
Mouse 2  4  A  FuncFvwmMaximizeVertically
Mouse 3  4  A  FuncFvwmMaximizeHorizontally
# ====================================================================

"H" does not work for Mouse 1 and Mouse 2, but works for Mouse 3.
"C" does not work for Mouse 2.
These cases are ignored. Other cases work.

One more problem:

# --------------------------------------------------------------------
DestroyFunc FuncFvwmIconifySameResource
AddToFunc   FuncFvwmIconifySameResource
+ I All ($r) Iconify $0

Mouse 2  6  A  FuncFvwmIconifySameResource on
# ====================================================================

This works (immediately on press), but a mouse release is passed to an
application below, causing (in this case) a clipboard text to be copied to
other window.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 22 Mar 2001 18:22:13 +0100

> This is broken recently. Consider this minimal rc file:

No, it's the parsing that is broken, not complex functions.  I did
not realise that '0' and '1' can not be used as toggle arguments
because they are numbers and will break the parsing patterns for
maximize and probably other commands too.

> One more problem:

I'll debug this at home.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 22 Mar 2001 18:47:48 +0100

> application below, causing (in this case) a clipboard text to be copied to

Fixed.

Bye

Dominik ^_^  ^_^