Subject: FvwmGtk small patch

From: "Yitzchak M. Gottlieb" <[email-masked]>
Date: Wed, 7 Mar 2001 13:34:54 -0500 (EST)

Hi,
	I'm not actually a developer, but I fixed a little bug in FvwmGtk which
I thought I should tell the contributers about.

FvwmGtk/exand.c:101
changed the body of the for-loop to read:

	if (*r->s) {
	    strcat (res, r->s);
	    free (r->s);
	}
	next = r->next;
	free (r);

This way blank strings aren't freed.

Hope this helps someone. (I'm not on the mailing list. To contact me use my address.)

Zuki

-- 
Yitzchak Gottlieb
[email-masked]

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 8 Mar 2001 04:52:14 -0600

> This way blank strings aren't freed.

It seems you use 2.3.23-2.3.27 version. I think I have fixed this core
dump in 2.3.28 by patching recursive_replace instead.

Regards,
Mikhael.

---

From: "Yitzchak M. Gottlieb" <[email-masked]>
Date: Thu, 8 Mar 2001 09:03:42 -0500 (EST)

Yes, you're right -- I was using 2.3.25. I didn't notice that change in the
2.3.29 files, so I just changed the version I already had.
Thank you very much.

Zuki

-- 
Yitzchak Gottlieb
[email-masked]