Subject: seg fault in snap-attraction

From: Tim Phipps <[email-masked]>
Date: Tue, 13 Mar 2001 12:34:25 +0000

Configuration Information [Automatically generated, do not change]:
uname output: SunOS silver 5.5.1 Generic_103640-34 sun4u sparc SUNW,Ultra-5_10
Compiler: gcc
Compilation CFLAGS: -g -O2
prefix: /u/phippst/sunos

FVWM Version:	2.3.30
FVWM_MODULEDIR:	/u/phippst/sunos/libexec/fvwm/2.3.30
FVWM_DATADIR:	/u/phippst/sunos/share/fvwm
FVWM_USERDIR:	/u/phippst/.fvwm

Built from fvwm-snap-20010311

Description:
	I got a croedump by moving an Acroread dialog box (the Find window)

Repeat-By:
	I'm not sure but I had a few acroreads open, tried to move the Find
	window and bang:
	
(gdb) where
#0  DoSnapAttract (tmp_win=0xe4a90, Width=273, Height=234, px=0xefffe274, 
    py=0xefffe270) at move_resize.c:895
#1  0x4699c in moveLoop (tmp_win=0xe4a90, XOffset=-224, YOffset=-228, Width=273, 
    Height=234, FinalX=0xefffe684, FinalY=0xefffe680, do_move_opaque=1)
    at move_resize.c:1410
#2  0x44d98 in InteractiveMove (win=0xffffff20, tmp_win=0xe4a90, FinalX=0xefffe684, 
    FinalY=0xefffe680, eventp=0x860ec, do_start_at_pointer=551480)
    at move_resize.c:533
#3  0x454a4 in move_window_doit (eventp=0x860ec, w=50334067, tmp_win=0xe4a90, 
    context=1, action=0xa95e4 "", Module=0xefffe86c, do_animate=0, do_move_to_page=0)
    at move_resize.c:772
#4  0x45818 in move_window (eventp=0x860ec, w=176162195, tmp_win=0xe4a90, context=1, 
    action=0xa95e4 "", Module=0xefffe86c) at move_resize.c:849
#5  0x4adb4 in execute_function (efa=0xefffe858) at functions.c:1083
#6  0x4af48 in old_execute_function (action=0x9d830 "Move", tmp_win=0xe4a90, 
    eventp=0x860ec, context=1, Module=-1, exec_flags=0 '\000', args=0x84c00)
    at functions.c:1152
#7  0x4bbf4 in execute_complex_function (eventp=0x68, w=50334067, tmp_win=0xe4a90, 
    context=1, action=0xefffe968 "", Module=0xefffeacc, desperate=0x9ce70)
    at functions.c:1742
#8  0x4ae08 in execute_function (efa=0xefffeab8) at functions.c:1100
#9  0x4af48 in old_execute_function (action=0xa33a0 "my_hidemoveraiselower", 
    tmp_win=0xe4a90, eventp=0x860ec, context=1, Module=-1, exec_flags=0 '\000', 
    args=0x84c00) at functions.c:1152
#10 0x3d6f0 in HandleButtonPress () at events.c:1623
#11 0x3eeb4 in DispatchEvent (preserve_Tmp_win=0) at events.c:2677
#12 0x3ef90 in HandleEvents () at events.c:2730
#13 0x5f9b0 in main (argc=1, argv=0xeffff12c) at fvwm.c:751
(gdb) print tmp
$1 = (FvwmWindow *) 0x0

Fix:
	Never had this happen before and I remember seeing a commit that
	changed snap attraction recently.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 13 Mar 2001 14:26:47 +0100

On Tue, Mar 13, 2001 at 12:34:25PM +0000, Tim Phipps wrote:
>...

I see the problem, but I can't fix it without CVS access.  In the
case statement below around line 900, remove the line

  tmp = tmp->next;

in the three cases and it will work again.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]