Subject: CVS dane: * fvwm/add_window.c (setup_style_and_decor): Make useDecor work again.

From: FVWM CVS <[email-masked]>
Date: Mon, 26 Mar 2001 20:40:18 -0600

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	dane	01/03/26 20:40:18

Modified files:
	.              : ChangeLog 
	fvwm           : add_window.c 

Log message:
* fvwm/add_window.c (setup_style_and_decor): Make useDecor work again.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 27 Mar 2001 12:47:43 +0200

> * fvwm/add_window.c (setup_style_and_decor): Make useDecor work again.

Oh, I now remember why this check was necessary.  Consider this:

  AddToDecor foo
  + ...
  AddToDecor bar
  + ...
  Style somewindow UseDecor foo
  ChangeDecor bar
   (select one window using somewindow style)

Now there is a window using the "somewindow" style and the decor
"bar".  If anything in the style is changed, the decor will be
overridden by the decor from UseDecor.  This should be easy to
solve with another window flag that remembers if ChangeDecor
was used on a window.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]