Subject: Patch for WindowList

From: Rami Lehti <[email-masked]>
Date: 05 Mar 2001 15:35:20 +0200

Hi,

There is a bug in fvwm/windows.c
If the windowlist overflows the More... entry in the
menu does not open another menu to show the rest of the entries but 
instead it gives an error message "No such menu Desk:".
This is because whitespaces are not allowed in menunames.

This patch fixes it.
--- fvwm/windows.c.orig Wed Jan 13 01:27:38 1999
+++ fvwm/windows.c      Mon Mar  5 15:27:21 2001
@@ -164,11 +164,11 @@
   globalFlags = flags;
   if (flags & SHOW_GEOMETRY)
   {
-    sprintf(tlabel,"Desk: %d\tGeometry",desk);
+    sprintf(tlabel,"Desk:_%d________________________________Geometry",desk);
   }
   else
   {
-    sprintf(tlabel,"Desk: %d",desk);
+    sprintf(tlabel,"Desk:_%d",desk);
   }
   mr=NewMenuRoot(tlabel, False);
   AddToMenu(mr, tlabel, "TITLE", FALSE, FALSE);

I'll be the first to admit that this is an ugly hack to get the thing
to work but it works. Use it however you like or write a better one.
A correct fix would be to truly allow whitespaces in menunames. But
that was a bit too much work for my taste.

Rami 
-- 
AIDE - Advanced Intrusion Detection Environment
Check http://www.cs.tut.fi/~rammer/aide.html
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 5 Mar 2001 20:38:02 +0100

> +++ fvwm/windows.c      Mon Mar  5 15:27:21 2001

I've made a proper fix that will show up in the next beta release.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]