Subject: Re: a small thing

From: Giuseppe Della Ricca <[email-masked]>
Date: Sun, 18 Mar 2001 14:08:14 +0100 (CET)

Dominik Vogt <[email-masked]> writes:

> I belive I fixed all of these.  I am sure about the xdvi thing and
> I think FvwmPager and FvwmButtons suffer from the same problem,
> but I can't make it happen here.  Can you please try again with
> tomorrow's snapshot or current CVS code?

Hi Dominik,

right know I'm updating from CVS. I'll report back if I see this problem
again.

Thanks a lot !!

cheers,
Giuseppe.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 18 Mar 2001 15:20:24 +0100

> right know I'm updating from CVS. I'll report back if I see this problem

Thanks.  BUt please report back also if the problem goes away :)

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Giuseppe Della Ricca <[email-masked]>
Date: Mon, 19 Mar 2001 15:14:48 +0100 (MET)

Hi !

after my morning CVS update, fvwm2 crashes on my Alpha.

Using gdb and -debug I have:

[FVWM][ReadSubFunc]: <<DEBUG>> Module switch 1, about to exec: '# BUTTON
Setup'
[FVWM][ReadSubFunc]: <<DEBUG>> Module switch 1, about to exec: '#'
[FVWM][ReadSubFunc]: <<DEBUG>> Module switch 1, about to exec: ''
[FVWM][ReadSubFunc]: <<DEBUG>> Module switch 1, about to exec: '## Buttons
actually being used (duplicated below)'
[FVWM][ReadSubFunc]: <<DEBUG>> Module switch 1, about to exec: '# little
box'
[FVWM][ReadSubFunc]: <<DEBUG>> Module switch 1, about to exec:
'ButtonStyle 1 Vector 5 40x40@1 60x40@1 60x60@0 40x60@0 40x40@1'

Program received signal SIGSEGV, Segmentation fault.
0x3ff801a2ce0 in strlen () from /usr/shlib/libc.so
(gdb) where
#0  0x3ff801a2ce0 in strlen () from /usr/shlib/libc.so
#1  0x12006724c in GetTokenIndex (
    token=0x14000cfe0 <Error reading address 0x14000cfe0: No such file or
directory>, list=0x140000368, len=1073742744, next=0x0) at Parse.c:577
Error accessing memory address 0x11fffdbd0: No such file or directory.
(gdb)

Commenting out all the ButtonStyle(s) avoids the crash.

I don't have problems on Linux (where I have the same ButtonStyle(s)).

Cheers,
Giuseppe.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 19 Mar 2001 16:01:33 +0100

> I don't have problems on Linux (where I have the same ButtonStyle(s)).

Please always tell us the version you are using.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Mon, 19 Mar 2001 11:01:47 -0500

> Please always tell us the version you are using.

Giuseppe did mention that this was with this morning's CVS.  (He probably
meant this morning in sunny Italy.)

I get a similar core dump with current CVS on Solaris:

(gdb) where
#0  0xff0329ec in strlen () from /usr/lib/libc.so.1
#1  0x627f8 in GetTokenIndex (token=0x81e58 "Pixmap", list=0x81300, len=0, 
    next=0x0) at ../../version-2_3_30/libs/Parse.c:577
#2  0x628c8 in GetNextTokenIndex (action=0xaf6f6 "Pixmap mini.iconify.xpm\n", 
    list=0x81300, len=0, index=0xffbec11c)
    at ../../version-2_3_30/libs/Parse.c:615
#3  0x4cec0 in ReadTitleButton (s=0xaf6f6 "Pixmap mini.iconify.xpm\n", 
    tb=0xafa80, append=0 '\000', button=0)
    at ../../version-2_3_30/fvwm/builtins.c:1716
#4  0x4e248 in do_button_style (eventp=0x3fffffff, w=42, tmp_win=0x0, 
    context=8, action=0x0, Module=0xffbec37c, do_add=0)
    at ../../version-2_3_30/fvwm/builtins.c:2366
#5  0x4e288 in ButtonStyle (eventp=0x82838, w=42, tmp_win=0x0, context=8, 
    action=0xaf6f4 "1 Pixmap mini.iconify.xpm\n", Module=0xffbec37c)
    at ../../version-2_3_30/fvwm/builtins.c:2376
#6  0x47588 in execute_function (efa=0xffbec368)
    at ../../version-2_3_30/fvwm/functions.c:1083
#7  0x47724 in old_execute_function (
    action=0xaf6b2 "ButtonStyle 1 Pixmap mini.iconify.xpm\n", tmp_win=0x0, 
    eventp=0x82838, context=8, Module=-1, exec_flags=0 '\000', args=0x0)
    at ../../version-2_3_30/fvwm/functions.c:1152
#8  0x4d54c in AddToDecor (decor=0xafa78, 
    s=0xaf6b2 "ButtonStyle 1 Pixmap mini.iconify.xpm\n")
    at ../../version-2_3_30/fvwm/builtins.c:1870
#9  0x4a6e8 in add_another_item (eventp=0x82838, w=42, tmp_win=0x0, context=8, 
    action=0xaf6b2 "ButtonStyle 1 Pixmap mini.iconify.xpm\n", 
    Module=0xffbec5a4) at ../../version-2_3_30/fvwm/builtins.c:407
#10 0x47588 in execute_function (efa=0xffbec590)
    at ../../version-2_3_30/fvwm/functions.c:1083
#11 0x47724 in old_execute_function (
    action=0xffbec628 "+ ButtonStyle 1 Pixmap mini.iconify.xpm\n", 
    tmp_win=0x0, eventp=0x82838, context=8, Module=-1, exec_flags=0 '\000', 
    args=0x0) at ../../version-2_3_30/fvwm/functions.c:1152
#12 0x2d51c in run_command_stream (f=0x82c40, eventp=0x82838, tmp_win=0x0, 
    context=8, Module=-1) at ../../version-2_3_30/fvwm/read.c:142
#13 0x2d67c in run_command_file (filename=0x0, eventp=0x82838, tmp_win=0x0, 
    context=8, Module=-1) at ../../version-2_3_30/fvwm/read.c:216
#14 0x2d7f4 in ReadFile (eventp=0x82838, w=42, tmp_win=0x0, context=8, 
    action=0xb1b6d "DecorCustom", Module=0xffbecc44)
---Type <return> to continue, or q <return> to quit---
    at ../../version-2_3_30/fvwm/read.c:268
#15 0x47588 in execute_function (efa=0xffbecc30)
    at ../../version-2_3_30/fvwm/functions.c:1083
#16 0x47724 in old_execute_function (action=0xae460 "read DecorCustom", 
    tmp_win=0x0, eventp=0x82838, context=8, Module=-1, exec_flags=0 '\000', 
    args=0xffbecd40) at ../../version-2_3_30/fvwm/functions.c:1152
#17 0x48118 in execute_complex_function (eventp=0x82838, w=0, tmp_win=0x0, 
    context=8, action=0xad790 "DecorCustom\n", Module=0xffbecea4, 
    desperate=0xae440) at ../../version-2_3_30/fvwm/functions.c:1625
#18 0x475e0 in execute_function (efa=0xffbece90)
    at ../../version-2_3_30/fvwm/functions.c:1100
#19 0x47724 in old_execute_function (action=0xffbecf28 "DecorCustom\n", 
    tmp_win=0x0, eventp=0x82838, context=8, Module=1, exec_flags=0 '\000', 
    args=0x0) at ../../version-2_3_30/fvwm/functions.c:1152
#20 0x2d51c in run_command_stream (f=0x82c30, eventp=0x82838, tmp_win=0x0, 
    context=8, Module=1) at ../../version-2_3_30/fvwm/read.c:142
#21 0x2d67c in run_command_file (filename=0x0, eventp=0x82838, tmp_win=0x0, 
    context=8, Module=1) at ../../version-2_3_30/fvwm/read.c:216
#22 0x5b284 in main (argc=2, argv=0x83174)
    at ../../version-2_3_30/fvwm/fvwm.c:666

Let me know if you want the config file, right now  I can't debug this
myself, maybe this evening.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 19 Mar 2001 17:16:24 +0100

On Mon, Mar 19, 2001 at 11:01:47AM -0500, Dan Espen wrote:
> Giuseppe did mention that this was with this morning's CVS.

Ups, I only scanned for a version number.

> (He probably meant this morning in sunny Italy.)

Wich is the same as in rainy Germany :)

> myself, maybe this evening.

I think I'll get along without a config file.

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 19 Mar 2001 17:56:12 +0100

> I get a similar core dump with current CVS on Solaris:

Hm, gcc did not detect a syntax error in this definition:

  static char *button_states[BS_MaxButtonState] =
  {
    "ActiveUp",
    "ActiveDown",
    "Inactive",
    "ToggledActiveUp",
    "ToggledActiveDown",
    "ToggledInactive",      <-- note the excess comma
  };

There should have been another NULL element in the array.  Anyway,
the core dump is fixed.

Bye

Dominik ^_^  ^_^

---

From: "Paul D. Smith" <[email-masked]>
Date: 19 Mar 2001 12:21:21 -0500

%% Dominik Vogt <[email-masked]> writes:

  dv> Hm, gcc did not detect a syntax error in this definition:

  dv>   static char *button_states[BS_MaxButtonState] =
  dv>   {
  dv>     "ActiveUp",
  dv>     "ActiveDown",
  dv>     "Inactive",
  dv>     "ToggledActiveUp",
  dv>     "ToggledActiveDown",
  dv>     "ToggledInactive",      <-- note the excess comma
  dv>   };

FWIW, that's not a syntax error; it's legal to have a trailing comma.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>    HASMAT--HA Software Methods & Tools
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Mon, 19 Mar 2001 12:43:42 -0500

> There should have been another NULL element in the array.  Anyway,

There would be a NULL entry if BS_MaxButtonState allowed for it.

enum ButtonState
{
  BS_All = -1,
  BS_ActiveUp,
  BS_ActiveDown,
  BS_Inactive,
  BS_ToggledActiveUp,
  BS_ToggledActiveDown,
  BS_ToggledInactive,
  BS_MaxButtonState
};

---

From: Giuseppe Della Ricca <[email-masked]>
Date: Tue, 20 Mar 2001 13:04:22 +0100 (MET)

> the core dump is fixed.

Yes ! Thanks !!

Sorry for not having answered before: I'm not on the mailing list, so I
follow the mail archive, and have to wait for its update.

Bye,

Giuseppe.