Subject: Notification: incoming/701

From: [email-masked]
Date: Mon, 05 Mar 2001 05:07:29 -0600

FVWM Bug Tracking notification

new message incoming/701

Message summary for PR#701
	From: [email-masked]
	Subject: Wrong geometry in swallow
	Date: Mon, 05 Mar 2001 05:07:28 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Mon Mar 05 05:07:29 2001
From: [email-masked]
To: [email-masked]
Subject: Wrong geometry in swallow
Date: Mon, 05 Mar 2001 05:07:28 -0600

Full_Name: Lars
Version: 2.3.26 - 29
CVS_Date: 
OS: Linux, RedHat 6.2, kernel 2.2.18
X_Server: XFree86 3.3.6
Submission from: (NULL) (129.242.5.30)

When I log in both xload and xapm seems to get wrong hints, and they
resize themselves too big for their respective buttons. This happens
after i use a 'GotoPage 1.0' and back again. This problem seems to be
introduced in 2.2.26, 2.2.25 have no problems with my config-files.

If I kill xapm or xload after logging in they will resize themselves 
to their buttons just fine. They also resize fine if I do a 'restart 
fvwm2'.

Here is my FvwmButtons configuration (well, most of it). 

################## FvwmButtons button-bar ################################
*FvwmButtons: Font        -*-fixed-*-*-*-*-10-*-*-*-*-*-*-*
*FvwmButtons: Back        rgb:BB/BB/BB
*FvwmButtons: Fore        Black
*FvwmButtons: Geometry    -0-0
*FvwmButtons: BoxSize     smart

*FvwmButtons: (Frame 0, Padding 0 0, \
               Container(Rows 1, Columns 5, Size 70 60, Frame 0,
Swallow(Respawn)))

  *FvwmButtons: (1x1, Container(Rows 3, Frame 1))
    *FvwmButtons: (Title Netscape Icon mini-nscape.xpm Action `Exec
"Netscape" netscape -no-about-splash -install -dont-save-geometry-prefs`)
    *FvwmButtons: (Title Opera,                        Action `Exec "Opera"
opera 2>/dev/null`)
    *FvwmButtons: (Title Konqeror,                     Action `Exec
"konqueror" konqueror 2>/dev/null`)
  *FvwmButtons: (End)

  *FvwmButtons: (1x1, Container(Rows 3, Frame 1))
    *FvwmButtons: (Title KMail,  Action `Exec "KDE" kmail 2>/dev/null`)
    *FvwmButtons: (Title XEmacs, Action `Exec "emacs" xemacs -geometry
80x51+0+0`)
    *FvwmButtons: (Title xterm,  Action `Exec "xterm" xterm`)
  *FvwmButtons: (End)

  *FvwmButtons: (1x1, Container(Rows 3, Frame 1))
    *FvwmButtons: (              Swallow(UseOld,Kill) "xapm"   `Exec xapm
-geometry -0-0 -percent -bg rgb:BB/BB/BB -fn '-*-arial
narrow-medium-r-*-*-11-*-*-*-*-*-iso8859-1'`)
    *FvwmButtons: (Padding 13 3, Swallow(UseOld,Kill) "iclock" `Exec iclock
-h 24 -d /usr/share/iclock/tinyred`)
    *FvwmButtons: (              Swallow(UseOld,Kill) "xload"  `Exec xload
-geometry -0-0 -bg rgb:BB/BB/BB -fg blue -hl red -nolabel -update 1`)
  *FvwmButtons: (End)

  *FvwmButtons: (1x1, Container(Rows 3, Frame 0))
    *FvwmButtons: (1x3 Swallow "FvwmPager" `FvwmPager 0 0` Frame 1)
  *FvwmButtons: (End)

*FvwmButtons: (End)

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 5 Mar 2001 21:05:36 +0100

> to their buttons just fine. They also resize fine if I do a 'restart 

I don't see a problem with your configuration, but on the other
hand I don't understand what exactly you are doing when you see
this.  Please step by step instructions so that I can see if this
happens for me too.  Furthermore, screenshots of your button bar
might help.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 18 Mar 2001 00:30:02 +0100

On Mon, Mar 05, 2001 at 10:35:12PM +0100, Lars Slettjord wrote:
> On Monday 05 March 2001 21:05, you wrote:
>  * Upgrade from 2.2.25 to 2.2.29
>  * Start fvwm2 for the first time (i.e log in)
>  * The buttons with the swallowed xapm and xload looks like the
>    buttons-corrupt.gif screenshot. The xapm is too wide, and i can't
>    see any xload at all. Looks like they are not resizing to the size
>    of the button, but appear with their default size.
>  * If I do a "Restart fvwm2" both xapm and xload resize to the size of
>    the button, as in the buttons-ok.gif screenshot.
>  * If i kill xapm and xload, FvwmButton respawns the processes, and they
>    appear correctly in their buttons.
>  * If I downgrade to 2.2.25 the buttons are also ok again when I log in.
> 
> So it's just when I log in the first time that they don't appear correctly, 
> but it's very annoying.
> 
> If I start xapm as a standalone under X it looks like the xapm.gif 
> screenshot.

I see.  I have made some patches that may or may not affect this
problem and added some debug output to the sources.  Please
download tomorrow's snapshot and see if the problem goes away.
FvwmButtons will generate some outpout on the console (all lines
beginnig with +++).  If the problem persists, plese send me this
output.

Bye

Dominik ^_^  ^_^

---

From: Lars Slettjord <[email-masked]>
Date: Mon, 19 Mar 2001 13:19:15 +0100

> > > > Submission from: (NULL) (129.242.5.30)

[snip]

> download tomorrow's snapshot and see if the problem goes away.

Nope, no change, the problem is still there. Here is the debug output:

+++ swallowing (do not use title)
+++ geom before constrain: 68x18
+++ geom after constrain: 68x18
+++ sizing window: 141 1 68x18
+++ swallowing (do not use title)
+++ geom before constrain: 68x18
+++ geom after constrain: 68x18
+++ sizing window: 141 41 68x18
+++ swallowing (do not use title)
+++ geom before constrain: 68x58
+++ geom after constrain: 67x58
+++ sizing window: 211 1 67x58
+++ geom before constrain: 68x58
+++ geom after constrain: 67x58
+++ sizing window: 211 1 67x58
+++ swallowing (do not use title)
+++ geom before constrain: 42x12
+++ button height 12, but min height 13
+++ geom after constrain: 42x13
+++ sizing window: 154 24 42x13
-- 
Lars Slettjord
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 19 Mar 2001 13:50:59 +0100

> +++ sizing window: 154 24 42x13

Hm, the log looks good.  What is the exact size of the buttons
that contain the applications with the wrong size (in pixels)?
And please post the output of "xwininfo -tree" (click on the
button bar).

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Lars Slettjord <[email-masked]>
Date: Mon, 19 Mar 2001 14:55:25 +0100

> that contain the applications with the wrong size (in pixels)?

The container is 70x20, the size of xapm and xload seems to be
68x18 in fvwm2-2.3.25.

> And please post the output of "xwininfo -tree" (click on the

Here is this output both for the ok 2.3.25 version and for the broken
20010318 snapshot:

First the 2.3.25:

xwininfo: Window id: 0xc00006 "FvwmButtons"

  Root window id: 0x26 (the root window) (has no name)
  Parent window id: 0x80007d (has no name)
     5 children:
     0x2000039 "iClock": ("iclock" "Iclock")  42x13+154+24  +758+732
        1 child:
        0x200004a (has no name): ()  42x13+0+0  +758+732
     0x1000004 "Local": ("FvwmPager" "FvwmPager")  67x58+211+1  +815+709
        1 child:
        0x100000a (has no name): ()  67x57+-1+-1  +814+708
           1 child:
           0x100000b (has no name): ()  67x42+-1+14  +814+723
              10 children:
              0x1000024 (has no name): ()  17x21+0+21  +815+745
              0x1000022 (has no name): ()  18x21+16+21  +831+745
              0x1000010 (has no name): ()  8x3+9+18  +824+742
              0x1000020 (has no name): ()  3x3+8+15  +823+739
              0x100001e (has no name): ()  14x21+16+0  +831+724
              0x100001c (has no name): ()  9x7+8+9  +823+733
              0x1000018 (has no name): ()  9x10+0+9  +815+733
              0x1000016 (has no name): ()  9x10+8+0  +823+724
              0x1000012 (has no name): ()  17x10+0+0  +815+724
              0x100000c (has no name): ()  16x20+0+0  +815+724
     0x1800005 "xload": ("xload" "XLoad")  68x18+141+41  +745+749
        1 child:
        0x1800006 (has no name): ()  68x18+0+0  +745+749
     0x1400013 "xapm": ("xapm" "XApm")  68x18+141+1  +745+709
        1 child:
        0x1400014 (has no name): ()  68x18+0+0  +745+709
           2 children:
           0x1400016 (has no name): ()  38x13+2+1  +747+710
           0x1400015 (has no name): ()  22x13+42+1  +787+710
     0xc00009 (has no name): ()  1x1+2000+2000  +2604+2708

And the broken 20010318 snapshot:

xwininfo: Window id: 0xc00006 "FvwmButtons"

  Root window id: 0x26 (the root window) (has no name)
  Parent window id: 0x80007d (has no name)
     5 children:
     0x2000039 "iClock": ("iclock" "Iclock")  42x13+154+24  +758+732
        1 child:
        0x200004a (has no name): ()  42x13+0+0  +758+732
     0x1800005 "xload": ("xload" "XLoad")  68x18+141+41  +745+749
        1 child:
        0x1800006 (has no name): ()  120x120+0+0  +745+749
     0x1c00013 "xapm": ("xapm" "XApm")  68x18+141+1  +745+709
        1 child:
        0x1c00014 (has no name): ()  103x22+0+0  +745+709
           2 children:
           0x1c00016 (has no name): ()  58x16+2+1  +747+710
           0x1c00015 (has no name): ()  34x16+63+1  +808+710
     0x1000004 "Local": ("FvwmPager" "FvwmPager")  67x58+211+1  +815+709
        1 child:
        0x100000a (has no name): ()  67x58+-1+-1  +814+708
           1 child:
           0x100000b (has no name): ()  67x43+-1+14  +814+723
              7 children:
              0x1000022 (has no name): ()  14x22+16+0  +831+724
              0x1000020 (has no name): ()  9x7+8+9  +823+733
              0x100001e (has no name): ()  9x10+0+9  +815+733
              0x100001c (has no name): ()  9x10+8+0  +823+724
              0x1000014 (has no name): ()  9x10+0+0  +815+724
              0x1000010 (has no name): ()  8x3+9+19  +824+743
              0x100000c (has no name): ()  16x21+0+0  +815+724
     0xc00009 (has no name): ()  1x1+2000+2000  +2604+2708

Please note that the 1 child of both xload and xapm has a different size than 
their parents in the broken version. In 2.3.25 the sizes are the same. The 
difference in size seems to be consistent with what I actually see on the 
screen.
-- 
Lars Slettjord
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 19 Mar 2001 17:36:06 +0100

> difference in size seems to be consistent with what I actually see on the 

Interesting.  The applications seem to somehow miss that they are
resized by FvwmButtons.  Perhaps more waiting, flushing X queues
and XSync'ing will help.

I've made another small patch that may help.

Bye

Dominik ^_^  ^_^