Subject: Mouse clicks on "override redirect" windows?

From: "Dmitry Yu. Bolkhovityanov" <[email-masked]>
Date: Fri, 23 Mar 2001 12:38:36 +0600

Hi!

    When one tries to click on an "override redirect" window (such as
a tooltip), the click goes to the root window, and usually Fvwm's menu pops
up.

    Is this a desired behaviour (i.e, is it dictated by ICCCM)?

    This is kinda xfig bug -- not dangerous, but a bit annoying (or funny :).
While it is not that simple to click a tooltip window (at least without a
sleep 5; kill -STOP %1), I've met it with xmms -- pressing the playlist
[Add|dir] button in some strange place (like big/slow/etc. dir), when xmms
stalls for a while, does the thing.

P.S. This is with 2.3.28.

       ___________________________________________________________________
       Dmitry Yu. Bolkhovityanov  |  Novosibirsk, RUSSIA
       phone (383-2)-39-49-56     |  The Budker Institute of Nuclear Physics
                                  |  Lab. 5-13
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 23 Mar 2001 13:24:13 +0100

> P.S. This is with 2.3.28.

That is already fixed in the current development sources.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]