Subject: A few minor problems

From: Olivier Chapuis <[email-masked]>
Date: Thu, 29 Mar 2001 14:16:13 +0200

Hello,

We probably do not have to take in account the followings problems,
but ...

1. Since last 15 days two times my menu definition completely
disappear (the second time just now with 2.3.30). When I go around
my root menu and popup all my submenus (to look at my mini icons)
suddenly all my menus definition go away:  The bindings are still here
but fvwm says "no menu xxx", "no menu yyy", ...  (the menus disappear
for ever when I use it).
Also it seems that the last popup before that the menu go away was not
the good submenu but one not very far from it.  I am unable to reproduce
this problem.

2. Seems that there are bad interactions between PopupDownDelayed
and animate menu. Under certain situation:
            - In a menu X popup a submenu A which cause animation
	- Go to menu A and popup a submenu B that cause animation
	- In menu A (try) to popup an other submenu C
	- before submenu B popup down the animation came back
               and the cursor fall on menu B.
I can reproduce this in fvwm-themes Themes Management menu and
going far (the problem arise more or less far from the root):
Themes Management/current/settings/GNOME/System menu
 
3. Build a menu R with two Popup one "A" with a real submenu and the
other one "B" with a non existing menu. Go to "A", the submenu popup,
then go to "B", menu "A" never PopupDown (PopupDelayed of course).
 
4. Under GNOME session : Use say a DesktopSize 2x2 and save
your session on page 2 2. When I restart the session I am again
on page 2 2 but the gmc icon are on the page on my left.
It seems that a page switching in the "same time" that a "stick"
(the gmc icon) cause the problem.

Olivier

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 30 Mar 2001 18:14:17 +0200

> the good submenu but one not very far from it.  I am unable to reproduce

That's a serious problem.  I had that a few times when I cleaned
up the menu deletion code.  Somehow the menu list gets corrupted.
THe menus are still in memory but can't be found.  Please try to
find a way to reproduce this.  It probably has something to do
with dynamic menus.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 30 Mar 2001 19:41:27 +0200

> Themes Management/current/settings/GNOME/System menu

Fixed, but I got some strange key behaviour and even a crash while
debugging.  I'll look into that later.

> then go to "B", menu "A" never PopupDown (PopupDelayed of course).

Fixed.

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 31 Mar 2001 18:15:53 +0200

> (the gmc icon) cause the problem.

That does not happen for me, but perhaps I did not do what you
did:

 1) Start fvwm.
 2) Start gnome-session.  It complains about not running a GNOME
    compliant window manager but starts up anyway.
 3) Go to the bottom right page (1 1).
 4) Chose "Save Current Session" from the Session menu.
 5) Log out of GNOME. Fvwm is still running.
 6) Start gnome-session again.

==> The gmc icons start on the current page, i.e. (1 1).

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 31 Mar 2001 13:57:38 -0600

>  6) Start gnome-session again.

gnome-session is a session manager like xsm; starting it inside fvwm has
no much sence. You should start it instead of fvwm and then go to panel's
menu and define fvwm2 as a window manager (FAQ #2.7). Then fvwm will be
started by gnome-session when you run gnome-session next time.

SessionInitFunction will be called instead of InitFunction.
If StartFunction is used to run modules they will be started as expected.

Session management functionality is turned off in fvwm (sm_conn = NULL)
unless fvwm is run under a session manager.

> ==> The gmc icons start on the current page, i.e. (1 1).

Regards,
Mikhael.