Subject: fvwm 2.3.29 BUG? default for "WindowListFunc" changed?

From: Mike Fabian <[email-masked]>
Date: 07 Mar 2001 17:47:32 +0100

The fvwm2 man page states:

Man: fvwm2>    By default the  "WindowListFunc" looks like this:
Man: fvwm2>
Man: fvwm2>                   AddToFunc WindowListFunc
Man: fvwm2>                    + I WindowId $0 Iconify off
Man: fvwm2>                    + I WindowId $0 FlipFocus
Man: fvwm2>                    + I WindowId $0 Raise
Man: fvwm2>                    + I WindowId $0 WarpToWindow 5p 5p

But unless I add this to my ~/.fvwm2rc, the WindowListFunc doesn't
seem to work like advertised in the man page. I.e. when I don't
add this to my ~/.fvwm2rc, open the WindowList and click on
an item in the WindowList, the window does not deiconify, does not
get focus, does not raise and the mouse pointer does not warp
to the window either.

So it looks like the default for WindowListFunc is empty now.

Is this on purpose (then the man page should be updated) or is this a
bug?

-- 
Mike Fabian   <[email-masked]>

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 07 Mar 2001 12:00:52 -0500

> Is this on purpose (then the man page should be updated) or is this a

Did you move fvwm around after you installed it?

When you configure fvwm, it creates a file named ConfigFvwmDefaults
in /usr/local/share/fvwm (or something like that), that contains
the function definition.
Fvwm then tries to read that file during startup.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mike Fabian <[email-masked]>
Date: 07 Mar 2001 21:55:52 +0100

> Mike Fabian <[email-masked]> writes:

[...]

> Fvwm then tries to read that file during startup.

You are right, I missed the ConfigFvwmDefaults file, I forgot
it in the %file list when creating the rpm-package.

Thank you very much, now everything works normally.

The support for Asian languages is also very nice.

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 8 Mar 2001 04:38:22 -0600

> it in the %file list when creating the rpm-package.

FYI, "make rpm-dist" creates correct rpm file.
Tested on RedHat, Mandrake and SuSE.

Regards,
Mikhael.