Subject: Notification: incoming/706

From: [email-masked]
Date: Wed, 21 Mar 2001 03:32:31 -0600

FVWM Bug Tracking notification

new message incoming/706

Message summary for PR#706
	From: [email-masked]
	Subject: FvwmIdent breaks when pointed to itself
	Date: Wed, 21 Mar 2001 03:32:30 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Wed Mar 21 03:32:31 2001
From: [email-masked]
To: [email-masked]
Subject: FvwmIdent breaks when pointed to itself
Date: Wed, 21 Mar 2001 03:32:30 -0600

Full_Name: Dmitry Bolkhovityanov
Version: 2.3.28
CVS_Date: 
OS: Linux RH6.1, 2.2.12
X_Server: XFree86 4.0.2
Submission from: (NULL) (140.221.9.192)

FvwmIdent abnormally terminates if after pressing Button2 ("reask
for a window") is pointed to itself, with "BadWindow" error and
ResourceID=<FvwmIdent's window ID>.  Probably it destroys its window
first and than tries to get info for it.

Haven't tried latest CVS yet, but last notion of FvwmIdent in ChangeLog
is 2000-05-01, so this probably doesn't matter.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 21 Mar 2001 18:55:37 +0100

> first and than tries to get info for it.

Yes, exactly.  I have fixed this.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 21 Mar 2001 17:28:32 -0600

> is 2000-05-01, so this probably doesn't matter.

You should search in ./modules/ChangeLog, not ./ChangeLog. :-)

Regards,
Mikhael.

---

From: Tim Phipps <[email-masked]>
Date: Thu, 22 Mar 2001 14:25:20 +0000

> is 2000-05-01, so this probably doesn't matter.

This is still broken in tha latest snapshots. The man page states:

Pressing  mouse  button 2 in the window restarts FvwmIdent and asks for
a new window to select.

which implies to me that the FvwmIdent window should go away while the
user picks another window. If anyone is going to fix this then could
they also make FvwmIdent change it's layer to the same layer as the
target window if the target window layer is higher than the FvwmIdent
window layer? This is to prevent FvwmIdnet windows being invisible.

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 22 Mar 2001 16:03:39 +0100

On Thu, Mar 22, 2001 at 02:25:20PM +0000, Tim Phipps wrote:
> user picks another window.

I already commited a patch yesterday.  It probably did not make it
into the snapshot you got.

> If anyone is going to fix this then could

Done.  But the FvwmIdent Window jump multiple times above and
below the target window since there is no way to specify that
the window is created on the proper layer.

Bye

Dominik ^_^  ^_^