Subject: busy wait in menu code

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 2 Mar 2001 12:45:33 -0600

Ok, final 2.3.29 is already buggy... But this is true for any release. :)

Run top, popup menu, select any item. See how fvwm2 + X eat all CPU.
I can reproduce this consistently with a default menustyle.
There is no problem if PopupDelay 0 is used.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 2 Mar 2001 20:25:10 +0100 (MET)

> Ok, final 2.3.29 is already buggy... But this is true for any release. :)

:-)

Did I say that was the final release?

I'm in no particular hurry to get the release out the door.
 
> There is no problem if PopupDelay 0 is used.

And what is the relation to the busy cursor patch? I'll look into that
later.

Bye

Dominik ^_^

-- 
Sent through GMX FreeMail - http://www.gmx.net

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 2 Mar 2001 13:50:16 -0600

> Did I say that was the final release?

By "final 2.3.29" I meant fvwm-2.3.29, as opposed to "pre-2.3.29" or
"cvs 2.3.29".

> And what is the relation to the busy cursor patch? I'll look into that

There is no any relation to the busy cursor.

Maybe "busy wait" is not the right term, but this is how my CS teachers
called this situation - CPU is used when not needed.

Regards,
Mikhael.