Subject: small problems

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 18 Feb 2001 07:05:41 -0600

Here is a list of some problems, which are easy to reproduce.

1) WindowShade ignores MaxWindowSize. Execute this (xv may be replaced):

  Style xv MaxWindowSize
  Exec xv
  Style xv MaxWindowSize 100p 100p
  All (xv) WindowShade

2) Moving of mini-windows inside the pager with LabelsBelow is incorrect:

  *FvwmPager-Test: LabelsBelow
  FvwmPager FvwmPager-Test

3) In FvwmButtons, press Mouse1 on any button, drag it outside the module,
press Mouse3, release both mouse buttons, the bar button stays pressed.

4) Another minor click-and-hold visual problem.

  Style * DepressableBorder  # !FirmBorder
  Mouse 1 A S ResizeOrRaiseOrShade

  AddToFunc ResizeOrRaiseOrShade
  + M Resize  # not important
  + C Raise   # not important
  + D WindowShade

Now put your mouse at the left or right side of a window (not handles),
double click on the border and hold the mouse button pressed.
Repeat the same on the shaded window, but now simply click.
In both cases a small corner is depressed. Probably not bad at all.

----

Some of the problems are hardier to reproduce, some I can't reproduce any
more. Will write later.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 18 Feb 2001 19:59:49 +0100

>   Style xv MaxWindowSize 100p 100p

Fixed.

>   *FvwmPager-Test: LabelsBelow

Fixed.

> press Mouse3, release both mouse buttons, the bar button stays pressed.

Fixed.

> In both cases a small corner is depressed. Probably not bad at all.

May I call you Mr. Eagle Eye?  I'll fix that when I'm in the mood.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 18 Feb 2001 20:06:12 +0100

> In both cases a small corner is depressed. Probably not bad at all.

Fixed.  I love these bugs.  Four fixes in only half an hour :-)

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 19 Feb 2001 06:39:11 -0600

> > In both cases a small corner is depressed. Probably not bad at all.

Yes, but a new problem is introduced by this fix. Use "Style * Handles".
Now if you bind WindowShade to border (FS) and hold a mouse button after a
click or double click, the whole border is depressed, not only the active
part. And the mentioned whole border is depressed using different drawing
from the usual, this is better seen with "Style * NoHandles". Am I clear?

Other 3 problems are fixed, nice.

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 19 Feb 2001 06:58:57 -0600

> >   Style xv MaxWindowSize 100p 100p

Ok, but before this fix, if you now execute "Style xv MaxWindowSize"
xv would restore its original size, this does not happen now, the
following MaxWindowSize are simply ignored if the window should grow.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 19 Feb 2001 14:29:46 +0100

> following MaxWindowSize are simply ignored if the window should grow.

Yes. The MaxWindowSize style has no memory of the previous size
and I don't think it should have.  There are better commands for
control over window sizes.  Previously, the maximum size was not
enforced on the three stored geometries, only on the current
geometry which lead to strange effects with shaded or maximized
windows.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 19 Feb 2001 15:12:22 +0100

> from the usual, this is better seen with "Style * NoHandles". Am I clear?

Yes, I see.  Fixed in a moment.  Just for the records: this was
not introduced by the drawing fix but by the patch to reduce
flickering.  BTW, do you see any positive effect on your
flickering window motion problem?

Bye

Dominik ^_^  ^_^