Subject: FvwmButtons Panel Hints

From: Dan Espen <[email-masked]>
Date: Sun, 18 Feb 2001 21:06:27 -0500

This is the current text.

If the \fIHints\fP option is enabled (the default) FvwmButtons may not
know the actual window  size and the  number of animation steps may be
slightly off.

I'm trying to add a description of what "NoHints" does.

This option seems to use window manager size hints to make the animation
steps match the size increments and use the minimum size hints
to figure out the smallest size of the window.

I don't understand what the author meant about "not knowing the actual
size".

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214             E-mail: [email-masked]
Piscataway, NJ 08854                       Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 19 Feb 2001 15:22:28 +0100

> I don't understand what the author meant about "not knowing the actual

I don't know either.  the hints option is used at two places
(b_NoHints).  When used in the sliding animation it tells the
sliding code in libs/WinMagic.c to

 - use the resize increments from the hints
 - not resize the window below the specified minimum size

I don't really understand what FvwmButtons does with the hints in
the other case.  This part of the man page refering to swallowed
windows (instead of panels) is not very clear either:

  NoHints / Hints -
  Specifies whether hints from the swallowed program in this
  button will be ignored or not, useful in forcing a window to resize itself
  to fit its button. The default value is "Hints".

BTW, yes, the opposite of "Hints" is "NoHints".

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 19 Feb 2001 19:27:23 +0100

> I don't understand what the author meant about "not knowing the actual

Hello,
I think I am the author of this sentence (and so you too Dan ...).
But, I do not see the meaning of this sentence too. I cannot say
more than Dominik say.
Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]