Subject: recent decoration bugs

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 27 Feb 2001 07:52:41 -0600

There are 2 recent problems with the current decoration code.
Here is how to reproduce them with fvwm-themes.

Load @migo (or @default) basic look.

1) Load colors@osx. The hilight/shadow colors of the focused title buttons
are incorrect. The shadow color is even lighter than the hilight one.

2) Load colors@redmond98 (the cvs version is good for this).
The unfocussed borders are drawn incorrectly. They are autofixed after
focusing/unfocusing or shading/unshading.

These problems are not present with the previous fvwm versions.
I am currently busy with other things to spot the problems more closely.
Olivier, can you help with minimal rc files to reproduce these problems?

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 27 Feb 2001 18:36:21 +0100

> are incorrect. The shadow color is even lighter than the hilight one.

No problem here.  This is the Motif-like algorithm to calculate
shadow and hilight colours.  If the base colour is too light or
too dark, the hilight look is inverted.  To prevent this you have
to use a darker base colour (in this case) or specify shadow and
hilight colours with a colour set.  If you didn't see this in
previous fvwm versions the the reason must be that the colours
of the osx theme were changed.  The hilight algorithm has been
there since late 1999.

> focusing/unfocusing or shading/unshading.

Works fine for me.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 28 Feb 2001 10:53:05 +0100

> are incorrect. The shadow color is even lighter than the hilight one.

Seems that we have to fix this in fvwm-themes.

> focusing/unfocusing or shading/unshading.

This work fine for me too. Which windowstyle do you use?

Olivier

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 28 Feb 2001 10:30:28 -0600

> This work fine for me too. Which windowstyle do you use?

I consistently reproduce this with windowlook@deault or windowlook@migo.

I still think these are fvwm bugs, because I tried the same with
fvwm-2.3.22 and it worked as expected (i.e. correctly).

I will prepare minimal rc files when I have a time.

Regards,
Mikhael.