Subject: FvwmScript warning that I can't fix

From: Dominik Vogt <[email-masked]>
Date: Sun, 11 Feb 2001 15:39:13 +0100

Mikhael, with you latest commit I get some warnings in FvwmScript
which I am unable to fix because it's in that evil code that is
generated:

gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..  -I/usr/X11R6/include   -DFVWM_DATADIR=\"/usr/local/share/fvwm\" -Wall -Werror -O2 -g -c script.c
cc1: warnings being treated as errors
y.tab.c: In function `yyparse':
y.tab.c:1145: warning: suggest parentheses around assignment used as truth value
y.tab.c:1194: warning: label `yyerrlab' defined but not used
y.tab.c:1189: warning: label `yynewerror' defined but not used
y.tab.c: At top level:
script.c:2: warning: `yysccsid' defined but not used

Can you try to suppress these messages, please?

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 11 Feb 2001 13:03:31 -0600

> Can you try to suppress these messages, please?

These warnings are not related to the changes, which are pretty trivial.
If you say that there were no warnings before, it is my byacc generating
them. If you have flex and another yacc flavor (byson?) can you or anyone
else please regenerate script.c by "make script" in FvwmScript directory?

In any case a possible solution is to edit script.c manually before 2.4.0.

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 11 Feb 2001 14:02:44 -0600

On 11 Feb 2001 13:03:31 -0600, Mikhael Goikhman wrote:
> 
> please regenerate script.c by "make script" in FvwmScript directory

I mean "make syntax", of course.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 12 Feb 2001 13:33:28 +0100

> In any case a possible solution is to edit script.c manually before 2.4.0.

I was able to regenerate the file without warnings, but not with
yacc.  My version of yacc generates less warnings, but not zero.
Using bison fixed that problem, but unfortunately bison gives
different names to the generated files, so I had to rename the
files manually:

  $ make syntax
  $ mv script.tab.c script.c
  $ mv script.tab.h script.h

It's probably a good idea to fix this in the makefiles.
Furthermore bison should be detected and preferred to yacc.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]