Subject: FvwmButtons BoxSize dumb

From: Dan Espen <[email-masked]>
Date: Sun, 18 Feb 2001 20:41:05 -0500

The FvwmButtons Boxsize option takes 3 values, dumb, fixed and smart.

I'm trying to improve the man page description.
I notice that "dumb" is not described at all.

"dumb" is the default.  I think this is a  problem.  If the idea is to
retain compatibility,  I'd rather  see  this described as "compat"  or
"orig".

I'm having some trouble figuring out how to describe what "dumb" does.
I can see that it resets "fixed" and "smart".  Its not very clear what
else it does.  It looks to me like "smart" should  be the default, and
there shouldn't be any "dumb" option.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 19 Feb 2001 11:31:10 +0100

> retain compatibility,  I'd rather  see  this described as "compat"  or

The "dumb" is the behaviour of the old 2.0.46 release.  I kept
this for the sole reason that the new behaviour is not 100%
compatible.  There are a few situations where the new code
produces a different layout of the button bar.  In general, the
new algorithms are more error tolerant than the old one.

It does not make much sense to use the old algorithm for new
configs.

> there shouldn't be any "dumb" option.

You are right about the naming.  The option should not be called
"dumb".  Perhaps it can be removed completely.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]