Subject: Some fixes to fvwm95-setup

From: Lorenz Minder <[email-masked]>
Date: Fri, 2 Feb 2001 00:43:03 +0100

Dear Fvwm-Workers

I recently (i.e. fvwm-snap-20010126) tested fvwm without config, to run
the setup scripts. Besides the fact that it didn't run out of the box
first, I must say, the fvwm-95-config looks very good to me. (I
specially liked the feature, that menus actually just contain software
that's installed.)

Below I have some patches: They contain one obvious bugfix and
some other (potentially controversial) improvements, that is:

*	s/script-fvwm-setup95.pl/fvwm-script-setup95.pl/ in the setup
	script. The other file doesn't exist, and caused 95-Setup to fail.
*	Swapped position of ``ok'' and ``cancel''-button in FvwmScript-Quit.
	This is how those buttons are placed usually.
*	Minor Typo fix in Start-Menu: ``Maple'' instead of ``Mapel''
*	Make Window-Buttons have ActiveDown and Toggled states.
*	Gradient Title-Bars, somewhat like Win98.
*	Make Mousecursor be left-ptr almost everywhere.

The pressed-in buttons need new buttons, I attached them below.

Thanks for the great WM. Regards,
--Lorenz
--- ./modules/FvwmScript/Scripts/FvwmScript-Quit.orig	Thu Dec 21 13:30:11 2000
+++ ./modules/FvwmScript/Scripts/FvwmScript-Quit	Thu Feb  1 23:58:25 2001
@@ -61,7 +61,7 @@
 Property
  Title {OK}
  Size 60 28
- Position 300 225
+ Position 40 225
  Flags NoReliefString
  Type PushButton
  Value 1
@@ -103,7 +103,7 @@
 Property
  Title {Cancel}
  Size 60 28
- Position 40 225
+ Position 300 225
  Flags NoReliefString
  Type PushButton
  Value 1
@@ -223,20 +223,3 @@
    Set $ToDo = Restart
   End
 End
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
--- ./modules/FvwmScript/Scripts/FvwmScript-Setup95.in.orig	Thu Feb  1 00:46:31 2001
+++ ./modules/FvwmScript/Scripts/FvwmScript-Setup95.in	Thu Feb  1 00:47:05 2001
@@ -1393,7 +1393,7 @@
    # Create the fvwm user home dir if needed
    Do {[Exec /bin/mkdir -p } $FDIR
  
-   # Backup: script-fvwm-setup95.pl do that
+   # Backup: fvwm-script-setup95.pl do that
    
    Set $ImagePath = (GetTitle 24)
    Set $SoundPath = (GetTitle 29)
@@ -1441,7 +1441,7 @@
    If $KdeUserMenu == {1} Then
       Set $KdeMenu = {1}
 
-   Set $PERLCMD = $DATADIR{/script-fvwm-setup95.pl --configin=} $INPUT { --dirout=} $FDIR { --fvwm=} $Fvwm { --sxs=} $Slow { --km=} $KdeMenu { --ksm=} $KdeSysMenu { --kum=} $KdeUserMenu { --kfm=} $KfmIcons { --gmg=} $GnomeMenuGtk { --gsmg=} $GnomeSysMenuGtk { --gumg=} $GnomeUserMenuGtk { --grmg=} $GnomeRHMenuGtk { --gsmf=} $GnomeSysMenuFvwm { --gumf=} $GnomeUserMenuFvwm { --grmf=} $GnomeRHMenuFvwm { --gs=} $GnomeSession { --gy=} $GnomeY { --gpath=} $GnomePath { --cde=} $Cde { --stroke=} $Stroke { --lap=} $Laptop { --pp=} $PanelStaysPut { --editor="} $Editor {" --reditor="} $Reditor {" --file="} $FileMgr {" --term="} $Term {" --spl="} $SoundPlayer {" --spa=} $SoundPath { --i=} $IP { --ip=} $ImagePath { --dip="} $DefImagePath {"}
+   Set $PERLCMD = $DATADIR{/fvwm-script-setup95.pl --configin=} $INPUT { --dirout=} $FDIR { --fvwm=} $Fvwm { --sxs=} $Slow { --km=} $KdeMenu { --ksm=} $KdeSysMenu { --kum=} $KdeUserMenu { --kfm=} $KfmIcons { --gmg=} $GnomeMenuGtk { --gsmg=} $GnomeSysMenuGtk { --gumg=} $GnomeUserMenuGtk { --grmg=} $GnomeRHMenuGtk { --gsmf=} $GnomeSysMenuFvwm { --gumf=} $GnomeUserMenuFvwm { --grmf=} $GnomeRHMenuFvwm { --gs=} $GnomeSession { --gy=} $GnomeY { --gpath=} $GnomePath { --cde=} $Cde { --stroke=} $Stroke { --lap=} $Laptop { --pp=} $PanelStaysPut { --editor="} $Editor {" --reditor="} $Reditor {" --file="} $FileMgr {" --term="} $Term {" --spl="} $SoundPlayer {" --spa=} $SoundPath { --i=} $IP { --ip=} $ImagePath { --dip="} $DefImagePath {"}
 
   Do {BusyCursor Read True}
   Do {Echo Piperead 'perl } $PERLCMD {'}
--- ./sample.fvwmrc/system.fvwm2rc-sample-95.orig	Thu Feb  1 23:52:23 2001
+++ ./sample.fvwmrc/system.fvwm2rc-sample-95	Fri Feb  2 00:11:01 2001
@@ -168,7 +168,12 @@
 # Set the root cursor
 #------------------------------------------------------------------------------
 
-CursorStyle ROOT top_left_arrow
+CursorStyle MENU	94
+CursorStyle ROOT	68
+CursorStyle TITLE	68
+CursorStyle SYS		68
+CursorStyle SELECT	68
+CursorStyle DEFAULT	68
 
 #------------------------------------------------------------------------------
 # Fonts - one for window titles, another for icons, and another for the menus
@@ -210,15 +215,38 @@
 Style	"*"	FvwmBorder  # MWMBorder
 BorderStyle	Inactive -- HiddenHandles NoInset
 BorderStyle	Active -- HiddenHandles NoInset
-TitleStyle	ActiveUp (solid Blue4 -- Flat)
-TitleStyle	ActiveDown (solid Blue4 -- Flat)
+TitleStyle	ActiveUp (HGradient 128 Blue4 DeepSkyBlue -- Flat)
+TitleStyle	ActiveDown (HGradient 128 Blue4 DeepSkyBlue -- Flat)
 TitleStyle	Inactive (solid grey51 -- Flat)
 TitleStyle	LeftJustified
-ButtonStyle	1	MiniIcon (-- flat)
-ButtonStyle	all	-- UseTitleStyle Flat
-AddButtonStyle	2	Pixmap mini.winXX-close.xpm
-AddButtonStyle	4	Pixmap mini.winXX-maximize.xpm
-AddButtonStyle	6	Pixmap mini.winXX-minimize.xpm
+ButtonStyle	all	- clear
+ButtonStyle	all	-- flat
+AddButtonStyle	all	Inactive solid grey51
+AddButtonStyle	1	ActiveUp solid Blue4 
+AddButtonStyle	1	ActiveDown solid Blue4 
+AddButtonStyle	1	MiniIcon 
+AddButtonStyle	2	ActiveUp solid DeepSkyBlue 
+AddButtonStyle	2	ActiveUp Pixmap mini.winXX-close.xpm 
+AddButtonStyle	2	Inactive Pixmap mini.winXX-close.xpm 
+AddButtonStyle	2	ActiveDown solid DeepSkyBlue 
+AddButtonStyle	2	ActiveDown Pixmap mini.winXX-close-pressed.xpm 
+ButtonStyle		4	- MwmDecorMax
+AddButtonStyle	4	ActiveUp solid DeepSkyBlue 
+AddButtonStyle	4	ActiveUp Pixmap mini.winXX-maximize.xpm 
+AddButtonStyle	4	Inactive Pixmap mini.winXX-maximize.xpm 
+AddButtonStyle	4	ActiveDown solid DeepSkyBlue 
+AddButtonStyle	4	ActiveDown Pixmap mini.winXX-maximize-pressed.xpm 
+AddButtonStyle	4	ToggledActiveUp solid DeepSkyBlue 
+AddButtonStyle	4	ToggledActiveUp Pixmap mini.winXX-normalize.xpm 
+AddButtonStyle	4	ToggledInactive solid grey51
+AddButtonStyle	4	ToggledInactive Pixmap mini.winXX-normalize.xpm 
+AddButtonStyle	4	ToggledActiveDown solid DeepSkyBlue 
+AddButtonStyle	4	ToggledActiveDown Pixmap mini.winXX-normalize-pressed.xpm 
+AddButtonStyle	6	ActiveUp solid DeepSkyBlue 
+AddButtonStyle	6	ActiveUp Pixmap mini.winXX-minimize.xpm 
+AddButtonStyle	6	Inactive Pixmap mini.winXX-minimize.xpm 
+AddButtonStyle	6	ActiveDown solid DeepSkyBlue 
+AddButtonStyle	6	ActiveDown Pixmap mini.winXX-minimize-pressed.xpm 
 
 #FVWM 11
 #Style	"*"	FvwmBorder
@@ -360,8 +388,10 @@
 #------------------------------------------------------------------------------
 Style * MWMFunctions
 Style * MWMDecor
+Style * MWMButtons
 Style * HintOverride
 Style * OLDecor
+Style * DecorateTransient
 
 BusyCursor DynamicMenu True, Read True
 
@@ -1606,7 +1636,7 @@
 + "Thx-1138%mini.calc.xpm%"	Exec exec thx-1138
 +  "GNU &plot%mini.graph.xpm%"	Exec exec xterm -T GNUplot -name GNUplot -e gnuplot
 + "&SCILAB%mini.zoom.xpm%"		Exec exec scilab
-+ "&Mapel%mini.graph2.xpm%"		Exec exec xmaple
++ "&Maple%mini.graph2.xpm%"		Exec exec xmaple
 + "&Mathematica%mini.graph2.xpm%"	Exec exec mathematica
 + "&Xaos%mini.fractal.xpm%"		Exec exec xaos
 + "&Fractint%mini.fractal.xpm%"		Exec exec xterm -font 7x14 -e xfractint

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 3 Feb 2001 06:35:05 -0600

> specially liked the feature, that menus actually just contain software

Yes, a good feature. For a more complete solution there is fvwm-themes,
it includes redmond98 theme among others.

> 	script. The other file doesn't exist, and caused 95-Setup to fail.

Woops. Obviously I had both files when tested this. :)

> 	This is how those buttons are placed usually.

I would prefer someone else to change or not to change this, since I am
not sure there was no reason for such button placement.

> *	Minor Typo fix in Start-Menu: ``Maple'' instead of ``Mapel''

Ok.

> *	Gradient Title-Bars, somewhat like Win98.

Seems good, but there are pros and cons for these changes. For example,
using gradients with 8bpp is not quite good.

I think we may try to incorporate this in fvwm-themes, maybe as options.
After that we may decide whether to duplicate this into fvwm or not.
This also would require changes in fvwm_icons on the web.

> *	Make Mousecursor be left-ptr almost everywhere.

Ok, applied with small changes. A better solution for cursors is to create
pixmap cursors similar to ones used in the mentioned OS.

If you want to do this, please implement this in fvwm-themes by adding
cursors@redmond98 component. You may take a look at cursors@ components in
other themes to figure out how to do this.

> Thanks for the great WM. Regards,

Thank you for the patch.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]