Subject: Re: more menu problems

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 19 Feb 2001 08:59:26 -0600

On 11 Jan 2001 10:50:16 +0100, Dominik Vogt wrote:
> 
> On Wed, Jan 10, 2001 at 12:33:39PM -0600, Mikhael Goikhman wrote:
> 
> > I think that the second click on the same submenu item should "unpost"
> > the submenu, i.e. return menus to the original browsing mode.
> 
> Good idea and probably trivial to implement.

It works ecceptably ok now, but not exactly as I suggested.
Currently, when you click on submenu item in level 1, it is unposted, when
you click on submenu item in other levels (-2, -1, 0, 2) it is reposted.

I suggested that it is always reposted except when you click at the same
submenu item that previously posted the menu. This seems more functional
and less confusing to me. It requires remembering the posting item.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 19 Feb 2001 16:56:01 +0100

> and less confusing to me. It requires remembering the posting item.

I don't really understand what you mean.  Currently the code works
like this:  Whenever you click on a submenu item and the menu is
not yet posted (either because the menu is not in 'posted' mode or
because another submenu is currently posted in the same menu) the
submenu is posted.  Clicking on the item again unposts the menu
and all its parent menus.  Clicking on one of the parent items
of the currently posted menu closes the current menu and all menus
between it and the clicked ancestor and posts the corresponding
submenu.

I think that's exactly how it's supposed to be:  When you use the
posting mode of menu navigation you expect that every click posts
a menu.  The only exception is that if you accidentally post a
menu (i.e. you don't use 'posting' mode) this disables posting
again.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 19 Feb 2001 10:35:30 -0600

> menu (i.e. you don't use 'posting' mode) this disables posting

I will try to explain this differently.
I think that the condition in the line 1589 is not the best one.

Here is an example from fvwm-themes. There is a menu tree:

	Theme Management ->
		current ->
			Settings ->
				Animation ->
					Disabled
		mytheme ->

Let use the default MenuStyle PopupDelay/PopdownDelay for simplicity.
Click on "current". Its submenu is posted. Click again - unposted.
Now, repeat the same but with a small change.
Click on "current". Its submenu is posted. Visit "Settings", return to
"current", click - its submenu is reposted this time. I think this is
confusing, it should not depend on whether I visited "Settings" or not.

What I suggest is - if you posted a submenu by clicking on "current",
then click on it (and only on it) for the second time, you return to the
browsing (non-posting) mode. If you click on a different submenu item
("Theme Management", "mytheme", "Settings", "Animation") this new submenu
will be reposted instead of the "current" one.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 19 Feb 2001 18:32:47 +0100

> confusing, it should not depend on whether I visited "Settings" or not.

Okay, I see this problem too.  I'll check the code later.

> will be reposted instead of the "current" one.

That is what's currently implemented.

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 19 Feb 2001 18:48:06 -0600

> Okay, I see this problem too.  I'll check the code later.

It is better now. Still there are unpostings where you would expect
repostings.

Two examples, click on "current", posted, click on "Settings", unposted
instead of reposted. Or click on "Animation", posted, then on "Settings",
unposted instead of reposted.

P.S. You asked to warn you to go to bed (just in case you are online yet).

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 20 Feb 2001 16:13:11 +0100

> unposted instead of reposted.

Should be fixed with the rewrite.

> P.S. You asked to warn you to go to bed (just in case you are online yet).

It's 4 pm here :)

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 20 Feb 2001 10:04:51 -0600

> Should be fixed with the rewrite.

I would be glad to say yes, but it is not yet. Now when you unpost a menu
the effect is as you posted its parent.

Example, go to "Settings", click, post, click, unpost, the effect is like
you posted "current".

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 20 Feb 2001 17:14:01 +0100

> Example, go to "Settings", click, post, click, unpost, the effect is like

Well, at least that's how I thought it should work :)

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 20 Feb 2001 10:37:18 -0600

Yes! This last commit did it. :-)

Regards,
Mikhael.