Subject: Notification: incoming/691

From: [email-masked]
Date: Tue, 16 Jan 2001 01:41:53 -0600

FVWM Bug Tracking notification

new message incoming/691

Message summary for PR#691
	From: [email-masked]
	Subject: Menus Feature Request: AutoPopup/NoAutoPopupI
	Date: Tue, 16 Jan 2001 01:57:44 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Tue Jan 16 01:41:53 2001
Date: Tue, 16 Jan 2001 01:57:44 -0600 (CST)
From: [email-masked]
To: [email-masked]
Subject: Menus Feature Request: AutoPopup/NoAutoPopupI

Full_Name: Neil Zanella
Version: 2.3.27
CVS_Date: 
OS: Linux 2.2.18
X_Server: XFree86 3.3.6
Submission from: (NULL) (24.108.214.226)

Hello,

It would be nice if fvwm2 had a feature called NoAutoPopup
which would keep a submenu from poping up unless the user
explicitly placed the mouse cursor on the menu's triangle
region found on the right hand side. This would allow
a user to scroll up and down a menu with submenues without
having to endure all that unwanted stuff popping up.
When a user WANTS a menu to pop up then the user can tell
fvwm to perform that action by moving the mouse over the
triangle.

Thanks!

Keep up the good work!

Neil

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 16 Jan 2001 14:53:55 -0600

> fvwm to perform that action by moving the mouse over the

FVWM already has this feature, it is called PopupDelayed. If you use

  MenuStyle * PopupDelayed, PopupDelay 0    # zero means infinity

this should do what you want in 2.3.27 - don't popup automatically until
you move to the right part of an item (about 25%, near triangle).

But in the current CVS PopupDelay is broken. Once submenu is pops up it is
not pops down if you move to an item on the down or up. Specifying
PopdownImmediately instead PopdownDelayed helps a bit, now a new submenu
may replace an old one, but it still does not pops down at all.

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 16 Jan 2001 15:15:47 -0600

> may replace an old one, but it still does not pops down at all.

I should get English lessons on usage of "is" and "does" with "pops"...

Regards,
Mikhael.