Subject: WindowList is broken in cvs fvwm

From: Alexander Kotelnikov <[email-masked]>
Date: Fri, 12 Jan 2001 20:41:05 +0300

Hello.

I just upgraded from 2.3.27 to cvs versin and got fvwm segfaul'ing when
it try to run WindowList (that is binded to mouse 3).

Here are the lines I get from fvwm:

X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  2 (X_ChangeWindowAttributes)
  Resource id in failed request:  0xe00009
  Serial number of failed request:  70
  Current serial number in output stream:  76
X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)
  Major opcode of failed request:  65 (X_PolyLine)
  Resource id in failed request:  0x120000a
  Serial number of failed request:  89
  Current serial number in output stream:  105

I was not able to run fvwm2 under gdb for. I do not know why, gdb just
stops.

-- 
Alexander Kotelnikov
Saint-Petersburg, Russia
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 12 Jan 2001 21:47:26 +0100

> it try to run WindowList (that is binded to mouse 3).

Yes, that's a know bug.  I didn't get around to identify the exact
cause yet.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Alexander Kotelnikov <[email-masked]>
Date: Sat, 20 Jan 2001 12:54:18 +0300

Hi,
WinList execution crashes fvwm if q3demo is running. No time to debug so
just report.
I have ~5 deys old cvs version.

xwininfo on q3demo:

sacha@akk ~ > xwininfo 

xwininfo: Please select the window about which you
          would like information by clicking the
          mouse in that window.

xwininfo: Window id: 0x1c00002 (has no name)

  Absolute upper-left X:  18
  Absolute upper-left Y:  50
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 1024
  Height: 768
  Depth: 16
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x1c00001 (installed)
  Bit Gravity State: ForgetGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +18+50  -558+50  -558-382  +18-382
  -geometry 1024x768+18+50

.xsession-errors:

/home/sacha/.xsession: line 11:  4680 Segmentation fault      fvwm2
X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)
  Major opcode of failed request:  62 (X_CopyArea)
  Resource id in failed request:  0xc00007
  Serial number of failed request:  249
  Current serial number in output stream:  252
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  61 (X_ClearArea)
  Resource id in failed request:  0x1200005
  Serial number of failed request:  241
  Current serial number in output stream:  243
On Fri, Jan 12, 2001 at 08:41:05PM +0300, Alexander Kotelnikov wrote:

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 20 Jan 2001 15:54:13 +0100

> I have ~5 deys old cvs version.
Please provide a stack trace and the command you used to bring up
the window list.

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 27 Jan 2001 16:06:12 +0100

> xwininfo: Window id: 0x1c00002 (has no name)

The crash was most likely caused by the missing window title.
Normally, the title should then be replaced by "Untitled"
internally, but this did not work always and caused a crash in
serveral places.  This is fixed in the current CVS code.

Bye

Dominik ^_^  ^_^