Subject: CopyMenuStyle patch

From: Olivier Chapuis <[email-masked]>
Date: Thu, 11 Jan 2001 10:01:05 +0100

Hello,

Attached to this message a patch against the current cvs.
This patch contains a new configuration *command*
"CopyMenuStyle orig dest" that copy the MenuStyle orig
to the MenuStyle dest (if dest does not exist it is created).

Why we can apply this patch:
1 - It is good and useful :o)
2 - It is not a new MenuStyle (the UseMenuStyle patch from
Pekka Marjola was a menu style option and interact a lot
with the MenuStyle code) here the code is disjoint from the
current menu code, so only the use of CopyMenuStyle can cause
new problems.
3 - I do not think that the CopyMenuStyle code can cause new
problems, I've extensively test it and think a bit ... any way
it is better that one read the CopyMenuStyle function (I will be
interested by any comments even if the patch is not applied).

Why we do have to apply this patch:
1 - we are in feature freeze!

So, I think that this patch is good but also that only
Dominik can take the responsibility to apply it.

Here the ChangeLog:

* fvwm/menu.c (CopyMenuStyle):
* fvwm/menu.h:
* fvwm/function.{c,h}:
* fvwm/fvwm2.1:
* test/purify/purify.fvwm2rc:
* NEWS:
New function and config command CopyMenuStyle which copy a menu style
to an other one.
Warning I've wrote the documentation! 

If this patch is applied IMHO the only important thing that FVWM
menus do not have is an "ApplyToSubMenu" MenuStyle option ...

Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 8 Jan 1904 21:33:17 +0100

> interested by any comments even if the patch is not applied).

I'm not against applying this even at this time.  It looks fairly
safe to me, and even if it is broken somewhere, you do not have to
use the command.  You say you have extensively tested this.
Please add your tests to the purify.fvwm2rc so these can be run
for every future release too.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 11 Jan 2001 11:34:14 +0100

Dominik Vogt wrote:
> use the command.  

Great! If there are no objections I will apply the patch my self
in a few days.

> You say you have extensively tested this.

The patch already contains this :o)

Olivier

---

From: Pekka Marjola <[email-masked]>
Date: 11 Jan 2001 12:40:58 +0200

>>>>> In <[email-masked]>,
>>>>> On Thu, 11 Jan 2001 10:01:05 +0100,
>>>>> "Olivier" == Olivier Chapuis <[email-masked]> writes:

Olivier> 1 - we are in feature freeze!

My rewrite of usemenustyle to copymenustyle was waiting for 2.4. Oh well,
I didn't bother to clean it anyway (though it is applied to my source).

Olivier's patch looks fine, and I'll be testing it :)

Now only important things on my wish list are CopyDecor and colorsets
in decors :)

-- 
[email-masked] * http://www.iki.fi/pema/
pema-init-0.17 @ http://www.iki.fi/pema/emacs/
zbkrc-0.18 @ http://www.iki.fi/pema/zbkrc/
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 11 Jan 2001 12:30:08 +0100

> Olivier's patch looks fine, and I'll be testing it :)

Better to use the attached patch (fix a logic bug which
"should" never happen ...).

Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 9 Jan 1904 00:08:37 +0100

> Now only important things on my wish list are CopyDecor and colorsets

For 3.0, we'll probably throw away the whole concept of decors
anyway.

Bye

Dominik ^_^  ^_^

---

From: Pekka Marjola <[email-masked]>
Date: 11 Jan 2001 15:18:02 +0200

>>>>> In <[email-masked]>,
>>>>> On Sat, 9 Jan 1904 00:08:37 +0100,
>>>>> "Dominik" == Dominik Vogt <[email-masked]> writes:

>> Now only important things on my wish list are CopyDecor and colorsets

Dominik> For 3.0, we'll probably throw away the whole concept of decors
Dominik> anyway.

How about a patch for 2.4 (I might have time)?