Subject: icon title crash and missing window titles with multibyte

From: Dominik Vogt <[email-masked]>
Date: Tue, 23 Jan 2001 13:34:08 +0100

Configuration Information [Automatically generated, do not change]:
uname output: Linux DarkSun 2.2.14 #14 Thu Sep 7 00:59:26 CEST 2000 i686 unknown
Compiler: gcc
Compilation CFLAGS: -Wall -Werror -O2 -g
prefix: /usr/local

FVWM Version:   2.3.28 (current CVS)
FVWM_MODULEDIR: /usr/local/libexec/fvwm/2.3.28
FVWM_DATADIR:   /usr/local/share/fvwm
FVWM_USERDIR:   /home/luthien/.fvwm

Description:
        Iconifying transients crashes fvwm; transients do not show up in
        modules.

Repeat-By:
        - Start FvwmPager and FvwmIconMan
        - Start Netscape
        - Select "edit" "preferences" to bring up a transient window.
          --> The transient is not shown in FvwmIconMan at all.  It is
              visible in FvwmPager, but has no title there.
          Both effects occur only if multibyte support is compiled in
        - Iconify the transient
          --> core dump
          (this happens with and without multibyte supprot)

#0  0x8069424 in CreateIconWindow (tmp_win=0x811cb10, def_x=122, def_y=163)
    at icons.c:205
#1  0x806b2b1 in Iconify (tmp_win=0x811cb10, def_x=122, def_y=163)
    at icons.c:1397
#2  0x806b654 in iconify_function (eventp=0x809c740, w=4194713,
    tmp_win=0x811cb10, context=64, action=0x8107fcf "", Module=0xbfffeec4)
    at icons.c:1541
#3  0x8072b98 in execute_function (efa=0xbfffeeb0) at functions.c:1084
...

Fix:
        No idea, but almost certainly caused by the latest icon
        title patch?

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 23 Jan 2001 18:28:20 -0600

>           (this happens with and without multibyte supprot)

I can't reproduce any problem described here. Tried with Netscape 3, 4 and
Mozilla; with or without multibyte support. FvwmIconMan and FvwmPager with
%i format work as expected for me. I also tried your theme (including your
module panel and styles for transients), no problems. Tried to iconify
"Netscape" and/or "Preferences" (despite of its hints). No core dumps.

I did noticed that when I compile with multibyte support, iconifying and
deiconifying of Netscape and its transient may cause pager to show olny
one window instead of two.

>         No idea, but almost certainly caused by the latest icon

Sorry, I can't see how this may be related from the trace stack.
I would debug this if I was able to reproduce any problem.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 24 Jan 2001 13:01:33 +0100

> I would debug this if I was able to reproduce any problem.

Well, since the crash happens in an XTextWidth call in icons.c
this seems a logical conclusion.  I'll look into thi and let
you know what I find out.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 27 Jan 2001 16:16:27 +0100

>         No idea, but almost certainly caused by the latest icon

Fixed.  A NULL pointer was not replaced by "Untitled" as the
icon name.

Bye

Dominik ^_^  ^_^