Subject: new (easily fixable? :) .26 segfault on solaris

From: "Nils Lohner" <[email-masked]>
Date: Tue, 02 Jan 2001 16:43:43 +0100

I'm not sure if this is the same segfault as before or not, and I'm 
also not sure if that loop should check for NULL pointers as an end (or 
error) condition and produce an error if it finds one.

This crash occurred when opening acrobat plain and simple.  The version 
is vanilla .26

Nils.

/sup/installed/fvwm-2.3.26/fvwm > fvwm2 -version
[FVWM][main]: <<DEBUG>> Entered, about to parse args
FVWM version 2.3.26 compiled on Jan  2 2001 at 10:53:56
with support for: ReadLine, XPM, GNOME WM hints, SM

/sup/installed/fvwm-2.3.26/fvwm > gdb fvwm2
GNU gdb 5.0
Copyright 2000 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and 
you are
welcome to change it and/or distribute copies of it under certain 
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for 
details.
This GDB was configured as "sparc-sun-solaris2.7"...
(gdb) !ls *core
Undefined command: "".  Try "help".
(gdb) core ducrocq-2000-01-02.core
Core was generated by `/sup/bin/fvwm2'.
Program terminated with signal 11, Segmentation Fault.
Reading symbols from /sup/lib/libXpm.so.4.11...done.
Loaded symbols for /sup/lib/libXpm.so.4.11
Reading symbols from /usr/openwin/lib/libSM.so.6...done.
Loaded symbols for /usr/openwin/lib/libSM.so.6
Reading symbols from /usr/openwin/lib/libICE.so.6...done.
Loaded symbols for /usr/openwin/lib/libICE.so.6
Reading symbols from /usr/openwin/lib/libXext.so.0...done.
Loaded symbols for /usr/openwin/lib/libXext.so.0
Reading symbols from /usr/openwin/lib/libX11.so.4...done.
Loaded symbols for /usr/openwin/lib/libX11.so.4
Reading symbols from /usr/lib/libsocket.so.1...done.
Loaded symbols for /usr/lib/libsocket.so.1
Reading symbols from /usr/lib/libnsl.so.1...done.
Loaded symbols for /usr/lib/libnsl.so.1
Reading symbols from /usr/lib/libm.so.1...done.
Loaded symbols for /usr/lib/libm.so.1
Reading symbols from /usr/lib/libc.so.1...done.
Loaded symbols for /usr/lib/libc.so.1
Reading symbols from /usr/lib/libdl.so.1...done.
Loaded symbols for /usr/lib/libdl.so.1
Reading symbols from /usr/lib/libmp.so.2...done.
Loaded symbols for /usr/lib/libmp.so.2
Reading symbols from /usr/platform/SUNW,Ultra-5_10/lib/libc_psr.so.1...d
one.
Loaded symbols for /usr/platform/SUNW,Ultra-5_10/lib/libc_psr.so.1
#0  0x2c9b4 in get_transientfor_fvwmwindow (t=0x0) at stack.c:219
219       for (s = Scr.FvwmRoot.next; s != &Scr.FvwmRoot; s = s->next)
(gdb) where
#0  0x2c9b4 in get_transientfor_fvwmwindow (t=0x0) at stack.c:219
#1  0x4a61c in setup_layer (tmp_win=0xcf308, pstyle=0xffbeeb50)
    at add_window.c:481
#2  0x4bd84 in AddWindow (w=4290702328, ReuseWin=0xffbeebb4)
    at add_window.c:1337
#3  0x2fb38 in HandleMapRequestKeepRaised (KeepRaised=0, ReuseWin=0x0)
    at events.c:883
#4  0x2fa80 in HandleMapRequest () at events.c:852
#5  0x323d0 in DispatchEvent (preserve_Tmp_win=0) at events.c:2532
#6  0x324d0 in HandleEvents () at events.c:2585
#7  0x51d14 in main (argc=1, argv=0xffbef2fc) at fvwm.c:736
(gdb) p s
$1 = (FvwmWindow *) 0x0
(gdb) l
214       FvwmWindow *s;
215     
216       if (!t || !IS_TRANSIENT(t) || t->transientfor == Scr.Root ||
217           t->transientfor == None)
218         return NULL;
219       for (s = Scr.FvwmRoot.next; s != &Scr.FvwmRoot; s = s->next)
220       {
221         if (s->w == t->transientfor)
222         {
223           return s;

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Tue, 02 Jan 2001 10:52:17 -0500

> #1  0x4a61c in setup_layer (tmp_win=0xcf308, pstyle=0xffbeeb50)

That bug was fixed in CVS and current snapshots.
It should be checking for NULL.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Nils Lohner <[email-masked]>
Date: Tue, 02 Jan 2001 17:38:56 +0100

In message <[email-masked]>, Dan Espen 
>It should be checking for NULL.

Are the snapshots generated automatically?  They seem to stop on the 
26th, and that was when the 2.3.26 release was made...

Nils.

Directory of ftp://ftp.fvwm.org/pub/fvwm/devel/snapshots/

total 40918
drwxr-xr-x   2 tibbs    staff        2048 Dec 26 12:35 .
drwxr-xr-x   4 tibbs    staff         512 Mar 23  1999 ..
-rw-r--r--   1 tibbs    15         327601 Dec 26 12:30 ChangeLog
-rw-r--r--   1 tibbs    15          68095 Dec 26 12:30 NEWS
-rw-r--r--   1 tibbs    15        1577756 Dec  1 12:32 
fvwm-snap-20001201.tar.gz
-rw-r--r--   1 tibbs    15        1578551 Dec  2 12:33 
fvwm-snap-20001202.tar.gz
-rw-r--r--   1 tibbs    15        1578610 Dec  3 12:32 
fvwm-snap-20001203.tar.gz
...
-rw-r--r--   1 tibbs    15        1587602 Dec 24 12:32 
fvwm-snap-20001224.tar.gz
-rw-r--r--   1 tibbs    15        1587616 Dec 25 12:32 
fvwm-snap-20001225.tar.gz
-rw-r--r--   1 tibbs    15        1587623 Dec 26 12:35 
fvwm-snap-20001226.tar.gz