Subject: unable to commit ChangeLog

From: Dominik Vogt <[email-masked]>
Date: Sun, 14 Jan 2001 22:02:51 +0100

When I try to commit the ChangeLog, I get this CVS error message:

  Checking in ChangeLog;
  /home/cvs/fvwm/fvwm/ChangeLog,v  <--  ChangeLog
  new revision: 1.1157; previous revision: 1.1156
  cvs [server aborted]: could not open lock file `/home/cvs/fvwm/fvwm/,ChangeLog,': File exists
  cvs commit: saving log message in /tmp/cvsGfFROP

This looks as if a previous commit went terribly wrong.  Can you
do something about this, Jason?

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sun, 14 Jan 2001 16:19:02 -0500

> do something about this, Jason?

Darn, I thought there was something wrong on my end.  I was getting
the same message.  Now I have conflict markers all over fvwm2.1.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Jason L Tibbitts III <[email-masked]>
Date: 16 Jan 2001 13:29:13 -0600

Sorry, folks, I was away yesterday (enjoying the last holiday we get for a
while).  CVS occasionally leaves stale locks like this; I wish I knew what
caused it.  I removed the offending lock this morning.

I don't know what could cause the conflict markers in fvwm2.1 outside of
someone actually checking in the result of a merge with conflicts.  The
conflict markers are generated by the client, not the server.

 - J<

---

From: Dan Espen <[email-masked]>
Date: Tue, 16 Jan 2001 14:46:28 -0500

> caused it.  I removed the offending lock this morning.

Perhaps a cron that detects them and if they are more than an hour or
2 old, removes them?

> conflict markers are generated by the client, not the server.

The conflict markers are normal.  Both Dominik and I decided to
revise the same section of the man page.

---

From: Jason L Tibbitts III <[email-masked]>
Date: 16 Jan 2001 15:02:59 -0600

>>>>> "DE" == Dan Espen <[email-masked]> writes:

DE> Perhaps a cron that detects them and if they are more than an hour or 2
DE> old, removes them?

As far as I know, other sites running far busier servers don't do such a
thing, even though it seems obvious.  I'm not sure if a newer CVS server
would help.

I need to move the CVS and FTP services off of the current machine anyway,
so we'll have the current server revision by default.

DE> The conflict markers are normal.  Both Dominik and I decided to revise
DE> the same section of the man page.

I thought you had actually seen them in the repository version.

 - J<

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 17 Jan 2001 11:12:13 +0100

> revise the same section of the man page.

BTW, Dan, if you think you can phrase the description of the
placement options better than I did, please do.  I am not happy
with the current wording.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]