Subject: CVS domivogt: * Keyboard shortcut w/ paging fixes.

From: CVS <[email-masked]>
Date: Wed, 3 Jan 2001 13:45:30 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	01/01/03 13:45:29

Modified files:
	.              : ChangeLog 
	fvwm           : add_window.c events.c events.h fvwm.h style.c 
	                 style.h virtual.c window_flags.h 
	libs           : Target.c 

Log message:
* Keyboard shortcut w/ paging fixes.
* Icon override style is honoured by icon hint handling after when the window
already exists.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 03 Jan 2001 16:33:41 -0500

> * Icon override style is honoured by icon hint handling after when the window

I don't know what causes it yet, but twice since I've started using this,
I've looked over at my XEmacs live-icon and it turned solid gray.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "Paul D. Smith" <[email-masked]>
Date: 03 Jan 2001 17:03:18 -0500

%% Dan Espen <[email-masked]> writes:

  de> I don't know what causes it yet, but twice since I've started
  de> using this, I've looked over at my XEmacs live-icon and it turned
  de> solid gray.

Should we start calling you Dan "Medusa" Espen now? :)

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>    HASMAT--HA Software Methods & Tools
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 03 Jan 2001 18:20:00 -0500

> Should we start calling you Dan "Medusa" Espen now? :)

Its not Medusa's gaze that turns you to stone, its looking at Medusa.

Do you think this could be fixed with an Amulet of Reflection?

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 5 Jan 2001 00:04:05 +0100

> I've looked over at my XEmacs live-icon and it turned solid gray.

I don't see this, but I found another bug in CreateIconWindow().
The ICON_OVERRIDE stuff was not handled properly there.  I'm not
sure it fixes your problem, so I left my debug fprintfs in the
code.  Hopefully this helps identifying the problem.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]