Subject: CVS chrisr: Modify fvwmSelect() semantics so that returning -1 means "interrupted"

From: CVS <[email-masked]>
Date: Wed, 17 Jan 2001 09:10:01 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	chrisr	01/01/17 09:10:01

Modified files:
	.              : ChangeLog 
	fvwm           : module_interface.c 
	libs           : fvwmsignal.c 

Log message:
Modify fvwmSelect() semantics so that returning -1 means "interrupted"
and returing 0 means "timed out". ALWAYS set errno to EINTR if we
return -1.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 17 Jan 2001 16:14:30 +0100

> and returing 0 means "timed out". ALWAYS set errno to EINTR if we

Is the SIGCHLD fix completed with this or is there still work to
do, Chris?  If it's complete we can move the item in the todo-2.4
file to closed.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Chris Rankin <[email-masked]>
Date: Thu, 18 Jan 2001 07:38:02 +1100 (EST)

> do, Chris?  If it's complete we can move the item in the todo-2.4

I believe that it's closed. Someone may come along and prove me wrong,
of course.

Chris