Subject: Broken TiledPixmap since 2.3.25 and fix

From: [email-masked]
Date: Fri, 12 Jan 2001 09:21:21 -0500 (EST)

This has been bugging me since fvwm-2.3.25, so I decided to figure out
which "fix" was added to that release that completely broke
TiledPixmaps in TitleStyles in code like:

+	TitleStyle	ActiveUp (TiledPixmap aqua-active.xpm -- Flat)

(I sent email to this list last month describing the problem, complete
with a reproducing .fvwm2rc and pixmaps and everything.  Not one
single person replied to it. [sigh])

Anyway, the change that seems to have broken TiledPixmaps was made on
28-Nov-2000.  I am enclosing a patch that reverts the behavior of
TiledPixmaps to its pre-2.3.25 state (where it was working).

-- 
Larry Gensch                                          [email-masked]

              Working for COMPAQ since the turn of the century
--- fvwm-snap-20010112.orig/fvwm/borders.c	Mon Dec  4 07:30:09 2000
+++ fvwm-snap-20010112/fvwm/borders.c	Fri Jan 12 08:53:49 2001
@@ -190,7 +190,6 @@
 #ifdef MINI_ICONS
     case MiniIconButton:
     case PixmapButton:
-    case TiledPixmapButton:
       if (type == PixmapButton || type == TiledPixmapButton)
 	p = df->u.p;
       else
@@ -201,7 +200,6 @@
       }
 #else
     case PixmapButton:
-    case TiledPixmapButton:
       p = df->u.p;
 #endif /* MINI_ICONS */
       if (DFS_BUTTON_RELIEF(df->style) == DFS_BUTTON_IS_FLAT)
@@ -268,6 +266,12 @@
 	  }
 	}
       }
+      break;
+
+    case TiledPixmapButton:
+      XSetWindowBackgroundPixmap(dpy, win, df->u.p->picture);
+      flush_expose(win);
+      XClearWindow(dpy,win);
       break;
 
     case GradientButton:

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 10 Jan 1904 03:39:33 +0100

> single person replied to it. [sigh])

Well, I thought I had fixed it and I *did* reply, but apparently
my mail never arrived.  Furthermor I did not notice a clipping bug
in my fix because the pixmap I used accidentally had the exact
height of my window titles (minus relief).  I'll apply the proper
fix shortly.  If that still does not solve your probelm, plese
report back.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]