Subject: bug I reported about

From: Alexander Kotelnikov <[email-masked]>
Date: Fri, 12 Jan 2001 22:40:03 +0300

Trouble with WindowList.

It occures only in fvwm is compiled with --enable-kanji. I passed --ggdb
to to gcc while building fvwm and got

when I run gdb fvmw2 I get:

GNU gdb 5.0
Copyright 2000 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu"...
(gdb) run
Starting program: /tmp/fvwm/fvwm/fvwm2 
Cannot access memory at address 0x40017de8
(gdb) continue
Continuing.
Cannot access memory at address 0x40017de8
(gdb) continue
Continuing.

Program received signal SIGSEGV, Segmentation fault.
0x400a60a1 in XmbTextEscapement () from /usr/X11R6/lib/libX11.so.6
(gdb) 

I am running debian 2.2 woody.
ii  libc6          2.2-11         GNU C Library: Shared libraries and Timezone
ii  gcc            2.95.3-4       The GNU C compiler.
ii  libreadline4   4.1-4          GNU readline and history libraries, run-time
ii  librplay3      3.3.2-4        Shared libraries for the rplay network audio
ii  libstroke0     0.3-4          support for strokes like those in Mentor Gra
ii  xlibs          4.0.2-1        X Window System client libraries

I have no problems with 2.3.27. And cvs version does not start at all
now.

Uhh... something wired

CC me, please, I am not subscribed.

-- 
Alexander Kotelnikov
Saint-Petersburg, Russia
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Alexander Kotelnikov <[email-masked]>
Date: Sat, 13 Jan 2001 01:00:23 +0300

I discovered, bug is in fvwm/menus.c, although I get with  gdb:

Program received signal SIGSEGV, Segmentation fault.
DispatchEvent (preserve_Tmp_win=0) at events.c:2562
2562      if (EventHandlerJumpTable[Event.type])

If I take previous versions of menus and functions files I have fvwm
compiled and running. I was wrong when told you fvwm crashes only if it
is configured with --enable-kanji. It crashes without it too. Sorry for
inconvenience. Fvwm crashes when WindowList command is executed.

Sacha

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 13 Jan 2001 00:04:20 +0100

> inconvenience. Fvwm crashes when WindowList command is executed.

Don't worry, it's already fixed.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]