Subject: Meta key combinations

From: "Nils Lohner" <[email-masked]>
Date: Thu, 07 Dec 2000 15:05:59 +0100

I can't get any key combination with Meta to work.  Below the relevant 
data. is it because Meta on the sun keyboard is defined as Meta_L and 
Meta_R maybe?  Do I need to define what the meta keys are somewhere?

Thanks,
Nils.

--doesn't work
Key F3    A    M    Lower
--works
Key Left        A       SC      CursorMove -1  +0
--doesn't work
Key Left        A       SM      CursorMove -10  +0

KeyRelease event, serial 23, synthetic NO, window 0x8c00001,
    root 0x25, subw 0x8c00002, time 1240091342, (43,38), root:(636,61),
    state 0x40, keycode 15 (keysym 0xffc0, F3), same_screen YES,
    XLookupString gives 0 characters:  ""

KeyRelease event, serial 23, synthetic NO, window 0x8c00001,
    root 0x25, subw 0x8c00002, time 1240091678, (43,38), root:(636,61),
    state 0x40, keycode 127 (keysym 0xffe7, Meta_L), same_screen YES,
    XLookupString gives 0 characters:  ""

KeyRelease event, serial 23, synthetic NO, window 0x8c00001,
    root 0x25, subw 0x8c00002, time 1240096609, (43,38), root:(636,61),
    state 0x40, keycode 129 (keysym 0xffe8, Meta_R), same_screen YES,
    XLookupString gives 0 characters:  ""

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Thu, 07 Dec 2000 09:28:06 -0500

> Meta_R maybe?  Do I need to define what the meta keys are somewhere?

That works for me using either "Diamond" key on a Sun Type 4 keyboard.

xev shows the keys defined as Meta_L and Meta_R but thats not what
Fvwm is using.  You need to make sure the modifer "mod1" is associated
with the key.  You can use xkeycaps, or xmodmap:

fork> xmodmap -pm
xmodmap:  up to 3 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x6a),  Shift_R (0x75)
lock        Caps_Lock (0x7e)
control     Control_L (0x53)
mod1        Meta_L (0x7f),  Meta_R (0x81)
mod2        Mode_switch (0x14)
mod3        Num_Lock (0x69)
mod4        Alt_L (0x1a)
mod5        F13 (0x20),  F18 (0x50),  F20 (0x68)

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]