Subject: fvwm-2.2.4 on RH-6.1 (xpm support)

From: "Tim Freedom" <[email-masked]>
Date: Fri, 29 Dec 2000 21:23:07 -0800

I read the FAQ, downloaded all the necessary xpm packages, now when I 
'configure' I get the following,

checking for atexit... yes
checking for XpmReadFileToXpmImage in -lXpm... no
checking for rplay_create in -lrplay... no

config.log contains this,
configure:4230: checking for atexit
configure:4258: gcc -o conftest -g -O2   conftest.c  1>&5
configure:4384: checking for XpmReadFileToXpmImage in -lXpm
configure:4403: gcc -o conftest -g -O2   conftest.c -lXpm -L/usr/X11R6/lib 
-lXpm   -lX11   1>&5
/usr/bin/ld: cannot open -lX11: No such file or directory
collect2: ld returned 1 exit status
configure: failed program was:
#line 4392 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char XpmReadFileToXpmImage();

int main() {
XpmReadFileToXpmImage()
; return 0; }

Which rpm ought I hunt-for for the 'X11' library ??

My command-line is,
./configure --with-xpm-library=/usr/X11R6/lib \
             --with-xpm-includes=/usr/X11R6/include

The xpm libs (xpm-3.4k-1 & xpm-devel-3.4k-1) are straight from RedHat going 
into their standard location, I'd assume ? What I am doing wrong ?  What 
should I do next ?
_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 31 Dec 2000 10:57:45 +0100

> /usr/bin/ld: cannot open -lX11: No such file or directory
                           ^^^^^
To me that looks as if your X11 isb't properly installed.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 30 Dec 2000 17:08:24 -0600

> /usr/bin/ld: cannot open -lX11: No such file or directory

Seems like you don't have XFree86-devel package installed.

Regards,
Mikhael.