Subject: Re: off topic

From: Giuseppe Della Ricca <[email-masked]>
Date: Sun, 3 Dec 2000 18:16:36 +0100 (CET)

Hi Dominik,

first the good news:

there was no need to apply your patch (BTW, the attachment was empty),
because your latest changes solved completely the problem about
clicking-and-dragging an xterm on Linux.

Great !!

Tomorrow I'll check on OSF-True64, too.

Now the bad news ...

There's a new problem, sorry: after restarting, I've lost all the window
started with StartsOnPage:

Style Pine           Icon pine2.xpm, MiniIcon mini.letter.xpm
Style Pine           SkipMapping, StartsOnPage 4 0 0, RandomPlacement

Style Netscape*      MiniIcon mini.netscape.xpm
Style Netscape*      SkipMapping, StartsOnPage 2 0 0, RandomPlacement

They're visible in pager and winlist, but 'they're not there' when I go
in desk 4 and 2: even if I move them 'out of the pager' in the current desk,
they are invisible (but appear on the pager).

Also new Pine and Netscape windows behave the same way: the problem is not
corrected restarting fvwm2 from scratch.

Cheers,
Giuseppe.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 5 Dec 2000 08:22:05 +0100

> Tomorrow I'll check on OSF-True64, too.

What kind of X server does OSF have?  It would be interesting to
know if this only happes with XFree or with any X server.
 
> started with StartsOnPage:

...

Fixed.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Giuseppe Della Ricca <[email-masked]>
Date: Tue, 5 Dec 2000 10:08:49 +0100 (CET)

Hi Dominik,

your commit:

2000-12-05  Dominik Vogt  <[email-masked]>

        * fvwm/events.c (HandleMapRequestKeepRaised):
        fixed staring windows on other desks

fixed the problem I've reported about 'StartOnPage' windows disappearing
after a restart. Good !

Now, if I restart while in a desk different from the first one, some of
my 'Sticky' windows just disappear ...

The 'Sticky' ones that disappear have:

Focus Policy:     Passive
 - Input Field:   True
 - WM_TAKE_FOCUS: Absent

The 'Sticky' one that works has:

Focus Policy:     No Input
 - Input Field:   False
 - WM_TAKE_FOCUS: XGetWMProtocols failed

Cheers,
Giuseppe.

---

From: Giuseppe Della Ricca <[email-masked]>
Date: Tue, 5 Dec 2000 12:35:48 +0100 (CET)

Hi !

> know if this only happes with XFree or with any X server.

I don't know how to check: I think is Digital/Compaq.

Fvwm2 is working fine now for me both on OSF1 and on Linux (apart from the
problem with Sticky windows reported before): the effect of changing from
XCreateGC to fvwm_XCreateGC is not as evident on OSF as on Linux, but it
seems to me that also the speed on OSF1 has increased a bit.

Cheers,
Giuseppe.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 5 Dec 2000 16:51:31 +0100

>  - WM_TAKE_FOCUS: XGetWMProtocols failed

Please check again with the next snapshot.  This ICCCM 'fix' I
started is really causing more trouble that it's worth.

Bye

Dominik ^_^  ^_^