Subject: loosing focus creating off screen windows

From: Dan Espen <[email-masked]>
Date: Tue, 26 Dec 2000 13:46:16 -0500

I have Netscape configured to start on a new page:

Style "Netscape" StartsOnPage 0    0 1, SkipMapping
Style "Netscape" RandomPlacement
Style "*" UsePPosition
Style "Netscape*" NoPPosition

I use mouse focus:

Style "*" MouseFocus

I have   a keyboard  key configured  to  bring up  a menu  that starts
Netscape.  With the latest CVS, if I'm in a window and
use the menu to start Netscape, at around the time the Netscape window
gets created  the window that  I'm  in looses  focus.  My root  window
keybindings work so it looks like focus transfers to the root.
 
-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214             E-mail: [email-masked]
Piscataway, NJ 08854                       Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 27 Dec 2000 04:47:46 +0100

> keybindings work so it looks like focus transfers to the root.

Fixed.  A simple typo in the logic:

  else if (!OnThisPage)
    do_grab_focus = True;

must of course be

  if (!OnThisPage)
    do_grab_focus = False;

(events.c HandleMapRequestKeepRaised())

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]