Subject: Purify test

From: Dan Espen <[email-masked]>
Date: Mon, 04 Dec 2000 09:52:07 -0500

I read the Purify man page, and found I could direct the output to stderr.
Now I get the Purify messages intermixed with the test output.
I'm including just the output leading up to the ABR.  There were some end
of job memory leaks reported that I'm not including.
The only error I see this morning is in the "Refresh_Recapture" part
of the test.
In an earlier run, this ABR seemed to happen twice.  I'm not sure why the
results vary from run to run, but the whole test seems to vary a bit in
effect each time I run it.  The test does need me to click each time I run it,
perhaps the variation comes from variations in what I click on as it runs.

I sure hope Purify is getting this right.  It does issue a message during
startup:

Purify slave: Warning: Non-ABI conforming section found in object file /usr/lib/ld.so.1.
Type code is 1879048188.  Treating section as uninterpreted data.

Our copy is a little old, I'm trying to get a newer version.

This is with current CVS.

### Mon Dec  4 09:35:04 EST 2000: Test Refresh_Recapture ###
[FVWM][FvwmErrorHandler]: <<ERROR>> *** internal error ***
[FVWM][FvwmErrorHandler]: <<ERROR>> Request 12, Error 2, EventType: 6
grab_stats (grabbed): 1 0 1 0 0 0 0 
grab_stats (-ungrab): 0 0 0 0 0 0 0 
grab_stats (grabbed): 1 0 1 0 0 0 0 
grab_stats (-ungrab): 0 0 0 0 0 0 0 
grab_stats (grabbed): 1 0 0 0 1 0 0 
[FVWM][FvwmErrorHandler]: <<ERROR>> *** internal error ***
[FVWM][FvwmErrorHandler]: <<ERROR>> Request 56, Error 7, EventType: 15
[FVWM][FvwmErrorHandler]: <<ERROR>> *** internal error ***
[FVWM][FvwmErrorHandler]: <<ERROR>> Request 56, Error 7, EventType: 15
[FVWM][FvwmErrorHandler]: <<ERROR>> *** internal error ***
[FVWM][FvwmErrorHandler]: <<ERROR>> Request 56, Error 7, EventType: 15
grab_stats (-ungrab): 0 0 0 0 0 0 0 

****  Purify instrumented /opt/public/src/fvwmpurify/fvwm/2.3.25/fvwm2 (pid 10089)  ****
ABR: Array bounds read:
  * This is occurring while in:
	execute_complex_function [functions.c:1622]
	execute_function [functions.c:1115]
	old_execute_function [functions.c:1162]
	execute_complex_function [functions.c:1625]
	execute_function [functions.c:1115]
	do_menu        [menus.c:885]
	menu_func      [menus.c:5138]
	staysup_func   [menus.c:5154]
	execute_function [functions.c:1098]
	old_execute_function [functions.c:1162]
	run_command_stream [read.c:143]
	run_command_file [read.c:217]
	ReadFile       [read.c:269]
	execute_function [functions.c:1098]
	old_execute_function [functions.c:1162]
	ExecuteModuleCommand [module_interface.c:641]
	ExecuteCommandQueue [module_interface.c:1494]
	My_XNextEvent  [events.c:2399]
	HandleEvents   [events.c:2537]
	main           [fvwm.c:730]
  * Reading 4 bytes from 0x3961b8 in the heap.
  * Address 0x3961b8 is 173 bytes past end of a malloc'd block at 0x3960f8 of 20 bytes.
  * This block was allocated from:
	malloc         [rtlib.o]
	safemalloc     [safemalloc.c:42]
	AddToFunction  [functions.c:1396]
	add_item_to_func [builtins.c:435]
	execute_function [functions.c:1098]
	old_execute_function [functions.c:1162]
	execute_complex_function [functions.c:1625]
	execute_function [functions.c:1115]
	old_execute_function [functions.c:1162]
	execute_complex_function [functions.c:1625]
	execute_function [functions.c:1115]
	do_menu        [menus.c:885]
	menu_func      [menus.c:5138]
	staysup_func   [menus.c:5154]
	execute_function [functions.c:1098]
	old_execute_function [functions.c:1162]
	run_command_stream [read.c:143]
	run_command_file [read.c:217]
	ReadFile       [read.c:269]
	execute_function [functions.c:1098]

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214             E-mail: [email-masked]
Piscataway, NJ 08854                       Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "Paul D. Smith" <[email-masked]>
Date: 04 Dec 2000 10:44:18 -0500

%% Dan Espen <[email-masked]> writes:

  de> Our copy is a little old, I'm trying to get a newer version.

Try:

  http://www.rational.com/support/downloadcenter/upgrades/purify.jsp

FYI.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>    HASMAT--HA Software Methods & Tools
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]