Subject: WindowList crushes fvwm under xsm

From: Max Ischenko <[email-masked]>
Date: Wed, 6 Dec 2000 12:45:38 +0200

Configuration Information [Automatically generated, do not change]:
uname output: Linux localhost.localdomain 2.2.16-22 #1 Tue Aug 22 16:49:06 EDT 2000 i686 unknown
Compiler: egcs
Compilation CFLAGS: -O2
prefix: /usr

FVWM Version:	2.3.24
FVWM_MODULEDIR:	/usr/libexec/fvwm
FVWM_DATADIR:	/usr/share/fvwm
FVWM_USERDIR:	unset

Description:
	NB: Sorry for my english ;-)
	
	I was playing with session support in this beta release
	and encounter a weird bug:
	When fvwm is invoked by xsm any attempt to run WindowList command
	crushes the fvwm itself.

	Here is my configuration

$ cat ~/.xsmstartup 
fvwm2
smproxy

$ xinit
	Start X and load x session.
	Open FvwmConsole
	Enter WindowList command. ---> fvwm crashed

-- 
We don't really understand it, so we'll give it to the programmers.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 6 Dec 2000 16:07:51 +0100

> 	Enter WindowList command. ---> fvwm crashed

Please do two things:

 1) Upgrade to the latest snapshot available on our we site. At
    the current pace of development and bug fixing, 2.3.24 has
    been released ages ago :)
 2) If it still crashes, please provide a stack trace:

      $ gdb fvwm2 core
      (gdb) where

    If it does not crash anymore (which is quite likely given all
    the fixes we made), please tell us anyway.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]