Subject: .25 restart problems

From: "Nils Lohner" <[email-masked]>
Date: Wed, 06 Dec 2000 13:54:56 +0100

This is with 2.2.25 freshly downloaded and compiled.

on a restart (from .22):

- many windows appeared empty inside (i.e. I only saw the borders)
- many windows window-shaded themselves.
- some windowshaded and shrunk themselves to the width of two window borders
- some of the shrunk windows displaced themselves to the top left corner of 
the screen.

on restart from .25:
- nothing (no prob) when I only had windows on the first desktop
-  empty (border only) windows on restart with windows on second desktop

~ > uname -a
SunOS topaze 5.7 Generic_106541-02 sun4u sparc SUNW,Ultra-5_10
~ > fvwm2 -version
[FVWM][main]: <<DEBUG>> Entered, about to parse args
FVWM version 2.3.25 compiled on Dec  6 2000 at 11:51:03
with support for: ReadLine, XPM, GNOME WM hints, SM
~ > gcc --version
2.95.2

Regards,
Nils.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 6 Dec 2000 16:03:27 +0100

> - some of the shrunk windows displaced themselves to the top left corner of 

Never think about the past :-)

> -  empty (border only) windows on restart with windows on second desktop

I believe this is already fixed in CVS.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked]
Date: Wed, 6 Dec 2000 10:46:36 -0500 (EST)

Well, I "upgraded" from 2.3.22 to 2.3.25.  And lost my titlebar tiled
pixmap.

My decor is a bit complicated; it's designed to look like the MacOS
"Aqua" interface in OSX.  I'm attaching a 3K .tar.gz file that
contains the pixmaps and the pertinent part of my .fvwm2rc
(post-processed for M4 definitions).  This includes my Decor
definitions, and related function definitions.

On 2.3.22, everything looks correctly.

On 2.3.25, the titlebar pixmaps aren't there.  (The menu pixmaps ARE
there, so you can see what I was striving for.)

Is this because I was doing something unexpected, or is there
something that was recently broken?

-- 
Larry Gensch                                          [email-masked]

              Working for COMPAQ since the turn of the century

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 17 Dec 2000 02:17:12 +0100

> something that was recently broken?

There were some problems with tiled pixmaps, but these should be
fixed with current CVS sources.  For me, you decor works
perfectly.  If you still encounter this problem, please report
it again.

Bye

Dominik ^_^  ^_^