Subject: "StartsOnPage -1, SkipMapping" confuses FvwmButtons

From: Tim Phipps <[email-masked]>
Date: Fri, 15 Dec 2000 09:24:49 +0000

Configuration Information [Automatically generated, do not change]:
uname output: SunOS silver 5.5.1 Generic_103640-34 sun4u sparc SUNW,Ultra-5_10
Compiler: gcc
Compilation CFLAGS: -g -O2
prefix: /u/phippst/sunos

FVWM Version:	2.3.26
FVWM_MODULEDIR:	/u/phippst/sunos/libexec/fvwm/2.3.26
FVWM_DATADIR:	/u/phippst/sunos/share/fvwm
FVWM_USERDIR:	/u/phippst/.fvwm

Description:
	I use the style "StartsOnPage -1, SkipMapping" for the windows
	that are swallowed by FvwmButtons to avoid having the client mapped
	in the current desk and then zooming into FvwmButtons. This has been
	broken since about fvwm-snap-20001126. Sorry to be vague about the date,
	1126 doesn't have the bug and 1201 does.
	
Repeat-By:
	Style oclock StartsOnPage -1, SkipMapping
	*FvwmButtons(Swallow (Respawn) oclock "Exec oclock")
	
	oclock appears on desk "-1" but FvwmButtons doesn't swallow it.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 17 Dec 2000 17:16:31 +0100

> 	oclock appears on desk "-1" but FvwmButtons doesn't swallow it.

Fixed.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]