Subject: Stack ring error

From: Brad Giaccio <[email-masked]>
Date: Fri, 15 Dec 2000 08:07:48 -0500

With CVS as of Dec 15 8:00AM EST I get the following error once I've
started up xmms.

vsrc: stack ring is corrupt! 'XMMS' (layer 4) is above 'Tk-SETI@Home Monitor v2.10 - [email-masked] - setiathome on colt - Setiathome Client v3.0' (layer 1)
dumping stack ring:
    l=4 fw=0x080cf100 f=0x00800d2e 'XMMS Playlist'
    l=1 fw=0x080c99d8 f=0x0080004e 'Eterm_skip'
    l=1 fw=0x080fe8f8 f=0x00800282 'panel'
    l=1 fw=0x080efd58 f=0x00800d60 'Netscape: Re: XMMS Problems'
    l=1 fw=0x080dd5a0 f=0x0080013a 'maximus'
    l=1 fw=0x080eab28 f=0x008001d4 'yellow'
    l=1 fw=0x080f4148 f=0x00800d3a 'Netscape: Result for query "XMMS"'
    l=1 fw=0x080d4dd0 f=0x008000d8 'xconsole '
    l=1 fw=0x080cc1f8 f=0x0080005d 'emacs@maximus:   *scratch* '
    l=1 fw=0x080f13e8 f=0x00800220 'Speedbar'
    l=1 fw=0x080d0928 f=0x0080009e 'cvs-client'
    l=1 fw=0x080cda18 f=0x00800074 'maximus'
    l=1 fw=0x08107b40 f=0x008005d6 'FvwmButtons'
    l=1 fw=0x08105658 f=0x008002a0 'Gimp'
    l=1 fw=0x081090a0 f=0x0080029c 'Gui Builder'
    l=1 fw=0x080c9618 f=0x00800287 'IconManButtons'
    l=1 fw=0x080ecf38 f=0x008001e7 'Netscape: Welcome to CompUSA.com! How can we help you?'
    l=1 fw=0x080e94c8 f=0x008001c1 'GnomeCard: Default'
    l=1 fw=0x080e7d48 f=0x008001ae 'maximus_sql '
    l=1 fw=0x080e6688 f=0x0080019b 'Brad Giaccio's calendar'
    l=1 fw=0x080e4f78 f=0x00800188 'dbserver '
    l=1 fw=0x080e3858 f=0x00800175 'emacs-start '
    l=1 fw=0x080dbb80 f=0x00800127 'lal '
    l=1 fw=0x080d9208 f=0x00800101 'Netscape: redhat.com | Red Hat Support'
    l=1 fw=0x080d7560 f=0x008000ec 'Netscape: Java(TM) 2 Platform, Standard Edition, v1.2.2 API Specification'
    l=1 fw=0x080d2000 f=0x008000b1 'maximus'
    l=1 fw=0x080e1470 f=0x00800162 'Tk-SETI@Home Monitor v2.10 - [email-masked] - setiathome on jojo - Setiathome Client v3.0'
    l=1 fw=0x080df0a0 f=0x0080014e 'Tk-SETI@Home Monitor v2.10 - [email-masked] - setiathome on colt - Setiathome Client v3.0'
    l=4 fw=0x080f2ab8 f=0x00800d2a 'XMMS'
    l=1 fw=0x080da8e8 f=0x00800114 'StarOffice 5.2 - [desktop]'
vsrc: stack ring is corrupt! 'XMMS' (layer 4) is above 'Tk-SETI@Home Monitor v2.10 - [email-masked] - setiathome on colt - Setiathome Client v3.0' (layer 1)
dumping stack ring:
    l=4 fw=0x080cf100 f=0x00800d2e 'XMMS Playlist'
    l=1 fw=0x080c99d8 f=0x0080004e 'Eterm_skip'
    l=1 fw=0x080fe8f8 f=0x00800282 'panel'
    l=1 fw=0x080efd58 f=0x00800d60 'Netscape: Re: XMMS Problems'
    l=1 fw=0x080dd5a0 f=0x0080013a 'maximus'
    l=1 fw=0x080eab28 f=0x008001d4 'yellow'
    l=1 fw=0x080f4148 f=0x00800d3a 'Netscape: Result for query "XMMS"'
    l=1 fw=0x080d4dd0 f=0x008000d8 'xconsole '
    l=1 fw=0x080cc1f8 f=0x0080005d 'emacs@maximus:   *scratch* '
    l=1 fw=0x080f13e8 f=0x00800220 'Speedbar'
    l=1 fw=0x080d0928 f=0x0080009e 'cvs-client'
    l=1 fw=0x080cda18 f=0x00800074 'maximus'
    l=1 fw=0x08107b40 f=0x008005d6 'FvwmButtons'
    l=1 fw=0x08105658 f=0x008002a0 'Gimp'
    l=1 fw=0x081090a0 f=0x0080029c 'Gui Builder'
    l=1 fw=0x080c9618 f=0x00800287 'IconManButtons'
    l=1 fw=0x080ecf38 f=0x008001e7 'Netscape: Welcome to CompUSA.com! How can we help you?'
    l=1 fw=0x080e94c8 f=0x008001c1 'GnomeCard: Default'
    l=1 fw=0x080e7d48 f=0x008001ae 'maximus_sql '
    l=1 fw=0x080e6688 f=0x0080019b 'Brad Giaccio's calendar'
    l=1 fw=0x080e4f78 f=0x00800188 'dbserver '
    l=1 fw=0x080e3858 f=0x00800175 'emacs-start '
    l=1 fw=0x080dbb80 f=0x00800127 'lal '
    l=1 fw=0x080d9208 f=0x00800101 'Netscape: redhat.com | Red Hat Support'
    l=1 fw=0x080d7560 f=0x008000ec 'Netscape: Java(TM) 2 Platform, Standard Edition, v1.2.2 API Specification'
    l=1 fw=0x080d2000 f=0x008000b1 'maximus'
    l=1 fw=0x080e1470 f=0x00800162 'Tk-SETI@Home Monitor v2.10 - [email-masked] - setiathome on jojo - Setiathome Client v3.0'
    l=1 fw=0x080df0a0 f=0x0080014e 'Tk-SETI@Home Monitor v2.10 - [email-masked] - setiathome on colt - Setiathome Client v3.0'
    l=4 fw=0x080f2ab8 f=0x00800d2a 'XMMS'
    l=1 fw=0x080da8e8 f=0x00800114 'StarOffice 5.2 - [desktop]'
vsrc: stack ring is corrupt! 'XMMS' (layer 4) is above 'Tk-SETI@Home Monitor v2.10 - [email-masked] - setiathome on colt - Setiathome Client v3.0' (layer 1)
dumping stack ring:
    l=4 fw=0x080cf100 f=0x00800d2e 'XMMS Playlist'
    l=1 fw=0x080c99d8 f=0x0080004e 'Eterm_skip'
    l=1 fw=0x080fe8f8 f=0x00800282 'panel'
    l=1 fw=0x080efd58 f=0x00800d60 'Netscape: Re: XMMS Problems'
    l=1 fw=0x080dd5a0 f=0x0080013a 'maximus'
    l=1 fw=0x080eab28 f=0x008001d4 'yellow'
    l=1 fw=0x080f4148 f=0x00800d3a 'Netscape: Result for query "XMMS"'
    l=1 fw=0x080d4dd0 f=0x008000d8 'xconsole '
    l=1 fw=0x080cc1f8 f=0x0080005d 'emacs@maximus:   *scratch* '
    l=1 fw=0x080f13e8 f=0x00800220 'Speedbar'
    l=1 fw=0x080d0928 f=0x0080009e 'cvs-client'
    l=1 fw=0x080cda18 f=0x00800074 'maximus'
    l=1 fw=0x08107b40 f=0x008005d6 'FvwmButtons'
    l=1 fw=0x08105658 f=0x008002a0 'Gimp'
    l=1 fw=0x081090a0 f=0x0080029c 'Gui Builder'
    l=1 fw=0x080c9618 f=0x00800287 'IconManButtons'
    l=1 fw=0x080ecf38 f=0x008001e7 'Netscape: Welcome to CompUSA.com! How can we help you?'
    l=1 fw=0x080e94c8 f=0x008001c1 'GnomeCard: Default'
    l=1 fw=0x080e7d48 f=0x008001ae 'maximus_sql '
    l=1 fw=0x080e6688 f=0x0080019b 'Brad Giaccio's calendar'
    l=1 fw=0x080e4f78 f=0x00800188 'dbserver '
    l=1 fw=0x080e3858 f=0x00800175 'emacs-start '
    l=1 fw=0x080dbb80 f=0x00800127 'lal '
    l=1 fw=0x080d9208 f=0x00800101 'Netscape: redhat.com | Red Hat Support'
    l=1 fw=0x080d7560 f=0x008000ec 'Netscape: Java(TM) 2 Platform, Standard Edition, v1.2.2 API Specification'
    l=1 fw=0x080d2000 f=0x008000b1 'maximus'
    l=1 fw=0x080e1470 f=0x00800162 'Tk-SETI@Home Monitor v2.10 - [email-masked] - setiathome on jojo - Setiathome Client v3.0'
    l=1 fw=0x080df0a0 f=0x0080014e 'Tk-SETI@Home Monitor v2.10 - [email-masked] - setiathome on colt - Setiathome Client v3.0'
    l=4 fw=0x080f2ab8 f=0x00800d2a 'XMMS'
    l=1 fw=0x080da8e8 f=0x00800114 'StarOffice 5.2 - [desktop]'
vsrc: stack ring is corrupt! 'XMMS' (layer 4) is above 'Tk-SETI@Home Monitor v2.10 - [email-masked] - setiathome on colt - Setiathome Client v3.0' (layer 1)
dumping stack ring:
    l=4 fw=0x080cf100 f=0x00800d2e 'XMMS Playlist'
    l=1 fw=0x080c99d8 f=0x0080004e 'Eterm_skip'
    l=1 fw=0x080fe8f8 f=0x00800282 'panel'
    l=1 fw=0x080efd58 f=0x00800d60 'Netscape: Re: XMMS Problems'
    l=1 fw=0x080dd5a0 f=0x0080013a 'maximus'
    l=1 fw=0x080eab28 f=0x008001d4 'yellow'
    l=1 fw=0x080f4148 f=0x00800d3a 'Netscape: Result for query "XMMS"'
    l=1 fw=0x080d4dd0 f=0x008000d8 'xconsole '
    l=1 fw=0x080cc1f8 f=0x0080005d 'emacs@maximus:   *scratch* '
    l=1 fw=0x080f13e8 f=0x00800220 'Speedbar'
    l=1 fw=0x080d0928 f=0x0080009e 'cvs-client'
    l=1 fw=0x080cda18 f=0x00800074 'maximus'
    l=1 fw=0x08107b40 f=0x008005d6 'FvwmButtons'
    l=1 fw=0x08105658 f=0x008002a0 'Gimp'
    l=1 fw=0x081090a0 f=0x0080029c 'Gui Builder'
    l=1 fw=0x080c9618 f=0x00800287 'IconManButtons'
    l=1 fw=0x080ecf38 f=0x008001e7 'Netscape: Welcome to CompUSA.com! How can we help you?'
    l=1 fw=0x080e94c8 f=0x008001c1 'GnomeCard: Default'
    l=1 fw=0x080e7d48 f=0x008001ae 'maximus_sql '
    l=1 fw=0x080e6688 f=0x0080019b 'Brad Giaccio's calendar'
    l=1 fw=0x080e4f78 f=0x00800188 'dbserver '
    l=1 fw=0x080e3858 f=0x00800175 'emacs-start '
    l=1 fw=0x080dbb80 f=0x00800127 'lal '
    l=1 fw=0x080d9208 f=0x00800101 'Netscape: redhat.com | Red Hat Support'
    l=1 fw=0x080d7560 f=0x008000ec 'Netscape: Java(TM) 2 Platform, Standard Edition, v1.2.2 API Specification'
    l=1 fw=0x080d2000 f=0x008000b1 'maximus'
    l=1 fw=0x080e1470 f=0x00800162 'Tk-SETI@Home Monitor v2.10 - [email-masked] - setiathome on jojo - Setiathome Client v3.0'
    l=1 fw=0x080df0a0 f=0x0080014e 'Tk-SETI@Home Monitor v2.10 - [email-masked] - setiathome on colt - Setiathome Client v3.0'
    l=4 fw=0x080f2ab8 f=0x00800d2a 'XMMS'
    l=1 fw=0x080da8e8 f=0x00800114 'StarOffice 5.2 - [desktop]'

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 17 Dec 2000 01:26:48 +0100

> With CVS as of Dec 15 8:00AM EST I get the following error once I've

Fixed.  The stack ring got messed up when windows used the GNOME
layer hint.  BTW, is there a specific reason why all your windows
except the XMMS windows seem to start in the lowest layer, not the
default layer?

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Sat, 30 Dec 2000 05:59:49 -0500

Yes there is a specific reason, I just don't rembember the reason behind it.
In my rc I have
DefaultLayers 2 1
Style "*" Layer 1

I can get rid of those lines, they were probabbly left over from a time
when layers were first added and I never removed it.

Brad