Subject: CVS domivogt: * Fixed window destruction logic.

From: CVS <[email-masked]>
Date: Fri, 22 Dec 2000 18:37:22 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	00/12/22 18:37:22

Modified files:
	.              : ChangeLog 
	fvwm           : add_window.c events.c module_interface.c 
	                 update.c update.h 
	libs           : fvwmsignal.c 

Log message:
* Fixed window destruction logic.
* fvwmSelect returns 0 instead of -1 on failure.
* Retry fvwmSelect if it fails with EINTR.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 23 Dec 2000 02:21:42 +0100

> * Retry fvwmSelect if it fails with EINTR.

It seems that this commit fix the FvwmThemes "fail to read descriptor"
error that arise with cde and luthien fvwm-themes themes.
Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]