Subject: Re: [FVWM-Themes] CDE-Theme

From: Olivier Chapuis <[email-masked]>
Date: Tue, 12 Dec 2000 18:15:23 +0100

Stefan Hueneburg wrote:
> 
> Hi!
> 
> The new CDE-Theme looks really good, good job. :-)
> 
> But I had some problems to get it working on my
> Solaris 7 Box.
> 
> I had to install gnu m4 and gawk, i didn't work
> with the default Solaris Tools.
>

It seems that the awk line is POSIX. However, the m4 esyscmd is a GNU
extension and I do not see how to fix it without changing the logic. 
We can transform all the .db file to m4 file  (using awk or by adding
a new sub option to fvwm-themes-image) and use include. Or we can change
the read command by something like:

PipeRead 'a one line program in perl or in awk/sed'

Any other suggestions?

Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 12 Dec 2000 19:02:30 +0100

Ooops, Sorry. This happen somtimes ...
Olivier

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 12 Dec 2000 12:21:12 -0600

> PipeRead 'a one line program in perl or in awk/sed'

If esyscmd does not exist in non-GNU m4, it probably can be emulated by
maketemp + syscmd + include.

It may be put into ifelse(defn({{__gnu__}}, ...) to use the current
solution without temporary files for GNU users.

Anyway I don't have non-GNU m4 to test this suggestion.

Regards,
Mikhael.