Subject: Re: fvwm.2.23

From: Dominik Vogt <[email-masked]>
Date: Sat, 2 Dec 2000 06:15:52 +0100

On Thu, Nov 30, 2000 at 12:37:36PM -0800, Elliot Sowadsky wrote:
> < solaris 2.5.1
> < 
> < fvwm.2.22 runs fine
> < 
> < fvwm.2.23 doesnt run my .fvwm2rc. It hangs at the initial screen w/o even a
> < menu.
> < 
> < An .empty .fvwmrc gives same result as no .fvwmrc.
> < 
> < How can i tell other than massive trial and error of my rc file what 23
> < doesnt like that 22 does?
> 
> 
> turns out that
> 
> WindowShade False
>        or
> WindowShade "False"
> 
> in .fvwm2rc will hang it up.

Have you already tried this with 2.3.24 or the latest snapshot?
Do you see the window selection cursor when it hangs?  In this
case you have to click somewhere to proceed.  If this still does
not help, please replace the line

  #undef GRAB_DEBUG

in the file misc.c with

  #define GRAB_DEBUG

and send me the output up to the moment when fvwm hangs.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 17 Dec 2000 02:37:48 +0100

> < doesnt like that 22 does?

Well, if you have this in you InitFunction, fvwm will ask for a
window to operate on.  Since there are no windows yet, all you can
do is to click somewhere.  But then the InitFunction will not be
executed at all because it requires a window.  That's no bug but
simply confusing.

Bye

Dominik ^_^  ^_^