Subject: Notification: incoming/680

From: [email-masked]
Date: Wed, 29 Nov 2000 02:26:18 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/680

Message summary for PR#680
	From: [email-masked]
	Subject: 'xv -root somepic' crashes fvwm2
	Date: Wed, 29 Nov 2000 02:26:12 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked]  Wed Nov 29 02:26:17 2000
Received: from localhost (localhost [127.0.0.1])
	by larry.math.uh.edu (8.9.1/8.9.1) with ESMTP id CAA01433
	for <[email-masked]>; Wed, 29 Nov 2000 02:26:12 -0600 (CST)
Date: Wed, 29 Nov 2000 02:26:12 -0600 (CST)
From: [email-masked]
Message-Id: <[email-masked]>
To: [email-masked]
Subject: 'xv -root somepic' crashes fvwm2

Full_Name: Harald Dunkel
Version: 2.3.24
CVS_Date: 
OS: Linux 2.4.0-test10
X_Server: XFree86 4.0.1 (Debian)
Submission from: (NULL) (212.121.155.45)

When I run 'xv -root somepic' then fvwm2 crashes.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 2 Dec 2000 06:11:37 +0100

> When I run 'xv -root somepic' then fvwm2 crashes.

This *can't* crash fvwm because it has absolutely no effect on
fvwm.  It could possibly crash the X server.  If fvwm crashes, you
will either find an fvwm error message on the console or a core
file.  Should this be the case, please provide the output or a
stack trace.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Harald Dunkel <[email-masked]>
Date: Sat, 02 Dec 2000 17:08:33 +0100

> file.  Should this be the case, please provide the output or a

I'm sorry, but it *does* crash fvwm2. My .xinitrc looks like

	(fvwm2 || wmaker || mwm || twm) & wmpid=$!

	# start some Xclients
	# :
	# :

	wait $wmpid

I got wmaker after fvwm2 crashed. All the other Xclients survived, 
which could not happen if the Xserver would crash.

This is the requested stack trace:

{harri@bilbo:fvwm 1009} gdb fvwm2 ../../../core 
GNU gdb 5.0
Copyright 2000 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu"...
Core was generated by `fvwm2'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/X11R6/lib/libXpm.so.4...done.
Loaded symbols for /usr/X11R6/lib/libXpm.so.4
Reading symbols from /usr/X11R6/lib/libSM.so.6...done.
Loaded symbols for /usr/X11R6/lib/libSM.so.6
Reading symbols from /usr/X11R6/lib/libICE.so.6...done.
Loaded symbols for /usr/X11R6/lib/libICE.so.6
Reading symbols from /usr/X11R6/lib/libXext.so.6...done.
Loaded symbols for /usr/X11R6/lib/libXext.so.6
Reading symbols from /usr/X11R6/lib/libX11.so.6...done.
Loaded symbols for /usr/X11R6/lib/libX11.so.6
Reading symbols from /lib/libm.so.6...done.
Loaded symbols for /lib/libm.so.6
Reading symbols from /lib/libc.so.6...done.
Loaded symbols for /lib/libc.so.6
Reading symbols from /lib/ld-linux.so.2...done.
Loaded symbols for /lib/ld-linux.so.2
#0  0x4008a287 in XTextWidth () from /usr/X11R6/lib/libX11.so.6
(gdb) where
#0  0x4008a287 in XTextWidth () from /usr/X11R6/lib/libX11.so.6
#1  0x806606f in CreateIconWindow (tmp_win=0x80b92c0, def_x=1091, def_y=-1073744056) at icons.c:124
#2  0x8067c7f in Iconify (tmp_win=0x80b92c0, def_x=1091, def_y=-1073744056) at icons.c:1269
#3  0x8063a43 in HandleMapRequestKeepRaised (KeepRaised=0, ReuseWin=0x0) at events.c:1000
#4  0x8063741 in HandleMapRequest () at events.c:865
#5  0x80658f6 in DispatchEvent (preserve_Tmp_win=0) at events.c:2512
#6  0x806595a in HandleEvents () at events.c:2552
#7  0x808074d in main (argc=1, argv=0xbffff82c) at fvwm.c:730
#8  0x4016dc1c in __libc_start_main () from /lib/libc.so.6

The environment is:

	Debian Woody, AMD K6, 2.4.0-test11, XFree 4.0.1

fvwm-2.3.23 crashed, too. fvwm-2.3.22 works for me.

Many thanx for your help

Harri
-- 
Harald Dunkel | [email-masked] | If your operating system seems to
Synopsys GmbH | Kaiserstr. 100     | be made by Dr. Frankenstein, then
52134 Herzogenrath, Germany        | it is time for a change.
+49 2407 9558 (fax? 44: 0)         |                        Try Linux!
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 2 Dec 2000 18:21:34 +0100

> #2  0x8067c7f in Iconify (tmp_win=0x80b92c0, def_x=1091, def_y=-1073744056) at icons.c:1269

Well, it has crashed when a window was iconified - which is a well
known (and already fixed) bug in 2.3.23.  And this has *nothing*
to do with the 'xv ...' command.  Upgrade to the latest snapshot
or stick with 2.3.22 and you will be fine (2.3.24 still crashes).

Bye

Dominik ^_^  ^_^