Subject: FvwmScript core dump

From: Olivier Chapuis <[email-masked]>
Date: Tue, 05 Dec 2000 14:32:52 +0100

Hello,
It seems that all FvwmScript Scripts core dump:

[olivier@snoopy fvwm]$ gdb /usr/local/libexec/fvwm/2.3.25/FvwmScript
~/core 
GNU gdb 4.18
This GDB was configured as "i586-mandrake-linux"...
Core was generated by `/usr/local/libexec/fvwm/2.3.25/FvwmScript 33 4
none 0 8 FvwmScript-KeyboardSetup'.
Program terminated with signal 11, Erreur de segmentation.
Reading symbols from /usr/X11R6/lib/libXpm.so.4...done.
Reading symbols from /usr/X11R6/lib/libSM.so.6...done.
Reading symbols from /usr/X11R6/lib/libICE.so.6...done.
Reading symbols from /usr/X11R6/lib/libXext.so.6...done.
Reading symbols from /usr/X11R6/lib/libX11.so.6...done.
Reading symbols from /lib/libm.so.6...done.
Reading symbols from /lib/libc.so.6...done.
Reading symbols from /lib/ld-linux.so.2...done.
#0  fvwmlib_XCreateGC (display=0x808bae0, drawable=121634817,
valuemask=0, values=0x0)
    at Graphics.c:983
983       Bool f = values->graphics_exposures;
(gdb) where
#0  fvwmlib_XCreateGC (display=0x808bae0, drawable=121634817,
valuemask=0, values=0x0)
    at Graphics.c:983
#1  0x804b3d0 in OpenWindow () at FvwmScript.c:382
#2  0x804b711 in BuildGUI (IsFather=1) at FvwmScript.c:497
#3  0x804c972 in main (argc=7, argv=0xbffff844) at FvwmScript.c:1020
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 5 Dec 2000 16:47:58 +0100

> #3  0x804c972 in main (argc=7, argv=0xbffff844) at FvwmScript.c:1020

"Fixed" by making a safety patch in the new function.  Really,
the code should not rely on X not accessing the pointer passed in.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]