Subject: CVS dane: * fvwm/add_window.c (AddWindow/destroy_window):

From: CVS <[email-masked]>
Date: Sun, 17 Dec 2000 09:13:08 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	dane	00/12/17 09:13:08

Modified files:
	.              : ChangeLog 
	fvwm           : add_window.c events.c placement.c 

Log message:
* fvwm/add_window.c (AddWindow/destroy_window):
* fvwm/events.c (HandleMapRequestKeepRaised):
* fvwm/placement.c (PlaceWindow): Fix inconsistent declaration of
PPosOverride as both Bool and Boolean.  Fixes fvwm doing interactive
placement during startup and recapture.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 17 Dec 2000 20:15:19 +0100

> placement during startup and recapture.

Huh?  Can you explain why this caused said bug?

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sun, 17 Dec 2000 14:49:47 -0500

> Huh?  Can you explain why this caused said bug?

OK.

In fvwm.c PPosOverride is declared:

Bool PPosOverride = False;

In the above files, PPosOverride was referenced as:

  extern Boolean PPosOverride;

It looks like fvwm expects both of these to be defined by X.
On Solaris, I see the definitions as:

/usr/openwin/include/X11/Intrinsic.h:172:typedef char Boolean;
/usr/openwin/include/X11/Xlib.h:76:#define Bool int

Since PPosOverride is a global, the only place the mismatch could have
been detected was by the linker, unfortunately, the linker doesn't
appear to do any type checking.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]