Subject: Problem with live-icon.el

From: Dan Espen <[email-masked]>
Date: Mon, 18 Dec 2000 09:02:02 -0500

This is a new symptom observed with current CVS.

I have:

Style "*"           Icon unknown1.xpm

which is a shaped icon.

With XEmacs I  use the  live-icon package which  creates  an icon that
looks  like  a  minature version   of  the window.   I  create  XEmacs
iconified.  Due to the way live-icon works, the  first icon for XEmacs
I see is the unknow1.xpm  icon.  The next  time I open/iconify XEmacs,
the icon changes  to a  square icon  thats a  minature version of  the
window.

With recent CVS,   the icon stays shaped  with  a the colors  from the
XEmacs window superimposed.  I'd suspect a latent bug in live-icon
except that a "Recapture" repairs the icon.

I use a slightly hacked version of live-icon.el and XEmacs 20.4.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214             E-mail: [email-masked]
Piscataway, NJ 08854                       Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 18 Dec 2000 16:58:59 +0100

> except that a "Recapture" repairs the icon.

Whatever you say - I don't understand a word :-)  How about a
screenshot and instructions how to set up this live-icons package?

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Thu, 21 Dec 2000 07:37:43 -0500

Dominik Vogt <[email-masked]> writes:
> > I see is the unknown1.xpm  icon.  The next  time I open/iconify XEmacs,

The live-icon package comes with XEmacs.
I have a slightly modified version, in your version, the icon will
have double spaced lines, and the icon will probably be larger.
I can't see how my modifications
would affect this, so just use the one that comes with XEmacs.

In your .emacs:

    (require 'live-icon)

In your .fvwm2rc:

Style "*macs*" Icon unknown1.xpm
Style "*macs*" NoIconTitle

The icon before and after a recapture:

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 21 Dec 2000 23:46:18 +0100

> Style "*macs*" NoIconTitle

I can't get that live-icon feature working properly in the first
place.  If I use 'Style "*macs*" Icon unknown1.xpm', I can
iconify the window as often as I like, it will never use the
application provided icon (even if I use NoIconOverride).  When 
I recapture the window, it will then use the "live" icon.
However, the handling of live icons is still not correct.  It
only works properly if the application provides the pixmap or
window right when the window is created, but not if the provided
icon is created later.  The reason is that the code in
setup_icon() and HandlePropertyNotify() does not match.

Perhaps this can be reproduced if you post your complete setup
(all icon related config lines, the xemcas startup command, your
hacked live-icon.el and the unknown1.xpm file).

Bye

Dominik ^_^  ^_^

---

From: Dan Espen <[email-masked]>
Date: Thu, 21 Dec 2000 19:23:08 -0500

> I recapture the window, it will then use the "live" icon.

The good news is that your "attempt" at a fix works.

It never did "work properly".  I normally start  XEmacs iconic from my
.xinitrc:

(xemacs -iconic -f my-mail &)&

The first icon I see is unknown1.xpm.
I have to de-iconify and iconify the window before I see a live-icon.
I don't really want to see unknown1.xpm.

I checked thru  my version of live-icon.   I think the instructions  I
gave should have worked after you fixed it.  The  setup for my version
might be a little different.  I did a diff and I see one of the things
I did was allow for frame name matching.  I'll attach  a copy, its not
too big.

> setup_icon() and HandlePropertyNotify() does not match.

Perhaps thats why I first see unknown1.xpm.

> hacked live-icon.el and the unknown1.xpm file).

Just for the record, from my .xinitrc:

(xemacs -iconic -f my-mail &)&

unknown1.xpm is part of the fvwm icon distribution, you have it.

Put this at the front of your emacs loadpath and just require it.
In my .emacs I have:

(require 'live-icon)
(setq live-icon-max-height 60)
(setq live-icon-max-width 48)

---

From: Brad Giaccio <[email-masked]>
Date: Sat, 30 Dec 2000 06:31:50 -0500

Dan,

a stupid question if you don't want to see unknown.xpm why are you asking 
for it I usually use 

Style "*compilation*" Icon
then I see the live icon right away.
I do the same thing for active icons of xterms

Brad

 
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sat, 30 Dec 2000 08:36:35 -0500

> I do the same thing for active icons of xterms

I only see unknown1.xpm when XEmacs is first created.
I start XEmacs with the -iconic arg.
That "*compilation*" pattern wouldn't match
an initial frame unless you started XEmacs in compilation mode.

If I use

Style * Icon

its worse, I see no icon at all until I deiconify and reiconify the
window.

If I start XEmacs open and then iconify it, the first live icon is fine.