Subject: FvwmScript

From: Olivier Chapuis <[email-masked]>
Date: Sun, 01 Oct 2000 11:55:53 +0200

Hello,
We use a lot FvwmScript in FVWM Themes. We need two very small
features
 * Allows more Widgets (100 -> 1000) and more variables (512 -> 5120)
   The change is almost nothings and do not give Scripts with more
   memeory (~ +40kb)
 * ItemDraw can understand a SingleClick (just a cut and past from
   an other widget)
I've commit the first feature, but I will revert it if some ask it.
For the second I wait some votes ...
Olivier

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 11 Oct 2000 18:08:36 +0200

> For the second I wait some votes ...

I don't think these are new features. More like half fixes, half
improvements of existing functionality. Since this is a workaround for a
problem which caused XFree86-4.0.1 freeze, I would say, just do it.

BTW, the FvwmScript-ScreenSetup included with fvwm consistently freezes
XFree86-4.0.0. This may be the same problem that we had in fvwm-themes,
i.e. widgets out of window. If yes, do you see a workaround. Olivier?

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 11 Oct 2000 21:42:19 +0200

> i.e. widgets out of window. If yes, do you see a workaround. Olivier?

I do not think that there are widgets out of the main window. I
will check again. Can you send me the output of xset -q?
Do Xfree freeze at FvwmScript-ScreenSetup startup or after?
I've made a few clean up, but I do not think that this
will change something.
Olivier

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 16 Oct 2000 21:58:21 +0200

>  * ItemDraw can understand a SingleClick (just a cut and past from

I've commit this. I've put the code between #ifdef, so I can
come back to the old code if one wants.

Olivier