Subject: strange startup mini window - bug ?

From: "Tim Freedom" <[email-masked]>
Date: Fri, 20 Oct 2000 11:36:44 PDT

This has been happening for awhile, I just neglected to report it since its 
so minor and I always assumed I was doing something wrong.  When I login on 
my ultra-5 box I get the obligatory "OpenWindows Welcome" Screen that looks 
something like this,

" Starting the OpenWindows Desktop

     Valkommen till
     .
     .
     [various other languages]
     .

                       SOLARIS
                    CDE Version 1.3 "

My mouse then turns into an hourglass -- all normal thus far.  Then I get a 
place-window icon and a very small window (3pixels x 2pixels approximately). 
  If I simply click, everything proceeds normally (no window is placed, it 
simply vanishes).  If I 'mouse-2' so as to resize this mysterious window in 
hopes of finding out what the heck this window is, I still can't see a title 
-- why is this window showing up (its nothing I'm spawning) ?

I've narrowed down to when this window appears. It only happens if I have 
the following line in my .fvwm2rc file,

  Style "*" ActivePlacement, DumbPlacement

Why is this happening ? Is it a bug ?

uname -a   : SunOS dude 5.7 Generic_106541-10 sun4u
fvwm-2.3.+ : fvwm-snap-20000809

Here is a minimal setup:

### .fvwm2rc file ###
# I will place my windows, thank you
Style "*" ActivePlacement, DumbPlacement

### .xinitrc file ###
#!/bin/sh
#
# .xinitrc - OpenWindows startup script (used by xdm).
#
$HOME/download/fvwm-0809/bin/fvwm2 > $HOME/.err_xinitrc 2>&1

Thanks for the help in advance.
_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

Share information about yourself, create your own public profile at 
http://profiles.msn.com.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 22 Oct 2000 14:45:35 +0200

> Why is this happening ? Is it a bug ?

Well, it does not seem to be an fvwm bug. What happens is that
there is really some small window being created, and fvwm tries
to place it on the screen. This usually happens without any user
interaction, and if the window dies before it has been decorated,
you will never see the window. If you choose both, active and dumb
placement the user is asked to place the window manually -
although it seems the window vanishes immediately.

Where this curious window comes from is a mystery to me, but it is
probably nothing that is stared by fvwm. Perhaps it is something
your OpenWindows does, or it might be some application that fails
to start up properly. If you can find out its name somehow, you can
give it the RandomPlacement or SmartPlacement style and it will
never show up.

If you add this line at the start of the PlaceWindow() function
in placement.c (in the 2.3.x betas), the window name will be
printed to the console:

  fprintf(stderr,"placing window: '%s'\n", tmp_win->name ? tmp_win->name : "(no name)");

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]