Subject: screenshot

From: Andre Bonhote <[email-masked]>
Date: Thu, 26 Oct 2000 19:30:07 +0200

hi you great guys who make my day with fvwm2!

i had a look at your webpage once again, just to see what's going on
there, and i noticed that the screenshot page was quite old. so i
decided to make a snapshot of my current desktop and send it to you. the
fvwm-mailing-list told me to this to your address.

my desktop shows (of course) fvwm2, of which not much is being seen
actually. only the root menu and the decorations are really fvwm-like. i
like gtk so i am using gnome's panels (top and bottom, left hand side).
there's an aterm window using transparency, gqmpeg and netscape, and, of
course, gkrellm running.

for the colors, i used grdb and grdb2fvwm, which takes gnome's colors
and fonts and puts it into my fvwm2rc. it's quite useful, i think.

well, that's it. dan espen told me that you can get along with making
thumbs, so i am sending only the big one, 150k approx. hope it appears
someday :)

btw: do you need someone to update your website?

thanks, 

andré

oops! i forgot! i am using suse 7.0 on a dell latitude laptop.

---

From: Tomokazu Murakami <[email-masked]>
Date: Fri, 27 Oct 2000 10:11:58 +0900

From: Andre Bonhote <[email-masked]>
Subject: screenshot
Date: Thu, 26 Oct 2000 19:30:07 +0200

> thumbs, so i am sending only the big one, 150k approx. hope it appears

It's very cool screenshot. Why don't you see my desktop screenshot.
http://fukuda.aist-nara.ac.jp/~tomoka-m/ScreenShot/

It comes true by this .fvwm2rc
-----------------------------------------------------------
# this is a bare bones sample .fvwm2rc/system.fvwm2rc file for fvwm-2.
# It should be customized before install.  See other sample .fvwm2rc files
# for hints, as well as pointers from the various links on the official
# fvwm web page (see the FAQ).

# be sure to customize these paths for your installation:
ModulePath /usr/local/libexec/fvwm/2.3.22
ImagePath /usr/local/lib/X11/fvwm/pitmaps
#IconPath   /usr/local/lib/X11/fvwm/bitmaps
#IconPath   /usr/local/include/X11/bitmaps:/usr/X11R6/include/X11/bitmaps:/usr/include/X11/bitmaps:/usr/openwin/include/X11/bitmaps

#EdgeResistance 250 10
#EdgeScroll 100 100
EdgeResistance 500 32
EdgeScroll 100 100
ClickTime 50

# make sure these fonts exist on your system:
WindowFont "-adobe-times-bold-r-*-*-18-*-*-*-*-*-*-*,-jis-fixed-medium-r-*-*-16-*-*-*-*-*-jisx0208.1983-*"
#WindowFont a16
IconFont "-adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*,-misc-fixed-medium-r-*-*-10-*-*-*-*-*-jisx0208.1983-*"

#HilightColor black palevioletred
HilightColor Yellow RoyalBlue
DeskTopSize 2x2
#MenuStyle maroon grey60 grey40 -adobe-times-bold-r-*-*-14-*-*-*-*-*-*-* fvwm
#MenuStyle black grey75 grey40 -adobe-times-bold-r-*-*-14-*-*-*-*-*-*-* mwm
MenuStyle black grey75 grey40 "-adobe-times-bold-r-*-*-14-*-*-*-*-*-*-*,-misc-fixed-medium-r-*-*-14-*-*-*-*-*-jisx0208.1983-*" mwm
TitleStyle	(-- Raised)
TitleStyle	Inactive (VGradient 10 Gray86 Gray50)
TitleStyle	ActiveUp (VGradient 10 RoyalBlue navy)
TitleStyle	ActiveDown (VGradient 10 navy RoyalBlue)
ButtonStyle	All -- UseTitleStyle

ColormapFocus FollowsMouse
#ColormapFocus SloppyFocus

# default Styles:
Style "*"           BorderWidth 7, HandleWidth 7
Style "*"           Title ,Button 1 ,Button 2 ,Button 4
Style "*"           Icon unknown1.xpm, Color blue4/LightGray
Style "*"           MWMFunctions, MWMDecor, HintOverride
Style "*"           MWMButtons
Style "*"           DecorateTransient, NoPPosition
#Style "*"           IconBox 0 -10 -280 -1
Style "*"           IconBox 130 5 600 150
#Style "*"           FocusFollowsMouse
Style "*"           SloppyFocus
Style "*"           RandomPlacement, SmartPlacement

# Styles for various Fvwm modules:
Style "Fvwm*"       NoTitle,  Sticky, WindowListSkip
Style "Fvwm*"       BorderWidth 2, CirculateSkipIcon, CirculateSkip
Style "FvwmPager"   StaysOnTop
Style "FvwmBanner"  StaysOnTop
Style "FvwmButtons" Icon toolbox.xpm, ClickToFocus , NoHandles

# Styles for your common terminal emulator programs:
Style "XTerm"       Icon xterm.xpm, SloppyFocus, IconBox 130 5 600 150
Style "rxvt"        Icon term.xpm, SloppyFocus, IconBox 130 5 600 150
Style "rxvt"        MWMBorder, MWMButtons

# Styles for various common programs:
Style "*lock"       NoTitle, NoHandles, Sticky, WindowListSkip, ClickToFocus
Style "xload"       NoTitle, Sticky, WindowListSkip, ClickToFocus
Style "xbiff"       NoTitle, Sticky, WindowListSkip, ClickToFocus ,NoHandles
Style "xcalc"       Icon xcalc.xpm, NoButton 2,RandomPlacement,ClickToFocus
Style "xmh"         Icon mail1.xpm, NoIconTitle,StickyIcon
Style "xmh"	    RandomPlacement, NoButton 2
Style "xman"	    Icon xman.xpm, RandomPlacement, ClickToFocus
Style "xmag"	    Icon mag_glass.xpm, RandomPlacement, ClickToFocus
Style "xgraph"      Icon graphs.xpm, RandomPlacement, ClickToFocus
Style "xmosaic"     Color Green/Yellow, ClickToFocus
Style "panel"       NoTitle, Sticky, WindowListSkip, ClickToFocus ,NoHandles

# some simple default key bindings:
Key Next         A       SCM     Next [*] Focus
Key Prior        A       SCM     Prev [*] Focus
# Arrow Keys
# press arrow + control anywhere, and scroll by 1 page
Key Left	A	SM	Scroll -100 0
Key Right	A	SM	Scroll +100 +0
Key Up		A	SM	Scroll +0   -100
Key Down	A	SM	Scroll +0   +100
Key Up		A	M	Scroll +0   -100
Key Down	A	M	Scroll +0   +100

# press arrow + meta key, and scroll by 1/10 of a page
Key Left	A	C	Scroll -10 +0
Key Right	A	C	Scroll +10 +0
Key Up		A	C	Scroll +0   -10
Key Down	A	C	Scroll +0   +10

# press shift arrow + control anywhere, and move the pointer by 1% of a page
Key Left	A	SC	CursorMove -1 0
Key Right	A	SC	CursorMove +1 +0
Key Up		A	SC	CursorMove +0   -1
Key Down	A	SC	CursorMove +0   +1

# press shift arrow + meta key, and move the pointer by 1/10 of a page
Key Left	A	CM	CursorMove -10 +0
Key Right	A	CM	CursorMove +10 +0
#Key Up		A	CM	CursorMove +0   -10
#Key Down	A	CM	CursorMove +0   +10
Key Up		A	CM	Raise
Key Down	A	CM	Lower

# Keyboard accelerators
# These are "borrowed" from the .4Dwmrc file on an SGI I use,
# except for AltF2 and AltF6 which I added for completeness.
# I think the other are standard Motif.  --tabaer@magnus
Key F1          WFST    M       Raise
Key F2          WFST    M       Delete
Key F3          WFST    M       Lower
Key F4          WFST    M       Destroy
Key F5          WFST    M       Raise
Key F6          A       M       WindowList
Key F7          WFST    M       Move
Key F8          WFST    M       Resize
Key F9          WFST    M       Iconify
Key F10         WFST    M       Maximize

# some simple default mouse bindings:
#   for the root window:
Mouse 1	R   	A       Menu RootMenu Nop
Mouse 2	R    	A      	Menu Window-Ops Nop
Mouse 3	R    	A      	WindowList

#   for the title bar buttons:
Mouse 0	1    	A      	Menu Window-Ops2 Close
Mouse 0	2    	A     	Maximize-Func
Mouse 0	4    	A     	Iconify

#   for other parts of the window/borders/icons:
#Mouse 1	F	A	Resize-or-Raise
#Mouse 1	TS	A	Move-or-Raise
#Mouse 1	I	A	Move-or-Iconify
#Mouse 2	I	A	Iconify
#Mouse 2	FST	A	Menu Window-Ops2 Nop
#Mouse 3	TSIF	A	RaiseLower

Mouse 1         FS      A       Resize-or-Raise
#Mouse 2         FS      A       Move-or-Raise
Mouse 2         FS      A       Move-or-Only
Mouse 3         FS      A       Move-or-Raise
Mouse 3         FS      M       Menu Window-Ops2 Nop
Mouse 1         T       A       Move-or-Raise
Mouse 2         T       A       Move-or-Only
Mouse 3         T       A       Move-or-Shade
Mouse 1         I       A       Move-or-Iconify
Mouse 2         I       A       Move-or-Iconify
Mouse 3         I       A       Menu Window-Ops2 Nop

######################## Initialization Functions ############################
#AddToFunc InitFunction 	  "I" Module FvwmButtons
#+		 	  "I" exec xsetroot -mod 2 2 -fg \#554055 -bg \#705070

#AddToFunc RestartFunction "I" Module FvwmButtons
#+			  "I" exec xsetroot -mod 2 2 -fg \#554055 -bg \#705070

AddToFunc StartFunction	  "I" Module FvwmPager 0 0
+			  "I" Module FvwmButtons

AddToFunc RestartFunction "I" Module FvwmPager 0 0
+			  "I" Module FvwmButtons

######################## Menus ###################
AddToMenu RootMenu	"Root Menu"	Title
+			"XTerm"		Exec exec xterm -geometry 80x25 -sb -sl 2048 -fg white -bg navy -cr green3
+			"KTerm"		Exec exec kterm -geometry 80x25 -sb -sl 2048 -fg white -bg navy -cr green3
+			"日本語端末"		Exec exec kterm -geometry 80x25 -sb -sl 2048 -fg black -bg white -cr navy
+			""		Nop
+			"Remote Logins"	Popup Remote-Logins
+			""		Nop
+                       "Utilities"     Popup Utilities
+			""		Nop
+			"Fvwm Modules"	          Popup Module-Popup
+                       "Fvwm Window Ops"         Popup Window-Ops
+                       "Fvwm Simple Config Ops"  Popup Misc-Ops
+			""		Nop
+                       "Refresh Screen"   Refresh
+                       "Recapture Screen" Recapture
+			""		Nop
+			"Exit Fvwm"	Popup Quit-Verify

AddToMenu Utilities     "Utilities" Title
+			"Top"		Exec exec xterm -T Top -n Top -e top
+			"Calculator"	Exec exec xcalc
+			"Xman"		Exec exec xman
+			"Xmag"		Exec exec xmag
+                       "Editres"       Exec exec editres
+			""		Nop
+			"XEmacs"	Exec exec xemacs
+                       "Mail"          MailFunction xmh "-font fixed"
+			""		Nop
+                       "XLock"         Exec exec xlock -mode random
+			""		Nop
+                       "Reset X defaults" Exec xrdb -load $HOME/.Xdefaults 

AddToMenu Misc-Ops "Misc Config Opts" Title
+                  "Sloppy Focus"        ChangeDefaultFocus SloppyFocus
+                  "Click To Focus"      ChangeDefaultFocus ClickToFocus
+                  "Focus Follows Mouse" ChangeDefaultFocus FocusFollowsMouse
+                  "" Nop
+                  "Colormap Follows Mouse" ColormapFocus FollowsMouse
+                  "Colormap Follows Focus" ColormapFocus FollowsFocus
+                  "" Nop
+                  "Full Paging ON"         EdgeScroll 100 100
+                  "All Paging OFF"         EdgeScroll 0 0
+                  "Horizontal Paging Only" EdgeScroll 100 0
+                  "Vertical Paging Only"   EdgeScroll 0 100
+                  "Partial Paging"         EdgeScroll 50 50
+                  "Full Paging && Edge Wrap" EdgeScroll 100000 100000

AddToMenu Window-Ops	"Window Ops"	Title		
+			"Move"		Move
+			"Resize"	Resize
+			"Raise"		Raise
+			"Lower"		Lower 
+		 	"(De)Iconify"	Iconify
+			"(Un)Stick"	Stick		
+			"(Un)Maximize"	Maximize
+			""		Nop
+			"Delete"	Delete
+			"Close"		Close
+			"Destroy"	Destroy
+			""		Nop
+			"Refresh Window" RefreshWindow

AddToMenu Window-Ops2	"&Move"		Move
+			"&Resize"	Resize
+			"R&aise"	Raise   	
+			"&Lower"	Lower   	
+			"(De)&Iconify"	Iconify 	
+			"(Un)&Stick"	Stick		
+                       "(Un)Ma&ximize" Maximize
+			""		Nop     	
+			"&Delete"	Delete	
+			"&Close"	Close
+			"Destroy"	Destroy 	
+			""		Nop
+			"ScrollBar" 	Module FvwmScroll 2 2	
+			"Print"         PrintFunction
+                       "Print Reverse" PrintReverseFunction

# be sure to fill these in with your correct machine names:
AddToMenu Remote-Logins	"dopey"	 Exec rsh dopey rxvt -display $HOSTDISPLAY &
+			"snoopy" Exec rsh snoopy rxvt -display $HOSTDISPLAY &
+			"grumpy" Exec rsh grumpy rxvt -display $HOSTDISPLAY &
+			"happy"	 Exec rsh happy rxvt -display $HOSTDISPLAY &
+			"bailey" Exec rsh bailey rxvt -display $HOSTDISPLAY &
+			"barnum" Exec rsh barnum rxvt -display $HOSTDISPLAY &
+			"joker"	 Exec rsh joker rxvt -display $HOSTDISPLAY &
+			"signal" Exec rxterm signal

AddToMenu Module-Popup	"FvwmModules"	Title
+			"Identify"	Module	FvwmIdent
+			"Talk"  	Module	FvwmTalk
+			""		Nop
+			"Button-Bar"	Module	FvwmButtons
+			"Pager"		Module  FvwmPager 0 0
+			"Pager (2 desks)" Module  FvwmPager 0 1
+			"WinList"	Module  FvwmWinList
+			""		Nop
+			"Banner"	Module	FvwmBanner
+                       "ScrollBar"     Module  FvwmScroll 50 50
+			"Background"	Module  FvwmBacker
+                       "AutoRaise"     Module  FvwmAuto 200 Raise Nop
+                       "Stop AutoRaise" KillModule FvwmAuto
+			""		Nop
+			"IconBox"	Module	FvwmIconBox
+                       "IconMan"       Module  FvwmIconMan
+			""		Nop
+                       "Form - Rlogin"      Module FvwmForm Rlogin
+                       "Form - MyFvwmTalk"  Module FvwmForm MyFvwmTalk
+                       "Form - QuitVerify"  Module FvwmForm QuitVerify

AddToMenu Quit-Verify 	"Really Quit Fvwm?" Title	
+		      	"Yes, Really Quit"  Quit	
+		      	""		    Nop	
+                       "Restart Fvwm2"     Restart fvwm2
+		      	"Restart Fvwm"	    Restart fvwm
+		      	""		    Nop	
+		      	"Start twm"         Restart twm
+		      	"Start ctwm"        Restart ctwm
+		        "Start tvtwm"       Restart tvtwm
+		        "Start vtwm"        Restart vtwm
+		      	"Start mwm"    	    Restart mwm
+	      	      	"Start olwm"        Restart /usr/openwin/bin/olwm
+		      	""		    Nop	
+		      	"Start dummy"       Restart xterm
+		      	""		    Nop	
+		      	"No, Don't Quit"    Nop	

######################## Sample Functions ##########################

AddToFunc MailFunction	   "I" Next [$0] Iconify -1
+		           "I" Next [$0] Focus
+			   "I" None [$0] Exec $0 $1

AddToFunc Move-or-Raise		"I" Raise
+				"M" Move
+  				"D" Lower
#+  				"D" WindowShade

AddToFunc Move-or-Shade		"I" WindowShade
+				"M" Move
+  				"D" Lower

AddToFunc Move-or-Only		
+				"M" Move
+  				"D" Lower

AddToFunc Move-or-Raise2	"M" Raise
+				"M" Move
+  				"D" Lower

AddToFunc Maximize-Func		"M" Maximize	 0 100
+				"C" Maximize	 0 80
+				"D" Maximize	 100 100

AddToFunc Move-or-Iconify	"I" Raise
+				"M" Move
+				"D" Iconify

AddToFunc Resize-or-Raise	"I" Raise
+				"M" Resize
+				"D" Lower

AddToFunc Resize-or-Raise2	"M" Raise
+				"M" Resize
+				"D" Lower

AddToFunc PrintFunction		"I" Raise
+				"I" Exec xdpr -id $w

AddToFunc PrintReverseFunction  "I" Raise
+                               "I" Exec xdpr 1/2 -h -rv -id $w

AddToFunc Iconify-and-Raise     "I" Iconify
+                               "I" Raise

# RLOGIN machine fg bg
AddToFunc RLOGIN "I" Exec xterm -fg $1 -bg $2 -e rlogin $0 -8

# TELNET machine fg bg
AddToFunc TELNET "I" Exec xterm -fg $1 -bg $2 -e telnet $0

AddToFunc FocusAndWarp "I" Focus
+                      "I" WarpToWindow 2p 2p

AddToFunc DeiconifyFocusAndWarp "I" Iconify -1
+                               "I" FocusAndWarp

AddToFunc ChangeDefaultFocus "I" Style "*" $0
+                            "I" Recapture

################## FvwmButtons button-bar ################################
#*FvwmButtonsBack bisque3
#*FvwmButtons(Frame 2 Padding 2 2 Container(Rows 2 Frame 1 Padding 10 0 \
#                                           Swallow(Respawn)))
#*FvwmButtons(NoSize Title Close, Icon bomb.xpm, Action Close)
#*FvwmButtons(Title Resize Icon mini.resize.xpm Back bisque4 Action Resize)
#*FvwmButtons(Frame -3 Swallow(Respawn,NoHints) xclock \
#       `Exec exec xclock -bg darkolivegreen -padding 0 -geometry +2000+0`)
#*FvwmButtons(3x1 Back darkolivegreen Fore white Frame 2 Padding 2 2 \
#                 Container(Rows 1 Frame -2 Padding 1 1 Back darkolivegreen))
#*FvwmButtons(Frame 2 Title(Side,Right) Mail Fore white \
#         Swallow(UseOld,NoRespawn)\
#         xbiff `Exec exec xbiff -bg darkolivegreen -geometry +200+200`)
#*FvwmButtons(2x1 Swallow (NoHints) "FvwmTalk" "FvwmTalk")
#*FvwmButtons(End)
#*FvwmButtons(End)

*FvwmButtonsFore Black
*FvwmButtonsBack gray
*FvwmButtonsGeometry +0+0
*FvwmButtonsFrame 2
*FvwmButtonsColumns 1
*FvwmButtonsPadding 10 1

*FvwmButtons(Title Netscape, Action 'Exec "Netscape" netscape')
*FvwmButtons(Title Emacs, Action 'Exec emacs -i')
*FvwmButtons(Title Winterm16, Action 'Exec kterm -geometry 80x25 \
	-sb -sl 4096 -fn a16 -fr a16 -fk kanji16 -fr r16\
	-fg black -bg white -cr navy -ms red -km euc')
*FvwmButtons(Title Winterm14, \
	Action 'Exec kterm -geometry 80x25 -sb -sl 4096 \
	-fk k14\
	-fg black -bg white -cr navy -ms red -km euc')

########################## Window-Identifier ###############################
# Just choose colors and a fonts
*FvwmIdentBack MidnightBlue
*FvwmIdentFore Yellow
*FvwmIdentFont -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*

########################### Pager #########################################
*FvwmPagerBack #908090
*FvwmPagerFore #484048
#*FvwmPagerFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmPagerFont "-adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*,-misc-fixed-medium-r-*-*-10-*-*-*-*-*-jisx0208.1983-*"
#*FvwmPagerHilight #cab3ca
*FvwmPagerHilight SeaGreen3
*FvwmPagerGeometry +0-0
*FvwmPagerDeskTopScale 32
*FvwmPagerLabel 0 Misc
*FvwmPagerLabel 1 Maker
*FvwmPagerLabel 2 Mail
*FvwmPagerLabel 3 Matlab
#*FvwmPagerSmallFont "5x8"
*FvwmPagerSmallFont "5x8,-misc-fixed-medium-*-*-*-10-*-*-*-*-*-jisx0208.1983-*"
#*FvwmPagerDeskColor    0 SkyBlue
#*FvwmPagerDeskColor    1 YellowGreen

*FvwmPagerBalloons            All
*FvwmPagerBalloonBack         Yellow
*FvwmPagerBalloonFore         Black
*FvwmPagerBalloonFont         "lucidasanstypewriter-12,-misc-fixed-medium-r-*-*-10-*-*-*-*-*-jisx0208.1983-*"
*FvwmPagerBalloonYOffset      +2
*FvwmPagerBalloonBorderWidth  1
*FvwmPagerBalloonBorderColor  Black

##########################FvwmWinList##################################
*FvwmWinListBack #908090
*FvwmWinListFore Black
*FvwmWinListFont "-adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*,-misc-fixed-medium-r-*-*-10-*-*-*-*-*-jisx0208.1983-*"
#*FvwmWinListFont "-adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*"
*FvwmWinListAction Click1 Iconify -1,Focus
*FvwmWinListAction Click2 Iconify
*FvwmWinListAction Click3 Module "FvwmIdent" FvwmIdent
*FvwmWinListUseSkipList
*FvwmWinListGeometry +0-1

*FvwmBackerDesk 0 -solid steelblue
*FvwmBackerDesk 1 -solid midnightblue

*FvwmScrollBack grey40
*FvwmScrollFore green
	
############################################################
############################################################
# Note that icons are shown in the module
#    only if NoIcon commnand is applied.
#Style     "*"  NoIcon

############################################################
*FvwmIconBoxIconBack    #cfcfcf
*FvwmIconBoxIconHiFore  black
*FvwmIconBoxIconHiBack  LightSkyBlue
*FvwmIconBoxBack        #5f9ea0
#*FvwmIconBoxFore       blue
*FvwmIconBoxGeometry    5x1+0+0
*FvwmIconBoxMaxIconSize 64x38
*FvwmIconBoxFont        -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*
*FvwmIconBoxSortIcons   IconName
*FvwmIconBoxPadding     4
*FvwmIconBoxLines       10
*FvwmIconBoxSBWidth     11
*FvwmIconBoxPlacement   Left Top
*FvwmIconBoxPixmap      fvwm.xpm
#*FvwmIconBoxHideSC Horizontal
*FvwmIconBoxSetWMIconSize
*FvwmIconBoxHilightFocusWin
#*FvwmIconBoxResolution          Desk
*FvwmIconBoxMouse       1       Click           RaiseLower
*FvwmIconBoxMouse       1       DoubleClick     Iconify
*FvwmIconBoxMouse       2       Click           Iconify -1, Focus
*FvwmIconBoxMouse       3       Click           Module FvwmIdent
*FvwmIconBoxKey         r       RaiseLower
*FvwmIconBoxKey         space   Iconify
*FvwmIconBoxKey         d       Close
*FvwmIconBoxKey         n       Next
*FvwmIconBoxKey         p       Prev
*FvwmIconBoxKey         h       Left
*FvwmIconBoxKey         j       Down
*FvwmIconBoxKey         k       Up
*FvwmIconBoxKey         l       Right
#
# Icon file specifications
#
# Mostly, you don't have to specify icon files, as FvwmIconBox now
# reads icon files specified in Style commands.
#
*FvwmIconBox            "Fvwm*"         -

# FvwmForm alias - rlogin or telnet to host via xterm
*RloginWarpPointer
*RloginFont         *helvetica*m*r*n*12*
*RloginButtonFont   *helvetica*m*o*n*12*
*RloginInputFont    *cour*m*r*n*12*
*RloginFore         Black
*RloginBack         Light Gray
*RloginItemFore          Wheat
*RloginItemBack          Gray50
# begin items
*RloginLine         center
*RloginText         "Login to Remote Host"
*RloginLine         center
*RloginText         "Host:"
*RloginInput        HostName  30   ""
*RloginLine         center
*RloginSelection    meth single
*RloginChoice       TN TN off "telnet"
*RloginChoice       RL RL on "rlogin"
*RloginSelection    UserSel   single
#*RloginChoice       Default   Default   on   "same user"
#*RloginChoice       Custom    Custom    off  "user:"
*RloginText         "(Userid:"
*RloginInput        UserName  10   ""
*RloginText         ")"
*RloginLine         center
*RloginText         "FG:"
*RloginInput        FgColor 15 ""
*RloginText         "BG:"
*RloginInput        BgColor 15 ""
*RloginLine         expand
*RloginButton       quit "Login" ^M
*RloginCommand Exec xterm  $(FgColor?-fg $(FgColor)) $(BgColor?-bg $(BgColor)) -T xterm@$(HostName) -e $(RL?rlogin) $(TN?telnet) $(HostName) $(RL?-8 $(UserName?-l $(UserName)))
*RloginButton       restart   "Clear"
*RloginCommand Beep
*RloginButton       quit "Cancel"
*RloginCommand Nop

# FvwmForm alias - query exit ala mwm
*QuitVerifyGrabServer
*QuitVerifyWarpPointer
*QuitVerifyFont          *helvetica*m*r*n*14*
#*QuitVerifyButtonFont    *helvetica*m*o*n*14*
*QuitVerifyButtonFont    7x13bold
*QuitVerifyFore          Black
*QuitVerifyBack          Light Gray
*QuitVerifyItemFore Wheat
*QuitVerifyItemBack Gray50
# begin items
*QuitVerifyLine          center
*QuitVerifyText          "Do you really want to exit FVWM?"
*QuitVerifyLine          expand
*QuitVerifyButton   quit      " Exit "
*QuitVerifyCommand  Quit
*QuitVerifyButton   quit      "Cancel"
*QuitVerifyCommand  Nop

# MyTalk & MyFvwmTalk from Dave Goldberg
# MyTalk Form - dissappears after use
*MyTalkWarpPointer
*MyTalkFont *helvetica*m*r*n*14*
*MyTalkButtonFont *helvetica*m*o*n*14*
*MyTalkInputFont *cour*m*r*n*14*
*MyTalkFore Red
*MyTalkBack Gray
*MyTalkItemFore Blue
*MyTalkItemBack Gray
*MyTalkLine center
*MyTalkText "Fvwm Function"
*MyTalkInput Func 40 ""
*MyTalkLine expand
*MyTalkButton quit "Run" ^M
*MyTalkCommand $(Func)
*MyTalkButton restart "Clear" ^R
*MyTalkButton quit "Cancel" ^C
*MyTalkCommand Nop
# MyFvwmTalk Form - sticks around
*MyFvwmTalkWarpPointer
*MyFvwmTalkFont *helvetica*m*r*n*14*
*MyFvwmTalkButtonFont *helvetica*m*o*n*14*
*MyFvwmTalkInputFont *cour*m*r*n*14*
*MyFvwmTalkFore Red
*MyFvwmTalkBack Gray
*MyFvwmTalkItemFore Blue
*MyFvwmTalkItemBack Gray
*MyFvwmTalkLine center
*MyFvwmTalkText "Fvwm Function"
*MyFvwmTalkInput Func 40 ""
*MyFvwmTalkLine expand
*MyFvwmTalkButton restart "Run" ^M
*MyFvwmTalkCommand $(Func)
*MyFvwmTalkButton restart "Clear" ^R
*MyFvwmTalkCommand Nop
*MyFvwmTalkButton restart "Iconify" ^Z
*MyFvwmTalkCommand Next [MyFvwmTalk] Iconify
*MyFvwmTalkButton quit "Quit" ^C
*MyFvwmTalkCommand Nop

# to change banner pixmap
#*FvwmBannerPixmap fvwm3.xpm
#*FvwmBannerTimeout 2

-----------------------------------------------------------
-- 
   ┏━━━━━━━━━━━━━━━━━━━━━━┓
   ┃  村上 智一   ( TomOne )     福田研究室     ┠┐
   ┃  奈良先端科学技術大学院大学 情報科学研究科 ┃│
   ┃  E-Mail: [email-masked]       ┃│
   ┃  http://fukuda.aist-nara.ac.jp/~tomoka-m/  ┃│
   ┗┯━━━━━━━━━━━━━━━━━━━━━┛│
     └──────────────────────┘
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Fri, 27 Oct 2000 12:30:28 -0400

> hi you great guys who make my day with fvwm2!

Flattery will get you everywhere.

> btw: do you need someone to update your website?

I can handle applying the screenshots.
I am not the only one that does this.

If you have other improvements in mind, let us know.
The fvwm-workers team is always open to new contributors.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Andre Bonhote <[email-masked]>
Date: Fri, 27 Oct 2000 22:53:55 +0200

well, i don't know, compared to sites like freshmeat.net, fvwm.org looks
quite oldscool. i know, graphics are a waste of bandwith, but, you know
;)

if you like, i could place some kind of redesign (within the next few
MONTHS) on my own page, and you could have a look at it, and, if you
like it, you can have it. what kind of server does fvwm.org run on?
apache? is php there? perl? hmm?
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Jason L Tibbitts III <[email-masked]>
Date: 27 Oct 2000 16:20:47 -0500

>>>>> "AB" == Andre Bonhote <[email-masked]> writes:

AB> what kind of server does fvwm.org run on?  apache? is php there? perl?

It's apache.  The machine is bog standard RedHat.  The extras aren't there
currently but I can install them if they're needed.

 - J<

---

From: Dan Espen <[email-masked]>
Date: Sat, 28 Oct 2000 07:26:47 -0400

> apache? is php there? perl? hmm?

Sounds like a good plan to me.

I admit I prefer the fvwm site to the freshmeat site for a few reasons:

I don't have to scroll to see my way around
I like dark backgrounds

Still, I agree, a bit more graphics and a more sophisticated layout
would help.