Subject: border_width is short

From: Olivier Chapuis <[email-masked]>
Date: Wed, 11 Oct 2000 23:34:49 +0200

>From the ChangeLog:
> * fvwm/fvwm.h (FvwmWindow):
> * fvwm/style.c (ProcessNewStyle):
> made boundary_width, border_width and handle_width short instead of int

Hm, this cause the TaskBar (and maybe other modules) to get some
problem of geometry. The taskbar used the border_width to fit 
exactly the screen:

win_border = (int)cfgpacket->border_width;

since now cfgpacket->border_width is short the taskbar is broken.
Of course this is easy to fix:

win_border = (short)cfgpacket->border_width;

But, I am not sure that this is the good fix. It seems
to me that maybe this is a fvwm2 bug ?????????

Olivier

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 12 Oct 2000 10:05:38 +0200

> since now cfgpacket->border_width is short the taskbar is broken.

Um, the border_width that is sent to the modules was and still
is unsigned long.  Only the way fvwm treats the border/handle
width internally has changed.  Look at libs/vpacket.h:

  typedef struct ConfigWinPacket
  {
  ...
  unsigned long int  border_width;
  ...
  } ConfigWinPacket;

I did not change that.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 12 Oct 2000 10:31:16 +0200

>   unsigned long int  border_width;

Argh, I didn't fathom the code was so touchy. You are right,
the modules get trash now. I'll commit a fix.

Bye

Dominik ^_^  ^_^