Subject: To do for 2.4 (update 38)

From: Dominik Vogt <[email-masked]>
Date: Sun, 8 Oct 2000 15:31:18 +0200

Please look over the "to be discussed" section so we can decide
which of these will not be done.

Items with highest priority / most severe problems:

  117, 134, 146

New since last update:

163 (former 9 + 12)

Closed since last update:

9, 12, 123, 127, 148

---------- Summary: ----------------------------------------------

 1 to be verified
10 to be discussed
 5 to do
 2 distribution issues
 9 testing
----------------------
27 open items
136 items closed
163 items in total

---------- To be verified: ---------------------------------------

118) Investigate "FvwmPager & StaysOnTop" bug (#543).
     [reported by Nadim Shaikli <[email-masked]>]

---------- To be discussed ---------------------------------------

 17) Fix the bug that causes icons to lose management (bug #352).
     [couldn't reproduce this yet; can anybody who has netcool
     event manager try it?]
     -> [unreproducible]
 32) Several applications are reported to not resize well under fvwm
     (Datek's "Streamer", CodeWarrior).
     [optional]
     -> [unreproducible]
116) Fix problem that can cause long icon titles to be expanded
     although the pointer is not over it.
     [reported by Mikhael]
     -> [Dominik: I know the problem is there, but it is difficult to debug and
     perhaps not worth to delay the release]
122) Investigate FvwmButtons panel problem.
     [reported by Robert H. Ford II <[email-masked]> on 18-Feb-2000]
     -> [no usable feedback]
126) Bug #489 (icons migrating on restart, ident does not work)
     -> [unreproducible]
129) Bug #560 (freeze on Exceed)
     [various reporters, but no usable feedback yet]
     -> [no usable feedback]
130) Fix bounds error with 'DestroyStyle *' in
     update_window_color_hi_style().
     [reported by Ben Winslow <[email-masked]>]
     [not reproduced yet]
     [purify may bring it up when we run the test script again]
     -> [unreproducible]
143) Bug #603 (TaskBar bugs): investigate and possibly fix.
156) xterm client window cursor corrupted.
     [reported by Nagi Aboulenein on 2-Nov-1999]
     -> [unreproducible]
158) IS_NAME_CHANGED flag still broken?
     [Mikhael]
     -> ?
162) Fix core dump with icon boxes
     [reported on 25-may-2000 by [email-masked]]
     -> [unreproducible]

--------- To do: ------------------------------------------------

117) Investigate icons disappearing if icon changes while on a
     different desk.
     [reported by Julian Gilbey/David Cunningham on 16-Mar-2000]
125) Bug #479 (windows migrating to page 0 0 during restart w/ xsession)
134) Investigate DecWindows ConfigureRequest/Notify race condition.
     [reported by Fabien Viallard on 19-Apr-2000]
146) Bug #542 (Winch signals).

---------- Distribution issues: ----------------------------------

 62) Write a new announcement.
     [in progress]
163) Make bzip2 and rpm packages available from our downloads page.

---------- Testing: ----------------------------------------------

 33) Test the GNOME patches.
 34) Update and run the purify script again (and update it).
 35) Test the strokes patch.
 36) Test the new menu styles (ItemFormat!)
 92) Test new session management code.
 94) Test colour set support in modules and fvwm.
 95) Test new panel implementation in FvwmButtons.
105) Test binding code.
106) Test window position code.

========== Closed recently: ======================================

123) Bug #378 (FvwmPager interferes with xscreensaver)
     [unreproducible, seems to be fixed]
127) Bug #511 (xpp subwindows not drawn properly)
     [not a bug, xpp is broken]
148) Losing focus when entering root window bug.
     [reported by Elliot Sowadsky on 29-Dec-1999]
     [confirmed by Dominik]
     [fixed]

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sun, 08 Oct 2000 16:43:01 -0400

> which of these will not be done.

I don't see anything on the list that would get in the way of releasing
our current release as a non-beta.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 11 Oct 2000 02:07:34 +0200

>      perhaps not worth to delay the release]

Well, I never said that this is a critical problem to be fixed before 2.4.
I simply report all bugs which I find. I should yet find a time to
report another bunch of problems (i.e. to try to find a minimal rc, better
description etc.), it is in http://fvwm-themes.dhs.org/fvwm-bugs.txt

I want to have a new stable release not less than others, but I am seeing
core dumps from time to time (some were overwritten by other app cores).
It would be nice to at least not have crashes before calling it stable.

> 143) Bug #603 (TaskBar bugs): investigate and possibly fix.

I can't reproduce an initial position problem with AutoStick, but now when
I played with it, if I undefine Geometry and AutoStick -

  DestroyModuleConfig FvwmTaskBar: Geometry
  DestroyModuleConfig FvwmTaskBar: AutoStick

FvwmTaskBar is started sticky on position +0-3384, i.e. out of screen.

> 158) IS_NAME_CHANGED flag still broken?

The problem was (and still is) this: when you do a checkpoint in a session
manager, i.e. save a session, fvwm stores a state file, which seems to be
correct. But then when fvwm starts again inside a session manager, this
session is restored and some windows, which change their names dynamically
(like my xterms in the shell's prompt) are placed in a fresh position
instead of restoring their old position. The interesting thing is that
when you save a session several times (usually 2), the problem disappears.

Seems like a syncronization problem, supposedly on add-window time.
I can't say now whether I will have a time to look at it before 2.4,
if not, we can promote this problem to a known bug, i.e. a feature.

I would replace the description of this problem:

158) Sometimes a state is not restored for windows with IS_NAME_CHANGED
     flag set under SM - no match in matchWin().
     [investigate/fix if there is a time]

> 163) Make bzip2 and rpm packages available from our downloads page.

bzip2 packages could be stored together with gzip ones. But rpm's should
be actually maintained. Supposing that I will do this (any taker welcome),
I will do this in the place where I have file permissions, i.e. on
fvwm-themes.sourceforge.net. We can simply link to it, already done.
Or, in case Jason setups an automatical mirror (ftp mirror or using rsync,
I can help with this), we can also have rpm-s on, say:

  ftp://ftp.fvwm.org/pub/fvwm/version-2/rpm/

with a possible subdirectory structure for versions/distributions.

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 11 Oct 2000 07:04:08 +0200

> FvwmTaskBar is started sticky on position +0-3384, i.e. out of screen.

Fixed, Olivier