Subject: A task for our configure gurus

From: Dominik Vogt <[email-masked]>
Date: Sun, 8 Oct 2000 01:51:54 +0200

I just found this piece of un-configure'd code in fvwm/colormaps.c:

    if(last_cmap != tmp->attr.colormap
#if defined(sun) && defined(TRUECOLOR_ALWAYS_INSTALLED)
       && !(tmp->attr.depth == 24 && tmp->attr.visual->class == TrueColor)
#endif
        )
    {
      last_cmap = tmp->attr.colormap;
      XInstallColormap(dpy, last_cmap);
    }

Any ideas if/why this is necessary and how we can remove this?
My guess is that the TRUECOLOR_ALWAYS_INSTALLED macro is never
defined anyway.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Tue, 10 Oct 2000 10:03:15 -0400

> My guess is that the TRUECOLOR_ALWAYS_INSTALLED macro is never

I can't find the macro being defined in any Solaris 2.8 header file.
I don't have access to any SunOs4 machines (Solaris 1.x).
But I've never seen a Solaris machine that wasn't 8 bit anyway.

The TRUECOLOR code is in 2.0.47d, but not in 1.24r.

Oh, here it is:

http://www.hpc.uh.edu/fvwm/archive/9708/msg00282.html

Heres the relevant part:

To: FVWM Mailing List <[email-masked]> 
     Subject: fvwm 2.0.46: patches and bugs 
     From: Grant McDorman <[email-masked]> 
     Date: Tue, 26 Aug 1997 14:31:02 -0400 (EDT) 
     Organization: ISG Technologies Inc. 

I have just finished installing - and patching - 2.0.46.

The patches (attached) are as follows:
...
   fvwm:
     colormaps.c: If, on Sun systems, TRUECOLOR_ALWAYS_INSTALLED is defined,
                  do not install a 24-bit TrueColor colormap. (Despite what
                  the server says, it is always installed.)
...

Grant McDorman <[email-masked]>

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Tue, 10 Oct 2000 10:33:30 -0400

> The TRUECOLOR code is in 2.0.47d, but not in 1.24r.

I just searched all my headers on sunos and solaris and can't seem to find it.  I checked system headers, X11 headers, motif and cde headers.

Dan, you are kidding right. You've never seen better thatn 8 bit?
Anything better than an ultra 1 comes with enough video ram to do 24
bit.  Unless I misread something over the years I thought your work was
providing your Sun's, if that is the case and you aren't on at least an
ultra2 by now I think you should fill out some request forms.

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Tue, 10 Oct 2000 11:03:12 -0400

Sorry, this is all off topic.

Brad Giaccio <[email-masked]> writes:
> 
> I just searched all my headers on sunos and solaris and can't seem to find it
> .  I checked system headers, X11 headers, motif and cde headers.

I assume you mean SunOS4. Solaris 2 is SunOS5.

> ultra2 by now I think you should fill out some request forms.

So far I've had Sparc 1+, Sparc IPC, Sparc 2, Sparc  10, and now Ultra
5.  I know newer   Ultra 5's can  be had  with  24 bit, but ours  were
acquired  early  with 8 bit.     The only compensation  is  the 21inch
monitor.

I see after market PCI cards (Raptor GFX-8P) that are 8/24 bit, but
I'd really like one that goes to 1600x1200 before I spend any of
my employers money.

Of course the corporate types really want us  to use PCs  and NT.
Fat chance.