Subject: CVS domivogt: * Fixed drawing of menu items with a picture but no test.

From: CVS <[email-masked]>
Date: Wed, 11 Oct 2000 09:52:30 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	00/10/11 09:52:30

Modified files:
	.              : ChangeLog 
	fvwm           : events.c fvwm2.1 menus.c virtual.c 

Log message:
* Fixed drawing of menu items with a picture but no test.
* Fixed MouseFocusClickRaises style when a new window was mapped over the window with the focus.
* Fixed unnecessary redraw when paging.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 13 Oct 2000 05:28:03 +0200

> * Fixed unnecessary redraw when paging.

Supposedly after this commit (unnecessary redraw), there are no enough
redraws when moving across the left page edge. I can reproduce this while
moving just about every app, say xcalc, xterm or yet better FvwmIdent.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 13 Oct 2000 09:16:07 +0200

> moving just about every app, say xcalc, xterm or yet better FvwmIdent.

Well, I don't understand what you mean, but it certainly has
nothing to do with the 'unnecessary redraw' fix.  What I fixed
was the order in which windows are mapped/unmapped when
switching pages.  The old code assumed a window and viewport
width/heigt that was 1 pixel too big, so windows touching the
right or bottom border were mapped/unmapped in the wrong order
(which caused X to first draw windows obscured below them and
the unmap them).

Please elaborate what problem you see.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 14 Oct 2000 03:26:51 +0200

On 13 Oct 2000 09:16:07 +0200, Dominik Vogt wrote:
> Well, I don't understand what you mean,

I was wrong, this can't be related to the latest changes. I can reproduce
this problem even with fvwm-2.2.4. And I can't reproduce it at all on my
second machine, so it is probably related to my new X Server.

The problem is that there are no enough refreshes while moving windows
across the left viewport edge. Like in the attached image.

I guess I should debug this problem (missing events?), but not now.
Unless others can reproduce the same problem, probably fvwm is ok here.

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 14 Oct 2000 03:42:52 +0200

attachment

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 18 Oct 2000 09:25:20 +0200

> Unless others can reproduce the same problem, probably fvwm is ok here.

Hm, that doesn't look like an fvwm bug. Fvwm can't do anything about
the contents of the window. Since you said it happens with all
windows, I guess it is an X server problem.

Bye

Dominik ^_^  ^_^