Subject: Re: core dump with fvwm-themes

From: Olivier Chapuis <[email-masked]>
Date: Sun, 01 Oct 2000 11:10:31 +0200

Dan Espen wrote:
> 
> Olivier Chapuis <[email-masked]> writes:
> > if one (Dan, Brad ?) can run Purify with fvwm-themes. Reapeting
> > "load all a_theme" will do somethings similar than the test/purify
> > "script" but updated for 2.4.
> 
> I used the latest beta for fvwm-themes.
> 
> I got lots of FMRs and some UMRs.  I've trimmed out the duplicates.
> If you'd like the complete file, I can mail it to you,
> its too big for this list.

Yes I am intersested by this file. But the problem is that
currently I do not understand the Purify output. Maybe, it will
be good that someone else take a look at it :)

Olivier

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Tue, 3 Oct 2000 12:31:37 -0400

Two things:

Dan, why don't you just run purify with -log-file=<filename> then purify
won't pop up a window.

Oliver, let me see if I can help you with the output a little.  An FMR
stands for free memory read.  What the output is telling you is that in
some file:line memory was read that had been freed, the rest of that
block is the stack trace.  The next section shows you where the memory
was allocated and the last shows you where it was freed.

The second type of error Dan gave you was a UMR (uninitalized memory
read), this often happens if you have a structure but don't make
assignments in all the fields, then pass it to a function that uses all
the fields.  Usually the safest thing to do here is look at where it was
allocated and see if it makes sense to set all aspects of the data type
to some default value.

Hope this helps, at the moment I've got Linux on my desk not Solaris so
I can't purify fvwm without some difficulty, so if you have it well in
hand Dan I'll let you do it.

Brad

On Sun, Oct 01, 2000 at 11:10:31AM +0200, Olivier Chapuis wrote:

> > If you'd like the complete file, I can mail it to you, its too big
> > for this list.
>
> Yes I am intersested by this file. But the problem is that currently
> I do not understand the Purify output. Maybe, it will be good that
> someone else take a look at it :)
>
> Olivier
>
>

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 03 Oct 2000 22:36:31 +0200

Thanks for the Help of every body!
So, I've tried to interpret Purify output for the bindings
code. I think that I've fixed some bugs but not sure that
I've fixed all. Dan can you run again Purify on my last
commit and FVWM Themes and sent me or to the list the output?
Olivier

PS: I've also take a fast look at the modules interface
URM, I do not see the problem, but it seems that the
core dumps are here or in the menu code ??????????

PS2: I've used --enable-dmalloc on fvwm2 (with the latest 
version of dmalloc) and dmalloc core dump (funny to see
a debugger that core dump). It seems that the core dump
arise when fvwm2 (or a module) used CachePicture 
(libs/Picture.c). Note that dmalloc help to find
memory leaks in FvwmScript.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Tue, 03 Oct 2000 23:17:25 -0400

> Dan, why don't you just run purify with -log-file=<filename> then purify

OK, this is the 3rd time I've tried to reply to this.  The
first 2 times I lost my connection typing exactly the same
letter.

The GUI is so much fun...
you're right of course.

(The "u" in "you're" was the killer.  I appear to be past it.)

I'm attaching Purify output after the latest commits.
I made 2 runs, the first with my normal config, the second with
fvwm-themes.  The FMRs seem to be gone.

There are a few UMRs (unitialized memory reads).  As Brad correctly
points out, UMRs should be investigated but are often not a problem.
I like to clean them up just so I don't seem them again, but sometimes
it just isn't worth it.

Heres the output:

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570