Subject: CVS domivogt: * Memory leak fixes. Dan, please run purify again. I think I fixed all leaks

From: CVS <[email-masked]>
Date: Fri, 6 Oct 2000 06:26:35 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	00/10/06 06:26:35

Modified files:
	.              : ChangeLog 
	fvwm           : conditional.c cursor.c style.c 

Log message:
* Memory leak fixes. Dan, please run purify again. I think I fixed all leaks
except the SetEnv leak (will not be fixed) and the MwmHints leak.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 06 Oct 2000 18:34:18 +0200

> except the SetEnv leak (will not be fixed) and the MwmHints leak.

Yes, I think that you fix almost all memory leaks :o)
Before all your commits fvwm2 with fvwm-themes has a
problem of memory: more you switched more fvwm2 used 
memory. Now this is no more the case!
Olivier

---

From: Dan Espen <[email-masked]>
Date: Fri, 06 Oct 2000 17:57:54 -0400

> except the SetEnv leak (will not be fixed) and the MwmHints leak.

I don't see any memory leaks (MLK) in this one, just UMRs.
Sorry its so long.  The beta version of the themes package seems to
have stopped changing the appearance of my windows.  I made quite
a few tries.

I hope its still testing the things we want to test.

I'm running this remotely.  Its unbelievably slow.  Just popping a menu
takes a minute or 2.  My guess is that its the gradients, but thats only
a guess.

Here it is:

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570