Subject: Problems building snap-20001018

From: Jason L Tibbitts III <[email-masked]>
Date: Wed, 18 Oct 2000 06:36:05 -0500 (CDT)

? fvwm-snap-20000125
? icons/Makefile.in
? icons/Makefile
? modules/FvwmAudio/Makefile.in
? modules/FvwmAudio/Makefile
? modules/FvwmAudio/.deps
? modules/FvwmAudio/FvwmAudio
? modules/FvwmScript/Scripts/some_nice_icons/Makefile.in
? modules/FvwmScript/Scripts/some_nice_icons/Makefile
P ChangeLog
P acinclude.m4
aclocal: macro ` at /usr/local/bin/aclocal line 319, <CONFIGURE> line 6.
Makefile.am:7: required directory ./utils does not exist
Makefile.am:7: required directory ./docs does not exist
Makefile.am:7: required directory ./sample.fvwmrc does not exist
Makefile.am:7: required directory ./tests does not exist
modules/Makefile.am:3: required directory modules/FvwmIdent does not exist
modules/Makefile.am:3: required directory modules/FvwmM4 does not exist
modules/Makefile.am:3: required directory modules/FvwmPager does not exist
modules/Makefile.am:3: required directory modules/FvwmRearrange does not exist
modules/Makefile.am:3: required directory modules/FvwmSave does not exist
modules/Makefile.am:3: required directory modules/FvwmSaveDesk does not exist
modules/Makefile.am:3: required directory modules/FvwmScript does not exist
modules/Makefile.am:3: required directory modules/FvwmScroll does not exist
modules/Makefile.am:3: required directory modules/FvwmTaskBar does not exist
modules/Makefile.am:3: required directory modules/FvwmTheme does not exist
modules/Makefile.am:3: required directory modules/FvwmWharf does not exist
modules/Makefile.am:3: required directory modules/FvwmWinList does not exist
loading cache ./config.cache
checking for a BSD compatible install... (cached) /usr/local/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... (cached) yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... found
checking whether to enable debugging messages... no
checking whether to enable multibyte character support (does not work yet)... no
checking whether to enable workaround for flickering windows during move... no
checking whether to enable modal dialogs for applications... yes
checking whether to enable shape extensions... yes
checking imagepath... /usr/include/X11/bitmaps:/usr/include/X11/pixmaps
checking for gcc... (cached) gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking how to run the C preprocessor... (cached) gcc -E
checking for POSIXized ISC... no
checking for minix/config.h... (cached) no
checking for X... (cached) libraries /usr/openwin/lib, headers /usr/openwin/include
checking whether -R must be followed by a space... no
checking for dnet_ntoa in -ldnet... (cached) no
checking for dnet_ntoa in -ldnet_stub... (cached) no
checking for gethostbyname... (cached) no
checking for gethostbyname in -lnsl... (cached) yes
checking for connect... (cached) no
checking for connect in -lsocket... (cached) yes
checking for remove... (cached) yes
checking for shmat... (cached) yes
checking for IceConnectionNumber in -lICE... (cached) no
checking whether to enable GNOME window manager hints... yes
checking for SmcOpenConnection in -lSM... no
checking for XpmReadFileToXpmImage in -lXpm... yes
checking for X11/xpm.h... yes
checking for Xpm 3.4g or better... no
checking for rplay_create in -lrplay... no
checking for stroke_init in -lstroke... no
checking with termcap... checking for readline in -lreadline... yes
checking for readline/history.h... yes
checking for _Xsetlocale in -lX11... (cached) no
checking for stdarg.h... (cached) yes
checking for vfprintf... (cached) yes
checking for waitpid... (cached) yes
checking for cpp... (cached) /usr/ccs/lib/cpp
checking for a BSD compatible install... /usr/local/bin/install -c
checking whether ln -s works... (cached) yes
checking whether make sets ${MAKE}... (cached) yes
checking for ranlib... (cached) :
checking for flex... (cached) flex
checking for flex... (cached) flex
checking for yywrap in -lfl... (cached) yes
checking lex output file root... (cached) lex.yy
checking whether yytext is a pointer... (cached) yes
checking for bison... (cached) bison -y
checking for perl... (cached) /usr/local/bin/perl
checking for perl 5.002 or better... no
configure: warning: /usr/local/bin/perl not found or too old
checking for ANSI C header files... (cached) yes
checking for sys/wait.h that is POSIX.1 compatible... (cached) yes
checking for stdlib.h... (cached) yes
checking for fcntl.h... (cached) yes
checking for limits.h... (cached) yes
checking for malloc.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for unistd.h... (cached) yes
checking for getopt.h... (cached) no
checking for sys/select.h... (cached) yes
checking for sys/systeminfo.h... (cached) yes
checking for working const... (cached) yes
checking for inline... (cached) inline
checking for off_t... (cached) yes
checking for pid_t... (cached) yes
checking for size_t... (cached) yes
checking return type of signal handlers... (cached) void
checking for working alloca.h... (cached) yes
checking for alloca... (cached) yes
checking for strftime... (cached) yes
checking for gettimeofday... (cached) yes
checking for mkfifo... (cached) yes
checking for putenv... (cached) yes
checking for setvbuf... (cached) yes
checking for socket... (cached) no
checking for waitpid... (cached) yes
checking for strdup... (cached) yes
checking for strstr... (cached) yes
checking for strtol... (cached) yes
checking for memmove... (cached) yes
checking for memcpy... (cached) yes
checking for strchr... (cached) yes
checking for sysconf... (cached) yes
checking for uname... (cached) yes
checking for div... (cached) yes
checking for sigaction... (cached) yes
checking for siginterrupt... (cached) no
checking for getpwuid... (cached) yes
checking for sig_atomic_t... (cached) yes
checking whether setvbuf arguments are reversed... (cached) no
checking for select... (cached) yes
checking for unistd.h... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/time.h... (cached) yes
checking for sys/select.h... (cached) yes
checking for sys/socket.h... (cached) yes
checking argument types of select()... (cached) select(int,fd_set *,...)
checking for gethostname... (cached) no
checking for strcasecmp... (cached) yes
checking for strncasecmp... (cached) yes
checking for strdup... (cached) yes
checking for strerror... (cached) yes
checking for usleep... (cached) no
checking for atexit... (cached) yes
checking for gtk-config... (cached) no
checking for GTK - version >= 1.1.0... no
*** The gtk-config script installed by GTK could not be found
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG environment variable to the
*** full path to gtk-config.
checking for imlib-config... (cached) no
checking for IMLIB - version >= 1.8.0... no
*** The imlib-config script installed by IMLIB could not be found
*** If IMLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the IMLIBCONF environment variable to the
*** full path to imlib-config.
checking for gnome-config... (cached) no
checking for gnomeConf.sh file in /usr/local/lib... not found
creating ./config.status
creating Makefile
creating libs/Makefile
creating fvwm/Makefile
creating modules/Makefile
creating utils/Makefile
creating utils/fvwm-config
creating utils/fvwm-menu-xlock
creating utils/fvwm-menu-directory
creating utils/fvwm-menu-desktop
creating utils/fvwm-menu-headlines
creating utils/fvwmbug.sh
creating rpm/Makefile
creating rpm/fvwm.spec
creating docs/fvwm.lsm
creating docs/Makefile
creating sample.fvwmrc/Makefile
creating tests/Makefile
creating modules/FvwmAnimate/Makefile
creating modules/FvwmAuto/Makefile
creating modules/FvwmBacker/Makefile
creating modules/FvwmBanner/Makefile
creating modules/FvwmButtons/Makefile
creating modules/FvwmCommand/Makefile
creating modules/FvwmCommand/scripts/Makefile
creating modules/FvwmConsole/Makefile
creating modules/FvwmConsole/FvwmConsoleC.pl
creating modules/FvwmCpp/Makefile
creating modules/FvwmDebug/Makefile
creating modules/FvwmDragWell/Makefile
creating modules/FvwmEvent/Makefile
creating modules/FvwmForm/Makefile
creating modules/FvwmIconBox/Makefile
creating modules/FvwmIconMan/Makefile
creating modules/FvwmIdent/Makefile
creating modules/FvwmM4/Makefile
creating modules/FvwmPager/Makefile
creating modules/FvwmRearrange/Makefile
creating modules/FvwmSave/Makefile
creating modules/FvwmSaveDesk/Makefile
creating modules/FvwmScript/Makefile
creating modules/FvwmScript/Scripts/Makefile
creating modules/FvwmScript/Widgets/Makefile
creating modules/FvwmScroll/Makefile
creating modules/FvwmTaskBar/Makefile
creating modules/FvwmTheme/Makefile
creating modules/FvwmWharf/Makefile
creating modules/FvwmWinList/Makefile
creating modules/FvwmGtk/Makefile
creating config.h
config.h is unchanged

Configuration:

  FVWM Version:                      2.3.22

  Have ReadLine support?             yes
  Have RPlay support?                no
  Have Stroke support?               no
  Have XPM support?                  no: Xpm library version is too old!
  Have GTK support?                  no
  Have GNOME Window Manager support? yes
  Have Session Management support?   no
  Have GNOME support in FvwmGtk?     no

cd . && aclocal
aclocal: macro ` at /usr/local/bin/aclocal line 319, <CONFIGURE> line 6.
aclocal: macro ` at /usr/local/bin/aclocal line 319, <CONFIGURE> line 6.
aclocal: macro ` at /usr/local/bin/aclocal line 319, <CONFIGURE> line 6.
aclocal: macro ` at /usr/local/bin/aclocal line 319, <CONFIGURE> line 6.
make: *** [aclocal.m4] Error 1
make: Failed to remake makefile `Makefile'.
make: Target `all' not remade because of errors.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 20 Oct 2000 01:10:32 +0200

> modules/Makefile.am:3: required directory modules/FvwmWinList does not exist

Jason, can you manually run aclocal (or autoreconf) in the fvwm directory?
Do you get the same errors or these only happen when executed from cron?

[...]

> make: Failed to remake makefile `Makefile'.

Seems strange that /usr/local/bin/aclocal didn't print the whole error
message. I would add the following in this file before warn in line 319:

  print "Macro missing: ($macro)\n";

This would at least print a problematic macro if any.

Regards,
Mikhael.

---

From: Jason L Tibbitts III <[email-masked]>
Date: 20 Oct 2000 12:07:28 -0500

>>>>> "MG" == Mikhael Goikhman <[email-masked]> writes:

MG> Jason, can you manually run aclocal (or autoreconf) in the fvwm
MG> directory? Do you get the same errors or these only happen when
MG> executed from cron?

Yes, things are exactly the same.

MG> Seems strange that /usr/local/bin/aclocal didn't print the whole error
MG> message. I would add the following in this file before warn in line
MG> 319:

It doesn't help; you get:

Macro missing: ( at /usr/local/bin/aclocal line 319, <CONFIGURE> line 6.
aclocal: macro ` at /usr/local/bin/aclocal line 320, <CONFIGURE> line 6.

Isn't that odd?  It's as if the macro has a spurious \0 in it.  As usual,
nothing has changed with this machine, there is plenty of disk space, etc.

 - J<

---

From: Jason L Tibbitts III <[email-masked]>
Date: 20 Oct 2000 19:41:20 -0500

Here's the result from a clean checkout.  This is most odd.

XYX:sina:~/fvwm> /usr/local/bin/automake --add-missing
automake: configure.in: installing `./install-sh'
automake: configure.in: installing `./mkinstalldirs'
automake: configure.in: installing `./missing'
configure.in: 6: required file `./config.h.in' not found

XYX:sina:~/fvwm> /usr/local/bin/autoreconf
ls: aclocal.m4: No such file or directory
Macro missing: ( at /usr/local/bin/aclocal line 319, <CONFIGURE> line 6.
aclocal: macro ` at /usr/local/bin/aclocal line 320, <CONFIGURE> line 6.
Macro missing: ( at /usr/local/bin/aclocal line 319, <CONFIGURE> line 6.
aclocal: macro ` at /usr/local/bin/aclocal line 320, <CONFIGURE> line 6.
Macro missing: ( at /usr/local/bin/aclocal line 319, <CONFIGURE> line 6.
aclocal: macro ` at /usr/local/bin/aclocal line 320, <CONFIGURE> line 6.
Macro missing: ( at /usr/local/bin/aclocal line 319, <CONFIGURE> line 6.
aclocal: macro ` at /usr/local/bin/aclocal line 320, <CONFIGURE> line 6.
configure.in: 6: required file `./config.h.in' not found
configure.in:158: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:371: warning: AC_TRY_RUN called without default to allow cross compiling
autoconf: Undefined macros:
configure.in:113:dnl AC_SUBST(sm_LIBS)
configure.in:114:dnl AC_SUBST(sm_CFLAGS)
configure.in:12:AC_SUBST(FVWM_MODULEDIR)
configure.in:13:AC_SUBST(FVWM_DATADIR)
configure.in:14:AC_SUBST(FVWM_CONFDIR)
configure.in:165:    FVWMBANNER=FvwmBanner AC_SUBST(FVWMBANNER)
configure.in:166:    XPMROOT=xpmroot AC_SUBST(XPMROOT)
configure.in:167:    FVWMSCRIPT=FvwmScript AC_SUBST(FVWMSCRIPT)
configure.in:173:AC_SUBST(xpm_LIBS)
configure.in:174:AC_SUBST(xpm_CFLAGS)
configure.in:185:AC_SUBST(rplay_LIBS)
configure.in:186:AC_SUBST(rplay_CFLAGS)
configure.in:197:AC_SUBST(stroke_LIBS)
configure.in:198:AC_SUBST(stroke_CFLAGS)
configure.in:246:AC_SUBST(readline_LIBS)
configure.in:247:AC_SUBST(readline_CFLAGS)
configure.in:374:AC_FUNC_SELECT
configure.in:381:AC_SUBST(LIBOBJS)
configure.in:391:AM_PATH_GTK(1.1.0,[FVWMGTK=FvwmGtk AC_SUBST(FVWMGTK)],)
configure.in:423:AC_SUBST(with_readline)
configure.in:424:AC_SUBST(with_rplay)
configure.in:425:AC_SUBST(with_stroke)
configure.in:426:AC_SUBST(with_xpm)
configure.in:427:AC_SUBST(with_gtk)
configure.in:428:AC_SUBST(with_gnome)
configure.in:429:AC_SUBST(with_sm)
configure.in:57:AC_SUBST(FVWM_IMAGEPATH)
configure.in:158: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:371: warning: AC_TRY_RUN called without default to allow cross compiling

XYX:sina:~> autoconf --version
Autoconf version 2.13

XYX:sina:~> automake --version
automake (GNU automake) 1.4

Copyright (C) 1999 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Written by Tom Tromey <[email-masked]>

On a Linux (RedHat 6.2) machine from a fresh checkout I get:

XYX:epithumia:~/a/fvwm> automake --add-missing
automake: configure.in: installing `./install-sh'
automake: configure.in: installing `./mkinstalldirs'
automake: configure.in: installing `./missing'
configure.in: 6: required file `./config.h.in' not found

XYX:epithumia:~/a/fvwm> autoreconf
ls: aclocal.m4: No such file or directory
configure.in: 6: required file `./config.h.in' not found
configure.in:158: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:371: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:401: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:158: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:371: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:401: warning: AC_TRY_RUN called without default to allow cross compiling

XYX:epithumia:~/a/fvwm> autoconf --version
Autoconf version 2.13

XYX:epithumia:~/a/fvwm> automake --version
automake (GNU automake) 1.4

Copyright (C) 1999 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Written by Tom Tromey <[email-masked]>

 - J<

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 21 Oct 2000 04:00:39 +0200

One note.

As I wrote recently, and it is now in cvs.html, the more correct order is
'autoreconf' and then 'automake -a', not vice versa, othervise you end up
with a Makefile without a 'ACLOCAL_M4 = $(top_srcdir)/aclocal.m4' line.

But this only affects dependances later, (configure is not regenerated
when acinclude.m4 is changed), not the initial generation of configure.

> aclocal: macro ` at /usr/local/bin/aclocal line 320, <CONFIGURE> line 6.

So, aclocal always fails to generate aclocal.m4 from acinclude.m4
on this machine for some unknown yet reason,

> configure.in:113:dnl AC_SUBST(sm_LIBS)

and configure then can't find macros, which should be in aclocal.m4.

Accourding to 'cvs log aclocal.m4', the file aclocal.m4 was in CVS until
1999/02/27 03:17:55, when Steve (rightfully) removed this autogenerated
file. This, together with an incorrect order of 'autoreconf' & 'automake'
some years ago, which caused a lossage of "configure <- acinclude.m4"
dependance, probably may somehow explain why you didn't have a need
earlier to ever invoke /usr/local/bin/aclocal. This is only my guess.

Am I right that you have perl 4 on the building system?
Can this be a reason for aclocal failure? I can't think of anything else.

If you will not be able to solve this aclocal problem, simply copy the up
to date aclocal.m4 file from your RH 6.2 machine. The correct thing would
be for a developement machine to be able to generate this file.

Regards,
Mikhael.