Subject: FvwmButtons patch

From: MURAKAMI Tomokazu <[email-masked]>
Date: Wed, 11 Oct 2000 18:33:43 +0900

I tried to compile fvwm CVS version with --enable-kanji option. But I
cannot compile FvwmButtons.c . So, I make patch. 

%diff -Ncr FvwmButtons.c FvwmButtons.c~
*** FvwmButtons.c	Wed Oct 11 18:02:18 2000
--- FvwmButtons.c~	Wed Oct 11 17:57:13 2000
***************
*** 136,141 ****
--- 136,143 ----
  Window MyWindow;
  char *MyName;
  static int screen;
+ char NoName[] = "Untitled";
+ 
  
  static int x_fd;
  static fd_set_size_t fd_width;
***************
*** 229,235 ****
            if (list)
  	    XFreeStringList(list);
            XFree(text.value); /* return of XGetWMName() */
!           if (XGetWMName(dpy, win, &text); /* XXX: read again ? */)
  	  {
  	    *winname = (char *)text.value;
  	  }
--- 231,237 ----
            if (list)
  	    XFreeStringList(list);
            XFree(text.value); /* return of XGetWMName() */
!           if (XGetWMName(dpy, win, &text) /* XXX: read again ? */)
  	  {
  	    *winname = (char *)text.value;
  	  }

-- 
   ┏━━━━━━━━━━━━━━━━━━━━━━┓
   ┃  村上 智一   ( TomOne )     福田研究室     ┠┐
   ┃  奈良先端科学技術大学院大学 情報科学研究科 ┃│
   ┃  E-Mail: [email-masked]       ┃│
   ┃  http://fukuda.aist-nara.ac.jp/~tomoka-m/  ┃│
   ┗┯━━━━━━━━━━━━━━━━━━━━━┛│
     └──────────────────────┘
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 11 Oct 2000 14:59:49 +0200

> cannot compile FvwmButtons.c . So, I make patch. 

I've applied the patch.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: MURAKAMI Tomokazu <[email-masked]>
Date: Thu, 12 Oct 2000 12:19:21 +0900

From: Dominik Vogt <[email-masked]>
Subject: Re: FvwmButtons patch
Date: Wed, 11 Oct 2000 14:59:49 +0200

> > cannot compile FvwmButtons.c . So, I make patch. 

I updated cvs. But FvwmButtons.c was old version. It didn't apply the
patch.

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 12 Oct 2000 05:42:44 +0200

> I updated cvs. But FvwmButtons.c was old version. It didn't apply the

Try now.

Regards,
Mikhael.

---

From: Tomokazu Murakami <[email-masked]>
Date: Thu, 12 Oct 2000 18:11:00 +0900

> I've applied the patch.

Now I tried cvs update. And, I look FvwmButtons.c.

However, it write
------------
            XFree(text.value); /* return of XGetWMName() */
            if (XGetWMName(dpy, win, &text)); /* XXX: read again ? */
          {
------------
in it.

But,
------------
            if (XGetWMName(dpy, win, &text)) /* XXX: read again ? */
------------
Should you describe it in this way?