Subject: XorValue

From: Olivier Chapuis <[email-masked]>
Date: Fri, 20 Oct 2000 07:28:49 +0200

Hello,
Recently, I try to use the XorValue command. The argument
of this command must be an integer which represent a color
in a not user friendly way: it seems to me that we have
to give the color relatively to the red, green, blue masks
(0xf800, 0x7e0, 0x1f in my machine) and the significant bits 
in color specification (6 bits in my machine).
One can imagine an algorithm to transform a color (in the usal
form) to such value (the Xlib can do that immediatly). My first
question is: Do such algorithm depands only on the significant bits 
in color specification? (i.e., do the red, green, blue masks
depends only on the significant bits? are they other paramaters to take
in account?). 
My second question is why we do not have a XorColor command? (as
"in" FvwmAnimate).

Olivier

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Fri, 20 Oct 2000 08:28:48 -0400

> depends only on the significant bits? are they other paramaters to take

This command  produces    different effects on   PseudoColor  displays
vs. True color.

On PseudoColor displays, the actual color being Xor'd has no relation
to the final color produced.  The color(s) on the background also contribute
to the random effect.

> My second question is why we do not have a XorColor command? (as

fvwm2 also has an XorPixmap command.

It would be nice if FvwmAnimate and fvwm were consistent.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]