Subject: mouse bindings

From: Brad Giaccio <[email-masked]>
Date: Thu, 12 Oct 2000 09:14:06 -0400

I'm guessing this is due to the current parse mods, but from this morning CVS October 12, I get the following error:

[FVWM][ParseBinding]: <<ERROR>> Illegal mouse button in line 4    A       C       Scroll +0 -100

[FVWM][ParseBinding]: <<ERROR>> Illegal mouse button in line 5    A       C       Scroll +0 +100

The related lines are
Mouse 4    A       C       Scroll +0 -100
Mouse 5    A       C       Scroll +0 +100

I have a logitech scroll mouse, and this binding would allow me to use
control + the scroll wheel to move up and down pages.

Honestlly I haven't used this feature much, I was just trying to come up
with some binding to use for those buttons.

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 12 Oct 2000 15:52:49 +0200

> Mouse 5    A       C       Scroll +0 +100

This started on 5 Oct. My binding is also censored now. :)

  Mouse 8 A A ...  # yes, it actually worked with 4 button+2 wheel mouse

I think the mouse number should not be checked as long as it is integer.
Or maybe NUMBER_OF_MOUSE_BUTTONS should be 10, will this affect something?

Note, it is possible to get big button numbers even with 3 button mice:

  xmodmap -e "pointer = 1 5 9"

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 12 Oct 2000 20:15:57 +0200

> Or maybe NUMBER_OF_MOUSE_BUTTONS should be 10, will this affect something?

X does not support more than 5 mouse buttons anyway.  This is
because there are no bits reserved in the button mask to select
and test button events for more than 5 buttons.  (X.h, look for
"Button1Mask" for example).

>   xmodmap -e "pointer = 1 5 9"

Well, this is easy to explain.  Fvwm never supported more than
three mouse buttons.  If bindings a la "Mouse 4" ever worked, this
was clearly a bug.  And there were many other places where this
failed (e.g. with MouseFocusClickRaises).  I cleaned up this mess
so that fvwm and all modules now work with the same number of
mouse buttons and enforced some sanity checks at the same time.
This is what happens now: the sanity checks complain about the
unsupported bindings.  It is no problem however to increase the
number of supported mouse buttons to 5 (in libs/defaults.h).  This
was the reason why I rewrote this anyway.  But there are some side
effects that may not be wanted:

 1) FvwmButtons will need more memory to store its bindings.
    There may be a few other modules with the same problem.
 2) A binding "Mouse 0 ..." will also grab the buttons 4 and 5.
    There may be configs which will break since they assume that
    buttons 4 and 5 are never grabbed.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]