Subject: Re: fvwm2.3.17 problems still in 2.3.21

From: Dominik Vogt <[email-masked]>
Date: Mon, 18 Sep 2000 13:40:22 +0200

On Sun, Sep 17, 2000 at 04:22:36PM -0700, Elliot Sowadsky wrote:
> 
> What's the proper way of specifying that i dont want -g in my build?
> I edited configure to say compiler cant do -g.
> Is there and "env" option?

You can either strip the executables after building fvwm:

  $ cd <installation directory>
  $ strip *
  (ignore error messages)

Or you can specify the compilation flags manually:

  $ make CFLAGS="O2"

O2 turns on optimization.  If you do not use gcc the flag
may be different.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 18 Sep 2000 12:29:13 +0200

> O2 turns on optimization.  If you do not use gcc the flag

There is a note about this in INSTALL.fvwm (worth reading), it suggests:

  make -k install-strip

The last section of this file should be redone. I can take a look later.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 18 Sep 2000 14:58:41 +0200

> The last section of this file should be redone. I can take a look later.

Ah, but didn't install-strip fail because it tries to strip
shell scripts?

Bye

Dominik ^_^  ^_^

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 25 Sep 2000 20:06:30 -0400

> Ah, but didn't install-strip fail because it tries to strip

Not that I've ever seen I've been doing make install-strip for over a
year, but the make -k says to ignore failures so even if it did try to
strip a script make would keep going.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]