Subject: Can't build fvwm2.3.20

From: Simon Nejadkashani <[email-masked]>
Date: Mon, 11 Sep 2000 22:40:58 -0700

Hi,

When compiling fvwm2.3.20 on a "SunOS 4.1.4 2 sun4m" machine, I got the
following errors. Do you have any idea what's causing it and how to get
around that?
To be sure I have attached the whole output starting from
'./configure'....

Thanks

-simon

wx19% make
make  all-recursive
Making all in libs
cd .. \
  && CONFIG_FILES=libs/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating libs/Makefile
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I..      -g -O2 -c Graphics.c
In file included from Graphics.c:20:
../libs/fvwmlib.h:196: parse error before `GetFontSetOrFixed'
../libs/fvwmlib.h:196: warning: data definition has no type or storage
class
*** Error code 1
make: Fatal error: Command failed for target `Graphics.o'
Current working directory /tmp_mnt/u/simon/gte/fvwm/fvwm-2.3.20/libs
*** Error code 1
make: Fatal error: Command failed for target `all-recursive'
Current working directory /tmp_mnt/u/simon/gte/fvwm/fvwm-2.3.20
*** Error code 1
make: Fatal error: Command failed for target `all-recursive-am'

Script started on Mon Jul 31 21:05:49 2000
wx19% ./configure
creating cache ./config.cache
checking for a BSD compatible install... /bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... missing
checking for working autoconf... missing
checking for working automake... missing
checking for working autoheader... missing
checking for working makeinfo... missing
checking whether to enable debugging messages... no
checking whether to enable multibyte character support (does not work yet)... no
checking whether to enable workaround for flickering windows during move... no
checking whether to enable modal dialogs for applications... yes
checking whether to enable shape extensions... yes
checking whether to enable GNOME window manager hints... no
checking imagepath... /usr/include/X11/bitmaps:/usr/include/X11/pixmaps
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking how to run the C preprocessor... gcc -E
checking for POSIXized ISC... no
checking for minix/config.h... no
checking for X... libraries /usr/lib/X11, headers 
checking for dnet_ntoa in -ldnet... no
checking for dnet_ntoa in -ldnet_stub... no
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... no
checking for XpmReadFileToXpmImage in -lXpm... no
checking for rplay_create in -lrplay... no
checking for stroke_init in -lstroke... no
checking with termcap... checking for readline in -lreadline... yes
checking for readline/history.h... no
checking with ncurses... checking for readline in -lreadline... no
checking for _Xsetlocale in -lX11... no
checking for stdarg.h... yes
checking for vfprintf... yes
checking for waitpid... yes
checking for cpp... /lib/cpp
checking for a BSD compatible install... /bin/install -c
checking whether ln -s works... yes
checking whether make sets ${MAKE}... (cached) yes
checking for ranlib... ranlib
checking for flex... no
checking for lex... lex
checking for flex... (cached) lex
checking for yywrap in -ll... yes
checking lex output file root... lex.yy
checking whether yytext is a pointer... no
checking for bison... no
checking for byacc... no
checking for perl... /usr/local/bin/perl
checking for perl 5.002 or better... no
configure: warning: /usr/local/bin/perl not found or too old
checking for ANSI C header files... no
checking for sys/wait.h that is POSIX.1 compatible... yes
checking for stdlib.h... yes
checking for fcntl.h... yes
checking for limits.h... yes
checking for malloc.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for unistd.h... yes
checking for getopt.h... no
checking for sys/select.h... no
checking for sys/systeminfo.h... no
checking for working const... yes
checking for inline... inline
checking for off_t... yes
checking for pid_t... yes
checking for size_t... yes
checking return type of signal handlers... void
checking for working alloca.h... yes
checking for alloca... yes
checking for strftime... yes
checking for gettimeofday... yes
checking for mkfifo... yes
checking for putenv... yes
checking for setvbuf... yes
checking for socket... yes
checking for waitpid... (cached) yes
checking for strdup... yes
checking for strstr... yes
checking for strtol... yes
checking for memmove... no
checking for memcpy... yes
checking for strchr... yes
checking for sysconf... yes
checking for uname... yes
checking for div... no
checking for sigaction... yes
checking for siginterrupt... yes
checking for getpwuid... yes
checking for sig_atomic_t... no
checking whether setvbuf arguments are reversed... no
checking for select... yes
checking for unistd.h... (cached) yes
checking for sys/types.h... yes
checking for sys/time.h... yes
checking for sys/select.h... (cached) no
checking for sys/socket.h... yes
checking argument types of select()... select(int,fd_set *,...)
checking for gethostname... yes
checking for strcasecmp... yes
checking for strncasecmp... yes
checking for strerror... no
checking for usleep... yes
checking for atexit... no
checking for on_exit... yes
checking for SmcOpenConnection in -lSM... no
checking for gtk-config... no
checking for GTK - version >= 1.1.0... no
*** The gtk-config script installed by GTK could not be found
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG environment variable to the
*** full path to gtk-config.
checking for imlib-config... no
checking for IMLIB - version >= 1.8.0... no
*** The imlib-config script installed by IMLIB could not be found
*** If IMLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the IMLIBCONF environment variable to the
*** full path to imlib-config.
updating cache ./config.cache
creating ./config.status
creating Makefile
creating libs/Makefile
creating fvwm/Makefile
creating modules/Makefile
creating utils/Makefile
creating utils/fvwm-config
creating utils/fvwm-menu-xlock
creating utils/fvwm-menu-directory
creating utils/fvwm-menu-desktop
creating utils/fvwm-menu-headlines
creating utils/fvwmbug.sh
creating docs/Makefile
creating sample.fvwmrc/Makefile
creating tests/Makefile
creating modules/FvwmAnimate/Makefile
creating modules/FvwmAuto/Makefile
creating modules/FvwmBacker/Makefile
creating modules/FvwmBanner/Makefile
creating modules/FvwmButtons/Makefile
creating modules/FvwmCommand/Makefile
creating modules/FvwmCommand/scripts/Makefile
creating modules/FvwmConsole/Makefile
creating modules/FvwmConsole/FvwmConsoleC.pl
creating modules/FvwmCpp/Makefile
creating modules/FvwmDebug/Makefile
creating modules/FvwmDragWell/Makefile
creating modules/FvwmEvent/Makefile
creating modules/FvwmForm/Makefile
creating modules/FvwmIconBox/Makefile
creating modules/FvwmIconMan/Makefile
creating modules/FvwmIdent/Makefile
creating modules/FvwmM4/Makefile
creating modules/FvwmPager/Makefile
creating modules/FvwmRearrange/Makefile
creating modules/FvwmSave/Makefile
creating modules/FvwmSaveDesk/Makefile
creating modules/FvwmScript/Makefile
creating modules/FvwmScript/Scripts/Makefile
creating modules/FvwmScript/Widgets/Makefile
creating modules/FvwmScroll/Makefile
creating modules/FvwmTaskBar/Makefile
creating modules/FvwmTheme/Makefile
creating modules/FvwmWharf/Makefile
creating modules/FvwmWinList/Makefile
creating modules/FvwmGtk/Makefile
creating config.h

Configuration:

  FVWM Version:                      2.3.20

  Have ReadLine support?             no
  Have RPlay support?                no
  Have Stroke support?               no
  Have XPM support?                  no: Xpm library or header not found!
  Have GTK support?                  no
  Have GNOME Window Manager support? no
  Have Session Management support?   no

wx19% 
wx19% 
wx19% 
wx19% make
make  all-recursive
Making all in libs
cd .. \
  && CONFIG_FILES=libs/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating libs/Makefile
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I..      -g -O2 -c Graphics.c
In file included from Graphics.c:20:
../libs/fvwmlib.h:196: parse error before `GetFontSetOrFixed'
../libs/fvwmlib.h:196: warning: data definition has no type or storage class
*** Error code 1
make: Fatal error: Command failed for target `Graphics.o'
Current working directory /tmp_mnt/u/simon/gte/fvwm/fvwm-2.3.20/libs
*** Error code 1
make: Fatal error: Command failed for target `all-recursive'
Current working directory /tmp_mnt/u/simon/gte/fvwm/fvwm-2.3.20
*** Error code 1
make: Fatal error: Command failed for target `all-recursive-am'
wx19% exit
wx19% 
script done on Mon Jul 31 21:08:54 2000

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 12 Sep 2000 23:24:00 +0200

> To be sure I have attached the whole output starting from

I think I have fixed this.  Please fetch the latest development
snapshot from http://fvwm.org and try again.  (look for the word
'snapshot' on our downloads page).  Please tell me if this fixes
your problem.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 15 Sep 2000 14:33:51 +0200

On Thu, Sep 14, 2000 at 09:58:44PM -0700, Simon Nejadkashani wrote:
> Dominik Vogt wrote:

> GetFontSet.c:32: parse error before `GetFontSetOrFixed'
> GetFontSet.c: In function `GetFontSetOrFixed':
> GetFontSet.c:34: `XFontSet' undeclared (first use in this function)
> GetFontSet.c:34: (Each undeclared identifier is reported only once
> GetFontSet.c:34: for each function it appears in.)
> GetFontSet.c:34: parse error before `fontset'
> GetFontSet.c:39: `fontset' undeclared (first use in this function)
> *** Error code 1
> make: Fatal error: Command failed for target `GetFontSet.o'
> Current working directory /tmp_mnt/u/simon/gte/fvwm/fvwm-snap-20000914/libs
> *** Error code 1
> Current working directory /tmp_mnt/u/simon/gte/fvwm/fvwm-snap-20000914
> *** Error code 1
> script done on Thu Sep 14 21:49:49 2000

Okay, I've applied another fix.  Tomorrow's snapshot should
pass this problem.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]