Subject: CVS migo: * module configuration now can be delimited by a colon and optional spaces

From: CVS <[email-masked]>
Date: Fri, 1 Sep 2000 18:39:53 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	migo	00/09/01 18:39:52

Modified files:
	.              : ChangeLog NEWS 
	fvwm           : functions.c fvwm2.1 modconf.c 
	                 module_interface.c module_interface.h 
	                 move_resize.c 

Log message:
* module configuration now can be delimited by a colon and optional spaces
* complex function parsing is now strict
* corrected rounding error in Move/Resize when using screen persentage
* several man page fixes

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 2 Sep 2000 01:58:53 +0200

> * module configuration now can be delimited by a colon and optional spaces

All three are equivalent now (except that the first allows conflicts):

  *FvwmIconBoxMaxIconSize 48x48
  *FvwmIconBox:MaxIconSize 48x48
  *FvwmIconBox: MaxIconSize 48x48

  DestroyModuleConfig FvwmTaskBarDeskOnly*
  DestroyModuleConfig FvwmTaskBar:DeskOnly*
  DestroyModuleConfig FvwmTaskBar:  DeskOnly*

Ideally the delimiter should be spaces only. But this can't be done now;
without a colon it would break existing configurations.

DestroyModuleConfig does not really support a new syntax yet, will do soon.

> * complex function parsing is now strict

'AddToFunc myfunc myarg' now gives an error rather than assuming myarg
function with "M" (Motion) specifier.

Does anyone else think that "I" (Immediate) specifier should be a default,
i.e. this command should be interpreted as 'AddToFunc I myfunc myarg'?

> * corrected rounding error in Move/Resize when using screen persentage

'Move w+1 w+1' and 'Move w-1 w-1' restore the original window geometry
rather than moving by 1 pixel.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 4 Sep 2000 17:54:46 +0200

> function with "M" (Motion) specifier.

Ah, good idea.

> i.e. this command should be interpreted as 'AddToFunc I myfunc myarg'?

No. I see no benefit in this additional syntax, it only makes
config files harder to understand.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]