Subject: Re: resizing maximized windows (PR#621)

From: Dominik Vogt <[email-masked]>
Date: Wed, 13 Sep 2000 17:15:53 -0500 (CDT)

This is no bug but exactly what was intended.  I could see this
exact "problem" too a while ago, but with gimp 1.1.18 it is gone.          
    I do not know how, but the gimp developers found a way to resize       
        the maximized window, so I recommend to simply upgrade your gimp   
            for now.  In the future we will probably implement some styles 
                specifically allowing or disallowing the program or the
user to                 move or resize windows. 
I do not know how, but the gimp developers found a way to resize           
    the maximized window, so I recommend to simply upgrade your gimp       
        for now.  In the future we will probably implement some styles     
            specifically allowing or disallowing the program or the user to
                move or resize windows. 
the maximized window, so I recommend to simply upgrade your gimp           
    for now.  In the future we will probably implement some styles         
        specifically allowing or disallowing the program or the user to    
            move or resize windows. 
for now.  In the future we will probably implement some styles             
    specifically allowing or disallowing the program or the user to        
        move or resize windows. 
specifically allowing or disallowing the program or the user to
move or resize windows.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Peter Daum <[email-masked]>
Date: Thu, 14 Sep 2000 09:29:00 +0200 (MEST)

Hi,

On Wed, 13 Sep 2000, Dominik Vogt wrote:

> for now.

Are you sure about that change in gimp? I am currently using
1.1.25 (which is the latest released version) and had tried most
of the preceeding versions (including 1.1.18) too - I couldn't
see any change with regard to that matter. (I had sent a bug
report to the gimp developers, but AFAIK, nobody addressed that
issue)

In the future we will probably implement some styles 
> user to move or resize windows. 

I personally am certainly eagerly waiting for this feature :-)

Is there maybe some simple patch to revert fvwm to the old
behavior?

Regards,
               Peter
-- 
                                             __o  
     Peter Daum <gator at cs.tu-berlin.de> _'\<_ 
       - pgp messages welcome -       ____(_)/(_)

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 14 Sep 2000 15:12:06 +0200

> report to the gimp developers, but AFAIK, nobody addressed that

Hm.  I've tried it again, and gimp does not even try to resize
the window in the conventional way by XResizeWindow() or
XMoveResizeWindow().  I don't know how it does this.  If it
tried that, fvwm would still prevent it.  Gimp does not use
GNOME hints either, so at the moment I have no idea how gimp
does it.

> Is there maybe some simple patch to revert fvwm to the old

The patch is simple:

Around line 1955 in events.c you will find this code:

    /* dont allow clients to resize maximized windows */
    if (!IS_MAXIMIZED(Tmp_win) || (!dw && !dh))
    {
      if (IS_SHADED(Tmp_win))
	get_shaded_geometry(Tmp_win, &new_g, &new_g);
      SetupFrame(
	Tmp_win, new_g.x, new_g.y, new_g.width, new_g.height, False);
    }

Simply remove the condition so that the code is executed
unconditionally:

    if (IS_SHADED(Tmp_win))
      get_shaded_geometry(Tmp_win, &new_g, &new_g);
    SetupFrame(
      Tmp_win, new_g.x, new_g.y, new_g.width, new_g.height, False);

This will do the trick.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Peter Daum <[email-masked]>
Date: Thu, 14 Sep 2000 16:23:21 +0200 (MEST)

Hi,

>       Tmp_win, new_g.x, new_g.y, new_g.width, new_g.height, False);

... and it did, indeed. 

Thanks a bunch :-)
                        Peter