Subject: CVS domivogt: * Fixed problem with RaiseLower/Lower on a ClickToFocus+ClickToFocusRaises

From: CVS <[email-masked]>
Date: Wed, 6 Sep 2000 15:11:02 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	00/09/06 15:11:01

Modified files:
	.              : ChangeLog 
	fvwm           : events.c fvwm.h stack.c window_flags.h 

Log message:
* Fixed problem with RaiseLower/Lower on a ClickToFocus+ClickToFocusRaises
window title that is not on top/bottom. Does this fix your problem, Brad?

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 6 Sep 2000 23:10:55 +0200

> window title that is not on top/bottom. Does this fix your problem, Brad?

Nice to see you back, Dominik.

Well, this seems to fix Raise/Lower command problems, but here is another
problem. Still there is a redudant Raise at the end of any non Raise
command when clicking on a border/title of ClickToFocusRaisesOff window.

  Style XCalc ClickToFocus, ClickToFocusRaisesOff
  Mouse 1 TSF S Menu MenuFvwmRoot
  Mouse 2 TSF S Move

Press Shift-Mouse1 or Shift-Mouse2 on a unfocussed (only) xcalc border or
title to reproduce this. This is the same bug as reported at the end of:

  http://www.hpc.uh.edu/fvwm/archive/0003/msg00269.html

but now it does a redudant Raise after a command, not before.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 7 Sep 2000 00:18:26 +0200

> Nice to see you back, Dominik.

I learned that there are much more unfulfilling things you can
do than developing fvwm :-)  Nice to see you again too.

> title to reproduce this.

Ah, yes.  Even back to 2.0.46, ClickToFocusRaisesOff only refered
to clicking in the client window.  You could not disable raising
when clicking on the decorations.  I wonder if this can safely be
changed or if people will start complaining.  Hm, probably this
will be not a good idea if people are using something like this:

  Style * ClickToFocus, ClickToFocusRaisesOff
  Mouse 1 t a MoveOrRaise
  AddToFunc MoveOrRaise
  + M Move
  + C Raise

But perhaps this is not a very common setup.  I will give
it a try, but if too many people complain I may reconsider.

[patch applied]

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 25 Sep 2000 07:56:51 -0400

Seems to have fixed it for the moment, but I'm sure now that I've said
that I will be plagued again.

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]