Subject: Problems building snap-20000906

From: Jason L Tibbitts III <[email-masked]>
Date: Wed, 6 Sep 2000 06:32:20 -0500 (CDT)

? fvwm-snap-20000125
? icons/Makefile.in
? icons/Makefile
? modules/FvwmAudio/Makefile.in
? modules/FvwmAudio/Makefile
? modules/FvwmAudio/.deps
? modules/FvwmAudio/FvwmAudio
? modules/FvwmScript/Scripts/some_nice_icons/Makefile.in
? modules/FvwmScript/Scripts/some_nice_icons/Makefile
cvs server: Updating .
P ChangeLog
P NEWS
cvs server: Updating archive
cvs server: Updating archive/automated_tests
cvs server: Updating archive/purify
cvs server: Updating docs
cvs server: Updating extras
cvs server: Updating extras/FvwmCommand
cvs server: Updating extras/FvwmCommand/scripts
cvs server: Updating extras/FvwmConfig
cvs server: Updating extras/FvwmConsole
cvs server: Updating extras/FvwmDebug
cvs server: Updating extras/FvwmGoodStuff
cvs server: Updating extras/FvwmPipe
cvs server: Updating extras/FvwmScript
cvs server: Updating extras/FvwmScript/Compiler
cvs server: Updating extras/FvwmScript/Scripts
cvs server: Updating extras/FvwmScript/Scripts/some_nice_icons
cvs server: Updating extras/FvwmScript/Widgets
cvs server: Updating extras/FvwmTaskBar
cvs server: Updating extras/FvwmWharf
cvs server: Updating extras/FvwmWharf/ASSound
cvs server: Updating extras/FvwmWharf/OffiX
cvs server: Updating extras/fvwmperl
cvs server: Updating extras/fvwmpython
cvs server: Updating extras/fvwmpython/Manual
cvs server: Updating fvwm
P fvwm/borders.c
P fvwm/builtins.c
P fvwm/conditional.c
P fvwm/events.c
P fvwm/focus.c
P fvwm/functions.c
P fvwm/functions.h
P fvwm/fvwm.c
P fvwm/fvwm.h
P fvwm/fvwm2.1
P fvwm/gnome.c
P fvwm/menus.c
P fvwm/misc.h
P fvwm/module_interface.c
P fvwm/move_resize.c
P fvwm/read.c
P fvwm/repeat.c
P fvwm/virtual.c
P fvwm/windowlist.c
cvs server: Updating icons
cvs server: Updating libs
cvs server: Updating modules
cvs server: Updating modules/FvwmAnimate
cvs server: Updating modules/FvwmAudio
cvs server: Updating modules/FvwmAuto
cvs server: Updating modules/FvwmBacker
cvs server: Updating modules/FvwmBanner
cvs server: Updating modules/FvwmButtons
cvs server: Updating modules/FvwmCascade
cvs server: Updating modules/FvwmCommand
cvs server: Updating modules/FvwmCommand/scripts
cvs server: Updating modules/FvwmConsole
cvs server: Updating modules/FvwmCpp
cvs server: Updating modules/FvwmDebug
cvs server: Updating modules/FvwmDragWell
cvs server: Updating modules/FvwmEvent
cvs server: Updating modules/FvwmForm
cvs server: Updating modules/FvwmGtk
cvs server: Updating modules/FvwmIconBox
cvs server: Updating modules/FvwmIconMan
cvs server: Updating modules/FvwmIdent
cvs server: Updating modules/FvwmM4
cvs server: Updating modules/FvwmPager
cvs server: Updating modules/FvwmRearrange
cvs server: Updating modules/FvwmSave
cvs server: Updating modules/FvwmSaveDesk
cvs server: Updating modules/FvwmSaveDesk/example
cvs server: Updating modules/FvwmScript
cvs server: Updating modules/FvwmScript/Scripts
cvs server: Updating modules/FvwmScript/Scripts/some_nice_icons
cvs server: Updating modules/FvwmScript/Widgets
cvs server: Updating modules/FvwmScroll
cvs server: Updating modules/FvwmTalk
cvs server: Updating modules/FvwmTaskBar
cvs server: Updating modules/FvwmTheme
cvs server: Updating modules/FvwmTile
cvs server: Updating modules/FvwmWharf
cvs server: Updating modules/FvwmWharf/ASSound
cvs server: Updating modules/FvwmWharf/OffiX
cvs server: Updating modules/FvwmWinList
cvs server: Updating modules/OLDFvwmWinList
cvs server: Updating sample.fvwmrc
cvs server: Updating sample.fvwmrc/BradyMontz
cvs server: Updating sample.fvwmrc/BradyMontz/bin
cvs server: Updating sample.fvwmrc/BradyMontz/icons
cvs server: Updating sample.fvwmrc/BradyMontz/icons/src
cvs server: Updating sample.fvwmrc/BradyMontz/roots
cvs server: Updating sample.fvwmrc/BradyMontz/src
cvs server: Updating sample.fvwmrc/BradyMontz/src/xpaste-1.1
cvs server: Updating tests
cvs server: Updating tests/purify
cvs server: Updating textures
cvs server: Updating utils
cvs server: Updating vms
cvs server: Updating xpmroot
Autoconf requires GNU m4 1.1 or later
Autoconf requires GNU m4 1.1 or later
Makefile.am:7: required directory ./utils does not exist
Makefile.am:7: required directory ./docs does not exist
Makefile.am:7: required directory ./sample.fvwmrc does not exist
Makefile.am:7: required directory ./tests does not exist
modules/Makefile.am:3: required directory modules/FvwmIdent does not exist
modules/Makefile.am:3: required directory modules/FvwmM4 does not exist
modules/Makefile.am:3: required directory modules/FvwmPager does not exist
modules/Makefile.am:3: required directory modules/FvwmRearrange does not exist
modules/Makefile.am:3: required directory modules/FvwmSave does not exist
modules/Makefile.am:3: required directory modules/FvwmSaveDesk does not exist
modules/Makefile.am:3: required directory modules/FvwmScript does not exist
modules/Makefile.am:3: required directory modules/FvwmScroll does not exist
modules/Makefile.am:3: required directory modules/FvwmTaskBar does not exist
modules/Makefile.am:3: required directory modules/FvwmTheme does not exist
modules/Makefile.am:3: required directory modules/FvwmWharf does not exist
modules/Makefile.am:3: required directory modules/FvwmWinList does not exist
Autoconf requires GNU m4 1.1 or later
Autoconf requires GNU m4 1.1 or later
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 6 Sep 2000 17:48:03 +0200

On 06 Sep 2000 06:32:20 -0500, Jason L Tibbitts III wrote:
[skipped]

I just did a fresh checkout in a new directory and everything worked as
expected. So I suppose the problem is either in system tools or a local
cvs copy is screwed (maybe due to a bug in cvs, I can only guess).

Jason, I suggest you to manually remove the existing fvwm hierarhy
completely and do a fresh checkout. This is good anyway, since your old
hierarchy contains obsolete files (marked by '?'). Then do all steps
described in cvs.html, if the system is ok, everything should work. :-)

I also suggest you to use 'cvs -q update', not 'cvs update'. The big part
of the log output is garbage, which makes it harder to see a real problem.

Regards,
Mikhael.