Subject: Re: fvwm2.3.17 problems still in 2.3.21

From: Elliot Sowadsky <[email-masked]>
Date: Mon, 4 Sep 2000 16:37:43 -0700 (PDT)

<<
Clicking on another window has ambiguous change of focus.
This started w/ 2.3.17

Normally, in xview, a black focal point indicates that window has focus.
A grey point indicates where the focal point is, but window doesnt actually have the focus.

In 2.3.21, the first click removes focus from the previous window (leaving a
grey focal point) and sets a grey focal point in new window, leading me to
believe it doesnt have focus yet. At that point, i cant actually tell which
window has it till i start typing.

A 2nd click in the window will result in the black type-in point.
This problem didnt exist in 2.3.16.

more info...

Above is w/ Lenience on.
Get same behavior in 2.3.16.

W/ Lenience off (which is how ive been running 2.3.16), in 2.3.21 it actually takes 2 clicks to move focus to another window.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 5 Sep 2000 20:47:36 +0200

> W/ Lenience off (which is how ive been running 2.3.16), in 2.3.21 it actually takes 2 clicks to move focus to another window.

Okay, I understand why this is happening now (without lenience):

 a) xview applications explicitly ask to be never given focus
    by the window manager.
 b) With any focus policy but NeverFocus, fvwm asks the
    application to take the focus itself. The Application
    does not get the first click because fvwm intercepts it
    (CLickToFocus and/or MouseFocusClickRaises styles).
 c) The application simply refuses to take the focus.
    
The correct solution in this case is to use NeverFocus and
NoLenience styles for the window.  The application takes care
of the focus itself then.

The Lenience style does not work because of (c).  Xview
applications simply do not want to listen to the window
manager's hints.  The correct thing for fvwm to do is
to treat such windows as if they had the NeverFocus
style set.

I'll commit a patch that tries to improve the general
situation a bit, but I still recommend using "NeverFocus, NoLenience"
for these windows.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 15 Sep 2000 23:53:32 +0200

> W/ Lenience off (which is how ive been running 2.3.16), in 2.3.21 it actually takes 2 clicks to move focus to another window.

I think I finally fixed all the focus problems bugs w/ xview
applications.  Everything works fine with any focus policy
for me.  I can't address the mailtool problem though since
I don't have a Linux version (if there is any).

Bye

Dominik ^_^  ^_^