Subject: Notification: incoming/652

From: [email-masked]
Date: Sun, 10 Sep 2000 09:55:58 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/652

Message summary for PR#652
	From: [email-masked]
	Subject: xmms ain't sticky anymore
	Date: Sun, 10 Sep 2000 09:55:57 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 12 Sep 2000 23:15:46 +0200

On Sun, Sep 10, 2000 at 09:55:58AM -0500, [email-masked] wrote:
> Message-Id: <[email-masked]>
> To: [email-masked]
> Full_Name: Harald Dunkel
> Version: fvwm-snap-20000910
> CVS_Date: 
> OS: Linux 2.4.0-test6
> X_Server: XFree86 3.3.6
> Submission from: (NULL) (212.121.155.45)
> 
> 
> Hi folks,
> 
> xmms windows ain't sticky anymore. This problem must have been
> introduced after 2.3.21. My .fvwm2rc file says
> 
> 	Style "xmms"	WindowListSkip, Sticky
> 	Style "XMMS*"	WindowListSkip, Sticky
> 
> The WindowListSkip attribute seems to work. The second line
> should be obsolete, anyway, cause the class name of all
> xmms windows is 'xmms'.
> 
> The xmms version is xmms-1.2.2, installed on July 30th.

It is the fault of xmms.  After startup, xmms explicitly asks not
to be sticky by using the GNOME hints.  Fvwm honours this request,
but if you 'recapture' the window, xmms will not notice that it
has become sticky now.  The reason why this problem appeared now
is that the default has been changed to compile in GNOME support
into fvwm by default.  If you want the old behaviour you can
compile fvwm without GNOME support:

  $ ./configure --disable-gnome
  $ make
  $ make install

Please send a bug report to the xmms developers.  The application
definitely should not try to override the preferences of the
window manager's user.  xmms does not handle stickyness of its
windows, so it really should not touch this setting.  There are
a lot of GNOME compliant window managers that xmms will not
cooperate with nicely.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]