Subject: Notification: incoming/648

From: [email-masked]
Date: Wed, 6 Sep 2000 17:13:10 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/648

Message summary for PR#648
	From: [email-masked]
	Subject: Configure can't find readline library
	Date: Wed, 6 Sep 2000 17:13:09 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 7 Sep 2000 01:24:56 +0200

On 06 Sep 2000 17:13:10 -0500, [email-masked] wrote:
> Full_Name: Bryan Henderson

> Configure cannot find my readline library.  I specify 
> --with-readline-library, but in its trial compilation with
> ncurses, Configure does not include the --with-readline-library
> value in the gcc command.  It does, however, correctly include it in 
> the readline/termcap trial compilation.  I circumvent this bug by
> setting the LDFLAGS environment variable.

Ok, I see this problem. I will fix it later and submit to you for testing.
About your next bug report #649, I think, I can add --with-library-path
or similar, so one could specify ncurses and/or termcap dir using it.

> By the way, I applaud the way Configure tells me at the end what
> features it isn't using because it couldn't find them on my system.
> Most Configures just silently omit the features and I find out 
> much later, at run time, after a lot of debugging, that there was a 
> problem at Configure time.

Yes, really useful.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 19 Sep 2000 18:59:43 +0200

> or similar, so one could specify ncurses and/or termcap dir using it.

I rewrote readline/termcap/ncurses detection code once again.
There are now --with-termcap-library and --with-ncurses-library
options. It is now possible to specify something like:
  --without-termcap-library --with-ncurses-library=/path/to/libdir-or-lib

Just to understand better how it works, --with-termcap-library=no and
--with-ncurses-library=no are equavalent to --with-readline-library=no.

Please get a daily snapshot and check how configure works for you now.

Regards,
Mikhael.