Subject: CVS dane: * Makefile.am (fvwm24_convert): Rules to build fvwm24_convert.

From: CVS <[email-masked]>
Date: Sun, 24 Sep 2000 16:00:45 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	dane	00/09/24 16:00:45

Modified files:
	utils          : ChangeLog Makefile.am fvwm24_convert.in 

Log message:
* Makefile.am (fvwm24_convert): Rules to build fvwm24_convert.
* fvwm24_convert.in: Works for me.  Docs next.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 27 Sep 2000 11:36:19 +0200

> * fvwm24_convert.in: Works for me.  Docs next.

Here are several bugs, which I experienced trying to convert someone
else's config, and suggestions. I have no time to fix these now.

The script handles incorrectly the commands in function, i.e.
  AddToFunc func-name I WindowFont fixed
  + I WindowFont fixed
  Key F1 A SC WindowFont fixed

HilightColor can accept a space delimiter, not only a slash delimiter.

PixmapPath/IconPath delete dirs starting with $VAR.

Also, I think, it is preferable not to delete potentially useful commands,
like ColorLimit and ModulePath, but comment them in with a note who
commented them and why. But this is not very important.

Probably, the script could print suggestion to convert all found Read'd
files if any.

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Thu, 28 Sep 2000 09:03:30 -0400

>   Key F1 A SC WindowFont fixed

For now, I've documented this as a bug.

> HilightColor can accept a space delimiter, not only a slash delimiter.

Fixed.

> PixmapPath/IconPath delete dirs starting with $VAR.

I'd like to expand the var and check it against the builtins.
I think I have to change this to perl or some other language.
For now, I've documented the behavior.

> commented them and why. But this is not very important.

Done.

> Probably, the script could print suggestion to convert all found Read'd

Yep.  I didn't like the way fvwmrc_convert did message printing.
(With $TTY.)  Another reason to convert this to perl, or maybe its just
my unfamiliarity with awk.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 29 Sep 2000 02:10:45 +0200

On 28 Sep 2000 09:03:30 -0400, Dan Espen wrote:
> 
> Another reason to convert this to perl, or maybe its just my
> unfamiliarity with awk.

Agree, probably awk is not powerful enough to help with all cases,
although there are not many.

Regards,
Mikhael.