Subject: [[email-masked]: Re: Can't build fvwm2.3.20]

From: Dominik Vogt <[email-masked]>
Date: Mon, 18 Sep 2000 13:46:54 +0200

> Okay, I've applied another fix.  Tomorrow's snapshot should
> pass this problem.
> 

Got further. But didn't compiled completely..... See attached

Script started on Sun Sep 17 22:57:24 2000
...

Configuration:

  FVWM Version:                      2.3.22

  Have ReadLine support?             no
  Have RPlay support?                no
  Have Stroke support?               no
  Have XPM support?                  no: Xpm library or header not found!
  Have GTK support?                  no
  Have GNOME Window Manager support? yes
  Have Session Management support?   no
  Have GNOME support in FvwmGtk?     no

...
Making all in fvwm
cd .. \
  && CONFIG_FILES=fvwm/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating fvwm/Makefile
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs            -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.3.22\"  -DFVWM_DATADIR=\"/usr/local/share/fvwm\"        -DFVWM_CONFDIR=\"/usr/local/etc\" -g -O2 -c menus.c
menus.c: In function `menuShortcuts':
menus.c:1045: `XK_Page_Up' undeclared (first use in this function)
menus.c:1045: (Each undeclared identifier is reported only once
menus.c:1045: for each function it appears in.)
menus.c:1051: `XK_Page_Down' undeclared (first use in this function)

*** Error code 1
make: Fatal error: Command failed for target `menus.o'
Current working directory /tmp_mnt/u/simon/gte/fvwm/fvwm-snap-20000917/fvwm
*** Error code 1
make: Fatal error: Command failed for target `all-recursive'
Current working directory /tmp_mnt/u/simon/gte/fvwm/fvwm-snap-20000917
*** Error code 1
make: Fatal error: Command failed for target `all-recursive-am'
wx19%
script done on Sun Sep 17 23:02:50 2000

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 18 Sep 2000 13:58:47 +0200

> script done on Sun Sep 17 23:02:50 2000

Well, this looks as if you do not have installed the X header
files.  Symbols like XK_Page_Up *must* be defined to compile
fvwm.  Perhaps someone who knows Ultrix better than I can give
you some hints here.

Bye

Dominik ^_^  ^_^

P.S.: Please always cc [email-masked] in your replies.