Subject: Keyboard mappings -- strange...

From: "Tim Freedom" <[email-masked]>
Date: Mon, 14 Aug 2000 10:34:19 PDT

I'm having alot of strange problems with my key mappings which don't appear 
on any of my other systems.  Both the Ctrl-Lock and the Num-Lock are off 
(disabled) and I tried toggling them just in case too (so it ain't them :-)

I have the following in my .fvwm2rc file

DeskTopSize 3 3

Key KP_Decimal  A       C       Prev [ CurrentPage !iconic] FlipFocus
Key KP_0        A       C       Prev [!CurrentPage !iconic] FlipFocus
Key KP_1        A       C       GotoPage 0 2
Key KP_2        A       C       GotoPage 1 2
Key KP_3        A       C       GotoPage 2 2
Key KP_4        A       C       GotoPage 0 1
Key KP_5        A       C       GotoPage 1 1
Key KP_6        A       C       GotoPage 2 1
Key KP_7        A       C       GotoPage 0 0
Key KP_8        A       C       GotoPage 1 0
Key KP_9        A       C       GotoPage 2 0

Key KP_7        A       M       WarpToWindow 50p 50p

Key Left        A       C       Scroll -100 +0
Key Right       A       C       Scroll +100 +0
Key Up          A       C       Scroll +0   -100
Key Down        A       C       Scroll +0   +100

This is what's happening.
Ctrl-7, Ctrl-4, Ctrl-5, Ctrl-6, and Ctrl-1 all work properly.
Ctrl-8, Ctrl-9, Ctrl-2 and Ctrl-3 do NOT for some reason (why ?????).

As for the arrow keys, the up and down don't seem to do anything at all.  
The left and right function as though they are 'GotoPage 0 1' and 'GotoPage 
2 1' respectively.  Again, Why ??????

Besides that my Meta (or Alt -- Diamond key on Sun's keyboard) doesn't work 
unless I'm using Emacs or Netscape.  In Fvwm it doesn't seem to have any 
affect.

Could someone please tell me what I'm doing wrong.  As noted, this all works 
on my linux box and on the previous Ultra-5 that I had (different OS 
though).

uname -a:       SunOS klepto 5.7 Generic_106541-10 sun4u
fvwm version:   fvwm-snap-20000809 (with xpm support)

Thanks for the help in advance.

+ Tim

________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 19 Aug 2000 19:44:16 +0300

> I have the following in my .fvwm2rc file
[...]
> 2 1' respectively.  Again, Why ??????

I am not familar much with sun keyboards, so probably there is a sun
specific solution here, but generally this is probably a X Server related
problem, not fvwm's. Try to run xev(1) and see whether KP_9 is really
generated when you press 9 (with or without Ctrl). You can use xmodmap(1)
to alter mappings.

> unless I'm using Emacs or Netscape.  In Fvwm it doesn't seem to have any 

Again, xev can answer what this key generates.

> fvwm version:   fvwm-snap-20000809 (with xpm support)

Regards,
Mikhael.