Subject: Re: FVWM: StrokeWidth patch

From: Dan Espen <[email-masked]>
Date: Fri, 11 Aug 2000 20:01:14 -0400

Olivier Chapuis <[email-masked]> writes:
> Johannes Zellner wrote:
> > 
> > Here's the patch which I forgot to attach at the fvwm list.
> > 
> > I hacked a variable StrokeWidth. The patch is attached
> > and contains also an update of the docs. Try:
> > 
> >     Mouse 3 A M StrokeFunc StrokeWidth 10 DrawMotion
> > 
> > I've also changed the allocation of the coordinate
> > array (for undrawing) to be dynamical, so that strokes
> > of arbitrary length (depends on your memory) can be drawn.
> > 
> > Well, I've been told it's a feature freeze ...
> > At least I consider the dynamical allocation for the
> > strokes a bug fix :-)
> 
> 
> Ok, I try the patch it works find (need just one change for
> using the fvwm libs malloc).
> I suggest to apply it. We may consider that it is a bug fix 
> patch (1 pixel line for the motion is not enought under certain
> config).
> 
> Some objections ?

I must be unsubscribed again, I haven't seen anything on fvwm-workers
for almost 2 weeks?

I guess I'll find out when this reply comes thru.

>From my viewpoint there don't appear to be any objections.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Jason L Tibbitts III <[email-masked]>
Date: 11 Aug 2000 21:51:33 -0500

>>>>> "DE" == Dan Espen <[email-masked]> writes:

DE> I must be unsubscribed again, I haven't seen anything on fvwm-workers
DE> for almost 2 weeks?

I only remove addresses that bounce for a really long time.  The software
will never automatically unsubscribe anyone.

I think the list has just been quiet.

 - J<

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 12 Aug 2000 12:49:32 +0300

> patch (1 pixel line for the motion is not enought under certain

I think it is good to apply it. This small feature/fix affects only ones
who have libstroke installed and use stroke.

There is a related bug, which is shown when stroke is drawn over window
titles. The visual effect is instead of the absolute title_w coordinates,
relative ones are used, i.e. stroke jumps when goes through any title.
The code is in 'case MotionNotify:' of strokeFunc, but I don't know what
the fix should be.

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Sun, 13 Aug 2000 09:07:44 +0200

> who have libstroke installed and use stroke.

I will commit the patch soon.
 
> The code is in 'case MotionNotify:' of strokeFunc, but I don't know what

I have noted this too but I don't know how to fix this. This maybe need 
an X expert.

Olivier