Subject: re: fvwm2.3.17-20 bugs

From: Elliot Sowadsky <[email-masked]>
Date: Fri, 7 Jul 2000 13:48:53 -0700 (PDT)

< From [email-masked] Fri Jul  7 12:08:47 2000
< Date: Fri, 7 Jul 2000 12:12:02 -0700
< From: Michael Han <[email-masked]>
< To: Elliot Sowadsky <elliot>
< Cc: [email-masked]
< Subject: re: fvwm2.3.17-20 bugs
< Content-Disposition: inline
< User-Agent: Mutt/1.2i
< In-Reply-To: <[email-masked]>; from [email-masked] on Thu, Jul 06, 2000 at 03:13:38PM -0700
< 
< On Thu, Jul 06, 2000 at 03:13:38PM -0700, Elliot Sowadsky wrote:
< > These worked on 2.3.16 but broke after that.
< >
< > ClickToFocus mode
< > Must click twice into a window for it to get focus.
< > Styles ClickToFocusDoesntPassClick/ClickToFocusPassesClick have same
< > behavior.
< >
< > (xview) mailtool up/down arrows no longer work in header window.
< > It'll do something on the 1st arrow key hit....then ignored.
< 
< > -----------
< >
< > mouse over root takes away focus for ClickToFocus
< >
< > This bug has always been broken, but a patch exists and is only half
< > implemented.
< >
< > the missing patch to events.c ...
< >
< > change the appropriate line to add the NumberOfScreens check.
< >
< > if (ewp->window == Scr.Root && Scr.NumberOfScreens > 1)
< 
< I use a similar config (WRT focus policy) and am up-to-date from CVS.
< I haven't ever experienced the problems you report. Could you forward
< your config for further examination? Can you reproduce the problem
< with a very minimal config? I'm wondering whether you maybe use
< FvwmAuto or FvwmEvent or something too.

After much playing around w/ .fvwmrc, i figured out the culprit.

xterm must be running.

2.3.17 and up requires an xterm to be running for these bugs not to happen.

I normally dont run xterm.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Michael Han <[email-masked]>
Date: Fri, 7 Jul 2000 19:25:39 -0700

> < > It'll do something on the 1st arrow key hit....then ignored.
 
Hmm, my config runs fine without xterms. My circulate function is
almost identical to yours, so I'm curious what else I might do to
reproduce the problem you're having. I have no unusual problems with
focus, and haven't had anything major like this since some very bad
betas.
-- 
[email-masked]                            http://www.mikehan.com/
coffee achiever                              San Francisco, California
"'Why is that toy on your head?' 'Because if I wear it anywhere else,
it chafes.'" - Chris Knight
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]