Subject: Re: bug list #3 (general bugs)

From: Dominik Vogt <[email-masked]>
Date: Tue, 4 Jul 2000 11:28:14 +0200

On Wed, Jun 07, 2000 at 12:27:37AM +0200, Dominik Vogt wrote:
> On Mon, Jun 05, 2000 at 07:35:30PM +0300, Mikhael Goikhman wrote:
> > Originally this list was longer, but Dominik already took a look at it. ;)
> 
> > 2) Opaque Move when draging on border edges and moving in the same to the
> >    edge direction jumps by 2 points. If dragging on another border place
> >    (somewhere in the center) or in opposite direction, the move is smooth.
> >    How to reproduce. Drag on rightmost edge of the right border and move
> >    to right; or on leftmost edge of the right border and move to left.
>  
> I don't see any jerky movement.  Let's make sure I understand this
> right.  You mean *moving* windows, not *resizing*, right?  And of course
> you don't use SnapGrid or SnapAttraction.  If both is true, can you
> make another minimal config and give me some picture that describes
> what you mean?

Mikhael, I never got a reply from you on this one, but if I remember
correctly Tim said something about backing store.  If this problem is
of any relevance, please try if backing store helps (either enable it
for individual windows or the X server or both).

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 4 Jul 2000 15:52:26 +0300

> for individual windows or the X server or both).

I don't think it can be related to backing store, it is a +1/-1 issue.
You can find my answer in this thread (you even answered that message), or
  http://www.hpc.uh.edu/fvwm/archive/0006/msg00099.html

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 4 Jul 2000 18:34:06 +0200

>   http://www.hpc.uh.edu/fvwm/archive/0006/msg00099.html

Oops, wrong bug. The bug with jerky movement was about flickering
titles. Anyway, any new information on the one quoted above? I can't
reproduce it.

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 5 Jul 2000 10:57:46 +0200

On Tue, Jul 04, 2000 at 11:23:27PM +0300, Mikhael Goikhman wrote:
> On 04 Jul 2000 18:34:06 +0200, Dominik Vogt wrote:
> > 
> > Anyway, any new information on the one quoted above? I can't
> > reproduce it.
> 
> As I said I can reproduce it with any config; the minimal file:
> 
>   OpaqueMoveSize 100
>   Mouse 2 STF A Move
> 
> Here is a window with BorderWidth 7:
> 
>   .......--------------F-------------.......
>   .......----------------------------.......
>   .......----------------------------.......
>   .......----------------------------.......
>   .......----------------------------.......
>   .......----------------------------.......
>   .......-------------E--------------.......
>   |||||||                            |||||||
>   |||||||                            |||||||
>   A||||||                            C||||||
>   ||||||B                            ||||||D
>   |||||||                            |||||||
>   |||||||                            |||||||
>   .......--------------H-------------.......
>   .......----------------------------.......
>   .......----------------------------.......
>   .......--------------------O-------.......
>   .......----------------------------.......
>   .......----------------------------.......
>   .......-------------G--------------.......
> 
> Now, drag the window in points A or C (be very accurate) and start move to
> the left, or drag in points B or D and start move to the right, or drag in
> points F or H and start move up, or for E or G - down.

Hm, exactly as I had understood it.  But it isn't jerky at all
on my machine.  The only thing that is not smooth is my mouse
movement (because it's so fast).

> If you drag anywhere else (O) or move to opposite direction, window move
> follows cursor move; in the cases above it jumps in at least 2 pixels.
> I would have had to solve this myself. Maybe later if you don't fix it.

Well, doesn't sound exactly like a show stopper for 2.4 :-)

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]