Subject: Notification: incoming/627

From: [email-masked]
Date: Thu, 8 Jun 2000 15:17:22 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/627

Message summary for PR#627
	From: [email-masked]
	Subject: MoveToPage - sometimes to the left
	Date: Thu, 8 Jun 2000 15:17:20 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 11 Jun 2000 16:58:28 +0200

On Thu, Jun 08, 2000 at 03:17:22PM -0500, [email-masked] wrote:
> >From [email-masked]  Thu Jun  8 15:17:21 2000
> Received: from localhost (localhost [127.0.0.1])
> 	by larry.math.uh.edu (8.9.1/8.9.1) with ESMTP id PAA25804
> 	for <[email-masked]>; Thu, 8 Jun 2000 15:17:20 -0500 (CDT)
> Message-Id: <[email-masked]>
> To: [email-masked]
> Full_Name: 
> Version: 2.2.2 and 2.2.4
> CVS_Date: not using
> OS: Linux 2.2.14 (Redhat 6.1)
> X_Server: Xfree86
> Submission from: (NULL) (131.225.84.23)
> 
> 
> DeskTopSize 2x2
> *FvwmPagerColumns 1
> *FvwmPagerLabel 0 MISC.
> *FvwmPagerLabel 1 SDSS
> *FvwmPagerLabel 2 MONITOR
> *FvwmPagerLabel 3 Mail/b
> *FvwmPagerLabel 4 WWW
> *FvwmPagerLabel 5 LINUX
> 
> *FvwmBackerDesk 5 Desk5Function
> AddToFunc Desk5Function
>   +  "I" Next [emacs*] MoveToDesk
>   +  "I" Next [emacs*] MoveToPage
>   +  "I" Next [emacs* !Sticky] Stick
> 
> 
> OK, heres the problem:
> If the [emacs*] window starts in a left page of any other desk and
> I move to one of the right side windows of desk 5, the MoveToPage
> does not seem to work. But, if the [emacs*] window starts in the right
> half of any other desk, the MoveToPage command does work.

This is already fixed in the current beta versions (please try it
and tell me if it still happens).

> The "Sticky" line doen't really matter, but just to let you know,
> what I'm trying to implement is a "StickyOnDesk" type of style.

You should *definitely* write patches for the latest development
code (or download the last beta).  Otherwise chances are good that
we are unable to apply the patch because the differences between
the betas and the stable version are big.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Ronald Rechenmacher <[email-masked]>
Date: Mon, 12 Jun 2000 13:13:41 -0500

Hi Dominik,

The particular MoveToPage bug I reported appears to be fixed in v2_3_19 but 
there appears to be a couple additional problems:

   1. when I move from one desk to another, unstick a window and move it to 
the desk I just came from, it does not show up on the pager window.

   2. when I bring a window to the front, the representation on the pager 
window does not get updated.

   3. using the key definitions:

key u           A       SC	Desk -1
key d           A       SC	Desk 1

when I go invoke either the pager window disappears. It will sometimes 
reappear after some undetermined number of repeated operations of one of the 
keys.

--Ron

---

From: Ronald Rechenmacher <[email-masked]>
Date: Mon, 12 Jun 2000 13:33:05 -0500

Hi again,

  2 additional items:

   1. pager window size on startup is inconsistant.  I've tried specifying the 
size with both (one at a time):
    *FvwmPagerGeometry x630-1-1
  and
    *FvwmPagerDeskTopScale 95

   2. I keep getting (output on window fvwm2 was started on):
    [FVWM][ExecuteFunction]: <<ERROR>> No such command 'UNLOCK'

---

From: Ronald Rechenmacher <[email-masked]>
Date: Mon, 12 Jun 2000 13:38:03 -0500

Hi again, again, (more potential clues)

   With regard to the MoveToPage not showing up in the pager window (item 1. 
in my first response), the window does show up *if* there are no other window 
on the desk it was moved to.

Hope this helps,
Ron

---

From: Dan Espen <[email-masked]>
Date: Mon, 12 Jun 2000 14:55:45 -0400

>     [FVWM][ExecuteFunction]: <<ERROR>> No such command 'UNLOCK'

A sure sign that you are running old modules with a newer version
of fvwm.   Check your PATH and ModulePath.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Ronald Rechenmacher <[email-masked]>
Date: Mon, 12 Jun 2000 15:08:33 -0500

[email-masked] said:
> A sure sign that you are running old modules with a newer version of
> fvwm.   Check your PATH and ModulePath. 

OK, Sorry! But now (using the correct modules) there are different errors:
   1. There is still a MoveToPage problem: *sometimes* the MoveToPage commands 
with no options moves the page to an invalid desk. I have 6 desks configured:
When I goto desk 5 (the 6th/last) desk, sometimes the selected window shows up 
correctly and sometimes it is moved to the 7th desk based on the window list 
display.
   2. Sometimes when I goto a new desk (via clicking on the desk in the pager 
window), the pager window disappears. It will sometimes reappear when I scroll 
%100 to a different page with the same desk. The pager window always 
disappears when I use the "key stroke Desk command binding".

Sorry again about the wrong modules.

--Ron

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 13 Jun 2000 02:24:42 +0200

> correctly and sometimes it is moved to the 7th desk based on the window list 

I don't understand what you want to say.  You seem to use
'MoveToPage', 'GotoPage', 'GotoDesk' and flipping desks or
pages in the pager all synonymously, so I can't make out
what you're actually doing.

  MoveToPage - moves a window to another *page*
  MoveToDesk - moves a window to another *desk*
  GotoPage   - moves the viewport to another page
  GotoDesk   - moves the viewport to another desk
  Desk       - obsolete, use GotoDesk instead

The pager does a combination of GotoDesk and GotoPage when
you click on it.  From what you write I guess you have the
correct idea of pages and desks.  Can you please describe
exactly (step by step) what you do, what you expect to happen
and what acually happens?  Screenshots may help too.
  
> disappears when I use the "key stroke Desk command binding".

Would it be silly to ask if the pager window is sticky at all?

> Sorry again about the wrong modules.

No problem.  This happens quite often.

Bye

Dominik ^_^