Subject: Re: hanging apps locking screen

From: Dan Espen <[email-masked]>
Date: Wed, 14 Jun 2000 19:50:26 -0400

This reply came directly to me.   This is just to put the reply on
the fvwm-workers list where it belongs...

Elliot Sowadsky <[email-masked]> writes:
> 
> What does "owning the whole screen" mean?
> 
> I think it means "X Server grab".
> 
> All applications apparently do it once they get focus....cuz when the app
> hangs, the only thing i can do is move the mouse around til the window
> unhangs or i remote login and kill the window.
> 
> mailtool delete....the sun keyboard left side (L10 i think).
> Click on the msg in the header window and hit L10.
> 
> worked up thru 2.3.16 (which is what i'm running).
> 
> 
> clicktofocus over root...
> 
> This patch worked
> 
>   if (ewp->window == Scr.Root && Scr.NumberOfScreens > 1)
>   if(Event.xcrossing.window == Scr.Root && Scr.NumberOfScreens > 1)
> 
> but only the 2nd line is in 2.3.19.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Thu, 15 Jun 2000 08:48:41 -0400

> unhangs or i remote login and kill the window.

I don't think that part about all applications doing it is right.
No application that I'm aware of does it.

When you have an application that hangs, you should be able to use the
root menus to popup a shell window and kill the window from there.

I have seen NFS problems lock up Solaris for extended periods of time.

> worked up thru 2.3.16 (which is what i'm running).

As with all keyboard problems, check whether NUMLOCK is part of the problem.
There are a few more hints in the FAQ.

On my Type-4 keyboard, L10 is labelled "Cut".  It does indeed delete mail
in mailtool.  (I'm using 2.3.20).

Its possible you have an fvwm keybinding thats taking the key away from
mailtool.  In fvwm the key would be known as "F20".  Look for something
like:

Key F20 A A ......

in your .xinitrc.