Subject: Re: hanging apps locking screen

From: Dominik Vogt <[email-masked]>
Date: Wed, 14 Jun 2000 21:41:12 +0200

On Wed, Jun 14, 2000 at 08:54:31AM -0700, Elliot Sowadsky wrote:
> 
> > Is there a setting that prevents an application from owning the whole screen?
> > So that if a window hangs, i can still access everything else?
> 
> < Try the MaxWindowSize style.
> 
> What does MaxWindowSize have to do w/ a window hogging the focus?

Nothing.  What Dan wanted to said was this:  if the application
has *grabbed* the server (i.e. requested that the server executes
only requests from the grabbing apllication), fvwm can do nothing
to bring the server back to life.  But I guess that is not what
you encounter (and it has nothing to do with the focus either).

> Is there a fix for
> 
> fvwm sez function Winlistfunc not a valid command or something like that.

I'll commit a fix in a moment.

> Must click twice into a window for it to get focus.
> I use clicktofocus mode

I still can't reproduce this.  Perhaps if I dig out your config...

> My delete key (Sun) no longer works in Mailtool main window (cant delete msg)
> (didnt retry this in 2.3.19)

Dan, can you try to debug this with Elliot's help on your Sun
machine?

> clicktofocus window loses focus when mouse over root

...  I don't know what I can do, Elliot.  I tried what I
could with the information you provided but couldn't make
out the root cause.  Could you perhaps revive the debugging
session you started weeks ago and try to find the reason for
this problem?  I can provide any assistance, but without this
happening for me I can't debug it myself.  Would you please
make a minimal config file thats shows the problem and try to
find a reliable way to reproduce it? (every detail may be
important).

--
Is this list of problems complete or are there other open issues?
I really want to clean that up befoore we release 2.4.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 14 Jun 2000 16:35:37 -0400

> you encounter (and it has nothing to do with the focus either).

Thats what I was trying to say.

I'm still confused as to what the problem is.

Is this an application we might know? Is it Star Office in full screen
mode?  What does "owning the whole screen" mean?

> Dan, can you try to debug this with Elliot's help on your Sun

I may use a desktop Sun, but I don't normally use mailtool.
The Delete key (either one) wouldn't delete mail for me either.
This is what the man page for mailtool says:

     Certain  menu  functions  are accelerated, and may be activated
     directly from the keyboard by holding down the Meta key  and
     the  appropriate  accelerator key. The accelerated functions
     are so indicated.
...
               Cut [Meta x]
                         Deletes  the  selected  mail   messages,
                         placing copies in the Clipboard.

               Copy [Meta c]
                         Copies the selected mail messages, plac-
                         ing copies in the Clipboard.

               Delete    Deletes  the  selected  mail   messages,
                         without placing copies in the Clipboard.
                         If no mail messages  are  selected,  the
                         messages   currently  being  viewed  are
                         deleted.

I think the things in [] are the keyboard  shortcuts.  It doesn't look
like  the delete  key is supposed  to delete  mail.  Meta-x  worked as
advertised.

I think I must be missing something.  A mail client without a keyboard
shortcut to delete the mail doesn't make any sense to me.

Send more information if you have it.  I have a type 4 keyboard.  What
keyboard do you have?  Which delete key are you trying to use?

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 15 Jun 2000 11:15:46 +0200

> mode?  What does "owning the whole screen" mean?

I think I can explain this.  Elliot has one of these annoying windows
that simply cover the whole screen (window decorations on other pages).
If the application hangs he can't close the application internally and
since there's no portion of the root window or the decoration visible
he can't close it via fvwm.  Not sure if this explanation is correct,
though.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]