Subject: Re: CVS domivogt: * Fixed button placement with 'NoButton'.

From: Giuseppe Della Ricca <[email-masked]>
Date: Wed, 14 Jun 2000 12:40:45 +0200 (MET DST)

Dear Dominik,

i've just updated from the CVS tree, but I'm still seeing the same
problem with a window with a title but without any button:

...
Style "Mxconns"        BorderWidth 0, NoHandles
Style "Mxconns"        Sticky, WindowListSkip, SkipMapping
Style "Mxconns"        NoButton 1, NoButton 2, NoButton 3
Style "Mxconns"        NoButton 4, NoButton 5, NoButton 6

The 'button' part of the title bar (i.e. the part that is on the sides
and below the title) is shorter than the title bar itself, leaving about
ten pixels on the right with the right color/pixmap but 'flat'.
...

(from my mail of Fri, 9 Jun 2000)

Looking in borders.c, I've modified the line:

  /* title */
  if (tmp_win->title_g.width <= 0 || ww <= 0)
    tmp_win->title_g.x = -10;

into:

  /* title */
  if (tmp_win->title_g.width <= 0 || ww < 0)
    tmp_win->title_g.x = -10;

(i.e. I've removed the '=')

I don't know if this is breaking something else, but it works for my
window.

Best regards,

Giuseppe.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 14 Jun 2000 12:04:32 +0200

> I don't know if this is breaking something else, but it works for my

The fix is OK.  I'll commit it.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]