Subject: Notification: incoming/629

From: [email-masked]
Date: Fri, 9 Jun 2000 19:48:23 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/629

Message summary for PR#629
	From: [email-masked]
	Subject: fvwm2 confuses Meta_R vs Alt_R key binding
	Date: Fri, 9 Jun 2000 19:48:21 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 11 Jun 2000 17:11:09 +0200

On Fri, Jun 09, 2000 at 07:48:23PM -0500, [email-masked] wrote:
> >From [email-masked]  Fri Jun  9 19:48:21 2000
> Received: from localhost (localhost [127.0.0.1])
> 	by larry.math.uh.edu (8.9.1/8.9.1) with ESMTP id TAA16303
> 	for <[email-masked]>; Fri, 9 Jun 2000 19:48:21 -0500 (CDT)
> Message-Id: <[email-masked]>
> To: [email-masked]
> Full_Name: Serge Winitzki
> Version: 2.2.4 
> CVS_Date: 
> OS: Debian 2.1/potato
> X_Server: XFree86 3.3.6
> Submission from: (NULL) (129.22.176.182)
> 
> 
>    my fvwmrc contains the following line:
> Key Meta_R      A       A       WindowList
>    this binds the "win95 right window key" in fvwm 2.0.46 and fvwm 2.2.0
> but
> works (I believe) incorrectly in fvwm 2.2.4 that I just installed from
> the
> Debian package. Namely, it binds not only the Meta_R but also the Alt_R 
> keysym to the same function.

This is probably a problem with your X keyboard configuration.
I find it rather unusual to use key bindings on modifier keys.
This can only work if Meta_R is not configured as a modifier
in X.  Look at the output of 'xmodmap -p'.  Does the Meta_R
key show up somewhere?  In the same line as Alt_R?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 14 Jun 2000 05:17:48 +0200

On Sun, Jun 11, 2000 at 01:32:56PM -0400, Serge Winitzki wrote:
> No, it doesn't:
> 11:24am mendax:~>xmodmap -p
> xmodmap:  up to 2 keys per modifier, (keycodes in parentheses):
> 
> shift       Shift_L (0x32),  Shift_R (0x3e)
> lock        Control_L (0x42)
> control     Control_L (0x25),  Control_R (0x6d)
> mod1        Alt_L (0x40),  Alt_R (0x71)
> mod2        Num_Lock (0x4d)
> mod3      
> mod4      
> mod5        Scroll_Lock (0x4e)
> 
> I used the key binding on Meta_R with previous versions of fvwm2 up to
> 2.2.0 with no problem. This way one can bind useful fvwm functions to
> the "win95" keys that generate "Meta_L", "Meta_R" and "Menu" keysyms. If
> there is some other way, I'd be interested to know.

What's the output of 'xmodmap -pke'?

Bye

Dominik ^_^

P.S.: Please always reply to the fvwm-workers list instead of directly
to me.

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Serge Winitzki <[email-masked]>
Date: Sat, 24 Jun 2000 22:55:59 -0400 (EDT)

> What's the output of 'xmodmap -pke'?

Here are the relevant parts of its output:

keycode  64 = Alt_L Meta_L
keycode 113 = Alt_R Meta_R
keycode 115 = Meta_L
keycode 116 = Meta_R
keycode 117 = Menu

The 115, 116 and 117 keys are the "windows" keys. Is something wrong in
my keyboard setup? I'm using standard Debian distribution.

--
	Serge