Subject: to do for 2.4 (update 36)

From: Dominik Vogt <[email-masked]>
Date: Fri, 2 Jun 2000 16:34:03 +0200

Items with highest priority / most severe problems:

 - #158 (IS_NAME_CHANGED flag) Mikhael (later)
 - What should we do with #128 (bug #564)?  Can fvwm do anything
   about the window that receives the selection?
 - Do we want to set up bzip2 tarballs (#12)?  We'd have to put
   links on the downloads page then.  Definitely saves a lot of
   space (compressed with bzip2 -9):
     fvwm-2.3.16.tar.gz:  1533662 bytes
     fvwm-2.3.16.tar.bz2: 1188684 bytes

New since last update:

160, 161

Closed since last update:

48, 107, 120, 133, 145, 148, 150, 157, 160, 161

---------- Summary: ----------------------------------------------

 2 to be verified
 2 to be discussed
21 to do
 3 distribution issues
 9 testing
----------------------
37 open items
124 items closed
161 items in total

---------- To be verified: ---------------------------------------

118) Investigate "FvwmPager & StaysOnTop" bug (#543).
     [reported by Nadim Shaikli <[email-masked]>]
138) Bug #593 (key bindings w/ Motif)
     [confirmed by Dominik]

---------- To be discussed ---------------------------------------

128) Bug #564 (pasting text goes to window with the mouse, not
     the focused window).
121) Investigate FvwmPager core dump.
     [reported by Wing Tung Leung <[email-masked]> on 20-Feb-2000]
     [Dominik: Didn't get any reply, stack trace, ...]
     [Dominik: I suggest to close it as unreproducible]

--------- To do: ------------------------------------------------

 17) Fix the bug that causes icons to lose management (bug #352).
     [couldn't reproduce this yet; can anybody who has netcool
     event manager try it?]
 32) Several applications are reported to not resize well under fvwm
     (Datek's "Streamer", CodeWarrior).
     [optional]
116) Fix problem that can cause long icon titles to be expanded
     although the pointer is not over it.
     [reported by Mikhael]
117) Investigate icons disappearing if icon changes while on a
     different desk.
     [reported by Julian Gilbey/David Cunningham on 16-Mar-2000]
122) Investigate FvwmButtons panel problem.
     [reported by Robert H. Ford II <[email-masked]> on 18-Feb-2000]
123) Bug #378 (FvwmPager interferes with xscreensaver)
124) Bug #477 (closing xbuffy popup window nukes focus)
125) Bug #479 (windows migrating to page 0 0 during restart)
126) Bug #489 (icons migrating on restart, ident does not work)
127) Bug #511 (xpp subwindows not drawn properly)
129) Bug #560
130) Fix bounds error with 'DestroyStyle *' in
     update_window_color_hi_style().
     [reported by Ben Winslow <[email-masked]>]
     [not reproduced yet]
     [purify may bring it up when we run the test script again]
134) Investigate DecWindows ConfigureRequest/Notify race condition.
     [reported by Fabien Viallard on 19-Apr-2000]
139) Fix TaskBar tips drawing.
     [reported by [email-masked] (Gregory A. Shimansky) on
     14-Apr-2000]
     [patch supplied but not yet applied]
143) Bug #603 (TaskBar bugs): investigate and possibly fix.
146) Bug #542 (Winch signals).
152) Investigate/fix fvwm freeze on Exceed.
     [various reporters, but no usable feedback yet]
156) xterm client window cursor corrupted.
     [reported by Nagi Aboulenein on 2-Nov-1999]
158) IS_NAME_CHANGED flag still broken?
     [Mikhael?]
159) configure check for gnome.h

---------- Distribution issues: ----------------------------------

 9)  Set up RPM packages.
     [???; Jason?]
 12) Set up bzip2 tarballs.
     [optional]
 62) Write a new announcement.
     [in progress]

---------- Testing: ----------------------------------------------

 33) Test the GNOME patches.
 34) Update and run the purify script again (and update it).
 35) Test the strokes patch.
 36) Test the new menu styles (ItemFormat!)
 92) Test new session management code.
 94) Test colour set support in modules and fvwm.
 95) Test new panel implementation in FvwmButtons.
105) Test binding code.
106) Test window position code.

========== Closed recently: ======================================

 14) Figure out what the problem with Amaya is.
     [reported on 3-Jun-1999 by Rob Urban <[email-masked]>]
     [still unreproducible; not relevant for 2.4]
 16) Try to fix the 'netscape stuck on page' problem.
     [reported on 17-May-1999 by <[email-masked]>]
     [still unreproducible; not relevant for 2.4]
 48) Finish Windoze 95 like config file.
 90) Icon distribution.
107) "Recapture" while an icon is focused takes several seconds.
     [reported by Mikhael; confirmed by Dominik]
     [workaround implemented]
110) Running two FvwmAuto modules at one freezes fvwm.
119) MaxSwallow does not work in FvwmWharf e.g. with
     'xload -g 50x50'.
     [reported by Dominik]
     [not reproducible anymore]
120) Icons are not always sorted properly; there may be
     gaps after page switching (with IconBox).
133) Bug #602 (window placement w/ 2.3.15)
140) Remove "Layer" command?  Instead, the "Layer" styles
     can be applied immediately w/o Recapture.
     [3 votes against vs 1 vote for removing]
     [maybe after 2.4]
141) Remove "MoveSmoothness" command?  I wrote it back when
     window motion was very jerky due to excessive network
     traffic, but I guess it's not very useful.
142) Remove copyright disclaimers from individual files
     (smaller tarball).
     [saves only 15k tarball size; not worth the effort]
145) Modules lose focus when a Netscape transient is opened
     (ClickToFocus).
148) Losing focus when entering root window bug.
     [reported by Elliot Sowadsky on 29-Dec-1999]
     [suggested fix: Lenience style... does not help]
     [implemented a workaround that cures the symptom]
153) Investigate/reduce excessive colour allocation traffic
     on startup.
     [reported by Dan]
     [perhaps after 2.4]
157) Stack ring still broken sometimes.
160) Remove FlipTransient style.
161) Rename MovedButton3 condition to PlacedByButton3.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 3 Jun 2000 01:01:23 +0300

>  - #158 (IS_NAME_CHANGED flag) Mikhael (later)

I can't for some time run gnome-session to test this.

>    about the window that receives the selection?

See below.

>      fvwm-2.3.16.tar.bz2: 1188684 bytes

Yes, of course. My experience with wm-icons shows that 55% of users prefer
.tar.bz2, which is smaller.

I produce both files using 'make dist2' (or distcheck2), I can add this.
But generating .bz2 from .gz on the ftp server side (Jason) is also good.

> 128) Bug #564 (pasting text goes to window with the mouse, not

Ok, it may be unexpected (to a reporter) and I can understand this.
But I personally would expect mouse (any button) to operate on the window
under a mouse, not on the focussed window, at least by default.

Another thing is that I would expect before such operation (i.e. a click)
the window under a mouse to receive a focus (unless NeverFocus).
This is also annoying sometimes to get a mouse in the center of unfocussed
window (SloppyFocus) and the only possibility to get a focus is leave and
enter again this window, instead of just click. Only my thoughts.

>      [Dominik: I suggest to close it as unreproducible]

I don't know whether it is related (you should close this entry anyway),
but it is easy to crash a pager if you resize it (horizontally only) to
the size 0. I am attaching a stack trace at the end of this message.

>      [reported by Mikhael; confirmed by Dominik]

Sorry, I can't confirm this. Still if I focus an icon and execute
(from a menu) "All (CurrentDesk Iconic) RecaptureWindow" it takes
many (30) seconds for me.

I see a similar problem with stroke. It takes a lot for a window started
with a stroke binding to appear when any icon is focused.

--------

Here is a stack.

[migo@sparta]/data/cvs/fvwm/fvwm> gdb modules/FvwmPager/FvwmPager ~/core
GNU gdb 19991004
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
Core was generated by `/opt/fvwm/libexec/fvwm/2.3.19/FvwmPager 23 4 /opt/fvwm/share/fvwm/.FvwmAnimate'.
Program terminated with signal 8, Floating point exception.
Reading symbols from /usr/X11R6/lib/libXpm.so.4...done.
Reading symbols from /usr/X11R6/lib/libSM.so.6...done.
Reading symbols from /usr/X11R6/lib/libICE.so.6...done.
Reading symbols from /usr/X11R6/lib/libXext.so.6...done.
Reading symbols from /usr/X11R6/lib/libX11.so.6...done.
Reading symbols from /lib/libm.so.6...done.
Reading symbols from /lib/libc.so.6...done.
Reading symbols from /lib/ld-linux.so.2...done.
#0  0x804cfef in CalcGeom (t=0x805f138, win_w=3, win_h=73, x_ret=0xbffff1a0, 
    y_ret=0xbffff1a4, w_ret=0xbffff1a8, h_ret=0xbffff1ac) at x_pager.c:171
171         edge -= max * pos / gap;
(gdb) bt
#0  0x804cfef in CalcGeom (t=0x805f138, win_w=3, win_h=73, x_ret=0xbffff1a0, 
    y_ret=0xbffff1a4, w_ret=0xbffff1a8, h_ret=0xbffff1ac) at x_pager.c:171
#1  0x8050420 in MoveResizePagerView (t=0x805f138) at x_pager.c:1756
#2  0x804f43c in ReConfigureAll () at x_pager.c:1348
#3  0x804f209 in ReConfigure () at x_pager.c:1271
#4  0x804e7fc in DispatchEvent (Event=0xbffff2b0) at x_pager.c:949
#5  0x804a96c in Loop (fd=0x805a48c) at FvwmPager.c:443
#6  0x804a932 in main (argc=6, argv=0xbffff484) at FvwmPager.c:419
(gdb)

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 3 Jun 2000 04:33:12 +0200

> under a mouse, not on the focussed window, at least by default.

Well, that's exactly what the confusion is about.  Keyboard
input goes to the focused window while mouse input goes to 
the window containing the pointer.  Now if you press the
mouse to fake keyboard input you might expect either.

But what I was aiming at was: is it at all possible to do
something about it?  If it is, we might make an option
controlling the behaviour of the selection (and make the
report an enhancement request).  Otherwise I can close the
report.

> many (30) seconds for me.

Really?  Have a look at builtins.c, line 2347 ff.  You should see
this code:

  if ((!Scr.Focus || !IS_ICONIFIED(Scr.Focus)) &&
      (Scr.BusyCursor & BUSY_RECAPTURE))
  {
    if (GrabEm(CRS_WAIT, GRAB_BUSY))
      need_ungrab = True;
  }

What you're saying is this:  An icon is focused, but in the
moment you look at the focused window it does not have its
'iconified' flag set.  Hmm.

> with a stroke binding to appear when any icon is focused.

No wonder.  As I said: I didn't fix anything but simply disabled
the busy cursor grav for recapture when an icon is focused.  There
are probably other situations when this will hang (e.g. icon focused
and you open a dynamic menu using the busy cursor).  Well, I could
move the workaround into the GrabEm function.  But that still wouldn't
fix the problem.

Perhaps someone else has an idea of what's going on.  The problem
is, that whenever fvwm tries to grab the pointer (XGrabPointer()
called via GrabEm()), the grab fails if an icon currently has the
focus (return code is AlreadyGrabbed).  Usually 'AlreadyGrabbed'
means: another application has already grabbed the pointer.  This
is nonsense - it even happens if no other applications or modules
are running.  I have already double checked the code: fvwm does
not grab the pointer itself.  So it must be something the X server
is doing, right?  Why?  Where is this documented?  How can we
prevent this?

> Here is a stack.
...
> 171         edge -= max * pos / gap;

??? Has this already been fixed?  In my x_pager.c this is
line 167:

  edge -= max * pos / Scr.MyDisplayWidth;

Bye

Dominik ^_^

---

From: Michael Han <[email-masked]>
Date: Sat, 03 Jun 2000 14:18:36 -0700

Previously from Dominik Vogt
>     [reported by Nadim Shaikli <[email-masked]>]

I'm still seeing stack ring corruptions with the latest CVS. I'll be
back with more information after another fun debugging session.

>138) Bug #593 (key bindings w/ Motif)

I believe this is fixed. Certainly it is for my setup:
ClickToFocus, ClickToFocusPassesClick, ClickToFocusDoesntRaise
MWMFunc, MWMDecor

Transient-related settings are default (GrabFocusTransient, etc.)

>     [Dominik: I suggest to close it as unreproducible]

There's a kinda-sorta trace in the original message... Still, I'm
inclined to believe that this is a hardware error producing signal 11,
and not something Pager did.

I just updated fvwm here at home and rebuilt... After restarting from
page 0 1 1, I found that windows moved around and lost the correct
geometries... This is something that's worked well for quite a while,
so I'm surprised by the problem. I don't recall anyone committing a
change that would have any effect on restart. I'll noodle around and
see if I can find out what happened -- it seems that the windows may
have had their maximized flags set, because when I maximized the
windows, they were restored to the correct geometry. Further maximize
DTRT...
-- 
[email-masked]                               http://www.mikehan.com/
coffee achiever                              San Francisco, California
"Notice how I  blame my own mistakes  on the lack  of rules?" - Dan Espen 
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 4 Jun 2000 03:10:58 +0300

>   edge -= max * pos / Scr.MyDisplayWidth;

Oh, blame on me. Both these problems are already fixed (recapture with
focussed icon workaround and pager crash).

Probably I got "connection timed out" from cvs server, as I sometimes get,
but didn't take to my attention, and continued with make. Really sorry.

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 4 Jun 2000 03:22:15 +0300

> windows, they were restored to the correct geometry. Further maximize

I believe, I already wrote exactly the same reply some months ago. :/

Don't bother to try to reproduce this. This is a one-time problem, which
everyone should have when restarting+upgrading from the version before
yesterday, when Dominik changed the window flags structure and the format
of restart file in session.c. Just quit fvwm and start again to fix this.
If you are a session manager user, you should correct windows themselves
(probably by closing and opening them again), then save session.

I think we have agreed that changing this format (including flags
structure) in stable versions is not acceptable, or versioning is needed,
or at least storing flags by names (partial fix for the problem).

Regards,
Mikhael.