Subject: CVS hippo: Config lines and messages are sent synchronously.

From: CVS <[email-masked]>
Date: Wed, 14 Jun 2000 09:03:46 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	hippo	00/06/14 09:03:45

Modified files:
	modules        : ChangeLog 
	modules/FvwmTheme: FvwmTheme.c 

Log message:
Config lines and messages are sent synchronously.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 15 Jun 2000 15:44:38 +0300

> Config lines and messages are sent synchronously.

Unfortunatelly, this hangs fvwm (and X) for me. I have no time (today)
to experiment with hanging fvwm, so I disabled this, I hope temporarily.

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 20 Jun 2000 02:36:33 +0300

> to experiment with hanging fvwm, so I disabled this, I hope temporarily.

Ok, I have moved the line   SetSyncMask(fd, M_CONFIG_INFO | M_STRING);
behind the 'while' in parse_config, and it works just fine now.

Regards,
Mikhael.