Subject: the Wait function and modules

From: Olivier Chapuis <[email-masked]>
Date: Sat, 17 Jun 2000 21:16:46 +0200

Hello,

It seems that there is a problem with modules to
fvwm2 communication during a Wait function pause.
I imagine that the problems came from the new
modules <-> fvwm2 communications protocol caused
by the double FvwmAuto problems.

Here "the" problem:

AddToFunc Test I wait pouf
Test

Then, the messages send by the modules to fvwm2 are not
handled. You have to unlock the wait (Ctl-atl-Escape)
so that the messages are handled by fvwm2.

Olivier

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Mon, 19 Jun 2000 14:49:48 +0100

Olivier Chapuis wrote:
> handled.

Oh rats! somebody noticed.  I've committed a fix. Could anyone who
understands reentrancy have a look at ExecuteCommandQueue() and see if
it's safe? Do I have to declare the list pointers as volatile?

Cheers,
Tim.