Subject: Re: CVS domivogt: * Fixed lots of parameter expansion bugs.

From: Dominik Vogt <[email-masked]>
Date: Fri, 2 Jun 2000 00:16:25 +0200

On Wed, May 31, 2000 at 09:08:21PM +0200, Tomas Ogren wrote:
> On 29 May, 2000 - CVS sent me these 0.7K bytes:
> 
> > CVSROOT:	/home/cvs/fvwm
> > Module name:	fvwm
> > Changes by:	domivogt	00/05/29 19:51:16
> > 
> > Modified files:
> > 	.              : ChangeLog NEWS todo-2.4 
> > 	fvwm           : functions.c fvwm2.1 gnome.c stack.c 
> 
> After this:
> 2000-05-27  Dominik Vogt  <[email-masked]>
> 
>         * fvwm/stack.c (RaiseOrLowerWindow):
>         performance enhancement
>         reindented some code
> 
> I get this:
> 383         for (s = Scr.FvwmRoot.stack_next; s != &Scr.FvwmRoot; s =
> s->stack_next)
> 384         {
> 385           if (test_layer >= s->layer)
> 386           {
> 387             break;
> 388           }
> 389         }
> (gdb) p s
> $3 = (FvwmWindow *) 0x8b990
> (gdb) p s->stack_next
> $4 = (struct FvwmWindow *) 0x8a730
> (gdb) p s->stack_next->stack_next
> $5 = (struct FvwmWindow *) 0x8f7c8
> (gdb) p s->stack_next->stack_next->stack_next
> $6 = (struct FvwmWindow *) 0x8b990
> 
> ... 100% looping in RaiseOrLowerWindow() using builtin config and
> starting ssh-askpass...

Okay I have backed out the commit on stack.c does this help?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tomas Ogren <[email-masked]>
Date: Fri, 2 Jun 2000 18:19:50 +0200

> >         * fvwm/stack.c (RaiseOrLowerWindow):
[..]
> Okay I have backed out the commit on stack.c does this help?

Works fine now.

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student at Computing Science, University of Umeå
`- Sysadmin at {cs,ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]