Subject: Notification: incoming/622

From: [email-masked]
Date: Mon, 29 May 2000 10:01:23 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/622

Message summary for PR#622
	From: [email-masked]
	Subject: Fvwm-2.3.18 crashes when "program specified resize increment" hint is equal to 0
	Date: Mon, 29 May 2000 10:01:22 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 30 May 2000 22:49:09 +0200

On Mon, May 29, 2000 at 10:01:23AM -0500, [email-masked] wrote:
> >From [email-masked]  Mon May 29 10:01:23 2000
> Received: from localhost (localhost [127.0.0.1])
> 	by larry.math.uh.edu (8.9.1/8.9.1) with ESMTP id KAA32194
> 	for <[email-masked]>; Mon, 29 May 2000 10:01:22 -0500 (CDT)
> Message-Id: <[email-masked]>
> To: [email-masked]
> Full_Name: Yuri B. Yudin
> Version: 2.3.18
> CVS_Date: 
> OS: 
> X_Server: Sun OpenWindows 3.6
> Submission from: (NULL) (195.19.226.98)
> 
> 
> Fvwm 2.3.18 crashes with arithmetic exception, when  
> "program specified resize increment" hint is equal to 0
> 
> xinc and yinc values should be checked against zero at least in
> constrain_size() (geometry.c:346)

Uh, yes.  For some reason the code accepted a size_inc of 0
in some cases.  I think that was a fix for the warnings that
are generated in GetWindowSizeHints() (add_window.c).  I'll
apply a patch.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]