Subject: Notification: incoming/616

From: [email-masked]
Date: Fri, 12 May 2000 12:54:18 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/616

Message summary for PR#616
	From: [email-masked]
	Subject: conftest cores during ./configure
	Date: Fri, 12 May 2000 12:54:17 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: [email-masked] (Paul D. Smith)
Date: 12 May 2000 14:31:44 -0400

%% [email-masked] writes:

  f> while compiling for solaris 8, the following occured:

  f> checking whether setvbuf arguments are reversed... configure: error: can
  f> not run test program while cross compiling

This error almost invariably means your compiler is not installed
correctly, or you're not invoking configure so that it can detect your
compiler correctly.

This is especially common on Solaris.

 1) Read the INSTALL.fvwm file for a discussion of this common problem.

 2) Run configure with the --without-cxx option, to avoid trying to find
    a C++ compiler.

 3) If it still fails, examine the config.log file to see what's going
    on where it fails, and try posting that information, along with
    specific version information about your compiler and other details
    you think might be relevant.

  f> Examining the directory, a file 'core' was found:

  f> -rw-------   1 [xxx] other      72204 May 12 12:35 core

  f> bash-2.03$ file core
  f> core:           ELF 32-bit MSB core file SPARC Version 1, from 'conftest'

This makes it even more likely that your compiler isn't installed
correctly.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]