Subject: Re: fvwm-themes-0.3.4

From: Olivier Chapuis <[email-masked]>
Date: Tue, 30 May 2000 09:08:00 +0200

Mikhael Goikhman wrote:
> 
> As I was already said to Olivier, I am releasing this fix version.
> 
> New:
> 
>   * settings/sound renamed to settings/sound-player; more players added
>   * options are now fully supported (I hope)
>   * switch-mouse-2-3 option does nothing for now, because of problems with
>     var expanding in the current fvwm (I had no time to think about this)
>   * new fvwm-themes-config parameters: --show-value, --component.
>   * new script fvwm-themes-xres, not good yet
> 
> As usual, after instalation, execute "Restart fvwm-themes-start" or choose
> the "Restart..." form from the menu.
> 
> Ok, Olivier, your turn. :)
> 

Yep!
It seems that there are problem with kde and gnome image path as well
with starting FvwmGtk. Can fvwm-themes-config do the following:

[component]
file=settings/gnome/system-menu
name=System Menu
default=1
choice+file=disabled
choice.name=Disabled
choice+file=gtk-menu
choice.name=Gtk Menu
choice.config+start-stop+=FvwmGtk
choice.config+requires+=settings/gnome/start:fvwmgtk     <----
choice+file=fvwm-menu
choice.name=Fvwm Menu

I.e can we require some cached component to be read? Of course
such a component have to be read only once but more than one
component can ask for it. Also, it seems that 
choice.config+start-stop+=
does not work?
Ok, I know that fvwm-themes-config is under developpement and that
may be I've to do the above, but it is difficult to understand
it. There are very few comments in the code and no *.cfg spec :)
Any way I've begin to play a litle bit with the "themes.cfg" and the
stuff seems powerfull :o)

Olivier

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 30 May 2000 22:45:48 +0200

I am really sorry, Olivier