Subject: to do for 2.4 (update 35)

From: Dominik Vogt <[email-masked]>
Date: Sat, 13 May 2000 14:56:21 +0200

Items with highest priority / most severe problems:

 - Is #48 finished? (win95-like config file)
 - Verify if #150 is really fixed.
 - #158 (IS_NAME_CHANGED flag) Mikhael?
 - What should we do with #128 (bug #564)?  Can fvwm do anything
   about the window that receives the selection?
 - Do we want to set up bzip2 tarballs (#12)?  We'd have to put
   links on the downloads page then.  Definitely saves a lot of
   space (compressed with bzip2 -9):
     fvwm-2.3.16.tar.gz:  1533662 bytes
     fvwm-2.3.16.tar.bz2: 1188684 bytes
 - #157
 - #138/#145

New since last update:

150 (from 'closed' to 'to be verified')

Closed since last update:

14, 16, 90, 110, 119, 140, 141, 142, 153

---------- Summary: ----------------------------------------------

 1 to be verified
 1 to be discussed
29 to do
 5 distribution issues
 9 testing
----------------------
45 open items
114 items closed
159 items in total

---------- To be verified: ---------------------------------------

150) Mini windows in pager can reach into adjacent pages
     because of the min size of 3x3 pixels.

---------- To be discussed ---------------------------------------

128) Bug #564 (pasting text goes to window with the mouse, not
     the focused window).

--------- To do: ------------------------------------------------

 17) Fix the bug that causes icons to lose management (bug #352).
     [couldn't reproduce this yet; can anybody who has netcool
     event manager try it?]
 32) Several applications are reported to not resize well under fvwm
     (Datek's "Streamer", CodeWarrior).
     [optional]
107) "Recapture" while an icon is focused takes several seconds.
     [reported by Mikhael; confirmed by Dominik]
116) Fix problem that can cause long icon titles to be expanded
     although the pointer is not over it.
     [reported by Mikhael]
117) Investigate icons disappearing if icon changes while on a
     different desk.
     [reported by Julian Gilbey/David Cunningham on 16-Mar-2000]
118) Investigate "FvwmPager & StaysOnTop" bug (#543).
     [reported by Nadim Shaikli <[email-masked]>]
     [in progress, reproduced by Mike Han]
120) Icons are not always sorted properly; there may be
     gaps after page switching (with IconBox).
     [reported by Joerg Klemenz on 26-Feb-2000]
     [confirmed by Dominik (hard to reproduce)]
121) Investigate FvwmPager core dump.
     [reported by Wing Tung Leung <[email-masked]> on 20-Feb-2000]
122) Investigate FvwmButtons panel problem.
     [reported by Robert H. Ford II <[email-masked]> on 18-Feb-2000]
123) Bug #378 (FvwmPager interferes with xscreensaver)
124) Bug #477 (closing xbuffy popup window nukes focus)
125) Bug #479 (windows migrating to page 0 0 during restart)
126) Bug #489 (icons migrating on restart, ident does not work)
127) Bug #511 (xpp subwindows not drawn properly)
129) Bug #560
130) Fix bounds error with 'DestroyStyle *' in
     update_window_color_hi_style().
     [reported by Ben Winslow <[email-masked]>]
     [not reproduced yet]
133) Bug #602 (window placement w/ 2.3.15): investigate and
     fix or close.
134) Investigate DecWindows ConfigureRequest/Notify race
     condition.
     [reported by Fabien Viallard on 19-Apr-2000]
138) Bug #593 (key bindings w/ Motif)
     [confirmed by Dominik]
     [Brad?]
139) Fix TaskBar tips drawing.
     [reported by [email-masked] (Gregory A. Shimansky) on
     14-Apr-2000]
143) Bug #603 (TaskBar bugs): investigate and possibly fix.
145) Modules lose focus when a Netscape transient is opened
     (ClickToFocus).  Probably the same as (138).
     [reported by [email-masked] (Gregory A. Shimansky) on
     1-May-2000]
     [confirmed by Dominik]
146) Bug #542 (Winch signals).
148) Losing focus when entering root window bug.
     [reported by Elliot Sowadsky on 29-Dec-1999]
     [suggested fix: Lenience style... does not help]
152) Investigate/fix fvwm freeze on Exceed.
     [various reporters, but no usable feedback yet]
156) xterm client window cursor corrupted.
     [reported by Nagi Aboulenein on 2-Nov-1999]
157) Stack ring still broken sometimes.
     [Mike Han/Dominik]
158) IS_NAME_CHANGED flag still broken?
     [Mikhael?]
159) configure check for gnome.h

---------- Distribution issues: ----------------------------------

 9)  Set up RPM packages.
     [???; Jason?]
 12) Set up bzip2 tarballs.
     [optional]
 48) Finish Windoze 95 like config file.
     [Olivier]
 62) Write a new announcement.
     [in progress]

---------- Testing: ----------------------------------------------

 33) Test the GNOME patches.
 34) Update and run the purify script again (and update it).
 35) Test the strokes patch.
 36) Test the new menu styles (ItemFormat!)
 92) Test new session management code.
 94) Test colour set support in modules and fvwm.
 95) Test new panel implementation in FvwmButtons.
105) Test binding code.
106) Test window position code.

========== Closed recently: ======================================

 14) Figure out what the problem with Amaya is.
     [reported on 3-Jun-1999 by Rob Urban <[email-masked]>]
     [still unreproducible; not relevant for 2.4]
 16) Try to fix the 'netscape stuck on page' problem.
     [reported on 17-May-1999 by <[email-masked]>]
     [still unreproducible; not relevant for 2.4]
 90) Icon distribution.
110) Running two FvwmAuto modules at one freezes fvwm.
119) MaxSwallow does not work in FvwmWharf e.g. with
     'xload -g 50x50'.
     [reported by Dominik]
     [not reproducible anymore]
140) Remove "Layer" command?  Instead, the "Layer" styles
     can be applied immediately w/o Recapture.
     [3 votes against vs 1 vote for removing]
     [maybe after 2.4]
141) Remove "MoveSmoothness" command?  I wrote it back when
     window motion was very jerky due to excessive network
     traffic, but I guess it's not very useful.
142) Remove copyright disclaimers from individual files
     (smaller tarball).
     [saves only 15k tarball size; not worth the effort]
153) Investigate/reduce excessive colour allocation traffic
     on startup.
     [reported by Dan]
     [perhaps after 2.4]

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Michael Han <[email-masked]>
Date: Sun, 14 May 2000 14:36:37 -0700

Previously from Dominik Vogt
>     [in progress, reproduced by Mike Han]

I think I've identified the problem. I'm not sure I've provided a
reasonable fix (not sure if it breaks something else).

>138) Bug #593 (key bindings w/ Motif)

I've discovered that this is no longer a problem... Huh? I have no
idea how/why it got fixed.

>     [reported by [email-masked] (Gregory A. Shimansky) on

Unfortunately this *is* still a problem. If there's a root cause that
associates the two, something's now fixed 138 without addressing
145... I suspect that motif defines something naughty. That or there's
some breakage in FVWM's MWM hints.

>     [suggested fix: Lenience style... does not help]

Did anyone ever duplicate this? I've used 'Style * ClickToFocus' for
years without ever seeing a problem of this sort.

>157) Stack ring still broken sometimes.

See 118 above.
-- 
[email-masked]                         http://www.best.com/~mikehan/
coffee achiever                              San Francisco, California
"Compulsory education is inconstitutional" - graffitti I saw in the subway
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 15 May 2000 08:20:33 +0200

> years without ever seeing a problem of this sort.

I have tried to debug this off-line by giving Elliot instructions
what to do and we could narrow down the place where it happens,
but didn't get much farther thatn this.  It still happens to him.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 15 May 2000 22:37:11 +0200

> idea how/why it got fixed.

I can still see it.  Something weird is happening with the keyboard
focus.  With the SloppyFocus feature of the pager I can even make
the window gain focus when I *leave* the window.

> some breakage in FVWM's MWM hints.

I'm on the hunt :-)

> years without ever seeing a problem of this sort.

I still suspect it is somehow related to 138/145.

Bye

Dominik ^_^

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 16 May 2000 07:53:59 +0200

>  - Is #48 finished? (win95-like config file)

For me it is finished. However, I think that it will be good that
others test it and edit it (I'm ready to fix any bug).
Olivier

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 17 May 2000 18:29:05 +0200

>      [reported by [email-masked] (Gregory A. Shimansky) on

This in progress thanks to Gregory A. Shimansky
Olivier

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 17 May 2000 21:39:27 +0200

> 143) Bug #603 (TaskBar bugs): investigate and possibly fix.

I'm unable to reproduce this bug. 
Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 18 May 2000 13:11:39 +0200

> I'm unable to reproduce this bug. 

Some or all of them may already be fixed.  I could verify that
in some setups the code tries to access a mailbox if 'None'
was specified (depending on the order of the options in the
config file).  I have already fixed this one.

Bye

Dominik ^_^

---

From: [email-masked]
Date: Sat, 20 May 2000 00:56:03 -0600

> others test it and edit it (I'm ready to fix any bug).
Hi, I tried your setup script, It is very nice. I especially like the
menus. But I have found two typos. When it asks what your prefered 
file manager is, I believe Midnight-Commander is spelled wrong. And 
in the Window Ops menu there is an extra "&" in a menu item...

--- menus.orig  Fri May 19 15:36:57 2000
+++ menus       Fri May 19 15:37:15 2000
@@ -1029,8 +1029,8 @@
 + "%mini.window.xpm%&NoHandles"                Pick (CirculateHit) Style $n NoHandles
 + "%mini.window.xpm%BorderWidth &0" Pick (CirculateHit) Style $n BorderWidth 0
 + "%mini.window.xpm%BorderWidth &5" Pick (CirculateHit) Style $n BorderWidth 5
-+ "%mini.window.xpm%HandleWi&dth &0" Pick (CirculateHit) Style $n HandleWidth 0
-+ "%mini.window.xpm%HandleWid&th &7" Pick (CirculateHit) Style $n HandleWidth 7
++ "%mini.window.xpm%HandleWi&dth 0" Pick (CirculateHit) Style $n HandleWidth 0
++ "%mini.window.xpm%HandleWid&th 7" Pick (CirculateHit) Style $n HandleWidth 7
 + "" Nop

HTH,
sa