Subject: Possible bug?

From: [email-masked]
Date: Sun, 7 May 2000 18:17:41 -0600

Hi, 
I Accidentally issued this command in FvwmConsole:

BorderStyle ActiveUp TiledPixmap blobby-blue.xpm
and got this error:
[FVWM][ReadDecorFace]: <<ERROR>> unknown style ctiveUp: (null)
                                               ^^--No A!
but, in my systems error console I get:
[FVWM][ReadDecorFace]: <<ERROR>> unknown style ActiveUp: ActiveUp
TiledPixmap blobby-blue.xpm

I thought it was wierd that there is a missing 'A' in the first one. So
I send this.

Thanks,
sa
(using today's CVS fvwm)
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Michael Han <[email-masked]>
Date: Sun, 07 May 2000 19:58:02 -0700

Previously from [email-masked]
>I thought it was wierd that there is a missing 'A' in the first one. So

How strange. I cannot reproduce this error... Hmm... What OS/hardware
are you on (`uname -a` please). Are you sure you're running
FvwmConsole from today's CVS (i.e. is your ModulePath correctly
detecting the FvwmConsole you installed)?
-- 
[email-masked]                         http://www.best.com/~mikehan/
coffee achiever                              San Francisco, California
"I will not be a snickerpuss." - Lisa
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked]
Date: Mon, 8 May 2000 01:17:53 -0600

> are you on (`uname -a` please). Are you sure you're running

~ % uname -a
Linux space 2.2.15pre14 #6 Sat Mar 25 13:46:17 MST 2000 ppc unknown

~ % fvwm2 -version
[FVWM][main]:  Fvwm Version 2.3.17 compiled on May  7 2000 at 17:33:53
[FVWM][main]:  with support for:  ReadLine XPM IMLIB Session
 
> detecting the FvwmConsole you installed)?
Yep, I only have FvwmConsole installed in one place
/usr/local/libexec/fvwm/2.3.17/FvwmConsole.
...
I fooled around some more and got some more weird stuff. Again the
errors sent to my system console look normal.

*FvwmConsole Ver. 1.3
BorderStyle foobar                            
[FVWM][ReadDecorFace]: <<ERROR>> unknown style oobar: (null)
TitleStyle foobar 
[FVWM][ReadDecorFace]: <<ERROR>> unknown style oobar: (null)
Emulate foobar
[FVWM][Emulate]: <<ERROR>> Unknown style 'Þ¡P'
Emulate foobar
[FVWM][Emulate]: <<ERROR>> Unknown style 'Þ¡('
Emulate foobar
[FVWM][Emulate]: <<ERROR>> Unknown style 'Cons'
Emulate foobar
[FVWM][Emulate]: <<ERROR>> Unknown style 'Þ¡('

If you need more infos let me know.
Thanks,
shawn a.

---

From: Michael Han <[email-masked]>
Date: Mon, 08 May 2000 12:32:45 -0700

>Linux space 2.2.15pre14 #6 Sat Mar 25 13:46:17 MST 2000 ppc unknown

Ah... PPC.

>[FVWM][Emulate]: <<ERROR>> Unknown style 'ޡP'
>Emulate foobar
>[FVWM][Emulate]: <<ERROR>> Unknown style 'ޡ('
>Emulate foobar
>[FVWM][Emulate]: <<ERROR>> Unknown style 'ޡ('
>

Could you try running FvwmDebug? It should output errors to stderr,
giving you two copies of each error on fvwm's stderr. I'm trying to
figure out if this is a problem with the module interface on your
machine or something specific in FvwmConsole. I see something that
looks like it might be suspect, but I'm not sure. BTW, do you happen
to know if byte-ordering on PPC differs from x86? I believe it does.
-- 
[email-masked]                         http://www.best.com/~mikehan/
coffee achiever                              San Francisco, California
"The lunatic, the lover and the poet
Are of imagination all compact:-" A Midsummer Night's Dream, V i
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked]
Date: Mon, 8 May 2000 15:04:12 -0600

> to know if byte-ordering on PPC differs from x86? I believe it does.

yeh PPC, byte ordering is different, I'm not really sure of the
difference, but its byte ordering is called big-endian. 

Here is some FvwmDebug stuff,
***in FvwmConsole:

BorderStyle foobar

***from FvwmDebug

[FVWM][ReadDecorFace]: <<ERROR>> unknown style  : foobar

Unknown packet type 0x20000
Configure Window
         ID 2800002
         frame ID 140009a
         fvwm ptr 7ffff1a8
         frame x 1
         frame y 210
         frame w 509
         frame h 489
         desk 0
         title height 16
         border width 7
         window base width 15
         window base height 4
         window resize width increment 5
         window resize height increment 7
         window min width 20
         window min height 11
         window max 32767
         window max 32767
         icon label window 0
         icon pixmap window 0
         window gravity 1
         forecolor d3d3d3
         backcolor 696969
         flags 20000000
Old Configure Window
         ID 2800002
         frame ID 140009a
         fvwm ptr 10086ab0
         frame x 1
         frame y 210
         frame w 509
         frame h 489
         desk 0
         flags 2200f800
         title height 16
         border width 7
         window base width 15
         window base height 4
         window resize width increment 5
         window resize height increment 7
         window min width 20
         window min height 11
         window max 32767
         window max 32767
         icon label window 0
         icon pixmap window 0
         window gravity 1
Configure Window
         ID 2000002
         frame ID 140007b
         fvwm ptr 7ffff1a8
         frame x 1
         frame y 1
         frame w 519
         frame h 202
         desk 0
         title height 16
         border width 7
         window base width 15
         window base height 4
         window resize width increment 5
         window resize height increment 7
         window min width 20
         window min height 11
         window max 32767
         window max 32767
         icon label window 0
         icon pixmap window 0
         window gravity 1
         forecolor d3d3d3
         backcolor 696969
         flags 20000000
Old Configure Window
         ID 2000002
         frame ID 140007b
         fvwm ptr 10080fd0
         frame x 1
         frame y 1
         frame w 519
         frame h 202
         desk 0
         flags 2200f800
         title height 16
         border width 7
         window base width 15
         window base height 4
         window resize width increment 5
         window resize height increment 7
         window min width 20
         window min height 11
         window max 32767
         window max 32767
         icon label window 0
         icon pixmap window 0
         window gravity 1
Configure Window
         ID c00003
         frame ID 1400055
         fvwm ptr 7ffff1a8
         frame x 973
         frame y 717
         frame w 51
         frame h 51
         desk 0
         title height 0
         border width 1
         window base width 1
         window base height 1
         window resize width increment 2
         window resize height increment 2
         window min width 1
         window min height 1
         window max 32767
         window max 32767
         icon label window 0
         icon pixmap window 0
         window gravity 9
         forecolor d3d3d3
         backcolor 696969
         flags a0000000
Old Configure Window
         ID c00003
         frame ID 1400055
         fvwm ptr 1007f6a8
         frame x 973
         frame y 717
         frame w 51
         frame h 51
         desk 0
         flags 2200b804
         title height 0
         border width 1
         window base width 1
         window base height 1
         window resize width increment 2
         window resize height increment 2
         window min width 1
         window min height 1
         window max 32767
         window max 32767
         icon label window 0
         icon pixmap window 0
         window gravity 9
Configure Window
         ID 1800005
         frame ID 1400062
         fvwm ptr 7ffff1a8
         frame x 831
         frame y 717
         frame w 142
         frame h 51
         desk 0
         title height 0
         border width 1
         window base width 0
         window base height 0
         window resize width increment 1
         window resize height increment 1
         window min width 1
         window min height 1
         window max 32767
         window max 32767
         icon label window 0
         icon pixmap window 0
         window gravity 9
         forecolor d3d3d3
         backcolor 696969
         flags a0000000
Old Configure Window
         ID 1800005
         frame ID 1400062
         fvwm ptr 10080a50
         frame x 831
         frame y 717
         frame w 142
         frame h 51
         desk 0
         flags 2200b804
         title height 0
         border width 1
         window base width 0
         window base height 0
         window resize width increment 1
         window resize height increment 1
         window min width 1
         window min height 1
         window max 32767
         window max 32767
         icon label window 0
         icon pixmap window 0
         window gravity 9
Configure Window
         ID 800007
         frame ID 140006e
         fvwm ptr 7ffff1a8
         frame x 520
         frame y 719
         frame w 310
         frame h 49
         desk 0
         title height 0
         border width 0
         window base width 0
         window base height 0
         window resize width increment 1
         window resize height increment 1
         window min width 1
         window min height 1
         window max 32767
         window max 32767
         icon label window 0
         icon pixmap window 0
         window gravity 9
         forecolor d3d3d3
         backcolor 696969
         flags a0000000
Old Configure Window
         ID 800007
         frame ID 140006e
         fvwm ptr 1007f990
         frame x 520
         frame y 719
         frame w 310
         frame h 49
         desk 0
         flags 20009804
         title height 0
         border width 0
         window base width 0
         window base height 0
         window resize width increment 1
         window resize height increment 1
         window min width 1
         window min height 1
         window max 32767
         window max 32767
         icon label window 0
         icon pixmap window 0
         window gravity 9
Configure Window
         ID c00003
         frame ID 1400055
         fvwm ptr 7ffff548
         frame x 973
         frame y 717
         frame w 51
         frame h 51
         desk 0
         title height 0
         border width 1
         window base width 1
         window base height 1
         window resize width increment 2
         window resize height increment 2
         window min width 1
         window min height 1
         window max 32767
         window max 32767
         icon label window 0
         icon pixmap window 0
         window gravity 9
         forecolor d3d3d3
         backcolor 696969
         flags a0000000
Old Configure Window
         ID c00003
         frame ID 1400055
         fvwm ptr 1007f6a8
         frame x 973
         frame y 717
         frame w 51
         frame h 51
         desk 0
         flags 2200b804
         title height 0
         border width 1
         window base width 1
         window base height 1
         window resize width increment 2
         window resize height increment 2
         window min width 1
         window min height 1
         window max 32767
         window max 32767
         icon label window 0
         icon pixmap window 0
         window gravity 9

*** Another in FvwmConsole:

Emulate foobar
[FVWM][Emulate]: <<ERROR>> Unknown style ''

*** FvwmDebug gives:

[FVWM][Emulate]: <<ERROR>> Unknown style 'foobar'
Unknown packet type 0x20000

HTH,
shawn a.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 9 May 2000 07:34:41 +0200

> difference, but its byte ordering is called big-endian. 

This means that if you have an integer value (4 bytes), e.g.
0x12345678, this is stored as 0x12 0x34 0x56 0x78 in memory
while the order is 0x78 0x56 0x34 0x12 in little endian (or
the other way round, I can never remember which is which).

> [FVWM][ReadDecorFace]: <<ERROR>> unknown style oobar: (null)
                                           ^^^^^
> Unknown packet type 0x20000
  ^^^^^^^^^^^^^^^^^^^^^^^^^^^
...

> [FVWM][Emulate]: <<ERROR>> Unknown style ''
                                     ^^^^^
> Unknown packet type 0x20000
  ^^^^^^^^^^^^^^^^^^^

This all looks seriously broken.  Are you using 2.2.x or one
of the 2.3.x betas?

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Michael Han <[email-masked]>
Date: Mon, 08 May 2000 23:51:15 -0700

Previously from Dominik Vogt
>the other way round, I can never remember which is which).

Yeah, I always get this confused too. The core question I was trying
to answer was whether the byte ordering differs between x86 and ppc. I
figured a byte-ordering problem could result in the kind of problem
being reported, since we pack chars into the body, which are ulongs...

>> Unknown packet type 0x20000

These are actually okay. The 'style' tokens are supposed to be present
in the fvwm_msg() calls in the functions referenced. Well, perhaps I
should say that that's the way the code generates the message
currently. Whether anyone thinks that's what they're supposed to do is
a separate matter... And the unknown packet types are M_ERROR packets.
I foolishly advised him to run FvwmDebug, forgetting that handling for
M_ERROR packets is one of the improvements I've made locally that
hasn't been committed in CVS... Oops. Anyway, I sent a patch so we can
see what FvwmDebug shows with these errors. We should get an idea if
the problem is systematically related to the module interface or if
its something funny about FvwmCommand.

>This all looks seriously broken.  Are you using 2.2.x or one

He reports using CVS as of two days ago.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 9 May 2000 08:08:56 +0200

On Mon, May 08, 2000 at 11:51:15PM -0700, Michael Han wrote:
[snip]
> in the fvwm_msg() calls in the functions referenced.

What I wanted to point out is that the error message doesn't fit
the command that was run.  'Emulate' won't generate a 'style'
error message usually.

> Well, perhaps I

Ah, thanks, I missed that.

Bye

Dominik ^_^

---

From: [email-masked]
Date: Tue, 9 May 2000 04:01:17 -0600

> Ah, thanks, I missed that.
Hi, in case it helps, I just tried Version 2.2.2 and it exhibits the
same wierdness as the CVS version.

sa