Subject: CVS domivogt: * Fixed lots of parameter expansion bugs.

From: CVS <[email-masked]>
Date: Mon, 29 May 2000 19:51:16 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	00/05/29 19:51:16

Modified files:
	.              : ChangeLog NEWS todo-2.4 
	fvwm           : functions.c fvwm2.1 gnome.c stack.c 
	modules        : ChangeLog 
	modules/FvwmCommand: FvwmCommand.c FvwmCommandS.c 

Log message:
* Fixed lots of parameter expansion bugs.
* Implemented several new parameters ('$*', '$[screen]', ...).
* Fixed FvwmCommand pipe names (now containd display and screen).

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tomas Ogren <[email-masked]>
Date: Wed, 31 May 2000 21:08:21 +0200

> 	fvwm           : functions.c fvwm2.1 gnome.c stack.c 

After this:
2000-05-27  Dominik Vogt  <[email-masked]>

        * fvwm/stack.c (RaiseOrLowerWindow):
        performance enhancement
        reindented some code

I get this:
383         for (s = Scr.FvwmRoot.stack_next; s != &Scr.FvwmRoot; s =
s->stack_next)
384         {
385           if (test_layer >= s->layer)
386           {
387             break;
388           }
389         }
(gdb) p s
$3 = (FvwmWindow *) 0x8b990
(gdb) p s->stack_next
$4 = (struct FvwmWindow *) 0x8a730
(gdb) p s->stack_next->stack_next
$5 = (struct FvwmWindow *) 0x8f7c8
(gdb) p s->stack_next->stack_next->stack_next
$6 = (struct FvwmWindow *) 0x8b990

... 100% looping in RaiseOrLowerWindow() using builtin config and
starting ssh-askpass...

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student at Computing Science, University of Umeå
`- Sysadmin at {cs,ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]