Subject: IconBox crashes

From: Local Echo <[email-masked]>
Date: Thu, 25 May 2000 00:25:52 -0700 (PDT)

I've been able to crash fvwm2 repeatedly with the
Style iconbox settings.

Style Style1 IconBox 500x0+185+950 

doesn't seem to produce much but if I do it about 10
times then issue a

Style * UseStyle Style1 I get a death right away.
Style * IconBox 500x0+185+950 Program received signal 

a gdb revels this 

Program received signal SIGSEGV, Segmentation fault.
0x805ebc7 in copy_icon_boxes (pdest=0x80d36f4,
src=0x80a70f8) at style.c:183
183         memcpy(temp, src, sizeof(icon_boxes));

I'm using the latest cvs from last night and XFree 4.0

__________________________________________________
Do You Yahoo!?
Kick off your party with Yahoo! Invites.
http://invites.yahoo.com/
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 29 May 2000 10:47:04 +0200

> 183         memcpy(temp, src, sizeof(icon_boxes));

Hm, can someone try this with purify, please?

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 31 May 2000 09:41:29 -0400

> Hm, can someone try this with purify, please?

I purified the current CVS as of yesterday.  Ran with my normal config.
Brought up FvwmTalk and ran:

... (10 times)
Style * UseStyle Style1

No complaints from Purify.

Using the menus gave me:

      UMR: Uninitialized memory read
      This is occurring while in:
            menuShortcuts  [menus.c:910]
               
                 /*** handle double-keypress ***/
               
            =>   if (pdkp->timestamp &&
                     lastTimestamp - pdkp->timestamp < Menus.DoubleClickTime &&
                     event->xkey.state == pdkp->keystate &&
                     event->xkey.keycode == pdkp->keycode)
            MenuInteraction [menus.c:1580]
            do_menu        [menus.c:791]
            MenuInteraction [menus.c:1960]
            do_menu        [menus.c:791]
            menu_func      [menus.c:5054]
            popup_func     [menus.c:5064]
            ExecuteFunction [functions.c:991]
            HandleKeyPress [events.c:275]
            DispatchEvent  [events.c:2324]
            HandleEvents   [events.c:2364]
            main           [fvwm.c:733]
            _start         [crt1.o]
      Reading 4 bytes from 0xefffb3a8 on the stack.
      Address 0xefffb3a8 is        8 bytes past start of local variable "dkp" in function do_menu.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]