Subject: problems with expansion of command

From: Olivier Chapuis <[email-masked]>
Date: Tue, 09 May 2000 23:44:45 +0200

Hello,
I've got a lot of problems with "expansion of command".
In particular I've got the following core dump:

[olivier@snoopy olivier]$ gdb fvwm2 core
GNU gdb 4.17
Core was generated by `fvwm2'.
Program terminated with signal 11, Erreur de segmentation..
find_solib: Can't read pathname for load map: Erreur d'entrée/sortie.

#0  0x80701bc in expand (input=0x0, arguments=0xbffff23c, tmp_win=0x80ecc78, addto=0)
    at functions.c:366
366       l = strlen(input);
(gdb) where
#0  0x80701bc in expand (input=0x0, arguments=0xbffff23c, tmp_win=0x80ecc78, addto=0)
    at functions.c:366
#1  0x8070cf5 in ExecuteFunction (Action=0xbffff2b0 "Silent", tmp_win=0x80ecc78, eventp=0x808cfec,
    context=1, Module=6, expand_cmd=EXPAND_COMMAND, args=0x0) at functions.c:831
#2  0x806ecd3 in HandleModuleInput (w=29360188, channel=6, expect=0x0) at moduleerr
#3  0x80639ec in My_XNextEvent (dpy=0x808e328, event=0x808cfec) at events.c:2186#4  0x8063c82 in HandleEvents () at events.c:2331
#5  0x8067a79 in main (argc=1, argv=0xbffffbd4) at fvwm.c:733

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 10 May 2000 09:11:41 +0200

> #5  0x8067a79 in main (argc=1, argv=0xbffffbd4) at fvwm.c:733

Fixed.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]