Subject: ActivePlacement resize looks bad with style: ResizeOpaque

From: Tim Phipps <[email-masked]>
Date: Wed, 3 May 2000 16:45:31 +0100 (BST)

Configuration Information [Automatically generated, do not change]:
uname output: SunOS tazmo 5.6 Generic_105181-15 sun4u sparc SUNW,Ultra-4
Compiler: gcc
Compilation CFLAGS: -g -O2
prefix: /home/tim/SunOS
sysconfdir: /home/tim/SunOS/etc
libexecdir: /home/tim/SunOS/libexec

FVWM Version: 2.3.17
FVWM_DATADIR: /
FVWM_MODULEDIR: /home/tim/SunOS/libexec/fvwm/2.3.17
FVWM_USERDIR: /home/tim/.fvwm

Description:
	Style * ResizeOpaque, DumbPlacement, ActivePlacement
	
	Start an xclock, place it with button 2 and try to resize.
	You get the size feedback window but the rubberband isn't drawn
	(presumably it's looking at ResizeOpaque).  The placement and size
	works but you have no feedback while sizing.

Fix:
	Temporarily set to ResizeOutline until the window is mapped, or
	add the condition (window_is_mapped) to the resize outline drawing code
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 4 May 2000 03:54:04 +0200

> 	add the condition (window_is_mapped) to the resize outline drawing code

Yup, checking for IS_MAPPED is sufficient.  I'll commit a fix.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]