Subject: Dynamic style and Modules

From: Olivier Chapuis <[email-masked]>
Date: Fri, 19 May 2000 10:02:19 +0200

Hello,

Some modules have to react to some style change
(e.g., TaskBar, WinList, IconMan and IconMan have
to react to a Style "*" Icon command). Some times
fvwm2 send immediately to the modules the style change 
via the GSFR in a CONFIGURE_WINDOW message.
However, in some case no such message are send. Here
the cases which cause problems on my current work:
- A Icon/NoIcon change (for forbidding a double/non animation
after a Style * Icon/NoIcon command).
- A WindowListSkip/WindowListHit change (for that the modules
respect the UseListSkip config command).

So, I have added a new update_win (update.h) flags: 
do_update_modules_flags
which is set to true if needed in check_window_style_change (style.c)
so that apply_window_updates (update.c) can do in this case a BroadcastConfig(M_CONFIGURE_WINDOW,t)

Dominik, Any objections for such a change?

Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 19 May 2000 11:20:52 +0200

> Dominik, Any objections for such a change?

No, not at all.  I want to catch all gaps in the dynamic styles
stuff before 2.4 if possible.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]