Subject: Re: Notification: incoming/593

From: Dominik Vogt <[email-masked]>
Date: Tue, 2 May 2000 21:17:49 +0200

On Mon, Apr 17, 2000 at 12:01:22AM -0500, [email-masked] wrote:
> FVWM Bug Tracking notification
> 
> new message incoming/593
> 
> Message summary for PR#593
> 	From: [email-masked]
> 	Subject: motif windows and key bindings
> 	Date: Mon, 17 Apr 2000 00:01:20 -0500 (CDT)
> 	0 replies 	0 followups
> 
> ====> ORIGINAL MESSAGE FOLLOWS <====
> 
> >From [email-masked]  Mon Apr 17 00:01:21 2000
> Received: from localhost (localhost [127.0.0.1])
> 	by larry.math.uh.edu (8.9.1/8.9.1) with ESMTP id AAA00016
> 	for <[email-masked]>; Mon, 17 Apr 2000 00:01:20 -0500 (CDT)
> Date: Mon, 17 Apr 2000 00:01:20 -0500 (CDT)
> From: [email-masked]
> Message-Id: <[email-masked]>
> To: [email-masked]
> Subject: motif windows and key bindings
> 
> Full_Name: Michael Han
> Version: 
> CVS_Date: 20000404
> OS: FreeBSD 4.0-STABLE
> X_Server: XFree86 3.3.6
> Submission from: (NULL) (63.201.69.194)
> 
> 
> When I use a menu to cause a motif window to be closed (File|Exit type
> things), I typically find that key bindings will cease functioning until
> I click the mouse. This happens both with staticly-linked binaries like
> Adobe Acrobat Reader and Netscape, as well as dynamically-linked ones
> (against lesstif 0.88). Can anyone verify this problem?
> 
> I suspect it's got something to do with the order in which windows are
> unmapped/destroyed in response to the event triggered in the menu.

What focus policy do you use?  What kind of key bindings fail
to work, window specific or root key bindings?  Please give an
example.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Michael Han <[email-masked]>
Date: Tue, 02 May 2000 19:55:26 -0700

Previously from Dominik Vogt
>to work, window specific or root key bindings?  Please give an

I use "style * clicktofocus" and never deviate from that. Given that
then context when I cause an unmap of a Motif window from its menu
falls to root, that's the context where my keybindings fail. But I
have plenty of "a" context bindings that do not work.

Your questions spurred me to look at this some more and I accidentally
found something that's probably useful... If I, for example, use
Netscape and then open a second window using Meta-N, then create a
third window from *either* one using Meta-N again, if I close the
third window from a menu and move the mouse into the frame of the
window that "created" the third window, it receives focus and my
keybindings start working again.

So, it looks like something's broken in the window destroy/unmap that
failes to return focus to the prior window in the stacking chain. It's
probably being caused because the menu closes its parent *before* it
unmaps/destroys itself, so when Fvwm attempts to return focus to the
menu's parent, it returns to a void context -- a window that's already
been deleted/unmapped... Or something like that. I can look deeper,
but it's been a while since I looked at core fvwm code and it'll take
me a while to figure anything out. Anyone see anything useful here to
figure this problem out?
-- 
[email-masked]                         http://www.best.com/~mikehan/
coffee achiever                              San Francisco, California
Avoid cliches like the plague
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 3 May 2000 05:42:03 +0200

Brad, have you seen this?  I bet my right arm that this is
the same as the one that Gregory reported.  It really seems
that fvwm gets FocusIn events wrong somehow.  I don't see
how this makes root bindings stop working, but it does for
me too.

Bye

Dominik ^_^