Subject: Latest enhancements.

From: Dominik Vogt <[email-masked]>
Date: Wed, 3 May 2000 04:56:19 +0200

Hi all,

I just committed some minor enhancements to the Move and
Resize commands and a new condition 'MovedButtons3'.  All
this stuff is marked with an ifdef.  I know it's really not
the time to add new features, but the changes are very small
and add a lot of flexibility:

 - Move syntax enhanced: a '-' tells fvwm to not change the
   coordinate (x or y), e.g.

     # move window to top of screen
     Move - 0
     
 - Resize: '0' tells fvwm not to change the dimension (vertical
     or horizontal), e.g.

     # resize horizontally
     Resize 80c 0

 - Resize: takes negative sizes (interpreted as
     screen size - given size), e.g.

     # resize to screen height minus 64 pixels
     Resize - -64p

 - Resize: bottomright or br option allows to place the bottom
     right corner instead of specifying a new size.

     # resize so that bottom right corner is in the corner of the screen
     Resize bottomright -0 -0

 - New command MoveResize does what Resize and Move do, but in
     a single step (reduces flickering).

     MoveResize 80c 24c +10p +10p

 - A new condition MovedButton3 was added: when a window motion
     is finished by a button 3 press, this flag is set.  This
     allows to call a function for newly mapped windows with
     ActivePlacement + DubPlacement.  This function can then
     e.g. resize the window to the bottom of the screen, e.g.

       Style * ActivePlacement, DumbPlacement

       *FvwmEventPassID
       *FvwmEventadd_window GrowDownFunc
       AddToFunc StartFunction
       + I FvwmEvent

       AddToFunc GrowDownFunc
       + I windowid $0 (XTerm MovedButton3) Resize bottomright - -0p

With these changes we can make quite a few people happy (there
were several questions/enhancement requests that can be solved
with these enhancements).  I still recognize that we are in
feature freeze and I don't want to force this.  If anybody
objects against these changes or - as always - I don't get two
votes for them, I'll remove them again (i.e. undefine the
ifdef).

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tomas Ogren <[email-masked]>
Date: Wed, 3 May 2000 14:24:34 +0200

On 03 May, 2000 - Dominik Vogt sent me these 2.3K bytes:

> Resize commands and a new condition 'MovedButtons3'.
[..]
>      # resize so that bottom right corner is in the corner of the screen

Maybe we'd want a generic thing for this.. so you can do the same with
all corners...

[..]
> votes for them, I'll remove them again (i.e. undefine the

I'll vote for. Could come in handy sometimes...

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student at Computing Science, University of Umeå
`- Sysadmin at {cs,ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 03 May 2000 08:45:35 -0400

> Maybe we'd want a generic thing for this.. so you can do the same with

The syntax "bottomright" is like the IconFill arguments (2 words):

IconFill Bottom Right

> I'll vote for. Could come in handy sometimes...

2.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Wed, 03 May 2000 14:15:52 +0100

>  - Resize: '0' tells fvwm not to change the dimension (vertical

This fails in the current CVS, i.e. "Next (xclock) Resize 100p 0"
results
in a 100x1 xclock.

>      MoveResize 80c 24c +10p +10p

Since the size arguments come before the position shouldn't the command
be called ResizeMove or the arguments switched?

> votes for them, I'll remove them again (i.e. undefine the

My vote is for them.

Cheers,
Tim.

---

From: [email-masked] (Paul D. Smith)
Date: 03 May 2000 09:52:48 -0400

%% Dominik Vogt <[email-masked]> writes:

  dv>  - Move syntax enhanced: a '-' tells fvwm to not change the
  dv>    coordinate (x or y), e.g.

  dv>      # move window to top of screen
  dv>      Move - 0
     
  dv>  - Resize: '0' tells fvwm not to change the dimension (vertical
  dv>      or horizontal), e.g.

  dv>      # resize horizontally
  dv>      Resize 80c 0

Unless I'm missing something, why isn't the same syntax used here?  I
prefer the "-", so shouldn't this be "Resize: '-' tells fvwm not to
change the dimension"?

I realize that resize with a "0" is silly, nevertheless I think
consistency in syntax is more important.

  dv> I still recognize that we are in feature freeze and I don't want
  dv> to force this.  If anybody objects against these changes or - as
  dv> always - I don't get two votes for them, I'll remove them again
  dv> (i.e. undefine the ifdef).

I like 'em!

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Michael Han <[email-masked]>
Date: Wed, 03 May 2000 07:33:01 -0700

Previously from Paul D. Smith
>consistency in syntax is more important.

The args for Resize line up with the behavior of Maximize.
Unfortunately, Maximize can't be made to line up with Move. All in all
I'd say it works out okay.
-- 
[email-masked]                         http://www.best.com/~mikehan/
coffee achiever                              San Francisco, California
"The lunatic, the lover and the poet
Are of imagination all compact:-" A Midsummer Night's Dream, V i
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 3 May 2000 11:48:01 -0400

> This fails in the current CVS, i.e. "Next (xclock) Resize 100p 0"

I can confirm this as well, and I built from sratch just to double check.

I had the same thoughts as Paul on the syntax but otherwise count me as
in favor.

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 4 May 2000 02:06:09 +0200

> This fails in the current CVS, i.e. "Next (xclock) Resize 100p 0"

I'll check this.

> be called ResizeMove or the arguments switched?

They can't be switched easily because the resize arguments
have to be parsed before the move arguments.  How about
a less confusing name, like 'Geometry' or 'WindowGeometry'?

Bye

Dominik ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 4 May 2000 03:26:56 +0200

Well, I hadn't expected so much feedback to my patch.  Thanks
for all the support.  Apart from the (now fixed) bug with
'0' args to a resize, there are several open syntax/naming
issues:

 1) Is there a better name for the 'bottomright' option?

 2) A better (less confusing) name for MoveResize. Suggestions:
     - ResizeMove (reflects order of arguments)
     - WindowGeometry
     - Geometry
     - SetGeometry

    I'll change the name to ResizeMove for now...

 3) Consistent naming of 'do not modify' arguments.  Currently
    Move uses '-', Resize uses '0' or '-' if bottomright is
    used (and don't ask about MoveResize).  Since the times
    of cryptic arguments like '-' and '0' have hopefully passed,
    I suggest 'keep' in both cases instead.  Although it's
    slightly more work to parse, you can understand it easily.

 4) I don't think 'MovedButton3' is a good name for the new
    condition, but I couldn't find a better one. Something
    like
      'InteractiveMoveOrInitialPlacementFinishedByButton3Press'
    would be clearer :-)

On Wed, May 03, 2000 at 04:56:19AM +0200, Dominik Vogt wrote:
>      ActivePlacement + DumbPlacement.  This function can then

Bye

Dominik ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 10 May 2000 06:21:52 +0300

>  1) Is there a better name for the 'bottomright' option?

'bottomright' and 'br' are ok with me.

>     I'll change the name to ResizeMove for now...

This should be an action, so either the first or the last.
If you don't like ResizeMove, I'd suggest SetGeometry, like:

	Exec  xterm    -geometry 80x40+60+20
	Next (xterm) SetGeometry 80 40 60 20

>     slightly more work to parse, you can understand it easily.

Let it be 'keep'.

>       'InteractiveMoveOrInitialPlacementFinishedByButton3Press'

I suggest 'PlacedByMouse3'.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 10 May 2000 09:06:50 +0200

> 	Next (xterm) SetGeometry 80 40 60 20

Any other opinions?

> >     slightly more work to parse, you can understand it easily.

Ok.

> I suggest 'PlacedByMouse3'.

Unfortunately that doesn't hit the spot exactly.  The flag is
set also when you used 'Move' and finished it with button 3.
But it's still better than MovedButton3.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]