Subject: parameter expansions broken?

From: Michael Han <[email-masked]>
Date: Sun, 07 May 2000 16:53:52 -0700

I just rebuilt and was running FVWM with no configuration to do some
testing when I discovered that parameter expansion seems to be broken.
When I use the builtin binding for Mouse 1 in title I get a message
back that $0 isn't a recognized command. I take it that parameter
expansion is broken?

[FVWM][ExecuteFunction]: <<ERROR>> No such command '$0'

To be exact.
-- 
[email-masked]                         http://www.best.com/~mikehan/
coffee achiever                              San Francisco, California
"If you lend me some money, it'll be my treat."
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 9 May 2000 09:09:26 +0200

On Mon, May 08, 2000 at 09:45:08PM -0700, Michael Han wrote:
> Previously from Dominik Vogt
> >On Sun, May 07, 2000 at 04:53:52PM -0700, Michael Han wrote:
> >No, it's fixed :-)  It was broken before. What command causes this
> >error message?
> 
> It looks like it's:
> 
> AddToFunc FuncFvwmRaiseLowerX I Raise
> + M $0
> + D Lower
> 
> and:
> 
> Mouse 1 TS A FuncFvwmRaiseLowerX Move
> 
> It's very puzzling.

Okay, I've fixed it.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]