Subject: FvwmTaskBar bug

From: [email-masked]
Date: Thu, 27 Apr 2000 03:59:02 +0100

I hope this is the right list to post this to?

There's been a bug in FvwmTaskBar which can cause fvwm2 to crash (at least, it
often causes 2.2 to crash) and/or behave strangely.

When the the Start Button is pressed, the associated Popup request is sent to
fvwm2 with an aribitary window id as context (non-deterministic -- based on an
uninitialised variable). This means that any window operations you invoke from
that menu have that wrong, probably illegal, context. At least, that's my
interpretation of it!

Really, of course, one wants that menu to be invoked with no context.

I believe the fix is trivial: see the following patch, made against
yesterday's snapshot.

--- FvwmTaskBar.c-old	Wed Apr 26 12:30:38 2000
+++ FvwmTaskBar.c	Wed Apr 26 20:32:51 2000
@@ -1236,7 +1236,7 @@
             y = win_y - ScreenHeight;
           }
           sprintf(tmp,"Popup %s %d %d", StartPopup, x, y);
-          SendFvwmPipe(Fvwm_fd, tmp, ItemID(&windows, num));
+          SendFvwmPipe(Fvwm_fd, tmp, None);
         } else {
 	  StartButtonUpdate(NULL, BUTTON_UP);
 	  if (MouseInMail(Event.xbutton.x, Event.xbutton.y)) {

Regards, John Latham

-----------------------------------------------------------------
Dr. John T. Latham, Room 2.113, Department of Computer Science,
University of Manchester, Oxford Road, Manchester, M13 9PL, U.K.
TEL: (0|+44) 161 275 6250        FAX: (0|+44) 161 275 6204
EMAIL: [email-masked]
-----------------------------------------------------------------
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 27 Apr 2000 05:12:34 +0200

> +++ FvwmTaskBar.c	Wed Apr 26 20:32:51 2000

Of course.  Will be applied in a moment.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]