Subject: STDERR reporting.

From: Eric Renfro <[email-masked]>
Date: Tue, 4 Apr 2000 00:37:06 -0500

In fvwm 2.0.0 and up, does fvwm's PipeRead read only STDIN? If I print to
STDERR in a script, will the PipeRead pick that up, or will it be ignored?
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 4 Apr 2000 10:19:49 +0200

> STDERR in a script, will the PipeRead pick that up, or will it be ignored?

PipeRead reads only from STDIN, not from stderr (if you read
from both, you can't know the order in which you have to
parse the input lines).  You probably know this, but just in
case you don't:  you can redirect all output to stderr to
stdin with '2>&1':

  grep "foo" bar 2>&1

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]