Subject: FvwmButtons manpage and Pixmap none

From: Dan Espen <[email-masked]>
Date: Thu, 06 Apr 2000 08:44:05 -0400

This is what the FvwmButtons man page has to  say about "Pixmap none":

     *FvwmButtonsPixmap pixmapfile
          Specifies a background pixmap to use.   Specify  "none"
          for a transparent background.

It neglects   to mention that  this  suppresses  the window  title and
frame.

I  can't find  an  explanation of this behavior   in the fvwm man page
either.

Is this something fvwm does automatically to all shaped windows?

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214             E-mail: [email-masked]
Piscataway, NJ 08854                       Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 6 Apr 2000 14:52:00 +0200

> I  can't find  an  explanation of this behavior   in the fvwm man page

...

> Is this something fvwm does automatically to all shaped windows?

Definitely not.  The must be a reason why FvwmButtons does
it this way.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Thu, 06 Apr 2000 13:54:51 -0400

> Definitely not.  The must be a reason why FvwmButtons does

Around line 410 in decorations.c:

#ifdef SHAPE
  if (ShapesSupported)
  {
    if(t->wShaped)
      decor &= ~(DECOR_BORDER|MWM_DECOR_RESIZEH);
  }
#endif

Disable it and you can get titles on shaped windows.
I suspect this is a change from the early days of fvwm
because I had a "Style xeyes NoTilte" line in my .fvwm2rc
that isn't necessary any more.

There must be other things  at work since  this turns off the  border,
and I end up with a title bar but still  no border.  I also killed the
code in add_window.c around line 432 but I still didn't have a border.

I'm not suggesting changing anything.  I'm just looking at the options
for a FAQ answer for the "desktop launcher" question.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 6 Apr 2000 19:21:04 +0200

> that isn't necessary any more.

Um, really?  Looks like a bug to me.  DECOR_BORDER shouldn't control
whether a window gets a title or not.  

Hm, checking again, deleting the DECOR_BORDER bit is essentially
a NOP.  This bit is never used anywhere else.

> code in add_window.c around line 432 but I still didn't have a border.

The SetShape() function in borders.c applies the shape.  There's
definitely code to handle a shaped window with border or title.
I don't understand why shaped windows don't have titles by default.
I'll probably have a look into this too.

Bye

Dominik ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 7 Apr 2000 01:08:25 +0200

> > for a FAQ answer for the "desktop launcher" question.

Fixed.  The MWM_DECOR... flags were screwed up.  To be precise
I've translated them to a fvwm specific format a while ago but
forgot to remove one of the old flags (namely DECOR_BORDER).

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]