Subject: to do for 2.4 (update 29)

From: Dominik Vogt <[email-masked]>
Date: Mon, 17 Apr 2000 03:20:54 +0200

Items with highest priority / most severe problems:

New since last update:

107-130

Closed since last update:

103

---------- Summary: ----------------------------------------------

 0 to be verified
27 to do
 5 distribution issues
 9 testing
----------------------
18 open items
87 items done
106 items in total

---------- New: --------------------------------------------------

107) "Recapture" while an icon is focused takes several seconds.
     [confirmed by Dominik]

108) FvwmPager desk separators are not updated if their colour set
     is changed (*FvwmPagerColorset).
     [reported by Olivier on 15-Apr-2000]

109) FvwmIconMan titles don't seem to work.
     [reported by Olivier on 15-Apr-2000]

110) Running two FvwmAuto modules at one freezes fvwm.
     [reported by Olivier on 15-Apr-2000]

111) Fix position hints not working with menus invoked
     from a menu like this: 'addtomenu foo foo menu foo root c c'
     [reported by Mikhael]

112) Recapture takes a long time if pointer is over an icon.
     [reported by Mikhael]
 
113) FvwmForm sets no class/resource.
     [reported by Mikhael]

114) FvwmIdent sets no class/resource.
     [reported by Mikhael]

115) FvwmWharf sets no class/resource.
     [reported by Mikhael]

116) Fix problem that can cause long icon titles to be expanded
     although the pointer is not over it.
     [reported by Mikhael]

117) Investigate icons disappearing if icon changes while on a
     different desk.
     [reported by Julian Gilbey/David Cunningham on 16-Mar-2000]
 
118) Investigate "FvwmPager & StaysOnTop" bug (#543).
     [reported by Nadim Shaikli <[email-masked]>]

119) MaxSwallow does not work in FvwmWharf e.g. with
     'xload -g 50x50'.

120) Icons are not always sorted properly; there may be
     gaps after page switching (with IconBox).
     [reported by Joerg Klemenz on 26-Feb-2000]
     [confirmed by Dominik (hard to reproduce)]

121) Investigate FvwmPager core dump.
     [reported by Wing Tung Leung <[email-masked]> on 20-Feb-2000]

122) Investigate FvwmButtons panel problem.
     [reported by Robert H. Ford II <[email-masked]> on 18-Feb-2000]

123) Bug #378

124) Bug #477

125) Bug #479

126) Bug #489

127) Bug #511

128) Bug #564

129) Bug #560

130) Fix bounds error with 'DestroyStyle *' in
     update_window_color_hi_style().
     [reported by Ben Winslow <[email-masked]>]
     [not reproduced yet]

More to come soon

131)
132)
133)
134)
135)
136)
137)
138)
139)
140)
141)
142)
143)
144)
145)
146)
147)
148)
149)
150)

---------- To be verified: ---------------------------------------

none

---------- To do: ------------------------------------------------

 14) Figure out what the problem with Amaya is.
     [reported on 3-Jun-1999 by Rob Urban <[email-masked]>]
 16) Try to fix the 'netscape stuck on page' problem.
     [reported on 17-May-1999 by <[email-masked]>]
 17) Fix the bug that causes icons to lose management (bug #352).
     [couldn't reproduce this yet; can anybody who has netcool
     event manager try it?]
 32) Several applications are reported to not resize well under fvwm
     (Datek's "Streamer", CodeWarrior).
     [optional]

---------- Distribution issues: ----------------------------------

 9)  Set up RPM packages.
     [???; Jason?]
 12) Set up bzip2 tarballs.
     [optional]
 48) Finish Windoze 95 like config file.
     [Olivier]
 62) Write a new announcement.
     [in progress]
 90) Icon distribution.

---------- Testing: ----------------------------------------------

 33) Test the GNOME patches.
 34) Update and run the purify script again (and update it).
 35) Test the strokes patch.
 36) Test the new menu styles (ItemFormat!)
 92) Test new session management code.
 94) Test colour set support in modules and fvwm.
 95) Test new panel implementation in FvwmButtons.
105) Test binding code.
106) Test window position code.
 
========== Done: =================================================

 1)  Document the GNOME stuff (man page still missing).
 2)  Add screen shots to web page.
 3)  Add link to fvwm cats page to web page.
 4)  Add link to Mikhael' wm-icons page.
 5)  Update the links on our home page.
 6)  Remove several configure options.
 7)  Create an I18N fvwm package (from 2.2 or so).
     [see #100]
 8)  Add an explanation about the various packages and where to
     discuss them to the web page.
     (stable, unstable (alpha), snapshots, ftp source tree, CVS).
 10) Remove 'PopupAsRootMenu' menu style (?).
     [rejected]
 11) Add FvwmKb module?
     [delayed until after 2.4]
 13) Use a 'busy' pointer during startup.
 15) Get restart straight (sometimes an application vanishes over restarts)
     [fixed]
 18) Check if there are still growing windows as reported for 2.13.
     [bug #184 reported by Michael Hughes <[email-masked]>]
     [no bug; doesn't happen for 2.2 and up]
 19) Fix: KFM windows stay on top of normal fvwm windows.
     [done]
 20) Check why no icon can be set for Eterm.
     [reported on 8-May-1999 by Amir Chossrow Akhavan <[email-masked]>]
     [no fix? or should we rather break 'xterm +ai'?]
 21) Fix the bug with eterm and transparent background (I think rxvt has
     the same problem.
     [Eterm bug fixed, rxvt doesn't work very well with transparent
     background. I've reported to the rxvt mailing list]
 22) Investigate bug #290. (windows cannot be raised over others sometimes).
     [mail thread from April; confirmed by me (Dominik)]
     [fixed; there is a new style and the behaviour is a bit more intuitive]
 23) Check if bug #312 is still there.
 24) Investigate bug #314.
 25) Investigate dying pager on desk-to-desk transfers (bug #358 et al.)
     [fixed; only in 2.2.2, caused by missing X error handler]
 26) Investigate bug #315. (Recapture doesn't work perfectly for changing the
     default decor).
     [mainly a documentation problem; man page was updated]
 27) Check if bug #334 is still a problem.
 28) Investigate FvemEvent core dumps.
     [fixed in 2.2.3, no bug in 2.3.4]
 29) Fix the pager bugs I reported recently.
 30) Fix the broken size hints of FvwmWinList (in fvwm itself).
 31) 'Maximize grow grow' works only on the current page.
 37) Fix interaction of moving with autoraising icon titles.
 38) Investigate bug #389. (StartsOnDesk does not work)
     [configuration problem, added a warning to the code]
 39) Investigate bug #390
 40) Investigate bug #394. (Overlapping pages)
     [no bug; doesn't happen after a recompile]
 41) Fix hanging fvwm when moving GNOME menu bars (bug #395).
 42) Get bitmap icons working again.
 43) Several pager bugs (bug #379).
 44) Fix TaskBar crash caused by latest patch in RemoveButton().
 45) Remove the web pages from the distribution.
 46) Titlebars should not inherit the pixmap from the border style.
 47) Verify the TaskBar clock update problem.
     [given up; I think I could reproduce the problem - it was a
     configuration mistake, but the reporter didn't care to answer
     if my suggestion helped; Dominik]
 49) Implement a 'H'old trigger for complex functions.
 50) Implement a 'ButtonGeometry' option for FvwmButtons.
 51) Fix constraining the window size when a window is maximized or
     larger than MaxWindowSize when mapped.
 52) Allow to resize in client resize increment steps.
 53) Decide what to do with overlapping moved icons.
     [will be ignored]
 54) Find a better solution for raising/lowering of transients.
 55) FvwmGtk can't be killed with 'KillModule'.
 56) Mini icons may overlap menu titles.
 57) Fix autohiding and TaskBar tips.
 58) DeskTopSize is not honoured upon a restart (the old one is reused).
     [use Restart --dont-preserve-state]
 59) Get Raise/Lower of transients straight.
     [duplicate of item 54]
 60) Make MaxWindowSize a style (don't release a command that will
     change anyway).
 61) Get SidecPics working again.
 63) Fix stacking order in pager.
 64) Install the new web pages.
 65) Fix "maximize true ..." when a window is already maximized.
 66) Fix ddd problems.
     [fixed as far as possible; bug reported to ddd list]
 67) Add a Windoze95 like screenshot to the web page.
 68) Investigate 'Xlib: sequence lost' message.
     [went away with a newer snapshot]
 69) Fix window moving. Several people have reported that moving windows
     is slow or the windows don't follow the pointer well. This is really
     a big problem.
 70) Fix resize. On one hand it's not nice that you can drag the window
     border off screen, on the other hand it doesn't hurt if the shadow
     of the border is not on screen.
 71) Fix drawing of window titles.
 72) Finish implementing colour sets for modules.
     [item split up]
 73) Remove 'panel' feature from FvwmButtons and re-implement it in a
     less disruptive way.
 74) To fix: icons are not preserved over a Quit - Start for fvwm
 75) Implement colour sets in FvwmWharf.
 76) Implement colour sets in FvwmTaskBar.
 77) Implement colour sets in menu styles.
 78) Implement colour sets in window styles.
     [only colours used yet]
 79) Implement colour sets in FvwmConsole?
     [rejected]
 80) Implement colour sets in FvwmScript
 81) Change the way in which fvwm 'posts' menus with a click.
 82) Introduce a 'transient' option for FvwmButtons. This is needed
     to replicate the old panel behaviour.
 83) Fix FvwmIconMan crashes introduced by colour set support(?)
     [doesn't happen anymore]
 84) Implement colour sets in FvwmBacker.
 85) Add 'geometry' panel option in FvwmButtons.
     I think it's not worth the effort because it's similarly
     complicated as the menu position hints if I want to do it right.
     I can't see an easy solution that does something useful fast.
     [future enhancement]
 86) Finish code for setting backgrounds of other applications with
     colour sets.
 87) Describe what to do for colour set support in the module docs.
 88) Investigate 'pager out of sync' problem
     [fixed]
 89) Make FvwmScript use the same visual as fvwm (prerequisite for 80)
 91) Fix Xpm version problem (bug #463).
 93) Finish 'CREATING PANELS' section in FvwmButtons man page.
 96) Make flat titlestyle work again.
 97) Rewrite FvwmTheme 'Colorset' syntax ala MenuStyle.
 98) Allow using colours from colour sets in fvwm commands.
 99) Make HilightColors command colour set aware.
100) Remove I18N patches since author seems to have lost interest
     in finishing the patch.
     [leave it in, started to rewrite patch in a better way]
101) Finish current work on style changes w/o recapture in a
     consistent way. This doesn't necessarily mean that the
     feature has to be complete before 2.4.
102) Patch 'UseDecor' and 'UseStyle' styles and various ...Style
     commands to apply without a recapture.
     [finished except UseStyle]
103) Add recent bug reports to to-do list.
104) Fix FvwmCommandS core dumps on X server shutdown.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Michael Han <[email-masked]>
Date: Sun, 16 Apr 2000 21:23:55 -0700

Previously from Dominik Vogt
>     [reported on 3-Jun-1999 by Rob Urban <[email-masked]>]

Perhaps we ought to consider this bug "unreproducible"? I know we
haven't gotten authoritative word back from Ron, but no one ever
managed to reproduce the bug, nor did he ever specify the version he
used. I just reread the thread and both Peter Forman and I failed to
reproduce the bug with various versions of amaya, including the (at
that time) latest version. Just for kicks, I just tried v2.4 on
FreeBSD 4 out of ports and it still works fine, as it always has. I
notice that it *is* one of those naughty apps that positions itself at
0,0.

If we want to track down the bug, perhaps it was related to Digital
Unix's libXm and fvwm's motif capabilities? Haven't there been some
recent fixes to fvwm's motif hinting?

Anyway, without input from Ron, it seems unlikely that anyone will
reproduce this bug.
-- 
[email-masked]                         http://www.best.com/~mikehan/
coffee achiever                              San Francisco, California
"What was your username?" - BOFH
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Tue, 18 Apr 2000 12:34:31 +0100

> 115) FvwmWharf sets no class/resource.

What should the class and rescource be set to? At present I think we
have:

Module   Name        Icon          Class       Resource

Banner   FvwmBanner  FvwmBanner
DragWell <argv[0]>   <argv[0]> 
Buttons  <alias>     <alias>       FvwmButtons <alias>
Form     <*config>   <*config>
IconBox  <argv[0]>   <argv[0]>     FvwmIconBox <argv[0]>
IconMan	 <*config>   FvwmIconMan   FvwmModule  <alias>
Ident    <argv[0]>   <argv[0]>
Pager    Fvwm Pager  Desk N        FvwmModule  <argv[0]>
Script   <argv[0]>   <script name>
Scroll   <captured>  <captured>
TaskBar  <argv[0]>   <argv[0]>
Wharf    <argv[0]>   <argv[0]>
WinList  <argv[0]>   <argv[0]>

I think I'd like the modules to conform to this:

Name/Icon               Class      Resource
<argv[0]/alias/*config> FvwmModule <module name>

Cheers,
Tim.

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 18 Apr 2000 15:05:40 +0300

> <argv[0]/alias/*config> FvwmModule <module name>

Probably a good idea, but not for generic GUI modules (Script, Form, Gtk),
where, the following scheme is better (I may be wrong):

Name/Icon                      Class       Resource
<anything module config sets>  FvwmScript  <config file>

Regards,
Mikhael.

---

From: Tim Phipps <[email-masked]>
Date: Wed, 19 Apr 2000 16:37:18 +0100

> <anything module config sets>  FvwmScript  <config file>
I'd prefer Class=FvwmModule for all modules. Why is the config file name
important?

Cheers,
Tim.

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 20 Apr 2000 03:21:01 +0300

> I'd prefer Class=FvwmModule for all modules. Why is the config file name

Because generic modules are only toolkits requiring config (file/alias).
Suppose that all Gnome programs have class "Gnome" and resource "GTK".

I think, it is important to be able to distinguish between practically
different tools. Like "QuitVerify" form and "Talk" form; script for
configuring keyboard and sample-95 setup script; different button bars.

I doubt it is anywhen needed to match against FvwmModule. And it will be
possible to exactly match in the future anyway: Style (Class Fvwm*) ...

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 22 Apr 2000 15:50:25 +0300

> 119) MaxSwallow does not work in FvwmWharf e.g. with

Can you remind me what the problem is? This works for me just like the man
page says, i.e. leaves an xload to be 50x50.

Swallow always forces an app to be 48x48.
MaxSwallow does not force an app to be 48x48 or 64x64, but verifies that 
it's still less than 64x64 and resizes if needed; 50x50 or 20x30 are ok.

If someone wants to get 64x64 he should specify "-g 64x64" or even better
"-g 60x60" to leave 3d look.

Should I change something here or just add this info to the man page?

Regards,
Mikhael.