Subject: I cannot compile with '--enable-kanji'.

From: [email-masked]
Date: Wed, 12 Apr 2000 10:44:37 -0500 (CDT)

Full_Name: MURAKAMI Tomokazu
Version: 2.3.15
CVS_Date: 
OS: Linux 2.2.13
X_Server: XF86
Submission from: (NULL) (163.221.100.93)

Sorry, I cannot compile with '--enable-kanji'.

I runned.
%./configure --enable-kanji
%make

......

add_window.c: In function `setup_window_name':
add_window.c:178: `list' undeclared (first use in this function)
add_window.c:178: (Each undeclared identifier is reported only once
add_window.c:178: for each function it appears in.)
add_window.c:178: `num' undeclared (first use in this function)
make[2]: *** [add_window.o] Error 1
make[2]: Leaving directory `/home/tomone/src/fvwm-2.3.15/fvwm'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/tomone/src/fvwm-2.3.15'
make: *** [all-recursive-am] Error 2

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 13 Apr 2000 08:33:34 +0200

> make: *** [all-recursive-am] Error 2

Yes, the author of kanji support unfortunately seems to have
lost interest in this patch before the work was completed
(He wrote the patch for an old version of fvwm.  I tried to
adapt it for the current versions, but didn't get any help
from him.) So, with the next release (2.4) this option will
probably be removed again.  We still had the vague hope that
someone would volunteer to complete the patch - thus this
option is still enabled).  Sorry if this has mislead you
to think that --enable-kanji actually works.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: MURAKAMI Tomokazu <[email-masked]>
Date: Thu, 13 Apr 2000 22:42:07 +0900

Hello, I'm MURAKAMI Tomokazu @ NAIST.

From: Dominik Vogt <[email-masked]>
Subject: Re: I cannot compile with '--enable-kanji'.
Date: Thu, 13 Apr 2000 08:33:34 +0200

> to think that --enable-kanji actually works.

I'm not good at English.

I'm sorry that this option will be removed at version 2.4. So, I
looked souce. So, I can compile with --enable-kanji. And, I changed
.fvwm2rc .

-------------------------------------
# make sure these fonts exist on your system:
WindowFont "-adobe-times-bold-r-*-*-18-*-*-*-*-*-*-*,-jis-fixed-medium-r-*-*-16-*-*-*-*-*-jisx0208.1983-*"
#WindowFont a16
IconFont "-adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*,-misc-fixed-medium-r-*-*-10-*-*-*-*-*-jisx0208.1983-*"
-------------------------------------

So, I can display kanji at Window Title. But I cannot display at Icon
Menu and Root Menu. I don't know that souce files are bad or that
.fvwm2rc is bad, Sorry.

% diff -Ncr add_window.c add_window.c~
*** add_window.c        Thu Apr 13 22:00:13 2000
--- add_window.c~       Mon Feb 21 18:27:52 2000
***************
*** 160,170 ****
  void setup_window_name(FvwmWindow *tmp_win)
  {
    XTextProperty text_prop;
! #ifdef I18N_MB
!   char **list;
!   int num;
! #endif
!   
    if ( XGetWMName(dpy, tmp_win->w, &text_prop) != 0 )
  #ifdef I18N_MB
    {
--- 160,166 ----
  void setup_window_name(FvwmWindow *tmp_win)
  {
    XTextProperty text_prop;
! 
    if ( XGetWMName(dpy, tmp_win->w, &text_prop) != 0 )
  #ifdef I18N_MB
    {

-- 
   ┏━━━━━━━━━━━━━━━━━━━━━━┓
   ┃  村上 智一   ( TomOne )     福田研究室     ┠┐
   ┃  奈良先端科学技術大学院大学 情報科学研究科 ┃│
   ┃  E-Mail: [email-masked]       ┃│
   ┃  http://fukuda.aist-nara.ac.jp/~tomoka-m/  ┃│
   ┗┯━━━━━━━━━━━━━━━━━━━━━┛│
     └──────────────────────┘
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Thu, 13 Apr 2000 10:03:11 -0400

> Menu and Root Menu. I don't know that souce files are bad or that

I applied your patch.

If we hear that --enable-kanji works, we will leave the feature in.

If you can, please send more patches.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 13 Apr 2000 16:23:46 +0200

> looked souce. So, I can compile with --enable-kanji. And, I changed

Well, perhaps I should simply find out the gaps in the implementation
and document appropriately.  There were some places where I didn't
understand the original patch.  I didn't apply the relevant parts,
so the patch is not complete.  But it wouldn't hurt much to leave
this option in if it is clear that the code is not supported.

Probably icon titles are one of the places where the patch
is incomplete.  I can't promise to do anything about it soon,
though.  I hope someday we find the time to do i18n support
properly.

Bye

Dominik ^_^

---

From: MURAKAMI Tomokazu <[email-masked]>
Date: Sat, 22 Apr 2000 22:31:27 +0900

I'm MURAKAMI Tomokazu @NAIST

From: Dan Espen <[email-masked]>
Subject: Re: I cannot compile with '--enable-kanji'. 
Date: Thu, 13 Apr 2000 10:03:11 -0400

> If you can, please send more patches.

I compiled 2.3.16 with --enable-kanji. But, FvwmWinList isn't able to
compile.  I make patch.

But, I cannot display Kanji in FvwmWinlist. I don't know FvwmWinList
is but or my .fvwm2rc is but.

-------------------------------------------------------------------

% diff -Ncr FvwmWinList.c FvwmWinList.c~
*** FvwmWinList.c       Sat Apr 22 22:11:18 2000
--- FvwmWinList.c~      Fri Apr  7 06:27:49 2000
***************
*** 57,71 ****
  
  #include <stdlib.h>
  
- #include "libs/Module.h"
- #include "libs/fvwmsignal.h"
- 
- #include "FvwmWinList.h"
- #include "ButtonArray.h"
- #include "List.h"
- #include "Mallocs.h"
- #include "libs/Colorset.h"
- 
  #ifdef I18N_MB
  #include <X11/Xlocale.h>
  #ifdef __STDC__
--- 57,62 ----
***************
*** 75,80 ****
--- 66,80 ----
  #endif
  #define XDrawString(t,u,v,w,x,y,z) XmbDrawString(t,u,ButtonFontset,v,w,x,y,z)
  #endif
+ 
+ #include "libs/Module.h"
+ #include "libs/fvwmsignal.h"
+ 
+ #include "FvwmWinList.h"
+ #include "ButtonArray.h"
+ #include "List.h"
+ #include "Mallocs.h"
+ #include "libs/Colorset.h"
  
  #define MAX_NO_ICON_ACTION_LENGTH (MAX_MODULE_INPUT_TEXT_LEN - 100)