Subject: CVS olicha: * sample-95 revolution.

From: CVS <[email-masked]>
Date: Tue, 11 Apr 2000 01:24:20 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	olicha	00/04/11 01:24:20

Modified files:
	.              : ChangeLog 
	sample.fvwmrc  : system.fvwm2rc-sample-95 Makefile.am 
	fvwm           : fvwm.c 
	modules/FvwmScript/Scripts: Makefile.am 
Added files:
	modules/FvwmScript/Scripts: ScriptFvwmSetup95 

Log message:
* sample-95 revolution.
* system.fvwm2rc-sample-95 is installed in the config directory.
* A new FvwmScript script for installing system.fvwm2rc-sample-95
* Added an entries for ScriptFvwmSetup95 in the root menu. Also
Also added an entries for restarting fvwm.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 12 Apr 2000 13:59:22 -0400

> Also added an entries for restarting fvwm.

It certainly is a revolution.

I agree with your comment, the file is way too big.

I wish you would fold your "QuitVerify" enhancement into
FormFvwmQuitVerify.

The file: modules/FvwmScript/Scripts/system.fvwmrc
doesn't seem to have a purpose.  I don't think you added it.

I don't see why the installation script does all that work
for ImagePath.  All but the users ImagePath should be built in.

I wish this was more integrated into the previous setup form.
I don't see how a new user can decide which one to use.
He can't use both.

The Solaris audioplayer is "audioplay".

It didn't create a ".fvwm2rc" for me.  I already have $FVWM_USERHOME
set to $HOME/.fvwm.

I found this on my console:

syntax error at -e line 1, near "$ENV-e "
Bareword found where operator expected at -e line 1, near "173PATH"
        (Missing operator before PATH?)
syntax error at -e line 1, near ") -e "
Scalar found where operator expected at -e line 1, at end of line
        (Missing operator before ?)
syntax error at -e line 1, near "175 -e "
Scalar found where operator expected at -e line 1, at end of line
        (Missing operator before ?)
Execution of -e aborted due to compilation errors.
[FvwmScript]: too long command 1006 chars max 998
[FvwmScript]: too long command 1015 chars max 998

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 13 Apr 2000 01:07:06 +0200

> I wish you would fold your "QuitVerify" enhancement into

Ok, but it is not my enhancement it was in sample-95 when
I take it.

> doesn't seem to have a purpose.  I don't think you added it.

No I do not, it is there since a long time I think. It is
obsolete ... 
 
> I don't see how a new user can decide which one to use.

Ok, I will try to do somthing more intelligent for the ImagePath. 
  
> The Solaris audioplayer is "audioplay".
Thanks
 
> I found this on my console:

Ok, this is normal :(. I will do a non executable external perl script 
script-fvwm-setup95.pl. It is impossible to write a one line perl 
script in FvwmScript since it is impossible to write { and },
so I use the ascii code but it seems that this does not work on
your machine (I was a quite naive here).

Thanks, for trying sample-95, 
Olivier

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 13 Apr 2000 19:06:10 +0200

Dan, Can you try again?
Olivier

---

From: Dan Espen <[email-masked]>
Date: Thu, 13 Apr 2000 13:47:24 -0400

> Dan, Can you try again?

Pretty neat.

My current ImagePath is way too long for your display:

  --with-imagepath=/opt/icons:/opt/public/src/fvwm/icons:/u/dane/icons:\
/u/dane/public_html/textures:/opt/public/bin/rxvt-pixmap/textures:\
/usr/WI/include/X11/bitmaps\

The font in the title bar gets truncated:

The menus refer to "xv" as "xview".  I don't think thats the right name.

I got these on my console:

<<< Thu Apr 13 13:24:46 2000 >>>
' instead.
sh: fvwm-menu-xlock: not found
sh: fvwm-menu-xlock: not found
usage: xsetroot [options]
  where options are:
  -display <display>   or   -d <display>
  -fg <color>   or   -foreground <color>
  -bg <color>   or   -background <color>
  -rv   or   -reverse
  -help
  -def   or   -default
  -name <string>
  -cursor <cursor file> <mask file>
  -cursor_name <cursor-font name>
  -solid <color>
  -gray   or   -grey
  -bitmap <filename>
  -mod <x> <y>

<<< Thu Apr 13 13:30:47 2000 >>>
/bin/sh: xcolormap: not found

The "fvwm-menu-xlock" part is my fault, fvwm is not in my path.

In fvwmbuttons I've got a 3x3 grid of mini-icons.
Only the first 2 and the last 3 buttons have mini-icons:

My "biff" application is "SSxbiff".  The style "*biff" would work
for more users.

My perfmeter is "XSysStats".  (I don't expect you to configure
everything.)

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 14 Apr 2000 07:26:09 +0200

> /usr/WI/include/X11/bitmaps\

Hum, my god, will try to truncate it ...

> The font in the title bar gets truncated: 

Can you try to remove the "Height 18" TitleStyle command in section 2
and restart?

> usage: xsetroot [options]
[snip]

Will be fixed

> Only the first 2 and the last 3 buttons have mini-icons:

But you do not use the latest version of fvwm_icons !

> My perfmeter is "XSysStats".  (I don't expect you to configure

Ok, about xcolorset and XSysStats, a priori we can expect that all
apps will be in the menus and that all apps in the menus be on the 
path. But, I will do so that that the perl script will parse the
menus for checking that the apps are in the path.
So, Every body can ask for adding any apps in the programs menu!

It will be fine to get a solaris support. I've solaris at work (currently
far from it), but I've never try to add a real "dt*" support in my
config, may be, Dan, you have done this in your machine? If yes can you
send me the relevant part of your config? Especially menu and styles.
When, I begin to try adding such support I've got 3 problems:
- How to detect Solaris? may be a test like [ -d /usr/dt ] ?
- At work, the dt apps (/usr/dt/bin) are not in the path, is this
the default? Is it "universal" to run dt apps as /usr/dt/bin/dt*
- I never succeed to run directly the dt "applications manager",
it is via dtfile I imagine but I never find the good option
(the better I can do is to open dtfile within /usr/dt/...apps.../C)

Olivier

---

From: Dan Espen <[email-masked]>
Date: Fri, 14 Apr 2000 08:58:59 -0400

> Can you try to remove the "Height 18" TitleStyle command in section 2

Fixes it nicely.

> But you do not use the latest version of fvwm_icons !

Right you are.  I wonder where I copied those icons to?

> config, may be, Dan, you have done this in your machine? If yes can you

The only dt app I use is dtcm.
dtfile worked with your config, but I don't normally use it.

> - How to detect Solaris? may be a test like [ -d /usr/dt ] ?

/usr/dt will identify CDE on AIX, HP and Solaris.

> the default? Is it "universal" to run dt apps as /usr/dt/bin/dt*

I don't know what the default is.

I don't like dtlogin.  Everyone using the fvwm environment
has the support staff disable dtlogin which gets rid of dtprofile.

> (the better I can do is to open dtfile within /usr/dt/...apps.../C)

I configure dt apps like this:

PATH=$PATH:/usr/dt/bin
MANPATH=$MANPATH:/usr/dt/man
export LD_LIBRARY_PATH=/usr/lib:/usr/dt/lib:$LD_LIBRARY_PATH:/usr/ucblib

In the .xinitrc:
xset fp+ /usr/dt/config/xfonts/C

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 14 Apr 2000 15:42:05 +0200

> /usr/dt will identify CDE on AIX, HP and Solaris.

And Linux :-)  There's a Linux port of CDE.

> I don't know what the default is.

Yes, I think it's the default (at least on HP-UX I'm sure).  The
default user is not supposed to start these from a shell.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]