Subject: Window Manager Icons Project bug report

From: Thomas Stroesslin <[email-masked]>
Date: Thu, 13 Apr 2000 20:11:45 +0200 (MET DST)

hi,

wm-icons-config.in , line 291 and 321

uses 	if [ -L $1 ]; then ...

however, the -L option is obsolete, and I couldn't run the
script. please use the -h option instead. thanks,

tom

----------
uname -a:
SunOS mantrasun3 5.7 Generic_106541-10 sun4u sparc SUNW,Ultra-5_10

man if:

...

     -h filename
               True if filename exists and is  a  symbolic  link.
               With  all  other  primitives (except -L filename),
               the symbolic links are followed by default.
...

     -L filename
               True if filename exists and is  a  symbolic link.
               With  all  other  primitives (except -h filename),
               the symbolic links are followed by default.
...

     The -L option is a migration aid for users of other shells which  
     have  similar  options  and  may  not be supported in
     future releases.

---------------------------------------
Thomas Stroesslin
DI-MANTRA (INF 130)
EPFL
CH-1015 Lausanne
phone: +41 (0)21 693 52 64
E-Mail: mailto:[email-masked]
WWW: http://diwww.epfl.ch/lami/team/stroessl/

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 14 Apr 2000 00:10:48 +0300

> script. please use the -h option instead. thanks,

But this is not that GNU test says.

> SunOS mantrasun3 5.7 Generic_106541-10 sun4u sparc SUNW,Ultra-5_10

Yes, on this system sh has an internal test (aka [), contradicting with
/bin/test. For example, it has no -e (a nonsense); this creates problems.
I will support this system in the next releases. Thank you.

Regards,
Mikhael.

---

From: Julian Gilbey <[email-masked]>
Date: Fri, 14 Apr 2000 00:36:16 +0100

> script. please use the -h option instead. thanks,

test(1) has never heard of a -h option.

   Julian

-- 
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

  Julian Gilbey, Dept of Maths, QMW, Univ. of London. [email-masked]
        Debian GNU/Linux Developer,  see http://www.debian.org/~jdg
  Donate free food to the world's hungry: see http://www.thehungersite.com/
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]