Subject: -Wall stuff

From: Michael Han <[email-masked]>
Date: Tue, 18 Apr 2000 22:26:47 -0700

Here is the additional output I got using -Wall with the current CVS.

session.c:80: warning: `sent_save_done' defined but not used
bindings.c: In function `ParseBinding':
bindings.c:97: warning: unused variable `i'

Looking at session.c, I'm kind of confused. Am I correct in thinking
that the #ifdef SESSION that begins on line 810 ends on line 1139? If
so, then sent_save_done should be hiding inside an ifdef too.

Again, in bindings.c, 'i' is undefined only without STROKE. Should
that declaration get hidden inside a STROKE_CODE() macro wrapper?
-- 
[email-masked]                         http://www.best.com/~mikehan/
coffee achiever                              San Francisco, California
"I will not be a snickerpuss." - Lisa
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 19 Apr 2000 11:43:30 +0200

> that declaration get hidden inside a STROKE_CODE() macro wrapper?

No, inside a STROKE macro.  I'll fix both.

Bye

Dominik ^_^  

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]