Subject: Notification: incoming/599

From: [email-masked]
Date: Sat, 22 Apr 2000 02:56:58 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/599

Message summary for PR#599
	From: [email-masked]
	Subject: *FvwmPagerGeometry broken?
	Date: Sat, 22 Apr 2000 02:56:57 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Tim Phipps <[email-masked]>
Date: Tue, 25 Apr 2000 12:51:56 +0100

> Full_Name: Shawn Anderson
> Geometry:           15x15-2-2
> Does anyone else see this?

Yes, it might be something to do with the code at line 415 of x_pager.c:

  if(xneg)
  {
    sizehints.win_gravity = NorthEastGravity;
    window_x = Scr.MyDisplayWidth - window_w + window_x -2;
  }

  if(yneg)
  {
    window_y = Scr.MyDisplayHeight - window_h + window_y -2;
    if(sizehints.win_gravity == NorthEastGravity)
      sizehints.win_gravity = SouthEastGravity;
    else
      sizehints.win_gravity = SouthWestGravity;
  }

Does anyone know what the -2's are doing there?

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 26 Apr 2000 16:51:16 +0200

>       sizehints.win_gravity = SouthWestGravity;

Yup, that's it.  I'll remove it with my next commit.
BTW, I can see this even back in 2.0.38 (the oldest
tarball on my disk).

> Does anyone know what the -2's are doing there?

Breaking the FvwmPagerGeometry resource?  No, honestly, I
have no idea.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]