Subject: CVS domivogt: * Fixed shed/iconify and maximize/iconify bug.

From: CVS <[email-masked]>
Date: Wed, 26 Apr 2000 11:59:23 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	00/04/26 11:59:23

Modified files:
	.              : ChangeLog 
	fvwm           : focus.c functions.c functions.h fvwm2.1 
	                 geometry.c geometry.h gnome.c icons.c 
	                 placement.c session.c virtual.c virtual.h 
	modules        : ChangeLog 
	modules/FvwmPager: x_pager.c 
	modules/FvwmScript: Instructions.c 

Log message:
* Fixed shed/iconify and maximize/iconify bug.
* Fixed FvwmPager sticky window workaround.
* -Wall fixes.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 27 Apr 2000 05:06:12 +0200

On Thu, Apr 27, 2000 at 04:39:04AM +0300, Mikhael Goikhman wrote:
> On 26 Apr 2000 11:59:23 -0500, CVS wrote:
> > 
> > Log message:
> > * Fixed shade/iconify and maximize/iconify bug.
> Sorry, I still can reproduce this "sticky windows on top" bug with the
> current fvwm using multidesk pager. Although on some conditions it really
> broadcasts restack and everything is ok. But if you play with it (lower
> sticky window, change desk in pager, change desk back) several times you
> can find a condition, when this is not done, so the bug still shows.

Sorry, try as I might - I can't find a situation where it doesn't work.
There are two places in virtual.c where the MapDesk function is called.
In both places, a BroadcastRestack is sent for all windows.  So, unless
the stacking chain is out of order it can't happen.  Did you really
*lower* the sticky window?  Or did you *raise* other windows above it?
In the latter case, if you switch to a different page and/or desk, the
window may be on top of the windows in the current viewport.  It's only
a bug if the pager doesn't reflect the actual stacking order properly.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]