Subject: Re: CVS migo: fixed duplicated --with-readline-* usage, bug #579

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 4 Apr 2000 00:33:58 +0200

On 31 Mar 2000 14:51:31 +0200, Dominik Vogt wrote:
> 
> On Fri, Mar 31, 2000 at 04:33:25AM -0600, CVS wrote:
> > CVSROOT:	/home/cvs/fvwm
> > Module name:	fvwm
> > Changes by:	migo	00/03/31 04:33:24
> > 
> > Modified files:
> > 	.              : ChangeLog configure.in 
> > 
> > Log message:
> > fixed duplicated --with-readline-* usage, bug #579
> 
> Okay, how did you fix it this time? :-)

The patch is this. I have commented out lines 172-173 and added lines
174-180,183. You can also search for word "readline" in configure.in.

As I already mentioned in one of the previous messages, the problem was
with two smr_CHECK_LIB macro calls. So I replaced the second one with the
actual expanded macro implementation (a mini variant), but without a code
adding the usage lines (for the second time). This is from the ChangeLog
and you are still asking, so I suppose you expect to hear something more?

For example, 1) why do we need these two check. This is done because some
users may have termcap, others - ncurses libs (or both of them), and
readline lib requires one of these term libs, so we first check compiling
with -lreadline -ltermcap, then with -lreadline -ncurses.

Or, 2) how did I get to this. By learning *.m4 autoconf macros and
installing/uninstalling readline (I have both libtermcap and libncurses).
It took me a lot of time, because I am learning autoconf stuff too.

Did I answer your question? :)

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 4 Apr 2000 10:15:53 +0200

> and you are still asking, so I suppose you expect to hear something more?

I must confess that I usually don't read ChangeLog entries because
the fixes I make are usually too complex for a detailed entry.

> Did I answer your question? :)

Yes, thanks.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]