Subject: Re: FVWM: Fvwm newbie's questions (problems with FvwmTaskBar)

From: Olivier Chapuis <[email-masked]>
Date: Sat, 15 Apr 2000 21:49:45 +0200

Gregory A. Shimansky wrote:
> 
> >>>>> "DV" == Dominik Vogt <[email-masked]> writes:
> 
> >> 1. It does not display any mail button when I have new mail even though I have
> >> #define MINI_ICONS 1
> >> in config.h file.
> 
> DV> Please try if this still is the case with the latest beta releases.
> DV> I think there was a fix a while ago, but I'm not sure.
> 
> >> 2. When I press the Start button a menu is called but it stays depressed
> >> untill I restart task bar.
> 
> DV> This is fixed since the 2.3.1 beta release.
> 
> Thank you, I upgraded to fvwm
> [FVWM][main]:  Fvwm Version 2.3.15 compiled on Apr 14 2000 at 15:07:02
> [FVWM][main]:  with support for:  ReadLine RPlay Stroke XPM IMLIB Session
> beta and a lot of things started to ork as I want them to :)
> 
> But... I encountered two new  problems with task bar.

Hello,
I've tested your TaskBar config.

> 
> 1. The mail mini icon started to appear when I get new mail but the action
> that I want it to do (switch to desk 2 where my mailer lives) does not
> work, it just makes the icon blank.
> 

One click blank the icon (you see that a mail arrives and so you will see
if a new one arrives). Double click will do the action you want.

> 2. Something is wrong with task bar tips now. Instead of showing little
> yellow window with window name it shows two strange lines, somewhat like
> this:
> 
>                                     |
>         ----------------------------+
> ---------------------------------------------------
> [Start] [Netsca...] [Netsca...] [Netsca...] [18:00]
> ---------------------------------------------------
>            ^
>          Mouse pointer
> 
> The length of the bottom line seems to be the same as needed for the tip
> but no text is drawn... :(
>

I'm unable to reproduce this problem. The tip work normally on my machine
with your config. You say that you have two strange lines and that's all.
This is strange: do you have a black box that "fill" this 2 lines? May be
you can send a little screen shot to the [email-masked] mailing
list.

Answer to the following questions may help debugging
- What happen if you use 
*FvwmTaskBarTipsBack white
*FvwmTaskBarTipsFore black
- Do you have the same problem if netscape does not run. 
Say that you can make a test with only an xterm running. 
Netscape use a lot of colors and can cause problems. There are 
solutions to solve this but I do not know them.

Olivier

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked] (Gregory A. Shimansky)
Date: 17 Apr 2000 15:43:25 +0400

>>>>> "OC" == Olivier Chapuis <[email-masked]> writes:

>> work, it just makes the icon blank.

OC> One click blank the icon (you see that a mail arrives and so you will see
OC> if a new one arrives). Double click will do the action you want.

Thanks, it works :)

>> yellow window with window name it shows two strange lines, somewhat like

OC> I'm unable to reproduce this problem. The tip work normally on my machine
OC> with your config. You say that you have two strange lines and that's all.
OC> This is strange: do you have a black box that "fill" this 2 lines? May be
OC> you can send a little screen shot to the [email-masked] mailing
OC> list.

Screenshot is in attachment.

OC> Answer to the following questions may help debugging
OC> - What happen if you use 
OC> *FvwmTaskBarTipsBack white
OC> *FvwmTaskBarTipsFore black
OC> - Do you have the same problem if netscape does not run. 
OC> Say that you can make a test with only an xterm running. 
OC> Netscape use a lot of colors and can cause problems. There are 
OC> solutions to solve this but I do not know them.

I changed FvwmTaskBarTipsBack and FvwmTaskBarTipsFore as you wrote and
restarted without netscape, tips still don't work though in xcmap I see a
lot of free colors. I don't think it problem is because of lack of colors.
Tips in FvwmPager work ok, on task bar they don't :(

I encountered one more problem with new task bar:

I have *FvwmTaskBarDeskOnly in my config. If windows made stiky by style
command, they are shown on task bar on every desk. If I have a window that
is not stiky originally and make it stiky by pressing one of the buttons on
the title bar

Mouse 0		3       A       Stick

and then move to the other desk, it's shown on the screen but not shown on
the task bar.

Thanks in advance.
--
Gregory.

P.S. I use
[FVWM][main]:  Fvwm Version 2.3.15 compiled on Apr 14 2000 at 15:07:02
[FVWM][main]:  with support for:  ReadLine RPlay Stroke XPM IMLIB Session
on SUN sparc workstation with openwindows 3.6.1.

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 17 Apr 2000 19:56:42 +0200

> and then move to the other desk, it's shown on the screen but not shown on

Yep, This one I can reproduce it. Will take look and try to fix
"all" the deskonly vs sticky bugs ...
Thanks for helping us to debuging fvwm-2.3.x so that fvwm-2.4
will be as bug free as possible.
Olivier

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 24 Apr 2000 07:46:46 +0200

> and then move to the other desk, it's shown on the screen but not shown on

Fixed in the current cvs. You may want to use a daily snap shot
or wait the next beta (2.3.17).
Olivier