Subject: CVS migo: * FVWM_USERDIR now defaults to $HOME/.fvwm, not $HOME.

From: CVS <[email-masked]>
Date: Tue, 25 Apr 2000 17:51:59 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	migo	00/04/25 17:51:58

Modified files:
	.              : ChangeLog NEWS configure.in 
	fvwm           : Makefile.am externs.h fvwm.c fvwm2.1 
	                 module_interface.c read.c read.h 
	modules        : ChangeLog 
	modules/FvwmAnimate: FvwmAnimate.c 
	modules/FvwmBacker: Makefile.am 
	modules/FvwmButtons: Makefile.am 
	modules/FvwmCpp: FvwmCpp.1 FvwmCpp.c Makefile.am 
	modules/FvwmForm: FormFvwmForm. FormFvwmRlogin. FormFvwmSetup.in 
	                  FvwmForm.1 Makefile.am 
	modules/FvwmIconBox: Makefile.am 
	modules/FvwmIconMan: Makefile.am 
	modules/FvwmIdent: Makefile.am 
	modules/FvwmM4 : FvwmM4.1 FvwmM4.c Makefile.am 
	modules/FvwmPager: Makefile.am 
	modules/FvwmScript: FvwmScript.1 FvwmScript.c Makefile.am 
	modules/FvwmScript/Scripts: Makefile.am ScriptFvwmBaseConfig 
	                            ScriptFvwmSetup95.in 
	modules/FvwmScroll: Makefile.am 
	modules/FvwmTaskBar: Makefile.am 
	modules/FvwmWinList: Makefile.am 
	sample.fvwmrc  : Makefile.am system.fvwm2rc-sample-95 
	utils          : ChangeLog fvwm-config.in fvwmbug.sh.in 
	vms            : config.h 

Log message:
* FVWM_USERDIR now defaults to $HOME/.fvwm, not $HOME.
* The user's directory is now created if needed.
* Instalating fvwm goodies is now to share/fvwm (FVWM_DATADIR).
* Trivial renamings/rewordings.

Consider to put all your personal fvwm files to $HOME/.fvwm;
to simulate the old fvwm behaviour, export FVWM_USERDIR=$HOME .

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked]
Date: Wed, 26 Apr 2000 02:00:39 -0500 (CDT)

> to simulate the old fvwm behaviour, export FVWM_USERDIR=$HOME .

Excelent, thank you. That's exactly what I've been patiently waiting
for. I have one more suggestion.

fvwm-config -s will report readline, rplay, stroke, xpm, gtk, and sm,
but I think it should also report imlib and gnome, for 100% assurance
of compiled-in features. Gnome is, afterall, different than just GTK+,
and Imlib, if my assumption is correct, adds more graphics support for
fvwm, such as jpg, gif, etc, instead of just xpm (which I'm sure isn't
perfect yet, I tried a png, and didn't work, and this is part of
imlib's internal features...).

Just a suggestion.

Eric Renfro