Subject: Command Line Variable Substitution bug in FvwmForm

From: Alex Wallis <[email-masked]>
Date: Wed, 12 Apr 2000 18:34:26 +0930

I've been meaning to report this for awhile now, but it's now become so
annoying that I must!  :)

To demonstrate this clearly, I provide a "simple form".

DestroyModuleConfig SimpleForm.*
*SimpleForm.WarpPointer
*SimpleForm.Line center
*SimpleForm.Text "$Title"
*SimpleForm.Line center
*SimpleForm.Selection simple multiple
*SimpleForm.Choice REST REST off "Restart Form?"
*SimpleForm.Line expand
*SimpleForm.Button quit "END"
*SimpleForm.Command $(REST?Module FvwmForm SimpleForm. Title=SimpleForm
REST=on)
*SimpleForm.Nop

At a console, have fvwm "Read" that form in, thusly....

Read /path/to/SimpleForm.
(Note: the trailing dot "." is important!)

Then invoke the form via a command like....

Module FvwmForm SimpleForm. Title=SimpleForm REST=on

The Choice button does not appear selected on startup.
Is this a bug? Or just not implemented properly?

TIA

Alex

================================================
Try out the latest development version of themes
for fvwm (fvwm-themes)! :) It's great! Get it at
https://sourceforge.net/project/?group_id=1738
------------------------------------------------
Bookmark it to quickly grab new releases when announced.

DestroyModuleConfig SimpleForm.*
*SimpleForm.WarpPointer
*SimpleForm.Line center
*SimpleForm.Text "$Title"
*SimpleForm.Line center
*SimpleForm.Selection simple multiple
*SimpleForm.Choice REST REST off "Restart Form?"
*SimpleForm.Line expand
*SimpleForm.Button quit "END"
*SimpleForm.Command $(REST?Module FvwmForm SimpleForm. Title=SimpleForm REST=on)
*SimpleForm.Nop

---

From: Alex Wallis <[email-masked]>
Date: Wed, 12 Apr 2000 19:44:14 +0930

Sorry, there's a typo.....

> *SimpleForm.Command $(REST?Module FvwmForm SimpleForm. Title=SimpleForm

This last line of course should read "*SimpleForm.Command Nop"
But I think you'll get the idea!  :-)
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 12 Apr 2000 07:33:01 -0400

> > *SimpleForm.Choice REST REST off "Restart Form?"

Maybe I'm just not understanding but shouldn't the above be 
*SimpleForm.Choice REST REST $REST "Restart Form?
                             ^^^^^ 

Brad
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Alex Wallis <[email-masked]>
Date: Wed, 12 Apr 2000 21:18:20 +0930

> *SimpleForm.Choice REST REST $REST "Restart Form?
Thank you! That seems to do the trick!  :)

Alex