Subject: Re: Recapture is still needed after some Style's

From: Dominik Vogt <[email-masked]>
Date: Wed, 19 Apr 2000 16:06:38 +0200

On Wed, Apr 19, 2000 at 04:50:01PM +0300, Mikhael Goikhman wrote:
> Hi,
> 
> Do you know the status of this problem as described in:
>   http://www.hpc.uh.edu/fvwm/archive/0002/msg00390.html

Do you mesn this one?

---------------------------------- snip --------------------------------------

On 15 Feb 2000 22:49:46 +0100, Joerg Klemenz wrote:
> 
> For example you press C-M-F10 to make a window fullscreen -> maximize, remove
> title, set Handlewidth 0.
> Then press M-F9 and put everything back on and iconify...
> 
> I want that badly.

Easily.

# ------------------------------------------------------------------------
Key F11 W SC FuncFvwmMaximizeFullScreen
Key F12 W SC FuncFvwmRestoreFromFullScreen

DestroyFunc FuncFvwmMaximizeFullScreen
AddToFunc   FuncFvwmMaximizeFullScreen
+ I Style $n NoTitle, NoHandles, BorderWidth 0
+ I WindowId "$w" RecaptureWindow
+ I WindowId "$w" Maximize true

DestroyFunc FuncFvwmRestoreFromFullScreen
AddToFunc   FuncFvwmRestoreFromFullScreen
+ I WindowId "$w" Maximize false
+ I Style $n Title, Handles, BorderWidth 5
# ------------------------------------------------------------------------

Press Ctrl-Shift-F11, Ctrl-Shift-F12.
Ok, I agree, it would be more clean with: Style (Id $w) Maximize.

Problems with the functions above:
  * Don't press Ctrl-Shift-F11 twice, you will not be able to restore.
    This is because Maximize after Recapture works differently...
  * Dominik, did you say Recapture is not needed after Style? :-)
    This will not work without it here.
  * If you have other style bindings and you execute them in between
    of Ctrl-Shift-F11/Ctrl-Shift-F12 - small memory leak, see other thread.

---------------------------------- snip --------------------------------------

> If I comment in RecaptureWindow line, it doesn't fully maximize.

No, it can't work.  Styles are only applied when fvwm is idle.
A style change doesn't become active before the function has
completed.  We'll need some function like 'FlushUpdates' that
can be used inside functions to force that styles are applied.

To all: any optinions here?  Should I implement such a
(trivial) command before 2.4?

> BTW, while searching for this msg, I have found your answer to my posting,
> which I never got (yet?) in my mbox (I don't know what to reply here now):
>   http://www.hpc.uh.edu/fvwm/archive/0002/msg00166.html

Don't care about configure options right now.  We have more pressing
issues than this at the moment.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 20 Apr 2000 02:11:52 +0300

> can be used inside functions to force that styles are applied.

Ah, I see.

> (trivial) command before 2.4?

Actually, it would be nice if fvwm detected the situations, when
FlushUpdates is needed automatically. Like here with Maximize command.

Another moment, if a user mixed Style and non-Style commands in function,
he probably always wants to have a flush before a first non-Style command.

This is not to say that we actually need (or don't need) this before 2.4.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 20 Apr 2000 10:51:03 +0200

> he probably always wants to have a flush before a first non-Style command.

It can't.  To find this out fvwm would have to apply the style
(at least for styles that don't entail a redraw).

Bye

Dominik ^_^